
 Update History 
 

Build 53 

Update Details: 

 

** Enhancements 

    * [IP-502] - Support for Tyro Pay@Table Surcharges 

    * [IP-1271] - StockManage - Support for Price Changes functionality 

    * [IP-1481] - Support for Fiji VAT Monitoring System 

    * [IP-1866] - Manufacture Items - multiple items can be processed in a Batch 

    * [IP-1886] - Inhibit accrual of Gross minus Nett gaming points where the nett tender is points-inhibited 

    * [IP-1909] - Konami Gaming - support for retrieving Member Image 

    * [IP-1938] - Promotions Report - option to Group by Location 

    * [IP-1815] - Xero API - automatically set Xero Accounts to Enable Payments 

 

  



EFTPOS Surcharges 

Support for Tyro Pay@Table Surcharges 

This function adds the ability for Tyro EFTPOS to support surcharges when using the Tyro Pay@Table feature.  
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Gaming Interface 

Konami Gaming – Support for retrieving member image 

This function adds support for retrieving the Konami Gaming Member from the Konami Gaming Server/Database. 

 

Go to Setup > Global Options > Gaming > Get Photo 

 

 
 

  



When adding a Konami Gaming Member to the POS transaction, the image for the member will be retrieved from the 

Konami Gaming Server/Database and displayed on the POS Screen. 

 

 
 

In the event that the member image is unavailable, the system will show ‘Image not Available’. 
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Manufacture Items  

Multiple items can be processed in a Batch 

This function replaces the previous functionality of manufacturing a single item one at a time. 

When manufacturing items, the process now involves adding Manufactured Items to a batch, then once all the 

required Manufactured Items have been added to the batch, the batch can be processed which will manufacture all 

the items in the batch at once.  

If a single item needs to be manufactured, a batch can be created, then simply add a single item to the batch, followed 

by processing the batch which will manufacture the item within the batch. 

 

Go to Transactions > Stock Control > Manufacture Items > Add 

 

 
 

  



The Manufacture Items screen will be displayed. 

On the right-hand side of the screen Manufacture Items screen, you will see the below options. 

Give the Batch a name, select the Location where the Manufactured Item will be manufactured, the Manufacture Date 

along with any notes for the batch. 

 

 
 

After you have filled in the above details, you may add items to the batch. 

Items can either be added manually by adding the required items to the batch, or they can be added automatically via 

the Generate by Reorder Levels button. 

 

To automatically add items to the batch: 

Press the Generate by Reorder Levels button. Using the Generate by Reorder Levels button will automatically add any 

Stock Items that have a Stock Level which is below the recommended level. When using the Generate by Reorder 

Levels, the Quantity to Manufacture for each item will also be automatically filled to increase the Manufactured Stock 

Item’s Stock Level to the recommended level. Note that pressing the Generate by Reorder Levels button will clear any 

existing Stock Items that have been added manually to the current batch.  

 

To manually add items to the batch: 

On the left-hand side of the screen, you will see a grid that shows the Stock Code, Description, Recommended Level, 

Stock Level and Quantity to Manufacture. 

 

 
 

To begin, click on the dropdown arrow located in the Stock Code column. 
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This will then display the Stock Items screen. The Stock Items screen will only show items which have the 
Manufactured Item flag enabled. 
 

 
 
Select the Manufactured Item that you want to Manufacture from the list by double-clicking on it, or alternatively 
select the item then press the OK button. 
 
The Manufactured Item will be added to the Manufacture Item batch. 
Enter the Quantity to Manufacture 
 

 
 
To add another item to the batch, click on the next available row and press the dropdown arrow. 
 

 
 
Repeat the above process to add any additional items to the batch. 
 
  



Once you have added all items that need to be manufactured to the batch, press the Save button located at the 
bottom right corner of the screen 
 

 
 
The batch will appear on the Manufacture Batches screen 
 

 
 
After a Manufacture Batch has been created, the Manufactured Items contained within the batch have not yet been 
manufactured, meaning that their stock levels have not been modified and the indirect items that make up the 
manufactured items have also not had their stock levels altered yet.  
With the ability to create a batch containing multiple items, you may want to display and print off a report that 
contains a list of all the manufactured items. This will be beneficial for handing to the kitchen staff where they can 
use the report to see a list of items that need manufacturing, then tick off the items from the list as they’ve 
manufactured them. 
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To produce the report, select the batch from the list, then press the ‘View’ button located at the bottom of the 
screen. 
 

 
 
This will display a report showing a list of Manufactured Items that have been added to the batch. 
 

 
 
Like the other reports available in Idealpos, you can Print, Email, PDF or Export the report using the buttons at the 
top of the report screen 
 

 
 
Close the report to return to the Manufacture Batches screen. 
 
  



When there are multiple batches in the system, the View All button can be used to display all batches as a report, 
with each batch occupying one or more pages, depending on the number of items in the batch. 
 

 
 
Once you’re ready to process the batch, press the Process button located at the bottom right corner of the 
Manufacture Batches screen. 
 

 
 
A confirmation prompt will be displayed. 
Press ‘Yes’ to proceed with processing the Manufacture Batch. 
 

 
 
The Manufacture Batch will be processed; all Manufactured Items that are included in the batch will have their stock 
levels increased and any indirect items that make up the manufactured items will have their stock levels decreased. 
 
After the batch has been processed, the following message will be displayed indicating that the batch was 
successfully processed. 
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The Processed column on the Manufacture Batches screen will also change to ‘Yes’ which indicates that the batch 
has been processed. 
 

 
 
Once a batch has been processed, no further adjustments can be made to the items within the batch. 
Batches will remain in the Manufacture Batches screen until you delete them. 
 
Additional features available on the Manufacture Batches screen are the ability to filter batches based on processed 
status.  

• Show all batches will display all batches. 

• Unprocessed Only will only show batches that have not been processed. 

• Processed Only will only show processed batches. 
 

 
 
Batches can be searched by name. Enter a batch name or part of a batch name and the Manufacture Batches screen 
will show any batches that match the entered name. 
 

 
 
Batches can be filtered based on the manufactured period. 
Select a period from the list to show any batches which match the period selected 
 

 
  



Items can also be manufactured from the POS Screen by setting up a POS Screen button using the Back Office 
Shortcut function. 
To utilise this functionality, the POS terminal needs to be licenced for the Back-Office module. 
If your POS terminal is licenced for the Back-Office module, this can be setup as follows. 
 
Go to Transactions > Stock Control > Manufacture Items > Add button > S button 
 

 
 
A Shortcut will be created for the Manufacture Items function. 
 

 
 
To create the button, go to Setup > POS Screen > POS Screen Setup > Select: POS Screen Layout > Buttons 
Select an empty/blank button > Choose the Backoffice Shortcut option, Select Manufacture Items from the Back 
Office Shortcut dropdown option, enter a button caption of ‘Manufacture Items’ then press Save 
 

 
 
Close the POS Screen editor and POS Screen layout, then open the POS Screen.  
Press the Manufacture Items button. 
 

 
 
 
 
 
 
 
The Manufacture Items screen will be displayed. 
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The Batch Name will be pre-filled with the POS terminal number followed by an incrementing number. 
When Manufacturing Items using the POS Screen, the batch is created and the items are manufactured at the same 
time after pressing the Process button. 
 

 
 
Items which have been manufactured via the POS Screen will be displayed on the Manufacture Batches screen. 
Go to Transactions > Stock Control > Manufacture Items 
 

  



Reports 

Promotions Report – Option to Group by Location 

This function adds the ability to Group by Site or Location when running the Promotions Report. 

This feature is useful where you have multiple sites or locations and need to group the Promotions by Site or Location. 

 

When running the report and selecting the Group by Site option, Promotions will be grouped by the Site at which they 

were triggered. 

When running the report and selecting the Group by Location option, Promotions will be grouped by the Location at 

which they were triggered. 

 

Go to Reports > Sales > Promotions 

Select the Location option to group by Location 
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The resulting report will show the Promotions grouped by Location. 

 

 
 

  



Close the Report. 

Then select Group by ‘Site’ 
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The resulting report will show the Promotions grouped by Site. 

 

  



Stock Manage 

Support for Price Changes functionality 

This function adds the ability for Idealpos to send Stock Prices to the Stock Manage app, as well as the ability to 

process Price Changes that have been performed from the Stock Manage app. In addition, the Pricing option in the 

Stock Manage app can be used to check the current price for a Stock Item, provided that the most recent data has 

been downloaded to the app. In order to utilise the Price Changes functionality, you will need to update your Stock 

Manage app on all your mobile devices.  

 

If the Stock Manage app has not updated automatically on your device, it can be updated manually. If you are using 

an iOS device, open the App Store app, click on Updates, then click on the UPDATE text located next to the Stock 

Manage app under the Available heading. This will update the app on an iOS device. 

If you are using an Android device, open the Google Play store app, click on the menu icon then click on My apps & 

games then under the Updates tab, look for the Stock Manage app and press the UPDATE button next to the app. This 

will update the app on an Android device. 

 

Once the Stock Manage app has been updated, the Pricing function will appear on the main menu of the Stock 

Manage app. 
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Before you can use the Pricing/Price Changes function, you need to enable Stock Prices in the POSServer. 

Open the POSServer application on your POSServer system.  

If you can’t find the shortcut to open the POSServer, you may find it in the following location. 

C:\Program Files\Idealpos Solutions\POSServer\POSServer.exe  

 

After you’ve opened the POSServer application, click on the Stock Manage option at the top of the window, then click 

on the Configuration button 

 

  
 

You will then need to enable the Stock Prices setting by setting it to ‘True’. 

This can be done by clicking on the row that contains the Stock Prices setting, then clicking on the dropdown arrow 

and selecting the ‘True’ option. After this has been done, True should be displayed next to Stock Prices, as per the 

following screenshot. 

 

 
 

Press OK to save the change, then close the Idealpos POSServer Configuration window by pressing the X on the top 

right corner of the window. 

 

  



You will then need to download the latest data to the Stock Manage app from Idealpos which will include Stock Items 

and their Sell Prices. Open the Stock Manage app on your device then click on Data Control. 

 

 
 

If you have any pending data on the device that needs to be uploaded, upload the data first by pressing the Upload 

button, then go to Idealpos and process it via the Stock Manage menu. 

 

Once the data has been uploaded and processed, you may then download the data to the app. Doing this will 

download your Stock Items and their prices to the app, ready for use with the Stock Manage Pricing function. 

Press the Download button to download the data. 
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Once the data has been downloaded, you will return to the Stock Manage main menu. 

Select the Pricing button. 

 

 
 

Then press the + button on the top right corner of the screen to search for a Stock Item which a Price Change will be 

performed against. 

 

 
 

  



This will display the Search Item screen where you may enter the Stock Item description to search for the Stock Item. 

Once you find the item that you want, click on it.  

 

 
 

After clicking the Stock Item, the item will be displayed and show the Item’s Selling Prices. 

 

 
 

Alternatively, you may search for an item by scanning the Stock Item’s barcode using the camera scan function, Linea 

Pro scanner or the GeneralScan Bluetooth scanner. If the Stock Item barcode exists, the Stock Item which matches the 

barcode will be displayed. If the barcode doesn’t match any Stock Items in your system, you will see a Not Found 

message indicating that the barcode was not found. 
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To change the selling price of a Stock Item, click on the Selling Price that you want to change. 

A numeric keypad will be displayed and the Selling Price will be highlighted, ready for editing. 

The value that is entered will overwrite the existing value. Update the price by entering a new value. 

 

 
 

You may continue and update any other Price Levels that require changing. 

Once you have changed the selling prices for the item, press the Save button. 

 

 
 

You will return to the Pricing screen. Any items that have had a Price Change will be displayed on this screen. 

To add price changes for any other Stock Items, press the + button on the top right corner and repeat the above 

process. 

  



Also note that once a Price Change has been made for an item, the Price Change entry can be opened and modified if 

required. This can be done by clicking on a Stock Item from the Pricing screen. 

Prices which have been changed will be displayed in bold as per the below screenshot. 

 

 
 

Any Stock Items that have had a Price Change made but no longer required can also be deleted. 

Simply swipe from right to left on the Stock Item in the Pricing screen and the ‘Delete’ button will be revealed (the 

same way that you would swipe on an item in a Stocktake to delete it).  

Press the ‘Delete’ button to delete the Price Change entry.  

 

 
 

When deleting a Price Change entry, the Sell Price for the item will revert back to the original sell price that was 

downloaded from Idealpos. 

 

Note that any price changes which have been made via Stock Manage will not be active in Idealpos until you upload 

the Pricing data to Idealpos then process it. 

 

To upload the Price Changes, return to the main menu in the Stock Manage app, then click on the Data Control option. 

Finally, press the Upload button. 
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Any Price Changes on the device will be uploaded to Idealpos. 

 

Before the price changes are applied in Idealpos, you will need to review them then process the changes. 

 

Go to the Idealpos main screen; you will see that ‘Stock Manage data is available’ will be displayed on the main screen. 

 

 
 

Click on the Stock Manage menu. The Process Price Changes option should show a green dot next to it, which 

indicates that there is Price Change data available for processing. 

Select the Process Price Changes option by clicking on it. 

 

 
 

  



You will see the following screen from where you may review the pending price changes. 

 

 
 

Each Sell Price will be displayed on an individual line. This means that if you’ve changed multiple Price Levels for a 

Stock Item, there will be multiple entries for the Stock Item. 
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A Sell Price for a Stock Item Price Change may be updated by clicking in the Price field then updating the price. On a 

touchscreen or POS device, you may click on the dropdown arrow and update the price using the on-screen keyboard, 

then press the Enter button on the on-screen keyboard to update the price.  

Updating the price is beneficial in the case that the operator may have accidentally entered the incorrect price via the 

Stock Manage app while making the change.  

 

 
 

  



In addition, an individual price change may be deleted by clicking on the line and pressing the ‘Delete Line’ button at 

the bottom left corner of the screen. The selected Price Change will be removed from the Price Changes and will not 

be processed.  

 

 
 

Finally, if Price Changes were uploaded in error and they are not required, the ‘Cancel All’ button may be used to 

delete all price changes from the list. Pressing the ‘Cancel All’ button will display a confirmation prompt and once you 

have confirmed that you want to cancel all price changes, they will be cleared and will not be processed into the 

system. 

 

 
 

 
 

Once you are happy with the Stock Item price changes that are displayed in the list, you can produce a report of the 

changes by pressing the eye icon on the top right corner of the screen.  
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This will produce a report showing the price changes.  

 

 
 

To apply the changes, close the report and press the Process button. 

 

 
 

This will process the changes into Idealpos. Note that displaying the report is not a requirement for processing the 

price changes, however may be beneficial for saving/printing in case you need to refer to the price changes that were 

processed. 

 

A message indicating that the Price Changes have been processed will be displayed 

 

 
 

  



Tax Monitoring 

Support for Fiji VAT Monitoring System 

This function adds support for the Fiji VAT Monitoring System. 

New law/regulation in Fiji has been enacted regarding Tax Administration/Monitoring. Businesses operating in Fiji will 

need to be compliant with the changes that have been enacted. For more information about the changes, please refer 

to the Fiji Revenue & Customs Service - https://www.frcs.org.fj  

 

You may need to refer to the Fiji Revenue & Customs Service for more information regarding the specific URL, Port or 

PIN numbers that need to be configured.  

To configure and use Idealpos with the Fiji VAT Monitoring System, the following steps need to be followed: 

 

1. Add the Fiji Vat monitoring option to the Licence. This step will enable the Fiji VAT Monitoring options in the 

Idealpos interface. You will need to speak to our sales team who will be able to organise this for you.  

Once the Fiji Vat monitoring option has been enabled for your Idealpos Licence, you may confirm this by 

opening the main Idealpos screen and going to Setup > Licence Gateway 

 
 

The Options column should include the option called Fiji Vat Monitoring 

 

 
 

2. A Buyers TIN (Tax Identification Number) text field option needs to be added. 

Go to Setup > Global Options > Customers and add the Buyers TIN to the Text Fields 

 

https://www.frcs.org.fj/
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3. The URL, Port, PIN and Buyer TIN Field need to be configured.  

Go to Setup > Global Options > Interfaces 2 

Select the Buyers TIN from the Buyer TIN Field option. The other options will need to be filled out using the 

details supplied by the Fiji Revenue & Customs Service. Please contact FRCS for more information.  

 

 
 

4. Adjust the QR Code size. We have used a QR Code Size of 4, however, you may find another size may you’re 

your setup better. 

Go to Setup > Global Options > Printing 
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5. Configure the Tax Descriptions and Tax Rates 

The Tax Descriptions/Labels must be explicit 

Go to Setup > Global Options > Sales 

 

 
 

The Tax Labels supplied for use with the Fiji VAT Monitoring System are listed below for reference, however, 

we recommend that you refer to the FRCS for the latest information regarding Tax Labels and rates. 

 

 
 

  



6. Setup the Customer TIN (Tax Identification Number) if required. 

Go to File > Customers > Customers > Select Customer > Modify > Advanced > Enter the TIN into the Buyers 

TIN field 

 

  
 

7. When a sale is completed at the POS, a Fiscal receipt will be generated 

 

 
 

 

  



 Update History 
 

8. To refund a transaction or to refund items from a previous transaction, press the Refund button on the POS 

screen and select a previous transaction 

 

 
 

  



9. The refund transaction will be displayed on the POS screen ready for processing 

 

 


