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Idealpos 7.1 Build 6 

Update Details: 

 

[IP-2230] - Due Date on Supplier Invoices for Xero Accounting 

[IP-2600] - Keep Serialized Coupon in unredeemed state if added to a sale but not applied 

[IP-2778] - Allotrac Transport Management Integration 

[IP-3007] - Activity Log - Show when Stock Manage has uploaded data 

[IP-3034] - Yes/No Option - Auto-Enable Stock Items in Location when modified 

[IP-3036] - Yes/No Option - Fast Service on Unoccupied Tables Only 

[IP-3061] - Automatic and manual Stock Item Export of Web Store items 

[IP-3070] - Add Customer Code Field to the Fast Add New Customers Window 

[IP-3090] - Prompt for Covers uses Default Covers when Occupying new table 

[IP-3120] - Order Number Function - support for Auto Text on Grids 

[IP-3121] - Global Options - consolidated area for Interface Setup 

[IP-3124] - Support for Idealpos ARK Cash Drawer 

[IP-3127] - Export Stock Items - option to Remove Padding 

[IP-3128] - Export Stock Items - option to have Prices in Cents 

[IP-3130] - Ishida Scalelink Export - Option To Set Price Level 

[IP-3149] - Speed Improvement with Large Kitchen Prints using Group Instructions by Seat 

[IP-3162] - Using Hold Print and Web Orders Simultaneously (User-Defined) 

 

  



Back Office 

Activity Log – Show when Stock Manage has uploaded data 

This function adds a pop-up prompt which will appear when attempting to update Stock Levels from a Stocktake when 

there are Stock Manage Stocktake counts that are still waiting to be processed. 

This particular function will assist customers who have specific terminals that are licenced for Stock Manage and other 

terminals which do not have a Stock Manage licence. This prompt therefore prevents unprocessed Stock Manage 

Stocktake counts from being missed when updating Stock Level counts for a Stocktake. 

 

To demonstrate and use this function, follow the below steps: 

Note that the below steps involve starting a Stocktake for the purpose of demonstrating this function. If you have an 

active Stocktake in progress, we recommend either completing the Stocktake, or demonstrate/test this function on a 

different environment which is separate to the one the Stocktake is being completed in. 

 

1. Start a Stocktake by going to Stocktake > Start Stocktake 

Click in the “Click to Start Stocktake” column next to Location, then press “Start Stocktake” on the bottom-

right corner of the screen. 
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2. Dismiss the following prompt by pressing “OK” 

 

  
 

3. Using Stock Manage on a mobile device, go to Data Control > Download. 

Then in Stock Manage, go to the Stocktake option and add items to the Stocktake.  

Return to the main Stock Manage menu, then select “Data Control” and upload the Stocktake to Idealpos 

 

4. Return to Idealpos and go to: Stocktake > Enter Stocktake. 

Enter counts for a few Stock Items, then close the Enter Stocktake window. 

 

  
 

  



5. Go to Stocktake > Update Stock Levels > Click into the “Click to Update Stock Levels” column next to the 

location to update counts, then press the “Update” button on the bottom-right corner. 

 

  
 

6. The following prompt will be displayed which indicates that there are unprocessed items from Stock Manage 

or PDE uploads. 

 

  
 

When this prompt is displayed, the user is given the opportunity to go back and process the unprocessed 

Stock Manage or PDE uploads. 

To cancel the update of the Stock Counts, press “No”. 

Otherwise, if you want to ignore the Stock Manage or PDE uploads, press the “Yes” button. 

If you choose to ignore the Stock Manage or PDE uploads, those Stock Manage uploads will remain in the 

system and can be processed at a later time when required via the Stock Manage > Process Stocktake menu in 

Idealpos.  
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Coupon Promotions 

Keep Serialised Coupon in unredeemed state if added to a sale but not applied 

This function improves on the logic used by Idealpos when adding Coupons to a sale. 

Previous to this change, serialised Coupons would become marked as redeemed if they were added to a sale but not 

applicable in that sale. After this change, serialised Coupons will only become marked as redeemed once they’ve been 

added and applied to that sale (i.e. caused a trigger to occur in the sale such as adding a bonus item, triggering a 

discount, etc.). 

 

To demonstrate this function, we will use a Coupon Promotion built into the Idealpos Demo Database. 

Using the Idealpos Demo Database, go to: 

File > Sales > Promotions > Coupon Promotions 

Check and ensure that a Coupon Promotion exists for “Next Day Free Rides”. 

The Coupon Promotion should appear as follows: 

 

 
 

The Coupon Promotion is configured as follows: 

Trip Conditions Set 1: 

Trip by Quantity: Buy 1 of items below 

Department: 701 – Admissions 

 

Trip Conditions Set 2: 

Trip by Quantity: Buy 1 of items below 

Department: 702 – Rides 

 

 



Discount Type: % Discount off Items: 100% 

One Item Only: Unchecked 

Serialised Tracking: Enabled 

Apply Discount to: Only Items Below 

Department: 702 – Rides 

 

Once the promotion has been confirmed to be active (From/To Date Range current) and configured as above, close 

the Coupon Promotion screen and any other Promotion windows, then open the POS screen by pressing the POS 

button on the top-left corner of the Back-Office dashboard. 

 

Click on the SERVICES tab at the bottom of the screen, then add the following items to the sale: 

• SINGLE ADULT ADMISSION 

• ALL RIDES ALL DAY 
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Press ENTER to go to the Tender screen, then select a tender type/amount to finalise the sale. 

A Coupon Promotion will be printed similar to the below. 

 

 
 

The Coupon will only apply a discount to any items sold from Department 702 – Rides. 

Therefore, adding this coupon to a sale with items other than rides will leave the coupon in an unredeemed state. 

 

  



To demonstrate this, go to the MANAGER tab on the POS Screen, then enter the Coupon Code (printed at the bottom 

of the Coupon – in the above example, the Coupon Code is 64001) and press the “COUPON PROMO” button. 

You can then add a Cappuccino item to the sale and tender the sale. 

 

 
 

Now start a new sale, go to the MANAGER tab, enter the same Coupon number then press the COUPON PROMO 

button. 
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Click on the SERVICES tab on the POS screen, then add “ALL RIDES ALL DAY”. 

The discount from the Coupon will be applied to the sale. 

 

 
 

Finalise the sale by pressing the “ENTER” button, then select a tender type/amount. 

 

Repeat the above steps to redeem the same coupon for RIDES ALL DAY and the Coupon is now marked off as 

redeemed, making it no longer possible to redeem the Coupon a second time. 

This demonstrates that the Coupon is only marked as redeemed when it has been added to a sale which contains 

items that the Coupon is applicable to. 

 

  



Customers 

Add Customer Code Field to the Fast Add New Customers Window 

This function adds the Customer Code field to the Fast Add New Customers window. 

This feature may be useful for users who manage their own Customer Codes and want to use the Fast Add New 

Customers window. These types of users may now use the Fast Add New Customers Window. 

 

To configure and use this function, go to: 

Setup > Yes/No Options > Enter “Fast Customer” into the “Enter Keyword Search” field. 

Enable the following Yes/No Options: 

• Fast-Customer – New Customer Code Field 

• Fast Customer Searching 

 

 
 

Close the Yes/No Options window, then from the main Idealpos back-office dashboard, press the “POS” button on the 

top-left corner of the screen. 
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Press the “Customer” button on the main POS screen, then press the “New Customer” button to add a new Customer. 

 

 
 

  



The New Customer window will appear and the Customer Code field is now available at the top of the screen. 

This field can be used to manually enter the Customer Code as required. 

After entering the Customer Code, fill out the required fields for the Customer, then press the “OK” button on the 

bottom-right corner of the screen. 
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Delivery Interface 

Allotrac Transport Management System 

This function adds the ability to configure Idealpos so that it sends jobs to the Allotrac Transport Management System. 

As this integration involves numerous steps to configure and use, we recommend that you review the Allotrac 

Transport Management System topic in the Idealpos User Guide for more information about configuring and using 

this integration. 

The Allotrac Transport Management System topic is available in our User Guide by clicking on the below link: 

https://userguide.idealpos.com.au/#Delivery Interface/Allotrac Interface/Allotrac Interface.htm 

 

The Allotrac Interface is configured via Setup > Global Options > Interfaces > Allotrac 

Refer to the link above for more information about configuring and using this interface. 

 

  

https://userguide.idealpos.com.au/#Delivery Interface/Allotrac Interface/Allotrac Interface.htm


Export Data 

Automatic and Manual Stock Item Export of Web Store Items 

This function adds the ability to Automatically and Manually export Web Store Items only. 

Some customers may require the ability to only export Web Store Items from Idealpos.  

By only exporting Web Store Items from Idealpos, the size of the export file will be reduced and may also improve the 

speed when only importing Web Store items into the Web Store interface/integration. 

 

To configure the Automatic Export of Web Store Items, go to: 

Setup > POS Terminals > Select Terminal > Modify > Import/Export 

 

In the “Export Stock Items” field, select the option “Webstore Items Only”. 

Configure any other details as required for the export such as:  

• Export Folder 

• Export Daily at/Or every # minutes 

• Filename 

• Any other required checkboxes as required 
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Close the POS Terminals window, then go to: File > Stock Control > Stock Items 

Open a Stock Item which is required on the Web Store, then enable the “Web Store” checkbox so that the item will be 

included in the Web Store Export. 

 

  
 

Repeat the above process for each item that needs to be included in the Web Store export. 

Alternatively, you can use the “Range Programming” function to enable the Web Store item for a range of Stock Items. 

This function is available via:  

Utilities > Range Programming > Stock Items 

 

When using Range Programming, we recommend that you take care and precaution as it is possible to modify 

settings/fields for all your Stock Items at once.  

 

The Web Store Items will be included in the Web Store Export which will take place as per the Import/Export 

configuration which has been configured in the above steps. 

  



In addition to the “Webstore Items Only” format, the Web Store Items option has also been implemented in the 

Automatic Export Format which can be configured by going to: Utilities > Export Data > Stock Items 

 

Select the Automatic Export Format, then enable the “Webstore Items Only” checkbox, then finally press the “Save 

Format” button on the bottom-right corner of the screen. Before Saving the format, you may also want to specify 

specific fields to be included in the Automatic Export Format. 
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Export Stock Items – Option to have Prices in Cents 

This function adds the ability to export Stock Items with the price listed in cents in the export file. This function is 

available when exporting using the “Automatic Export Format”. 

 

To use this function, go to: Utilities > Export Data > Stock Items 

From the Export format dropdown box, select the “Automatic Export Format”. 

Prices in Cents is available from the bottom-right corner of the window which can be used to enable this function. 

Note that if the Automatic Export Format hasn’t previously been used/saved, you may need to select the specific fields 

that you require in the exported data. 

 

 
 

  



Once you have selected the required fields and ensured that the “Prices in Cents” option is enabled, press the “Save 

Format” button on the bottom-right corner of the screen. 

An “Automatic Export Format Saved” message will appear, indicating that the format was saved successfully. 

Press the “OK” button to dismiss the prompt. 

 

 
 

This format will be used when data is exported using the Automatic Export Format. 

In order to use the Automatic Export format, you will need to configure an Automatic Export in Idealpos. 

To do this, go to: Setup > POS Terminals > Modify > Import/Export > Automatic Export Settings 

 

In the Automatic Export Settings, configure the details as required. 

The key details which are required are: 

• Export Folder 

• Export Stock Items – All items 

• Export Daily at (enter in 24 hour format)/Or every # minutes 

• Filename 

• Use Saved Automatic Export Format 
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Once configured, close the POS Terminals configuration screen, then wait until the time configured in the “Daily Export 

at” has lapsed. 

The Automatic Export file will be created in the Export Folder as configured above. 

 

When “Prices in Cents” is enabled, the decimal place in the price is completely omitted. 

Whereas when “Prices in Cents” is disabled, the decimal place will appear for all prices in the export file. 

In the below example, the sample export file was produced with the Prices in Cents option disabled: 

 

 
 

In the below example, the sample export file was produced with the Prices in Cents option enabled: 

 

  



Export Stock Items – Option to Remove Padding 

This function adds the ability to export Stock Items without padding (i.e. any white will be removed).  

This function is available when exporting using the “Automatic Export Format”. 

 

To use this function, go to: Utilities > Export Data > Stock Items 

From the Export format dropdown box, select the “Automatic Export Format”. 

Remove Padding is available from the bottom-right corner of the window which can be used to enable this function. 

Note that if the Automatic Export Format hasn’t previously been used/saved, you may need to select the specific fields 

that you require in the exported data. 
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Once you have selected the required fields and ensured that the “Prices in Cents” option is enabled, press the “Save 

Format” button on the bottom-right corner of the screen. 

An “Automatic Export Format Saved” message will appear, indicating that the format was saved successfully. 

Press the “OK” button to dismiss the prompt. 

 

 
 

This format will be used when data is exported using the Automatic Export Format. 

In order to use the Automatic Export format, you will need to configure an Automatic Export in Idealpos. 

To do this, go to: Setup > POS Terminals > Modify > Import/Export > Automatic Export Settings 

 

In the Automatic Export Settings, configure the details as required. 

The key details which are required are: 

• Export Folder 

• Export Stock Items – All items 

• Export Daily at (enter in 24 hour format)/Or every # minutes 

• Filename 

• Use Saved Automatic Export Format 

 

 
  



 

Once configured, close the POS Terminals configuration screen, then wait until the time configured in the “Daily Export 

at” has lapsed. 

The Automatic Export file will be created in the Export Folder as configured above. 

 

When “Remove Padding” is enabled, any white space in each line of the exported data is omitted, simply being 

separated by commas. 

Whereas when “Remove Padding” is disabled, any white space in each line will be included in the output file. 

In the below example, the sample export file was produced with the Remove Padding option disabled (white space 

included in each line): 

 

 
 

In the below example, the sample export file was produced with the Prices in Cents option enabled (white space 

omitted from each line): 
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Ishida ScaleLink Export – Option To Set Price Level 

This function adds the ability to set a Price Level for the exported Stock Items when using the Ishida ScaleLink Export 

format. Previous to this change, the Ishida ScaleLink Export would push Price Level One, regardless of what the POS 

Terminal Price Level was locked to. With this change, the Price Level can now be specifically defined in the Automatic 

Export Settings so that the desired Price Level is exported. 

 

To configure and use this function, go to:  

Setup > POS Terminals > Select Terminal > Modify > Import/Export 

From the “Export Stock Items” dropdown box, select “Ishida ScaleLink Export”. 

A Price Level field will be displayed to the right-hand side of the Export Stock Items dropdown box. 

Enter a desired Price Level between 1 to 12 that you want to use for the Ishida ScaleLink Link Export. 

Enter or update any other configuration options as required: 

 

 
 

The export file will be saved to the Export Folder using the Filename configured at the time or interval configured.  

All Stock Items included in the export will be exported using the Price Level that has been defined.   



Global Options 

Global Options – Consolidated area for Interface Setup 

This function has consolidated the Interfaces and Interfaces 2 tabs into a single tab in Global Options. 

This change was made in order to add the ability for us to add new interfaces without creating an Interfaces 3 tab. 

All Interfaces are now displayed in a list within a single Interfaces tab. 

You can see which interfaces are enabled/configured by either a tick next to the name, or the type of Interface that has 

been selected. Once an interface has been configured, either a tickbox will appear next to the Interface name, or the 

Interface Type will appear next to the Interface name. 

 

To use this function, go to: Setup > Global Options > Interfaces 

 

A list of interfaces will be displayed on the left-hand side of the screen. 

Select the interface to display the options available for configuring that interface. 

Once an Interface has been configured, it will either show a tickbox or the Interface Type, depending on what the 

Interface Type is. Also note that some Interfaces will need to be licenced and configured in order for them to display 

the tickbox or the Interface Type next to the Interface. 

 

In the below example, the eCommerce Interface has been enabled and the Reservations Interface has been configured 

with the Interface Type of ResDiary. 

 

 
 

 

  

  



 Update History 
 

POS Screen Setup – Grids 

Order Number Function – Support for Auto Text on Grids 

This function adds the ability to configure an Order Number button on a POS Screen Grid with Auto Text. 

Using the Auto Text option within the Order Number function allows a default Order Number to be used when 

pressing the Order Number button. 

Note that this function (Auto Text in the Order Number function) was previously available from the POS Screen Layout, 

but this change enables it to be used within a POS Screen Grid. 

 

To configure and use this function, go to:  

Setup > POS Screen > Grids 

Select the grid from the list, then press “Items”. 

Alternatively, press the “Add” button on the bottom-right corner to create a new POS Screen Grid. 

 

 
 

  



Then select the Order Number function from the list available on the right-hand side of the screen. 

The Automatic Text field will become available towards the top of the screen. 

Enter an order number into the Automatic Text field. This number can be alpha-numeric and will be automatically 

assigned to any order when the button is pressed. 

Also ensure that you also assign a Button Caption which will be displayed on the button and if required, the 

background colour, font, text colour and size can also be adjusted as required. 

Once complete, press the “Save” button on the bottom-right corner of the screen. 

 

 
 

If multiple Order Number buttons are required, repeat the above process. 

Once complete, you may close the POS Screen Grid. 
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If the Order Number button was added to an existing POS Screen Grid, you may skip this step and proceed to using 

the button.  

Otherwise, you will need to complete the next step in order to link a button on the POS Screen Layout to the POS 

Screen Grid that was created above. 

Go to: Setup > POS Screen > POS Screen Setup > Select a Layout > Buttons 

 

Select a blank POS Screen Button, then configure the button by selecting the “POS Screen Grid” function from the list. 

Finally, select the name of the POS Screen Grid from the dropdown list. 

You may also name the POS Screen Grid as required and once complete, press the “Save” button to save the change. 

 

 
 

Close the POS Screen Layout window, then open the POS screen. 

  



Add Items to the order, then press the button on the POS Screen which is configured to open the POS Screen Grid. 

In the below example, the button which opens the POS Screen grid was created within the Restaurant tab. 
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The POS Screen grid will appear with the Order Number button. 

Press the button to assign an Order Number to the order using the text that was configured in the Automatic Text 

field. 

 

 
 

  



After the button is pressed, the Order Number will be assigned to the order using the text that was entered into the 

Automatic Text field. 

 

 
 

The order can then be finalised by pressing the ENTER button, then press a tender amount. 

The Kitchen Docket and final customer receipt will both show the Order Number from the Automatic Text field. 
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POS Terminals 

Support for Idealpos ARK Cash Drawer 

This function adds support for the Idealpos ARK Cash Drawer to Idealpos. 

The steps to configure the Idealpos ARK Cash Drawer are fairly straight-forward.  

Simply go to: Setup > POS Terminals > Select Terminal > Modify > Other Peripherals 

 

Under the Cash Drawer section, select the “Idealpos ARK” option from the Connection dropdown box. 

 

 
 

  



Restaurant 

Prompt for Covers uses Default Covers when Occupying new table 

This change updates the logic that is used to display the number of covers in the Covers Prompt that appears in 

Idealpos when selecting a table from the table map. As part of this change, a prompt has also been introduced when 

entering a number of covers that exceeds 99. 

 

Previous to this change, the Default Covers that were set for a table were not fixed, which meant that when you saved 

an order to a table and you entered a number of covers that were different to the default number of covers, the 

default covers for the table were then modified with the newly entered number of covers. After the table was paid and 

the next time the table was used, the newly entered number of covers were displayed in the Covers Prompt instead of 

the default covers that were originally set for the table. 

After this change, the Default Covers that are set for a table are now fixed, which means that when you save an order 

to a table and you enter a number of covers for the table which differs to the Default Covers, the next time the table is 

used, the default number of covers will appear in the Covers Prompt instead of the number of covers that were last 

used for the table. 

There is no configuration involved to enable this as this logic/behaviour has been hard-coded into Idealpos. 

 

To use this function, go to: Setup > Restaurant > Table Maps > Select Map > Modify.  

Right-click on a table, select “Covers” then click on the number of Covers that you want to set as the default number 

for the table. 

 

 
 

You may repeat the above process for all tables that you want to set a Default number of covers. 

Once completed, press the “Save” button on the bottom-right corner of the screen. 
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Close the Table Maps screen.  

 

Go to: Setup > Yes/No Options and ensure that the below options are configured as follows:  

• Prompt for Covers – Enabled/Checked 

• Fast Service on Unoccupied Tables Only – Disabled/Unchecked 

 

The configuration of these Yes/No Options is shown below: 

 

 
 

 
 

  



Once the Yes/No options have been configured, close the Yes/No Options window, then open the POS Screen by 

pressing the “POS” button from the top-left corner of the back-office dashboard. 

From the POS screen, press the “Table Map” button, then select a table from the map and press the “POS” button on 

the bottom-left corner of the screen. 

 

 
 

The Covers prompt will be displayed and will show the default number of covers for the table. 

The example on the left is the default number of covers for the table and the example on the right is the number of 

covers that have been manually entered for this particular sale. 
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After pressing “OK” to the Covers prompt, the POS screen is displayed. Add any required items to the order, then press 

the “Table Map” button to save the sale to the table. The number of entered Covers are displayed on the left-hand 

side of the screen in the centre in brackets as indicated below. 

 

 
 

Press the “Table Map” button to save the sale to the table and to go to the Table Map screen. 

Select the table from the Table Map and press the “Pay All” button. 

Press the “ENTER” button, select a tender type to finalise the sale. 

 

  



The Table Map will be displayed and depending on how your system is setup, the table status may appear as “To 

Clean”. If required, select the table and press the “Finished” button. 
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You can now select the same table and press the “POS” button. 

 

 
 

The Prompt for Covers window will appear, and the number of covers displayed will be the Default Covers that were 

set for the Table via Setup > Restaurant > Table Maps > Modify (in this case, the number of default covers were set to 

4), not the number of covers that were entered for the table the last time it was used (the last time the table was used 

in the above example, 2 covers were entered for the  table). 

 

 



In addition to the above change, when entering a number of Covers which exceeds 99 as per the below example, a 
prompt will be displayed to confirm: 
 

 
 
Pressing “Yes” will proceed to the Table Map with the entered number of covers, or pressing No will return to the 
Covers Prompt so that you can enter a smaller number of Covers. 
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Stock Purchases 

Due Date on Supplier Invoices for Xero Accounting 

This function adds the ability to set the payment due date days for any supplier and to send that final Due Date to 

Xero Accounting.  

The way this function works is by specifying a number of days in the Payment Due Date Days field of the Supplier 

(typically, this is the number of days that the Supplier requires the Invoice to be paid by). 

Then when a Stock Receive/Invoice is created in Idealpos for that Supplier, the Due Date for the Invoice is calculated 

by adding the number of Payment Due Date Days to the Invoice Date. The Invoice is then then sent to Xero 

Accounting and will include the Due Date for payment. 

 

To configure and use this function, go to: File > Suppliers > Suppliers 

 

Select the Supplier from the list, then press “Modify” 

The default Payment Due Date Days will be “14”, however, you will want to set this to the number of days that the 

Supplier requires payment from the Invoice Date.  

Once the Payment Due Date Days have been updated, press “Save” on the bottom-right corner to save the change. 

 

 
 

  



Go to Transactions > Stock Control > Stock Purchases 

Select an Invoice, then press “Modify”. 

Ensure that the correct “Date of Invoice” has been entered. 

The date displayed in the “Due Date” field will be automatically updated based off the Invoice Date. 

If required, you can also change the date displayed in the Due Date field from the default value. 

Note however that if you modify the Invoice Date, the Due Date will be re-calculated using the Payment Due Date 

Days configured in the Supplier. 

 

 
 

Once the Invoice is correct, press the “Save” button on the bottom-right corner. 
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Select the Invoice from the list of Stock Purchases, then press “Process”. 

 

 
 

Once the Invoice has been Processed, go to: Accounting > Supplier Invoices 

Click into the “Send?” field next to the Invoice, then Send the Invoice to the Accounting package. 

 

 
 

Once the Invoice has been sent to the Accounting package, a “Successful Transfer to Accounting!” prompt will be 

displayed. 

 

 
 

From this point on, you can follow the standard procedure when handling invoices in your Xero Accounting package. 

For more information about using Xero Accounting with Idealpos, please visit the Supplier Invoices page within the 

Xero API Accounting Interface topic of the Idealpos User Guide. 

 

  

https://userguide.idealpos.com.au/#Accounting%20Interfaces/Xero%20API/Supplier Invoices Xero.htm
https://userguide.idealpos.com.au/#Accounting%20Interfaces/Xero%20API/Xero API Accounting Interface.htm


Yes/No Options 

Yes/No Option – Auto-Enable Stock Items in Location when modified 

This Yes/No option adds the ability to control if a Stock Item is automatically enabled in a location when it is modified 

from that same location.  

Each Location in Idealpos has a tickbox option called “Auto Enable Stock Items”.  

When this tickbox is enabled, Stock Items are automatically enabled in all locations which have the option ticked at the 

time the Stock Item is created. When a Stock Item is modified from a selected location, it would also become 

automatically enabled in that location if the “Auto Enable Stock Items” tickbox was checked.  

This change now enables this behaviour to be controlled so that when Stock Items are modified from a specific 

location, the Stock Item will or won’t be automatically enabled depending if the “Auto Enable Stock Items” option 

ticked. 

 

To configure and use this function, go to: Setup > Yes/No Options 

Enter Keyword Search: “auto-enable”, then disable the setting “Auto-Enable Stock Items in Location when modified” 

 

 
 

Close the Yes/No options window. 

 

To demonstrate the usage of this function, we will need to identify which location the current POS terminal is in. 

At the top of the Idealpos window, the POS Terminal name and number are displayed as per the below example: 

 

 
 

Then go to Setup > POS Terminals 

 

Find the current POS terminal that matches the terminal displayed in the previous step to determine the Location that 

the POS terminal exists in. The below example shows that POS 1 exists in Location 1. 
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Close the POS Terminals window, then go to:  

File > Stock Control > Locations 

 

A list of locations will be displayed and will show the status of the Auto-Enable Stock setting as shown below. 

 

 
 

Ensure that the location which the current POS Terminal is located in has the “Auto Enable Stock Items” option 

enabled, then press “Save” to save the change. 

 

 
 

  



Close the Locations window, then go to: File > Stock Control > Stock Items 

 

Search for an unused Stock Item, then select the item.  

Press the “Locations” button on the bottom-right corner of the screen. 

 

 
 

 

A list of locations which the selected Stock Item is currently enabled in will be displayed. 

If the Stock Item is currently enabled in the same location as the POS Terminal, remove the item from the location by 

selecting the Location then pressing the “Delete” button on the bottom-right corner of the screen. 

 

 
 

Press “Yes” to confirm and delete the Location. 
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Close the Stock Items By Location window, then double-click on the Stock Item to modify it. 

 

Make any number of changes to the Stock Item, then press the “Save” button on the bottom-right corner of the 

screen. In the below example, each of the Selling Prices were modified. 

 

 
 

After pressing “Save” to make the change, ensure the Stock Item is selected from the list of items, then press the 

“Locations” button. 

 

 
 

  



A list of Locations will be displayed.  

The Stock Item will not be enabled in any new locations. 
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If the Yes/No Option “Auto-Enable Stock Items in Location when modified” is enabled and the Location which the 

terminal resides in also has the “Auto Enabled Stock Items” option enabled, then any changes or modifications to the 

Stock Item made from the terminal will result in the Stock Item being enabled. 

 

 
 

  



Yes/No Option – Fast Service on Unoccupied Tables Only 

This function improves the serving speed when selecting Unoccupied tables from the Table Map. 

When this Yes/No option is enabled and you select an unoccupied table from the Table Map, Idealpos will 

automatically initiate a sale for the selected table and return to the POS screen, allowing items to be added to the 

table. By enabling this setting, the step of having to press the “POS” button after selecting a table is removed, 

therefore improving the speed of serving the customer and saving items to a table.  

Note that when this Yes/No Option is enabled, the Yes/No option “Prompt for Covers” will be overridden in the case 

when there are no items in the sale, pressing the Table Map button and selecting a table. In this particular case, the 

default number of covers configured for the table will be used. 

If you need to specify the number of covers for a table when using this Yes/No option, you can alternatively add the 

items to the sale first, press the Table Map button, then select a table from the Table Map – the Covers Prompt will be 

displayed.  

Also note that when Fast Service on Unoccupied Tables option is enabled, the following functions will be unavailable: 

• Reserve an Unoccupied Table  

• Occupy function (when Yes/No option “Inhibit Occupy Table Function” is disabled) 

 

To configure and use this function, go to: Setup > Yes/No Options 

Enter “fast service” into the Enter Keyword Search field.  

Then enable the Yes/No Option “Fast Service on Unoccupied Tables Only” 

 

 
 

Close the Yes/No Options screen, then go to the POS Screen by pressing the “POS” button on the top-left corner of 

the back-office screen. 

  



 Update History 
 

Press the Table Map button from the POS Screen, then select an unoccupied table. 

 

 
 

  



After selecting the Unoccupied table, Idealpos will go straight to the POS screen where items can be added to the 

order. The selected Table Number will also be displayed on the POS screen indicating that any items added to the sale 

will be saved to the table. 

 

 
 

  



 Update History 
 

Add any required items to the table, then press the “Table Map” button. 

Items added to the order will be saved to the table and a Kitchen Docket will be printed. 

 

 
 

  



If the Yes/No Option “Fast Service on Unoccupied Tables Only” is disabled, the Table Map screen will remain open 

after selecting an Unoccupied Table. 

 

 


