
Ideal Handheld v2 

Ideal Handheld (IH) enables a waiter to remotely take table orders on the go throughout the restaurant.  This version 

has been updated to include a lot of new features which include a mode to allow guests to order from the device 

themselves.  

 

   
 

IH uses an app installed on an iPod, iPhone or iPad through a host terminal. IH is an add-on module to Idealpos and 

needs relevant licensing on the host terminal. Idealpos and POSServer must both be running when using IH. 

POSServer does not need to be on the host terminal. There can be as many host terminals as required throughout the 

establishment.  

 

Ideal Handheld v2 uses the POS Screen Tabs to connect to the database, but can also use Menus if they have already 

been setup. The benefit of using tabs is that you don’t have to do any additional programming from your POS screen. 

Using an iPad you can also use the Table Map with table status indicators the same as on the POS screen.  

 

 
 

https://itunes.apple.com/us/app/idealpos-handheld-ordering/id843100758?ls=1&mt=8


Handheld Options v2 

Global Options 

Any terminal with the IH License is able to access and use additional settings from Idealpos. Any changes that are 

made in this area of the program will require the Handheld to exit and restart the Ideal Handheld software before the 

changes made will be visible.  

 

Go to Setup > Global Options > Miscellaneous > Ideal Handheld.  

 

  
 

Enable v7 Features –   This allows you to connect to the database and use the POS Screen Tabs to create the 

items on the handheld rather than menus.  

Menus in Code Order –  Menus are sorted by default in Alphabetical Order, you can change this setting by 

checking this box. 

Price Level –   You can set the default price level to be used by the handheld. If no price level is 

selected, Price Level 1 will be used.  

Use Price Level from Menu –  The price level will be selected from the menu that is being used at the current time.  

Notes –   This function is used to display the “Specials of the Day” etc. Use the tilde ~ special 

character to force the items onto a new line on the handheld. 

Print Group Shift 1/2 –  Once setup swipe the item onscreen to the right & it will display the print group 

shifts.  

Tab Layer Colours –   These colours represent the 18 different tabs you use at the bottom of the POS 

Screen layout. Only the tabs with stock items on them will display on the app.  

 

POS Terminal Options 

Other options are available for the handheld to use are direct from the terminal the handheld is licensed. The 

handheld will by default, use the printing options of the host pc. Under some circumstances the handheld can print to 

the kitchen and the terminal will not. This is setup per POS Terminal and uses Sales Categories linked to Sales Category 

Descriptors.  

 



The Stock Item must be configured to not have an order printer selected, which disables printing from the POS 

Terminal.  

 

Go to File > Stock Control > Stock Items > Modify > Printer Settings. 

 

 
 

Check the Department Code the Stock Item is linked to.  

 

 
 

Go to File > Sales > Departments > Modify the Department the Stock Item was linked to (Coffee/Tea) > Ensure the 

Sales Category is linked to Beverage.  

 



 
 

Go to File > Sales > Sales Categories > Modify the Sales Category the Department was linked to (Beverage) > Ensure it 

has been selected for ‘Add to BEVERAGE Total’.  

 



 
 

Go to Setup > POS Terminals > Modify the selected terminal > Miscellaneous > Handhelds.  

 

 
 

When a Flat White is ordered through the POS Terminal, no kitchen docket will print, however, when ordered through 

the handheld device, the docket will be printed automatically.  

 

To use Item Graphics and Table Map (Handheld Background) images they need to be hosted on the web. Link to their 

locations so they can display on the iPad app using v7 features. Item Graphics will only display for POS Screen Tabs 

and Menus when the images are the named the exact same as the Tab or Menu you want them to represent. Beer.jpg 

for Beer, etc.  

 



 
 

User Registration 

The Ideal Handheld Module is used to define how many handheld devices will be connected to a terminal in the 

registration. The number of devices is indicated by the number next to the IH (IH1) in the registration options. It is a 

requirement of this module that Restaurant (RST) module is also installed. You will also need to ensure there is a table 

map with programmed tables. Ideal Handheld will not work without at least one table.  

 

If you have a licence for 3 handhelds (IH3) in your venue, this means you can use any 3 devices with the app installed. 

If a staff member is using their own device, and leaves the venue without logging out of the app, their device will still 

be using one of the 3 licences available to you. To unlock devices and allow new devices to connect, restart the POS 

software on that terminal. All connections will drop and allow new devices to connect.  

 

Handheld POS Screen Layout and Menus v2 

Ideal Handheld v2 will use the POS Screen Layout stock items, grouped by the tabs used to save you programming 

menus. You need to select both Idealpos v7 Features in the app and in POS Terminal Settings for this to take place. 

Once you have done this, any stock item that is on a tab will display within the app the same as menus do, only better. 

All grids will step through the same way allowing staff to be familiar with the layout as soon as it is implemented.  

 



 
 

Ideal Handheld can also use Menus, to display the items on the device. Any items that you want to display on the 

device should be grouped into corresponding menus. These menus then need to be linked to the default Menu 999. 

More information on Menus can be found in the POS Screen Setup Help Guide. 

 

Add items to menus, and menus to the Waiter Pad menu by going to Setup > POS Screen > Menus > Add/Modify. 

 



 
 

The menus that we want to be able to access through the handheld are the only ones that we have programmed to be 

visible here. 

 



 
 

iPhone and iPod Screens v2  

Main Screen 

The main program screen provides you multiple choices on how to use the Ideal Handheld program. The screen will 

look different depending on if you are using an iPad or a smaller screen device. This section details the smaller screen 

devices.  

 

Three Horizontal Lines – Opens the screen to perform advanced functions such as Settings, Change Password, About 

and Log out. 

Clerk – Select the Clerks from the drop down menu provided.  

Guests – This button will only display if selected in the Settings. This will allow you to enter the number of guests 

seated on the table.  

Table – Select the table from the grid selection. 

Start Order – Will open the selected Table and allow items to be added.  

Enquire – This button will open the table details of all items that have been placed on the table.  

Print Bill – Select a table number and press this button to print a bill to the default receipt printer.  

Notes – This button is where specials or other information can be displayed.  

 



  
 

Setup Screen 

Before you will be able to use Ideal Handheld you will need to set some options that enable you to connect to the host 

PC. Before you can access the settings you will need to enter a password. To do this, swipe your finger without lifting it 

from the device across 3 or more dots to make a pattern. This is your password. 

 

Server IP  This field must contain the IP Address of the terminal that has the IH license. 

Server Port  6983 

Root Menu Code  Enter the Menu Code that corresponds to the Main Menu Code that you will be linking to in 

Idealpos. By default this is set to 999. If you are using V7 Features you do not need to have 

anything in this field as the items will be built from the POS Screen Layout. 

Accumulate Items Select if you want items to accumulate on the handheld. 

Enable Connection Allows you to use the app without any orders being sent to the kitchen. 

Hide Guest Field Select this option to enter the amount of guests that are seated at the table.  

Hide Seat Selection This option will not allow seat buttons to be displayed.   

Menu in Code Order By default the menus will display in alphabetical order.  

Monitor Network Displays network status of the device if required. 

Show Notes  This option will allow you to keep the specials on the device so staff have quick access.  

 



  
 

V7 Features 

This screen allows you to turn on advanced Idealpos Version 7 features that will build the items in the app from the 

POS Screen Layout tabs. This option needs to be selected in both the app and Idealpos 7.  

 

V7 Features   This needs to be turned on if you want to link the app to Idealpos 7. 

Graphic File Type  Select from .jpg, .png, .gif or .bmp for the item images.  

Item Graphics   Select if you want to use images for the items.  

Show Image Only Top Menu This option will display images on the very top menu only if selected 

 

 
 

Order Screen 

This screen allows you to enter items to the table and perform multiple actions.  

 

Total Ordered  This is the current total of all ordered items. 



Item Entry  This is the area that will display the items that are entered.  

Table Number  This is the number of the table placing the order. 

Back   Return you to the previous screen. 

+ -   This allows you to add/subtract the quantity of items by multiples of 1. Swipe right to access. 

TXT  This button allows you to add text to the item. Swipe left to access. 

Delete  This allows you to delete the item from the table. Swipe left to access. 

Insert  This will allow you to insert an item that might print out of order. 

Finalize  This will finalize the sale to the table. 

Seat Numbers  This will allocate the selected item to a seat number. 

Menus   This will display the menus to select the items.  

 

   
 

iPad and iPad Mini Screens v2 

Main Screen 

The main program screen provides you multiple choices on how to use the Ideal Handheld program. The screen will 

look different depending on if you are using an iPad or a smaller screen device. This section details the larger screen 

devices. 

 

Home – This button returns you to the table map screen.  

Start Order – This button will allow you to add items to a table. You need to select a table before you can start an 

order. 

Enquire – This button will open the table details of all items that have been placed on the table.  

Print Bill – Select a table number and press this button to print a bill to the default receipt printer.  

Note – This button is where specials or other information can be displayed.  

Refresh – This button will refresh the screen to ensure that the tables are correctly displayed.  

Clerk – Select the Clerks from the drop down menu provided. The button will be named the clerk that is currently 

logged in.  

Settings – Opens the screen to perform advanced functions such as Settings, Change Password, About and Log out. 

Lock – This button will lock the screen in a mode that allows orders to be entered onto a table, but cannot access 

other tables without the device’s password being entered. This can be used to give to the customer to enter their own 

meals while the staff clear other tables.  

 



 
 

Settings Screen 

Before you will be able to use Ideal Handheld you will need to set some options that enable you to connect to the host 

PC. Before you can access the settings you will need to enter a password. To do this, swipe your finger without lifting it 

from the device across 3 or more dots to make a pattern. This is your password. 

 

Server IP  This field must contain the IP Address of the terminal that has the IH license. 

Server Port  6983 

Root Menu Code  If using menus, enter the Menu Code that corresponds to the Main Menu Code that you will 

be linking to in Idealpos. By default this is set to 999. If you are using V7 Features you do not 

need to have anything in this field as the items will be built from the POS Screen Layout. 

Accumulate Items Select if you want items to accumulate on the handheld. 

Enable Connection Allows you to use the app without any orders being sent to the kitchen. 

Hide Guest Field Select this option to enter the amount of guests that are seated at the table.  

Hide Seat Selection This option will not allow seat buttons to be displayed.   

Menu in Code Order By default the menus will display in alphabetical order.  

Monitor Network Displays network status of the device if required. 

Show Notes  This option will allow you to keep the specials on the device so staff have quick access.  

V7 Features  This will expand to another menu allowing you to make further options for use with Idealpos 

version 7 software only.  

 



 
 

V7 Features 

This screen allows you to turn on advanced Idealpos Version 7 features that will build the items in the app from the 

POS Screen Layout tabs. This option needs to be selected in both the app and Idealpos 7.  

 

V7 Features   This needs to be turned on if you want to link the app to Idealpos 7. 

Graphic File Type  Select from .jpg, .png, .gif or .bmp for the item images.  

Item Graphics   Select if you want to use images for the items.  

Show Image Only Top Menu This option will display images on the very top menu only if selected 

 



 
 

Order Screen 

This screen allows you to enter items to the table and perform multiple actions.  

 

Total Price  This is the current total of all ordered items. 

Menu List  This will display the menus to select the items.  

Order List  This is the area that will display the items that are entered.  

Table Number  This is the number of the table placing the order. 

Back   Return you to the previous screen. 

+ -   This allows you to add/subtract the quantity of items by multiples of 1. Swipe right on an item to 

access. 

TXT  This button allows you to add text to the item. Swipe left on an item to access. 

Delete  This allows you to delete the item from the table. Swipe left on an item to access. 

Insert  This will allow you to insert an item that might print out of order. 

Finalize  This will finalize the sale to the table. 

Seat Numbers  This will allocate the selected item to a seat number. 

 



 
 

Using Ideal Handheld v2 

To begin a sale, you can select a Clerk from the drop down menu or use the default clerk selected. 

 

  
 



 
 



 
 

Select a table from the grid layout or table map.  

 

 
 



 
 

Enter the number of guests seated at the table if required and press OK. Press Start Sale to enter items.  

 

 
 

Navigate through the menus to select the items to add to the table.  

 



   
 

 
 



 
 

Swipe right on an item in the sale window to change the quantity.   

 

 
 



 
 

Swipe left on an item in the viewing area and press Delete to remove it from the order. You can also add some text to 

the item, or insert a new item if you have print lines for order of meal service enacted.  

 

 
 



 
 

If there are a lot of items entered into the sale you can use the scroll bar to navigate through each item, or you can 

select ˅ to expand the order display. Press ^ to return the menus. 

 

 
 

You can see the details of what is on the table already by pressing the table number and then press Enquire.  

 



 
 

 
 

Press the Notes button to display any specials or instructions.  

 



 
 

 
 

When you have added all the items you want to add, simply press Finalize to send it to the printer. The table status will 

change to show you the process the table is currently on. These will change throughout the dining experience for all 

the other status colours that you 

 



  
 

 
 



 
 

You can select to print a bill from the app which will also be reflected on the table with live status display.  

 

 
 



 
 

Idealpos V7 Features – iPad and iPad Mini Only 

On larger screen devices you can lock the device and allow customers to enter their own meals. This is probably not a 

great idea in a fine dining restaurant with entrees and main as this can get complicated, but in a bistro environment, it 

can be extremely easy.  

 

Before locking the device, ensure that you have selected the table the guests are seated at and pressed Start Order. 

Press the lock button on the bottom left of the screen.  

 



 
 

Help tips will be displayed to show you and the customer how to order with the device. You can press the question 

mark in the bottom right corner to turn off the help tips.  

 



 
 

Enter the items into the device as per normal. You have the option to select different seats.  

 



 
 

When finished, press Finalize to send it to the kitchen and bar printers.  

 



 
 

Before you can have full access to the app again you will need to enter the password for the device. This does not lock 

the device, it will only lock the Ideal Handheld app.  

 



 
 

 


