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EFTPOS 

IP-4818 – Idealpos Payments module 

This function adds support for the Idealpos Payments module to Idealpos. 

 

Idealpos payments is currently available in Australia on pilot. 

If you are interested in joining our pilot program, please register here - 

https://webforms.pipedrive.com/f/ItmwAA1NNTGr7jObY4rH0Pydyp3UE3Ge6mV13AOU4QGgKP4CGJf1VL92xxRfJUT   

https://webforms.pipedrive.com/f/ItmwAA1NNTGr7jObY4rH0Pydyp3UE3Ge6mV13AOU4QGgKP4CGJf1VL92xxRfJUT
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Network Printers 

IP-4826 – Network Printers – Support for Idealpos BTP-S80 

This function adds support for the Idealpos BTP-S80 thermal printer. 

Refer to the printer drivers supplied with the printer for details on configuring the printer itself, interface/IP 

configuration, etc. 

This printer model has been added to the Network Printers configuration function. 

 

To configure the printer in Idealpos, go to: Back Office > Setup > Network Printers > Add. 

Type: idealpos BTP-S80 

Connection: Select the Connection Type being used (e.g. Ethernet, COM1, etc.) 

Baud Rate/IP Address: [Enter either the Baud Rate or IP Address – the type of input this field accepts will change 

depending on the Connection Type selected above] 

Port/POS System: [Enter either the Port Number or POS System – this field will also change depending on the 

Connection Type selected]. 

Configure any other settings as required 

 

When selecting a Connection Type of None or COM#, the Baud Rate and POS System fields will appear as shown in 

the example below – If using a COM port connection, configure the settings according to the COM Port Number/Baud 

Rate and POS Terminal Number that the Printer is connected to: 
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When selecting a Connection Type of Ethernet, the IP Address and Port fields will appear as shown in the example 

below – If using an Ethernet connection, configure the settings according to the Printer’s IP Address and Port Number: 
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Once the printer has been configured, drag and drop the printer into each POS Terminal that you want the printer to 

be used by: 

 

 
 

The printer is now ready for use. 
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IP-4827 – Network Printers – Support for Idealpos TP100 

This function adds support for the Idealpos TP100 thermal printer. 

Refer to the printer drivers supplied with the printer for details on configuring the printer itself, interface/IP 

configuration, etc. 

This printer model has been added to the Network Printers configuration function. 

 

To configure the printer in Idealpos, go to: Back Office > Setup > Network Printers > Add. 

Type: idealpos TP100 

Connection: Select the Connection Type being used (e.g. Ethernet, COM1, etc.) 

Baud Rate/IP Address: [Enter either the Baud Rate or IP Address – the type of input this field accepts will change 

depending on the Connection Type selected above] 

Port/POS System: [Enter either the Port Number or POS System – this field will also change depending on the 

Connection Type selected]. 

Configure any other settings as required 

 

When selecting a Connection Type of None or COM#, the Baud Rate and POS System fields will appear as shown in 

the example below – If using a COM port connection, configure the settings according to the COM Port Number/Baud 

Rate and POS Terminal Number that the Printer is connected to:  
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When selecting a Connection Type of Ethernet, the IP Address and Port fields will appear as shown in the example 

below – If using an Ethernet connection, configure the settings according to the Printer’s IP Address and Port Number: 
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Once the printer has been configured, drag and drop the printer into each POS Terminal that you want the printer to 

be used by: 

 

 
 

The printer is now ready for use.  
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Restaurant & Table Map 

IP-3965 – Table Details screen – Yes/No option to Group by Print Group 

This function adds the ability to group the Stock Items shown in the in the Table Details by Print Group (e.g. Entrée, 

Main, Drinks, etc.). 

Prior to this change, you could either Group by Order Time, or have no grouping. 

 

If the existing Yes/No Option “Table Details – Group by Order Time” was disabled for ALL POS Terminals prior to 

upgrading to this build, this new Yes/No Option “Table Details – Group by Print Group” will be enabled by default. 

 

In addition to setting the default grouping behaviour via the Yes/No Option, the Table Details screen now has a 

dedicated button to toggle the grouping method, so it can be toggled on-the-fly as you use the Table Details screen. 

Note that when the button on the Table Details screen is used to toggle the grouping, the Table Details screen will 

revert to the default grouping option the next time it is opened, as per the setting configured in the Yes/No Options. 

 

To configure this function, go to: Back Office > Setup > Yes/No Options 

In the Search field, enter “Group by”. 

You have the option to either Group by Order Time, or you can Group by Print Group. 

If you enable both options, the Group by Order Time will take priority. 

 

For the purpose of demonstrating this function, the Y/N Options have been configured as follows: 

Table Details – Group by Print Group - Enabled  

Table Details – Group by Order Time - Disabled 

 

 
 

Close the Yes/No Options window to save your changes. 
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Go to: POS Screen. 

Add items from one or more various Print Groups to the sale, then press the “Table Map” button to save the items to a 

Table. 
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Select a Table within the Table Map to transfer the Sale to: 

 

 
 

If prompted, enter the number of covers, then press “OK”. 
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Select the Table from the Table Map, then press the “Details” button on the bottom-left corner of the window. 
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The Items saved to the Table will be grouped by Print Group, as shown in the example below: 

When using any of the Grouping functions, you can click on the Group header (e.g. Entrée, Beverage or any other Print 

Group) and all the items from that Print Group will be selected. 
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The Grouping can be toggled by pressing the No Grouping/Group by Order Time/Group by Print Group button. 

The button label will vary, depending on the current Grouping method being used, as shown in the examples below. 

 

The first example below shows the Table Details screen grouped by Print Group.  

The toggle button shows “No Grouping”.  

Pressing this will toggle the Table Details screen to use no grouping as shown in the example on the following page. 
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The second example below shows the Table Details screen using No Grouping. 

The toggle button shows “Group by Order Time”. 

Pressing this will toggle the Table Details screen to use Order Time Grouping as shown in the example on the 

following page. 
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The third example below shows the Table Details screen using Group by Order Time. 

The toggle button shows “Group by Print Group”. 

Pressing this will toggle the Table Details screen to Group by Print Group. 

When the order is Grouped by Order Time, you can click on the ordered time and all items ordered at that time will be 

selected. 

 

  



 Update History 
Return to top 

Idealpos 8 Build 6 - Update History Page 17 of 50 

 

IP-4786 – Table Map 1920/1366 Resolutions – Ability to toggle Activity Feed 

This function adds the ability to toggle the Activity Feed shown on the Table Map (when using POS Screen Resolutions 

of either 1920x1080 or 1366x768). The new behaviour will default the Activity Feed to a hidden state, and if required, 

the Table Activity Feed can be displayed by pressing the “>>>” button at the bottom of the Activity Feed section. 

 

Provided that a POS Screen Resolution of either 1920x1080 or 1366x768, no other additional configuration is required. 

 

Go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify 

Within the POS Settings tab, ensure that the POS Screen Resolution is set to either 1920x1080 or 1366x768. 
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Open the POS Screen, then press the Table Map button. 

 

 
 

The Table Map will be displayed, with the Activity Feed hidden as shown below: 
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To display the events within the Activity Feed, press the “>>>” toggle button towards the bottom-right corner of the 

window. 

 

 
 

After pressing the “>>>” button, the Activity Feed is displayed as shown below. 

 

 
 

Once the Activity Feed has been toggled to be visible (unless the Activity Feed is toggled to be hidden via the “<<<” 

button before closing the Table Map), it will remain visible each time the Table Map is opened during that session. 

Once Idealpos or the POS Terminal is restarted, the Activity Feed will default to hidden.   
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IP-4845 – Table Details Delete Items – Recorded as Transaction 

This function will record any items that are deleted via the Restaurant - Table Details as a transaction. 

Any items deleted in this manner can then be reported on via the following methods: 

Journal History Enquiry – Using the Function dropdown box, “Table Item Delete” can be selected to filter the results 

and only show items that were deleted from a table. 

Alerts – An Alert can be created to write an event to the Alerts.Log file and/or Send an Email to an email address. 

Financial Report – Items that are deleted from a Table will be included in the Voids total shown on the Financial 

Report. 

 

To configure an Alert for this function, go to:  

Back Office > Setup > Alerts 

Press the “Add” button on the top-left corner of the window. 
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In the create new Alert window, configure as follows: 

 

Alert Description: Table Deletes 

If Function Type: Table Item Delete 

Quantity reaches in: Configure as required. This will trigger the alert to be written and/or emailed when the number 

of deletes reach the entered quantity within the entered number of minutes/days. 

Group by: Clerk or POS terminal. 

POS Range: Enter the POS Range that you want to Alert on. If this field is blank, Alerts for all POS Terminals will be 

reported. 

Clerk: Enter the Clerk Code if you want to alert for specific clerks. Leaving this field as blank will trigger the Alert for all 

Clerks. 

Email/Log Message: This is the message that will be emailed and/or written to the Alerts.Log file. You can also use the 

Message Formulas dropdown box/Add button to add formulas to the Email/Log Message field.  

An example Email/Log Message has been included below. 

 

There has been a Table Item Delete! 

{STOCKITEMQUANTITY} 

{SPENDAMOUNT} 

CLERK = {CLERKNAME} 

POS = {POSTERMINALDESCRIPTION} 

 

Write to Alerts.Log – Enabling this checkbox will write the Alert using the message configured above. 

Send Email to – Enabling this checkbox and entering an email address will trigger Idealpos to send an email to the 

entered email address. If the Send Email to function is used, ensure that the Email Settings have been configured in 

Back Office > Setup > Global Options > Other Options > Email Settings. 
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Press the “Save” button on the top-left corner of the window to save the Alert. 

A new Alert entry will appear in the Alerts window. 

 

 
 

Close the Alert window to continue. 
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So that Alerts are generated (and if required, emailed), you will need to perform additional configuration in the Global 

Options.  

Go to: Back Office > Setup > Global Options > Other Options.  

 

• Output from POS # - Enter the POS Terminal Number that you want to Output Alerts from. 

• Email Settings - Enter the Email Settings (optional – this is only required if you want to utilise the Email 

functionality within Alerts). 

 

 
 

Close the Global Options window to save your changes. 
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To use this function, go to: POS Screen. 

Press the Table Map button and within the Table Map, select a Table and press “Details”. 
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Within the Table Details screen, select the Items that you want to delete, then press the “Delete” button. 

 

 
 

Press “Yes” to confirm the deletion of the selected items. 
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Select a refund reason. 

 

 
 

The Table Details screen can now be closed. 
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Table Deletes can be reported on/viewed as follows: 

 

• Journal History Enquiry 

Go to: Back Office > Enquiry > Journal History 

In the Function dropdown box, select “Table Item Delete”. 

The Journal Enquiry will be filtered to only show Table Item Deletes. 

 

  
 

 

• Alerts.Log/Email (if Alerts were configured). 

When using Alerts with the Table Deletes function, note that once an Alert is triggered, the Alert counter is 

reset. Examples of two scenarios using Quantity reaches 5 in 1 minute are outlined as follows: 

 

Example 1 – Delete 11 items from a table, then delete another 4 items from another table all within the same 

minute. Only a single alert for the 11 items deleted from the first table will be triggered. 

 

Example 2 – Delete 4 items from a table, then delete another item from another table within the same minute. 

A single alert for a total of the 5 items that were deleted across both tables within the same minute will be 

triggered. 
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The Alerts.Log is located in the Idealpos Logs folder (C:\ProgramData\Idealpos Solutions\Idealpos\LOGS\). 

When an Alert is triggered, it will be emailed and/or written to the Alerts.Log, depending on the Alert 

configuration. 

The Alert will appear in the Alerts.Log/email body. 

 

Email Subject: ALERT: [Alert Description entered in the Alert Config] 

 

Email body and/or Alerts.Log: Will contain details of the Alert that was triggered similar to the below 

example (message may vary depending on the Email/Log Message configured in the Alert): 

 

20220428 11:58:59.139    There has been a Table Item Delete! 

3 

$10.00 

CLERK = Jeremy 

POS = POS 200 

 

• Financial Report 

Go to: Back Office > Reports > Financial > Financial Report. 

Run the Financial Report. 

The Table Deletes are included in the Voids total, as shown below. 
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Room Interface 

IP-4771 – NewBook API Integration 

This function adds the ability to connect Idealpos to NewBook via the API Integration. 

The previously available NewBook Integration was done via a File method, whereas this new method utilises the API 

Interface. The File method is still available and can continue to be used. 

Any sites that are currently utilising the NewBook File integration and want to upgrade to the API method will need to 

contact NewBook and request for their account to be upgraded to API. 

Once NewBook have upgraded the account to API, the integration can be configured utilising the steps outlined as 

follows. 

 

Before continuing with the below steps, ensure that the NewBook module has been enabled in the Licence Gateway 

on each POS Terminal that will utilise this integration. This can be confirmed by going to Back Office > Setup > Licence 

Gateway. 

Ensure that Newbook appears in the Options column for each POS Terminal that will use this integration: 
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The following Function Descriptors will need to be configured for NewBook: 

 

Received Account – Add Money – This is used for adding money to the NewBook Guest’s eWallet. 

Tender – Room Charge – This is used for charging sales to the NewBook Guest’s Room. 

Tender – Wallet – This is used for spending or redeeming value from the NewBook Guest’s eWallet. 

 

Go to: Back Office > Setup > Function Descriptors. 

 

Select an unused Received Account function (unused Received Account Functions will show as “RA #”, where # will 

show a number between 1 and 4), modify it and enter a Description “Add Money”.  

This Received Account will be used to add money to the eWallet for the NewBook Guest. 

Press “Save” to close the Function Descriptor. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 6 - Update History Page 31 of 50 

 

Select an unused Tender Function (similar to unused Received Account Functions, unused Tenders will have a 

description of “Tender #”, where # will show a number between 1 and 18 (e.g. TENDER 13)).  

Enter a Description of “ROOM CHARGE”. 

This Room Charge Tender will be used for charging against the Guest’s Room. 

When setting up the Tender, enable any checkboxes that you require (e.g. Show in Banking, Open Cash Drawer, etc.). 

Press “Save” to save the changes. 
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Select the next available unused Tender Function. 

Enter a Description of “WALLET”. 

This Tender will be used for redeeming value from the NewBook Guest’s eWallet. 

When setting up the Tender, enable any checkboxes that you require (e.g. Show in Banking, Open Cash Drawer, etc.). 

Press “Save” to save the changes. 
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Go to: Back Office > Setup > Yes/No Options > Tenders. 

Remove the Inhibit checkbox for the Room Charge and Wallet Tenders so that they will be accessible from the Tender 

screen. 
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One or more buttons need to be created for adding value to the eWallet. 

Go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select POS Screen Layout > Buttons. 

Select a blank button on the POS Screen and configure as follows: 

 

Function: Received on Account. 

Received on Account: ADD MONEY [select the Received Account function configured above]. 

Automatic Text: This is optional. If left as blank, you will need to enter the value to add to the Wallet before pressing 

the button. If you enter a value into the Automatic Text field, the entered value will be used when pressing the button. 

If desired, multiple Add Money buttons can be created, each with a different amount entered into the Automatic Text 

field. 

 

 
 

An example showing the Received on Account with a pre-configured amount of $10.00 in the Automatic Text Field: 
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Create a Customer Type if one doesn’t already exist which will be used for NewBook customers. 

Go to: Back Office > File > Customers > Customer Types. 

Press the “Add” button on the top-left corner of the window, create the Customer Type and enable any settings as 

required. 

Further details about creating Customer Types can be found in the Customer Types topic of the User Guide by clicking 

here. 

 

 
  

https://userguide.idealpos.com.au/#Customers/Customer%20Types.htm
https://userguide.idealpos.com.au/#Customers/Customer%20Types.htm
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Go to: Back Office > Setup > Global Options > Interfaces. 

Select the Rooms option and configure as follows: 

 

Interface Type: NewBook 

Version: API 

Interface ID: [Enter the Interface ID supplied by NewBook] 

Tender Type: ROOM CHARGE [select the Room Charge Tender that was configured during the Function Descriptor 

configuration step]. 

Customer Type: MEMBERS [or select the Customer Type that was configured during the Customer Type configuration 

step]. 

Add Money Function: ADD MONEY [or select the Received Account Function that was configured during the 

Function Descriptor configuration step – this Function is used for adding money to the eWallet]. 

Spend Money: WALLET [or select the Tender that was configured during the Function Descriptor configuration step – 

this is used for tendering or redeeming the money from the NewBook Guest’s eWallet] 

 

Wristband Membership Type: 1 

Unmatched GL Code: 6000 

Gratuity GL Code: 6000 

Post Paid Transactions: Enabled 

Default Client Account ID: -1 
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Once configured, press the “Test” button to establish and test the connection. 

A connection should be established successfully, and this is reflected in a response next to the Test button, as shown in 

the example below: 
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The NewBook API Integration supports the following functionality: 

Further in-depth details are available in the Using NewBook API topic in the User Guide. 

 

Room Charge using Room Number 

Add items to the sale, press ENTER to go to the Tender screen, then press the Room Charge button. 

Idealpos will display a Room Number prompt – enter the room number which the Guest is staying in, then select the 

Guest Name from the list and confirm the prompt. 

 

 
 

Confirm the prompt to save the charge to the Guest’s room. 

Note that when there are multiple guests in a room, regardless of which guest is selected, the charge will be posted to 

the Room Account and not to the Guest eWallet Account. 
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Add money to eWallet 

To add money to a NeBook Guest’s eWallet, first, swipe the Guest’s Wrist Strap. 

The Guest’s details will be displayed at the top of the POS Screen, along with the current eWallet balance. 

Press the “Add Money” button and you will see “ADD MONEY” within the sale window with the amount entered. 

 

 
 

Press the ENTER button to go to the Tender screen and tender the sale using a standard tender (e.g. Cash) to add 

value to the eWallet. 

 

 
 

Next time the guest’s wrist strap is swiped, the eWallet value (top of the sale window) will show the updated amount. 
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Spend money from eWallet 

To spend money from the NewBook Guest’s eWallet, swipe the NewBook Guest’s Wrist Strap, then add the required 

items to the sale. 

 

 
 

Press the ENTER button to go to the Tender Screen, then press the “Wallet” Tender button. 

 

 
 

The amount of the sale will be deducted from the NewBook Guest’s eWallet. 

 

If the Wallet Tender is used when a NewBook Guest has not been added to the sale, Idealpos will display a prompt and 

you will be returned to the sale screen to select another tender (or add the NewBook Guest to the sale): 

 

  
 

If the Guest’s eWallet has insufficient funds, Idealpos will display the following prompt and you will be returned to the 

sale screen to select another tender: 
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Room Charge using a Guest Wrist Strap  

To perform a Room Charge using a Guest Wrist Strap, swipe the NewBook Guest’s Wrist Strap, then add the required 

items to the sale. 

 

 
 

Press ENTER to go to the Tender screen, then press the Room Charge Tender button. 

 

 
 

The sale will be finalised and the sale amount will be charged against the NewBook Guest’s room. 

As the Guest’s Wrist Strap was scanned, the “Enter Room Number” prompt will not appear. 

If the Guest’s Wrist Strap was not scanned, the “Enter Room Number” prompt will appear and the clerk will need to 

enter the Guest’s Room Number, then select their name from the list. 
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Stock Items  

IP-4758 – Show Variant Options on Stock Search screen when linking existing items 

This function will show the Variant Options at the top of the Stock Search screen when linking a Variant to an existing 

Stock Item. This change improves the linking process by reducing any confusion regarding which Variant Item you are 

linking to. In addition, this change also improves the linking process by pre-filling the Description Search field with that 

of the Parent Stock Item. Typically, the child item you are linking to will contain the Parent Item’s description.  

E.g. The Parent Item will contain a description such as “Sport Shirt”, with the Child Items containing descriptions such 

as “Sport Shirt Blue Small”, “Sport Shirt Red Medium”, etc. Therefore, it makes sense that the Link Variant screen 

should pre-fill the description search field with that of the Parent Item to simplify the linking process. 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

Modify a Parent Stock Item (an item that has the “Has Variants” option enabled/checked) 

Within the Variants tab, enable any Variant Options that aren’t ticked. 

This will enable the “New Variants of [Item] section. 

Within the Stock Code field, press the “+” button. 
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The Variant Option that is being linked will be displayed at the top of the Link Variant window (in this example, the 

New Variant being linked is Shirt (Size=Small, Colour=Blue, Material=Cotton). 

The Parent Item Description will also be pre-filled in the Search field so that the list of available items are filtered, 

simplifying the process of finding the required item. 
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Select the Stock Item that you want to link from the list, then press “OK”. 

 

 
 

The Stock Item Code will appear in the Stock Code field. 

 

 
 

You can also hover over the Stock Code field to display the Description of the Stock Item you are linking to. 
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To link to the existing Item, press the “Create New Variants” button on the bottom-right corner of the window. 

 

 
 

Press “Yes” to proceed. 

 

 
 

A prompt showing the number of Variants Created will be displayed. Press “OK” to continue. 
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The Item will appear in the Existing Variants of [Item] list. 

 

 
 

When modifying the linked item directly, it will show the Parent Item Code/Description. 
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Stock Purchases 

IP-4034 – Stock Purchases – Support for Stock Item Long Descriptions 

This function adds the ability to display a Stock Item’s Long Description (Description 3) on the Stock Purchase/Order 

screens as well as the corresponding Reports. 

By default, this function is disabled; if it is required, it will need to be enabled. 

 

To enable and use this function, go to: Back Office > Setup > Yes/No Options. 

In the Search field, enter “Long Description”. 

Enable “Stock Item Long Descriptions in Stock Purchases”. 
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Close the Yes/No Options, then go to: Back Office > File > Stock Control > Stock Items. 

Ensure that the Stock Items you are ordering in a Purchase Order contain a Long Description (ensure that Description 

3 is populated with a long description similar to the below example). 

 

 
 

If any changes were made, press “Save” to close the Stock Item and repeat the process as necessary. 
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Go to: Back Office > Transactions > Stock Control > Stock Purchases 

 

Select the Supplier as required, then add the Stock Item to the Purchase Order. 

The Stock Item’s Long Description (Description 3) will be displayed in the Description column. 
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If the Yes/No Option “Stock Item Long Descriptions in Stock Purchases” is disabled, the shorter Stock Item Description 

will be shown in Stock Purchases: 

 

 


