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Customers  

IP-6863 – Customer Types – Support for Customer Points Limit 

This function introduces the ability to set a Customer Points Limit by Customer Type. 

Prior to this change, the Customer Points Limit had to be set for each individual Customer. 

As it is now possible to set a Points Limit for a Customer Type and/or a Customer, the Points Limit that’s set against 

the Customer takes priority over the Points Limit that’s set for the Customer Type. 

The following are a few bullet points that outline examples and behaviour of the Points Limit functionality: 

• If the Points Limit is set to 60 for the Customer record and the Points Limit is set to 120 for the Customer Type 

that the Customer is linked to, then the Customer will be subject to the Points Limit of 60 that has been set 

against their Customer record. 

• When a Points Limit is set and the Customer reaches their limit, they will not accrue any additional points, and 

their points balance will remain the same. 

• If a Points Limit is set with a value that’s lower than the Points Balance that the Customer has already accrued, 

they will retain their existing points balance, but they will also be unable to accrue any additional points. 

 

 

To configure and use this function, go to: 

Back Office > File > Customers > Customer Types > Select a Customer Type > Modify. 

Within the Points Limit field, enter the required Points Limit to be applied to the Customer Type.  

Press “Save” to save the change. 
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When a Customer that’s linked to the Customer Type reaches the limit, they will no longer accrue additional points 

and their balance will remain at the points limit. 

This can be confirmed by going to:  

Back Office > Enquiry > Customers > Select a Customer that has reached their limit > Press the “Journal” button. 

The Customer’s Journal History is displayed and will display each transaction along with the Points they accrued for the 

transaction and their Total Accumulated Points. 

In the example below, the Customer started with a 0 Points Balance and 3x identical sales with a total $60.00 sale 

amount were completed. 

The Customer accrued 60 points for each of the first two sales, bringing them to a total of 120 points. 

On the third sale, they didn’t accrue any points, as they had reached the 120 Points Limit set in their Customer Type 

when the second sale was performed. 
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EFTPOS 

IP-6793 – Oolio Pay AU/NZ (Verifone) Eftpos Interface (Certification pending) 

This function introduces the ability to configure Idealpos with the Oolio Pay AU/NZ (Verifone) Eftpos Interface. 

 

Contact Idealpos or your Idealpos Reseller for further information. 

 

To configure this interface, go to: 

The Oolio Pay AUS/NZ module must be enabled in the Licence Gateway for each POS Terminal that will utilise this 

interface. 

Contact Idealpos or your Idealpos Reseller for further information. 

Once the interface has been enabled for each POS Terminal, go to: Back Office > Setup > Licence Gateway > Reload. 

The Oolio Pay AUS/NZ module should appear for each POS Terminal that will be used with the interface. 
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Go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > EFTPOS Settings. 

Disable: Uncheck 

EFTPOS Type: Oolio Pay AUS/NZ Verifone. 

Host IP Address: Enter the IP Address of the Verifone Pinpad 

 

Connect: Press the Connect button after the EFTPOS Type and Host IP Address have been configured. 

CONNECTED should appear next to the Connect button to indicate that a successful connection has been established 

between Idealpos and the Verifone Pinpad. 
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Go to: Back Office > Setup > Function Descriptors > EFTPOS > Modify. 

Ensure that the EFTPOS checkbox is enabled on the EFTPOS Tender > Press “Save” to save changes. 
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Ensure that the EFTPOS Tender is not Inhibited on the POS Screen. 

Go to: Back Office > Setup > Yes/No Options > Tenders. 

Ensure that “Inhibit EFTPOS” is not ticked as per the example shown below. 

If Inhibit EFTPOS is ticked, untick it. 
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If Cash Out on Debit Cards is required, enable the Yes/No Option “Enable Cash Out – EFTPOS” and ensure that “Inhibit 

Cash Out Question” is disabled. 

 

 
 

A Print Settlement Button can also be created to print a settlement. 

Go to: Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 

Select a POS Screen tab to create the button > select an unused/blank button and configure it as follows > Press Save: 

 

 
 

A Close Suite/Open Suite may be required to save all the changes. 

Go to: Start > Idealpos > IPSUtils > Close. 

The EFTPOS Interface is now ready for use > Press the EFTPOS button on the Tender screen and follow the prompts on 

the pinpad.  
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LMG Integration 

IP-6754 – LMG Zen Loyalty Interface 

This function introduces the ability to configure Idealpos with the LMG Zen Loyalty Interface. 

LMG Zen Loyalty is a loyalty program offered by the Liquor Marketing Group. 

When the LMG Zen Loyalty Interface is enabled and configured, it will enable customers to be added to a sale and 

redeem any vouchers that they’re eligible for, along with any other benefits that are applicable to the loyalty program. 

 

For more information about LMG Zen Loyalty and what it can do for you, refer to the Liquor Marketing Group website 

(https://www.lmg.com.au) or contact LMG (https://www.lmg.com.au/contact/). 

 

Configuring the LMG Zen Loyalty Interface will require the LMG Advanced module to be enabled in your Idealpos 

Licence Gateway for each POS Terminal (contact Idealpos or your Idealpos Reseller for further information) and will 

also require credentials that will be supplied by LMG. 

 

To configure this interface, go to: 

Back Office > Setup > Licence Gateway > Reload the Licence Gateway (perform this step after Idealpos or your 

Idealpos Reseller have enabled the LMG Advanced module for your site). 

 

 
  

https://www.lmg.com.au/
https://www.lmg.com.au/contact/
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This interface can perform member lookups by entering the Mobile Phone Number of the Customer or scanning the 
Customer’s QR Code. 
The QR Code should be scannable at any time on the POS Screen to add the member, however, it may be useful to 
have a Member Lookup button which can be pressed; this will enable the Member’s Phone Number to be entered 
into a lookup screen, enabling the member to be added to the sale quickly and easily. 
 
To configure the Member Lookup button, go to:  
Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 
Select the desired POS Screen tab where the Member Lookup button should be located > Locate a blank/unused 
button and configure it as follows: 
 

• Function: Member Number 

• Button Caption: Member Number (or enter a desired caption that reflects the Loyalty Program Name). 
 

 
 
Once the button has been saved, close the POS Screen Layout window. 
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Go to: Back Office > Setup > Global Options > Interfaces > LMG. 

Configure the following using the credentials supplied by LMG: 

• LMG Site Number 

• Site Serial 

• API Key 

• API Secret 

 

• Default Customer Type – Specify the default Customer Type that will be used for LMG Zen Loyalty. 

• Loyalty Card Prefix – 920 (this prefix may vary depending on your Loyalty Program; enter the Loyalty Card 

Prefix as required for your setup/environment). 

• Upload Scan Data – Enable the option to upload Scan Data to LMG. 

 

 
 

After the above steps have been completed, a Close Suite/Open Suite must be performed on each POS Terminal so 

that the settings are applied. 

This requirement is also indicated via a prompt that will appear after the Global Options window is closed: 
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After a Close Suite/Open Suite has been performed on all POS Terminals, the interface is ready for use. 

 

From the POS Screen, press the Member Number button that was created earlier. 

A Get Member window will appear; within this window, the Member’s Mobile Number can be entered. 

Press OK to complete the Get Member lookup. 

 

Alternatively, the Member’s Card Number can be scanned into the sale. 

 

 
 

A Loyalty Member window will appear and will display a list of the available Vouchers that can be redeemed. 

Select a voucher from the list, then press “Redeem Selected Voucher” to redeem it. 
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After the voucher has been redeemed, the Stock Item that corresponds to the voucher will need to be scanned into 

the sale and the voucher/discount will be applied to the item. 

 

This process can also be done in the reverse order (i.e. scan items into the sale, then perform the member lookup > 

select a voucher > Redeem Selected Voucher > Voucher is applied to the item(s)). 

 

 
 

Note that when the member lookup is performed, and a list of available vouchers are displayed; data is also retrieved 

from LMG that contains a list of Stock Item Scan Codes that each voucher is applicable to. 

Therefore, the Scan Codes for the Stock Items in your Idealpos database must match the Scan Codes for the vouchers 

in the data that is retrieved from LMG for the items to be discounted via their respective voucher. 

Refer to LMG for further information about the Vouchers and the Stock Items/Scan Codes that they’re applicable to. 

 

If the data is required to aid in the configuration of Scan Codes, it can be retrieved from the following folder path: 

C:\ProgramData\Idealpos Solutions\Idealpos\LOGS\IdealposLMG.log 

 

Note that the data is only written to the log file after a member lookup is performed and the data written to the log 

will contain a list of vouchers that are applicable to the member. 
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Promotions 

IP-6755 – Recalculate Promos Function (Pay@Table Module) 

This function introduces the ability to manually recalculate promotions via a Recalculate Promos POS Screen function. 

This function can be utilised when the Pay@Table Module is enabled, and scenarios arise where the Promotions need 

to be recalculated. In these scenarios, the “Recalculate Promos” POS Screen function can be used and will trigger the 

Idealpos POS Screen to recalculate any Promotions that are applicable for the sale. 

 

An example scenario where this function can be utilised is outlined as follows: 

 

• Pay@Table Interface is enabled in Back Office > Setup > Global Options > Pay@Table. 

• A Promotion exists that is only triggered when a Customer from a specific Customer Type is added to the sale 

and the specific items in the Promo are sold. 

• The Items specified in the Promo are saved to a table without adding the Customer to the sale. 

• When selecting the Table from the Table Map and pressing “Pay All”, the items are shown on the Tender 

Screen. 

• The Clerk then adds a Customer to the sale that is linked to the Customer Type that is specified in the 

Promotion. 

• The Promotion is not triggered – in this case, the “Recalculate Promos” button can be pressed which will 

trigger the Promotions to be recalculated and applied to the sale. 

 

Take note of the following prior to configuring and utilising this functionality: 

The Recalculate Promos button will use the current date and time when the button is pressed, not the date/time when the 

items were added. This will affect promotions that are time-based. 

E.g. A Happy Hour Promotion is active when items are saved to at table. 

Happy Hour ends and the items are still saved to the table in an unpaid state. 

When paying the Table and pressing the “Recalculate Promos” button, the items will have Promotions applied that are 

valid at the date/time when the Recalculate Promos button is pressed. 

Therefore, the Happy Hour Promotion will not apply to the items in this instance. 

 

To configure this function, go to:  

Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 

Select a POS Screen Tab in which the button will be created > Locate a blank/unused button and configure as follows, 

ensuring to press the “Save” button when completed: 
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When the Promotions need to be recalculated in a scenario like the one outlined on the previous page, press the 

“Recalculate Promos” button. 

 

Example showing the POS Screen after pressing the “Pay All” button on a Table and then adding a Customer to the 

sale (no Promotion triggered yet): 

 

 
 

After pressing the Recalculate Promos button, the Discount from the Promo is applied (bottom-left).  

When proceeding to the Tender Screen, the full Promotion details are displayed (bottom-right). 

 

  
 

Note – The Recalculate Promos button can only be used in cases where it is applicable to the sale.  

When not applicable and the button is used, a prompt “This function is not available at this time” will be displayed.   
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IP-6842 – Promotions – Trigger by spending “On Anything” option 

This function introduces the ability to configure Promotions to trigger by spending On/Of Anything in the Trip 

Condition Set 1. 

This is achieved via a new option called “On/Of Anything” that appears above Trip Condition Set 1 which can be 

chosen when creating or modifying a Promotion. 

When using the On/Of Anything option, a dollar value can be specified (when using Trip by Amount) or quantity 

(when using Trip by Quantity) can be specified.  

The Promotion will be triggered when the specified quantity or dollar value has been spent on Anything.  

 

To configure and use this function, go to: Back Office > File > Sales > Promotions > Promotions > Add/Modify. 

 

Within Trip Condition Set 1, set the Trip Conditions Set to “of Anything” if using Trip by Quantity, or “on Anything” if 

using Trip by Amount and enter a of/on Anything value that will need to be purchased to trigger the Promotion. 

 

Select a Discount Type and value that will be applied when the Promotion is tripped. 

The Discount Type for the Promotion in the example below has been set to a “% Discount off Items” at 10%. 
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Close the Add New Promotion window and press “Yes” when prompted to Save Changes. 

 

 
 

Go to: POS Screen 

Add Stock Items to the sale to trigger the Promotion. 

In the example below, 7 Stock Items have been added to the sale as per the Promotion which has been set with “Buy 7 

of Anything” which will trigger the Promotion to apply – the Discount Type of % Discount off Items” has been applied 

with a discount value of 10%. 
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Room Interface 

IP-6808 – Room Interface – Support for serial port RFID scanning 

This function introduces the ability to use a serial port RFID scanner to scan RFID cards with a Room Interface. 

The serial port RFID scanner will need to be configured in the POS Terminal settings (Back Office > Setup > POS 

Terminals > Select a POS Terminal > Modify > Customer Readers tab > RFID Reader > Configure the Type/Connection 

and Settings as required). 

 

The example screenshot below shows the area where this is configured, however, does not show the settings that are 

required as these will differ based on the COM Port that the scanner is connected to along with the type of RFID 

Scanner being used. 

 

 
 

When the RFID scanner is configured accordingly, the RFID scanner can be used for scanning RFID cards with any 

Room Interface in Idealpos that supports RFID cards.  
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Stocktake 

IP-6830 – Stocktake Variance Report – Added “Last Cost” option to Cost/Selling Price dropdown 

This function introduces the ability to run the Stocktake Variance Report with the “Last Cost” option in the Cost/Selling 

Price dropdown box. 

When the “Last Cost” option is selected, the Stock Items shown in the Stocktake Variance Report will be displayed with 

their Last Cost and the Last Cost value. 

 

To use this function, go to: Back Office > Stocktake > Stocktake Variance Report. 

In the Cost/Selling Price for Valuation dropdown box, select “Last Cost”. 

Press the “View” button to run the Stocktake Variance Report. 

 

 
 

  



    Update History 
Return to top 

Idealpos 9 Build 6 - Update History Page 20 of 21 

 

The Stocktake Variance Report will be displayed, and the Last Cost will be displayed, as selected in the Cost/Selling 

Price for Valuation dropdown box. 
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Yes/No Options 

IP-6835 – Force Receipt after a Paid Out 

This function introduces the ability to Force a Receipt to be printed after a Paid Out Transaction. 

When this Yes/No Option is disabled, a Paid Out receipt will only be printed if the Receipt is turned on via the Receipt 

On/Off function. 

When this Yes/No Option is enabled, a Paid Out receipt will be forced, regardless of whether or not the Receipt is 

turned on. 

 

To configure this function, go to:  

Back Office > Setup > Yes/No Options > Search: “force receipt” > Enable “Force Receipt after a Paid Out”. 

 

 
 

When performing a Paid Out transaction, the receipt will be forced to print when this Yes/No Option “Force Receipt 

after a Paid Out” is enabled. 

 

Go to:  

POS Screen > Turn off Receipt via Receipt On/Off button (as this Yes/No Option will Force a Receipt when Receipt Off). 

POS Screen > Enter an amount > Press “Paid Out” button > Press ENTER to go to Tender Screen > Press a Tender. 

The Paid Out is tendered to the selected Tender and a receipt is forced: 

 

 
 

Additional information about the Receipt On/Off function is available in the User Guide by clicking here.  

Additional information about Paid Out is available in the User Guide by clicking here. 

https://userguide.idealpos.com.au/Default.htm#Receipt%20On%20Off/Receipt%20On%20Off.htm
https://userguide.idealpos.com.au/Default.htm#Received%20Account%20and%20Paid%20Out/Received%20Account%20Paid%20Out.htm

