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Customers 

IP-6481 – Customer Grid Screen – Rebuilt for improved performance on large databases 

The Customer Grid Screen (Back Office > File > Customers > Customers) has been rebuilt for improved performance 

on large databases. 

With this change, the Top N Records function (which was originally added to improve performance) no longer appears 

on the Customers Grid Screen. 
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It should also be noted that the performance of the Customers Grid screen is affected by the number of fields that are 

shown on the Customer Grid. 

E.g. Some venue databases contain numerous fields that are minimised, but in these cases, Idealpos still has to retrieve 

the data even though it isn’t shown. 

 

 
 

To achieve the best performance, hide any fields that are not required on the Customer Grid screen. 

 

Fields can be hidden by going to: Back Office > Setup > Users > Select a User > Modify > File Fields > Customers. 

Toggle the fields so that only the required fields are enabled and disable/hide any fields not required. 

Also note that the User-Defined fields for each Customer take an additional performance hit on large databases, so if 

these User-Defined fields are not required to appear in the Customer Grid, then they can be hidden via the File Fields. 
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Ideal Kitchen Monitor 

IP-6492 – Delayed Pending Sale Printing – Support for Ideal Kitchen Monitor 

This function adds support for delaying the printing of Pending Sales to the Ideal Kitchen Monitor. 

Previously, Pending Sales that used a delayed time to print to kitchen would only apply to Kitchen Printers; the print 

job would still print immediately to the Ideal Kitchen Monitor. 

 

It is now possible to configure Idealpos so that the Delayed Pending Sale Printing applies to print jobs sent to Ideal 

Kitchen Monitor.  

 

To configure this function, go to:  

Back Office > Setup > POS Terminals > Select POS Terminal > Modify > POS Settings > User-Defined Options. 

Create a new User-Defined Option as follows: 

Description: PENDINGSALESBATCHPRINTING 

Setting: 1 
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In addition to the User-Defined Option, the Kitchen Print minutes before Expected Time must also be enabled (if not 

configured already). 

Go to: Back Office > Setup > Global Options > Sales > Pending Sales. 

Kitchen Print minutes before Expected Time: Enable checkbox and enter the default number of minutes. 
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Close the Global Options window, then go to: POS Screen. 

Add Items to the sale > Press “Pending”. 
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Enter the Customer’s Details. 

The Date and Time that appear below the Customer’s Details are the expected time. 

Adjust the expected time as required. 

The “Send to Kitchen” section will pre-populate the minutes before expected time as per the setting configured in 

Global Options. 

This can be adjusted as required or leave it as the default minutes before expected time. 
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The items in the order will be printed to the Ideal Kitchen Monitor and any other Kitchen Printers using the number of 

minutes entered before the Expected Time. 

 

 
 

 
 

For further information about Ideal Kitchen Monitor, refer to the Ideal Kitchen Monitor topic in the User Guide. 

For further information about configuring Idealpos to send orders to Ideal Kitchen Monitor, refer to the Configure 

Idealpos to send orders to IKM page in the Idealpos User Guide. 

  

https://userguide.idealpos.com.au/#Ideal%20Kitchen%20Monitor/Ideal%20Kitchen%20Monitor.htm
https://userguide.idealpos.com.au/#Ideal%20Kitchen%20Monitor/Configure%20Idealpos%20to%20send%20to%20IKM.htm
https://userguide.idealpos.com.au/#Ideal%20Kitchen%20Monitor/Configure%20Idealpos%20to%20send%20to%20IKM.htm
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LMG Integration 

IP-6485 – LMG Integration – Transaction Export API 

This function introduces the ability to configure Idealpos to export transactions to the LMG – Transaction Export API. 

To configure this function, complete the following steps: 

 

In order to configure the LMG - Transaction Export API, the LMG Basic module will need to be enabled in the Idealpos 

License Gateway. 

Contact Idealpos or your Idealpos Reseller to purchase this module. 

Once the module has been purchased, go to: Back Office > Setup > Licence Gateway. 

Press the "Reload" button in the Licence Gateway and the "LMG Basic" module will be displayed. 

If the LMG Basic Module does not appear after pressing the "Reload" button, contact Idealpos or your Idealpos 

Reseller. 

 

 
 

After the Licence Gateway has been reloaded, perform a Close Suite/Open Suite. 

Go to: Start > Idealpos > IPSUtils > Close. 
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Go to: Back Office > Setup > Global Options > Interfaces > LMG. 

Enter the credentials supplied by LMG: 

• LMG Site Number 

• Site Serial 

• API Key 

• API Secret 

• Upload Scan Data: Enable 

 

 
 

After the credentials have been entered, close the Global Options. 

The following prompt will be displayed - press "OK" and perform a Close Suite/Open Suite on all POS Terminals. 

Alternatively, all POS Terminals can be physically restarted to apply the change. 

  

 
  

Once done, the Transaction Export API configuration has been completed. 

Transactions will be exported to LMG as they take place on each POS Terminal. 

The IdealposLMG log file stored in C:\ProgramData\Idealpos Solutions\LOGS\IdealposLMG.log can be referenced to 

confirm that the interface is successfully exporting data. 

Should there be any issues communicating with LMG, the events will be recorded in the IdealposLMG.log file.  
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POS Screen  

IP-6452 – Dynamic POS Screen Grids functionality 

This function introduces the ability to create Dynamic POS Screen Grids which when accessed on the POS Screen, will 

be dynamically and automatically populated with Stock Items using the Departments and Stock Item Attributes that 

have been configured. When there are too many Stock Item buttons to fit on one screen, the Dynamic Grid will simply 

display previous and next buttons to cycle through multiple pages. 

 

To configure and use this function, go to: Back Office > Setup > POS Screen > Grids > Add. 

The Add New POS Screen Grid window will open and by default, the new “Dynamic Grid” checkbox will be unchecked. 
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Enable the “Dynamic Grid” checkbox. 

After the checkbox has been enabled, additional options will be displayed which will be used to customise the 

Dynamic POS Screen Grid (e.g. select from which Department(s) and Stock Item Attributes to only display Stock Items 

from the chosen Department(s) and Attributes, as well as any button customisation settings and Grid Link).  

 

The options that are displayed are outlined as follows: 

Department: Enter or select the Department Code(s) in this field. The Department Codes can be entered as a comma 

separated list (e.g. 1, 2, 3) or as a range (e.g. 1-3), or a combination of both (e.g. 1, 2, 3, 5 – 10). 

 

Attributes: Enter or select the Attributes in this field. Stock Items must be linked to the same Attributes selected in this 

field for the items to appear in the Dynamic Grid. 

Note – Leaving the Department and Attributes fields as blank will result in all Stock Items appearing in the Dynamic 

Grid.  

 

Double Height Buttons: Toggle this checkbox for each Stock Item button in the Dynamic Grid to be a double height 

button. 

 

Button Appearance: All Stock Item buttons within the Dynamic Grid will be displayed using the configured 

appearance. 

 

Grid Link: This option will control which POS Screen Grid is displayed after a Stock Item is added to the sale from the 

Dynamic Grid.  

E.g. If this option is left as blank, the default value will be set to the current Dynamic POS Screen grid (after the grid is 

saved), which means that after an item is added to the sale from the Dynamic Grid, the Dynamic Grid will remain on-

screen.  

If this option is set to MAIN, the MAIN POS Screen Grid will be displayed after an item is added to the sale. 
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The below example shows a Dynamic Grid setup for the Department “Soft Drink” and Attributes “1.25L Bottle”. 
 

 
 
Once the required Dynamic Grid options have been selected, press the “Save” button on the top-left corner to save 
the Dynamic Grid, then close the POS Screen Grids window. 
 

 
 
Create a button on the POS Screen to link to the Dynamic Grid by going to:  
Back Office > Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons > Select a POS Screen Tab 
> Select a blank POS Screen button > Select “POS Screen Grid” and link to the newly created Dynamic POS Screen 
Grid. 
Customise the button appearance/button caption as required > Save button > close POS Screen Layout: 
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Go to: POS Screen. 
Navigate to the POS Screen tab where the Dynamic Grid POS Screen button was created > Press the button. 
The Dynamic Grid is displayed: 
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When there are too many items to fit within the Dynamic POS Screen Grid, “<<<” and “>>>” buttons will be displayed 
which can be used to navigate between the previous and next screens, as shown in the example below: 
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POS Terminal Settings – Import/Export 

IP-6467 – Stock Item Sales Export for Pivot Table Functionality 

This function introduces the ability to configure POS Terminals with an Automatic Export - Export Sales Format of 

“Pivot Table”. The exported data can then be used in a Pivot Table within an Excel Spreadsheet.  

 

To configure and use this function, go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Import/Export 

 

Each field that requires configuration is outlined on the next page. 

 

 
 

  



    Update History 
Return to top 

Idealpos 9 Build 3 - Update History Page 17 of 35 

 

Export Folder: Select a folder location where you want the data exported to. If required, a new folder may need to be 

created prior to configuring this function, then select the newly created folder here. Note that when creating the 

PivotTable in Excel, the file created in this folder location will be used to establish a data source connection. 

 

Export Sales Format: Pivot Table 

 

Pivot Table File Name: Enter the File Name for the Pivot Table export. E.g. IdealposSalesPivotTable.csv. 

 

Reset: Options available are Never, Daily, Weekly, Monthly, Yearly. This option will control if/when the exported data is 

reset (i.e. The Pivot Table File Name will be renamed after the Reset is done as per the setting configured here).  

 

Never – The sales data will keep being appended to the file indefinitely and will never be purged. If the file needs to 

be reset, this can be done manually by re-naming or moving the file to a different location; a new file will be created 

when data is exported. 

 

Daily – The export file will be reset Daily. The file will be reset at the End of Day Time which is configured in Back 

Office > Setup > Global Options > General > End of Day. When the file is ‘reset’, the file for the day will be renamed, 

and a new file for the new day will be created using the Pivot Table File Name. 

 

Weekly – The export file will be reset Weekly. The file will be reset when the First Day of Week commences, which is 

configured in Back Office > Setup > Global Options > General > First Day of Week. 

 

Monthly – The export file will be reset Monthly.  

 

Yearly – The export file will be reset Yearly. 

 

Every X minutes – This is the interval for the number of minutes that the sales data will be exported. When choosing 

the number of minutes, take into consideration the demand for the required sales data as well as how often a sale is 

performed at the POS Terminal. If a POS Terminal is always in use performing sales and the sales data needs to be 

reflected in the Pivot Table shortly after the sales have been performed, enter a lower number. 

If a POS Terminal isn’t constantly in use and the exported sales data is not in high demand, then a larger minute 

interval can be entered.  

 

Once the settings have been configured as required, close the POS Terminals window. 

Once the sales data starts exporting to the folder location, an export file will exist which can be linked to an Excel 

Spreadsheet and a Pivot Table created. 

The steps for adding a Pivot Table to an Excel Spreadsheet from an external data source vary slightly between versions 

of Excel. A basic overview on how to do this is outlined on the next page. 
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Create a new Excel Spreadsheet. 

Within Excel, press the Insert tab > PivotTable (down arrow to show additional options) > From External Data Source. 

 

 
 

Enable “Add this data to the Data Model” > “Choose Connection”. 
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Browse for More… 

 

 
 

A Folder Browser window will open. 

Browse to the Export Folder location configured in Idealpos earlier (e.g. using the example in the steps above, C:\temp) 

> Once the file has been selected, press “Open”. 
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The Text Import Wizard will appear. 

Step 1 of 3: 

 

Ensure that the following options have been selected: 

Original Data Type: Delimited 

Start import at row: 1 

File origin: Windows (ANSI) 

My data has headers: Enable checkbox 

 

Press “Next” to continue to the next step of the Text Import Wizard. 
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Step 2 of 3: 

 

Untick the “Tab” Delimiter checkbox and enable the “Comma” checkbox. 

Press “Next” to continue to the next step of the wizard. 
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Step 3 of 3: 

 

Leave the Column data format as General and press “Finish”. 

 

 
 

Press the “OK” button on the PivotTable from an external source window. 
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Even though the Data Source connection to the PivotTable data has now been created, a few more steps are required 

to configure the Refresh Control for the connection. 

In Excel, press the “Data” tab and select “Queries & Connections”. 

 

 
 

On the right-hand side of the Excel window, a “Queries & Connections” section will be displayed. 

Ensure that “Connections” is selected, then right-click on the “PivotTable” and choose “Properties”. 
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Set the options as follows > “OK”: 
 

  



    Update History 
Return to top 

Idealpos 9 Build 3 - Update History Page 25 of 35 

 

The fields for the PivotTable will need to be selected from the fields on the right-hand side of the Excel window. 

Any fields that are required can be selected. 
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For the purposes of demonstrating this function, the below is an example set of fields that have been selected. 

Description, Quantity, DiscountedPrice, Site, Location, CustomerCode, Clerk, Department. 

 

After the required fields are checked/enabled, the Excel window will appear like the below example: 

 

 
 

Before dragging the suggested fields to the Filters section | After dragging suggested fields to the Filters section: 
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After the fields have been dragged into the Filters field, the Pivot Table will appear like the example below. 

The table can be filtered as required via the dropdown boxes at the top of the table. 
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If the PivotTable Fields option is closed and further adjustments to the PivotTable Fields are required, the PivotTable 

Fields can be displayed again by clicking on the “PivotTable Analyze” tab in Excel, then selecting the Field List. 

 

 
 

This will display the PivotTable Fields so they can be adjusted as required. 
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Reports 

IP-6466 – Stock Totals by Week Report 

This change introduces a new Report to the Idealpos Back Office Reporting menu (Stock Totals by Week Report). 

This new report can be accessed via Back Office > Reports > Stock Control > Stock Totals by Week. 

This report will display the following details: 

• Opening Stock Level of each Stock Item at the start of the period. 

• Each Stock Item’s Purchases and Sales for each week, shown as figures specific for each Week. 

• Other Movement – Any other types of Stock Movements that don’t fall into the Purchase or Sale type. 

• Closing Stock – The closing Stock Level of each Stock Item at the end of the period. 

 

The options that are available in this report are as follows: 

Date Range: 4 Weeks to Today, Last 4 Full Weeks, 4 Weeks Last Month, Custom Date. When using a Custom Date, 

note that the Custom Range is restricted to a month. E.g. Entering 1st January 2024 will auto-populate the To field with 

28th January 2024. Modifying the To Date will also auto-adjust the From Date to be 4 weeks prior to the date entered. 

Sort Order: Code or Description. 

Group by: Department, Supplier, Location, Stock Item, Site. 

Options: Decimal Places on Quantities: 0, 1, 2, 3, 4. 

Selection Range: Leaving the Selection Range fields below as blank will run the report for all Stock Items. 

Stock Item From/To: Enter Stock Item Codes in the From/To to include Stock Items between the entered range. 

Supplier From/To: Enter a Supplier From/To Code to restrict the report to items linked to the entered Supplier Range. 

Department: Enter one or more Department Code(s). Departments can be entered as a comma separated list (e.g. 

1,2,3), range (e.g. 1-3), or a combination of both (e.g. 1-3, 5,6,7). 

Location: Enter Location Code(s) to restrict the report to the entered Location(s). 

Site: Enter the Site Code(s) to restrict the report to the entered Site Code(s). 
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When running the report, it will appear as follows, showing the details that were outlined on the previous page: 
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Stock Purchases 

IP-6501 – Stock Purchases – Options to turn off for improved performance 

This function introduces the ability to disable Auto-Refresh and Unit Cost Colours. 

When the Auto-Refresh and Unit Cost Colour options are enabled, they can slow down the Stock Purchases screen 

when viewing large Stock Purchases on some slower POS terminal hardware. 

When the Auto-Refresh and/or Unit Cost Colours options are toggled, their state (enabled or disabled) will be saved, 

so that the next time a Purchase Order is created or modified, the state of the checkboxes will remain the same as they 

were the last time the Purchase Order screen was used. 

 

Go to: Back Office > Transactions > Stock Control > Stock Purchases > Create or Modify a Stock Purchase. 

On the bottom-left corner of the window, the following checkboxes are now available which can be used to toggle this 

functionality: 

• Auto-Refresh 

• Unit Cost Colours 
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When the Unit Cost Colours option is disabled, the colour shown in the Unit Cost Column will be toggled on/off. 

Note that the Unit Cost Colours option will hide or show colours after the Stock Items have been ‘refreshed’ on the 

screen. The items are refreshed when they are scrolled off the screen, then back onto the screen, or when closing and 

re-opening the Stock Purchases screen. 

 

Unit Cost column with Unit Cost Colours enabled | Unit Cost column with Unit Cost Colours disabled: 

  
 

The Auto-Refresh checkbox controls the refreshing of the Stock Item details that are shown on the bottom-left corner 

of the Stock Purchases window. 

When Auto-Refresh is disabled, the Stock Item details on the bottom-left corner of the Stock Purchases window need 

to be refreshed manually by pressing the “Refresh” button. 

The first time a Stock Item is selected in the Stock Purchase, there will be no prior item details shown. 

 

 
 

Press “Refresh” to show the currently selected item. 

 

  
 

When selecting another Stock Item in the Purchase Order, its details will not appear until the “Refresh” button is 

pressed.  
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VDMS Vending Integration 

IP-6446 – VDMS Vending Integration 

This function introduces the ability to integrate Idealpos with VDMS Vending (Vend Data Media Solutions). 

VDMS is a company that provides solutions for securing and dispending Tobacco products. 

When a Tobacco Stock Item is sold via the Idealpos POS Screen, the VDMS Vending Dispenser will dispense the 

Tobacco product after the customer’s payment has been processed. 

If you are interested in utilising this module at your venue, contact Idealpos or your Idealpos Reseller for further 

details. 

 

VDMS Vending offer various types of dispensing units, and their dispensers offer many advantages: 

 

• Control access to high value products at Point of Purchase (POP). 

• Touch Screen selection of items through Idealpos POS Screen. 

• Deter theft and robberies and protect your employees. 

• Legally compliant with state and territory legislations. 

• Eliminate staff and customer shrinkage. 

 

As this interface involves numerous steps that are too vast for the Update History document, refer to the new VDMS 

Vending topic in the Idealpos User Guide for more information about setting up this integration. 

 

More information about VDMS and their solutions is available on the VDMS website by going to: https://vdms.com.au/  

https://userguide.idealpos.com.au/Default.htm#VDMS%20Vending/VDMS%20Vending%20Integration.htm
https://userguide.idealpos.com.au/Default.htm#VDMS%20Vending/VDMS%20Vending%20Integration.htm
https://vdms.com.au/
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Yes/No Options 

IP-6534 – Yes/No Option – Special Points ignore Customer Type Multiplication Factor 

This function introduces the ability to configure Idealpos to ignore the Customer Type Multiplication Factor for Special 

Points. This can be used in scenarios where a venue wants to exclude Special Points from being multiplied by the 

Multiplication Factor set against the Customer Type. 

 

To configure this function, go to: Back Office > Setup > Yes/No Options > Enter Search: Special Points. 

Toggle the Yes/No Option “Special Points ignore Customer Type Multiplication Factor” as required. 

 

 
 

The Customer Type Multiplication Factor is configured in Back Office > File > Customers > Customer Types > Select a 

Customer Type > Modify > Point Multiplication Factor. 
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The Special Points are configured against each Stock Item. 

Go to:  

Back Office > File > Stock Control > Stock Items > Select a Stock Item > Modify > Advanced > Use Special Points. 

When the checkbox is enabled and a value is entered, the Customer will accrue the number of points entered in the 

Special Points field, depending on the Point Multiplication Factor set against the Customer Type and the state of the 

Yes/No Option.  

If the Yes/No Option “Special Points ignore Customer Type Multiplication Factor” is enabled (checked), the Customer 

will earn the number of Special Points without a multiplication factor. 

If the Yes/No Option “Special Points ignore Customer Type Multiplication Factor” is disabled (unchecked), the 

Customer will earn the number of Special Points, multiplied by the Point Multiplication Factor defined against their 

Customer Type that they are linked to. 

 

 
 

 


