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Customers 

IP-7340 – User-Defined Option to change Customer Company Label 

This functionality introduces the ability to change the default label of “Company” to any desired text.  

The “Company” label appears on the Fast Customer Search screen on the POS. 
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To change the “Company” label, go to: 

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > POS Settings. 

Within the User-Defined Options section on the bottom-left corner, create a new User-Defined Option as follows: 

• Description: COMPANYLABEL 

• Setting: Enter a new label here. 

 

E.g. The below example will trigger the Company Label to show as “Business Name” as shown in the below User-

Defined Option/Fast Customer Search Screen example. 

 

 
 

POS Screen – Fast Customer Search screen: 
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Fuel Console 

IP-7297 – Enabler Fuel Interface – Ability to Pause/Resume during Fuel Delivery 

This function introduces the ability to Pause and Resume a pump during Fuel Delivery. 

This functionality can be utilised to pause a pump and temporarily stop fuel from pumping. 

Fuel will resume pumping when the clerk presses the pump number and selects the “Resume Delivery” option. 

This functionality can be used when a customer commits an offence while pumping fuel (e.g. if they use a mobile 

phone or smoke while pumping fuel), the clerk can Pause the pump and make an announcement using the forecourt 

PA system advising the customer to cease offending. 

When the customer stops using their mobile phone or stops smoking, the clerk can press the “Resume Delivery” 

option which will enable the customer to resume pumping fuel. 

 

To use this function, press a pump number while the pump is dispensing fuel. 

The Pause Delivery option will be displayed – press “Pause Delivery” to pause the pump. 

 

 
 

After pressing Pause Delivery, the pump colour will change to red to indicate that it is currently paused. 

 

 
 

To resume the pump, press the pump number and select the “Resume Delivery” option. 

 

 
 

The pump will resume, and the dollar value will increment until the customer stops filling. 
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IP-7298 – Enabler Fuel Interface – Sound support for Customer Calling and Delivery Finished 

This function introduces the ability to play a sound for customer calling and delivery finished for the Enabler Fuel 

Interface. 

Two sound files are included in v9 Build 10 and higher and these will be played when the following events occur: 

• FuelCalling.wav – When the customer lifts a nozzle, the POS Terminal will play the FuelCalling.wav file. The 

sound will trigger the clerk’s attention so that they can authorise the pump. 

• FuelFinished.wav – When the customer finishes filling, the FuelFinished.wav file will be played. 

 

If required, these sound files can be replaced with different sound files.  

When using custom sound files, ensure that the replacement files use the same filenames as the original files. 

 

The sound files are stored in the following location: 

C:\ProgramData\Idealpos Solutions\Idealpos\  
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IP-7300 – Enabler Fuel Interface – Display Grade Codes on Pumps 

This functionality adds support to display Grade Codes on Pumps. 

Other than setting the Grade Code in the ITL Enabler, there is no additional configuration required in Idealpos to 

enable this functionality. 

The Grade Code that corresponds to the grade of fuel being pumped will be displayed next to the amount shown in 

the slots at the top of the POS Screen. 

 

The Grade Code is configured in the ITL Enabler Web Interface by opening a web browser and going to: 

http://[enterIPAddress] > Enter Username/Password.  

If the IP address of the ITL Enabler is 192.168.1.1, then enter http://192.168.1.1  

 

Once logged in, go to: Configuration > Grades.  

 

 
 

Press “Edit” next to a grade. 

 

 
  

http://[enteripaddress/
http://192.168.1.1/
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The Grade Code that appears in the Code field will be displayed in the slots at the top of the POS Screen when the 

grade of fuel is being pumped. 
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IP-7339 – Enabler Fuel Interface – Ability to Authorise from Back Office Terminal 

This function introduces the ability to authorise fuel sales from a Back Office Terminal. 

However, payment of Fuel will need to be performed from a POS Terminal. 

No additional configuration is required for this functionality. 

To use this functionality, from the Back Office, select the fuel nozzle icon in the Windows taskbar. 

 

 
 

The fuel pumps will appear at the top of the screen. 

Select the desired pump number and press “Authorise” to authorise the pump. 

 

 
 

The pump is authorised. 

 

 
 

The same process can be completed to authorise the pump when the nozzle is lifted. 

When the nozzle is lifted, a symbol of a raised hand will be displayed, which can then be pressed to authorise the fuel 

sale. 
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Global Options 

IP-7244 – Idealpos Email – Support for Sending Email Address 

This function introduces the ability to set a Sending Email Address when using the Idealpos Email Service. 

The Sending Email Address will be included as the Sending Email Address in emails that are sent from Idealpos. E.g. 

When a recipient of an email sent from Idealpos selects the “Reply” option, the “To” field will be pre-populated with 

the Sending Email Address populated here. Also note that if this field is blank, the Email Address configured in Back 

Office > Setup > POS Terminals > Modify > Main Settings > User Settings > Email will be used as the Sending Email 

Address. If the Sending Email Address in Global Options > Other Options and the Email address in Setup > POS 

Terminals > Main Settings are both blank, then the Sending Email Address used will be no-reply@idealpos.co. 

 

To configure this function, go to: Back Office > Setup > Global Options > Other Options > Email Settings. 

 

Enter the required email address in the “Sending Email Address” field as shown below.  

Close the Global Options window to save the change. 

 

 
 

  

mailto:no-reply@idealpos.co
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Emails that are received from Idealpos will contain the Sending Email Address in the email. 

To demonstrate this functionality, go to: Back Office > Enquiry > Journal History > Select a Journal > Email. 

 

 
 

Enter an Email address into the “To” field, then press the “Send” button to send the Journal. 
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An EMAILED line will be added to the Journal in the Journal History Enquiry showing the date and time which the 

Journal was emailed. 

 

 
 

When the Email containing the Journal is received, it will show the no-reply@idealpos.co as the From email address as 

shown below: 

 

 
 

When pressing the “Reply” button in the email client, the Sending Email Address will be pre-populated in the To field. 

 

 
 

  

mailto:no-reply@idealpos.co
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Depending on the Email Client or Email Service that is used, the Sending Email Address can be viewed via a variety of 

methods. 

Refer to the documentation/help for the Email Client being used for more information. 

As an example for Classic Outlook, the Sending Email Address appears in the “Have replies sent to” field which can be 

viewed by double-clicking on an email > File > Properties. 
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Home Screen 

IP-7163 – Home Screen Image – Support for PNG File Format 

This functionality introduces the ability to use a Home Screen Image which has been saved as a PNG File Format.  

 

To use a Home Screen that has been saved as a PNG File Format, place the image in the Pictures folder (e.g. 

C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\). 

The image must exist in this path on each POS Terminal. 

If required, the image can be placed into the above path on the Back Office Terminal, then utilise the “Send Pictures” 

folder from the Back Office > Utilities > Send > Pictures Folder which will enable the images to be sent/updated at all 

the POS Terminals. 

 

Go to: Back Office > Setup > Global Options > Other Options > Home Screen Graphic. 

Enter the name of the PNG Image Home Screen Graphic in the “Home Screen Graphic” field. 

 

 
 

Close the Global Options window to save the change. 

A Close/Open Suite may be required for the change to take effect. 
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The PNG Format Home Screen Image will be displayed when the Home Screen is opened. 

 

 
 

The Home Screen Image Slideshow also supports PNG Images. 
Images can be placed into the following location and will be displayed when the Home Screen Slideshow starts as per 
the Slideshow Start Time (in seconds) field configured in Global Options > Other Options: 
C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\HomeScreen  
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As part of adding PNG image support for the Home Screen Image on a standard POS Screen, the Kiosk now supports 

PNG Images for the following image types (which are configured via Back Office > Setup > POS Terminals > Modify > 

Display/Kiosk):  

• Home Screen Image 

• Order Finalised Image 

• Kiosk Closed Image 

• Home Screen Images Location 
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IPS Utility 

IP-7240 – IPSUtil Backups password-protected 

All backups from Idealpos v9 Build 10 and newer are password protected. 
Password Details: 

• Unique to each Idealpos License. 
• Not user-configurable and cannot be disabled. 

 
When Password is Required: 

• Only needed when restoring a backup to a system with a different license to the one that originally created 
the backup. 

• Not required if restoring to a system with the same license. 
 
Support Code Access for Idealpos/Idealpos Resellers: 

• Idealpos and Resellers can retrieve the Support Code via the Idealpos Portal: 
• Navigate to: https://portal.idealpos.com.au > Enter Username & Password > Customers > 

Search/Select the Customer > Customer Support > Support Code. 
 
Backups from v9 Build 10 cannot be restored to older builds of Idealpos v9: 

• Due to older builds of Idealpos v9 not supporting password protected backups, attempting to restore a 
backup produced by v9 Build 10 or newer onto a system running a build older than v9 Build 10 will produce 
an error. 

 
When switching between backups from different customers, there are two options: 
 
Option 1 – Perform a Full System Reset then restore the database by double-clicking on it.  
A shortcut can be created to IPSUtil.exe with an argument of /mode=masterreset to perform the Master Reset, 
double-click the shortcut, then restore the database by double-clicking on it. 
E.g. IPSUtil.exe /mode=masterreset 
Use caution with this option and only configure on a test environment.  
 
Option 2 – Use Support Code when switching between backups. 
In some cases, two Support Codes may be required when switching between backups from different customers: 
If restoring Backup B (Customer B) on a system currently running Backup A (Customer A): 

1. First Admin Password Prompt: Enter the Admin password for Customer A 
(or enter the Support Code for the current license used on the system). 

2. Second Prompt: Enter the Support Code for Customer B into the Password field. 
 
  

https://portal.idealpos.com.au/
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A demonstration of using this functionality is as follows: 
Double-click on an Idealpos Database Backup (*.ips file extension). 
If an Admin User Password has been set, the Admin Password prompt will appear. 
Enter the Admin Password for the current database (or enter the Support Code for the current license used on the 
system). 
 

 
 
After entering the correct Admin Password, the IPS Utility will appear. 
A new Password field will be displayed next to the path of the backup. 
The Password will only need to be entered if restoring the database backup onto an Idealpos system with a different 
license to the one that originally created the backup. 
If required, retrieve the Support Code from the Idealpos Portal (https://portal.idealpos.com.au) > Enter Username 
and Password > Customers > Search > Select Customer > Customer Support > Support Code. 
Enter the Support Code into the Password field > Press “Restore”. 
 

 
  

https://portal.idealpos.com.au/
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Press “Yes” to confirm the restore of the backup. 
 

 
 
A prompt is shown to confirm the successful restore of the backup. 
 

 
 
If an incorrect password is entered, the following prompt will be displayed and after closing the prompt, the IPS 
Utility will close.  
 

 
 
To reattempt the restore of the database after an incorrect password is entered, double-click on the *.ips file. 
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Kiosk 

IP-7304 – Kiosk – Option for Coupon Promotion Button 

This function introduces the ability to enable a Coupon Promotion button on the Kiosk. 

The Coupon button will appear on the CHECK OUT screen. 

When the Coupon Promotion button is pressed, an on-screen keyboard will be displayed which the customer can use 

to enter their Coupon Promotion Code into the Kiosk, enabling the Coupon to apply to the sale. 

 

To configure this functionality, go to:  

Back Office > Setup > POS Terminals > Select a Kiosk Terminal > Modify > Display/Kiosk. 

Enable the “Coupon Button” checkbox then close the POS Terminals window to save the change. 

Enabling this option should not require a restart of the Kiosk Terminal. 
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At the Kiosk Terminal, start a new sale > add items to the sale > Press the “CHECK OUT” button at the bottom of the 

screen. 

 

 
 

The new Coupon button will be displayed at the bottom of the Kiosk screen. 

When the customer has a coupon that they want to redeem, they will press the Coupon button. 

 

 
 

The Kiosk will display an on-screen keyboard that the customer will use to enter the coupon code. 

 

 
 

The Coupon will be applied to the sale and the customer can press the Pay by Card button to process their payment 

and finalise the sale. 

 

 

 

  



    Update History 
Return to top 

Idealpos 9 Build 10 - Update History Page 21 of 44 

 

Metcash Interface 

IP-7251 – Metcash Interface – Support for Competitor Pricing Date Updated 

This function introduces the display of the date which the Competitor Pricing was updated. 

The current date that a Metcash Host containing competitor pricing data is imported is shown as the date next to the 

Competitor Pricing details (in the Modify Stock Item > Other tab). 

When a host is processed that updates the Competitor Pricing info for a Stock Item, the date will be updated to the 

current date that the host is processed. 

Prior to this change, the Competitor Pricing information didn’t show the date that the competitor pricing was 

populated. 

 

To use this functionality, go to: 

Back Office > File > Stock Control > Stock Items > Search for a Stock Item > Modify > Other tab. 

The Competitor Pricing Updated Date will be shown next to the Competitor Price. 
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Pending Sales 

IP-7331 – Pending Sale A4 Print – Support for Company Graphic 

This functionality adds support for the Company Graphic to appear on an A4 Print of a Pending Sale. 

Prior to this change, the top-right corner of a Pending Sale A4 printout would only show the text “Table” (or the text 

that has been configured for the Pending Sale function in Setup > Function Descriptors > Pending Sale). 

This functionality will now include the company logo on the top-right corner of the Pending Sale A4 printout. 

 

If a Company Logo isn’t already configured, it can be configured by going to:  

Back Office > Setup > Global Options > General > Company Logo Graphic (pictures folder). 

 

Place the image in the Pictures folder (located in C:\ProgramData\Idealpos Solutions\Idealpos\Pictures). 

Then in the Company Logo Graphic field shown below, press the “>” button, browse to the folder location shown 

above and select the company logo graphic. 

 

 
 

Close the Global Options window to save the change. 
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Go to: POS Screen. 

Press the PENDING/Pending Sale button > Select a Pending Sale > Press “Windows Print” on the bottom-left corner of 

the window. 

 

 
 

The Pending Sale will be printed, and the company logo will appear on the top-right corner of the A4 Pending Sale 

printout. 
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POS Screen Functions  

IP-7069 – Coupon Promotion option to use On-Screen Keyboard 

This function adds the ability to use an on-screen keyboard with the Coupon Promotion POS Screen function. 

The on-screen keyboard that is displayed can be used to input the Coupon Code. 

 

To configure and use this function, go to: Back Office > Setup > POS Screen > POS Screen Setup > Buttons. 

If a button linked to the Coupon Promotion function already exists, modify the button. 

If a button linking to the Coupon Promotion function does not exist, select a blank/unused button and link to the 

Coupon Promotion function. 

To trigger the on-screen keyboard to appear, enter [KEYBOARD] into the Automatic Text field as shown below: 

Press “Save” to save the button. 

 

 
 

Close the POS Screen Layouts window. 
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Go to: POS Screen. 

Add the required items to the sale. 

Click on the Coupon Promotion button > On-Screen Keyboard is displayed. 

Enter the Coupon Code via the On-Screen Keyboard and press Enter. 
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The Coupon for the entered Coupon Code is applied to the sale. 
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IP-7252 – POS Screen Function – Close/Open Suite 

This function introduces a new POS Screen Function “Close/Open Suite”. 

When a POS Screen Button that’s linked to this function is pressed, the POS Screen will display a confirmation prompt 

“Are you sure you wish to Close/Open Suite?”. 

Pressing “Yes” will trigger a full Close Suite/Open Suite from the POS Screen. 

 

To configure and use this function, go to: Back Office > Setup > POS Screen > POS Screen Setup > Select a POS 

Screen Layout > Buttons. 

As this is a function that may need to be restricted to specific Clerks/Users, it is recommended that it be placed on a 

POS Screen tab that is only accessible by specific Clerks (e.g. Admin tab). 

Select a POS Screen tab > locate a blank/unused button > select the button and configure as follows.  

Function: Close/Open Suite 

Button Appearance: Customise as required. 

Press “Save” to save the button. 

 

 
 

Access to the Admin tab can be disabled for specific Users. 

Note that Clerks are linked to Users, so when access to a POS Screen tab is disabled for a specific User, all the Clerks 

that are linked to that User will be denied from accessing the POS Screen tab. 
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To ensure that the POS Screen tab is disabled for unauthorised Clerks, go to:  

Back Office > Setup > Users > Select a User > Modify. 

Expand: Clerk Permissions > POS > Layers.  

To disable the Clerk’s access to a specific POS Screen tab, untick the checkbox next to the tab, then press “Save” on the 

top-left corner of the Users window. 
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When a Clerk that does not have access to the Admin tab attempts to press the Admin tab on the POS Screen, a 

prompt is displayed which restricts them from accessing the tab. 

 

 
 

When a Clerk that has permission to open the Admin tab presses the “Admin” POS Screen tab, they will have access to 

the tab along with access to the Close/Open Suite button. 

 

 
 

Pressing the “Close/Open Suite” button will trigger the following confirmation prompt: 
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Pressing “Yes” will trigger a full Close Suite/Open Suite. 

After the Close Suite is triggered, Idealpos will automatically start again. 

 

 
 

The POS Screen will reappear after the Open Suite completes. 
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IP-7336 – Web Page Function – Custom URL has Open Windows Keyboard option 

This function introduces the ability to display the Windows Keyboard when using the Web Page Function with Custom 

URL. This is achieved by enabling a new checkbox called “Open Windows Keyboard” when configuring the POS Screen 

Button for the Web Page Function. Displaying the Windows Keyboard will enable character entry into any fields 

displayed on the Web Page that is opened via the Web Page Function. 

 

To configure this function, go to: Back Office > Setup > POS Screen > POS Screen Setup > Buttons. 

Press a POS Screen to create the button in, then locate a blank/unused button and configure as follows: 

• Function: Web Page 

• Web Page Type: Custom 

• Open Windows Keyboard: Enable checkbox to open the Windows Keyboard when this Web Page button is 

pressed. 

• URL: Enter the desired URL to open (e.g. https://www.idealpos.com.au) 

• Button Caption: Enter a Caption for the button. 

 

  
 

Press “Save” once the button configuration has been completed. 

 

  

https://www.idealpos.com.au/


    Update History 
Return to top 

Idealpos 9 Build 10 - Update History Page 32 of 44 

 

Go to: POS Screen. 

Press the newly configured Web Page button on the POS Screen. 

The Web Page will open in a new window, and the Windows Keyboard will also be opened at the same time. 

The Windows Keyboard can be used to enter characters into any fields of the page (search fields, web forms, etc.). 

The Windows Keyboard can be re-positioned on the screen by pressing and holding on the On-Screen Keyboard title-

bar and dragging it to the desired position. 
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Stock Items 

IP-7230 – Stock Items Grid – Allow for Headers to wrap to second line 

This function allows for headers at the top of the Stock Items Grid screen to wrap to a second line. 

This can be useful when using longer Sell Price Descriptors but using a shorter column width. 

Prior to this change, all headers were only displayed on one line. 

 

The areas in Idealpos that control the display of the Selling Price Descriptors are summarised below: 

• Selling Price Descriptor Labels – Back Office > Setup > Global Options > Sales > Selling Price Descriptors – 

The Descriptions for each Price Level can be customised here. 

• File Fields – To control which Sell Prices appear in the Stock Items Grid, go to: Back Office > Setup > Users > 

Modify > File Fields > Stock Items > Toggle Price 1 to Price 12 as required. Any Price Levels that have a 

checkbox enabled will appear in the Stock Items Grid for the selected User. Note that an Idealpos Close 

Suite/Open Suite will be required for changes to take effect. 

 

To customise the Stock Items Grid, go to: Back Office > File > Stock Control > Stock Items. 

Press the configuration cog icon on the bottom-left corner of the window. 

Resize the column widths as required by hovering over the edge line of a column and click/drag. 

When the width of a column is reduced, the text will wrap to a second line, as shown on the Price Level 1 below (which 

has the Selling Price Descriptor set to “STANDARD SELL PRICE”) 
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Close the customise Stock Items Grid to finalise any customisations done to the column widths. 

When opening the Stock Items Grid (e.g. File > Stock Control > Stock Items), the resized column widths will be used, 

and any columns that were reduced with longer text values will be wrapped to a second line, as shown for the Sell 

Price 1 Price Level which has a descriptor of “STANDARD SELL PRICE”: 
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Stock Purchases 

IP-7236 – Stock Purchases – Add New Supplier Stock Codes when linking inside Purchase 

This functionality will add new Supplier Stock Codes when they have been linked inside a Stock Purchase. 

When an invoice is imported that contains a Supplier Code that is not linked to a Stock Item, the Description in the 

Stock Purchase shows as “Deleted Stock Items”. 

When the Stock Code dropdown box is pressed and the Supplier Stock Code is linked to the correct Idealpos Stock 

Item, the Supplier Stock Code will be saved so that when another invoice is imported with the same Stock Item, the 

Stock Item will be correctly identified and displayed in the Stock Purchase. 

 

To use this functionality, go to: 

Back Office > Transactions > Stock Control > Stock Purchases > Import. 
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In the Import Invoices window:  

Supplier: Select the Supplier by pressing the “>” button in the Supplier field. 

Location: Select the Location for the Invoice. 

Select Import File: Press to browse to the import file. 

 

 
 

After selecting the invoice file, the “Select Import File” button will show the name of the Invoice. 

The Invoice Number, TotalLines and Total will be displayed below. 

 

 
 

The Stock Purchases window will appear and the newly imported Invoice appears. 

Ensure that the Invoice/Purchase Order is selected, then press “Modify”. 
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The Stock Code field will show “***Invalid” for the Supplier Codes that do not exist. 

For Stock Codes that show “***Invalid”, press the dropdown box. 
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The Stock Items grid will be displayed. 

Search for and select the Stock Item that matches the Invalid Stock Code, then press “OK”. 

 

 
 

A prompt “Would you like to save this Supplier Stock Code” will appear. 

Press “Yes” to create a new Supplier Stock Code for the item. 
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The Stock Code will show the Stock Item that the item has been linked to. 
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Repeat the above process for each Invalid Stock Code. 

When complete, each Stock Code should be linked to a Stock Item in Idealpos > Press “Save” to save the Stock 

Purchase/Stock Received. 
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The Supplier Stock Codes have been created for each of the Stock Items that were linked in the Stock Purchase/Stock 

Received. 

This can be confirmed by going to: Back Office > File > Suppliers > Supplier Stock Codes. 

Select the Supplier from the Supplier dropdown box; the newly created Supplier Stock Codes will be displayed. 

 

 
 

The next time a Supplier Invoice is imported with the same items, the items will be linked correctly. 
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Yes/No Options 

IP-7341 – Yes/No Option – Discontinue Customers after Full Account Payment 

This function introduces the ability to configure Idealpos to Discontinue Customers after a Full Account Payment.  

A Customer will be marked as discontinued if their owing balance reaches $0.00 after their payment is made.  

If there is still an outstanding balance owing after their Account Payment is made, the customer will remain active and 

won’t be discontinued. 

 

To configure this functionality, go to: Back Office > Setup > Yes/No Options > Search: discontinue. 

Enable the option “Discontinue Customers after Full Account Payment”. 

 

 
 

After the option is enabled, close the Yes/No Options. 

It is recommended that a Close Suite/Open Suite is performed to ensure that the setting takes effect. 

Go to: Start > Idealpos > IPSUtils > Close. 
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Go to: POS Screen. 

Add an Account Customer to the sale by pressing the Customer button > Select Customer. 

Press the “>>>” button at the top of the POS Screen to display the Customer’s details on the bottom-right corner of 

the POS Screen. 

Press “Payment” 

 

 
 

Press “Pay All”. 
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The outstanding amount is populated into the tender screen. 

Select a tender to finalise the sale. 

 

 
 

The customer has now been marked as discontinued. 

To confirm, go to: Back Office > File > Customers > Customers. 

Press the “Discontinued” button on the bottom-left corner > the Customer will appear in the Discontinued list. 

 

 
 


