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Function Descriptors 
IP-3779 – Override Receipt Footer on Tender – by POS Number 

This function adds the ability to control which POS Terminal(s) will override the standard receipt footer (configured 
in Setup > POS Terminals > Modify > Receipt Printer > Footer) using the text that has been entered into the 
Override Receipt Footer field in the Tender Type Function Descriptor (configured in Setup > Function Descriptors > 
Modify > Override Receipt Footer), when tendering a sale using the Tender Type containing the overridden receipt 
footer. 
 
This function is configured by entering the required text into the Override Receipt Footer field, then entering 
[OVERRIDERECEIPTFOOTERPOS=#] into the User-Defined Text field, where # is substituted with the POS Terminal 
number. You have the option of entering a single POS Terminal number, multiple POS Terminal numbers as a 
comma separated list, a POS Terminal number range, or a combination of all three. 
 
Examples: 
[OVERRIDERECEIPTFOOTERPOS=1] – This will override the receipt footer on POS terminal 1 only. 
[OVERRIDERECEIPTFOOTERPOS=1,2,3,4,5] – This will override the receipt footer on POS terminals 1, 2, 3, 4 and 5. 
[OVERRIDERECEIPTFOOTERPOS=1-5] – This will override the receipt footer on all POS terminals between 1 to 5. 
[OVERRIDERECEIPTFOOTERPOS=1-2,4,5] – This will override the receipt footer on POS terminals between 1 to 2 
and POS terminals 4 and 5. 
  
To configure and use this function, go to: 
Back Office > Setup > Function Descriptors > Select Tender Type from the list of Function Descriptors > Modify. 
In the Override Receipt Footer field, enter the text that you want to appear at the bottom of the Customer Receipt 
when the sale is tendered with this Tender Type. 
In the User-Defined Text, enter the POS Terminals that you want to print the text from the Override Receipt Footer 
field. The POS terminals need to be entered using the format shown in the examples listed above. 
For this example, we’ll use [OVERRIDERECEIPTFOOTERPOS=1] to have the setting apply only on POS 1. 
Any POS terminals that aren’t included in the OVERRIDERECEIPTFOOTERPOS will use the standard receipt footer.  
Once configured, press the “Save” button on the bottom-right corner of the Function Descriptors window. 
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When a sale is tendered using EFTPOS at POS 1, the Receipt Footer from the Override Receipt Footer field in the 
Function Descriptor is printed at the bottom of the receipt (example shown on the left). 
When a sale is tendered using EFTPOS at POS 2, the standard footer configured in Setup > POS Terminals > Modify 
> Receipt Printer > Footer will be printed at the bottom of the receipt (example shown on the right). 
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Gaming Interfaces 
IP-3796 – Aristocrat Gaming – Support for Source ID field 

This function adds the ability to set a value for the Source ID which may be required when communicating with 
Aristocrat (when awarding or redeeming points and performing other actions). 
Note that this function may or may not be required depending on your environment. 
We recommend configuring this option if you encounter problems when attempting to award or redeem points 
with your Aristocrat system. 
Therefore, it is recommended that you test the overall functionality of your Aristocrat system (including awarding 
points and redeeming points). If you find issues with your system, we recommend that you try setting the Source ID 
field with the required setting provided by Aristocrat. Should you find that your system is already working correctly, 
please do not modify your system as configuring this option may affect your system. 
 
To set this option, go to: Setup > Global Options > Gaming > Interface Type: Aristocrat 
In the Source ID field, enter the Source ID as supplied by Aristocrat. 
In our experience with a gaming system, POSCON needed to be entered, however, this may vary in your gaming 
environment. Please refer to Aristocrat for further details. 
After modifying this setting, you may need to restart Idealpos on your POS Terminals. 
This can be done via IPSUtils > Close (go to: Start > Idealpos > IPSUtils). 
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Global Options 
IP-3751 – Entire Order to Triggered Kitchen Printers – Filter by Sales Category 

This function adds the ability to have an entire order print to all Kitchen Printers based on Sales Category. 
When enabling this functionality, you can choose to:  
Have all items printing to all triggered Kitchen Printers (the functionality prior to build 14 was hard-coded as “All 
Items”) 
Or, you can have items that are from a specific sales category printing to triggered Kitchen Printers (functionality 
available from build 14 and onwards). 
 
Examples that show how this function behaves are listed as follows: 
 
Listing of Kitchen Printers: 
Printer 1 – Mains 
Printer 2 – Pizza 
Printer 3 – Pasta 
Printer 4 – Bar 
 
Stock Items and their Printer Configuration: 
Steak and Veg [Food Sales Category] – Configured to print to Mains Printer 
Hawaiian Pizza [Food Sales Category] – Configured to print to Pizza Printer 
Pasta [Food Sales Category] – Configured to print to Pasta Printer 
Beer [Beverage Sales Category] – Configured to print to Bar Printer 
 
Enable “Print Entire Order to triggered Kitchen Printers” setting in Global Options for “All Items”. 
 
Example 1 – An order containing Steak and Veg is sent to the Kitchen.  
Result – The Steak and Veg item will only be printed to the Mains Printer. 
 
Example 2 – An order containing Steak and Veg and Pizza is sent to the Kitchen. 
Result – The Steak and Veg and Pizza items are printed to the Mains Printer and Pizza Printer. 
 
Example 3 – An order containing Steak and Veg, Pizza, Pasta and Beer is sent to the Kitchen. 
Result – The Steak and Veg, Pizza, Pasta and Beer items will be printed to all Kitchen Printers (Mains Printer, Pizza 
Printer, Pasta Printer and Bar Printer). 
 
In example 3 above, items from the Food Sales Category are printed to the Bar Printer. 
If you don’t want items from the Food Sales Category to print to the Bar Printer, the Sales Category dropdown box 
can be set to the “Food” Sales Category. The ability to select the sales category has been added to build 14 and 
onwards. 
Enable “Print Entire Order to triggered Kitchen Printers” setting in Global Options and set the Sales Category as 
“Food”. 
 
Example 4 – An order containing Steak and Veg, Pizza, Pasta and Beer is sent to the Kitchen. 
Result – The Steak and Veg, Pizza and Pasta items will be printed to the Kitchen Printers (Mains Printer, Pizza 
Printer and Pasta Printer).  
The Bar Printer will only print the Beer item due to the Sales Category option being set to “Food”, which only 
triggers items from the “Food” Sales Category to print to all triggered Kitchen Printers. 
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To configure and use this function, go to: 
Setup > Global Options > Printing > Enable the option “Print Entire Order to triggered Kitchen Printers”. 
Note that this option is only supported for the Kitchen Docket Format “Group Instructions by Seat”. 
The dropdown box can be set to the Sales Category you want this setting to apply to. 
If you want all items to print to all triggered Kitchen Printers, select the “All Items” option. 
Otherwise, select a specific Sales Category and only items from the selected Sales Category will be printed to 
triggered Kitchen Printers. The below example shows the option “Print Entire Order to triggered Kitchen Printers” 
enabled with the Sales Category set to “Food”. 
 

 
 
Using example 4 shown further above, an order containing the following items is saved to a table: 
Steak and Veg [Food Sales Category] 
Pizza [Food Sales Category] 
Pasta [Food Sales Category] 
Beer [Beverage Sales Category] 
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The resulting Kitchen Dockets are printed: 
 

Bar Printer: 

 
 

Pasta Printer: 

 
 

Pizza Printer: 

 
 

Mains Printer: 
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Keyboard Program 
IP-3727 – Keyboard Program – Customer Type Selection on Customer Function 

This function adds the ability to program a key to display a list of Customers from a specific Customer Type. 
Previous to this change, it was only possible to either program a key to add a specific customer to the sale or 
display a list of all Customers on the POS Screen. It is now possible to program a key to only display a list of 
Customers from a specific Customer Type. 
 
To configure and use this function, go to: Back Office > File > Customers > Customer Types 
Identify which Customer Type that you want to display a list of Customers from, then note down the Customer  
Type Code that’s displayed next to the Customer Type that you want to use.  
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Close the Customer Types window, then go to: Back Office > Setup > Keyboard Program 
 
If you already have a specific key that has been programmed to add a Customer to the sale and you want to modify 
it so that it displays a list of Customers from a specific Customer Type, you can select it from the list then press the 
“Modify” button at the bottom of the Keyboard Program window. 
 

 
 
  



 Update History 
Return to top 

Idealpos 7.1 Build 14 - Update History Page 10 of 37 

 

If you are programming a new key, press the “Add” button on the bottom-right corner of the Keyboard Program 
window. The Key field will display “Press Key to be Programmed”. 
 

 
 
Press any key on the keyboard and Idealpos will detect the keypress and display the key in the key field.  
In this example, we have pressed the “F2” key on the keyboard. 
 

 
 
Note that if you press a key that has already been programmed, Idealpos will display a “This Key has already been 
Programmed” prompt. 
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Select the “Customer” function from the list, then enter the Customer Type code into the Customer Type field 
(using the Customer Type Code that was noted down earlier). 
For this example, we’ll use the Customer Type Code of 1 which refer to the Accounts Customer Type. 
Do not enter anything into the Automatic Text field. 
 

 
 
Press the “Save” button on the bottom-right corner of the window to save your change. 
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The newly programmed key will appear on the list of programmed keys. 
Once again, press the “Save” button on the bottom-right corner of the screen, then confirm the change by pressing 
“Yes”. 
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You can now return to the POS screen by pressing the “POS” button on the top-left corner of the Back Office 
window. 
Press the key on the keyboard which was programmed above (F2). 
A list of Customers from the Customer Type will be displayed on the POS Screen. 
If Fast Customer Searching is enabled in the Yes/No Options, a window similar to the below will be displayed; click 
on any Customer from the list to add them to the sale. 
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If Fast Customer Searching is disabled in the Yes/No Options, a window similar to the below will be displayed; either 
double click on the required customer to add them to the sale, or select the customer by single clicking on them, 
then press the “OK” button on the bottom-right corner of the window.  
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POS Screen  
IP-3722 – Audit Number shows on POS Screen and Home Screen 

This function adds the Audit Number to the POS and Home Screens. 
A unique Audit Number is assigned to each transaction or sale that is performed and by displaying the current Audit 
Number on both the POS Screen and Home Screen, it may come in useful for finding the transaction via the Journal 
History Enquiry, Activity Enquiry or Journal History report. 
Note that the Audit Number has always been printed on the receipt and has also been available via the 
abovementioned reports.  
 
To view the Audit Number on the POS Screen, from the Back Office, press the “POS” button on the top-left corner 
of the screen. 
The Audit Number is displayed on the top-left corner of the POS Screen as shown in the below example: 
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After a sale is completed, the Audit Number will appear on the right-hand side of the Home Screen as shown in the 
below example. 
 

 
 
Note that the Home Screen will only appear immediately after a sale if the Yes/No Option “Return to Home Screen 
after Each Sale” is enabled or if the Home Screen is manually displayed by pressing a POS screen button assigned to 
the Home Screen function. The last transaction will be available on the Home Screen for the amount of time that 
has been configured in the Last Transaction Timeout. 
The Last Transaction Timeout can be configured via Setup > Global Options > Other Options > Home Screen > Last 
Transaction Timeout. 
If required, you can configure Idealpos to show the last transaction indefinitely. 
Note that in order to do this, you will need to set both the Last Transaction Timeout and Slideshow Start Time to 0 
meaning that you’ll lose the ability to trigger the slideshow on the Home Screen. 
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IP-3743 – Customer Tipping screen – Enable by Tender Types 

This function adds the ability to control which Tender Types will trigger the Customer Tipping screen to appear on 
the Customer Display and POS Screen. Previous to this change, enabling the Customer Display Tipping on a POS 
Terminal would cause the Customer Tip prompt to appear after the Clerk pressed the “ENTER” button and before 
the list of Tender Types were displayed on the POS Screen. With this change, you can configure specific Tender 
Types that will trigger the Customer Tipping screen.  
Note that this function supports all Tender Types EXCEPT for Cash. If you require Customer Tipping on the Cash 
tender, you will need to enable Customer Display Tipping via Setup > POS Terminals > Modify > Display/Kiosk and 
therefore will be unable to specifically control which Tender Types will show the Customer Tipping screen. 
Also note that Overtendering is not supported when the Customer Tipping screen is enabled on specific tender 
types. Attempting to Overtender on a tender type which has Customer Tipping enabled will produce a “Cannot 
Overtender with Customer Tipping” prompt. 
 
To configure and use this function, go to: 
Back Office > Setup > POS Terminals > Select POS Terminal > Modify > Display/Kiosk 
In order for you to control which Tender Types will trigger the Customer Tipping Screen, the “Enable Customer 
Display Tipping” option must be DISABLED. The Customer Display Tipping screen will be enabled on the required 
Tender Types in the next step. Note that the even though the “Enable Customer Display Tipping” option needs to 
be unchecked as shown below, the Customer Display Tipping settings that are configured below (i.e. the Tip % 
amounts as well as the RA Function) will be used for the Customer Tipping prompt which you’ll enable for the 
required Tender Types. 
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Once Customer Display Tipping has been disabled on the POS Terminal(s), close the POS Terminal configuration 
windows. 
Then go to: Setup > Function Descriptors. 
Select the Tender Type that you want to have the Customer Tipping prompt enabled, then press “Modify” on the 
bottom-right corner of the window. Note that this function is available on Tender 2 up to Tender 18. It is not 
available on the CASH tender (Tender 1). 
Place a check into the “Enable Customer Tipping” option, then press “Save”. 
 

 
 
You may repeat the above process for each Tender Type that requires Customer Tipping functionality. 
Once complete, close the Function Descriptor windows, then return to the POS Screen. 
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From the POS Screen, add the required items to the sale, then press the “ENTER” button to go to the Tender 
Screen: 
 

 
 
  



 Update History 
Return to top 

Idealpos 7.1 Build 14 - Update History Page 20 of 37 

 

A list of Tender Types will be displayed. When selecting any Tender Type that does not have the “Enable Customer 
Tipping” option enabled, the Customer Tipping prompt will not be displayed. 
Selecting any Tender Type which has the “Enable Customer Tipping” option enabled will trigger the Customer 
Tipping prompt to be displayed on both the POS Screen and the Customer Display. 
Any amount selected or entered via the Customer Tipping Screen will be added to the final amount. 
 
In the below example, the EFTPOS Tender Type has the Customer Tipping option enabled: 
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After EFTPOS is selected, the Customer Tipping prompt will be displayed on both the POS Screen and the Customer 
Display: 
 

 
 
After an amount has been selected, it will be added to the total amount due and in this example, the total amount 
due will be sent to the EFTPOS pinpad: 
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You may also be prompted to enter a cashout amount if this has been enabled. 
Note the new amount including the tip will also be displayed on the Enter Cash-Out Amount prompt: 
 

 
 
If using integrated EFTPOS, Idealpos displays a prompt to swipe card: 
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The tip will be included in the total amount and will appear as TIPS IN on the customer’s receipt: 
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Pre-Ordering Functionality 
IP-3781 – Preorder Functionality – Ability to change pickup date 

This function enables the ability to change the pickup date for a Pre-Order once it has already been saved. 
The Pre-Ordering functionality was introduced in the previous build of Idealpos (Idealpos 7.1 – Build 13) and allows 
Customers to pre-order their items with a deposit and specify a pickup date of when they’re expecting to collect 
their order. Should a Customer decide to change their pickup date, this function can be used after the order has 
been saved. 
 
In order to use this functionality, your system needs to be configured for Pre-Ordering functionality. 
For further details about configuring and using Pre-Ordering functionality, click here. 
 
To configure and use this function, go to: 
Back Office > Setup > POS Screen > POS Screen Setup > Select “Buttons” on the bottom-left corner of the window. 
Locate a POS Screen tab where you’d like to create the button for the “Change Pickup Date” button. 
Locate a blank button, click on it and configure it as follows: 
 
POS Screen Function: Date 
Auto Days/Auto Minutes: Leave as default 
Button Caption: Change Pre-Order Pickup Date 
Button Appearance: Customise Button appearance as desired/required 
 

 
  

https://userguide.idealpos.com.au/#Pre-Ordering%20Functionality/Pre-Ordering%20Functionality.htm
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Once the button has been created, close the POS Screen layout windows. 
Then go to: POS Screen 
 
To modify a pickup date of an existing order, add the Bar Tab Customer to the sale which contains a saved pre-
order. 
This can be done by clicking on the pre-configured POS Screen button for the Customer Type (e.g. XMAS CLUB) that 
you created when originally setting up the Pre-Ordering Function, then select a Customer from the list which 
currently has a pre-order saved: 
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The Customer is added to the sale. 
Before changing the pickup date, you may want to confirm whether or not the customer has a pre-order in the 
system. 
The reason being that if the customer has a pickup date that falls on the current date, the pickup date window will 
highlight the current date. Also, if the customer does not have a pre-order in the system, the pickup date window 
will also highlight the current date. 
Therefore, to avoid any possible confusion, it is a good idea to ensure that the customer does indeed have a pre-
order saved in the system.  
This can be confirmed by checking the customer details that are displayed within the POS Sale screen. Pre-Orders 
will typically display “Outstanding” text next to the Customer’s name and any outstanding balance will appear here. 
If you want to confirm whether the customer has items saved in their pre-order, the Customer Type text (e.g. XMAS 
CLUB) can be pressed on the POS Screen. 
 

 
 
If items have been saved to the pre-order, they will be shown in the window similar to the below example: 
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If the customer doesn’t currently have items saved in a pre-order, a blank window will be shown similar to the 
below example: 
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Once you have confirmed that the customer has a pre-order saved, the “Change Pre-Order Pickup Date” button can 
then be pressed on the POS Screen. 
The pickup date window will be displayed and the previously chosen pickup date will be highlighted (from when the 
pre-order was originally saved). 
You can either leave the date as-is and press OK, then either Void the sale or press “ENTER” to clear the customer 
from the sale. 
If you want to change the pickup date, select a new date from the pickup date window, then press “OK”. 
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The new pickup date will appear on the top-right corner within the sale as shown in the below example: 
 

 
 
To apply the change, press the “ENTER” button on the POS Screen. 
 
When running the Pending Sales Report (from the Back Office, go to Reports > Sales > Pending Sales), the new 
pickup date will now appear for the order. 
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Stock Items 
IP-3773 – Support for Stock Item Tags 

This function adds tag functionality to Stock Items. 
Tags can be added to Stock Items and they can be used to record additional details about the item or type of item. 
E.g. In a clothing store, you may have clothing articles which are for babies, children, adolescents and adults. 
Clothing Stock Items can be marked using tags such as Clothing – Baby, Clothing – Children, etc. 
You can create as many tags as needed for each item. 
E.g. An item can be marked with tags such as:  

• Clothing – Baby 
• Pants 

• Size – Small 
• Etc. 

 
Note that the length of each tag is restricted to twenty characters. 
In the near future, we’ll be adding support for sending tags from Idealpos to Shopify (via Idealpos Online). 
This will result in the tags that are entered against a Web Store Stock Item in Idealpos being sent to and created in 
Shopify. 
 
An option to enter tags has also been added to the Stock Item Sales Report which enables you to enter one or more 
tags. The Stock Item Sales Report will only report on items that match the entered tags. 
 
There is no configuration required to enable the tags function. 
 
To use this function, go to: File > Stock Control > Stock Items 
Open a Stock Item by selecting it and pressing “Modify” on the bottom-right corner of the screen. Alternatively, you 
can double-click on an item to open it. 
In the Tags section, click into the blank field and start entering a tag. 
As you enter a tag, you will notice a small popup appear below the blank field showing “+ Add [tag]”, where [tag] is 
the text is representative of the tag that you’ve entered into the field shown above. 
To add the tag to the list, you can either press the “+” button on the small popup area. Alternatively, you can press 
ENTER or the comma (,) button on your keyboard. 
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The tag will be added to the right-hand side of the Tags field. You can repeat this process to add as many tags as 
required for the item. 
 

 
 
If more tags are entered than can be displayed in the Tags area, a scrollbar will appear on the right-hand side of the 
Tags area to enable scrolling through the list of tags.  
 

 
 
Tags can be removed by pressing the “X” button located to the right-hand side of the tag. 
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Once the required tags have been added to the Stock Item, press the “Save” button on the bottom right corner of 
the Stock Item window. 
If you add tags to a Stock Item and close the window without saving by pressing the “X” button on the top-right 
corner, a “Save Changes?” prompt will be displayed as below. Press “Yes” to save your changes or press “No” to 
discard any newly entered tags. 
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The Stock Item Sales Report has been updated to support tags functionality.  
Specific tags can be entered into the selection range when running the report and the report will only display items 
that match the entered tags. Entering multiple tags into the report selection range will display items that match 
any of the entered tags. 
E.g. Entering multiple tags into the selection range acts as an “or” function, meaning that entering multiple tags 
such as “UV protection” and “Headwear” will display any Stock Items that have “UV protection” OR “Headwear” tags 
(to broaden the selection range).  
Entering multiple tags does not restrict the results to only show items that contain all the tags within the one item. 
E.g. The two following Stock Items exist with the following tags: 
 
Stock Item: Hat Large  
Tags: “UV protection” and “School” 
 
Stock Item: Boys Size M Shirt 
Tags: “Shirts” and “School” 
 
When running the Stock Item Sales Report with tags “School” and “UV protection”, both Stock Items (Hat Large and 
Boys Size M Shirt) will appear in the report, provided that there are sales for both Stock Items within the sales 
period selected. This is because the tags function looks for any Stock Items that contain any of the tags entered in 
the report selection range. It does not look for Stock Items that specifically have all of the entered tags in each 
item. 
 
To use the reporting function, go to: Reports > Sales > Stock Item Sales 
At the bottom of the Stock Item Sales report window, enter the tags for the Stock Items that you want to report on, 
then press the “View” button. After you have entered a tag, ensure that you press the comma button on your 
keyboard “,” to add it to the list of tags in the selection range. 
The below example shows the tags “School” and “UV protection” added to the selection range. 
To add School and UV protection to the list of tags, you would need to enter “School,UV protection,” into the Tags 
field (excluding the quotes).  
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The report will run and will display a list of Stock Items that have been assigned to the tags which were entered in 
the selection range. Any tags that were entered into the selection range will be displayed at the top of the Stock 
Item Sales Report as a comma separated list. 
 

 
 
Tags can also be included as a default setting in the Stock Item Sales Report via the “Save Defaults” function. 
To include tags in the report defaults, enter the required tag(s), then press the “Save Defaults” button. 
Each time the report is opened via Reports > Sales > Stock Item Sales, the tags will be pre-entered. 
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IP-3764 – Stock Items – Support for Weight field (Shopify) 

This function adds a Weight field into the Idealpos Stock Items – Advanced tab. 
The Weight field will be sent to Shopify once support is added for this functionality. 
Note: Support for sending Weight info to Shopify that has been entered into this field will be added in the near 
future. 
 
This functionality is available by going to: File > Stock Control > Stock Items > Select Item > Modify 
Enable the Scale checkbox and enter the unit of measurement for the weight (e.g., g, kg, oz, lb, etc.). 
If required, the tare can also be entered. 
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Once you’ve entered the unit of measurement for the scale and entered the tare weight, press the “Advanced” tab, 
and enter the weight of the item. 
 

 
 
Note that as mentioned previously, this functionality is available in the Idealpos User Interface, however, sending 
this data to Shopify is not yet supported. Support for sending the actual weight of an item to Shopify (via Idealpos 
Online) will be added in the near future. 
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Xero Interface 
IP-3698 – Xero Interface – Support for Chromium Embedded Framework 

This function adds Chromium Embedded Framework support to the Xero Interface in Idealpos. 
This change ensures that Idealpos can continue to connect to and work with the Xero Oauth 2.0 Accounting 
Interface beyond December 2020. 
Previous to this change, we were utilising a component that leveraged the latest Microsoft web browser installed 
on the PC/terminal to establish a connection with Xero. However, the components that were being used are no 
longer being supported by Xero after December 2020 and therefore, when connecting Idealpos to Xero, the Xero 
login prompt would display the following message: “Xero support for your browser ends in December”. 
In order to ensure that our customers can continue to connect to Xero, we have added support for Chromium 
Embedded Framework.  
 
If you are using Xero or plan to use Xero, you must install the Framework patch which includes support for 
Chromium Embedded Framework. The Framework patch must be installed prior to installing the latest build 
release, otherwise you may encounter error prompts after starting Idealpos. 
Should you forget to install the Framework patch before installing the latest build release, please install the 
Framework patch, then re-run the latest Idealpos build installer. 
 
Once the Framework Patch has been installed, the process for connecting Idealpos to Xero remains the same as per 
the steps that have been documented in the User Guide here.  
 
If the Framework Patch has not been installed and you attempt to connect Idealpos to Xero via the connect to Xero 
button, a prompt “Could not Authorize Organization” will be displayed as shown below.  
 

 
 
To rectify this, complete the steps in the order shown below:  

• Install the Framework Patch. 

• Install the latest Idealpos build. 
• Connect Idealpos to Xero using the button on-screen. A popup window should appear where you can login 

using your Xero credentials. 

 

https://userguide.idealpos.com.au/#Accounting%20Interfaces/Xero%20OAUTH2/Getting%20Started.htm

