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End of Shift 
IP-3517 – USA Region – “Float” function renamed “Starting Bank” 

The “Float” function has been renamed to “Starting Bank” for the USA Region. 
This change will only be visible when the Idealpos Region is set to “USA” and is reflected throughout Idealpos 
where the Float descriptor is shown (i.e. Float Count Entry is now Starting Bank Entry, any Yes/No Options which 
contained the word “Float” have been replaced with the word “Starting Bank”, etc.). 
As mentioned above, this change is only applicable for the USA Region (the Idealpos Region must be set to USA). 
The region is set by going to:  
Back-Office Dashboard, then selecting Setup > POS Terminals > Modify > Main Settings > Region. 
 
Float and Starting Bank perform the same task and by renaming this function to “Starting Bank” for the USA 
Region, customers that reside in the USA will find it easier to locate and make use of this function. 
This function is used to count the amount of money that is in the Starting Bank/Float before any sales take place. 
Once the shift is finished, the amounts entered or counted from the Starting Bank/Float can be checked against the 
float from the beginning of the shift to ensure that the amount of money in the till balances correctly.  
More information about using Starting Bank or Float is available in the User Guide under the End of Shift > Float 
Count Entry topic.  
Click here to view the End of Shift topic. 
Click here to view info about the Starting Bank/Float which is located within the above End of Shift topic.  

https://userguide.idealpos.com.au/#End%20of%20Shift/End%20of%20Shift.htm
https://userguide.idealpos.com.au/#End%20of%20Shift/Float%20Count%20Entry.htm
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Gift Vouchers 
IP-3537 – Gift Vouchers – Recipient Name can be modified when using Customer 

This function makes it possible to change the name of the Gift Voucher Recipient when purchasing a Gift Voucher 
while a Customer has been added to the sale. In addition to this change, the “Customer Name” field within the Gift 
Voucher Sale window has now been changed to “Recipient Name”. 
Previous to this change, the Customer Name field in the Gift Voucher Sale window would be pre-filled using the 
name of the Customer which was added to the sale and it was not possible to modify the name. 
The above changes have been made to simplify the process of selling Gift Vouchers. This change also makes logical 
sense as the majority of Gift Voucher sales are typically purchased to give to someone else, so it is appropriate that 
the Gift Voucher sale window should allow the Recipient Name to be recorded against the voucher, not the name of 
the Customer who is purchasing the Gift Voucher. 
 
If Gift Vouchers have not been configured or if you want to find out more about using Gift Vouchers in Idealpos, 
click here to visit the Gift Voucher topic in the User Guide. 
 
Before using this function, we recommend disabling the option “Gift Vouchers use Customer Code” (if you intend 
on allowing your Customers to purchase Gift Vouchers for other recipients). 
Go to: Setup > Global Options > Credit Notes/Gift Vouchers.  
Clear the Checkbox “Gift Vouchers use Customer Code” 
 

 
 
 
 
  

https://userguide.idealpos.com.au/#Gift%20Vouchers/Gift%20Vouchers.htm
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From the POS Screen, go to: Customers > Add Customer to Sale 
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Press the GIFT VOUCHER button to sell a Gift Voucher. 
The GIFT VOUCHER Sale window will appear. 
The Customer Name field will now appear as Recipient Name. 
The Recipient Name field will be pre-filled using the name of the Customer that has been added to the current sale. 
If a Customer has not been added to the sale, the Recipient Name field will be blank. 
The Recipient Name field can be modified to reflect the name of the intended recipient of the voucher.  
Previously, this field would be pre-filled and greyed out if a Customer had been added to the sale. 
The Email Address of the recipient can also be entered and a copy of the Gift Voucher will be emailed to them. 
Note that in order for the Gift Voucher to be emailed to the recipient successfully, Email Settings must be 
configured in Setup > Global Options > Other Options > Email Settings. 
 
The below example shows the GIFT VOUCHER Sale window pre-filled with the name of the Customer which has 
been added to the current sale. 
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Enter the Gift Voucher Amount, Recipient Name and Email Address, then press “OK” to add the Gift Voucher to the 
sale: 
 

 
 
The Gift Voucher is added to the sale similar to the below example: 
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Tender the Sale by pressing the ENTER button, then choose an amount to finalise the sale. 
The Gift Voucher is then emailed to the recipient’s email address that was entered during the sale. 
The Gift Voucher will be received as a PDF attachment: 
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If required, the Gift Voucher can be emailed to the recipient again (in case there are problems during the send email 
process or if they accidentally delete their email). 
This can be done via the GIFT VOUCHER ENQUIRY button. 
Press GIFT VOUCHER ENQUIRY from the POS Screen > Name Search > Enter the Recipient Name into the “Enter 
Name” field > Select the recipient name from the right-hand side > Use 
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Press the “Email” button to Email the voucher. 
 

 
 
A confirmation prompt will appear. 
Press “Yes” to continue to email the voucher. 
It will be emailed to the same email address as was originally entered when the voucher was sold. 
Alternatively, the Voucher can also be Printed if required via the “Print” button. 
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Global Options  
IP-3410 – Additional Sales Type Fields Added 

This function enables the ability to configure additional Sales Types which can be used for Pending Sales. 
Examples of Sale Types include Takeaway, Delivery, Pickup, etc. 
Prior to this change, there were a maximum number of four sale types that could be configured. 
With this change, this has now been increased to a maximum number of nine sale types that are now available. 
More information about using Pending Sales is available in the User Guide by clicking here. 
 
To configure Sale Types, go to: Setup > Global Options > Sales > Sale Type Status 
Enter the required Sale Types into the blank fields, then close the Global Options window to save your change: 
 

 
 

  

https://userguide.idealpos.com.au/#Pending%20Sales/Pending%20Sales.htm
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Note that you also have the ability to control whether the Sale Type is printed on the receipt via the Yes/No Options. 
To control this function, go to:  
Setup > Yes/No Options > Enter Keyword Search: type > Enable “Show Sale Type on Receipt” 
Note that the receipt must be forced for this option to work, as a reprint receipt will not show the sale type. 
 

 
 

The Sale Type Statuses are available from the Pending Sales screen. 
Go to the POS Screen, then add items to the Sale. 
Finally, press the “Pending” button. 
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Enter the Customer Name/Address, then select the Sale Type from the list as per the below example. 
Note that when all Sale Type slots have been configured in Global Options > Sales, all Sale Types will be shown with 
a radio button for each Sale Type which is used to select the desired Sale Type. The below example shows seven 
Sale Types as the remaining two Sale Type slots were left as blank in Global Options > Sales. 
Press “Save” to save the Pending Sale. 
The Sale Type will be recorded against the sale. 
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To retrieve the Pending Sale, press the “Pending” button, select the Pending Sale from the list, then press the “OK” 
button on the bottom-right corner of the screen. 
 

 
 
The items from the sale will be displayed on the POS Sale Screen. 
Tender the sale by pressing “ENTER”, select a Tender from the list to pay off and finalise the sale. 
If the Yes/No Option “Show Sale Type on Receipt” is enabled, the Sale Type will be printed on the Customer 
Receipt. 
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Journal Enquiry 
IP-3246 – Journal History Enquiry – Filter by Safe Drop Function 

This change adds the ability to filter the Journal History Enquiry screen by Safe Drop. 
When selecting “Safe Drop” from the Function dropdown box, the Journal History Enquiry screen will only show 
transactions where a Safe Drop was performed. This function can be accessed either via the Back Office > Enquiry > 
Journal History, or it can also be accessed via a Journal Enquiry button on the POS Screen which you can configure 
to automatically select the “Safe Drop” function. 
 
To use this function from the Back-Office, go to: Back Office Dashboard > Enquiry > Journal History 
 
Select “Safe Drop” from the Function dropdown box. 
The list of transactions shown in the enquiry below are updated to only display transactions that contain a “Safe 
Drop”. 
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If you’d like to utilise this function via a button on the POS screen, this can be done so as follows: 
Go to: Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 
 
Locate a suitable tab on the POS Screen, then find a blank button and select it. 
From the Function List, select “Journal Enquiry”. 
Within the Automatic Text field, enter [FUNCTION=Safe Drop]. 
Configure the other options on the button as required, then press “Save” to save the button. 
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Close the POS Screen Layout windows, then open the POS Screen. 
When pressing the button on the POS Screen, the Journal Enquiry function will be displayed, and the Safe Drop 
function will be pre-selected: 
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Order Numbers 
IP-3433 – Support for Larger Order Numbers 

This function increases the maximum digit length allowable for Order Numbers in Idealpos. 
Prior to this change, the maximum length was 6 digits. 
The maximum Order Number length has now been increased to 18 digits which will allow longer numbers such as 
Mobile Phone Numbers to be used as an Order Number. 
 
There is no additional configuration required to increase the maximum length as this has been updated in this build 
of Idealpos. Simply running Idealpos 7.1 Build 11 or higher will enable the ability to utilise larger Order Numbers. 
 
In order to utilise the Order Numbers function, you will require an Order Number button on your POS Screen. 
If an Order Number button already exists on your POS Screen, you can skip the below step. 
 
To create an Order Number button, go to:  
Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 
 
Click on the POS Screen tab where you’d like to create the button, then select an unused/blank button. 
Configure the button as follows, then press “Save” to save the button: 
 

 
 
Once the button has been created, close the POS Screen layout windows. 
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Go to the POS Screen > Add Items to the Order > Press the “Order Number” button. 
 
You will be prompted to enter an Order Number. 
A longer Order Number can be entered (such as the Customer’s Phone Number), then press Enter. 
The below example shows a generic Mobile Phone Number of 0412312312 being entered: 
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Once the Mobile Phone Number/longer Order Number has been entered, press the “ENTER” button to accept the 
entered number and proceed to the Tender screen. 
Alternatively, you can press the Order Number button again (once the Order Number has been entered) and you 
will remain on the Sale Screen so you can continue to add other items to the sale. 
You can also enter the Order Number first, then press the Order Number button and this will also leave you in the 
sale screen so additional items can continue to be added to the sale. 
 
After the ENTER button has been pressed, Idealpos will show the Tender screen ready for payment. 
The Order Number will be shown at the top of the POS Screen: 
 

 
 
The entered Order Number/Phone Number will be printed on the Customer Receipt as well as any Kitchen Dockets 
that are printed.  
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IP-3509 – Order Number Range functionality only when Order Number function is used 

This function enables the ability to configure Idealpos so that an Order Number is assigned to the sale only when 
required via the Order Number button. Previous to this change, an Order Number was always assigned to the sale if 
the Show Order Number was configured in the POS Terminal > Miscellaneous Settings.  
This functionality is useful to users who run a venue that either sells items that can simply be picked up and 
purchased or items that require preparation. When the items being purchased do not require preparation, the 
Order Number function is not required; the customer simply pays and leaves immediately with their items.  
If the items require preparation, an Order Number can be assigned to the sale via the Order Number button when 
the sale is completed. Once the order is ready, the Order Number is called out by the Clerk, allowing the customer 
to collect their order and leave the premises.  
 
To configure and use this function, follow the below steps: 
This function utilises Order Numbers which are automatically assigned to the Sale. 
Therefore, depending on your environment and how you want to configure and use this function, you have the two 
following choices/options: 
 

1. Have a Unique Order Number range/Order Number pool for each POS Terminal. If setting the system up 
this way, POSServer is not required and the Order Number range/pool is configured for each POS Terminal. 
It is recommended to have a unique number range/pool for each POS Terminal to prevent 
overlapping/clashing Order Numbers. 
 

2. Have the same Order Number range/pool that is used across all POS Terminals. If setting the system up this 
way, POSServer is required and the Order Number range/pool is configured in POSServer. POSServer will 
then automatically assign an Order Number to the sale when a POS Terminal requests it. This ensures that 
each POS Terminal issues a unique Order Number to prevent any conflicting or clashing Order Numbers. 

  



 Update History 
Return to top 

Idealpos 7.1 Build 11 - Update History  Page 21 of 50 

 

If you want to assign a unique Order Number range for each POS Terminal, go to:  
Setup > POS Terminals > Select POS Terminal > Modify > Miscellaneous Settings 
Ensure that an Order Number range has been entered into the Show Order fields. 
 

 
 
Repeat the above process for each POS Terminal that requires Order Number functionality.  
It is recommended to assign a unique Order Number range for each POS Terminal. 
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If you prefer to assign a single number range across all POS Terminals, first ensure that POSServer is running. 
POSServer can be started either via the Start Menu > Idealpos > Idealpos POSServer, or by opening POSServer.exe 
(C:\Program Files\Idealpos Solutions\POSServer\POSServer.exe), then ensuring that it is started. 
POSServer only needs to be running on a single system (whether it is a dedicated POSServer PC, the main POS 
Terminal or Back-Office PC). 
 
To ensure that POSServer is running, open the POSServer using one of the above methods (either via the Start 
Menu or by opening the POSServer.exe). Note that you may have to run the POSServer.exe as Adminsitrator (right-
click on the icon and select “Run as Administrator”). After opening POSServer, “Running” should appear on the 
bottom-left corner of the window.  
 

 
 
If “Running” does not appear on the bottom-left corner, select “Advanced”, then press “Service”. 
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Ensure that the Startup state is set to “Automatic”, then press the “Set State” button to apply the change. 
Then press the “Start” button to start the service. 
 

 
 
The Service should then appear as “Running” as per the below image: 
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Then from the Idealpos Back-Office Dashboard, go to: Setup > Global Options > Miscellaneous > POSServer 
Ensure that the “POSServer” checkbox is enabled, enter the IP address of the system which is running the 
POSServer, enable the “Order Numbers” checkbox. 
Enter the Order Number range into the Order Number field and close the Global Options window to save your 
changes. 
 

 
 
A prompt may be displayed advising to restart all POS Terminals. 
Before restarting Idealpos, the Yes/No option “Inhibit Automatic Order Number” should also be enabled and an 
Order Number button created. 
 
Go to: Setup > Yes/No Options > Enter Keyword Search: “Inhibit auto” 
Enable the “Inhibit Automatic Order Number” option as per the below example. 
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Close the Yes/No Options, then go to:  
Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 
 
Select a POS Screen tab, select a blank button and configure the POS Screen button as follows:  
Ensure that the Automatic Text field is left as blank so that the Order Number can be auto-assigned when this 
button is used.  
If a value is entered into the Automatic Text, the value in the Automatic Text field will be assigned as the Order 
Number each time this Order Number button is pressed. 
 

 
 
To ensure that the above changes have applied across all POS Terminals, it is recommended that you restart 
Idealpos on each POS Terminal. This can either be done by going to Start > Idealpos > IPSUtils > Close. 
Alternatively, the entire POS terminal can be restarted. 
For more information about configuring POSServer, click here. 
 
  

https://userguide.idealpos.com.au/#POSServer/POSServer%20Configuration.htm
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To use the Order Number functionality, simply add the required items to the sale.  
Press the Order Number button when an Order Number is required, then press the Enter button. 
An Order Number will be automatically assigned to the POS Terminal using either the Order Number Range 
configured for the POS Terminal or the Order Number range configured in the POSServer Configuration. 
The Order Number will appear at the top of the POS Screen and the POS will go to the Tender screen. 
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The Order Number will appear on any Kitchen Dockets and will also appear on the Customer Receipt. 
If the Order Number button is not used during the sale, an Order Number will not be assigned to the sale and will 
not be printed on Kitchen Dockets or the Sale Receipt. 
The below examples show a Kitchen Docket and Customer Receipt with an Order Number: 
 

 
 
If you require an “Order Number Docket” to be printed in your venue, there is a Yes/No option “Print Order Number 
Dockets” which can be enabled to achieve this. This can be enabled by going to: Setup > Yes/No Options > Enter 
Keyword Search: “order number” > Enable “Print Order Number Dockets”. 
 

 
 
When a sale is completed that includes an Order Number, an Order Number docket will be printed. 
This can either be handed to the customer or used as part of your internal processes when preparing the order. 
Once the Order is ready, the Customer can present the Order Number Docket to collect their order.  
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Pending Sales 
IP-3438 – Option to filter by Clerk Code on Pending Sales screen 

This function adds the ability to filter by Clerk Code on the Pending Sales screen. 
Previous to this change, the Pending Sales screen had the option to filter by Pending Sale Code, Clerk Name or 
Customer Name. After this change, the Pending Sale screen can now be filtered by Clerk Code. 
Note that as part of this change, the descriptions of the existing Search For options have been adjusted to reduce 
ambiguity. 
 
To use this function, go to: POS Screen > Press the “Pending” button to view the existing Pending Sales. 
The new “Clerk Code” option will appear at the top of the window next to the “Search For” section as shown below: 
 

 
 
  



 Update History 
Return to top 

Idealpos 7.1 Build 11 - Update History  Page 29 of 50 

 

Ensure that the Clerk Code Option is selected, then enter a Clerk Code. 
The list of Pending Sales will be filtered by the entered Clerk Code number: 
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IP-3539 – Pending Sales – Option to send to Kitchen Printers at a future time 

This function adds the ability to send Pending Sales to the Kitchen Printer(s) at a future time.  
When saving a Pending Sale, Expected Date and Time fields are used to specify the date and time that the customer 
requires the order.  
To support this functionality, a new field “Kitchen Print minutes before Expected Time” has been added to Global 
Options. This setting can be configured and enabled as required. When configured, new options will appear on the 
Save Pending Sale window. These new fields/options are “# minutes before Expected Time” and “Immediately”.  
 
When a Clerk saves a Pending Sale, they can choose to send the order to the Kitchen using the number of minutes 
before Expected Time or the Clerk can opt to send the order to the Kitchen immediately.  
The # minutes before Expected Time will be pre-filled using the value that has been configured in the Global 
Options, or the Clerk can choose to enter an alternate number of minutes before the Expected Time. 
 
Depending on the selection made when the Pending Sale was saved, the order will either be sent to the Kitchen 
Docket Printer(s) the number of minutes before the Expected Time, or the order will be sent to the Kitchen Docket 
Printer(s) Immediately. It must be noted that in order for the Order to send to the Kitchen the number of minutes 
before the Expected Time, the POS Terminal must be on and Idealpos must be running the number of minutes 
before the Expected Time. 
 
This function can be used when the Chef requires a specific amount of time to prepare the order. The number of 
minutes before Expected Time can be configured to match the average time it takes the Chef to prepare the order 
at the venue. This will ensure that the meal will be fresh/hot when the Customer arrives to collect their order. 
 
To configure and use this function, go to: Setup > Global Options > Sales > Pending Sales 
Enable the checkbox “Kitchen Print minutes before Expected Time” and enter the number of minutes you want to 
have the Kitchen Dockets print prior to the Expected Time. 
Note that some checkbox descriptions for Pending Sales in Global Options > Sales have changed slightly from 
Idealpos 7.1 Build 11 and higher. Refer to the Global Options > Sales topic in the User Guide for more details. 
 

 
  

https://userguide.idealpos.com.au/#Global%20Options/Sales.htm
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It is also important to note that in order for this option to work, the following criteria must be met: 
• “Print to Docket Printers” must be enabled In Setup > Global Options > Sales > Pending Sales 
• Kitchen Docket Printers/Network Printers must be configured/enabled (Setup > Network Printers) 
• Items that are saved to the Pending Sale must have the Kitchen Printer enabled 

 
Close the Global Options window to save your change. 
Go to the POS Screen, add items to the sale, ensuring that the items being added are enabled for Kitchen Printing 
(this can be configured by going to File > Stock Control > Stock Items > Open/Modify Item > Enable the Kitchen 
Printers). 
Once items have been added to the sale, press the “PENDING” button to save the Pending Sale. 
The Save Pending Sale window will appear. Note that the window title may differ depending on the Function 
Descriptor used for “Pending Sale”. 
If a Customer has not been added to the sale, enter the Customer’s details. 
If a Customer has been added to the sale, their details will be pre-filled. 
Enter the Expected Date/Time when the customer requires the order to be ready. 
The Send to Kitchen function will default to “# minutes before Expected Time”, where # will show the number of 
minutes that were configured in Global Options for this particular function. 
Select the minutes before Expected Time to delay printing to the Kitchen Docket printer until the specified time. 
Alternatively, the “Immediately” option can be selected to print to the Kitchen Docket Printer(s) Immediately.  
After the “Save” button is pressed, the selected action will be taken. 
Note that if the option “Kitchen Print minutes before Expected Time” is not enabled in Global Options, the “Send to 
Kitchen” section shown below will not be visible on the “Save Pending Sale”. 
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After saving the Pending Sale, the Activity Log will show “Pending Sale queued for Kitchen @ DD MMM HH:MM as 
per the below example (The Activity Log can be accessed via the Back Office > Enquiry > Activity Log): 
 

 
 
When the Pending Sale Kitchen Docket is printed to the Kitchen Printer(s), the Date/Time shown at the top of the 
Kitchen Docket will reflect the Date/Time which the Pending Sale was saved. 
The Date/Time shown above the Customer Name will reflect the Expected Date/Time. 
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POS Screen Setup 
IP-3500 – POS Screen Grids – Stock Item Functions can link to previous Grid (BACK) 

This function adds a [BACK] option to the Grid Link dropdown box within the POS Screen Grid setup. 
Previous to this change (during the POS Screen Grid programming process), if you wanted to program the POS 
Screen Grid to show the previous grid after adding an item, you had to know the name of the previous POS Screen 
Grid so that you could select it from the Grid Link dropdown box. This would involve closing the current POS Screen 
Grid Layout, navigating between different POS Screen Layouts to determine what the name of the previous layout 
so that it can then be selected during the programming process (which involved a lot of back and forth actions). 
With this change, you now have the ability to select [BACK] from the Grid Link list and this will achieve the same 
outcome, saving time when programming Stock Items on the POS Screen Grid. When an item on the POS Screen 
Grid is linked to the Grid Link [BACK], the previous POS Screen Grid will be displayed after that item has been 
added. 
 
For the purpose of demonstrating this change, we will use the COOK TYPES FISH GRID in the Demo Database 
included with Idealpos. 
 
To use this function, go to: Setup > POS Screen > Grids > Select “COOK TYPES FISH”. 
 
By default, the items shown on the COOK TYPES FISH Grid all link to Grid Link “MAIN” as per the below example: 
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The new [BACK] option can now be used to display the previous Grid after the item is added to the sale: 
Ensure that you press “Save” on the bottom-right corner of the window to save your change. 
 

 
 
  



 Update History 
Return to top 

Idealpos 7.1 Build 11 - Update History  Page 35 of 50 

 

After adjusting the Grid Link setting, go to the POS Screen and select RESTAURANT, then press “SEAFOOD”. 
The COOK TYPES FISH Grid is displayed. 
Select “GRILLED” 
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The POS Screen returns to the previous Grid, which in this case is the MAIN Grid: 
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Reservations 
IP-3498 – Reservations Docket printout includes Customer Comments fields 

This function has enabled the Reservations Docket Printout to include the Customer Comments field. 
There is no additional configuration required to enable this function; simply entering Customer Comments when 
saving a reservation will result in those comments being shown on the Reservations Docket Printout. 
 
Before using this function, you will need to have the Idealpos Reservations Interface enabled in your Licence 
Gateway. Note that the Idealpos Reservations Interface is used in conjunction with the Restaurant Module. 
More information about the Idealpos Reservations Interface can be found in the User Guide by clicking here. 
More information about the Idealpos Restaurant Interface can be found in the User Guide by clicking here. 
 
To use this function, go to: Idealpos Back-Office > Reservations > Reservations. 
Alternatively, you can press the RESERVATIONS button from the POS Screen or the Table Map 
 
Select a day, time and table from the grid, then press the “Reserve” button on the bottom-right corner of the 
window. 
The below example shows a selected reservation for Saturday 1st August 9:00AM – 10:30AM 
 

 
 
  

https://userguide.idealpos.com.au/#Reservations%20Interfaces/Idealpos%20Reservations/Idealpos%20Reservations.htm
https://userguide.idealpos.com.au/#Restaurant%20and%20Table%20Map/Restaurant%20Table%20Map.htm
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Enter the Customer’s details as required. The Reservation Arrival/Duration can be adjusted if required. 
Two Comments fields are available as shown in the below example. 
Enter Comments as required, then press “Save” to save the Reservation. 
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The Reservation will be displayed on the Reservation grid similar to the below example. 
Any other reservations will also be displayed: 
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Towards the top of the window, click on the “Runsheet” text to view the runsheet. 
The Runsheet is shown. 
On the bottom-right corner of the window, press the “Print Docket” button. 
 

 
 
The Docket is printed and includes the table details along with Comments that were entered when the Reservation 
was saved: 
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Schedules 
IP-3513 – Schedules – Email Dashboard Option 

This function enables the ability to create a schedule to email the Back-Office Dashboard to your desired email 
address. 
The Schedule will email an image of the dashboard at the time the schedule is run. 
Note that in order for the schedule to run and email the dashboard to the specified email address, Idealpos must be 
logged in as a User which has access to view the dashboard. 
If the logged-on User does not have access to view the Dashboard, the schedule will not email the dashboard. 
It should also be noted that the terminal which runs the schedule needs to have the Back-Office module enabled in 
the Licence Gateway as this is required in order for the dashboard to be visible. 
 
To configure and use this function, go to: Setup > Schedules > Add 
From the “Type” dropdown box, select “Email Dashboard”. 
Then configure the Schedule as required and ensure that you enter a To address which the Dashboard will be 
emailed to. If required, you can also enter email addresses into the CC and BCC fields and enter a message to be 
included in the email. 
Ensure that the terminal number entered into the “From POS” field has the Back-Office module enabled. If the 
terminal only has POS module enabled in the licence, the terminal will not send/generate the Email Dashboard. 
 

 
 
Once the configuration has been completed, press the “X” button on the top-right corner and a “Save Changes?” 
prompt will appear. Press “Yes” to confirm. 
When the schedule is run by Idealpos, the current state of the Dashboard at the time the schedule is executed will 
be emailed to the email addresses entered into the Schedule Configuration as configured above. The dashboard 
will be included as a JPG image attachment. 
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When the schedule runs, it is essentially performing the same task as pressing the “Save” button on the top-right 
corner of the dashboard, except on a schedule and emailing the report to the specified email addresses within the 
Schedule. 
 

 
 
 
An example of the emailed Dashboard is shown below: 
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Special Price Schedule 
IP-3529 – Special Prices Screen – Search/Sort Functionality 

This function adds Search and Sort functionality to the Special Prices Screen which allows the User to find Stock 
Items either by Description or by Stock Item Code. This is especially useful at venues or stores which have an 
extensive list of Stock Items that have a Special Price assigned to them. 
The Special Prices screen is used for assigning Special Prices to Stock Items. When the Special Price Schedule is 
active, any item which has a Special Price will be sold for that price whilst the Special Price Schedule is active. 
 
There are no additional steps required to enable this functionality; simply opening the Special Prices screen will 
reveal the field that can now be used to search for Stock Items. 
 
Go to: File > Sales > Promotions > Special Price Schedule. 
Select a Special Price Schedule from the list, then press the “Specials” button on the bottom-left corner of the 
window. 
Note that you must have at least one Special Price Schedule in the list. If there are no Special Price Schedules in the 
list, pressing the “Specials” will have no effect. 
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A list of Specials will be displayed. 
If the Specials list is blank, the Special Price Schedule selected has only been configured to apply a specific Price 
Level during the schedule. You will need to have items added to the Specials list to use the search functionality. 
It should be noted that Handheld only supports setting a Price Level during a Special Price Schedule. Handheld does 
not currently support Specials/Special Prices for Stock Items which have been set via the Specials screen. 
 
The Search function is available on the top-right corner of the window. 
 

 
 
It is possible to search by Code or Description – press the “Description Search” or “Code Search” button, then select 
the preferred type of search. Any items that match the search term will be displayed: 
 

 
 
Finally, you can also sort by Column Header (e.g. sort by Stock Code, Description or Special Price). 
Simply press the Column Header of the header you want to sort by and the Stock Items shown in the list will be 
sorted by the column.  
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Stock Items 
IP-3555 – Stock Codes From option supports alpha codes 

This function adds the ability to configure the POS Terminal so that alpha-numeric codes will be used when new 
Stock Items are created. Note that this function will only calculate the next numeric portion of the Stock Code. It 
will not calculate the next character sequence in the code. 
E.g. If entering ABC into the From field, once the numeric portion after ABC has been exhausted, Idealpos will not 
increment the next character in the sequence (I.e. from ABC to ABD). 
This function is configured via the POS Terminal Settings and is used when creating Stock Items via File > Stock 
Control > Stock Items > Add.  
 
To configure and use this function, go to:  
Setup > POS Terminals > Select POS Terminal > Modify > Miscellaneous Settings 
Within the Stock Item Codes From field, enter the starting alpha-numeric code (e.g. ABC123) and in the to field, 
enter the last number sequence (e.g. ABC999). 
 

 
 
Close the POS Terminals window to save the change. 
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Go to: File > Stock Control > Stock Items > Add 
The Stock Code field will be populated using the range entered in the previous window: 
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After the Stock Item has been saved, the Stock Code will be incremented to the next available code ready for you to 
create the next Stock Item: 
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Stocktake 
IP-3546 – Archived Stocktake Report – Include original Stock Level Valuation column 

This function includes additional details on the Archived Stocktake Report and a few slight changes to make the 
Archived Stocktake Report easier to read. 
When running the Archived Stocktake Report, the report will now display an original Stock Level Valuation column 
(which is represented by the column heading “Pre-Stocktake”).  
In addition to this change, the following changes have also been made: 

• The Stock Level column header has been renamed to “Pre-Stocktake” to represent the Stock Level prior to 
the Stocktake.  

• The Variance Quantity column has been moved next to the Stocktake count columns 
• The Variance Value/Variance % columns are located below the Valuation section. 

 
To use the Archived Stocktake Report, go to: Reports > Stock Control > Archived Stocktakes 
Select the Archived Stocktake from the list and select the required criteria, then press “View” to run the report for 
the selected Stocktake: 
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The Archived Stocktake Report is displayed. 
The additional column added to the report has been annotated in the below example. 
 

 
 
Previous to this change, the Archived Stocktake Report used to appear as per the below example: 
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Tax Monitoring  
IP-3512 – Tax Monitoring Fiscal Receipts – Retry functionality 

This function enables the ability to create a button which can be used to retry the sending of Fiscal Receipts to the 
ESDC. This function is useful in cases where the connection between Idealpos and the ESDC is interrupted and you 
want to trigger Idealpos to reattempt sending Fiscal Receipts. Note that when using this function, any unsent or 
outstanding Fiscal Invoices will be sent. Fiscal Invoices that have already been sent successfully will not be sent 
again when this function is triggered or used. 
 
To configure and use this function, a button will need to be created on your POS Screen which will be pressed when 
required. 
Go to: Setup > POS Screen > POS Screen Setup > Select a Layout > Buttons 
Find a suitable POS Screen tab at the bottom of the screen where you would like the "Retry Fiscal Receipts" button 
be located and click on it. 
Then find a blank button within the tab to create the button. 
Configure the button as follows: 
Select the "User-Defined" option from the list of available functions, then enter "FISCALRETRY" into the Automatic 
Text Field. 
Enter the desired button caption into the Button Caption field. The appearance can also be customised as required.  
Once the button has been configured, press "Save" to save the button: 
 

 
 
Close the POS Screen Layout windows and return to the POS Screen via the “POS” button on the Back-Office 
Dashboard. 
 
When there are any issues which prevent Idealpos from communicating with the ESDC, the “Retry Fiscal Receipts” 
button can be pressed which will trigger Idealpos to reattempt the sending of any unsent Fiscal Invoices to the 
ESDC. Note that pressing this button will not re-send Fiscal Invoices that have previously been sent successfully. 
Only unsent Fiscal Invoices will be sent when using this function. 


