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Address Autocomplete  

IP-5125 ð Address Autocomplete Functionality [beta]  

This function adds the ability to utilise the Address Autocomplete function which has been implemented on the 

Customers, Suppliers, Clerks and Pending Sales screens. 

As an address is entered into the address field of any of the abovementioned screens, Idealpos will dynamically display 

a list of suggested addresses that match the input that has been entered so far.  

Once the user sees a suggested address on-screen that matches the complete address they are entering, they can click 

on the address in the list and Idealpos will populate the entire address into the Address, Suburb, State and Postcode 

fields.  

 

This function is enabled via a licensed module based on the number of lookups performed per month.  

Once this module has been enabled in the Licence, no further configuration is required, and the function will be 

available after performing a Close Suite/Open Suite; contact our sales team for further details about purchasing this 

module. 

 

Once this function has been enabled in the Licence Gateway, the function will be available in the following screens:  

 

¶ Customers (Back Office > File > Customers > Customers > Add/Modify) 

¶ Suppliers (Back Office > File > Suppliers > Suppliers > Add/Modify) 

¶ Clerks (Back Office > Setup > Clerks > Add/Modify) 

¶ Pending Sales (POS Screen > Add Items to Sale > Pending Sale Button, or POS Screen > Pending Sale Button 

> Select Pending Sale > Modify) 

 

When entering part of a Customer Address, the suggested addresses will be displayed: 
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After an Address is selected, all Address fields are populated with the selected address. 
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Bookings  

IP-5212 ð TicketSocket Interface  

This function enables the integration of the TicketSocket Interface in Idealpos. 

TicketSocket is a white label ticketing and registration control interface that enables the redemption of TicketSocket 

tickets via the Idealpos POS Screen. 

TicketSocket will customise their ticketing solution for your brand using your company logo and to suit your 

requirements. 

 

Once this has been done, TicketSocket can be enabled in Idealpos so that TicketSocket Tickets can be redeemed from 

the Idealpos POS Screen. 

 

As this is an integration that is tailored for specific customers, the process for configuring  and using TicketSocket with 

Idealpos is outlined  in the User Guide. 

In the User Guide, go to: Bookings > TicketSocket.   

https://userguide.idealpos.com.au/
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EFTPOS 

IP-5182 ð Support for  Paymentree Prepaid/Partial Payment  

This function adds support for Paymentree Prepaid/Partial Payment. 

When a Prepaid card with a limited balance is used to make a partial sale payment through Paymentree, the partial 

payment will now correctly apply to the  sale in Idealpos.   
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Export Data  

IP-5127 ð Stock Items Export ð Support for Promotion Description  

This function adds the ability to include the first Promotion that references a Stock Item in the Stock Item Export.  

Note that the Priority Order of your Pro motions DOES NOT affect which Promotion will be displayed in the Stock Item 

Export. Idealpos will export the first Promotion that it finds which references the Stock Item. 

 

The logic that determines which Promotion Description will be exported is as follow s: 

The description of the first Promotion that is found which references the Stock Item will be exported.  

If a Promotion cannot be found which directly references the Stock Item, it will then export the first Promotion that 

references the Departments. 

Promotions which link to ôAll Itemsõ or ôAny Itemõ will not be exported. 

 

The below contains a few examples and which Promotion description will be exported: 

 

¶ Stock Item is directly referenced by multiple Promotions ð The description of the first Promotion tha t 

references the Stock Item will be exported.  

¶ The Stock Itemõs Department is referenced by a single Promotion AND the Stock Item is also directly 

referenced in another promotion ð The description of the Promotion  that directly references the Stock Item 

will be exported. 

¶ The Stock Itemõs Department is referenced by multiple Promotions ð The description of the first Promotion 

that references the Stock Itemõs Department will be exported. 
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To use this function, go to: Back Office > Utilities > Export Data > Stock Items 

Export: Specific Fields by Range or Automatic Export Format 

 

Export Folder: Enter a folder location where the exported data should be written to (e.g. C:\Export) 

Filename: Enter a filename for the exported data (e.g. StkItems.txt) 

Enable the required checkbox options (e.g. Append Date/Time to filename, Include Headers). 

 

Export Specific Fields by Range: Select the fields required. 

To demonstrate this function, the following fields have been selected: 

1: CODE 

2: DESCRIPTION 

3: DPT 

4: DPT DESCRIPTION 

5: PROMODESCRIPTION 
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If required, the ôSave Defaultsõ button can be pressed on the top-left corner so that each time this function is used, it 

will be pre-filled using the selections that have been made. 

Press the ôOKõ button to export the data.  

 

If Automatic Export Format was selected, press ôSave Formatõ to save the change. When the Automatic Export runs, the 

Promo Description will be included in the exported data.  

 

While the data is being exported, a progress bar will appear at the bottom of the window.  

 

 
 

Once complete, an ôExport Completeõ prompt will be displayed. 
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The Exported Data will contain the Promo Description, similar to the below example: 
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Function Descriptors  

IP-5114 ð Tender Functions ð Give Change in Local Currency option  

This function will enable a Tender to be over-tendered and give the change in CASH. 

 

To configure this function, go to:  

Back Office > Setup > Function Descriptors > Select a Tender between TENDER 2 and TENDER 18 > Modify. 

Toggle the checkbox ôGive Change in Local Currencyõ as required. 

 

Note that the following logic applies to each tender when over -tendering: 

Cash Tender ð When over-tendered, change is given in Cash. 

EFTPOS tender ð When over-tendered, change is given in Cash. 

Credit/Non -Credit Tender ð Does not give change, unless the ôGive Change in Local Currencyõ option is enabled. 

 

Press the ôSaveõ button on the top-left corner of the Modify Function Descriptors screen to save the change. 
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Ideal Handheld/Pocket Pad  

IP-1790 ð Ideal Handheld ð Support for Orders to show in Journal History  

This function enables orders placed to tables via Ideal Handheld/Pocket Pad to appear in the Journal History Enquiry. 

This can be useful for tracking the placement of orders to a table. 

 

This function does not need to be enabled nor require any additional configuration.  

 

From Ideal Handheld or Pocket Pad, select a Table from the Table Map and press ôStart Orderõ. 

 

 
 

If prompted, enter the number of Covers > OK  
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Add Items to the order > Send > Finalise 

 

 
 

Press Send Order 
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Success ð Order Sent 

 

 
 

Go to: Back Office > Enquiry > Journal History 

The order will appear in the Journal History Enquiry. 
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The Activity Log will also show that the Table was sent to the Kitchen (Table # (WP) sent to Kitchen). 

 

Go to: Back Office > Enquiry > Activity Log. 

The Table number and (WP) will appear as being sent to Kitchen. 
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Import Data  

IP-3730 ð Metcash ð Support for new ALM Invoice DAT format  

This function adds the ability for Idealpos to support the importing of files using the new ALM (Australian Liquor 

Marketers) Invoice DAT format files which are supplied by Metcash. 
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Kitchen Dockets  

IP-5188 ð Kitchen Printing ð Option to Accumulate with Instructions (Order by P rint Group)  

This function adds the ability to enable Accumulate Items with Instructions . 

Previously, it was possible to only enable Accumulate Items which would accumulate Stock Items on the Kitchen 

Docket, but if any Instructions were added, then the Stock Item and Instructions would not accumulate. 

 

The ôAccumulate Items with Instructionsõ option is now available when using the following Kitchen Docket Formats: 

¶ Order by Print Group 

¶ Order by Seat/Print Group 

¶ Order by Print Group/Seat 

 

When enabling this option, the Accumulate Items option must be enabled first  which will then trigger the ôWith 

Instructionsõ option to appear so that it can be enabled. 

When both ôAccumulate Itemsõ and ôwith Instructionsõ are enabled, multiples of the same Stock Item with the same 

instructions will be accumulated. 

It should be noted that  when an item contains more than one instruction , the Stock Item with instructions will only be  

accumulated when the instructions are added in the same order to each item. 

 

Example 1: Instructions are added in the same order for each item. 

A Cappuccino is added to the sale, then the instructions Extra Hot, then Extra Choc are added. 

Another Cappuccino is added to the sale, then the instructions Extra Hot, then Extra Choc are added. 

 

In this example, both Cappuccinos with the  instructions will be accumulated, as the instructions have been added in 

the same order for each of the Cappuccinos that were added to the sale. 

 

Example 2: Instructions are added in a different order for each item. 

A Cappuccino is added to the sale, then the instructions Extra Hot, then Extra Choc are added. 

Another Cappuccino is added to the sale, then the instructions Extra Choc, then Extra Hot are added. 

 

In this example, the Cappuccinos will not be accumulated as the instructions for each Cappuccino were added to the 

sale in a different order. 
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To configure this function, go to:  

Back Office > Setup > Global Options > Printing > Print Formats > Kitchen Docket Format 

 

Select one of the following Kitchen Docket Formats: 

¶ Order by Print Group 

¶ Order by Seat/Print Group 

¶ Order by Print Group/Seat 

 

To demonstrate this function, the ôOrder by Print Groupõ function will be selected. 

Enable ôAccumulate Itemsõ.  

Enabling ôAccumulate Itemsõ will trigger the ôWith Instructionsõ option to appear.  

Enable ôWith Instructionsõ. 
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Close the Global Options window, then go to POS Screen. 

 

Add the following Stock Items and Instructions in the following order:  

Cappuccino > Extra Hot > Extra Choc 

Cappuccino > Extra Hot > Extra Choc 

 

 
 

The items will appear in the sale window similar to the below example when added in the order listed above. 
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Finalise the sale by pressing Enter > Select a Tender. 

Alternatively, save the sale to a table by pressing the Table Map button > select a table > enter number of covers > OK 

 

When the Kitchen Docket is printed, the Stock Item and the Instructions will both accumulate as per the example 

shown in the below Kitchen Docket printout.  

 

 
 

If the same items are ordered with the ôWith Instructionsõ option disabled, the items will print to the Kitchen Docket as 

follows (no accumulation): 

 

 
 

Additional  examples of Kitchen Dockets for each of the Kitchen Docket Formats [Accumulate With Instructions] can be 

found in Print Formats section within the Global Options > Printing topic  of the User Guide.  

https://userguide.idealpos.com.au/Content/Global%20Options/Printing.htm#Print_Formats
https://userguide.idealpos.com.au/Default.htm#Global%20Options/Printing.htm
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IP-5189 ð Entire Order to Triggered Kitchen Printers ð Order by Print Group Formats  

This function adds the option ôPrint Entire Order to triggered Kitchen Printersõ to the Order by Print Group Formats. 

Prior to this change, the option  ôPrint Entire Order to triggered Kitchen Printersõ was only available when using the 

Kitchen Docket Format ôGroup Instructions by Seatõ. 

 

The ôPrint Entire Order to triggered Kitchen Printersõ is now available when using the following Kitchen Docket Formats: 

¶ Order by Print Group 

¶ Order by Seat/Print Group 

¶ Order by Print Group/Seat 

 

When the ôPrint Entire Order to triggered Kitchen Printersõ is enabled with the ôAll Optionsõ option selected, the entire 

order that was placed will be printed to all Kitchen Printers that have been triggered. 

For example, there are four separate Kitchen Printers: Mains, Pizza, Pasta and Bar. 

There are four items in these Sales Categories:  

Main [Food Sales Category] 

Pizza [Food Sales Category] 

Pasta [Food Sales Category] 

Beer [Beverage Sales Category] 

 

Example 1 : An order is placed that only contains a Pizza ð Only the Pizza will print to the Pizza Printer. 

Example 2 : An order is placed that contains a Pizza and Pasta ð Pizza and Pasta will print to the Pizza Printer and Pasta 

Printer. 

Example 3 : An order is placed that contains a Pizza, Pasta and Main ð Pizza, Pasta and Main will print to the Mains 

Printer, Pizza Printer and Pasta Printer. 

Example 4 : An order is placed that contains a Pizza, Pasta, Main and Beer ð Pizza, Pasta, Main and Beer ð Pizza, Pasta, 

Main and Beer will print to the Mains Printer, Pizza Printer, Pasta Printer and Bar Printer. 

 

To prevent Food Items from being printed to the Bar Printer, the ôFoodõ Sales Category can be selected. 

When the ôFoodõ Sales Category is selected, the system will behave the same way as described in the examples above 

except for example 4.  

 

Example 4 when Sales Category is set to ôFoodõ (order is placed that contains a Pizza, Pasta, Main and Beer) ð 

Pizza, Pasta and Main will print to the Mains Printer, Pizza Printer and Pasta Printer. The Beer item will only print to the 

Bar Printer. 
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Go to: Back Office > Setup > Global Options > Printing. 

In addition to the existing Kitchen Docket Format ôGroup Instructions by Seatõ which already contained support for this 

function, t he options which can now utilise this function  are shown in the below examples: 
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POS Screen Setup 

IP-5179 ð POS Screen ð New Customer Function  

This function adds the ability to create a POS Screen button linked to the New Customer Function, enabling the Clerk 

direct access to the New Customer Function via a dedicated POS Screen button. 

Prior to this enhancement, the New Customer Function on the POS Screen could only be accessed via the Customer 

Search button > New Customer. 

 

To configure and use this function, go to:  

Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

 

Click on the desired POS Screen Tab where a button for this function is required, then locate a blank button and 

configure it as follows: 

 

Function: New Customer 

Button Caption: New Customer 

Configure/Customise the button appearance as desired. 

 

Press ôSaveõ to save the button. 
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Close the POS Screen Layout windows, then press the ôPOSõ button from the Back Office Dashboard. 

Click on the POS Screen tab that contains the button and press it. 

 

The New Customer function is displayed on the POS Screen. 
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Enter the New Customerõs details, then press ôOKõ. 

The only compulsory field is the Last Name, however, it is recommended that all possible details be entered in the 

event that the customer needs to be contacted. 
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The Customer record is created, then the customer is added to the sale. 
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This function also obeys the Yes/No Option ôFast Customer Modify can modify Credit Limitõ, and when enabled, the 

Credit Limit field will be displayed on the New Customer screen. 

To enable this function, go to:  

Back Office > Setup > Yes/No Options > Search: credit limit > Enable ôFast Customer Modify can modify Credit Limitõ. 

 

 
 

When this Yes/No Option is enabled, the New Customer screen will display a Credit Limit field which can be used to 

enter the Customerõs Credit Limit. 
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In addition to the Credit Limit field, the Customer Code field can also be displayed as an editable field on the New 

Customer screen. To display the Customer Code field, enable the Yes/No Option ôFast Customer ð New Customer Code 

Fieldõ. 

Go to: Back Office > Setup > Yes/No Options > Search > ônew customer codeõ. 

Enable the Yes/No Option ôFast Customer ð New Customer Code Fieldõ. 

 

 
 

The New Customer screen will display the Customer Code field. 

 

 
  



 Update History 
Return to top  

Idealpos 8 Build 10 - Update History  Page 28 of 63 

 

POS Terminal Settings  

IP-5178 ð Customer Display ð Option to show Customer Account Balance  

This function adds the ability to show the Customer Account Balance on the Customer Display Screen. 

This function requires that the POS Terminal has a Customer Display Screen configured and enabled. 

This function is only available on the following Display Formats: 

¶ Small Sales with Company Logo 

¶ Full Height Sales with Company Logo 

 

To enable this function, go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify. 

In the Display/Kiosk tab, enable the ôShow Customer Balanceõ checkbox. 

As mentioned above, this function is only available on the Small Sales with Company Logo or Full Height Sales with 

Company Logo Display Formats. 
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Close the POS Screen Setup window. 

From the Back Office Dashboard, press the ôPOSõ button to display the POS Screen. 

Add a Customer to the sale via the Customer button. 

The Customerõs Balance will be overlayed over the Company Logo portion of the Customer Display Screen. 

 

 
 

For the above Customer Display example, the Customerõs record appears as follows on the POS Screen. 
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Reports  

IP-5153 ð A4 Invoices ð Override Header/Footer Image by Customer Ty pe 

This function enables the ability to override the Header and/or Footer Image that is displayed on the Customerõs 

Invoice, based on the Customer Type that the Customer is associated with. 

A custom header image can be set for cases where you may want to display a custom rewards club branding graphic 

or similar which reflects the Customer Type that the customer is linked to. 

A custom footer image can be set for cases where you may want to list different payment details for each Customer 

Type, along with any graphics or imagery that are specific to the Customer Type that the customer is linked to. 

 

The way this function works is that if an Override Header and/or Footer Image has not been set for the Customer Type, 

then Idealpos will use the Header/Footer Image that has been configured in the Global Options. 

If an override image is not set and an image is not specified in the Global Options, then no image will be shown on the 

Customerõs invoice. 

 

To configure this function, go to:  Back Office > Setup > Global Options 

Ensure that a Company Logo Graphic (displayed on the Invoice Header) and Invoice Footer Graphic are selected. 

The images should be in the Idealpos Pictures folder, which is located hereê  

C:\ProgramData\Idealpos Solutions\Idealpos\Pictures 

 

The maximum pixel size of the Company Logo image can be 330 pixels wide x 90 pixels high. 

The maximum pixel size of the Invoice Footer Graphic image can be 710 pixels wide x 192 pixels high. 
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Close the Global Options window to save any changes. 

The images specified in Global Options will be used when an Invoice is produced for a Customer that belongs to a 

Customer Type which does not have an Override Header/Footer Image configured. 

 

To configure the Override Header/Footer Image by Customer Type, go to: 

Back Office > File > Customers > Customer Types > Select a Customer Type > Modify 

 

Specify the filenames of the override images in the A4 Invoice Override Header Image and A4 Invoice Override Footer 

Image fields. In the same way as the images were configured in Global Options above, the images must be placed in 

the Idealpos Pictures folder which is in C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\. 

The maximum image resolutions are also the same as they were for the images that were configured in Global 

Options. 

The maximum pixel size of the A4 Invoice Override Header Image can be 330 pixels wide x 90 pixels high. 

The maximum pixel size of the A4 Invoice Override Footer Image can be 710 pixels wide x 192 pixels high. 
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After the Override Header/Footer Images have been selected, press the ôSaveõ button. 
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Close the Customer Types window, then go to: 

Back Office > Reports > Customers > Customer Invoices 

Specify the selection criteria for the Customer Invoices Report and press ôViewõ. 

 

Any Customers that are linked to the Customer Type containing the overridden Header/Footer Images will display 

those images on their Customer Invoices. 

 

 



 Update History 
Return to top  

Idealpos 8 Build 10 - Update History  Page 34 of 63 

 

Customers/Cash Sales that are not linked to a Customer Type which does not have an Override Header/Footer image 

configured will display the standard images that are configured in the Global Options.  
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IP-5194 ð Stock Item Sales Report ð MDI Functionality [beta]  

This function adds MDI (Multiple Document Interface) functionality to the Stock Item Sales Report. 

This means it is now possible to run a Stock Item Sales Report, then resize the full screen report to a smaller window.  

This functionality will enable multiple Stock Item Sales Reports to be run concurrently, making it possible to compare 

reports side-by-side on the same screen.  

In addition, the ability to access other Idealpos Back Office functions is now possible while viewing the Stock Item 

Sales Report. 

While it is possible to reposition the Stock Item Sales Report on a screen running at a resolution of 1024x768 and 

access other Back Office functions, it wonõt be possible to display multiple Stock Item Sales reports side by side on this 

resolution. 

Therefore, a resolution of 1920x1080 is recommended to utilise this function. 

Even greater usability of this function can be attained by using a screen resolution of 3840x2160 on supported 

monitors. 

 

To use this function, go to: Back Office > Reports > Sales > Stock Item Sales 

Specify the required selection criteria and press the ôViewõ button on the top-left corner of the Stock Item Sales 

selection criteria window.  

On larger resolution screens, the Stock Item Sales Report selection criteria window will be displayed as a window, as 

shown in the below example: 
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After pressing ôViewõ on the selection criteria window shown above, the Stock Item Sales Report will be displayed as a 

full-screen window. 

Press the resize button located on the top-right corner next to the close button to resize the report to a smaller 

window. 

 

 
 

After resizing the report to a window, other Idealpos Back Office functions can be accessed. 

To drag the Stock Item Sales Report window to another location on the screen, position  the mouse cursor into the 

area shown, then click and hold the mouse button and drag the window to the desired location on the screen .  

Release the mouse button  to drop the window to the position . 
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After repositioning the Stock Item Sales Report window, menu options in the Idealpos Back Office can be clicked to 

access other functions. 

 

 
 

It is also possible to run multiple Stock Item Sales Reports and display them side-by-side. 

Click onto the Stock Item Sales window to bring focus back to the Stock Item Sales Report selection criteria screen. 

Modify the Stock Item Sales Report selection criteria and press ôViewõ to run another Stock Item Sales Report. 

 

 
  



 Update History 
Return to top  

Idealpos 8 Build 10 - Update History  Page 38 of 63 

 

Another Stock Item Sales Report window is displayed. 

Resize the window using the resize button on the top-right corner of the  report  window (next to the close button).  

Two Stock Item Sales Reports are now displayed on-screen. 

The Stock Item Sales Report windows can be dragged around on the screen and repositioned side-by-side so that they 

can be viewed concurrently for comparison. 

This process can be repeated as many times as required; there is no limit to the number of concurrent Stock Item Sales 

Report windows that can be displayed concurrently. 

 

 
 

Note that the main Stock Item Sales Report selection criteria window can also be closed, and any Stock Item Sales 

Reports will remain on-screen. 
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Any Report Shortcuts (created by pressing the ôSõ button on the top-right corner of the report) will also  support the 

MDI (Multiple Document Interface) functionality when running reports via the Back Office shortcut.  

 

Create the report shortcut by pressing the ôSõ button on the top-right corner of the report.  

 

 
 

Enter a Shortcut Name, select the Shortcut Group, then press ôSaveõ. 

 

 
 

The report is added to the Favourite Reports. 
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Selecting the Shortcut from the Favourite Reports will run the report and the report will contain the resize button, 

enabling the report to be resized and making it possible to run additional reports side -by-side, or access to other Back 

Office functions. 

 

 
 

Also note that the resize button will appear for all types of reports when theyõve been run via a Back Office Shortcut. 

The below example shows various Report Types that have all been run via a Back Office Shortcut, all resized and 

displayed concurrently. 

 

 
  
















































