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Idealpos 7.1 Build 5

Update Details:

** Enhancements
* [IP-3045] - Newbook Interface - Tax Flag option
* [IP-3058] - Speed Improvement for Finalizing Sales with large number of Stock Transactions
* [IP-3059] - PAX Eftpos - TSYS Payments Support
* [IP-3086] - Macros support for Delays between functions
* [IP-3092] - Journal History Report - option to Show Tenders Only



EFTPOS

PAX EFTPOS - TSYS Payments Support

This function adds the ability to configure the PAX EFTPOS payment integration with TSYS Payments
(https://www.tsys.com/). This is supported through an additional SETVAR Command section within the Setup > POS
Terminals > Modify > EFTPOS Settings screen.

To configure PAX EFTPOS for TSYS Payments, go to:
Setup > POS Terminals > Select the Terminal > Modify > EFTPOS Settings

Within the EFTPOS Settings tab, the EFTPOS Type must be set to PAX.

A SETVAR Command section will appear on the bottom-right corner of the window.

A pre-filled set of Var Names will be displayed (UserName, UserPassword, MID, DevicelD and EDC Type of CREDIT).
Enter the Var Value into the Var Value fields as supplied by TSYS.

If any Var Names have changed or additional names required, you can add them to any blank Var Name/Var Value
fields.

Once the details supplied by TSYS have been entered, press the “Run Command” button to set the variables.

t inal Main S Receipt Kitchen Display / Customer Other EFTPOS Import /
pos terminals Settings Settings Printer Printers Kiosk Readers  Peripherals Settings Export
EFTPOS Settings EFTPOS
Disable
EFTPOS Type | PAX j

v Allow multiple EFTPOS Tendering
v Automatically choose Tender Type based on Card Type
Pinpad IP Address 192,168.15.200
Port 10009

v Enable Integrated EFTPOS post-transaction Tips

Function to Use TIPS IN j

Connect

SETVAR Command
Var Name Var Value

UserName
UserPassword
MID

DevicelD

EDCType CREDIT Run Command



https://www.tsys.com/
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Macros

Macros support for Delays between functions

This function adds the ability to specify a delay between two characters that are entered in a macro through the use
of a {D} character.

Due to the way macros work (a block or sequence of characters are inputted into Idealpos when triggering the macro),
any characters or sequence of characters that a macro passes back to Idealpos may be entered too quickly, especially
if a new window or dialog appears which takes a few moments to appear.

This can result in the macro not behaving the way you intended (e.g. characters from the macro not being entered into
the correct window or characters that exist in the macro aren’t passed to Idealpos correctly).

Therefore, an additional delay character can be entered between other characters in order to introduce a delay in the
macro, allowing the macro to function as expected.

To use this function, go to:
Setup > Keyboard Program> Add
Then press the Key on the keyboard that you want to have programmed to the function.

keyboard program X

Mone

Customer Coupons -
Customer Statement
Date

Delivery Docket
Delivery Job
Department

Dpt Sales Report
Drawer 1 Clerk
Drawer 2 Clerk
Duplicate Receipt
EAN

EFTPOS CashOut
EFTPOS Functions
EFTPOS RePrint
Eftpos Reversal Function: [None
EFTPOS Settlement
Employee Log

End of Shift

EPay Products —
EPay Reprint
External Application
Gift Voucher Enquiry
Hold Print

Home Screen

Item Discount
Journal Enquiry
Journal History
Layaway Adjustment
Layaway Cancellation
Layaway Credit
Layaway Payment
Machine Lookup
Macro

Manual Maodifier
Manual Tare
Member Number
No Sale

Key: Press Key to be Programmed...




After pressing the desired key, the key will appear in the Key field.
In the below example, the F1 key was pressed and is therefore displayed in the Key field.

keyboard program X

MNone

Customer Coupons -
Customer Statement
Date

Delivery Docket
Delivery Job
Department

Dpt Sales Report
Drawer 1 Clerk
Drawer 2 Clerk
Duplicate Receipt
EAN

EFTPOS CashOut
EFTPOS Functions
EFTPOS RePrint
Eftpos Reversal Function: [None
EFTPOS Settlement
Employee Log

End of Shift

EPay Products |
EPay Reprint
External Application
Gift Voucher Enquiry
Hold Print

Home Screen

Item Discount
Journal Enquiry
Journal History
Layaway Adjustment
Layaway Cancellation
Layaway Credit
Layaway Payment
Machine Lookup
Macro

Manual Maodifier
Manual Tare
Member Number
No Sale

Key: F1
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Finally, assign a function to the key from the list of functions on the left-hand side of the Keyboard Program window.
In this example, we have selected the Customer function.

Enter a Customer code into the Automatic Text field in order to add that customer to the sale automatically.

Once configured, press the “Save” button on the bottom-right corner of the screen.

keyboard program X

Customer

Bar Tab Preauth -
Bar Tab Preauth Void
Blackboard

Cash Dispenser
Clear

Clerk

Clipp Tabs Enquiry
Coupon Promation
Course Separator
Credit Mote Enquiry
| |Customer

Customer Coupons
Customer Statement

Key: |F1

Date | |
Delivery Docket Function: |Customer |
Delivery Job oy

Department

Dpt Sales Report
Drawer 1 Clerk
Drawer 2 Clerk
Duplicate Receipt
EAN

EFTPOS CashOut
EFTPOS Functions
EFTPOS RePrint
Eftpos Reversal
EFTPOS Settlement
Employee Log

End of Shift

EPay Products

EPay Reprint
External Application
Gift Voucher Enquiry
Hold Print

Home Screen

Item Discount
Journal Enquiry
Journal History -

Automatic Text 13




Repeat the above process for another function.
The below function used is “Sale Reference” with a Key of F4 assigned to the function.

keyboard program X

Sale Reference

Reservations -
Rewards Enquiry

Reweigh

Safe Drop

|Sale Reference |
Sale Type

Scale On/Off

Seat Number

Send Message

Stock Item

Stock Item Edit

Stock Item Sales

Stock Item Search Key: F4
Stock Level Enquiry
Stock Location Function: |Sale Reference

Stock Motes
Subtotal Discount
Table

Table Summary
Tax Invoice

Tax Shift

Tender

Tender Correct
Text Entry (Hash)
Text String

Ticket

Transfer Mode
Type Text

Unlock Permissions
User-Defined
Validation Print
Void

Void Entire Sale
Void Last Item
Void Line

Void Maode
Waste Made

X -
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Now that the functions have been assigned to keys, the macro can be configured on a POS button.
This can be done by going to: Setup > POS Screen > POS Screen Setup > Select Layout > Buttons

Select a blank button and configure the button using the “Macro” function.

In the Automatic Text field, enter the keys to the functions created earlier surrounded by curly braces {}.
l.e. Enter {FTH{D}{F4}

Add a {D} between the F1 and F4 keys to trigger a delay, allowing the macro to function correctly.

Enter the Button Caption that you want assigned to the button, then press the “Save” button to save.

Macro

Automatic Text {F1HDHF4}

Button Appearance

Macro

Graphic

Format All

Button Caption
Macro

Back Colour Font

Text Colour A - | a

[] Double wWidth
[] Double Height

Visible

=

Save Cancel

| Macro

Layaway Credit
Layaway Payment
Machine Lookup

Manual Modifier
Manual Tare
Member Number
Mo Sale

Mone

Order Mumber
Pager System
Paid Cut

Pay Bar Tab
Pending 5ale
POS Screen Grid
POS Screen Menu
Prefix 5tring

Price Enguiry
Price Level

Print Bar Tab Eill
Print Bar Tab Report
Print Group Shift




Close the POS Screen Setup/POS Screen layout screens, then open the POS Screen via the POS button on the top-left
corner of the back-office dashboard window.

Press the new button on the POS screen which was created to trigger the macro.

The customer number configured within the macro (in this example, customer 13) will be added to the sale, then the
Sale Reference screen will appear.

Nov 07 09:31 Adult ID: Nov-07-2001
Jererny PRICE1

Elizabeth Willis - 0 Points
RECEIPT CLERK

PRICE LEVEL 5% ST DISC

CUSTOMER 5% ITEM
BAR TAB REFUND
PENDING  VOID SALE

0 Points TABLE MAP VoID ENTER

SCHOOL
BOYS SHORTS BOYS SHIRTS BOYS PANTS ... BOOKS ITEMS H

The delay character {D} is not limited to the above functions/macro. It can be used in other cases that trigger
multiple functions and a delay is required between each key/function that is triggered in a macro.
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If the delay character {D} is removed from the macro and the POS screen button assigned to the macro is pressed, the
Sale Reference window is not displayed:

ICE 1
Elizabeth Willis - 0 Points
RECEIPT CLERK

PRICE LEVEL 5% ST DISC
CUSTOMER 5% ITEM
BAR TAB REFUND

PENDING VOID SALE

TABLE MAP VoID

0 Points $OOO

BOYS SHORTS BOYS SHIRTS BOYS PANTS  GIRLS SHORTS @ GIRLS SHIRTS @ GIRLS SKIRTS

Alexandria

ELECTRICAL

Elliot

CAFE TAP BEER SPIRITS RETAIL MANAGER

DRINKS e COCKTAILS  FRUIT & VEG GROCERY
RESTAURANT & RTD ) WINE SERVICES ADMIN




Reports

Journal History Report — Option to Show Tenders Only

This function adds the ability to run the Journal History Report with a checkbox option to “Show Tenders Only”.
Running the report with this option enabled will hide all journal details and will only show the total amounts that were
paid, along with the type of tender used to make the payment.

To use this function, go to: Reports > Sales > Journal History
Select the required Date/Date Range, then enable the “Show Tenders Only” option.
Finally, press the “View" button on the bottom-right corner to run the report.

journal history report X

Date Range
From 07 Nov 2019 00:00:00 ~
Taday j J
To 07 Nov 2019 23:5%:59 j
Group by Options

Clerk
& Show Totals/Tendering

POS Syst
.ys em lshow Tenders Onlyf
Location
Selection Range
Clerk Code = to =
Clerk Name = to =
Location = to =
>

POS System
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A list of tenders will be displayed along with the amounts paid for each journal.

deslpos Demo MNOT-FOR-RESALE™
POS 1(1)

Journal History

07 Mow 2019 00:00:00 to 07 Nov 2015 23:55:55

Printed 07/11/201

07117201
OTM17201

001382 Jeremy
001383 Jeremy

[T
En i
in

CASH 10.00
CASH 3800

When running the report without the “Show Tenders Only” option enabled, the report will appear similar to the below:

|dealpos Deme <“MOT-FOR-RESALE™
FOS 11}

Journal History
07 Mov 2019 00:00:00 to 07 Mowv201% 23:55:55

Printed 07/11/201

Fage 1

2 12:03:40

of 1

0712015 09:31:32 001355 Jeremy
WOIDENTIRE SALE 0.00

07112019 05:33:48 001380 Jeremy
WOIDENTIRE SALE 0.00

07M1/2019 05:34:28 001361 Jeremy
WVOIDENTIRE SALE 0.00

07112019 11:53:38 001362 Jeremy
202001 CAPPUCCINO 3.50
202002 FLAT WHITE 3.50
202004 SHORT BLACK 3.00

077112019 11:55:24 001362 Jeremy
06002 BEEF 13.00
002014 WELL DONE 0.00
06008 PORK 13.00

2Z -4.00 Daily Specials 54 Off
08004 SEAFOOD 6.00
002008 GRILLED 0.00
22 Daily Specisls 34 Off -4.00




Room Interface

Newbook Interface — Tax Flag option

This function adds the ability to control whether or not tax transactions that are sent to NewBook will be charged as
Tax or Tax Free.

To configure/control this setting, go to:

Setup > Global Options > Interfaces > Room Interface

Toggle the Tax Flag option to control whether or not transactions sent to NewBook are Tax or Tax Free.
site 1 (Site 1) S X

Other
Optio

global options

General  Miscellaneous Purcha estaurant Customers nting Interfaces | Intel Printing Gaming

Room Interface
Interface Type MNewbook

Clipp Interface

Clipp Tender No Clipp Tender

POS Master# 1 Clipp Tips TIPS IM Qutput from POSE 1

Network Path C\newbook

Pay@Table Interface Tender Type NEWEQOK

+' Post Paid Transactions S Tax Flag

Tender No Tender Type
POS Master# 1 Tips TIPS IM

If exists, Auto choose Tender Type based on Card Type

Bev Con Interface

Falder
POS Master #

Pager Interface

Interface Type Unipage
IP Address

Port

epay Interface
Primary Server
Secondary Server
Retailer ID
Store ID

Username

Password

Gunnebo Interface

Folder =

Reservation Interface

Interface Type
IP Address
Port

Drinks Served
Entree Served
Main Served

Dessert Served

Customer Type

Bookings Interface
Interface Type
URL

AP Key

Tender Type

MNo Reservation Interface

5602 v Send Transaction Details

Link to User-Defined Status Buttons

DRINKS AWAY -
ENTREE AWAY -
MAINS AWAY -

-

DESSERT AWAY

RESERVATIOM

MNo Booking Interface

OMLINE




