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Build 56 

Update Details: 

** Enhancements 

    * [IP-678] - Network Printers - Support for Epson Series USB Connection via OPOS 

    * [IP-1947] - Warn when Selling Item below Cost Price 

    * [IP-2189] - RFID Wrist Strap support for Customer Codes 

    * [IP-2193] - Vault Eftpos option to Not Print Eftpos Receipt Automatically 

    * [IP-2217] - SmartConnect QR Code Support 

    * [IP-2240] - Dynamic Tab functionality toggles on Click 

    * [IP-2260] - Quest EftposPlus Check Printer Status for New Zealand 

    * [IP-2271] - Yes/No Option for Dynamic Screen Tab Functionality 

    * [IP-2285] - Filtered Overwrites include Account Customer Balances 

 

 

  



Back Office 

Dynamic Tab functionality toggles on Click 

This function improves on the Dynamic Tab functionality that was introduced in the previous build of Idealpos. 

The behaviour was updated so that when hovering the mouse cursor over any tab in Idealpos, the screen would 

dynamically switch to that tab without the need to click on the tab. After receiving feedback on this function, it has 

been further enhanced to allow the user to control this function to prevent the system from undesirably switching 

between tabs while making modifications to settings. 

 

This functionality has been enhanced on the following screens: 

 

• Yes/No Options (Setup > Yes/No Options) 

• POS Options (Setup > POS Terminals > Modify) 

• Global Options (Setup > Global Options) 

• Modify Customer (File > Customers > Customers > Select a Customer > Modify) 

• Modify Stock Item (File > Stock Control > Stock Items > Select a Stock Item > Modify) 

• Stock Item Enquiry (Enquiry > Stock Items) 

 

In order to use this functionality, the Dynamic Screen Tabs Yes/No Option must be enabled. This option is enabled by 

default, however, it may need to be re-enabled if it has previously been disabled. 

 

Go to: Setup > Yes/No Options > Enter Keyword Search: Dynamic Screen 

Then Uncheck the “Dynamic Screen Tabs” option to disable the Dynamic Screen Tabs functionality 
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To use this function, click on any tab in one of the above screens to toggle the Dynamic Tab functionality. After a tab 

has been clicked on, the system will temporarily disable the Dynamic Tab functionality and will remain in the tab which 

has been clicked on. After clicking on a tab, hovering over other tabs in that same screen will be disabled, however, 

you may still click on other tabs and the system will switch to those tabs. 

To re-enable the Dynamic Tab functionality, click on the tab that you are currently in and the Dynamic Tab 

functionality will be re-enabled. After re-enabling the Dynamic Tab functionality, the system will dynamically switch to 

tabs that the mouse cursor hovers over.  

In addition to toggling Dynamic Tab functionality by clicking on a tab, this functionality will also be disabled after 

modifying any setting within a tab. This will prevent the system from automatically switching between tabs while you 

are making any modifications to settings within a tab. 

Note that the Dynamic Tab functionality cannot be turned off permanently. As described above, simply clicking on a 

tab will prevent the system from dynamically switching to any other tabs when hovering the mouse cursor over them. 

 

To identify whether the Dynamic Tab functionality is currently enabled or disabled, pay attention to the tab name.  

If an orange rectangle outline appears around a tab name, the Dynamic Tab functionality is currently enabled.  

The below example shows the Dynamic Tab functionality enabled on the Yes/No Options – Clerks tab. 

 

 
 

After clicking on a tab, the orange rectangle outline around the tab name will disappear which indicates that the 

Dynamic Tab functionality has now been toggled off and if you hover over any tabs, the system will not switch to 

those tabs automatically. Modifying any setting within a tab will also disable the Dynamic Tab functionality.  

 

 
 

  



To use this function in Yes/No Options, go to: Setup > Yes/No Options 

 

 
 

In the Yes/No options, the Dynamic Tab functionality will be disabled after entering a value into the “Enter Keyword 

Search” field.  

 

 
 

The Dynamic Tab functionality will also be disabled if you click on any of the tabs at the top of the Yes/No Options 

screen (e.g. Clerks, Confirmation, Customers, etc.). 

When the Dynamic Tab functionality is enabled, an orange rectangle outline will appear around the tab name. 

 

 
 

When the Dynamic Tab functionality is disabled, the orange rectangle outline will not appear around a tab name. 
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Clicking on a setting text label in the Yes/No options screen will disable the Dynamic Tab functionality. 

The below example shows an outline around the setting text labels which can be clicked on to disable the Dynamic 

Tab functionality on the current screen. 

 

 
 

 

Clicking on a setting in the All or POS terminal number column will also disable the Dynamic Tab functionality.  

The below example shows an outline around the All and POS Terminal Number columns. Clicking on these columns 

will toggle the setting and will also disable the Dynamic Tab functionality on the current screen. 

 

 
 

  



To use this function on the POS Options screen, go to: Setup > POS Terminals > Modify 

 

  
 

Clicking on any tab will disable the Dynamic Tab functionality and keep you in the tab that you’ve clicked on. 

 

  
 

In addition, modifying any setting within a tab will automatically disable the Dynamic Tab functionality and will keep 

you within the tab of the setting that is being modified. Hovering over any tabs after modifying a setting will not 

automatically switch tabs. Dynamic Tab functionality can be re-enabled by clicking on the tab that you’re currently in.  
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To use this function on the Global Option screen, go to: Setup > Global Options 

 

 
 

Clicking on any tab will disable the Dynamic Tab functionality and keep you in the tab that you’ve clicked on. 

 

 
 

In addition, modifying any setting within a tab will automatically disable the Dynamic Tab functionality and will keep 

you within the tab of the setting that is being modified. Hovering over any tabs after modifying a setting will not 

automatically switch tabs. Dynamic Tab functionality can be re-enabled by clicking on the tab that you’re currently in. 

  



To use this function on the Modify Customer screen, go to:  

File > Customers > Customers > Select a Customer > Modify 

 

 
 

Clicking on the General or Advanced tab will disable the Dynamic Tab functionality and keep you in the tab that you’ve 

clicked on. 

 

  
 

In addition, modifying any setting within a tab will automatically disable the Dynamic Tab functionality and will keep 

you within the tab of the setting that is being modified. Hovering over any tabs after modifying a setting will not 

automatically switch tabs. Dynamic Tab functionality can be re-enabled by clicking on the tab that you’re currently in. 
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To use this function on the Modify Stock Item screen, go to:  
File > Stock Control > Stock Items > Select a Stock Item > Modify 
 

 
 

Clicking on the General, Advanced or Indirect Item tabs will disable the Dynamic Tab functionality and keep you in the 

tab that you’ve clicked on. 

 

 
 
In addition, modifying any setting within a tab will automatically disable the Dynamic Tab functionality and will keep 
you within the tab of the setting that is being modified. Hovering over any tabs after modifying a setting will not 
automatically switch tabs. Dynamic Tab functionality can be re-enabled by clicking on the tab that you’re currently 
in.  



To use this function on the Stock Item Enquiry screen, go to:  

Enquiry > Stock Items 

 

 
 

Hover over either the “Sales History” or “Stock Transactions” tabs, then click on the “>” button in the Code field. 

Select a Stock Item that you want to perform an enquiry on, then press “OK”. 

The Stock Item Enquiry screen will disable the Dynamic Tab functionality on the tab that you clicked on the “>” button 

and will remain on that screen. The Dynamic Tab functionality can also be toggled on/off by clicking on either the 

“Sales History” or “Stock Transactions” tabs. 

 

 
 

Modifying the selections in the Location or Period dropdown boxes will also disable the Dynamic Tab functionality. 
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Customer Readers 

RFID Wrist Strap support for Customer Codes 

This function adds the ability to use RFID Wrist Straps or RFID Cards for Customer Codes. This function will allow 

customers to be assigned with either an RFID Wrist Strap or RFID Card which can be used during a POS transaction to 

add the customer to the sale. 

 

To use this function, go to:  

Setup > POS Terminals > Select terminal > Modify > Customer Readers > RFID Reader 

 

 
 

By default, the “Clerk Wrist Bands” option will be enabled/checked and the Customers option will be 

disabled/unchecked. 

Enable the checkbox next to Customers to enable RFID functionality for customers. 

 

 



 

Close the POS Terminals screen to apply the change. 

To assign a customer with an RFID tag/fob, go to: File > Customers > Customers > Select a Customer > Modify 

 

 
 

At the top-right corner of the Modify Customer screen, you will see a “Scan Code” field as well as an “Other Codes” 

field. 

 

 
 

Either of these fields can be populated with a barcode from a card that can be scanned or an RFID code from a card 

which the customer or operator can tap against the reader. 

 

To populate the field with an RFID code, simply click into a blank Scan Code or blank Other Codes field. 
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Once the cursor is blinking inside the desired field, tap the RFID card against the card reader. 

The field will be populated with the data from the RFID card. 

 

 
The RFID card has been successfully programmed for the selected customer. 

Press the Save button located on the bottom right corner of the Modify Customer screen to save the change. 

 

 
 

  



Close the Customers screen, then open the POS screen. 

The RFID card can now be scanned from the POS screen and the customer will be added to the sale. 

 

 
 

The above process can be repeated for each customer that you want to assign with an RFID card.  
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EFTPOS 

Quest EftposPlus Check Printer Status for New Zealand 

This change modifies the behaviour for the printer status check for customers in the New Zealand region only. 

When tendering a sale using the EFTPOS Quest EftposPlus integration, a check will be performed to ensure that 

Idealpos can communicate with the printer. Should the printer be unavailable, the EFTPOS transaction will not proceed 

and Idealpos will display a message advising the operator to check the printer.  

After the printer connection is restored, the operator will then need to try tendering the sale off again using EFTPOS.  

If the printer connection has been restored and the printer is contactable, the transaction will proceed and will prompt 

for the EFTPOS card to be presented. After the EFTPOS card has been presented and transaction approved, the sale 

will finalise and the receipt will be printed by the printer. 

 

The printer check behaviour remains the same for customers in other regions. 

 

To use this function, go to the POS Screen and add items to the sale. 

 

 
 

  



Press the “ENTER” button to go to the Tender screen. 

Turn the receipt printer off.  

Then press the EFTPOS button. 

 

 
 

Idealpos may show the “Enter Cash-Out Amount” prompt. Press OK to continue. 

 

  
The “Need to check Printer. Cannot continue!” prompt will be displayed. 

This prompt is only displayed if the printer check is unsuccessful and the printer cannot be reached. 
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After pressing “OK”, Idealpos will take you back to the main sale screen. 

 

 
 

  



Check that the printer is available – as per the steps above, the printer was turned off for the purposes of 

demonstrating this function. Turn the printer on, then press the “ENTER” button on the Sale screen, then press the 

“EFTPOS” button on the Tender screen. 

 

 
 

Idealpos may show the “Enter Cash-Out Amount” prompt. Enter a Cashout amount if required, then press “OK”. 

 

 
Idealpos will show a prompt “PLEASE SWIPE OR INSERT CARD”.  
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After the card has been swiped or inserted into the pinpad and the transaction has been processed and approved, the 

receipt will be printed to the receipt printer.  



SmartConnect QR Code Support 

This function adds QR Code support to the SmartConnect EFTPOS integration.  

Any customers who have a Smart Phone can download the AliPay app and setup an AliPay account linked to their 

bank account. Once they have setup the AliPay app, they can pay for their items at the POS terminal by simply 

scanning the QR Code that is displayed on the SmartConnect pinpad terminal’s screen and the payment will be 

processed.  

Note that this function may only be available in specific regions and/or Countries – please refer to Smartpay for more 

information. 

 

Before this function can be used with Idealpos, the SmartConnect pinpad has to be configured so that it supports this 

feature. Please contact Smartpay for further instructions on how to enable this function on your pinpad. 

 

Once the QR Code Support function has been enabled on the pinpad, follow the below steps to configure Idealpos: 

 

Go to: Setup > Function Descriptors 

Find the next available Tender in the list, select it, then press the Modify button. 

Unused Tenders are typically named TENDER followed by the Tender ID. 

In the below example, TENDER 13 is the next available Tender which is currently unused. 
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After pressing the Modify button, enter a name for the tender (e.g. EFTPOS QR Code) and enable the required 

selections. Ensure that checkboxes have been enabled for “Credit Function”, “Show in Banking” and “EFTPOS”.  

Enable any other options/checkboxes as required.  

Press the “Save” button once the Tender has been setup as required. 

 

 
 

  



Close the Function Descriptors screen, then go to:  

Setup > Yes/No Options > Enter “inhibit tender” into the Enter Keyword Search field. 

Then remove the tick from the All column for the “Inhibit EFTPOS QR Code” tender as per the below screenshot. 

 

 
 

Close the Yes/No options screen to save the change. 
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Go to: Setup > POS Terminals > select terminal > Modify > EFTPOS Settings 

 

Click on the QR Code Tender dropdown box and select the “EFTPOS QR Code” option from the list.  

If you chose a different name, select the name of the tender you created from the list. 

 

 
 

Once the change has been made, close the POS Terminals screen. 

If you have more than one POS terminal using SmartConnect EFTPOS, select the next terminal from the list of POS 

Terminals, press the “Modify” button, then click on the EFTPOS Settings tab and repeat the above process of selecting 

the Tender from the QR Code Tender dropdown box. Once you have finished configuring each POS Terminal, close the 

POS Terminal screens and return to the Idealpos POS screen (press the POS button from the main Idealpos screen). 

 

  



Now that the QR Codes function has been enabled, add items to a sale then press the “ENTER” button to go to the 

Tender screen. The customer has the option to pay for their items using the traditional method of presenting their 

EFTPOS card, or they can pay for their items using the AliPay app on their Smart Phone. 

If the customer wants to pay using their EFTPOS Card, select the EFTPOS option from the Tender screen. 

If the customer wants to pay using the QR Code option, select the EFTPOS QR Code option from the Tender screen. 

 

 
 

After selecting the EFTPOS QR Code tender option, you may see an Enter Cash-Out amount screen if Cash-Out is 

enabled. Press OK if no Cash-Out is required, otherwise enter the CashOut amount. Note that using CashOut when 

paying with a QR Code is subject to being supported by Smartpay. 
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The top of the Idealpos POS screen will show EFTPOS Communications to show that it is communicating with the 

pinpad as per the below example. 

 

 
 

The pinpad will display a QR Code on-screen along with the amount that’s due for payment. 

 

 
 

 

  



Using the AliPay app, the customer will press the “Scan” button. 
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The AliPay app will then display the QR Code Scanner. 

Aim the Smart Phone camera at the QR Code so that QR Code is positioned within the centre of the blue square in the 

app. 

 

 
 

After the customer has scanned the QR Code using the AliPay app, the pinpad screen will show “QR Code 

PROCESSING NOW”. The PROCESSING NOW prompt will remain on the pinpad screen while the customer processes 

the payment in the AliPay app. 

 

 
 

  



The Customer will see a screen similar to the below which will show them the amount due. 

To proceed, they will press the “Pay now” button then they’ll be prompted to enter their password. Once the Password 

has been entered, the customer will press the “Pay” button to proceed with their payment. 
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After payment has been processed by the app, the customer will see a “Completed” message followed by a Payment 

Succeeded message as below. 

 

 
 

Shortly after the app has processed the transaction successfully, the pinpad will display a successful response and will 

print out a Customer Copy receipt as well as a Merchant Copy receipt. 

 

 
 

  



When running the Financial Report (Reports > Financial > Financial Report), sales tendered using the “EFTPOS QR 

Code” tender will be displayed separately from other tender types under the “AMOUNTS TENDERED FOR SALES” and 

“BANKING”. 
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Vault EFTPOS option to Not Print EFTPOS Receipt Automatically 

This function adds an option to stop EFTPOS receipts from printing when using Vault EFTPOS and receipts are turned 

off.  

 

To enable this function, go to:  

Setup > POS Terminals > Modify > EFTPOS Settings > EFTPOS Settings 

Enable the checkbox “Don’t automatically print EFTPOS Receipt when Receipts turned off” 

Once the change has been made, close the POS Terminal screens to apply the change. 

 

 
 

  



In order to toggle receipt printing on/off, a POS Screen button needs to exist. 

Go to Setup > POS Screen > POS Screen Setup > Buttons 

Look for a RECEIPT IS ON or RECEIPT IS OFF button. You may need to toggle between pages/tabs to see if the button 

exists on any existing page or tab. 

Should the button not exist, find a preferred POS Screen tab where you want the Receipt On/Off button to be created, 

then look for a blank button on the tab. 

Click on a blank button then select the “Receipt On/Off” function. 

Depending on the desired button appearance, you may want to enable the Double Width and/or Double Height 

options and pick a colour for the button using the Back Colour button: 

 

 
 

Press “Save” to save the button. 

 

You will also need to ensure that a RECEIPT button exists and if it doesn’t, create a Receipt button.  

In the event that the customer requires a receipt to be printed while receipt printing is turned off, the Receipt button 

can be used to trigger a receipt to print from the previous transaction. 

The Receipt button should be configured on the top right corner of the Idealpos POS screen. 

This ensures that the button is always displayed on the POS Screen and can be pressed at any time to trigger a receipt 

printout. 
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If a RECEIPT button doesn’t already exist, select an available button within the top right corner of the Idealpos POS 

Screen and assign it to the “Duplicate Receipt” function as per the below example. 

 

 
 

Press the “Save” button to save the change. 

Close the POS Screen Layout windows to return to the main Idealpos screen. 

Click on the POS button to open the POS Screen, then navigate to the tab where you saved the new button. 

The Receipt button will indicate whether receipt printing is currently turned on or off. 

In the below example, the Receipt button exists on the “MANAGER” POS Screen tab and it shows that “RECEIPT IS ON”. 

 



 
 

To turn receipt printing off, press the “RECEIPT IS ON” button. 

The button text will change to “RECEIPT IS OFF” to indicate that receipt printing has been turned off. 

 

 
 

You may now proceed and add items to the sale. 

After the items have been added to the sale, press the ENTER button to go to the Tender screen.  

Press the EFTPOS button and tender the sale using the integrated Vault EFTPOS. After the EFTPOS transaction has 

been approved, the sale will be finalised and a receipt will not be printed automatically. 

If the customer wants a receipt, press the RECEIPT button on the POS Screen as configured in the previous steps 

above. 

 

 
 

The receipt printer will produce a printout of the POS and EFTPOS receipt. 
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Network Printers 

Support for Epson Series USB Connection via OPOS 

This function adds a connection type of “OPOS” for the Epson TM-T88 printer type which can be used to connect the 

printer via a USB connection. 

 

To connect above printer type using a USB connection via OPOS, go to: 

Setup > Network Printers > Add 

 

Select “Epson TM-T88” from the Type dropdown box, select “OPOS” from the Connection dropdown box, enter the 

Device Name then select the POS System which the printer is physically connected to. 

Press the “Save” button to save the printer. 

 

 
 

  



Once the printer has been saved, set the POS Terminals which should use the printer by dragging the Printer Name to 

the Receipt Printer column for the POS Terminal. If desired, the OPOS printer can also be used for a Kitchen Printer – 

just drag the OPOS printer to the column of the Kitchen Printer that you want Kitchen Dockets printed to. 

In the below example, Café POS 1 and Bar POS have been configured to use the OPOS Printer as the Receipt Printer. 

 

 
 

Once the OPOS Printer has been assigned to the terminal(s), close the Network Printers window. 

 

Open the Idealpos POS screen. 

Ensure that Receipt Printing is turned on, then complete a transaction by adding items to the sale, then press the Enter 

button to go to the tender screen. 

 

Select a Tender type or cash amount. After the sale has been tendered, the receipt will be printed using the OPOS 

printer configured above. If the OPOS printer was assigned to any Kitchen printers, those printouts will also be printed 

to the OPOS printer. 
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Yes/No Options 

Dynamic Screen Tabs 

This function adds the ability to disable the Dynamic Screen Tabs functionality. This option is enabled by default and 

allows screen tabs to be changed using a mouse when hovering over the tab. When disabled, a tab in Idealpos needs 

to be clicked on in order to switch to the tab. 

 

Go to: Setup > Yes/No Options > Enter Keyword Search: Dynamic Screen 

Then Uncheck the “Dynamic Screen Tabs” option to disable the Dynamic Screen Tabs functionality 

 

 
 

The Dynamic Screen Tabs functionality will be disabled on the following screens. 

 

• Yes/No Options (Setup > Yes/No Options) 

 
 

• POS Options (Setup > POS Terminals > Modify) 

 
 

• Global Options (Setup > Global Options) 

 
 

• Modify Customer (File > Customers > Customers > Select a Customer > Modify) 

 
 

• Modify Stock Item (File > Stock Control > Stock Items > Select a Stock Item > Modify) 

 
 

• Stock Item Enquiry (Enquiry > Stock Items) 

 
 

• Modify Promotion (File > Sales > Promotions > Promotions > Modify) 

 
  



Warn when Selling Item below Cost 

This function enhances the behaviour of the existing option “Warn when discounting below Cost”. 

Previously, this option warned when an item was discounted below cost. Extra functionality has now been 

implemented to include the amount override function.  

When the operator uses the Amount Override function to sell an item below cost, Idealpos will now display a warning 

prompt asking them if they want to continue. 

 

To use this function, go to: 

Setup > Yes/No Options 

In the “Enter Keyword Search” field, enter “below cost”. 

Enable the tickbox in the All column next to the “Warn when discounting below Cost” option. 

 

 
 

Close the Yes/No options window, then open the Stock Items screen to identify a Stock Item to sell below Cost. 

Go to: File > Stock Control > Stock Items 

 

Open a Stock Item and review the “Standard Cost” field. 

For the purpose of this demonstration, the below example shows the “BEEF” Stock Item from the Demo Database with 

a Standard Cost Price of $6.25. 

 

 
 

 

 

 

Close the Stock Item screens.  

Ensure that a button exists for the Amount function (which we’ll utilise for the Amount Override function) by going to: 

Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons  
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Look for an Amount button on your screen which will be used for the Amount Override function. 

Typically, the Amount button will exist on the Admin tab. 

Should the Amount button not exist, you can create the button by selecting a preferred tab to place the button on, 

then select a blank button and choose the Amount function. 

You may want to customise the button by setting the Button Caption and Button Appearance as required. 

 

 
 

Once the Amount button has been created, close the POS Screen Layout windows then return to the main Idealpos 

POS screen. 

 

  



There are three different ways that can be used to override the item’s sell price. Regardless of the method you choose 

to use, a warning prompt will be displayed when using the amount override function to sell an item below the cost 

price. 

 

Amount Override can be used in the following ways: 

• Enter Price > Override > Enter Item 

• Enter Item > Enter Price > Override > Select Item > Enter 

• Enter Item > Select Item > Override > Enter Price > Enter 

 

Enter Price > Override > Enter Item 

Start by entering the new Price into the Sale window. 

 

 
 

Press the Amount button on the POS screen. The amount entered will move across to the right-hand side of the Sale 

window. 

 

 
 

Enter the Item into the sale window by pressing the Item button on the POS screen or manually enter the Stock Item 

Code. Idealpos will display a prompt with a warning that you are selling the item below cost price. Press “Yes” to 

continue and sell the item below cost price or press “No” to cancel the override. 
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After pressing “Yes”, the Item will be overridden with the new sell price. 
 

 
 
Enter Item > Enter Price > Override > Select Item > Enter 
Start by entering the Item into the Sale window. Enter the Stock Item code manually or press the Item’s button on 
the POS screen to add the Item to the Sale window. 
 

 
 
Enter the new price for the item into the Sale window. 
 

 
 
  



Press the “Amount” button on the POS screen. The amount entered will move across to the right-hand side of the 
Sale window. 
 

 
 
Select the Item that you want to override by selecting it on the Sale window. 
 

 
 
Press the “Enter” button to apply the override price to the selected Item. 
Idealpos will display a prompt with a warning that you are selling the item below cost price. Press “Yes” to continue 
and sell the item below cost price or press “No” to cancel the override. 
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After pressing “Yes”, the Item will be overridden with the new sell price. 
 

 
 
Enter Item > Select Item > Override > Enter Price > Enter 
Start by entering the Item into the Sale window. Enter the Stock Item code manually or press the Item’s button on 
the POS screen to add the Item to the Sale window. 
 

 
 
Select the Item that you want to override by selecting it on the Sale window. 
 

 
 
  



Press the “Amount” button on the POS screen. An Enter Selling Price screen will appear showing the Stock Item 
name and the price. Enter a new price using this screen, then press the OK button. 
 

 
 
After pressing “OK”, Idealpos will display a prompt with a warning that you are selling the item below cost price. 
Press “Yes” to continue and sell the item below cost price or press “No” to cancel the override. 
 

 
 
After pressing “Yes”, the Item will be overridden with the new sell price. 
 

 
 
 


