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Build 52 

Update Details: 

** Enhancements 

    * [IP-400] - Jackpot Winner shows on Customer Display 

    * [IP-401] - Raffle Winner shown on the Customer Display 

    * [IP-503] - Support for Tyro Pinpad Surcharging 

    * [IP-954] - Support for Alpha Table Codes [*Support for Handheld app coming soon] 

    * [IP-1034] - Ability to Email Pending Sales 

    * [IP-1059] - Unlock Permissions button for Table Details 

    * [IP-1462] - Option to Inhibit Manual Subtotal Discounts by Customer Type 

    * [IP-1563] - Customer Mag Card Printing: Suppress Member Number when using Format 1 

    * [IP-1576] - Auto Import Supplier Invoices - can find Supplier by Code 

    * [IP-1600] - Saudi Arabia region - Tax System same as Canadian region setting 

    * [IP-1610] - Reports Date Selection drop-down list includes Last 2,3 and 6 months 

    * [IP-1638] - Ability to add Log Out function to Shortcut Bar 

    * [IP-1639] - Log Out function - Hides Backoffice Screen 

    * [IP-1643] - Safe Drop function - option to open the Cash Drawer 

    * [IP-1686] - Financial Summary Report - Gross Sales field added 

    * [IP-1687] - Financial Summary Report - support for Dynamic Grouping in Shortcut Reports 

    * [IP-1702] - Yes/No Option - Inhibit Delete Items after Bill Print 

    * [IP-1705] - Assembly Payments EFTPOS Integration 

    * [IP-1713] - Yes/No Option - Print Order Number Dockets 

    * [IP-1719] - RMS/Hirum Room Interface - option to set Customer Type for new Customers 

    * [IP-1723] - Yes/No Option to Inhibit Stock Transactions on locations that have a different Stock Location 

    * [IP-1724] - Auto Import Promotions 

    * [IP-1735] - Zebra Label Printer - change font size on instruction items 

    * [IP-1749] - Manufactured Items option on Re-Order Reports 

    * [IP-1753] - Yes/No Option - Print Large Order Number on receipts 

    * [IP-1755] - Support for Multiple HC 100 Wristband Printers per Site 

    * [IP-1760] - Yes/No Option - Inhibit Order Number on Table Kitchen Prints 

    * [IP-1762] - Long Description Support on A4 Invoices when using Stock Notes for Long Descriptions option 

    * [IP-1766] - Xero API - Upgraded Transport Layer Security to 1.2 

    * [IP-1771] - Konami Gaming - Get Member by House Number query 

    * [IP-1777] - Tax Amount on Bills shows in Windows Currency Format 

    * [IP-1778] - Tender Labels on Receipt can show in Unexpanded Format 

    * [IP-1779] - Export Financial Data - support for Group by POS 

    * [IP-1784] - Stock Items Grid - show Grid Link Field 

    * [IP-1788] - Ability to specify a default Customer Photo Location 

    * [IP-1797] - Redirected Kitchen Printer Jobs show where they were Redirected from 

    * [IP-1809] - Pending Sale Deletions - items recorded in Journal and Activity Log 

    * [IP-1810] - Clerk/User Permissions for Tender Types 

    * [IP-1812] - Promotions - Can set specific Priorities / Move to Top and Bottom 

    * [IP-1826] - Support for longer Alternate Codes 

    * [IP-1839] - Embedded Marketing Website into Dashboard to advertise Idealpos Online 

    * [IP-1843] - Gift Vouchers will hide Expiry Date when Expiry Days 99999 

 

  



Customers – Customer Types 

Inhibit Manual Subtotal Discounts by Customer Type 

This function allows you to stop Subtotal Discounts from being applied to specific Customer Types. 

This is useful if you want to stop particular types of customers from receiving subtotal discounts when a sale is being 

finalised on a POS terminal. 

 

To inhibit manual subtotal discounts from applying to a Customer Type, 
Go to File > Customers > Customer Types > Select Customer Type > Modify > Inhibit Manual Subtotal Discounts 
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Export Data 

Export Financial Data – Support for Group by POS 

This function adds the ability to Group by POS when exporting Financial Data. 

 

Go to Utilities > Export Data > Financial Data > Group by POS 

 

 
 

Leave the Output File Format as Standard to export the data in a single line/row or change it to Single Column to 

export data in a single column. 

 

All the Export Fields can be left as selected or you can deselect any fields that are not required. 

 

Press the OK button. 

 

  



A prompt will appear allowing you to choose a location and filename for the exported data. 

 

 
 

Press the ‘Save’ button to save the data. 

 

The file is created and the data exported. 

 

The below is an example of an Output File Format of ‘Standard’ 
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The below is an example of an Output File Format of ‘Single Column’ 

 

 
  



Functions 

Safe Drop function – Option to open the Cash Drawer 

This function adds the ability to open the Cash Drawer when using the Safe Drop function at the POS terminal. 

 

Go to Setup > POS Screen > POS Screen Setup > Buttons > Select Blank Button > Function > Safe Drop > Open Cash 

Drawer 

 

 
 

When the Safe Drop button is pressed on the POS Screen, the Cash Drawer will open.  
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Gift Vouchers 

Gift Vouchers will hide Expiry Date when Expiry Days 99999 

This function allows Gift Vouchers to print without an Expiry Date when the Expiry Days have been set to 99999. 

 

Go to Setup > Global Options > Credit Notes/Gift Vouchers 

 

  
 

In the Expiry Days column, enter a value of 99999 to set that type of Gift Voucher to never expire. 

By doing this, the Gift Voucher will print without an expiry date. 

 

 
 

At the POS Screen, sell the Gift Voucher by pressing the ‘Gift Voucher’ button. 

 

  
  



Then enter the Gift Voucher value and the Customer Name for who the Gift Voucher is for. If the Customer does not 

exist, leave the Customer Name field as blank and press the OK button. 

 

  
 

The Gift Voucher will be added to the sale. 
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Press the ‘Enter’ button to go to the Tender screen, then choose a Tender to Finalise the sale. 

 

  
 

  



The Receipt will print, followed by the Gift Voucher. 

The Expiry Date will not print on the Gift Voucher as per the example below. 
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Global Options 

Gaming Interface – Konami Gaming – Get Member by House Number 

Idealpos previously looked up active members by sending a GMID number to the Konami Gaming System.  

However, the GMID number was not known or easily remembered by staff at the venue.  

The venue identifies machines by the House Number. 

Therefore, Idealpos has been updated so that the House Number is sent to the Konami Gaming System instead of the 

GMID number.   



Import Data 

Auto Import Promotions 

This function allows Promotions to be imported into Idealpos automatically. 

 

Go to Setup > POS Terminals > Select POS Terminal > Modify > Import/Export > Automatic Import Settings 

 

 
 

Specify the Import Folder location of where you will be placing the Import files. 

Then specify the name of the promotion file that you will be importing under Import Promotions – Filename. 

 

The format of the promotion file needs to be as per the format that’s documented on the ‘Import Promotions’ section 

of the User Guide. 

For completeness, the promotion format has been included below: 

 

ZONE – Currently unused but included for future plans. Header must be included but data can be left blank. 

DESCRIPTION – Promotion Description. 

TRIP_QUANTITY – The number of items required to purchase to trip the promotion. 

PROMO_PRICE – Price of the promotion. 

START_DATE – Start date of the promotion. 

END_DATE – End date of the promotion. 

ITEM_CODE – Stock items to be included in the promotion. 

CUSTOMER_TYPE or CUSTOMERTYPE - Customer Type Code 

CUSTOMERTYPERANGE or CUSTOMER_TYPE_RANGE - The range of Customer Type Codes expressed as 1-4, 16. 

Anything fields that contain a comma must be contained within quotes, so "1-4, 16". 

POS or POS_NUMBER or TERMINAL - POS Terminal Code 

POS_RANGE - POS Terminal Code range expressed as 1-4, 16. Anything fields that contain a comma must be 

contained within quotes, so "1-4, 16". 

LOCATION - The Location Code 

LOCATION_RANGE - The Location Code range expressed as 1-4, 16. Anything fields that contain a comma must be 

contained within quotes, so "1-4, 16". 

SITE - The Site Code 

SITE_RANGE - The Site Code range expressed as 1-4, 16. Anything fields that contain a comma must be contained 

within quotes, so "1-4, 16". 

PRICE_LEVEL - The Price Level Code. 

 

As the POS Range, Location Range, Site Range, Price Level all share the same field, whichever field comes first will take 

precedence if you have a record that has data in both fields. 
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Here is an example of a promotion file: 

 

 
 

 
 

Once the Promotion file has been created and saved with a name of PROMO.TXT, copy it into Import Folder location 

(in the above example, the location and name of the promo file is C:\Import\PROMO.TXT).  

When copied to the configured location, the Promotion File will then be imported automatically and will appear in 

Promotions.  

 

Go to File > Sales > Promotions > Promotions 

 

 
 

  



View the promotion by double clicking on it or selecting it and press the ‘Modify’ button to see the details of the 

promotion which was imported as per the promotion file. 
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Auto Import Supplier Invoices – Can find Supplier by Code 

Previously, Idealpos would look up a Supplier by Supplier name. Idealpos has now been updated to look up the 

Supplier by Supplier Code if the Supplier name cannot be found. 

 

Go to Setup > POS Terminals > Modify > Import/Export > Supplier Invoices > Retrieve Supplier from Filename 

 

Enter the location of the Supplier name or Supplier code using the information in the filename. 

E.g. To retrieve the Supplier Name from a filename of “Warehouse – ALM.csv”, you would set the “Retrieve Supplier 

from Filename - Right of” setting as “–“ and the “Retrieve Supplier from Filename - Left of” setting as “.” 

Idealpos will retrieve the Supplier name of “ALM” from a filename of “Warehouse – ALM.csv” using the above “Right 

of” and “Left of” settings. 

 

If the filename contains the Supplier Code instead of the Supplier Name, Idealpos will retrieve and search for the 

Supplier Code instead. 

E.g. For a filename of “Warehouse – 1.csv”, Idealpos will retrieve a Supplier Code of 1 using the “Left of” and “Right of” 

settings that have been described above. 

 

 
  



Invoices 

Long Description Support on A4 Invoices when using Stock Notes for Long Descriptions option 

This function adds support for Long Descriptions to be displayed in their entirety on A4 Invoices when the Stock Notes 

for Long Descriptions option has been enabled. 

 

Go to Setup > Yes/No Options > Miscellaneous > Enable: Use Stock Notes Field for Long Descriptions 

 

  
 

When enabling the above setting, the Stock Notes field will be used to handle Stock Item Descriptions and you 

will lose access to the Stock Notes features. 

 

After enabling the above Yes/No option, a long Stock Item Description can be entered against the Stock Item. 

 

Go to File > Stock Control > Stock Items > Select: Stock Item > Modify > Update Description Field: Enter a long 

description into the Description field > Save 

 

 
 

 

 

 

Open the POS screen and sell the Stock Item containing a long description in a Sale. 

After the sale has been finalised, close the POS screen and go to:  

Enquiry > Journal History > Select the Journal from the list > Press the Tax Invoice button 
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After pressing the ‘Tax Invoice’ button, the Tax Invoice will print and will include the full Stock Item Description 
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Log Out 

Hide Backoffice screen 

This function hides the Backoffice screen after logging out of Idealpos. 

This prevents unauthorised staff from seeing the figures that were displayed on the Dashboard by the last logged in 

user. 

This function is hard-coded and there are no configuration changes required. 

 

Go to File > Log Out 

 

 
 

The Backoffice screen is now hidden and only the Idealpos 7 logon screen is displayed on the screen.  



Pending Sales 

Ability to Email Pending Sales 

The ability to send a customer a Pending Sale as an email is now available in Idealpos. 

Pending Sales are used to save a sale for use at a later stage. 

For complete details about configuring Pending Sales in Idealpos, please search for Pending Sales in our Support User 

Guide available on the Idealpos website. 

 

In order to use the Email Pending Sales feature, you will need to ensure that the Outgoing Email Server is configured 

in Idealpos. 

Go to Setup > Global Options > Other Options > Email Settings 

 

 
 

Enter the details that are used by your email server. You may need to request these settings from your Internet Service 

Provider or from the Email Service that you use to send/receive your emails. 
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By default, the Pending Sale Descriptor is set as ‘Table’. The Descriptor appears on the top right corner of any Pending 

Sales that you email to your customers. Therefore, you may want to change this to Pending Sale or to another 

Description that you prefer.  

Go to Setup > Function Descriptors > Pending Sale > Modify 

 

 
 

Enter your preferred Description for Pending Sales into the Description field, then press the ‘Save’ button. 

 

Open the Idealpos POS screen, then add the Customer to the sale if they exist in your database, then add the Stock 

Items you want in your Pending Sale by selecting them from the POS Screen, or alternatively scan the Stock Item 

barcodes if they are barcoded and you have a barcode scanner. 

Then press the Pending Sale button. 

 

 
 

  



If you added a Customer to the transaction, their details will be pre-filled in the below screen, otherwise you may enter 

their details. POS only requires the Code, the other fields are optional. 

 

 
 

Press the Save button to Save the Pending Sale 

 

To email the Pending Sale, press the Pending Sale button on your POS Screen to view a list of Pending Sales then 

select the Pending Sale that you want to Email. 

 

 
 

Press the Email button to Email the Pending Sale. 
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Fill in the details for the email. 

 

 

 

Press the Send button to email the Pending Sale. 

 

The following window will appear to show that the Pending Sale was emailed successfully. 

 

 
 

  



The Pending Sale email will contain the above message and will also have a PDF attachment containing the details of 

the Pending Sale. 
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Pending Sale Deletions - Items recorded in Journal and Activity Log 

This function adds the ability to see the Stock Items that were added to a Pending Sale after a Pending Sale has been 

deleted. After a Pending Sale is deleted, the Pending Sale and the Stock Items it contained will be recorded in the 

Journal and Activity Log. 

 

Go to POS Screen and add required Stock Items to the transaction. 

If the sale is being created for a Customer, ensure that you add the Customer to the sale. 

Then press the ‘Pending’ button 

 

 
 

The ‘Save Pending Sale’ screen will appear. 

  



If you selected a Customer during the sale, the Customer’s details will appear. 

Otherwise, enter the details of the Customer which the Pending Sale is being created for (Name, Address, Suburb, 

State and Post Code), select the Type of Pending Sale (None, Takeaway, Delivery, Pickup, Cater) then press the ‘Save’ 

button. 

 

 
 

The Pending Sale has now been saved. 
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Now press the ‘Pending’ button to open the Pending Sales screen 

 

 
 

  



From the Pending Sale screen, select the Pending Sale that you want to Delete, then press the ‘Delete’ button 

 

  
 

Confirm the deletion by pressing the ‘Yes’ button 
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Close the Pending Sale screen, then close the POS screen, then go to Enquiry > Journal History 

The Deleted Pending Sale will appear as an entry for the day that the Pending Sale was deleted on 

 

  
 

The Deleted Pending Sale will also appear in the Activity Log. 

Go to Enquiry > Activity Log 

 

   



Promotions 

Can set specific Priorities / Move to Top and Bottom 

This function adds the ability to set a Priority for a Promotion by selecting a Promotion from the list then entering a 

numeric value for the Priority. 

It also adds the ability to move a Promotion to the top or bottom of the list. 

 

Go to File > Sales > Promotions > Promotions > Change Priority 
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The Promotions will change to a light-yellow background and additional buttons will be revealed at the bottom of the 

Promotions window. The new buttons have been annotated below 

 

 
 

The following arrow button pointing upwards sends the selected promotion to the top of the list 

 

  
 

The following arrow button pointing downwards sends the selected promotion to the bottom of the list 

 

  
 

The following button allows you to specify a priority for the selected promotion.  

Select the promotion, enter a numeric value for the promotion into the white field, then press the Set Priority button. 

The selected promotion’s priority will be updated and the promotion will move accordingly.  

 

  
Once changes to the priorities have been made, press the ‘Lock Priority’ button  



Receipts 

Tax Amount on Bills shows in Windows Currency Format 

Idealpos has been updated to show the Tax Amount using the Currency Format that has been configured in Windows. 

There is no configuration required to enable this function; it is enabled automatically when upgrading to this build of 

Idealpos. 
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Reports 

Financial Summary Report – Gross Sales field added 

This function allows you to report on the Gross Sales of your selected period when running the Financial Summary 

Report. 

 

Go to Reports > Financial > Financial Summary 

 

 
 

  



From the Report Options, select Gross Sales and press the ‘>’ arrow to include it in the ‘Selected Fields’, then press the 

‘View’ button to run the report using your selections. The resulting report will include the Gross Sales Report option as 

selected on the previous screen. 

 

  



 Update History 
 

Financial Summary Report – Support for Dynamic Grouping in Shortcut Reports 

This function adds support for creating Shortcut Reports with Dynamic Grouping. This then allows those Shortcut 

Reports to use Dynamic Grouping selections that were made when the Reports were initially created. 

 

Go to Reports > Financial > Financial Summary 

 

Select the criteria that you want included in your Shortcut Report. The Dynamic Grouping selections that are now 

supported in the Shortcut Report are illustrated below. 

 

 
 

Press the ‘View’ button to run the report. 

 

When the report is displayed on the screen, press the Shortcut button (S) on the top right corner of the window to 

create a shortcut for the report. 

 

  



Enter a Shortcut Name for the report and select the location where you want the shortcut for the report to be saved. 

 

 
 

The report can now be run anytime by selecting it from the Favourite Reports section which is located on the left-hand 

side of the Dashboard on the main Idealpos window. 
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The Shortcut Report can also be scheduled to run. 

Note that before setting up Schedules, ensure that your Email Settings have been configured in Idealpos 

Go to Setup > Schedules > Add 

 

Complete each of the fields with the options that you want to use to run the scheduled Shortcut Report. 

Drag and drop the newly created Shortcut Report from the Shortcut Reports Available section into the scheduled 

reports section. 

 

 
 

Once you have finished setting up your report, press the X button on the top right corner of the window. 

 

Press ‘Yes’ to Save Changes. 

 

 
 

  



The Report will run as scheduled and will include the Dynamic Grouping options that were selected when the Shortcut 

Report was created. 
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Re-Order Report – Add option for Manufactured Items 

This function adds the ability to report on Manufactured Items that need to be re-ordered. 

Since Manufactured Items are Stock Items that are Manufactured in-house, any Manufactured Items that appear on 

the Re-Order Report simply mean that these items need to be manufactured. 

When running the Re-Order Report with the ‘Manufactured Items’ option ticked, the system will look for Stock Items 

which have the ‘Manufactured Item’ checkbox enabled and need to be re-ordered. The quantities recorded against the 

Stock Level, Recommended Level and Reorder Level are all used to determine whether a Stock Item needs to be 

ordered.  

When the current Stock Level of a Manufactured Stock Item is less than the Reorder Level AND the Recommended 

Level is higher than the current Stock Level, the Item will be displayed on the Re-Order Report. The Reorder Quantity 

that is displayed on the Re-Order report against the Stock Item will be the quantity that is needed to increase the 

Quantity of the Stock Item back to the Recommended Level. 

 

Go to Reports > Stock Control > Re-Order > Select: Manufactured Items 

 

  
 

Any Manufactured Items that need to be re-ordered will be displayed on the Report 

 

   



Reports Date Selection drop-down list includes last 2, 3 and 6 months 

Extra period selections have been added to all Idealpos Reports in the Reports menu. 

 

Go to Reports > Select a Report Type (Financial, Sales, Stock Control, Purchases, Customers, Employees or Restaurant) 

> select the Report you want to run 

 

 
 

Click on the Date Range dropdown box. You will see three new options at the bottom of the Date Range list (Last Two 

Months, Last Three Months and Last Six Months). 

Selecting any of these three options will pre-fill the From/To fields according to your selection 
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Restaurant & Table Map 

Support for Alpha Table Codes 

This function enables the ability to setup tables with alphanumeric codes (e.g. 100A, Couch1, etc.). 

 

Go to Setup > Restaurant > Table Maps > Select: Table Map > Modify 

 

 
 

Enter a caption for the table into the ‘Table Caption’ field located at the bottom of the Map Modify screen. 

 

 
 

  



Then select a table on the map by clicking on it. The caption will be applied to the selected table. 

 

 
 

Once you have finished making changes to the Table Map, press the ‘Save’ button. 

 

The table will now show the caption on the Table Map. 

When Kitchen Receipts are printed, the caption will be printed in place of the Table Number that would have 

previously been printed for the table. 

 

Please note that support for Alpha Table Codes on the Ideal Handheld app will be released shortly. 

In the meantime, Tables will appear on the Handheld app with the Table Number that was set for the table at 

the time the table was created. 
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Unlock Permissions button for Table Details 

This function adds an ‘Unlock Permissions’ button to the Table Details screen. 

The ‘Unlock Permissions’ button allows a manager or supervisor to temporarily unlock all functions on the Table 

Details screen using a pre-configured ‘Table Details Unlock Permissions Password’.  

This function is used when a Clerk has restrictions imposed on them (e.g. their ability to Pay, Transfer, Bill, Delete or 

Finish under the Table Map option is disabled in the Clerk security settings). 

When a Clerk with restricted access needs to perform one of the above functions, they will call a supervisor over who 

will press the ‘Unlock Permissions’ button then enter the password. After the password has been eAll functions are 

temporarily unlocked for the current Table Details screen which allows them to perform the task (Pay, Transfer, Bill, 

Delete or Finish) that is required (while they are under supervision of the supervisor or manager). 

Once the required operation has been completed and the Table Details screen is closed, all security functions will 

return to normal. The next time the Clerk presses the ‘Details’ button for a table, the standard restrictions that have 

been imposed on that Clerk will apply.  

 

Go to Setup > Global Options > Restaurant > Miscellaneous > Table Details Unlock Permissions Password 

 

 
 

  



For the above setting to be effective, you need to have a Clerk which has security restrictions applied to them on the 

Table Map. You also need to have ‘Compulsory Clerk’ and Require ‘Clerk Entry on Table Map’ enabled in the Yes/No 

options. 

 

To enable ‘Compulsory Clerk’ and ‘Clerk Entry on Table Map’,  

Go to Setup > Yes/No Options > Clerks > Enter Keyword Search: Compulsory Clerk  

 

 
 

Go to Setup > Yes/No Options > Clerks > Enter Keyword Search: Clerk Entry 
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Then Go to Setup > Clerks > Select: Clerk > Permissions 

 

 
 

  



Then under Clerk Permissions > Table Map, enable/disable the options that the Clerk should have access to, then press 

the ‘Save’ button to apply the changes 
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Open the Idealpos POS Screen and login using the clerk that has had the permissions applied to them 

Press the ‘Table Map’ button, select a table that contains an Order on it then press the ‘Details’ button 

 

 
 

  



Then press the ‘Unlock Permissions’ button 
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A Password prompt will appear – Enter the Password as previously configured then press the ‘Enter’ button 

 

 
 

The following prompt will appear. All functions will now be temporarily unlocked – the clerk may now perform any of 

the Table Map actions that are normally not available to them. 

 

 
 

Once the required actions have been performed under the supervision of the supervisor/manager, close the Table 

Details screen. After closing the Table Details screen, the Permissions for that Clerk will be locked.  



Setup – Clerks/Users 

Clerk/User Permissions for Tender Types 

This function allows you to control which Users/Clerks have access to specific Tender Types. 

E.g. You can stop a specific Clerk or User from finalising a transaction using the EFTPOS Tender 

 

To configure Tender Types for a particular Clerk, go to: 

Setup > Clerks > Select Clerk > Permissions  
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Under the ‘Tender Types’, select/unselect the Tender Types that you want the Clerk to have access to, then press the 

‘Save’ button to save the changes 

 

 
 

Any Tender Types that have been enabled for the Clerk will continue to work as normal. 

When the Clerk attempts to use a Tender Type that they don’t have permission to use, the POS will display the 

following prompt. 

 

 
 

  



In addition to having the ability to set Tender Type access for Clerks, the same can be configured for a User. 

When a Tender Type is disabled for a specific User, any Clerk that is linked to that User will also be denied access to 

that Tender Type, even if access to the Tender Type has been enabled under the Clerk level access (Setup > Clerks > 

Permissions). 

 

Go to Setup > Users > Select User Name > Modify 
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Under Clerk Permissions > Tender Types, tick/untick the Tender Types that you want the User to have access to, then 

press the ‘Save’ button save changes 

 

 
 

When a Clerk that is linked to the User attempts to use a Tender Type that has been disabled, they will see the 

following prompt. 

 

  



Setup – Global Options 

Ability to specify a default Customer Photo Location 

This function allows you to specify the default location for Customer Photos. 

When a Customer doesn’t have a photo programmed against their customer record in the system, the system will look 

into the Photo Folder and look for a Photo that matches the customer number. 

If a match is found, the photo will be displayed when the Customer is selected during a POS transaction. 

Note that when a Photo Folder is configured and a match exists for the Customer, the photo for the Customer will not 

be displayed when viewing the Customer record in File > Customers > Customers. 

It will only display the photo when the Customer has been selected during a POS transaction. 

 

Go to Setup > Global Options > Customers > Photo Folder 

Enter a location into the Photo Folder field that contains Customer Photos. 

The filename of the Customer Photo needs to match the Code that has been assigned to the Customer and photos 

should be in JPG format.  
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Go to File > Customers > Customers > Select a Customer > Modify 

 

 
 

  



Refer to the Code field on the Modify Customer screen – The code that is displayed is the Customer’s Code. 

The JPG file needs to match the Code that is displayed 
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To check if they have a Photo assigned to them, click on the Advanced tab in the Modify Customer screen. 

The Photo Location field needs to be empty 

 

 
 

In addition to the Code and as mentioned previously, the Customer’s Photo that exists in the Photo Folder will only be 

used if the Customer doesn’t already have a Photo assigned to them. 

Copy the photo to the Photo Folder that’s configured in Global Options as per the above steps 
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When the Customer is selected during a POS transaction, their photo will now appear 

 

 
 

  



RMS/Hirum Room Interface – Option to set Customer Type for new Customers 

This function allows you to specify a Customer Type for new RMS Customers. When customers are read from the RMS 

data file, they will be assigned to the Customer Type that has been selected. 

 

Go to Setup > Global Options > Interfaces > Customer Type 

 

 
 

Select the Customer Type that you want new RMS Customers assigned to. 

If you don’t already have an existing Customer Type that is suitable for RMS Customers, you may create a new 

Customer Type. 

This can be done by going to File > Customers > Customer Types > Add  

 

Configure the new Customer Type as required then press the ‘Save’ button to save changes. 

 

 
 

Note that after adding a new Customer Type, you may need to restart Idealpos in order for the Customer Type to 

show as an available Customer Type from the Customer Type dropdown box in the above Room Interface settings.  
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Setup – Network Printers 

Redirected Kitchen Printer Jobs show where they were Redirected from 

This function will print details at the top of the receipt that shows the name of the printers that the Kitchen Print Job 

was redirected from. 

This function is hard-coded and there are no settings that need to be modified in order for the Kitchen Print Job to 

show where it was redirected from.  

There are two ways a Print Job can be redirected from one printer to another, with both ways being triggered when 

the target printer is not available due to being turned off or not available. 

 

Option one – When you attempt to print to a printer that’s offline and redirect printer is not configured, the POS 

terminal will display a Printer Error box from where you can select the printer that you want to send the Print Job to. 

 

 
 

After selecting the desired printer, the Kitchen Receipt will print and will show the Kitchen Print Job will show the 

printer from where it was redirected from. 

 

Option two – When you attempt to print to a printer that’s offline and redirect printer is configured, the POS terminal 

will attempt to print to the redirected printer. If it is successful, the Kitchen Receipt will print to the redirected printer 

and will print the receipt showing the printer name from which it was redirected from.  

 

In the event that the redirected printer is also not available, the POS terminal will display a Printer Error box from 

where you can select the printer that you want to send the Print Job to. The Kitchen Receipt will print showing the 

printer name from which it was redirected from. 

 

  



To setup automatic printer redirecting, go to Setup > Network Printers > Modify > Redirect Printer 

 

  
 

 

  



 Update History 
 

When the Printer goes offline, any print job sent to it will be automatically redirected to the Redirect Printer that’s 

selected in the ‘Redirect Printer’ dropdown box. The Print Job that was redirected will show the Printer where it was 

redirected from at the top of the Kitchen receipt. 

 
 

Note that if there are multiple levels of Receipt Redirection, each level will be printed at the top of the receipt. 

E.g. There are three printers in the system; Printer A, Printer B and Printer C. 

The system is configured to print to the Kitchen Printer which is Printer C.  

Printer C is configured to redirect to Printer B. Printer B is configured to redirect to Printer A. 

Printer B and Printer C are both offline. 

The Print Job tries to print to Printer C which fails. 

It then redirects to Printer B which also fails then redirects to Printer A. 

Printer A prints the Kitchen Receipt successfully and the Kitchen Receipt will show each printer that it was redirected 

from.  

This aids in tracing each printer that the receipt was redirected from. 

 



Support for Multiple HC 100 Wristband Printers per Site 

This function adds support for Multiple HC 100 Wristband Printers per site. 

You will need to ensure that all Wristband printers have been configured in Idealpos - Network Printers. 

Once all wristband printers have been configured in Network Printers, the printer that will be used for the printing of 

the wristband is configured within the Stock Notes of the Stock Item. 

 

Go to Setup > Network Printers > Add 
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Enter a Printer Name, under Type, select ‘Zebra HC100’, then specify the IP address and Port (if it is not the default 

port of 9100). Then press ‘Save’ to save the printer. Repeat this step for each printer, ensuring that each HC100 printer 

has a unique Printer Name. 

 

 
 

After the HC100 printers have been configured, open a wristband Stock Item. 

 

  



Go to File > Stock Control > Stock Items > Select: Stock Item > Modify > Advanced 

 

 
 

The formula for what you want printed on the wristband needs to be entered along with the PRINTERNAME tag and 

the printer within the Stock Notes field. Please refer to the User Guide for more information about setting up tags. 

For the purpose of this guide, an example formula including the printer name has been included below: 

[WRISTBAND=TIME PRINTERNAME=Rides] 

 

The above example should appear in the Stock Notes field as follows… 

 
 

Repeat the above for each Stock Item that is used for printing a wristband ensuring that the printer has been correctly 

specified. 

 

When printing the wristband, the wristband will print to the wristband printer that has been specified in the Stock 

Notes for the Stock Item. 
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Setup – POS Terminals 

EFTPOS Settings – Assembly Payments EFTPOS Integration 

This function enables the ability to integrate Idealpos with Assembly Payments. 

Before setting up Assembly Payments, you need to be licenced to use Assembly Payments. You also need to be setup 

with Assembly Payments as your EFTPOS service provider. Speak to Idealpos Sales for more information if you are 

interested in using Assembly Payments as your EFTPOS provider. 

 

We recommend setting up the Assembly Payments Pinpad using a Wi-Fi connection. Therefore, it is a requirement that 

you have Wi-Fi connectivity at your site in order to use Assembly Payments. 

 

To enable Assembly Payments Integration, go to: 

Setup > POS Terminals > Select: POS Terminal > Modify > EFTPOS Settings > EFTPOS Type: Assembly Payments 

 

 
 

Ensure that the Disable box is unticked. If Disable is ticked, untick the box to enable EFTPOS. 

Enter the IP address of the Pinpad into the IP Address field on the bottom right corner of the EFTPOS Settings window, 

then press the Pair button. Follow the remaining instructions on-screen and on the pinpad. 

For more detailed information on setting up Assembly Payments, please refer to the EFTPOS – Assembly Payments 

section in the User Guide which is available on our website. 

  



Region - Saudi Arabia – Tax System same as Canadian region setting 

The Tax System in Saudi Arabia has changed to include VAT taxes. 

Therefore, Idealpos has been updated so that when the Saudi Arabia region is selected, the Tax System that’s used will 

be the same as the Tax System used by the Canadian setting. 

We highly recommend that any customers in Saudi Arabia should take a backup and print out all reports up to the 

current date before they upgrade to this new build. 

 

You can check what Region the POS has been set to by going to Setup > POS Terminals > Modify > Region 
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Support for Tyro Pinpad Surcharging 

Idealpos now supports Tyro Pinpad surcharging based on the card presented. 

There are two modes for this. Both are controlled from settings in Tyro. 

• The default mode (set from Tyro) is to have the surcharges deducted from the settlement amounts. Tyro then 

sends the settlement amounts without the surcharges, so that Idealpos will balance with the Tyro settlement 

• You can also configure Tyro to have the settlement amounts sent to Idealpos as part of the settlement. If using 

this mode, you must set the Surcharges to a Stock Item in Global Options > Sales > Undistributed Links. 

Idealpos then adds the surcharges to the item specified. 

  



Shortcuts 

Ability to add Log Out function to Shortcut Bar 

This function allows you to add the Log Out function to the Shortcut Bar located on the left-hand side of the 

Dashboard on the main Idealpos window. The shortcut can then be used to Log Out of Idealpos 

 

Go to the main Idealpos window 

 

 
 

On the left-hand side of the Dashboard, right click on the Functions heading and select ‘Add Log Out Menu’ 

 

 
 

The Log Out Shortcut will then appear in the Functions menu which can be used to Log Out of Idealpos 
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Stock Control 

Stock Items Grid – Show Grid Link Field 

This function enables the Grid Link Field to be displayed in the Stock Items Grid. 

 

Go to Setup > Users > Modify > File Fields > Stock Items > GridLink 

 

 
 

 

 

Enable the GridLink option, then press the Save button to save the change. 

After the GridLink option has been enabled for the User, close the Users screen, return to the main Idealpos 

dashboard, then open the Stock Items screen. 

 

Go to File > Stock Control > Stock Items 

The GridLink option will be displayed at the far right-hand side of the Stock Items grid 

 

  
 

Stock Items can also be sorted by the Grid Link column. Click on the Grid Link header and the Stock Items will sort by 

the Grid Link column. Pressing on the Grid Link header multiple times toggles the order that the column is being 

sorted by (i.e. Ascending or Descending). 

 

  



The Grid Link option that is displayed in the Stock Items grid corresponds to the Link to Grid setting that is configured 

within the Stock Item. Open the Stock Item then click on the Advanced tab. 
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Support for longer Alternate Codes 

Idealpos has been updated to support longer Stock Item Alternate Codes. 

The maximum allowed Alternate Code length has increased to 30. 

There is no configuration required for this to take effect. 

 

Go to File > Stock Control > Stock Items > Select Stock Item > Alternate Codes 

 

 
 

Press the ‘Add’ button 

 

 
 

  



Enter the Alternate Code for the Stock Item. 

An alphanumeric Alternate Code of up to 30 characters may now been entered. 

Once the code has been entered, press the ‘Save’ button. 

 

 
 

The Alternate Code has now been saved for the Stock Item. 

 

From the Stock Items screen, select the Stock Item then press the ‘Alternate Codes’ button. 

The saved Alternate Code will be displayed 
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Yes/No Options 

Inhibit Delete Items after Bill Print 

This option will disable the ability to delete items from a table once a bill has been printed for that table.  

 

Go to Setup > Yes/No Options > Restaurant > Inhibit Delete Items after Bill Print 

 

 
 

Open the POS Screen and add items to the sale  

 

 
 

  



Save the items to a table by pressing the ‘TABLE MAP’ button, select a table from the Table Map then enter the 

number of Covers and press OK. 

 

Then open the Table Map, select the table and press the Details button. 

 

Items can be deleted from the table before the bill has been printed by selecting the item and pressing the ‘Delete’ 

button. 
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Print a bill for the table by pressing the ‘Print Bill’ button from the Details screen. 

 

 
 

  



After a Bill has been printed, the ‘Bill Printed’ status will be displayed at the top right corner of the Table Details screen. 
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Once the bill has been printed, select an item from the Details screen, then press the ‘Delete’ button.  

 

 
 

The following prompt will be displayed. 

 

 
 

 

The item that you attempted to delete will remain in the order. 

 

  



Inhibit Order Number on Table Kitchen Prints 

This function prevents the Order Number from printing on Table Kitchen Prints. 

 

Go to Setup > Yes/No Options > Receipt/Kitchen > Inhibit Order Number on Table Kitchen Prints 

 

 
 

When you enter an Order Number into a sale that also contains Stock Items which print to a Kitchen Printer and save 

the sale to a table, the Order Number will not be printed on the Kitchen Printout. 

If the Inhibit Option is not enabled, the Order Number will print to the Kitchen Print in the above scenario. 

 

Note that this option only affects Table Kitchen Prints. If you add Kitchen Print Stock Items to a sale and then tender 

the sale (without saving the sale to a table), the Kitchen Print will still contain the Order Number. 

 

Inhibit Order Number on Table Kitchen Prints unchecked (Order Number is printed on Kitchen Print) 

 

 
 

Inhibit Order Number on Table Kitchen Prints checked (Order Number is not printed on Kitchen Print) 
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Inhibit Transactions for Locations with different Stock Location 

This function will stop Transactions (Transfers, Purchases, Stocktakes) from occurring at a Location which has a 

Location other than its own Location set as the Stock Location. 

This function is useful for scenarios where a site has two locations such as a Mini Mart and a Café.  

All Stock is located in the Café and the site does not want Transactions performed against the Mini Mart.  

This function will allow you to stop Transactions (Transfers, Purchases, Stocktakes) from being performed at the Mini 

Mart location. 

Before making changes regarding Stock Locations, we recommend that you create a backup of your Idealpos system.  

To backup your Idealpos system, go to File > Backup Database > OK 

 

Go to Setup > Yes/No Options > Stock Control > Inhibit Transactions for Locations with different Stock Location 

 

  
 

If required, setup/update your Locations so they reflect the Stock Location. 

 

Go to File > Stock Control > Locations > Select: Location > Modify 

 

  
  



Select the Stock Location from the Stock Location dropdown list which reflects the location of where the Stock is 

located for the current location then press Save to save the change. 

 

 
 

Using the above as an example, transactions (Transfers, Purchases or Stocktakes) will be inhibited. 

This means that the Mini Mart Location will not be shown as an available Location when performing Transfers, 

Purchases or Stocktakes. 
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The Mini Mart Location is now hidden on the Transfers, Purchases and Stocktake screens  

 

 
 

 
 

 
 

 

  



Jackpot/Raffles are shown on Customer Display 

This function displays the Jackpot or Raffle winner on the Customer Display when a Jackpot or Raffle is drawn. 

This function is enabled by default. In order to see Jackpot/Raffle winners on the Customer Display, you must also have 

a physical Customer Display installed and enabled. 

 

Go to Setup > Yes/No Options > Miscellaneous > Jackpot/Raffles are shown on Customer Display 

 

 
 

To ensure that Idealpos is enabled to use your installed Customer Display, go to: 

Setup > POS Terminals > Modify > Customer Display > Resolution > Select the resolution of your Customer Display, 

Display Format > Select your desired display format for the Customer Display 

 

Then go to the POS Screen and draw a Jackpot or Raffle by pressing the Jackpot or Raffle button on your POS screen. 

The Jackpot or Raffle winner will be displayed on both the POS Screen and the Customer Display. 

 

 
 

For complete details about using Jackpots and Raffles in Idealpos, please search for either Jackpot or Raffles in our 

Support User Guide available on the Idealpos website.   
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Print Large Order Number 

This function configures the receipt to print Order Numbers in large font type if an Order Number is entered during a 

sale.  

 

Go to Setup > Yes/No Options > Receipt/Kitchen > Print Large Order Number 

 

 
 

During a sale on the POS Screen, press the Order Number button, or enter a number and then press the Order 

Number button. 

 

 
 

If you just selected the Order Number button or have the option to Force Order Entry, the sales screen will prompt you 

to enter a number. Enter the Order Number and press the ‘Enter’ button. 

 

 
 

Add items to the sale then tender the sale. 

 

  



After you tender the sale, the receipt will print out and will contain the Order Number printed in large font type. 
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Print Order Number Dockets 

This function forces Idealpos to print an Order Number docket to the receipt printer when a sale is done that contains 

an Order Number. This function is useful for Quick Service businesses that assign Order Numbers for each order, then 

hand a copy of the Order Number docket to their customer. Then when the customer’s order is ready for collection, 

the business will call out the order number. 

 

Go to Setup > Yes/No Options > Receipt/Kitchen > Print Order Number Dockets 

 

 
 

From the Idealpos POS screen, press the Order Number button, or enter a number and then press the Order Number 

button. 

 

 
 

If you just selected the Order Number button or have the option to Force Order Entry, the sales screen will prompt you 

to enter a number. Enter the Order Number and press the ‘Enter’ button. 

 

 
 

Add items to the sale then tender the sale. 

 

  



The sale receipt will print followed by the Order Number docket. Any Kitchen Receipts will also print at the Kitchen 

Printers if Kitchen Printers have been configured.  

If Receipt Printing is turned off, the Order Number docket will still print followed by any Kitchen Receipts if Kitchen 

Printers have been configured. 

 

 
 

 
 

 


