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Build 55 

Update Details: 

 

** Enhancements 

    * [IP-140] - Automatic Email of Account Payments - Email Subject Line shows "Payment" 

    * [IP-1426] - Support for Sale Type printing on Table/Hold Print Sales 

    * [IP-1551] - Schedules - Ability to modify the POS number that Processes the Schedule 

    * [IP-1614] - Dashboard Pie Chart displays percentages 

    * [IP-1656] - Gift Voucher Balance recorded to the Journal 

    * [IP-1663] - Reservations Report - increased font size for greater readability 

    * [IP-1694] - Open Stock Item as Instruction allows Force Selling Price functionality 

    * [IP-1709] - Banking Report: XREPORT with LOCATION tag 

    * [IP-1845] - Customer Invoice - Total Ex label changed to Subtotal 

    * [IP-1850] - Table Details - Auto Select Priced Instructions when Parent Item is selected 

    * [IP-1883] - Waive Tender Surcharge Threshold 

    * [IP-1885] - Option to Disable Gaming Points Accrual on a Promotion 

    * [IP-1889] - User-Defined Options - support for On-Screen Keyboard functionality 

    * [IP-1904] - Yes/No Option - Print POS Description on Receipts 

    * [IP-1939] - Bill Print - Option to show Single Surcharge Percent 

    * [IP-1950] - Gift Voucher Report with drill-down transactions - Added running total column 

    * [IP-1952] - Raffle Tickets show Customer Name and Code 

    * [IP-1989] - Journal Enquiry to Stock Item Sales - Ability to Create Shortcut 

    * [IP-2029] - Ability to encode Customer into QR Code on Receipts 

    * [IP-2039] - Table Details - Reorder Items Function 

    * [IP-2049] - Stock Item Search function - Default Search Type option 

    * [IP-2050] - Stock Item Search function on POS Grids 

    * [IP-2064] - Allow Waste Mode functionality when performing a Sale 

    * [IP-2071] - Ideal Webit - Support for Add Stock Notes as Text option 

    * [IP-2075] - Purchase Orders - Option to show Stock Code next to Description 

    * [IP-2077] - Activity Log entry for Replayed Transaction 

    * [IP-2081] - Export Stock Sales - option to Filter by Site 

    * [IP-2090] - Pending Sales Address recorded in Journal History when finalized (User-Defined) 

    * [IP-2092] - Westpac Group Eftpos - Support for Pinpad Surcharging 

    * [IP-2096] - Show POS Description on BackOffice and POS Screen Captions 

    * [IP-2097] - Supplier Selection on Promotion Details by Item Report 

    * [IP-2103] - Unit Cost field on Purchase Orders - allow entry of extra digit 

    * [IP-2104] - Stock Item Search - support for Chinese Character searching 

    * [IP-2108] - Support for Vault Eftpos 4.0 API 

    * [IP-2109] - Support for Yield Percentage Attributes 

    * [IP-2110] - Yes/No Option for Master Accounts to Accumulate Points from Sub-Accounts 

    * [IP-2113] - User-Defined Option - INDIARECEIPTSPLITTAX 

    * [IP-2114] - Range Programming allows bulk changes of Large Stock Notes data 

    * [IP-2122] - Table Details - Instruction Items Indented for greater readability 

    * [IP-2134] - USA and Canada Regions split into separate options 

    * [IP-2137] - Westpac Group Eftpos - Support for MOTO Transactions 

    * [IP-2148] - Import Stock Items supports importing Supplier Quantity Type/Sell Quantity 

    * [IP-2150] - Stock Valuation Report - Summary option enabled for Department/Sales Category Groupings 

    * [IP-2158] - Synchronize Sales utility - option to synchronize all sales from one terminal 

    * [IP-2173] - Ebet Gaming - Till ID 5588 Functionality for Void Mode transactions 

    * [IP-2179] - Dynamic Screen Tab Functionality 

    * [IP-2181] - Dashboard - Last 7 Days/Previous 7 Days and This Month/Last Month Charts 

 



Back Office 

Activity Log entry for Replayed Transaction 

This feature adds logging to Idealpos Activity Log to indicate whether a transaction completed in POS was a new 

transaction or a replayed transaction. Previously, Idealpos did not show whether or not a transaction was replayed.  

“Replay Transaction: [Transaction No]-[POS Number]” will now appear in the Activity Log section of the Idealpos Back 

Office screen as well as in the Enquiry > Activity Log section. Transaction No will show the Transaction Number and 

the POS Number will show the number of the POS terminal (e.g. Replay Transaction: 788-1)  

 

To replay a transaction, go to: POS Screen > Journal Enquiry > Select Journal > Replay Transaction > Tender the 

Transaction 

 

After a transaction has been replayed, a Replay Transaction entry will be logged in the Activity Log. 

 

To view the Activity Log, go to: Enquiry > Activity Log. 

An entry showing “Replay Transaction” will be displayed as per the below example: 

 

 
 

In addition, the Replay Transaction will also be displayed in the Activity Log section of the main Idealpos Back Office 

Screen as illustrated below: 
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Dashboard – Last 7 Days/Previous 7 Days and This Month/Last Month Charts 

This function re-instates the ability to show the Last 7 Days/Previous 7 Days and This Month/Last Month on the 

Idealpos Back Office Dashboard. 

 

To use this function, go to: Idealpos > Dashboard 

 

The Pie Chart may be displayed by default. 

To view the other available charts, press the button that contains three dots (…) towards the bottom of the Back Office 

Dashboard screen as indicated below: 

 

 
 

  



Further charts will be displayed. 

 

 
 

To toggle the Charts on the Dashboard, press the “>” arrow button and the next available Chart will be displayed. 

Press the “>” arrow button until you see the “Last 7 Days/Previous 7 Days” chart. 
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The value for each bar on the chart can be displayed by hovering the mouse cursor over the bar. 

 

 
 

The style of chart can also be toggled by pressing the button that contains three dots (…) towards the centre of the 

Back Office Dashboard screen as indicated below: 

 

   



Dashboard Pie Chart displays percentages 

Idealpos has been updated to show percentages on the Dashboard Pie Charts which are displayed on the main 

Idealpos Back Office screen. There is no configuration required to enable this feature and is enabled by default. 

 

Go to the main Idealpos Back Office screen. 

 

 
 

Click on the Sites button at the bottom of the screen, then select the type of data that you want to view as a Pie Chart. 
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After selecting the type of data, the pie chart will be updated to reflect the selection. Each portion of the pie chart will 

be shown as a percentage of the overall chart. 

 

 
 

The desired Period can also be selected to show data on the pie chart to reflect the period selected. 

Click on the ‘Last Financial Year’ text to display the list of available periods, then select the period to view the pie chart 

data for that period 

 

 
 

  



Dynamic Screen Tab Functionality 

This function changes the behaviour of navigating between screen tabs in Idealpos. Previously, navigating between 

screen tabs required the user to click on the required tab. After this change, hovering the mouse cursor over a screen 

tab will switch to that  tab. 

 

This functionality has been enabled on the following screens: 

 

• Yes/No Options 

• POS Options 

• Global Options 

 

To access this function on the Yes/No Options screen, go to: Setup > Yes/No Options 

Hover the mouse cursor over any of the tabs at the top of the screen (Clerks, Confirmation, etc.) and the screen will 

dynamically update to reflect the settings available for the tab which the mouse cursor is hovering over. 
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To access this function on the POS Options screen, go to: Setup > POS Terminals > Select a terminal > Modify 

Hover the mouse cursor over any of the tabs at the top of the screen (Main Settings, POS Settings, etc.) and the screen 

will dynamically update to reflect the settings available for the tab which the mouse cursor is hovering over. 

 

 
 

To access this function on the Global Settings screen, go to: Setup > Global Options 

Hover the mouse cursor over any of the tabs at the top of the screen (General, Miscellaneous, etc.) and the screen will 

dynamically update to reflect the settings available for the tab which the mouse cursor is hovering over. 

 

  



Show POS Description on BackOffice and POS Screen Captions 

This function implements the display of the POS Description on the BackOffice screen as well as POS Screen Captions. 

The POS Description is always displayed on the BackOffice screen and there is no configuration required to enable this 

function.  

 

To view the POS Description on the Back Office screen, ensure that the POS screen is closed and ensure the main 

BackOffice screen is opened. The POS Description is displayed on the title bar of the Idealpos main screen.  

The format/order of the details displayed on the title bar are: 

Idealpos v7 Build [Build Number] [Trading Name] [Site Name] – [POS Description] [POS Number] 

The Trading Name is retrieved from the Licence. 

The Site Name is retrieved from the Site configuration. 

The POS Description is retrieved from the POS Terminals Configuration in Idealpos. 

The POS Number displayed reflects the number of the POS Terminal which is also retrieved from the Licence which has 

been activated on the POS terminal. 

 

In the below screenshot example, the details displayed on the Title Bar are: 

Idealpos v7 Build 55 Idealpos user Extra Steamy Cafe Group – Cafe POS 1(1) 

 

 
 

If the Site Name or POS Description require updating, you may update them by following the below steps: 

Note that in order for the change to take effect, Idealpos may require restarting after making the following changes. 

 

To update the Site Name, go to: Setup > Sites > Modify 

Update the Description in the Description field, then press the Save button 

 

 
 

To update the POS Description, go to: Setup > POS Terminals > Modify 

Under the Main Settings section, update the Description in the Description field, then close the POS terminals screen. 

 

  



 Update History 
 

EFTPOS 

Westpac Group – Support for MOTO Transactions 

This function adds the ability to perform Integrated MOTO Transactions using Westpac Group EFTPOS (Assembly 

Payments).  

MOTO is a way of allowing a customer to pay for their items without them being present at the EFTPOS terminal.  

This function may be useful where a customer places an order over the phone and you take payment using the 

customer’s credit card details. 

 

To enable and use this function, go to: Setup > POS Terminals > Select terminal > Modify > EFTPOS Settings 

Ensure that “Allow multiple EFTPOS Tendering” has been enabled. 

 

 
 

  



Close the POS Terminal configuration screens, then go to:  

Setup > Function Descriptors 

Find the next available Tender in the list which hasn’t been used (e.g. Tender 12, Tender 13, etc.), select it then press 

the Modify button 
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Set the Description to MOTO and ensure that the EFTPOS option is enabled. 

Press the Save button once the changes have been made. 

 

 
 

Ensure that the Tender shows the new Description on the Function Descriptors screen 

 

 
 

Close the Function Descriptors screen.  

  



Go to: Setup > Yes/No Options 

Enter “Inhibit Tender” into the Keyword Search and click on the tick in the All column next to the “Inhibit MOTO” 

option. Doing this will enable the MOTO option on the Tender screen. 

 

 
 

Close the Yes/No options screen then open the POS Screen. 

Add an item to the sale then press the Enter button to go to the Tender screen. 

Select the MOTO option from the list of Tenders 
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A popup window will appear on the POS Screen showing that Idealpos has asked EFTPOS to do MOTO for the amount 

requested. 

 

 
 

The Pinpad will show a MOTO prompt with options to select Telephone Order or Mail Order. 

Select the option required by either pressing the number listed next to the required option, or use the 8/0 buttons to 

change the selected option. Press the green circle (O) button to select the highlighted option. 

 

 
 

  



The Pinpad will then prompt to enter the Card Number. 

Enter the Customer’s Card Number then press the green (O) button. 
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The Pinpad will then prompt for the expiry date. 

Enter the expiry date printed on the card then press the green circle (O) button 

 

 
 

  



The Pinpad will then prompt for the CVV number. This is typically the last three digits of the number printed at the 

back of the card. 
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Finally, the pinpad will show the total amount including any surcharges applicable to the transaction. 

To proceed, press the green circle (O) button. 

 

 
 

  



If the card is accepted, the transaction will be approved and a receipt will be printed from the receipt printer. 

If the card isn’t accepted or expired, the transaction will be declined. In the event the transaction is declined, you will 

need to try re-entering the card number again or try entering a different card number. 

 

  



 Update History 
 

Westpac Group – Support for Pinpad Surcharging 

This function adds the ability for Idealpos to support surcharging by the Pinpad. 

Surcharging and the surcharge amounts are enabled and configured by Westpac/Assembly Payments.  

To have Surcharging enabled on your pinpad along with the surcharge amounts, please speak to Westpac/Assembly 

Payments who will enable this functionality for you. 

Once Westpac/Assembly Payments have enabled surcharging on your pinpad, surcharges will be applied depending 

on the card type and account selected (e.g. Cheque, Savings, Credit). Idealpos will include surcharges on your Financial 

reports and these surcharges will also be exported to your Accounting Suite. 

 

In order for Idealpos to correctly report on any surcharges that have been collected from pinpad EFTPOS payments, 

you need to ensure that Undistributed Surcharge has been configured. 

To configure Undistributed Surcharge, a new dummy Stock Item needs to be created as well as creating a new Sales 

Category and Department. The dummy stock item is then defined in the Global Options and any surcharges are 

recorded against the Undistributed Surcharge dummy Stock Item. The steps involved in setting this up are outlined 

below: 

 

To create the Sales Category, go to File > Sales > Sales Categories > Add 

Enter “Other” into the Description field then press “Save” 

 

 
 

  



Close the Sales Categories screen, then go to File > Sales > Departments > Add 

In the Description field, enter “Other” then from the Sales Category dropdown box, select the Sales Category that was 

created in the previous step. Once done, press the “Save” button to save the Department. 

 

 
 

Close the Departments screen, then go to File > Stock Control > Stock Items > Add. 

Create a Stock Item called Undistributed Surcharge and ensure that you link it to the “Other” Department that was 

created in the previous steps above. If surcharges incur GST, ensure that GST is enabled, otherwise if surcharges are 

GST free, enable the GST-Free checkbox. Once you have finished creating the Undistributed Surcharge Stock Item, 

press the “Save” button to save the item. 
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Close the Stock Items screen, then go to Setup > Global Options > Sales > Undistributed Links 

 

 
 

Click on the “>” button in the Surcharges field to display the Stock Items screen. 

 

 
 

From the Stock Items screen, enter Undistributed into the Description search field, then select the Undistributed 

Surcharge from the list and press OK. 

 

 
 

The Surcharges field in the Undistributed Links section should now show the Stock Item Code for the Undistributed 

Surcharge Stock Item. 

 



 
Close the Global Options screen to save the change. 

 

EFTPOS Surcharges will appear on the Financial Report as Subtotal Surcharges. 

 

 
 

EFTPOS Surcharges are included in the EFTPOS Total: 

 

 
 

When surcharges are collected from EFTPOS payments, they will be recorded against the Undistributed Surcharge 

Stock Item. This means that the number of times and the total amount of surcharge collected can be identified by 

running the Stock Item Sales Report and selecting the Undistributed Surcharge Stock Item.  

In addition, surcharge amounts will be displayed under the Other Sales Category as well as the Other Department.  

These can be reported on by either:  

• Running the Stock Item Sales Report and selecting the Undistributed Surcharges Stock Item 

• Running the Department Report and selecting the Other Department 

• Running the Sales Categories Report and selecting the “Other” Sales Category 

 

These surcharges will be exported to your accounting suite and will appear under the Other Category. 
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EFTPOS Surcharges will also appear on the EFTPOS Settlement Reports as well as EFTPOS Settlement Enquiry Reports. 

 

EFTPOS Settlement Enquiry Report: 

 

  



Export Data 

Export Stock Sales – Option to Filter by Site 

This function adds the ability to Filter by Site when Exporting Stock Sales from Idealpos. 

The ability to Filter by Site when exporting Stock Sales is available for the following Output File Formats: 

• Impact Data 

• Nielsen 

• Standard Stock Item Sales 

• Generic 

 

To use this function, go to:  

Utilities > Export Data > Stock Item Sales then select one of the above Output File Formats which support exporting 

Stock Item Sales with the Site Filter option. 

 

The Options section will be displayed and contain a Site dropdown box. 

Select the Site which you want to export Stock Sales data for and set any other dates/date ranges to match your 

required criteria. You can select All Sites to export Stock Sales data from all sites or you may instead select an 

individual site of your preference from the list. If you want your selections to be pre-filled as the default values when 

opening the Export Stock Sales screen, press the “Set as Default” button at the bottom left corner of the window, 

otherwise, press the OK button to export the Stock Item Sales. 
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After pressing the OK button, the “Export Stock Sales to…” window will appear. 

Browse to a folder of your choice and press the “Save” button to save the exported data to the selected folder. 

 

 
 

The exported data can then be viewed by opening the exported file. 

As the data is exported in a comma separated file, the file can be opened with a Spreadsheet application such as Excel 

to view the data. 

 

  



Global Options – Restaurant 

Bill Print – Option to show Single Surcharge Percent 

This function adds the ability to show a single surcharge percent at the bottom of a bill when printing a bill from the 

table map. 

This is useful for users who have a single surcharge amount for all their payment types and they don’t want to have 

the surcharges repeated on the bill.  

Note that this function does not add a surcharge to the final amount; it is simply a way of conveying the surcharge 

amount to the customer when printing the bill. The actual surcharge is handled by the pinpad.  

The surcharge on the bill will be displayed as “Pay By CREDIT CARD (5%)”, where 5% will contain the percentage 

amount and CREDIT CARD can be substituted with any text of your choice; these values are configurable via the Global 

Options – Restaurant as outlined below. 

 

To configure this function, go to Setup > Global Options > Restaurant > Bill Print Surcharge Percent/Text 

 

 
 

Enter the Bill Print Surcharge Percent and if required, update the Text to reflect the payment type which incurs the 

surcharge. The Text entered below will be printed on the bill to reflect the payment type that incurs the surcharge. 
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Once the change has been made, close the Global Options screen. 

To demonstrate the use of the surcharge on a bill, follow the below steps: 

 

Add items to the sale then press the Table Map button. 

 

 
 

Select a table from the table map to transfer the sale to the table. 

 

 
 

  



If prompted, enter the number of covers (guests) for the table and press OK. 

 

 
 

Then while still viewing the table map, ensure that the table is selected and press the “Bill” button to print a bill for the 

table. 

 

 
 

When the bill is printed, it will now include a “Pay By” line that includes the Surcharge Text, Surcharge Percentage 

value and the Total amount due including the surcharge. 
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Ideal Webit 

Support for Add Stock Notes as Text option 

This enhancement adds the ability for Idealpos to display Stock Item Stock Notes in the Journal History Enquiry as well 

as on the POS screen for Stock Items that were ordered via a Web Order using Webit. 

 

To use this function, go to: Setup > Yes/No Options 

Ensure that the option “Add Stock Notes as Text into Sale” is enabled 

 

 
 

Go to File > Stock Control > Stock Items 

Setup a Stock Item (e.g. Delivery Charge). 

 

 
 

  



Click on the Advanced tab to add Stock Notes. 

Press the “Save” button at the bottom right corner of the Stock Items screen to save the change. 

 

 
 

When the Stock Item is ordered via Ideal Webit through the e-commerce site (e.g. Shopify) and the sale appears in the 

Web Orders screen in Idealpos, the Stock Notes will be displayed within the Web Orders screen as well as the Journal 

History Enquiry. 
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Go to: Enquiry > Journal History > Select Transaction 

 

 
 

  



Import Data 

Import Stock Items supports importing Supplier Quantity Type/Sell Quantity 

This function adds the ability to specify the Supplier Quantity Type and Sell Quantity in a Stock Item Import file. 

If the Supplier and Supplier Code have been specified in the file and if the Supplier Stock Code doesn’t already exist in 

the system for the Stock Item, the Supplier Stock Code record will be created and will set both the Supplier Quantity 

Type and the Sell Quantity as specified in the Stock Item Import file. 

If the Supplier Stock Code for the Stock Item already exists in the system, the system will not modify the Supplier 

Quantity Type or Sell Quantity. 

This function can be used either via the manual Stock Item Import method (Utilities > Import Data > Stock Items) or 

via the Automatic Import method (Setup > POS Terminals > Select: POS Terminal > Modify > Import/Export > 

Automatic Import Settings). For the purposes of this document, the manual import method will be demonstrated. 

 

To use this function, create a Stock Item Import file. 

Include the following headers in the Stock Item Import file:  

• SUPPLIERQUANTITYTYPE 

• SUPPLIERSELLQUANTITY 

 

SUPPLIERQUANTITYTYPE must have a value of either “Units” or “Cartons” 

SUPPLIERSELLQUANTITY must have a number value. 

 

A usage example for specifying the Supplier Quantity Type and Sell Quantity in an import file is listed below: 

 

CODE,DESC,DPT,STDCST,PRICE1,SUPP,SUPPCODE,SUPPLIERQUANTITYTYPE,SUPPLIERSELLQUANTITY 

1020001,SHORTS SMALL,101,8.30,21.50,1,01234ST,Units,15 

 

Create a CSV file with the above data and save as StockItemImp.csv. Save the file to a location you will remember. 

 

Go to: Utilities > Import Data > Stock Items 

Press the small magnifying glass icon to browse to the location where the StockItemImp.csv file was saved. 
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Browse to the location where the CSV file was saved. 

Change the file type option to show “CSV files”, then the file should appear. 

Select the file then press the “Open” button. 

 

 
 

 The contents of the file will be displayed on the Import Stock Items screen. 

Press the OK button on the bottom right corner of the screen to import the Stock Items. 

 

 
 

  



Idealpos will display an Imported Records prompt showing the number of Items that were either New, Modified or 

Failed. Press the “OK” button to close the prompt. 

 

 
 

Go to: File > Suppliers > Supplier Stock Codes > Select: Supplier > Select Supplier Stock Code > Modify 

 

The newly imported Supplier Stock Code will show the Quantity Type (Cartons or Units) and the Quantity as per the 

Stock Item Import file. 
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Journal History Enquiry 

Gift Voucher Balance recorded to the Journal 

This function enhances the querying of Journals which had a Gift Voucher redemption occur by recording the Gift 

Voucher Balance to the Journal. This function enables a venue to view the balance of a voucher at the time of the 

transaction. 

 

To use this function, go to: Enquiry > Journal History > Select: Transaction which contains a Gift Voucher redemption 

 

The Journal History Enquiry will display the remaining balance at the time that the Gift Voucher was redeemed. 

 

  



POS Screen 

Show POS Description on BackOffice and POS Screen Captions 

This function implements the display of the POS Description on the BackOffice screen as well as POS Screen Captions. 

The POS Description is only displayed on the POS screen when the POS is displaying the “Enter Clerk” screen.  

When Compulsory Clerk is turned on in the Yes/No options, the POS Description will be displayed on the POS screen 

after completing each sale. Otherwise if the Compulsory Clerk option is not enabled in the Yes/No options, the Clerk 

button can be used on the POS screen instead to return the POS to the Enter Clerk screen. 

 

If Compulsory Clerk isn’t enabled, press the “Clerk” button, then the POS Description will be displayed at the top left 

corner of the POS screen as indicated in the below example. 

 

  
 

Should you need to update the POS Description, close the POS screen then go to: 

Setup > POS Terminals > Modify 

Under the Main Settings section, update the Description in the Description field, then close the POS terminals screens 

to save the change. 

 

 
 

Then open the POS Screen. The updated POS Description will be displayed when the POS displays the “ENTER CLERK” 

screen. 

 

 

Stock Item Search function – Default Search Type option 

This function adds the ability to specify the Default Search Type when programming a Stock Item Search button.  
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After the button has been programmed, pressing the Stock Item Search button will open the Stock Item search screen 

and will automatically select the Search Type that was specified for the button. Examples of available Search Types are 

Code, Description, Alternate/Scan Codes, etc. The Default Search Type option can also be used in combination with 

the Automatic Text option. When using both Automatic Text and the Default Search type, the Stock Item Search screen 

will open and will pre-select the Search Type and will also pre-fill the search box with the value entered in the 

Automatic Text field. 

 

To use the Default Search Type option with the Stock Item Search function, create a Stock Item Search button by 

going to: 

Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons 

 

 
 

  



Select a blank button on the POS Screen clicking on a blank button then select the Stock Item Search function from 

the list of Functions. 

 

 
 

After selecting the Stock Item Search function, fields for Automatic Text, Department and Search Type will become 
available. 

The Search Type field is used to specify which Search Type will be selected when using the button to open the Stock 

Item Search screen. To use any of the below Search Types, enter them into Search Type field exactly as they’re listed 

below, including the square brackets surrounding the Search type. 

[CODE] – Used to search for a Stock Item using the Stock Item’s Code 

[DESCRIPTION] – Used to search for a Stock Item using the Stock Item’s Description 

[ALTERNATE/SCAN CODES] – Used to search for a Stock Item using the Stock Item’s Alternate Code or Scan Code 

[SUPPLIER’S STOCK CODE] – Used to search a Stock Item using the Stock Item’s Supplier Stock Code 

[DESCRIPTION 2] – Used to search for a Stock Item using the Stock Item’s Description 2 value 

[DEPARTMENT] – Used to search for a Stock Item using the Stock Item’s Department description 

[PRICE CHANGES][PRICELEVEL][DATE] – Used to search for a Stock Item using the date/time since the last Price 

Change. Any Price Changes that have occurred between now and the selected date/time will be displayed. To use this 

function, the Search Type needs to be entered in the exact order as listed and no spaces between each square bracket. 

Replace the PRICELEVEL text with the Price Level label that you want to search and replace the Date with the date that 

you want to search for. An example showing the usage of the Price Changes function is listed as below. 

[PRICE CHANGES][STANDARD][01 JAN 2018] 

[ATTRIBUTETYPE][ATTRIBUTE] – Used to search for a Stock Item by Attribute Type and Attribute. To use this 

function, specify the Attribute Type that you want to search for followed by the Attribute value. 

E.g. [ATTRIBUTETYPE=Container Type][ATTRIBUTE=Can] 

In the above example, any Stock Items with an Attribute Type of “Container Type” which have an attribute of “Can” will 

be displayed in the Stock Item Search screen. 
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To demonstrate the configuration of a POS Screen button with the Search Type function, a screenshot has been 

included below: 

 

 
 

When pressing the Stock Item Search button from the POS screen for the above button configuration, the Stock Item 

Search screen will open and the Search Type will be pre-selected as per the below example. 

 

 
 

Any item on the Stock Items search screen can be selected to add the item to the sale. To add an item to the sale from 

the Stock Items search screen, double click on the item and it will be added to the sale. Alternatively, you may click on 

the item once followed by pressing the “OK” button on the bottom right corner of the Stock Item search screen. 

  



The Automatic Text field can be used in combination with the Search Type for all Search Types excluding [PRICE 

CHANGES] and [ATTRIBUTE]. Note that the Automatic Text is not compulsory and can be left as blank.  

If you specify a Search Type and leave the Automatic Text field blank, the Search Type will be selected and no search 

value will be entered into the search box in the Stock Item Search screen. 

 

Example usage of Automatic Text in combination with the Search Type function: 

 

 
 

When pressing the Stock Item Search button from the POS screen for the above button configuration, the Stock Item 

Search screen will open and the Search Type will be pre-selected as well as the Automatic Text being entered as per 

the below example. 

 

 
 

Any item on the Stock Items search screen can be selected to add the item to the sale. To add an item to the sale from 

the Stock Items search screen, double click on the item and it will be added to the sale. Alternatively, you may click on 

the item once followed by pressing the “OK” button on the bottom right corner of the Stock Item search screen. 
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POS Screen Grids 

Stock Item Search function on POS Grids 

This function adds the ability to create a Stock Item Search button a POS Screen Grid. 

The Stock Item search button can then be used to display the Stock Items screen from where the operator can search 

for a Stock Item by searching based on the Code, Description, Alternate/Scan Code, Supplier’s Stock Code, Description 

2, Department, Price Changes or Attribute. Once the item has been selected from the Stock Item search screen, the 

item will be added to the POS sale. 

 

To create a Stock Item Search button on a POS Screen Grid, go to: 

Setup > POS Screen > Grids > Select a POS Screen Grid > Items 

 

 
 

Select a blank button on the selected POS Screen Grid by clicking on a blank button. 

  



A POS Screen Grids window will then appear.  

Select the Stock Item Search Function. 

After selecting the Stock Item Search function, new fields will appear for entering Automatic Text and Search Type. 

The Automatic Text field is used to enter a value which will be pre-filled into the search box when using the button. 

Using the Automatic Text function can save the operator time if they are always searching for items which start with a 

particular Code, Description, located in a specific department, etc. 

The Search Type field is used to specify which Search Type should be selected when using the button. 

The search types available for use with the Stock Item Search button are: 

[CODE] – Used to search for a Stock Item using the Stock Item’s Code 

[DESCRIPTION] – Used to search for a Stock Item using the Stock Item’s Description 

[ALTERNATE/SCAN CODES] – Used to search for a Stock Item using the Stock Item’s Alternate Code or Scan Code 

[SUPPLIER’S STOCK CODE] – Used to search a Stock Item using the Stock Item’s Supplier Stock Code 

[DESCRIPTION 2] – Used to search for a Stock Item using the Stock Item’s Description 2 value 

[DEPARTMENT] – Used to search for a Stock Item using the Stock Item’s Department description 

[PRICE CHANGES] – Used to search for a Stock Item using the date/time since the last Price Change. Any Price 

Changes that have occurred between now and the selected date/time will be displayed. 

[ATTRIBUTE] – Used to search for a Stock Item using the Attribute field 
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Promotions 

Option to Disable Gaming Points Accrual on a Promotion 

This function adds the ability to disable the accrual of Gaming or standard Points for any Promotion in Idealpos. 

To disable gaming points/Points accrual for a promotion, go to: 

Setup > Yes/No Options 

 

Ensure that the option Inhibit Points on Discounts/Promotions is disabled 

 

 
 

Go to: File > Sales > Promotions > Promotions > Select a Promotion > Modify 

Select the Advanced option at the top of the screen  

 

 
 

  



Enable the checkbox next to “Inhibit Points” then close the Promotions window. 

 

 
 

Confirm the change by selecting “Yes” 

 

 
 

Close the Promotions window. 

 

Open the POS screen, add a Customer to the sale then trigger the promotion by adding the required number of items 

to the sale. In the below example, two PORTERHOUSE (Stock Code 107008) items from the MAIN department were 

added to trigger the Main Meal Buy 1 Get 1 Free promotion and the customer Sarah Charlton was added to the sale. 

The Promotion has been triggered as per the “Discounts” amount shown below. 
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Press the “Enter” button, then either select a tender amount or press “Cash” to cash the sale off. 

 

 
 

After the sale has been tendered, add the customer to the next sale. 

The Customer’s total points value displayed on the POS screen is the same as the value displayed on the previous sale. 

 

 
  



In addition, the points earned by the customer in previous transactions can be checked by going to:  

Reports > Customers > Customer Journal History 

 

Select the Date Range which the transaction occurred, enter the Customer’s Code then press the “View” button. 

 

 
 

The Points value for the transaction will be 0.00 as the Promotion was set to Inhibit Points. 

 

 
 

The above example demonstrates inhibiting standard customer points in a promotion, however, the Inhibit Points 

option is also applicable for inhibiting the accrual of Gaming Points within a Promotion. 
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Purchase Orders 

Purchase Orders – Option to show Stock Code next to Description 

This function adds the ability to display Stock Codes next to the Description on Purchase Orders.  

 

To enable this function, go to: Setup > Global Options > Purchases > Purchase Order Default Settings 

Enable the option “Show Stock Codes next to Descriptions” 

 

 
 

Close the Global Options screen. 

  



Go to: Transactions > Stock Control > Stock Purchases > Add 

Set the Purchase Type to Purchase Order, select the Supplier and fill out the required fields as per the Purchase Order. 

Add the required items to the order then press the Save button to save the order 

 

 
 

Select the Purchase Order from the list and press the “View” button 
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The Purchase Order will be displayed and the Stock Codes will be shown next to the Item Descriptions on the Purchase 

Order as per the below example. 

 

 
 

 

 

 

 

 

  



Raffles 

Raffle Tickets show Customer Name and Code 

This feature enables printing the Customer Name and Customer Code on a raffle ticket when a Customer is added to 

the sale at the time the raffle tickets are purchased. If a customer is not added to the sale at the time a raffle ticket is 

purchased, the ticket will be printed without a Customer Name and Customer Code. 

 

To use this function, go to: POS Screen > Add a Customer to the Sale > Sell a Raffle Ticket by adding the ticket from a 

POS Screen button or enter the Stock Item Code for the Raffle Ticket 

 

 
 

Press the Enter button then select a Tender/Amount to finalise the sale. 

The receipt and raffle ticket will print. 
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Range Programming 

Range Programming allows bulk changes of Large Stock Notes data 

This function adds the ability to specify large Stock Notes data when using the Range Programming function to 

update a range of Stock Items. Previous to this change, the maximum character limit that was supported for the Stock 

Notes field via Range Programming was 10 characters. This limitation has now been removed. 

 

As Range Programming is an advanced function and is possible to change values for all Stock Items, we highly 

recommend that you exercise caution when using it. Create a backup of your Idealpos database if required. 

 

To use this function, go to: Utilities > Range Programming > Stock Items 

 

 
 

At the top of the Range Programming screen, specify the range of Stock Codes/Descriptions/Departments/Suppliers 

that you want to apply the range programming to. Note that if you leave the Code, Description, Department and 

Supplier fields blank when performing range programming, the changes specified in the fields below will apply to ALL 

Stock Items in your system after you press the “Proceed” button. 

You will also see a range of blank dropdown fields with the text “Field” next to them. You can program up to a 

maximum of twelve fields at once. 

To program the Stock Notes field, click into the first Field dropdown box and select the “Stock Notes” option. 

To the right-hand side of the field, you will see an equals (=) sign along with another blank field. 

Specify the Stock Notes that you want to set for the items in the blank field next to the equals sign. 

If you want to update any other fields for the criteria specified, select the desired fields from the dropdown boxes 

along with the value you want to set for those fields. 

Once you’re ready to perform the range programming, press the “Proceed” button on the bottom right corner of the 

Range Programming window. Wait while the range programming is completed. 

  



In the below example, Stock Codes between 1 and 10 will have Range Programming applied to them. 

The Stock Notes value will be set to “A Stock Note is used to list extra info about the item”. 

 

 
 

After pressing the “Proceed” button, a confirmation will be displayed. 

Press “Yes” to proceed with Range Programming. 

 

 
 

After Range Programming has completed, a “Programming Completed” message will be displayed to indicate that 

programming was completed successfully. 
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Any Stock Item that was included in the range of Stock Codes specified has had the Stock Notes updated. 

To confirm, you can open the Stock Item via the Stock Items screen to view the updated Stock Notes. 

Close the Range Programming screen, then go to:  

File > Stock Control > Stock Items > Select: Stock Item > Modify > Advanced > Stock Notes 

 

 
 

  



Receipts 

Ability to encode Customer into QR Code on Receipts 

This function enables the ability to include the Customer Code as well as text in a QR Code that is printed at the 

bottom of a Customer Receipt. This may be useful for cases where you have a loyalty website and you want to pass the 

Customer Code through to your website when a customer scans the QR Code at the bottom of their receipt. 

 

To use this function, go to: Setup > Global Options > Printing > QR Codes 

 

 
 

Configure the QR Code section with the settings and values you want used to print on the bottom of your Customer’s 

receipts. Enable the “Print on Receipt Footer” setting to print the QR Code at the bottom of the Customer Receipt. 

Enable the “Print on Coupons” setting if you also want the QR Code printed on any coupons printed from the POS 

terminal. Enter a value between 2 and 9 into the QR Code Size field. You may want to try a few different sizes and print 

a receipt to see what size suits your needs. We also recommend testing the QR Code by scanning it with a smartphone 

to ensure that it is readable. Should the smartphone have difficulty reading the QR Code, try setting a larger QR Code 

size. 

An example screenshot showing the QR Code configuration for printing the Customer Code and text within the QR 

Code Data has been included in the below screenshot: 
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When a receipt is printed from the POS terminal, the QR Code will be included on the Receipt Footer. 

If you include the [CUSTOMERCODE] field in the Receipt QR Code Data, the Customer Code will be included if you add 

a Customer to the sale. If a Customer isn’t added to the sale, the Receipt QR Code Data will still be included on the 

receipt, but it will exclude the Customer Code.  

Using the above screenshot as an example for a case when a Customer isn’t added to the sale, the Receipt QR Code 

Data that will be printed on the receipt will include the URL address of https://www.customerloyaltyprogram.com/ 

however will not include the Customer’s Code after the URL. 

 

An example Receipt showing the QR Code Data is listed below: 

 

 
 

  

https://www.customerloyaltyprogram.com/


Region 

USA and Canada Regions split into separate options 

This option splits the USA and Canada regions into separate options for the purpose of setting the Fast Cash Button 

images on the Tender Screen to match the currency of the Canada or USA region. This function is only available when 

performing a clean install of Idealpos or after performing a full system reset of Idealpos then starting Idealpos. 

Selecting Canada or USA both use the same Tax options. Also note that the USA and Canada regions are still grouped 

as a single option from the POS Terminals settings screen. 

WARNING – Performing a full system reset will remove all data from your database including Sales History, Journals, 

Stock Items, Clerks, POS Screens. 

 

To use this function, a clean install of Idealpos or a full system reset needs to be performed. 

As mentioned above, a full system reset will completely erase and remove all data from your database and this 

action must not be performed on a production/live system which is being used for trade as data loss will occur. 

 

To use this function, perform a full system reset via the IPS Utility > Advanced menu. After performing a full system 

reset or clean install of Idealpos, start Idealpos. 

You may see the following popup appear at the bottom right corner of the screen. 

Double click on the IPSClient logo to open POS. 

 

 
 

After opening Idealpos, the country selection window will open. 

The USA and Canada options have been separated on this screen. 

Click on USA. 
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The screen will then show the option to use the Demonstration Database or Blank Database. 

Selecting Demonstration Database will setup Idealpos with a database that is ready for immediate use to test and 

demonstrate Idealpos. 

Selecting Blank Database will setup Idealpos with a blank database. If you select Blank Database, you will need to 

manually create the required Departments, Stock Items, POS Screen Buttons, Clerks and any other data that is required 

for your store. 

For the purpose of this document, Demonstration Database has been selected. 

 

 
 

After selecting Demonstration Database, Idealpos will start then the POS Screen will be displayed. 

 

 
  



Add items to the sale then press the Enter button 

 

 
 

The images used for the Fast Cash buttons will match the currency used in the USA region. 
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The POS Terminal Settings screen (Setup > POS Terminals > Modify) will still show a region of Canada / USA. 

 

 
 

Once a region has been selected as part of the clean install/full system reset process, the images displayed on the Fast 

Cash Buttons can only be changed manually via the Global Options screen. Changing the Region via the above POS 

Terminals settings screen will not automatically change the images displayed on the Fast Cash buttons. 

 

To update the Fast Cash button images, go to: Setup > Global Options > General 

 

 
  



Under the Fast Cash section, click on the “>” button within the Graphic field for the amount denomination that you 

want to update. 

 

 
 

An Open window will be displayed. 

Select the image of the currency denomination that you want to use. Idealpos includes images for note denominations 

for various regions. The filenames of the images are named in the format of denomination amount, note, then the 

region. 

E.g. “50noteAUS.jpg” resembles a denomination of $50.00 for the Australia region. 

Press the “Open” button once you have selected the required image. 

 

 
 

The new Fast Cash button image will be displayed on the Fast Cash Buttons screen for the denomination selected. 
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The updated image will be displayed on the Tender screen when finalising a transaction from the POS screen. 

 

 
 

  



Reports 

Banking Report: XREPORT with LOCATION tag 

This function adds the ability to print an XREPORT from a single terminal and combines the shifts that were completed 

on other terminals within a location. This function will show the combined total of the current shift completed across 

all terminals within the location. The requirement for this to work is that the shift start time must be the same on all 

terminals in the location. This means that if the time the shift started on other terminals differs to the shift of the 

current terminal which the report is being run on, the totals from those shifts will not be included.  

 

To use this function, go to: Setup > POS Screen > POS Screen Setup > Select: POS Screen Layout > Buttons > Banking 

Report button > Automatic Text: XREPORT LOCATION 

 

In the below example, the Banking Report button has been configured to perform the XREPORT for the Location, 

however, you may want to create a new button specifically for performing an XREPORT for the Location. 

Press the “Save” button to save the change. 
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Go to the POS screen and press the Banking Report button. 

The X-REPORT will be displayed for the shift at the Location and show combined totals from all terminals that are also 

currently on the same shift. 

 

  



Gift Voucher Report with drill-down transactions – Added running total column 

This function adds the ability to drill-down into a Gift Voucher Report and show a running total column when running 

the Gift Voucher report with the “Include drill-down transactions” option enabled. 

 

To use this function, go to:  POS Screen > Gift Voucher Button 

 

 
 

Enter an amount, Customer Name and Email Address if the Customer has one, then press OK. 

 

 
 

The Gift Voucher will appear on the Idealpos POS screen along with the Gift Voucher amount. 

 

 
 

Press the “Enter” button on the POS screen then cash the sale off by either pressing the Cash button or one of the 

tender amounts. 
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A receipt will be printed along with a printout of the Gift Voucher. 

 

The sale will be finalised and the POS screen will be displayed ready for processing another sale. 

Add items to the sale then press the “Enter” button to go to the Tender screen. 

 

 
 

  



Redeem the Gift Voucher by pressing the Gift Voucher Redeem button. 

Note that if the GV Voucher Tender option does not appear, you will need to enable it via Setup > Yes/No Options > 

Inhibit Tender. 

 

 
 

Scan the voucher or press the “Name Search” button. 
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Enter the name into the “Enter Name” field, select the customer name from the list on the right-hand side of the 

screen, then press the “Use” button at the bottom right corner of the screen. 

 

 
 

The Voucher Code will appear in the Scan or Enter Voucher Code field. 

Press the “Add” button to add the voucher to the transaction. 

 

 
  



The Voucher Code and Redeeming Amount will be displayed. 

Press the “Finalize” button to finalize the redemption of the Gift Voucher. 

 

 
 

If the “Reference” option has been enabled for the Gift Voucher tender, you will be prompted to enter a reference for 

the tender. 

Enter a reference, then press the “Enter” button. 

 

 
 

A receipt will be printed along with another Gift Voucher containing the remaining balance. 

 

The Gift Voucher Report can now be run to show the drill-down of the Gift Voucher. 
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To run the report, go to: Reports > Sales > Gift Voucher Report 

 

Select the required period and ensure that the “Include drill-down transactions” option is enabled, then press the 

“View” button to run the report. 

 

 
 

When the report is initially displayed, a list of Gift Vouchers will appear and show the Gift Voucher Amount 

(GVAmount column), Redeemed and Balance amounts. 

In order to view the drill-down details for a voucher, double-click on the Gift Voucher. 

In the below example, we will double-click on Gift Voucher 9898414687501. 

 

 
 

The Gift Voucher will be expanded and show the running total column. 

The first amount is the initial amount, and the subsequent amount is the value remaining after the first redemption. 
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Stock Valuation Report – Summary option enabled for Department/Sales Category Groupings 

This function adds the ability to run the Stock Valuation Report with a Summary option enabled when Grouping by 

Department or Sales Category.  

When running with the Summary option enabled, the report will be only show the Departments or Sales Categories 

with the Stock Level, L/B Leve, Avg Cost and Stock Value. The individual items contained within the Departments or 

Sales Categories will be excluded from the report. This may be useful for customers who only want a summary of Stock 

Level and value of stock in a Department or Sales Category instead of listing all items from the Department or Sales 

Category. 

 

Go to: Reports > Stock Control > Stock Valuation 

 

Enable the Department or Sales Category checkbox under the Group By section, then enable the Summary checkbox 

under the Options section.  

 

 
 

  



Press the “View” button at the bottom right corner of the Stock Valuation Report window to view the report. 

The Report will be displayed in Summary view and will show either Departments or Sales Categories depending on the 

Group By selection. 

 

The below example Stock Valuation Report was produced with the Group By option set to Department. 

 

 
 

The below example Stock Valuation Report was produced with the Group By option set to Sales Category. 
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Supplier Selection on Promotion Details by Item Report 

This function adds the ability to specify a Supplier when running the Promotions Report using a Report Type of 

“Promotion Details by Item”. This will then allow you to report on any items from a particular supplier that were 

included in a promotion. This may be useful in situations where a supplier may want a report from a store to show how 

many items were sold as part of a promotion in order to claim a cashback or commission from a supplier for selling 

the items. 

 

To use this function, go to: Reports > Sales > Promotions 

Set the Report Type to “Promotion Details by Item”. 

The Supplier field will then appear in the Selection Range. Click on the “>” button in the field to specify the Supplier. 

 

 
 

Press the View button to view the Promotions Report. 

The Promotions by Item Report will be displayed and will contain any Items from the selected Supplier that were 

included in any Promotions within the date range selected. 

 

 
  



Restaurant & Table Map 

Table Details – Auto Select Priced Instruction when Parent Item is selected 

This function will auto select the Priced Instruction Item when selecting a Parent Item from the Table Details screen. 

This is a useful feature to save operators time when each guest from a table pays for their own meal and the 

instruction items that were ordered incur an additional expense. There is no configuration required to enable this 

function as it is hard-coded and always enabled. 

 

To use this feature, go to: POS Screen > Add Item to the sale (e.g. Cappuccino) > Add Priced Instruction to the sale 

(e.g. Decaf). In this example, the Cappuccino is the Parent Item and the Decaf Instruction Item is the Priced Item as per 

the below example. 

 

 
 

Then press the Table Map button, select a Table from the Table Map, then enter the number of Covers if prompted. 
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Ensure that the Table is selected on the Table Map and press the “Details” button 

 

 
 

Select the Parent Item (Cappuccino) by clicking on it. 

The Priced Instruction item (Decaf) will be auto selected. 

 

 
 

The Items can now be paid off by pressing the “Pay” button on the bottom right corner.  



Table Details – Instruction Items Indented for greater readability 

The Idealpos Table Details screen has been updated to show Instruction Items Indented for greater readability. 

This allows the operator to easily distinguish Instruction Items apart from normal Stock Items on the Table Details 

screen. 

 

Go to: POS Screen > Add a normal Stock Item (e.g. Cappuccino) then add an Instruction Item (e.g. 2 SUGAR) 

 

 
 

Then press the Table Map button, select a Table from the Table Map, then enter the number of Covers if prompted. 
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Ensure that the Table is selected on the Table Map and press the “Details” button 

 

 
 

The Table Details will be displayed and any instruction items will be indented for greater readability 

 

  



Table Details – Reorder Items Function 

This function adds the ability to reorder items already saved to a table via the Table Details screen. This feature may be 

useful in cases where a customer has ordered a drink or meal at their table, finished the meal, and has come back to 

the counter wanting to reorder the same meal. The operator can select the customer’s Table from the Table Map, then 

select the required items and press the Reorder button. The selected items will be added to the sale where the 

operator will have the opportunity to add any other additional items.  

Finally, they can press the Table Map button which will save the sale back to the same table and the docket(s) will be 

printed to the Kitchen Printers. 

 

To use this function, go to:  

POS Screen > Table Map > Select a Table that contains an Order > Details 
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To reorder items, first select the required items from the Table Details screen. When selecting the items, they will 

highlight in grey to indicate that they’ve been selected. After the items have been selected, press the “Reorder Items” 

button. 

 

 
 

The POS Screen will be displayed with the items that were selected on the Table Details screen. 

 

 
  



If required, additional items can be ordered. Press the “Table Map” button to save the sale to the table. 

The Kitchen Docket will be printed to the Kitchen Printer(s) and the reordered items will appear on the Table Details 

screen. 
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Sale Type Printing 

Support for Sale Type printing on Table/Hold Print Sales 

This function adds the ability for the Sale Type status to print on Kitchen dockets as well as on Hold Print Sales. 

Examples of Sale Types are Takeaway, Delivery, Pickup and Cater. These can be modified to suit your requirements. 

There is no configuration required to toggle the printing of the sale type on a Kitchen docket or Hold Print sales.  

This way this feature works is simply if a Sale Type has been specified or selected during the sale, the Sale Type will be 

printed on the Kitchen docket and Hold Print Sales. If a Sale Type has not been specified or selected during the sale, 

the Sale Type will not be printed. 

 

You may need to create a button on your POS Screen to enable the ability to use a Sale Type. You may also need to 

setup the Sale Types to suit your requirements. This is outlined as follows. 

 

To update the available Sale Type Statuses in your system, go to:  

Setup > Global Options > Sales > Sale Type Status 

 

 
 

  



To add Sale Type buttons to your POS Screen, go to: 

Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons 

 

 
 

Find a blank button on the POS Screen. If a blank button isn’t available, try navigating to another page and find 

available blank buttons (as per the above example screenshot, the Retail page has an available block of blank buttons). 

 

Click on a blank button and select the “Sale Type” option from the list of functions.  

After selecting the “Sale Type” function, the Status and Price Level options will appear.  

Select the desired Sale Type from the Status dropdown box. Note that if you have more than one Sale Type that you 

want to use, you will need to create a separate button for each Sale Type on the POS Screen.  

If you want to apply a different Price Level to the sale when using the Sale Type button, make sure you select the 

desired Price Level from the Price Level dropdown box. 
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Press Save to apply the change for the selected button and repeat the above process if required to create additional 

Sale Type buttons on your POS Screen. 

 

To apply the Sale Type to the sale, simply press the Sale Type button during the sale. 

After pressing the Sale Type button, the Sale Type will be displayed at the top-right corner of the POS Screen. 

 

 
 

Add Stock Items to the sale then save the sale to a table by pressing the Table Map button followed by selecting a 

Table from the Table Map. When the Kitchen docket(s) are printed, they will contain the Sale Type. 

 

 
 

  



Schedules 

Schedules – Ability to modify the POS number that Processes the Schedule 

This function enables the ability to modify the POS number from where the email schedules are sent from without 

having to completely remove the schedule and add/configure it on another POS terminal. 

 

To use this function, go to: Setup > Schedules > Select the Scheduled Report > Modify 

Modify the POS number in the POS field to reflect the POS terminal that should process the Schedule  

 

 
 

To save the change, close the Schedules window and confirm the change by pressing “Yes” to the Save Changes 

prompt. 

 

 
 

The Schedule will be processed by the POS number defined in the POS field.  
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Shortcuts 

Journal Enquiry to Stock Item Sales – Ability to Create Shortcut 

This function adds the ability to create a shortcut to the Stock Item Sales Report using the criteria that was selected 

when running the Journal Enquiry then opening the Stock Item Sales screen. 

 

To use this feature, go to:  

Enquiry > Journal History 

 

  
 

Select the criteria for the Journal History Enquiry by choosing the desired options using the dropdown boxes and fields 

available at the top of the Journal History Enquiry screen. 

 

 
 

  



Once you have selected your desired criteria, press the “Select” button, then press the “Stock Item Sales” button 

located at the bottom of the Journal History Enquiry screen to run the Stock Item Sales Report. 

 

 
 

The Stock Item Sales Report will then be displayed using the criteria that was selected. 

 

 
 

Press the ‘S’ shortcut button at the top right corner of the screen to create a shortcut to the report. 
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Name the Shortcut then select a location to save the Shortcut to (Favourites or Others) 

 

 
 

When saving the shortcut to the Favourites location, a shortcut will appear under the “Favourite Reports” section of 

the main Idealpos Back Office screen and when saving the shortcut to the Others location, the report will appear under 

the “Other Reports” section as per the below illustration. 

 

 
 

  



Once the shortcut has been created, run the report by clicking on the Shortcut from either the Favourite or Other 

Reports section. 

The Stock Item Sales Report will run using the selection criteria that was used when the shortcut was created. 
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Stock Item Attributes 

Support for Yield Percentage Attributes 

This function adds the ability to set Yield Percentage Attributes in Idealpos which can then be set against Stock Items. 

Yield Percentages can be used in cases where only a specific percentage of a Stock Item can be used to manufacture a 

Stock Item. An example of this is using an Onion as an ingredient when making a Pizza; only 70% of the onion can be 

used due to peeling the onion and disposing of any offcuts. In addition to manufacturing Stock Items, Yield 

Percentages can also be used when selling Stock Items. An example scenario for using the Yield Percentage function 

when selling an item could be a shop selling meat. A butcher purchases meat which contains a bone, then when a 

customer visits the butcher, they may request that the butcher cuts out the bone for them. Therefore, there is wastage 

at the time the meat is sold and the initial quantity of meat that the butcher purchased is not entirely sold to the 

customer due to the removal of the bone. This may be the case when selling ham – a butcher has a leg ham that 

contains a bone and they slice the ham off the leg for their customers. The bone is never sold and accounts for 

wastage. 

 

To configure Yield Percentage Attributes, go to: File > Sales > Stock Item Attributes 

Click on the “Add New Attribute Type” button at the bottom left corner to add the new Attribute Type 

 

 
 

Enter “Yield Percentage” into the Add Attribute Type field then press the Save button to save the Attribute Type 

 

 
 

Press the X at the top right corner of the Stock Item Attributes window to close the Add Attribute Type screen. 

  



Select the “Yield Percentage” Attribute Type from the list of Attribute Types then click on the “Add New Yield 

Percentage” button. 

 

 
 

Enter the required Yield Percentage into the “Add Yield Percentage” field then press the “Save” button. 

We recommend adding 50, 60, 70, 80 and 90, but you may want to enter other amounts as required. 

 

 
 

Repeat the process for each Yield Percentage required. 

Once you have finished adding the required Yield Percentages, press the X at the top right corner of the screen to 

close the Add Yield Percentage screen. 

 

After creating the Yield Percentage Attribute and types, the Stock Item Attributes screen should look similar to the 

below depending on the percentages that you’ve added. 

 

 
 

Once the Attribute Type and Attributes have been created, the Attribute Type and Attribute then need to be linked to 

the required Stock Items. 
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Close the Stock Item Attributes window, then go to:  

File > Stock Control > Stock Items > Select a Stock Item for Attributes > Modify > General > Attributes 

 

Under the Attributes section, click on a dropdown box on the left and select “Yield Percentage” from the list of 

available options. Then in the dropdown box on the right, select the Yield Percentage that is required. 

In the below example, a Yield Percentage of 70% has been linked to the Onion Brown Stock Item. 

 

 
 

Press “Save” to save the change to the Stock Item. 

The Stock Item “Onion Brown” is used as an ingredient to manufacture the Stock Item “Supreme Pizza”. 

Open Stock Item “Supreme Pizza” and ensure that “Indirect Item” and “Manufactured Item” are both enabled under 

the “Other Options” section. 

 

 
 

  



After the Indirect Item option is enabled, the Indirect Item tab will be enabled. 

Click on the “Indirect Item” tab then press the “Add” button. 

 

 
 

In the Component Stock Code field, press the “>” button and select the Brown Onion Stock Item then enter the Stock 

Item Quantity used to manufacture the Supreme Pizza. In the below example, the quantity has been entered as a 

fraction “50/1000”. Press the “Save” button to save the change then close the screen by pressing the X button at the 

top right corner of the Indirect Items screen. 
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The “Indirect Item” tab should then show the “Onion Brown” under the “Made up of” section. 

 

 
 

Press the “Save” button to save the change. 

 

Manufacture a single “Supreme Pizza” Stock Item by going to:  

Transactions > Stock Control > Manufacture Items > Add 

 

From the Stock Code column, click on the down arrow to display a list of Manufactured Stock Items in the system, then 

click on the Supreme Pizza. 

Enter 1 into the Quantity to Manufacture field and fill out the Batch Name field. 

 

 
 

Press the “Save” button on the bottom right corner of the Manufacture Items screen to save the Manufacture Batch. 

 

  



Select the batch from the Manufacture Batches screen then press the “Process” button. 

 

 
 

Idealpos will display a prompt to confirm if you want to process this Manufacture Batch. Select “Yes” to continue. 

 

 
 

After the batch has been manufactured, Idealpos will display the below prompt. Press “OK” to continue. 

 

 
 

Close the Manufacture Batches screen.  

  



 Update History 
 

Go to: Reports > Stock Control > Stock Transaction 

Press the “View” button at the bottom right corner of the window to run the Stock Transaction Report. 

 

 
 

The Stock Transaction Report will show the transfer of Onion Brown used for the manufacture of the Supreme Pizza 

Stock Item. The Quantity used to manufacture the Supreme Pizza will be 50/1000 using a Yield Percentage of 70%. 

The formula for calculating the Quantity when a Yield Percentage is set is Quantity x (100 / Yield Percentage). 

So in this example, the Quantity is 0.05 (50/1000=0.05) and Yield Percentage 70%. 

0.05 x (100 / 70) = 0.0714285714285714 

 

 
 

  



The Quantity used to manufacture the item can also be viewed via the Stock Item Enquiry. 

Go to: Enquiry > Stock Items > Code: Enter Code for Onion Brown > Stock Transactions > Period: Today 
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As initially mentioned, Yield Percentages can also be used when selling a Stock Item such as ham from a bone. 

 

Go to: File > Stock Control > Stock Items > Select stock item: LAMB LEG > Modify > General > Attributes 

 

Under the Attributes section, click on a dropdown box on the left and select “Yield Percentage” from the list of 

available options. Then in the dropdown box on the right, select the Yield Percentage that is required. 

In the below example, a Yield Percentage of 80% has been linked to the Lamb Leg Stock Item. We recommend that 

you perform your own research and perform your own yield tests to determine the required Yield Percentage value. 

Press the “Save” button once the change has been applied. 

 

 
 

  



Open the POS screen and sell the required quantity of the Item (as mentioned above, this may be used in a butcher 

shop after removing bones). The below example shows 1KG of Lamb Leg. 

 

 
 

Press the ENTER button to proceed to the tender screen then cash the sale off. 
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A receipt will be printed for the customer and will contain the amount sold as indicated on the POS screen (1.000KG). 

 

 
 

The Stock Transaction Report can be opened to confirm the actual amount deducted from the Stock Level (which 

factors in the Yield Percentage amount that has been set for the Lamb Leg Stock Item). 

 

Go to: Reports > Stock Control > Stock Transaction > View 

 

The Sale will be displayed and the Quantity will be as per the Yield Percentage configured for the item. 

As mentioned previously, the formula for Yield Percentage is Quantity x (100 / Yield Percentage). 

So, for this instance, a quantity of 1 was sold and the Yield Percentage configured for the Lamb Leg is 80%. 

1 x (100/80) = 1.25 

A Quantity of 1.2500 was sold as per the Stock Transaction Report displayed below. 

 

  



Stock Items 

Open Stock Item as Instruction allows Force Selling Price functionality 

This function adds the ability for Idealpos to display the Force Selling Price entry screen when selling an Open Stock 

Item which has the Instruction option enabled. This feature may be useful in situations when selling a Stock Item such 

as an Entrée dish and having a button to allow the staff to manually enter a specific instruction as well as entering the 

sell price for the extras. An example of this may be selling an Entrée dish such as Pasta and when a customer requests 

extra cheese or other ingredients such as herbs and spices, these can be entered by pressing the Open Stock Item, 

entering the sell price then entering the instructions via the on-screen keyboard. 

 

To use this function, go to: File > Stock Control > Stock Items > Add 

Create a Stock Item with a Description of OPEN STOCK ITEM and ensure that the “Force Selling Price Entry” and 

“Instruction” options are enabled. If you are creating the Open Stock Item (Instruction item) for a particular type of 

dish such as an Entrée, you can also include the word ENTRÉE within the OPEN STOCK ITEM description (e.g. OPEN 

STOCK ITEM ENTRÉE). Also ensure that you tick the Printers under Printer Settings according to the printers where you 

want the Open Stock Item to be printed to. 

 

 
 

Also note that in order for the Instruction Item to print on Bills or Receipts, you will need to ensure that specific 
Yes/No options have been enabled.  
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Then create a button on the POS Screen for the OPEN STOCK ITEM. 

Go to Setup > POS Screen > POS Screen Setup > Select a layout > Buttons > Add new button 

Ensure that the Stock Item function has been selected, then press the “>” button in the Stock Item field to select the 

OPEN STOCK ITEM. You may also update the button caption if required. Press Save to create the Open Stock Item 

button. 

 

 
 

Close the POS Screen Layout windows then open the POS Screen. 

  



Add an Entrée or another dish to the sale. 

 

 
 

Then press the OPEN STOCK ITEM button from the POS Screen and enter a Selling Price. 

 

 
 

The on-screen keyboard will then appear. Enter a description for the Open Stock Item (Instruction) then press Enter. 
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The Open Stock Item (Instruction) will be added to the sale and will be indented below the previous item that was 

added. 

 

 
 

When the sale is saved to a Table, the Kitchen Docket will show the Open Stock Item (Instruction) indented below the 

Stock Item. 

 

 
 

When paying off the Table, the Receipt printed will also include the Open Stock Item (Instruction) indented below the 

Stock Item and will show the price at which the Instruction Item was sold at. 

 

  



Surcharges 

Waive Tender Surcharge Threshold 

This function adds the ability to set a threshold whereby a Tender Surcharge will only be applied when the sale is paid 

using a specific tender and the amount paid using the tender is less than the amount configured. This may be useful in 

cases where you are charged extra fees for processing transactions which are less than a specific amount. 

This function is available to all tenders except for Cash. 

 

To enable and configure this feature, go to:  

Setup > Function Descriptors > Select the Tender from the Function Descriptors list > Modify 

 

 
 

Enter an amount into the Surcharge field and select the % or $ radio button, depending on whether the Surcharge will 

be a Percentage surcharge or a fixed dollar amount surcharge. 

Then enter an amount into the Waive Surcharge Threshold field. By entering an amount into the “Waive Surcharge 

Threshold field”, any value tendered that is equal to or greater than the Waive Surcharge Threshold will not be subject 

to having a Surcharge applied. Any value tendered that is less than the Waive Surcharge Threshold will be subject to 

having the Surcharge applied. 
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In the below example, the EFTPOS tender has a Surcharge amount of 5.00% with a Waive Surcharge Threshold of 

10.00. 

This means any amount tendered less than 10.00 (9.99 or lower) will be subject to having the Surcharge of 5.00% 

applied. Any amount 10.00 or higher will be excluded from the Surcharge. 

 

 
 

  



When tendering a transaction less than 10.00 ($9.99 in the below example), the 5% Surcharge will be applied. 

 

 
 

When tendering $10.00 or above, the surcharge is not applied. 
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Utilities 

Synchronize Sales Utility – Option to synchronize all sales from one terminal 

This function adds the ability to synchronize the sales data of all terminals from a single terminal. 

E.g. A site contains three terminals, POS 1, POS 2 and POS 3. 

If you open the Synchronize option on POS 1, then enable the checkbox for POS 2 from the list of terminals and 

enable the “Retrieve Data of All Terminals from a Single POS Terminal” setting, the data for POS 1, POS 2 and POS 3 

will be retrieved from POS 2. 

 

To use this function, go to: Utilities > Synchronize  

Enable the checkbox for the POS Terminal which you want to retrieve data from, select the period from the dropdown 

box, or alternatively manually select the date range that you want to retrieve data for then enable the checkbox 

“Retrieve Data of All Terminals from a Single POS Terminal”. Once you have ensured that the correct options have 

been selected, press the “Proceed” button. 

 

 
 

The Synchronize will then commence and after it has completed, Idealpos will display “Synchronize Completed”. 

 

 
 

  



Press OK. The Synchronization Results will be displayed on the Synchronize window. 

 

 
 

The POS terminal will now contain the updated data that was synchronized from the selected POS terminal. 

Note that the length of time to complete the synchronization will vary depending on the period selected and the 

amount of data that is synchronized.  
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Waste Mode 

Allow Waste Mode functionality when performing a Sale 

This function allows the Waste Mode function to be used while performing a sale. This feature is useful in cases where 

customers leave without paying the bill that’s due for their table. 

 

The process for using this function is outlined as follows: 

 

1. Customer places an order and the sale is saved to a table. 

 

 
 

 
 

2. The waiter brings the customer their meal and the customer consumes their meal. 

3. The customer leaves without paying for their table and the waiter/operator discovers that the meal hasn’t 

been paid for and the customer has left. 

4. The items from the table can be marked off as stolen by opening the Journal Enquiry screen from the POS 

Screen, select the Table then press the “Replay” button. 

 

 



5. Select the transaction from the left-hand side. The contents of the sale will be displayed on the right-hand 

side. Once you have identified the unpaid order, ensure that it remains selected then press the Replay button. 

 

  
 

6. Idealpos will display a prompt to confirm if you want to replay this transaction. Select “Yes”. 

 

 
 

7. The unpaid items will be added to the sale. 

 

 
 

  



 Update History 
 

8. Press the “Waste Mode” button to enable Waste Mode 

 

 
 

9. Idealpos will display a prompt for you to confirm that you want to enter the sale into Waste Mode. Select 

“Yes” to continue. 

 

 
 

10. WASTE MODE will be displayed towards the top right corner of the screen to show that Idealpos is now in 

Waste Mode. 

 

 
 

  



11. Press the “Enter” button on the POS screen. 

A Waste Mode screen will appear allowing you to select the type of wastage to mark the items against.  

Select “Stolen” if the customer has left without paying for their items. 

 

 
 

12. A receipt will be printed and will show the type of Waste Mode selected along with the items that were 

marked as wasted and a line for the operator to sign off the wastage. 

 

 
 

13. Note that after the items have been marked off as wasted, the items will still remain on the table that they 

were originally saved to. 

Once the table has been cleaned, you can return to the Table Map, select the table then press the “Finished” 

button to clear the items from the table so the table can be used by the next customer.  
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Yes/No Options 

Yes/No Option – Master Accounts accumulate Points from Sub-Accounts 

This function adds the ability to control whether or not the Master Account should accumulate points for any 

transactions made by the Sub-Account customer. Note that changing this setting does not move points already 

accrued against Sub-Accounts. Any changes to the setting will only affect any transactions that occur after the change 

has been made. 

 

To enable this function, go to:  

Setup > Yes/No Options > Enter Keyword Search: Master accounts > Enable All: Master Accounts accumulate Points 

from Sub-Accounts 

 

 
 

Create a Master Account then create a Sub-Account linked back to the Master Account. 

 

Go to: File > Customers > Customers > Add 

Create the Master Account – Ensure that the “Account” option is enabled and the “Master Account” field remains 

blank. Press the “Save” button to create the Master Account. 

 

  
 

  



Now create the Sub-Account. 

Ensure that the “Account” option is enabled and click on the “>” button inside the Master Account field, then select 

the Master account from the list of Customers to link to the Master Account. Press the “Save” button to create the 

Sub-Account. 

 

  
 

Once the accounts have been created, perform a transaction via the POS Screen using the Sub-Account. 

Any points accrued by the Sub-Account will be accumulated against the Master Account. 
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Go to the POS Screen > Add Customer: Frank Smith > Add Stock Items to the sale 

 

 
 

Press the “Enter” button, then either select “Cash” or select a tender amount to cash the sale off. 

 

 
 

  



After the sale has been finalised, add the Sub-Account Customer (Frank Smith) to the sale. 

The Points balance will appear as 0, as the points have been accumulated against the Master Account. 

 

  
 

When adding the Master Account Customer to the transaction, the Points accumulated by the Sub-Account will be 

displayed. 

 

  
 

Points accrued using the Sub-Account will appear under the Master Account when running the Customer Points 

Report. 
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To view the Customer Points Report, go to: Reports > Customers > Customer Points > View 

 

 
 

Any Transactions performed by the Sub-Account will be allocated to the Master Account. 

 

   



Yes/No Option – Print POS Description on Receipt 

This function adds a Yes/No option to print the POS Description on Receipts. When this option is enabled, the Receipt 

printout from a POS terminal will contain a line which shows the POS description and POS number. 

 

To enable this feature, go to:  

Setup > Yes/No Options > Enter Keyword Search: POS Description > Enable: Print POS Description on Receipt 

 

 
 

Once the option has been enabled, close the Yes/No options window then open the POS Screen. 

Add Items to the sale, then press the Enter key and select a Tender amount. 

The receipt printout will include the description of the POS Terminal on the receipt. 

 

 
 


