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Alerts 

IP-7385 – Alerts Function – Delete Pending Sale Alert 

This function introduces the ability to configure an Alert that is triggered by the deletion of Pending Sales. 

The Alert can be configured to write an entry to the Alerts.log and/or Send Email. 

 

To configure this function, go to: Back Office > Setup > Alerts > Add. 

Alert Description: Enter a Description (e.g. Delete Pending Sale). 

If Function Type: Pending Sale Delete 

Quantity reaches X in X Minutes/Days: Enter the Quantity and enter the number of Minutes or Days. When the number 

of Pending Sale Deletions reaches the value specified here, an Alert will be triggered. 

 

Alert Action 

Write to Alerts.Log – Enable this option to trigger the Alert to be written to the Alerts.Log.  

The Alerts.log is typically located in C:\ProgramData\Idealpos Solutions\Idealpos\Logs\Alerts.log 

 

Send Email to – Enable this checkbox and enter an email address to trigger the Alert to be emailed. Multiple Email 

Addresses can be entered as a comma separated list. 

 

Email/Log Message – Configure the Email/Log Message in this field. An example Alert Message has been included 

below. 

 

{FUNCTIONQUANTITY} Pending Sales have been deleted by Clerk {CLERKNAME}! 
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Additional configuration may also be required for Alerts. 

Ensure that the following options are configured in Global Options > Other Options: 

• Output from POS 

• Email Service/Settings 

 

Go to: Back Office > Setup > Global Options > Other Options.  

Output from POS # 

Output from POS# is the POS Terminal or Back Office that will handle the recording of Alerts. 

 

Email Service 

Either select Idealpos Email or Custom. 

If selecting Idealpos Email, the Idealpos Email service will handle the sending of Email Alert notifications. 

If using Custom, SMTP/Username/Password settings will need to be configured. 
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To delete Pending Sales, go to: POS Screen. 

Select the Pending Sale button > Select a Pending Sale > Delete. 
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After deleting the number of Pending Sale(s) as configured in the Alert, an entry will be written to the Alerts.Log 

and/or Email (also as configured in the Alert). 

 

The Alerts.Log is created on the POS Terminal/Back Office that was configured as the Output from POS# Terminal. 
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Coupon Promotions 

IP-7326 – Coupon Promotions – Ability to Redeem Coupon when paying Table (Pay@Table) 

This function adds support to apply a Coupon Promotion when paying a Table with Pay@Table enabled. 

A Coupon Promotion will now be applied to the sale when paying a table (as summarised below): 

• Save Items to a Table 

• Select the Table from the Table Map > Pay All. 

• Apply/Enter the Coupon 

• The Coupon Promotion applies to the sale 

 

From the Table Map, select the Table > Press “Pay All”. 
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Enter the Coupon Code > Press “Coupon Promo”. 

 

 
 

The Coupon Promo is applied to the sale and discounted as per the Coupon Promo > The sale can now be paid. 
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Fuel Interface  

IP-7296 – Enabler Fuel Interface – Ability to change Live Fuel Prices 

This functionality introduces the ability to change live fuel prices. 

This functionality can be used to change the Fuel Prices Live, and any changes to the Fuel Prices via this function will 

update the Prices in both the Enabler and in the Idealpos Stock Item. 

 

To configure and use this functionality, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

Select a POS Screen Tab > select a blank button.  

It is strongly recommended that this button only be placed on a POS Screen tab that is restricted to specific clerks (e.g. 

an Admin tab or Manager tab that is restricted to Admin or Manager Clerks) to prevent unauthorised changes to Fuel 

Prices. 

Link the button to the Fuel Prices function > Press “Save” to save the button. 
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Access to POS Screen tabs is controlled via the User Level as well as the Clerk Level. 

I.e. Each Clerk is linked to a User and access to a specific POS Screen tab can be set for a User. 

If the User’s access to a tab is disabled, all Clerks linked to that User will be denied from accessing the tab. 

If the User’s access to a tab is enabled, all Clerks linked to that User will be allowed to access the tab. 

 

In addition to the User Level permissions, Clerk Level permissions can also be set. 

Note however that Clerk Level permissions can only be used to deny a Clerk’s access to a function. 

E.g. If a Clerk is linked to a User that does not have permission to access a specific POS Screen Tab, enabling access to 

the POS Screen Tab at the Clerk Level will not give them access to the POS Screen Tab. 

If a Clerk is linked to a User that has access to a POS Screen Tab, the Clerk’s permissions can be modified to disable 

the Clerk from having access to a specific POS Screen Tab. 

 

To control access to a POS Screen Tab using User Level permissions, go to: 

Back Office > Setup > Users > Select a User > Modify > Clerk Permissions > POS > Layers. 

Disable the checkbox next to the POS Screen Tab(s) that the User is not permitted to access (e.g. Admin and/or 

Manager tabs) > Press “Save” on the top-left corner. 
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A Clerk’s access to a POS Screen Tab can be restricted via the Clerk level permissions. 

Note that as mentioned earlier, Clerk level permissions cannot be used to grant a Clerk access to a POS Screen tab. 

Clerk level permissions can only be used to deny specific Clerks from accessing functions that have been enabled for 

the User that they’re linked to. 

 

To configure Clerk Level Permissions, go to:  

Back Office > Setup > Clerks > Select a Clerk from the list > Press the “Permissions” button on the top-left corner of 

the window. 

Clerk Permissions > POS > Layers > Disable the checkboxes next to the Layers/Tabs that the Clerk is not permitted to 

access. 
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To utilise the Live Fuel Prices functionality, go to:  

POS Screen > Select the POS Screen tab which the Fuel Prices button was added to. 

 

A Grade Prices window will be displayed containing the Fuel Prices. 

Adjust the prices of the Fuel Grades as required using the on-screen numeric keypad. 

Press the “Update Prices” button to apply the changes. 

The updated prices will be sent to the Enabler, and the updated Sell Prices will also be applied to the Stock Items. 

 

Note that the ability to change Live Fuel Prices can only be done from the POS Terminal. 

Updating the Fuel Prices of the Fuel Grade Stock Items at the Idealpos Back Office will not trigger the prices to be updated 

at the Enabler. 

 

 
 

It is strongly recommended that Clerks which have access to this functionality are not left logged into the POS 

to prevent unauthorised access to this functionality. 

If required, a Clerk Timeout can be configured to automatically trigger a Clerk to timeout after a period of inactivity. 

To set a Clerk Timeout, go to: Back Office > Setup > Global Options > General > Clerk Timeout. 

Enter a value, noting that the timeout is counted in seconds. 

Entering 60 will trigger the Clerk to timeout after 60 seconds (1 minute). 

It is also recommended that the Yes/No Option “Compulsory Clerk” be enabled (Go to: Back Office > Setup > Yes/No 

Options > Search “Compulsory Clerk” and enable this option). 

This will ensure that a Clerk needs to be entered into the sale to use the POS Screen, preventing unauthorised access 

to POS Screen functions. 

Changes to the above Clerk Timeout and/or Yes/No Option will require a Close Suite/Open Suite for the change to 

take effect. 
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Global Options 

IP-7412 – Custom Kitchen Docket Headers 

This functionality introduces the ability to configure Custom Kitchen Docket Headers. 

This includes the ability to customise the Descriptor, Wrap Characters, Empty Lines and Left-Aligned/Centred. 

 

Prior to this functionality, Kitchen Docket Headers were hard coded for each Kitchen Docket Type. 

E.g. Saving items to a table will trigger a Kitchen Docket Header of “TABLE #”. 

Adding items to a sale with an Order Number will trigger a Kitchen Docket Header of “ORDER #” 

Receiving a print job from a Web Order will trigger a Kitchen Docket Header of “WEB ORDER #”. 

 

To customise the Kitchen Docket Headers, go to: Back Office > Setup > Global Options > Printing. 

 

Within the “Other Options” section, select the Kitchen Docket Type being customised . 

Available options are Order Number, Table Number or Web Order. 

Each Kitchen Docket Type can have a unique set of values (Alignment, Descriptor, Wrap Characters, Empty Lines). 

Once the required option has been selected, the following options can be customised: 

 

• Descriptor: This is the Descriptor that will appear at the top of the Kitchen Docket. 

• Wrap Character(s): These are the characters that are wrapped before and after the Descriptor. 

• Empty Lines: This is the number of empty lines that appear after the Kitchen Docket Header. 

• Left-Aligned/Centred: This controls whether the Docket Header is Left-Aligned or Centred. 

 

For reference purposes, the default values are listed as follows: 

Kitchen Docket Type Descriptor Wrap Characters Empty Lines Alignment 

Order Number ORDER * 1 Centred 

Table Number TABLE  0 Left-Aligned 

Web Order WEB ORDER  1 Centred 
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E.g. The “Table Number” can be customised: 

• Descriptor: DESK 

• Wrap Characters: ** 

• Empty Lines: 0 

• Alignment: Centred 

 

 
 

When saving items to a Table, the Kitchen Docket Header will appear as follows (the Kitchen Docket Format may vary 

depending on Kitchen Docket Format that has been configured in Global Options > Printing): 

 

 
 

In addition to the above, the Web Order Number can be hidden if required via a User-Defined Option. 

Go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > POS Settings Tab > Create as follows: 

 

• Description: HIDEWEBORDERNUMBER 

• Setting: 1 
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Journal History Enquiry 

IP-7384 – Journal Enquiry – Filter for Pending Sale Deletions 

This function introduces the ability to filter the Journal History Enquiry by Pending Sale Deletions. 

Any Pending Sales that have been deleted will be filtered when the “Pending Sale Delete” option is selected from the 

Function dropdown box. 

 

Go to: Back Office > Enquiry > Journal History. 

Select a Date Range, then ensure that the “Pending Sale Delete” option has been selected in the Function dropdown 

box. 

All the Pending Sale Deletes that took place within the selected Date Range will be displayed in the Journal History 

Enquiry. 
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Labels 

IP-7374 – Stock Item Labels – “Items Created Since” selection criteria 

This function introduces the ability to Add Stock Items to the Labels Grid based on an Items Created Since date filter. 

When enabling/selecting the Items Created Since option, entering a date/time and pressing the “Add to Grid” button, 

any Stock Items that were created since the specified date and time will be added to the grid and will have labels 

printed. 

 

Go to: Back Office > Utilities > Labels. 

 

Enable the checkbox and select “Items Created Since”, then select a Date/Time in the date selection dropdown. 

Press the “Add to Grid” button to add items that were created since the selected Date/Time. 
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IP-7372 – Stock Item Labels – Support for extra Metcash Fields 

This functionality introduces support for extra Metcash Fields so that they will be printed on Stock Item Labels. 

The extra Metcash fields are typically included in a Metcash XML Host File which is processed into Idealpos via the 

Back Office > Utilities > Metcash > Import Files. 

The fields that are supported are listed as follows: 

 

• Unit – E.g. ea, /kg, etc. 

• Metcash Carton Quantity (MinimumOrderQuantity) – E.g. 1, 6, 8, 24, etc. 

• WarehouseIndicator – E.g. W, D, Z, etc. 

• ComplianceIndicator – 3, 4, etc. 

• ProductGrade – E.g. R, A, C, B, etc. 

 

The above Metcash fields will be printed onto the Stock Item Label when using one of newly added formats that were 

added to IP-7402 – Stock Item Labels – Extra Landscape Formats (4x5, 4x8).  

Any other Idealpos A4 label format will not include the above Metcash fields on the label. 

 

To demonstrate how the Metcash Fields appear on a label, a Stock Item was imported from a Metcash Host that 

contains the following Metcash Fields with the following data: 

• MinimumOrderQuantity – 6 

• WarehouseIndicator – W 

• ComplianceIndicator – 2 

• ProductGrade – A 

 

The below is a Label produced using the format “20 labels (4x5) Landscape”: 

 

 
 

The below is a Label produced using the format “32 labels (4x8) Landscape”: 
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IP-7402 – Stock Item Labels – Extra Landscape Formats (4x5, 4x8) 

This function introduces the ability to print Stock Item Labels to two new Landscape Formats which are 4x5 and 4x8. 

These two formats are designed to print to stationery supplied by Metcash. 

The new formats are available by going to: Back Office > Utilities > Labels. 

• Data Type: Stock Items 

• Output to: Idealpos A4 Labels 

• Dimensions: 20 Labels (4x5) Landscape or 32 Labels (4x8) Landscape 
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Add Stock Items to the grid via the options available on the right-hand side of the Labels window. 

If using the selection criteria options (e.g. Code, Scan Code, Description, Department or Price Changes Since/Items 

Created Since), enter the required criteria into the fields, then press the “Add to Grid” button. 

If required, the “Multi Select” button can be pressed which will open the Stock Items grid and while holding down the 

CTRL button, multiple Stock Items can be selected. 

The Shift button can also be used to select a range of items (i.e. select the first item in the grid, then while holding 

down the Shift key on the keyboard, press the last Stock Item in the range; all Stock Items between the first and the 

last Stock Item will be selected, including the first and the last item). 

Then press the “OK” button in the Stock Item grid to add those selected Stock Items to the Labels grid. 

 

Press the “Print” button once the required items have been added to the Labels grid. 

If required, the Labels can be previewed prior to pressing the “Print” button. 

The Preview button will trigger the labels to appear on-screen as a preview. 

 

Note – When printing labels to a printer, it is important to note that printer margins and settings may vary from printer 

to printer. 

E.g. Settings configured on the physical printer or printer driver may affect the printer printing within the perforations of 

the label stationery. Settings such as Edge-to-Edge Print or similar settings. 

Refer to the documentation specific to the printer being used for more information about printer margins, printer scaling, 

etc. Some trial and error may be required to determine which settings need to be adjusted for the Stock Items to print 

within the perforations of the label stationery. 
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The below is an example of the 20 Labels (4x5) Landscape Label Dimension format triggered via the Preview button: 

 

 
 

  



    Update History 
Return to top 

Idealpos 9 Build 11 - Update History Page 20 of 42 

 

The below is an example of the 32 Labels (4x8) Landscape Label Dimension format triggered via the Preview button: 
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IP-7429 – Stock Item Labels – Support for Labeljoy Software 

This function adds Labeljoy support to Idealpos so that the Idealpos Label Export functionality can be used to export 

labels, then trigger the Labeljoy application to open and display the exported Labels. 

As Avery no longer offers a Windows application that can be used for printing labels, Labeljoy can be used as an 

alternative. 

Note that Labeljoy is a paid application; it can be used as a trial to establish whether it is suitable and provides the 

required functionality. 

 

As the process to fully install Labeljoy and configure Idealpos to export involves numerous steps, a summarised 

version has been included below. 

For a full end-to-end process on configuring this functionality, refer to the User Guide – go to: 

https://userguide.idealpos.com.au and via the Table of Contents, go to: Labels > Labeljoy. 

There are pages that outline the installation of Labeljoy, Creation of Data File for Labeljoy, Creation of Labels and 

Layout in Labeljoy, Configuring Idealpos to Print to Labeljoy and the printing of Labels from Idealpos to Labeljoy. 

 

In summarised form, the process of setting up Idealpos with Labeljoy is as follows: 

• Install Labeljoy – Download the application from https://www.labeljoy.com 

• Create a TXT file that Idealpos will export the labels to (e.g. C:\Temp\Labeljoy.txt) 

• Go to: Idealpos Back Office > Utilities > Labels.  

Select Data Type: Stock Items 

Output To: Labeljoy 

Format File: Leave as blank 

Data File: Browse to path where the TXT file has been created. 

Save Format As: Enter name and press “Save Format As” button. 

Add Labels and press the “Export” button to populate the TXT file. 

• The Labeljoy application will open. 

Select “Link data source wizard” 

Select “Text file” 

Browse to the Txt file 

Header row settings – Select “The first row is the header row (default)” 

Field separator – Select “Comma” 

Quantity – Select “(1 label per record)” and select “Skip empty rows” 

Review the loaded data – Enable “Show automatic data update settings when finished” 

Review the loaded data – Enable “Remove existing elements from the labels” 

Connect to the data source – Yes 

Enable “Update data when this file is loaded or printed” 

Press the “Layout” button at the top of the window to select the layout that matches the stationery 

Drag the data sources from the left-hand side of the window onto the label on the right-hand side 

Save the design as a Label and layout file (.lpa file extension) 

• Go to: Idealpos Back Office > Utilities > Labels. 

Select the previously saved format and in the Format File field, browse to the lpa file created in Labeljoy 

Save the Format As again and use the same name as before to update the format. 

• Labels can now be printed from Idealpos to Labeljoy – when Exporting Labels, Idealpos will trigger the 

Labeljoy application to open and will display the exported Labels. 
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When configured as per the summarised bullet points on the previous page: 

Back Office > Utilities > Labels > Select the Format that was saved to print to Labeljoy. 

 

 
 

After pressing the “Export” button, the Labeljoy application will open with the exported Labels. 
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POS Screen Layouts 

IP-7333 – POS Screen Layouts – Export/Import Functionality 

This function introduces the ability to Export/Import POS Screen Layouts. 

POS Screen Layouts can be exported to a CSV file and can then be imported via the Import function. 

This functionality is useful when POS Screen Layouts need to be exported for backup purposes or when setting up 

multiple venues/sites and needing an easy way to import a POS Screen Layout into another Idealpos system. 

 

To use this functionality, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

On the left-hand side of the POS Screen Layouts window, two new buttons exist – Import, Export. 

Also note that the “Buttons” button has been moved from the bottom to the top of the list. 
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Exporting a POS Screen Layout  

To Export a POS Screen Layout, select the required layout in the list, then press the “Export” button. 

The “Export To…” folder browser window will open > Browse to a location to export the POS Screen Layout CSV file > 

Press “Save”. 

 

 
 

After the POS Screen Layout has finished exporting, a “POS Screen Layout Exported Successfully.” Prompt will be 

displayed. 
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Importing a POS Screen Layout  

Note that when using the Import option, it will overwrite the POS Screen Layout that is currently highlighted in the list. 

Therefore, it is recommended that a blank layout is created via the Add button. 

Then ensure that the newly created POS Screen Layout is selected to prevent overwriting an existing layout. 

 

Select a POS Screen Layout > Press “Import” > Overwrite Layout Prompt is displayed > Press “Yes” to Overwrite the 

selected layout. 

 

 
 

The “Import From…” folder browser window will open > Browse to the location of a POS Screen Layout CSV file > 

Press “Open”. 

 

 
 

After the layout has finished importing, a “POS Screen Layout Imported Successfully.” Prompt will be displayed. 
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Raffles 

IP-7334 – Raffles – Yes/No Option to allow setting of Starting Raffle Number 

This function introduces the ability to set a Starting Raffle Number when resetting a raffle. 

When a raffle is reset, the Raffle Number increments by one, and the Starting Ticket Number resets back to 1. 

This may cause slight confusion to patrons at the venue if the same Raffle (e.g. Meat Tray) is Reset and further tickets 

sold over the course of a short period, resulting in multiple ticket holders that have the same ticket numbers (for 

different Raffle Numbers). 

To create further separation between the Raffle Draws, a Starting Ticket Number can be entered when resetting the 

Raffle. Any Raffle Tickets that are sold will start using the Starting Ticket Number. 

 

To configure and use this functionality, go to: Back Office > Setup > Yes/No Options > Search: raffle. 

Enable “Reset Raffle Function can set Starting Number”. 

 

 
   

This Yes/No Option does not require a Close Suite/Open Suite and should therefore take effect after setting the option 

and closing the Yes/No Options window. 

 

Go to: POS Screen > Press the “Raffles” button linked to the Raffles function. 

If there are multiple Raffles configured, a raffles window will appear; select the Raffle from the list. 
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A “Starting Ticket” field will appear on the bottom-left corner of the Raffles window next to the “Reset Raffle” button. 

In the Starting Ticket field, enter the Starting Ticket Number. 

The “>” button can be pressed to display an on-screen keyboard to facilitate the entry of the Starting Ticket Number. 

After entering the Starting Ticket Number, press the “Reset Raffle” button. 

Note that the Raffle cannot be reset if Tickets have not been sold for the Raffle. 
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After pressing the “Reset Raffle” button, various prompts may appear depending on how Raffles have been 

configured: 

 

If the Raffle has not been drawn, a confirmation prompt will be displayed: 

 

 
 

If the Raffle has been drawn and the Yes/No Option “Confirm you want to Reset a Raffle” is enabled, a Confirmation 

prompt will appear: 

 

 
 

If Raffle Tickets have not been sold, attempting to Reset the Raffle will trigger a prompt, preventing the Resetting of 

the Raffle: 

 

 
 

After the Raffle has been reset, a prompt will appear confirming the Starting Ticket Number: 
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Any tickets sold after the reset will start from the Starting Ticket Number that was entered. 
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Surcharges 

IP-7381 – Surcharges – Show Site-Specific Surcharges only (Site Management) 

This functionality changes which Surcharges that visible in the Surcharges function on Site Management Terminals 

(accessed via Back Office > File > Sales > Surcharges). 

Previously, Site Management Back Office Terminals could see Surcharges in the Surcharges screen for POS Terminals 

that were not linked to the same Site. 

E.g. In previous builds of Idealpos, if a business has a Head Office (Site 1), and a Sites (Site 2 and Site 3), Site 

Management Back Office Terminals located in Site 2 could see Surcharges that were only applicable to POS Terminals 

in Site 3 and vice-versa. 

 

With this change, Site Management Back Office Terminals will now only see Surcharges in the Surcharges function 

(Back Office > File > Sales > Surcharges) if the Surcharge’s POS System field contains POS Terminals that are specific 

to their Site.  

 

Note that Surcharges can be configured to apply to POS Terminals that exist in a single Site, or they can be configured 

to apply to POS Terminals that span across multiple Sites. 

If a Surcharge contains POS Terminals in the POS System field that span across multiple Sites, then Back Office Site 

Management Terminals from each of those Sites will see the Surcharge in their Surcharge configuration screen 

(accessible via Back Office > File > Sales > Surcharges). 

Note though that when the POS System field in a Surcharge includes Terminals from multiple Sites, only the Head 

Office will be able to Modify or Delete such Surcharges. 

If the POS System field in a Surcharge only includes POS Terminals for a single Site, then it can be Modified or Deleted 

by Site Management Back Office Terminals at the Site. 
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To use this functionality, go to: Back Office > File > Sales > Surcharges. 

The list of Surcharges that appear in the Surcharges window will include Surcharges that apply to POS Terminals that 

exist in that Site.  

The Surcharges window will also show Surcharges that apply to POS Terminals that span across multiple Sites 

(provided that the Surcharge is linked to one or more Terminals that exist within the Site that the Site Management 

Back Office is linked to). 

As mentioned above, a Site Management Back Office Terminal can only modify or delete a Surcharge if it is only linked 

to Terminals in its own Site.  

If the Surcharge is linked to Terminals across multiple Sites, then only Head Office Terminals can modify or delete such 

Surcharges. 

 

To demonstrate this functionality, the following Head Office/Site Management Environment was configured: 

• POS 1 Head Office Terminal located at Site 1 

• POS 2 Site Management Terminal located at Site 2 

 

The following Surcharges were created: 

• “Site 1 and Site 2 Surcharge” (Surcharge is linked to POS Terminal 1 and POS Terminal 2) 

• “Site 1 Surcharge” (Surcharge is only linked to POS Terminal 1) 

• “Site 2 Surcharge” (Surcharge is only linked to POS Terminal 2) 

 

The following screenshot shows the Surcharges which are visible from the Head Office Terminal: 

 

 
 

The Back Office Site Management Terminals at Site 2 can only see the following Surcharges: 

• “Site 1 and Site 2 Surcharge” – This surcharge is effectively “Read-Only” at the Site 2 Back Office Site 

Management Terminal due to the Surcharge including POS Terminal numbers that are linked to Site 1 and Site 

2. 

• “Site 2 Surcharge” – This surcharge can be modified by the Site 2 Back Office Site Management Terminal 

because it is not linked to POS Terminals located in multiple sites. 

 

The following screenshot shows the Surcharges which are visible from the Site Management Terminal at Site 2: 

Note that the “Site 1 Surcharge” is not visible at the Site 2 Site Management Terminal because that Surcharge is not 

linked to any Terminals that exist in Site 2. 
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A Site Management Terminal can Modify or Delete Surcharges that are linked to POS Terminals that only exist within 

the Site Management Terminal’s Site (e.g. Site 2). 

If a Surcharge is linked to Terminals that exist in multiple Sites (e.g. POS Terminals in Site 1 and Site 2), then the Site 

Management Terminals at Site 1 and Site 2 cannot modify or delete the Surcharge.  

The Surcharge can only be modified or deleted from a Head Office Terminal. 

 

If a Site Management Terminal attempts to Modify and Save a Surcharge that includes POS Terminals in other Sites, 

the following prompt will be displayed, preventing the modification of the Surcharge: 

 

 
 

If a Site Management Terminal attempts to Delete a Surcharge that includes POS Terminals in other Sites, the 

following prompt will be displayed, preventing the deletion of the Surcharge: 
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Yes/No Options 

IP-2639 – Yes/No Option – Table Details – Auto Create Seats for Split Bills 

This function introduces the ability for Idealpos to automatically create seats for Split Bills. 

When selecting items and hitting Bill Print from Table Details, this will assign the selected items to a new Seat Number 

and split the Bill for that Seat. 

 

To configure and use this functionality, go to: Back Office > Setup > Yes/No Options > Search “auto create seats”. 

Enable Yes/No Option “Table Details – Auto Create Seats for Split Bills” 

 

 
 

This Yes/No Option does not require a Close Suite/Open Suite, so it should take effect immediately. 

 

Once the option has been enabled, go to: POS Screen > Add items to a sale > Press “Table Map” > Select a Table. 
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Select the Table on the Table Map > Details. 

Within the Table Details screen, select items > Press “Print Bill”. 

 

 
 

The Enter Seat Number prompt will be skipped, and the Bill will be printed for the selected items. 

The selected items will be auto assigned to the first unused Seat Number, with the Seat Number appearing on the Bill. 
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Select the next two items and press “Print Bill”, they will be assigned to the next Seat Number. 
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The above process can be repeated until all Stock Items have been allocated to Seat Numbers. 

Note that once a Bill has been printed for the selected items, pressing the “Print Bill” button for the same selected 

items again will trigger the Enter Seat Number prompt. 

If the items selected in the Table Details screen were previously auto allocated to the same Seat Number, the Enter 

Seat Number prompt will be pre-filled with previously allocated Seat Number. 

 

 
 

If the items selected in the Table Details screen were previously assigned to different Seat Numbers, the Enter Seat 

Number prompt will not be pre-filled with the previously allocated Seat Number. 

Entering a Seat Number will assign the items to the entered Seat Number or leaving the Seat Number as blank will 

trigger Idealpos to auto allocate the items to the next available Seat Number. 
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IP-7415 – Yes/No Option – Hide Date on Kitchen Dockets 

This function introduces the ability to Hide the Date on Kitchen Dockets. 

Prior to the introduction of this Yes/No Option, the Date is always printed to the Kitchen Docket Printer. 

 

To configure and use this functionality, go to: Back Office > Setup > Yes/No Options > Search “Hide Date”. 

Enable Yes/No Option “Hide Date on Kitchen Dockets”. 

 

 
 

This Yes/No Option does not require a Close Suite/Open Suite, so it should take effect immediately. 

 

Once the option has been enabled, go to: POS Screen > Add Kitchen Items to the Sale > Tender the Sale. 

When the Kitchen Docket is printed, the Date will be hidden. 

The below examples show the option Disabled and Enabled. 

Disabled|Enabled 
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IP-7416 – Yes/No Option – Hide Sale Type Status on Kitchen Dockets 

This function introduces the ability to Hide Sale Type Status on Kitchen Dockets. 

Prior to the introduction of this Yes/No Option, the Sale Type Status would print to the Kitchen Docket Printer when a 

Sale Type Status was added to the sale. 

With this Yes/No Option, if a Sale Type Status is added to the sale, it will be hidden from Kitchen Dockets.  

Examples of Sale Types are Takeaway, Delivery, Pickup, Cater, etc. 

 

To configure and use this functionality, go to: Back Office > Setup > Yes/No Options > Search “hide sale”. 

Enable Yes/No Option “Hide Sale Type Status on Kitchen Dockets” 

 

 
 

This Yes/No Option does not require a Close Suite/Open Suite, so it should take effect immediately. 

 

In addition to configuring the Yes/No Options, Sale Type Status buttons will need to exist so that the relevant Sale 

Type button can be pressed when performing a sale, enabling the reporting of sales based on the Sale Type. 
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If not already configured, Sale Type Statuses will need to be configured. 

Go to: Back Office > Setup > Global Options > Sales > Sale Type Status. 

Configure the required Sale Type Statuses, a maximum of 9 Sale Type Statuses can be configured; it is not a 

requirement to populate all Sale Type Status fields; only populate what is required: 
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To configure Sale Type Status buttons on the POS Screen, go to:  

Back Office > Setup > POS Screen > POS Screen Setup > Select the POS Screen Layout > Buttons. 

Select a POS Screen Tab where the Sale Type buttons will be created, then select a blank/unused button and configure 

as follows (repeat this step to create a button for each Sale Type Status).  

When creating the Sale Type Status buttons, a Price Level can also be set (e.g. if Takeaway orders are charged at a 

different price to other orders, a Price Level can be set for each Sale Type. 

 

• Function: Sale Type 

• Status: Select the Sale Type Status from the dropdown box. 

• Price Level: “Don’t Change” or select a Price Level to use for the specified Sale Type. 

• Button Caption: Defaults to the selected Sale Type Status; change if required. 

 

Press “Save” to save the changes and repeat this step for each Sale Type Status that is required. 

 

 
 

Now that the Yes/No Option, Sale Type Statuses and Sale Type Status buttons have been configured, the function is 

ready for use. 
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Go to: POS Screen > Add Kitchen Items to the Sale > Press the required Sale Type Status button to set the Sale Type > 

Tender the Sale. 

When a Sale Type Status has been added to the Sale, the Status will be displayed towards the top-right corner of the 

POS Screen. 

 

 
 

When the Kitchen Docket is printed, it will not contain the Sale Type Status as per this Yes/No Option. 
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If it is a requirement to show the Sale Type Status on the Customer Receipt, this can be enabled via the Yes/No 

Options (Back Office > Setup > Yes/No Options > Search for “Show Sale Type on Receipt” and enable the option. 

 

 
 

 

 

 

 

 

 

 

 


