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EFTPOS 

IP-4622 – Windcave EFTPOS – Support for Pinpad Surcharging/Tips 

This function adds the ability for the Windcave EFTPOS Integration in Idealpos to support Pinpad Surcharging and 

Tips. 

 

Surcharging and tipping functionality may need to be configured and enabled in the Windcave Pinpad and/or 

Windcave software. 

Support for surcharging in Idealpos can be configured via the Undistributed Links configuration. 

Support for tipping via the Windcave EFTPOS Integration in Idealpos can be enabled via the POS Terminal settings > 

EFTPOS tab > Enable Integrated EFTPOS post-transaction Tips. 

 

To enable tipping functionality in Idealpos, go to: Back Office > Setup > Function Descriptors. 

Ensure that one of the Received Account functions (Received Account 1 – 4) have been set to TIPS IN. 

If a TIPS IN function does not exist, select the first unused Received Account function. 

Unused Received Account functions will be labelled as RA [N], where [N] corresponds to the number of the Received 

Account Function. 
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Enter TIPS IN into the Received Account Description.  

Press Save on the top-left corner of the window to save the change. 
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Close the Function Descriptors window, then go to: Back Office > Setup > POS Terminals > Select Terminal > Modify. 

In the EFTPOS Settings tab, ensure that TIPS IN has been selected from the Function to Use dropdown box. 

Also, ensure that Enable Integrated EFTPOS post-transaction Tips is enabled: 

 

 
 

Note that Tipping Functionality/Tipping amounts may need to be configured within the Windcave EFTPOS 
Pinpad/Windcave EFTPOS Software.  
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To configure Surcharging via Undistributed Links, go to: 

Back Office > Setup > Global Options > Sales. 

Within the Undistributed Links section, the Surcharges field needs to be linked to an Undistributed Surcharge Stock 

Item. 
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Press the “>” button in the Surcharges field, then link to an Undistributed Links Surcharges Stock Item. 

 

The below is an example of an Undistributed Surcharge Stock Item: 
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Idealpos Online eGift Interface 

IP-4605 – Idealpos Online eGift Interface 

This function is currently in Beta and documentation will be released shortly. 

When this function becomes available, documentation can be found in the Idealpos v8 User Guide under the “Idealpos 

Online eGift Interface” topic.  
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Labels 

IP-1954 – Zebra Kitchen Labels – Support for Customer Name 

This function adds the ability to have the Customer Name printed on the Zebra Kitchen Label. 

The Customer Name will print on the Zebra Kitchen Label, provided that the Customer is added to the sale at the time 

the sale is processed. 

 

To use this function, ensure that your Zebra Kitchen Labels have been configured accordingly. 

Steps that outline the configuration of Zebra Kitchen Printer/Labels are available in the User Guide by clicking here. 

 

Once the Zebra Kitchen Label printer has been configured according to the steps shown in the User Guide, the 

Customer Name will be printed on the Kitchen Label when a Customer has been added to the sale and the customer 

purchases a Stock Item which has the Zebra Kitchen Label Printer enabled. 

 

 

 
 

 

 

 

 

  

https://userguide.idealpos.com.au/#Labels/Zebra%20Label%20support%20for%20Kitchen%20Printers.htm
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Pending Sales 

IP-4703 – Pending Sales screen – Support for 1366/1920 Resolutions 

This function adds the ability for the Pending Sales screen to fully support 1366x768 and 1920x1080 POS Screen 

Resolutions. This support enables the Pending Sales screen to take advantage of the entire available resolution 

available when using the above resolutions. 

Prior to this change, opening the Pending Sales screen on the above resolutions did not make use of the entire 

available screen resolution. 

 

To configure this function, ensure that your POS Screen supports either 1366x768 or 1920x1080 and ensure that your 

Windows Screen Resolution has been configured accordingly.  

To set your Windows Display Resolution:  

Right-click on your Windows Desktop > Select Display Settings > Display Resolution > Select the appropriate 

resolution for your screen size. 

 

Then configure Idealpos by going to: Back Office > Setup > POS Terminals > Select POS Terminal > Modify. 

Within the POS Settings tab, select either 1366x768 or 1920x1080 or 1920x1080 Retail, depending on your physical 

screen resolution. 
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Depending on the configuration changes made, you may need to restart Idealpos for the new resolution to display 

correctly. 

 

To view any existing Pending Sales, ensure that there are no items added to the sale, then press the Pending button. 

The Pending Sale window will be displayed and will occupy the entire POS Screen Resolution of either 1366x768 or 

1920x1080. 

 

 
 

To save a Pending Sale, add items to the sale, then press the Pending Sale button. 

The Save Pending Sale window will be displayed and will occupy the entire POS Screen Resolution of either 1366x768 

or 1920x1080: 
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IP-4716 – Pending Sales screen – Support for Date Range filter 

This function adds a Date Range filter to the Pending Sales Screen. This function will enable the ability to filter the list 

of Pending Sales based on the Order Date and time (the date/time which the Pending Sale was saved). 

 

To use this function, ensure that there are no items saved to the sale, then press the Pending button on the sale 

screen. 

A list of existing Pending Sales will be displayed. 

A new date dropdown box will be displayed on the top-right corner of the window. 

The dropdown box will default to “All Dates”, meaning that Pending Sales placed on all dates are displayed in the list. 
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Clicking on the dropdown box will reveal a list of all the available date range options. 

Selecting any of these options will adjust the Date Range based on the selected option and any Pending Sales that 

have an Order Date which fall within the range will be filtered. 
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A Custom Date can also be selected, which enables both a Date and Time to be specified in the From/To fields. 

This enables further filtering, simplifying the search for specific Pending Sales that took place at certain times. 
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POS Screen Setup 

IP-4499 – POS Screen Setup – Search Stock Items by Attribute 

This function adds the ability to search for Stock Items by Attribute when adding Stock Items to the POS Screen via the 

POS Screen Setup function. This can be a useful time-saver if you’ve already allocated your Stock Items to their 

respective Attributes and want to add them to the POS Screen. 

 

To use this function, go to: 

Back Office > Setup > POS Screen > POS Screen Setup 

Select a POS Screen Layout > Buttons 
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On the top-left corner of the window, click the “Search Code like” dropdown box, then select “Search Attribute like”. 

 

 
 

An additional dropdown box will appear to the right side of the “Search Attribute like”. 

 

 
 

In the right-hand side dropdown box, select an Attribute from the list. 
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The Stock Item list is filtered by the selected Attribute. 

 

 
 

The Stock Items from the list can then be dragged onto any button within the POS Screen Grid. 
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The Stock Item will appear on the button that it was dragged to. 
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Attributes can be created/modified by going to: Back Office > File > Sales > Stock Item Attributes 

The Attribute Type (e.g. Country of Origin) will be displayed within the left-hand side column. 

The Attribute (e.g. Australia, Mexico, etc.) will be displayed within the right-hand side column. 

 

 
 

New Attribute Types can be created by pressing the “Add New Attribute Type” button on the top-left corner of the 

window. 

New Attributes can be added to an Attribute Type by ensuring that the required Attribute Type is selected, then 

pressing the “Add New [Attribute Type Name]” button, where [Attribute Type Name] will display the name of the 

Attribute Type which has been selected. 
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Attributes can be assigned to Stock Items by going to: 

Back Office > File > Stock Control > Stock Items > Select a Stock Item > Modify 

In the Attributes section on the bottom-right corner of the window, Attributes can be assigned to the Stock Item. 

 

  



 Update History 
Return to top 

Idealpos 8 Build 5 - Update History Page 20 of 50 

 

IP-4739 – POS Screen Tab Buttons – Support for Images 

This function adds the ability to assign images to the POS Screen Tab Buttons shown at the bottom of the POS Screen. 

Assigning images to POS Screen Tab Buttons will assist Clerks to easily identify the items contained within a POS 

Screen Tab using imagery. 

Note that this function is not currently supported by the Handheld/Pocket apps. 

 

To configure and use this function, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select the required POS Screen Layout > Press “Buttons” on the top-left corner of the window. 

Within the POS Screen Layout window, click on any of the POS Screen Tab Buttons displayed at the bottom of the 

window. 
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The options to modify the button will appear within the top-left corner portion of the POS Screen Layout. 

In this window, you can:  

• Enter or modify or the Button Caption 

• Enable or Disable the Double Height option - This option is only available when modifying a POS Screen Tab 

Button from the top-row or when modifying a button that has already been configured as Double Height. 

When enabling Double Height, the POS Screen Tab Button on the bottom row will be covered and will be 

unavailable. 

• Assign a Graphic to the button 
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When assigning a Graphic to the POS Screen Tab Button, copy the required JPG image into the Pictures folder in this 

location - C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\ 

Alternatively, you may select an existing JPG image from the above location. 

Within the Graphic field, press the “>” button as shown below: 

 

 
 

Browse to the Pictures Folder (C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\), then select a JPG image within 

this folder. Alternatively, you can copy the required the image into this folder and use it. 

Note that when using images, we recommend using an image that is the same resolution as the POS Screen button. 

Using a large image will result in the POS terminal needing to perform additional processing to display the image, 

which can result in degraded performance when using the POS Terminal. 

Button resolution sizes can vary depending on your POS Screen Resolution size.  

The following is a guide on button size resolutions: 

 

1024x768/1024x600 

Standard Size – 110x52 

Double Height – 111x105 

 

1920x1080 

Standard Size – 128x59 

Double Height – 128x120 
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Select an image, then press “Open” 

 

 
 

The Image will appear in the Button Appearance preview. 

Press the “Save” button to continue: 
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The Graphic will now appear on the POS Screen Tab Button: 

 

 
 

You can repeat the above process for each POS Screen Tab Button that requires a graphic. 

Once complete, close the POS Screen Layout window. 
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If any new images were copied into the Pictures Folder (C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\), you 

will need to copy the Image Folder to each POS Terminal on your network.  

This can be achieved by going to: Back Office > Utilities > Send > Pictures Folder. 

Select the POS Terminals that you want to copy the image folder to, then press “OK” on the bottom-right corner. 

If all Terminals require the images to be sent, press the “Select All” button on the bottom-left corner of the window: 

 

 
 

After the images have been sent and the operation has completed, press the “OK” button on the bottom-right 
corner of the window to close the window.  
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Open the POS Screen. 

The images will now appear within the POS Screen Tab button(s) as configured above. 
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Range Programming 

IP-4711 – Range Programming – Inherit Parent Pricing for Variants 

This function adds the ability to toggle the “Inherit Prices from Parent” checkbox on Variant Items via the Range 

Programming function. 

 

Before utilising the Range Programming Function, please be aware that this function can be used to perform bulk 

changes to your Stock Items. Any mistakes made while using this function can result in the change being applied to all 

your Stock Items. Use caution and ensure that any settings which have been entered are correct before applying the 

change. 

 

To use this function, go to:  

Back Office > Utilities > Range Programming > Stock Items 

 

Set the criteria as required via the Code, Description, Department and Supplier fields. 
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From one of the available Fields, select “Inherit Parent Pricing” option. 
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Set the checkbox for the option as required. 

Enabling the checkbox will enable the “Inherit Prices from Parent” checkbox for all items within the selected criteria. 

Disabling the checkbox will disable the “Inherit Prices from Parent” checkbox for all items within the selected criteria. 

Note that setting this option on Stock Items which are not Variant Items will have no effect on the item – this option is 

only applicable to Variant Stock Items.  

 

 
 

To apply the change to the selected criteria, press the “Proceed” button on the top-left corner of the window. 

 

 
 

Press “Yes” to proceed. 
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The “Inherit Prices from Parent” will either be enabled or disabled, depending on the option selected during the Range 

Programming process. 
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Reservation Interfaces 

IP-4725 – ResDiary Interface – Support for TLS 1.2 

This function adds support for TLS 1.2 to the ResDiary Interface. 

ResDiary have indicated that they will be turning off TLS 1.0 later this year, so we are adding support for TLS 1.2 to the 

ResDiary Interface well in advanced before they turn off TLS 1.0.  

 

Once we are advised of an exact TLS 1.0 cut-off date, we will also list this date in the ResDiary topic within the Idealpos 

User Guide. 

 

For further details about the ResDiary Reservation Interface, refer to the ResDiary topic in the User Guide.  

https://userguide.idealpos.com.au/#Reservations%20Interfaces/ResDiary%20TheFork/ResDiary%20TheFork.htm
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Restaurant and Table Map 

IP-4732 – Table Details – Show Order Date if not Today 

This function adds further information to the Table Details screen by displaying the date that an Order was saved to a 

Table. The ordered date will only be displayed if the order was not placed on the current date.  

This means that any orders placed to a table and paid on the same day will not display the ordered date. 

Any orders that were placed to a table on the previous day or prior will display an ordered date. 

This function is useful for venues that may use tables over the course of multiple days. 

 

To utilise this function, ensure that you have the option “Table Details – Group by Order Time” enabled in Yes/No 

Options. 

Go to: Back Office > Setup > Yes/No Options. 

Search: Group 

Enable: “Table Details – Group by Order Time” 
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Open the POS Screen > Table Map. 

Select a Table from the Table Map > Details. 
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Any orders which are placed today will only show the ordered time. 

Orders that were placed prior to today will contain the ordered date and time. 

In the below example, the first order contains the ordered time and date as it was placed on a date prior to the current 

date when the below screenshot was taken. 

The second order does not show the ordered date as it was placed on the current date.  
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Stock Items  

IP-4648 – Stock Item Variants – Ability to Bulk-Select the Create field 

This function adds the ability to bulk-select the Create field. 

Before this change, you would have to manually unselect the Create checkbox for each Variant in the list if you didn’t 

want all Create checkboxes enabled.  

With this change, the “Create” heading text label now acts as a toggle which can be pressed to either enable or disable 

the Create checkbox for each Variant in the list. 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

Select an existing Parent Stock Item which doesn’t have all Variant Options enabled. 

Alternatively, create a new Parent Stock Item which will utilise the Variants functionality. 

If a new Parent Stock Item is being created, ensure that the “Has Variants” checkbox has been enabled which will 

enable access to the Variants tab. 

Within the Variants tab, enable the required Variant Option checkboxes on the left-hand side of the window. 

 

 
  



 Update History 
Return to top 

Idealpos 8 Build 5 - Update History Page 36 of 50 

 

Clicking on the “Create” column header text will either toggle all Create checkboxes on or off. 
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IP-4649 – Stock Item Variants – Filter options for new Variants 

This function adds the ability to filter the list of new Variants by selecting a Variant Type (e.g. Colour), then selecting 

the type of colour (e.g. Blue). All the Variants that match the filter will be displayed in the list. 

The filter function enables you to create smaller batches of New Variant items at a time, useful if you are working your 

way through creating batches of New Variants at a time (e.g. Create all Variant Items which are Coloured Blue first, 

then work your way through creating the remaining colours). 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

Either select a Stock Item that you intend on setting as a Parent Stock Item or select an existing Parent Stock Item that 

doesn’t have all variant options enabled > Modify. 

 

Navigate to the Variants tab (ensure that the item has the “Has Variants” option enabled):  
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In the Variants tab, enable new variant options on the left-hand side of the window. 
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On the top-right corner of the window, select the Variant Type and the Variant Option you want to filter by: 

 

 
 

The first drop-down box refers to the Variant Type (e.g. Colour) and the second drop-down box is the Variant Option 

(e.g. Blue). 
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Once the filter options have been selected, the list of New Variants will be updated to reflect the filter: 

 

 
 
Pressing the “Create New Variants” button while the filter is active will result in only the visible filtered Variant Items 
being created.  
Once the filtered Variant Items are created, they will be shown at the top of the window under the Existing Variants 
list, the filter will be cleared and any New Variant Items which haven’t been created yet will reappear half-way down 
the screen under the “New Variants” list. 
Note that when any changes have been made to the list of Variant Items (such as toggling the “Create” checkbox, 
modifying the Price 1 of the Variant, modifying/entering a Scan Code, etc.) the filter drop-down boxes will be 
replaced with a “Reset New Variants” button.  
Pressing this button will Reset the New Variants list, causing any changes that you have made to the list of New 
Variants to be cleared. After the button is pressed, the Variant filter drop-down boxes will reappear. 
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IP-4650 – Stock Item Variants – Manually adjust Sell Prices when creating new Variants 

This function adds the ability to manually adjust Sell Price 1 when creating new Variant Items. 

Before this change, Variant Items that were created would always inherit prices from the Parent Item and any change 

to the New Variant’s Sell Price could only be made after the Variants are created by manually opening each Variant 

Item and modifying the Sell Price. 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

Create or modify an existing Parent Variant Item. 

The Parent Item must have the “Has Variants” checkbox enabled in order to have the ability to access the Variants tab. 
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Navigate to the Variants tab, then enable the required Variant options from the left-hand side. 

Once the required options have been enabled, disable the “Inherit Prices from Parent” checkbox. 
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Once the “Inherit Prices from Parent” checkbox has been unchecked, a new Price 1 column will appear. 

The amounts displayed in Price 1 will default to the value entered into the Price 1 from the Parent Item. 
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The Sell Prices of each Variant Item can now be adjusted by clicking into the Price 1 field and modified as required.  
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The Variants can then be created by pressing the “Create New Variants” button on the bottom-right corner of the 

window. 
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Each Variant Item created as part of this process will contain a Level 1 Sell Price as entered during the Variant Item 

creation process listed above and will also have the “Inherit Prices from Parent” checkbox unticked. 
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IP-4652 – Stock Item Variants – Changing fields of Parent Item can bulk-change all Variants 

This function adds the ability to bulk change fields of all Child Variant Stock Items when modifying fields of the Parent 

Stock Item. An example of this is modifying the Department, Purchase Category and/or Supplier that the Parent Stock 

Item is linked to. 

Once the fields have been modified and the Parent Stock Item is saved, Idealpos will display one of seven prompts 

asking whether to update the Variant Items. 
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To use this function, go to: Back Office > File > Stock Control > Stock Items. 

Select a Parent Stock Item > Modify. 

Parent Stock Items will display a drop-down arrow when the Stock Item is selected in the Stock Items grid (as shown in 

the example below): 

 
 

The Stock Items grid can also be filtered by entering “Y” into the Has Variants field: 

 
 

Modify a Parent Stock Item by opening it (double-click the Stock Item or select the Stock Item > Modify). 

Modify the Department, Purchase Category and/or Supplier: 
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Press the “Save” button on the top left-hand side of the window: 

 

 
 

Idealpos will display a prompt similar to the below (the message will vary depending on whether you modified the 

Department, Purchase Category, Supplier or any combination of these three options). 

Press “Yes” to update the Variant items if you would like to apply the change of Department/Supplier to the Variants. 

 

 
 

The change can be confirmed by modifying a Variant Item linked to the Parent Item. 

The modified Department/Supplier will be displayed: 

 

 


