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Back Office 
IP-3721 – Remote Assistance – Direct link from Backoffice Help Menu 

This function adds a Remote Assistance option to the Backoffice Help Menu. When this option is selected from the 
Back Office Help Menu, it will trigger the TeamViewer Quick Support application to open.  
The TeamViewer ID and Password will be displayed which can be provided to the Support Staff so they can connect 
to your system and render assistance. 
 
To use this function, simply click the Help Menu from the Back Office and then select “Remote Assistance” as 
shown below: 
 

 
 
TeamViewer Quick Support is then displayed showing your ID and Password 
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Customer Display 
IP-3639 – Accumulating Items will accumulate on Customer Display 

This function adds accumulating item support to the Customer Display. 
The Non-Accumulating checkbox available when editing a Stock Item controls the way the item appears on both the 
POS screen and Customer Display when more than one quantity of the item is added to a sale. 
When the Non-Accumulating checkbox is ticked, adding multiples of the same item will result in each instance of 
the item occupying a separate line on the POS Screen and Customer Display. 
When the Non-Accumulating checkbox is unticked, adding multiples of the same item will result in the item 
appearing on a single line on the POS Screen and Customer Display with a quantity counter next to the item 
showing the quantity of the item in the sale/number of times the item has been added to the sale. 
 
Previous to this change, the Non-Accumulating option configured within a Stock Item would only apply to the POS 
Screen. If a Stock Item had the Non-Accumulating option unticked and multiples of the Item were added to a sale, 
the item would accumulate on the POS Screen but would not accumulate on the Customer Display. 
With the change introduced in this function, accumulating items will now accumulate on both the POS Screen and 
the Customer Display.  
 
In order to utilise this function, your system will require a Customer Display.  
The steps outlined below which outline this function are based on the assumption you already have a Customer 
Display configured and enabled. 
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To configure and use this function, go to: 
File > Stock Control > Stock Items 
Double-click on a Stock Item to modify it. 
Configure the Non-Accumulating function as required. 
As outlined above, when Non-Accumulating is unticked, multiples of the same item will be shown on a single line 
with the quantity counter indicating the number of times the item has been added to the sale. 
When Non-Accumulating is ticked, adding multiples of the same item will result in each instance of the item 
occupying a separate line. 
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Once the item has been configured, go to the POS Screen and add multiples of the same item. 
In the below examples, we have added a quantity of two Cappuccinos with the Non-Accumulating option disabled. 
 
POS Screen: 
 

 
 
Customer Display: 
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When the Non-Accumulating option is enabled, the item will appear on the POS Screen and Customer Display as 
shown below: 
 
POS Screen: 
 

 
 
Customer Display: 
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Another option available to complement the display of accumulating Items on the POS Screen is the Yes/No Option 
“Show Unit Price of Items”. When this Yes/No Option is enabled, the Unit Price will also appear on both the POS 
Screen and the Customer Display. It should be noted that the Unit Price may be omitted from the Customer Display 
if the selected Customer Display layout and/or Customer Display screen resolution do not have the required screen 
real-estate to display the Item Description and the Unit Price. 
 
To display the Unit Price on the Customer Display and the POS Screen, go to: 
Setup > Yes/No Options > Enter Keyword Search: Unit 
Enable “Show Unit Price of Items” 
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When an accumulating or non-accumulating Stock Item is added to the Sale, the Unit Price will appear on both the 
POS Screen and the Customer Display (provided that the Customer Display has enough screen real-estate to display 
the full Stock Item Description and the Unit Price). 
 
POS Screen: 
 

 
 
Customer Display: 
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Customers 
IP-3678 – Customer Type – Bar Tab Descriptor tag in User-Defined Text 

This function has been implemented as part of a wider Pre-Ordering function which enables customers to pre-order 
their items with a deposit, then come back at a later date, pickup the order and pay the outstanding balance. 
A complete list of new features that have been implemented which allow this function to be utilised are listed 
below: 
 

• IP-3677 – Yes/No Option – New Bar Tab Customers default to Allow Prepaid 
• IP-3678 – Customer Type – Bar Tab Descriptor tag in User-Defined Text 
• IP-3680 – Pending Sales Report – Filter by Customer Type 
• IP-3681 – Customer Type – Option to Ask for Expected Date on Bar Tabs 
• IP-3686 – Yes/No Option – Pre-paid Bar Tabs recall Bar Tab if no Prepayment has been done 

 
If you’d like to follow an end-to-end list of steps to configure and use this Pre-Ordering function in the User Guide, 
click here. 
Otherwise, please continue below for details about this change (Customer Type – Bar Tab Descriptor tag in User-
Defined Text): 
 
This function adds the ability to configure the Bar Tab Descriptor tag text that is displayed on the POS Sale Screen 
when a Bar Tab Customer is added to the sale. A usage example of this function is when the Pre-Ordering function 
described above is being used and the default “BAR TAB” descriptor is unsuitable. 
 
To configure and use this function, go to: File > Customers > Customer Types 
In the User-Defined Text field, enter the following text: 
[BAR TAB DESCRIPTOR=XMAS CLUB] 
 
Then press the “Save” button on the bottom-right corner of the Customer Types window to save the change. 
 

 
  

https://userguide.idealpos.com.au/#Pre-Ordering%20Functionality/Pre-Ordering%20Functionality.htm
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Go to: File > Customers > Customers 
Either create a new Customer by pressing the “Add” button on the bottom-right corner of the window, or select an 
existing Customer, then press the “Modify” button on the bottom-right corner of the window. 
Ensure that the new or existing Customer is linked to the Customer Type configured in the previous step and 
ensure that the “Bar Tab” checkbox is enabled. 
Press the “Save” button on the bottom-right corner of the customer window to save the change. 
 

 
 
Close the Customers window, then go to the POS Screen by pressing the “POS” button on the top-left corner of the 
Back Office Dashboard. 
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Press the “Customers” button, then select the above Customer from the list. 
The Customer is added to the sale, and the descriptor that was configured for the XMAS CLUB Customer Type is 
displayed on the POS Screen as per the below example: 
 

 
 
When the User-Defined option is not configured and a Bar Tab Customer from the XMAS Club Customer Type is 
added to the sale, the POS Screen will appear as follows: 
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IP-3681 – Customer Type – Option to Ask for Expected Date on Bar Tabs 

This function has been implemented as part of a wider Pre-Ordering function which enables customers to pre-order 
their items with a deposit, then come back at a later date, pickup the order and pay the outstanding balance. 
A complete list of new features that have been implemented which allow this function to be utilised are listed 
below: 
 

• IP-3677 – Yes/No Option – New Bar Tab Customers default to Allow Prepaid 
• IP-3678 – Customer Type – Bar Tab Descriptor tag in User-Defined Text 
• IP-3680 – Pending Sales Report – Filter by Customer Type 
• IP-3681 – Customer Type – Option to Ask for Expected Date on Bar Tabs 
• IP-3686 – Yes/No Option – Pre-paid Bar Tabs recall Bar Tab if no Prepayment has been done 

 
If you’d like to follow an end-to-end list of steps to configure and use this Pre-Ordering function in the User Guide, 
click here. 
Otherwise, please continue below for details about this change (Customer Type – Option to Ask for Expected Date 
on Bar Tabs): 
 
This new option (Prompt for Expected Date for Bar Tabs) has been added to the Customer Types screen.  
When this option is enabled for a Customer Type and the Customer assigned to this Customer Type has the “Bar 
Tab” option enabled in their Customer record, Idealpos will display a prompt for a pickup date when items are 
saved to the Customer’s Bar Tab. The date which is entered in the prompt is then displayed in the Pending Sales 
report which can be used for reporting purposes. 
 
Before configuring and using this function, it is assumed that your system has already been configured and ready-
to-use with Bar Tabs. For further details about configuring and using Bar Tabs, visit the Bar Tab topic in the Idealpos 
User Guide. 
 
 
  

https://userguide.idealpos.com.au/#Pre-Ordering%20Functionality/Pre-Ordering%20Functionality.htm
https://userguide.idealpos.com.au/#Bar%20Tabs/Bar%20Tabs.htm


 Update History 
Return to top 

Idealpos 7.1 Build 13 - Update History Page 14 of 109 

 

To configure and use this function, go to: File > Customers > Customer Types 
Either select an existing Customer Type and press the “Modify” button on the bottom-right corner of the window, 
or press the “Add” button on the bottom-right corner of the window to create a new Customer Type. 
 
When Modifying/Creating a new Customer Type, enable the option “Prompt for Expected Date for Bar Tabs”. 
Note that the “New Customers Default to Bar Tab” option does not need to be enabled for the Customer Type, 
however, any Customer assigned to this Customer Type will need to have the “Bar Tab” option enabled within their 
Customer record in order to utilise and see the “Prompt for Expected Date for Bar Tabs”. 
Once you have finished creating or modifying the existing Customer Type, press the “Save” button on the bottom-
right corner of the Customer Types window. 
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As mentioned above, you will need to ensure that the Customer has the Bar Tab option enabled to utilise the 
Expected Date functionality. 
Go to: File > Customers > Customers. 
Select the required Customer, then press the “Modify” option on the bottom-right corner of the window. 
Then enable the “Bar Tab” option as shown in the below example. 
If the Pre-Paid functionality isn’t being utilised, you will also want to ensure that a Credit Limit has been set 
(located to the right of the “Bar Tab” tickbox). The Credit Limit controls the maximum total sale amount allowed for 
the Bar Tab. The customer cannot have a total sale amount that exceeds the Credit Limit entered when saving to  
the Bar Tab. 
Once you have finished making changes to the Customer, press the “Save” button on the bottom-right corner of the 
Modify Customer window: 
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From the Back-Office dashboard, open the POS Screen by pressing the POS button on the top-left corner of the 
window. 
Press the BAR TAB button to show a list of Bar Tab Customers, then select a Bar Tab Customer. 
The Bar Tab Customer is added to the sale: 
 

 
 
Add the required items to the sale. Remember that the total value of all items that can be saved to the Bar Tab is 
limited to the amount set in the Credit Limit for the Bar Tab Customer. 
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Press the “ENTER” button to save the Bar Tab. 
 

 
 
Idealpos will prompt for the Pickup date. Select a date from the Calendar when the order is required. 
The below example shows the current date of 19/10/2020, with the selected date being the 20/10/2020. 
 

 
 
Press OK to proceed with the selected date. 
The sale is now cleared from the POS screen, ready to serve the next customer. 
  



 Update History 
Return to top 

Idealpos 7.1 Build 13 - Update History Page 18 of 109 

 

The Pending Sales Report can now be run to show Bar Tabs that are due for Pickup on any given day. 
Go to: Reports > Sales > Pending Sales 
Select the date on the left-hand side of the window. 
You have the option to select a pre-selected period (today, tomorrow, next week, etc.), or you can select Custom to 
select a specific day or period. 
The “Show Bar Tabs only” checkbox can also be enabled to exclude any non-Bar Tab Pending Sales from appearing 
in the Report. 
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Any Bar Tabs that have a Pickup Date which matches the date chosen when running the Report will be displayed. 
If the date period entered when running the report covers a range of more than one day and there are Bar Tabs 
with Pickup Dates that fall within the range, the Bar Tabs will be grouped by date (provided that Group by Order 
Date is selected). Otherwise, the Pending Sales will be grouped by Status. 
The Pending Sales Report is useful to determine the number of orders that are going to be picked up on any given 
day along with the items that are required for each order and the Customer Name which placed the order. 
In the below example, the Customer Name is “Bar Tab Customer”, the order was placed on 19th October 2020 and 
the Pickup date is Tuesday 20 October 2020. 
 

 
 
When the Customer arrives to pickup their order on the day, the process is as simple as adding the Customer to the 
sale, then pressing the “Pay Bar Tab” button which will recall all the items to the sale, followed by pressing the 
“ENTER” button to go to the Tender screen and take payment from the Customer. 
For further details about using the Bar Tab functionality, please refer to the Bar Tab topic in the User Guide. 
  

https://userguide.idealpos.com.au/#Bar%20Tabs/Bar%20Tabs.htm
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EFTPOS 
IP-595 – Tyro Pay@Table – Support for Newbook/GuestCentrix/GuestPoint 

This function adds support for posting sales to Newbook/Guestcentrix/Guestpoint that have been paid for using 
Tyro Pay@Table. 
To use this function, you will require the following: 

• Tyro Pay@Table Pinpad and Tyro Pay@Table enabled in your Licence Gateway 
• Room Interface enabled and configured (either Newbook, GuestCentrix or GuestPoint) 
• Idealpos Restaurant Module (to use Table Maps/Table Ordering) 

 
The steps in the Update History document for using this function only outline the basics due the complexity in 
setting this up in addition to the requirement of already having specific interfaces enabled and configured. 
It is assumed that your system is already configured for Tyro Pay@Table and one of the Room Interfaces outlined 
above. 
 
To configure and use this function, go to: Setup > Global Options > Interfaces > Room Interface 
Ensure that “Post Paid Transactions” is enabled for your Room Interface. 
The below examples show the GuestPoint and Newbook Interfaces with the “Post Paid Transactions” option 
enabled. Note that when enabling the Post Paid Transactions option, other options in your system will already be 
configured and should not be modified unless necessary. 
It is also assumed that you understand the repercussions of enabling this option for your Room Interface. 
If unsure, please consult with your Room Interface provider on whether this will affect your Room Interface. 
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Once the “Post Paid Transactions” option is enabled, any tables which are paid off using the Tyro Pay@Table 
interface will be written to the CHARGES.DAT file in your Network Path location configured above. 
Save Items to a table by adding them to a sale then press the Table Map and select a table. 
 
After Items have been saved to a table, they can be paid off using the Tyro Pay@Table Pinpad. 
To pay off a table from the Tyro Pay@Table pinpad, first, enter the Clerk ID. 
Then enter the Table Number. 
The amount due for the table will be shown. 
It can be either paid off in full or paid using Split Payments. 
Once the table is paid, the transaction data is exported to the Room Interface in the CHARGES.DAT file as per the 
example shown below. 
For further information about the process on how to use the Tyro Pay@Table Interface, please refer to the Tyro 
Pay@Table topic in the Idealpos User Guide. 
 

  

https://userguide.idealpos.com.au/#EFTPOS/Tyro/Tyro%20Pay%20Table.htm
https://userguide.idealpos.com.au/#EFTPOS/Tyro/Tyro%20Pay%20Table.htm
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Export Data 
IP-3598 – Automatic Export – Filter for Scale Items only 

This function adds the ability to configure the Automatic Export in Idealpos so that only Scale Items are included in 
the export file. This may be useful in environments where you need to import scale items into a scale and require a 
file only containing scale items in the exported data. 
 
To configure and use this function, go to:  
Back Office > Setup > POS Terminals > Import/Export 
Enable the “Scale Items Only” checkbox. 
 

 
 
If your system hasn’t already been configured to Automatically Export data, you will need to ensure that the 
following fields are configured to enable the Automatic Export functionality: 
 

• Export Folder 
• Export Daily at/Or every # minutes 
• Filename 

 
Any other checkboxes can also be enabled as required. 
  



 Update History 
Return to top 

Idealpos 7.1 Build 13 - Update History Page 23 of 109 

 

Once configured, the Automatic Export will occur either daily at the specified time, or the export will occur using 
the interval entered into the every # minutes field. 
When Scale Items Only is enabled, any Stock Item which has the Scale checkbox enabled will be included in the 
exported data and any non-scale items will be excluded from the exported data. 
 
The scale option appears in the Stock Items screen (from the Back Office, go to: File > Stock Control > Stock Items > 
Select Stock Item > Modify). 
The below example shows a Scale Item with the Scale checkbox enabled: 
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The below is an example showing data exported using the Automatic Export function with the Scale Items Only 
checkbox enabled: 
 

  
 
For further details about configuring and using the Automatic Export function, refer to the POS Terminal Settings 
Import/Export topic in the Idealpos User Guide.  

https://userguide.idealpos.com.au/Default.htm#POS%20Terminals/Import%20Export.htm
https://userguide.idealpos.com.au/Default.htm#POS%20Terminals/Import%20Export.htm
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Gaming 
IP-3719 – Gaming – Option to Trigger Card Swipe manually using semi-colon prefix 

This function adds the ability to have Idealpos trigger a Card Swipe manually when it receives any data entered 
either manually or via Keyboard Wedge which starts with a semi-colon [;]. 
 
To enable this functionality, go to: 
Setup > Global Options > Gaming 
Enable “Trigger Card Swipe manually using [ ; ] Prefix 
 

 
 
Close the Global Options window to save the change. 
Any data the POS receives which contains the prefix shown above will trigger a card swipe manually.  
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Pending Sales 
IP-3657 – Pending Sales – Option to record Order Date in Journal 

This function will add the Pending Sale Order Date into the Transaction Journal when the Pending Sale is finalised. 
This can serve as a useful option when you require the ability to see the Order Date/Required Date in the Journal 
History for historical or informational purposes. This applies to both Pending Sales as well as eCommerce orders 
that are received by Idealpos. 
 
This option is controlled by toggling the Yes/No Option “Pending Sale Order recorded as Text in Journal” 
Note that this option will need to be enabled prior to saving/recalling the Pending Sale. 
Enabling the Yes/No option after the Pending Sale has already been finalised will not trigger prior sales to have 
their Order Dates populated in the Journal. 
 
To configure and use this function, go to: Setup > Yes/No Options > Enter Keyword Search: order date 
Enable “Pending Sale Order Date recorded as Text in Journal” 
 

 
 
Close the Yes/No Options, then restart the Idealpos suite to ensure changes have applied. 
Go to: Start > Idealpos > IPSUtils > Close IPS Utility > Close 
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Start Idealpos by either double-clicking on the Idealpos desktop shortcut, or go to Start > Idealpos > Idealpos 
From the POS Screen, add items to a sale, then press the “PENDING” button: 
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In the Save Pending Sale window, enter the Customer’s Name, Address and Order Date/Time, then press the “Save” 
button on the bottom-right corner to save the Pending Sale. The date entered in the annotated field below will be 
displayed in the Journal Enquiry once the sale is finalised as shown in the steps further below: 
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Once the Pending Sale has been saved, press the “PENDING” button and select the Pending Sale from the list, then 
press the “OK” button on the bottom-right corner of the window to recall the sale to the POS Screen: 
 

 
 
The Pending Sale is recalled to the POS Screen: 
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Press the ENTER button on the POS Screen and tender the sale using the required Tender type. 
In the below example, we will tender with CASH: 
 

 
 
Close the POS Screen, then from the Back Office, go to: Enquiry > Journal History 
Select the finalised transaction from the left-hand side of the Journal History Enquiry window. 
The right-hand side of the window will display the Journal details, including the Order Date as shown in the 
example below: 
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POS Screen 
IP-3668 – Can’t buy with Gift Voucher message enhanced 

This function enhances the prompt that appears on the POS Screen when attempting to tender the transaction 
with a Gift Voucher when the transaction contains Items marked as “Can’t buy with Gift Voucher”.  
Previous to this enhancement, Idealpos will display a prompt that simply stated “There are items in this transaction 
that you cannot buy with a GIFT VOUCHER!”, however, the prompt did not give any indication which items were 
affected, nor did it state what maximum permissible value could be tendered with the Gift Voucher for the current 
transaction. 
 
An example of the old prompt is shown below: 
 

 
 
When using a Gift Voucher to tender a sale that contains items which are marked as “Can’t buy with Gift Voucher”, 
an enhanced and more informative prompt is now displayed which will appear similar to the below example. 
The prompt will display a list of offending items which cannot be purchased with the Gift Voucher, and it also 
indicates the maximum permissible amount that can be tendered using a Gift Voucher for the current sale. 
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To use this function, you will need to ensure that the following conditions are met: 
• Stock Items which are marked as “Can’t Buy with GIFT VOUCHER” 
• Gift Voucher Redemption button exists on your Tender Screen 

 
You will also need to ensure that your system is configured for the sale of Gift Vouchers. 
Complete details on how to configure your system for Gift Vouchers can be found in the Gift Vouchers – Setting up 
Gift Vouchers topic in the User Guide. You may also want to refer the Gift Vouchers topic for complete details on 
how to utilise the Gift Vouchers function in Idealpos. 
 
The steps outlined below will only cover the two bullet points above which are required to demonstrate the 
enhanced “Can’t buy with Gift Voucher” prompt.  
 
To enable the Can’t Buy with GIFT VOUCHER setting on the Stock Items you want to restrict, go to: 
File > Stock Control > Stock Items 
Select a Stock Item which you want to exclude from Gift Voucher purchase, then press “Modify” on the bottom-
right corner of the window to modify the Stock Item. 
 
Enable the “Can’t Buy with GIFT VOUCHER” checkbox, then press the “Save” button on the bottom-right corner of 
the Stock Item window. 
 

 
 
You may repeat the above process for all Stock Items which you want to exclude from purchase with a Gift Voucher. 
Once complete, close the Stock Item windows. 
 
  

https://userguide.idealpos.com.au/Default.htm#Gift%20Vouchers/Setting%20up%20Gift%20Vouchers.htm
https://userguide.idealpos.com.au/Default.htm#Gift%20Vouchers/Setting%20up%20Gift%20Vouchers.htm
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You will also need to ensure that a GV Redeem button exists on the Tender Screen. 
To enable this, go to: Setup > Function Descriptors. 
Ensure that one of your Received Account functions are configured for GV Purchase. 
Typically, one of the Received Account 1 to 4 will have GV Purchase or similar entered into the Description. 
If not, you may select the first unused RA function and double-click on it to configure it. Unused Ra functions are 
named as RA #, where # will reflect the number of the Received Account. 
 
The below example shows a system which has already been configured with the GV PURCHASE: 
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Whether you are configuring a new Received Account function for GV PURCHASE or you’re checking an existing GV 
PURCHASE (to ensure it is configured correctly), the Received Account should be labelled correctly (GV 
PURCHASE/Gift Voucher Purchase/etc.) and the GIFT VOUCHER option should be ticked as shown in the below 
example. 
Press “Save” to save any changes to the Function Descriptor. 
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Then ensure that you have a Tender configured for the GV Redeem button. 
Tenders are listed as TENDER 1 up to TENDER 18. 
Ensure that you have a Tender labelled GV REDEEM or Gift Voucher Redeem. 
If you don’t have a GV REDEEM tender or equivalent, find the next unused Tender and modify it. 
Unused Tenders are simply labelled as TENDER ##, where ## refers to the tender number. 
 
The below example shows the GV REDEEM being assigned to Tender 7, however, your Tender number may vary 
depending on the existing tender functions that have already been assigned and configured: 
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Ensure that the following changes are made to the selected Function Descriptor: 
• Description is set accordingly (e.g. GV REDEEM) 
• GIFT VOUCHER Redemption enabled 
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The last step to enable the GV Redemption button on the POS Screen is to enable it in the Yes/No Options. 
Go to: Setup > Yes/No Options > Tenders 
 
Ensure that the “Inhibit GV REDEEM” tender is unticked. 
Any Tenders which are checked in this list are disabled and do not appear on the Tender screen, and unticked 
Tenders will appear on the Tender screen. 
 

 
 
Once the above steps have been completed, restart the Idealpos suite to ensure changes have applied. 
Go to: Start > Idealpos > IPSUtils > Close IPS Utility > Close 
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Start Idealpos via the Idealpos Desktop shortcut, or go to: Start > Idealpos > Idealpos 
From the Idealpos POS Screen, add items to the sale and ensure that you add an item which has had the Can’t But 
with GIFT VOUCHER option enabled. 
In the below example, the Can’t Buy with GIFT VOUCHER option was enabled on the FAMILY ADMISSION Stock 
Item.  
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Press “ENTER” to go to the Tender screen, then press the GV REDEEM button: 
 

 
 
Idealpos will display a prompt indicating which items in the current sale are not applicable for purchase with a Gift 
Voucher: 
 

 
 
Because an amount wasn’t entered when pressing the GV REDEEM button, Idealpos has determined that the total 
amount includes items not applicable for redemption with a Gift Voucher. 
You have the two following options:  

• Return to the sale and void the items not applicable for purchase with a Gift Voucher 
• Continue with the sale and advise the customer they will need to purchase the Restricted Items using 

Cash/EFTPOS 
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If the Customer wants to continue with the purchase of the Restricted Items using Cash or EFTPOS, note down the 
amount shown in the above prompt next to “Total Amount allowed on GIFT VOUCHER”, then press “OK”. 
Enter the amount using the on-screen numeric keypad and the amount will show in the amount field as shown in 
the below example, then press the “GV REDEEM” button: 
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Idealpos will then display the GIFT VOUCHER redemption prompt where you can Scan or Enter the Voucher Code: 
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The process outlined in the User Guide - Redeem Gift Voucher topic can be used to redeem the Gift Voucher. 
Once the Voucher has been redeemed, the remaining balance due can be paid using Cash, EFTPOS or any other non-
Gift Voucher tender. Press the desired Tender method to finalise the remaining amount. 
 

   

https://userguide.idealpos.com.au/Default.htm#Gift%20Vouchers/Redeem%20Gift%20Voucher.htm
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POS Screen Setup 
IP-3720 – Remote Assistance Function for POS Screen 

This function adds the ability to create a button on the POS Screen to open the TeamViewer Quick Support 
application. When Remote Assistance button is pressed, the TeamViewer Quick Support application will be 
displayed and will contain Your ID and Password. Provide the ID and Password to support staff when you require 
support and once the support staff establish a connection to your system, they will see POS screen, ready to 
provide assistance. This functionality is particularly useful if you’re currently faced with an issue on the POS Screen 
and need to give the support staff access to the system quickly. The Remote Assistance button can be pressed 
without having to close the POS Screen. 
 
To configure and use this function, go to: Setup > POS Screen > POS Screen Setup 
Select the POS Screen layout, then press the “Buttons” button on the bottom-left corner of the window. 
Click on a suitable POS Screen tab where you’d like to have the Remote Assistance button located, then locate a 
blank/unused button and select it. 
From the Function List, select “Remote Assistance”. 
The button can be customised as required (Button Caption, Button Size, Button Colour, Font, Font Size)  
Once finished creating and customising the button, press the “Save” button. 
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Close the POS Screen layout windows, then go to the POS Screen by pressing the “POS” button on the top-left 
corner of the Back-Office Dashboard. 
Press the POS Screen tab where the Remote Assistance button was created and press it. 
The TeamViewer Quick Support window is displayed, showing the ID and Password which you will need to provide 
to Support Staff to get remote assistance. 
 

 
 
Once the support session has been completed, ensure that you close TeamViewer Quick Support. 
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Pre-Ordering Functionality 
This function enables customers to pre-order their items with a deposit, then come back at a later date, pickup the 
order and pay the outstanding balance. 
A complete list of new features that have been implemented which allow this function to be utilised are listed 
below: 
 

• IP-3677 – Yes/No Option – New Bar Tab Customers default to Allow Prepaid 
• IP-3678 – Customer Type – Bar Tab Descriptor tag in User-Defined Text 
• IP-3680 – Pending Sales Report – Filter by Customer Type 
• IP-3681 – Customer Type – Option to Ask for Expected Date on Bar Tabs 
• IP-3686 – Yes/No Option – Pre-paid Bar Tabs recall Bar Tab if no Prepayment has been done 

 
For a complete end-to-end list of steps required to configure and use this Pre-Ordering function, please refer to the 
Pre-Ordering Function topic in the User Guide by clicking here.  

https://userguide.idealpos.com.au/#Pre-Ordering%20Functionality/Pre-Ordering%20Functionality.htm
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Reports 
IP-3640 – Customer Invoice Report – Email Invoice based on Invoice Number 

This function adds the ability to email Customer Invoices by entering an Invoice Number range into the Customer 
Invoices report, then press the Email button. Any Customer Invoices within the entered Invoice Number range will 
be emailed to Customers who have their email address entered in their Customer record. 
 
In previous builds of Idealpos, entering an Invoice range then pressing the Email button would result in an “Invoice 
Ranges not supported with Emailing”. This functionality is now supported from Idealpos 7.1 Build 13 and onwards. 
 
Before using this function, the following conditions must be met: 
 

• Valid Email Settings configured in Setup > Global Options > Other Options > Email Settings 
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• Customers that have Accounts need to have an email address entered in their Customer Record (File > 
Customers > Select the Account Customer > Modify > Ensure that an Email Address has been entered into 
the Email field located under the Contact Details section) 
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Go to: Back Office > Reports > Customers > Customer Invoices 
Select the required report selection criteria. 
Note that if you have any Account Customers that don’t have an email address and have invoices in the entered 
Invoice range, they will not receive their Invoice. However, you can enable the checkbox “Print if no Email Address” 
which will trigger Idealpos to print Invoices for Customers who do not have an email address. 
Finally, ensure that you enter an Invoice Range into the Invoice and to fields, then press the “Email” button as 
shown in the below example: 
 

 
 
After pressing the “Email” button on the bottom-left corner of the window, an “Are you sure you wish to proceed?” 
prompt will be displayed. Press “Yes” to continue with the email operation. 
Ensure that you are certain you want to continue, as this operation will result in all customers who have invoices in 
the entered range being emailed a copy of their Invoices. 
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Each Customer will receive an email containing an attachment with a filename of "Customer Invoice Customer 
x.pdf" (where x is the Customer's Code in Idealpos). This attachment will include all their invoices that were 
included in the Invoice Range entered when emailing the report in the previous step. 
It should be noted that when tendering a sale  
The below is an example of what the Customer Invoice will look like when the Customer opens their PDF 
attachment. If there is more than one Invoice included in the PDF attachment, each Invoice will appear on a 
separate page in the PDF file. 
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IP-3680 – Pending Sales Report – Filter by Customer Type 

This function has been implemented as part of a wider Pre-Ordering function which enables customers to pre-order 
their items with a deposit, then come back at a later date, pickup the order and pay the outstanding balance. 
A complete list of new features that have been implemented which allow this function to be utilised are listed 
below: 
 

• IP-3677 – Yes/No Option – New Bar Tab Customers default to Allow Prepaid 
• IP-3678 – Customer Type – Bar Tab Descriptor tag in User-Defined Text 
• IP-3680 – Pending Sales Report – Filter by Customer Type 
• IP-3681 – Customer Type – Option to Ask for Expected Date on Bar Tabs 
• IP-3686 – Yes/No Option – Pre-paid Bar Tabs recall Bar Tab if no Prepayment has been done 

 
If you’d like to follow an end-to-end list of steps to configure and use this Pre-Ordering function in the User Guide, 
click here. 
Otherwise, please continue below for details about this change (Pending Sales Report – Filter by Customer Type): 
 
  

https://userguide.idealpos.com.au/#Pre-Ordering%20Functionality/Pre-Ordering%20Functionality.htm
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This function introduces additional options to the Pending Sales Report which are outlined as follows: 
• Group by Status: Enabling this option will group the orders in the Pending Sales Report based on status 

(e.g. Takeaway, Delivery, Pickup, Cater, etc.). The Sale Type Status is selected at the time the Pending Sale is 
saved and the Sale Type Statuses can be configured via Setup > Global Options > Sales > Sale Type Status. 

• Customer Type: This field enables the selection of the required Customer Types to include in the report. It 
is possible to select one or more Customer Types. To select multiple Customer Types, press the “>” button, 
select the Customer Type, press “OK”, then repeat the process until the required Customer Types have 
been selected. Alternatively, you can manually enter the Customer Type codes separated by commas. 

• Quantity Totals only: When the report is run with this option enabled, the report will simply show a list of 
Stock Items and the quantities ordered and will be grouped by either the Order Date or Status (depending 
on the Group by selection made when running the report). This enables you to quickly gather a list of Items 
and their quantities that are required for the selected date range without displaying further details such as 
Customer Names, Amounts Owing, Clerk Names, etc. 

 
To use this function, go to: Reports > Sales > Pending Sales 
The new options are shown in the below example: 
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An example of running the report with the Group by Status option enabled is shown below: 
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An example of running the report with the Customer Type option populated is shown below: 
 

 
 
The selected Customer Type is listed at the top of the report below the Report Heading/Date Range: 
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An example of running the report with the Quantity Totals only option enabled is shown below: 
 

 
 
Quantity Totals only will simply show a list of Items and the quantity that has been saved in Pending Sales: 
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Restaurant and Table Map 
IP-1756 – Table Map – Support for more than 10 Map Selection Buttons 

This functionality has increased the previous limit of 10 Map Selection Buttons up to a new maximum of 20 Map 
Selection Buttons. Previous to this change, a maximum of 10 Table Map Selection Buttons would appear, regardless 
of how many Table Maps had been created in the system. 
 
To configure and use this function, go to: Setup > Restaurant > Table Maps 
New Table Maps can be created by pressing the “Add” button on the bottom-right corner of the Table Maps 
window. You may now create up to 20 Table Maps and a button for each Table Map will appear at the bottom of the 
Table Map screen. 
The below example shows 20 Table Maps displayed on the Table Maps window. 
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Once you have created a maximum of 20 Table Maps, close the Table Map windows. 
Go to the POS Screen > Table Map. 
On the bottom-right corner of the Table Map window, press the “>>>” button to show a list of Table Maps. 
 

 
 
Each of the Table Maps are represented by a button at the bottom of the Table Maps window, with a maximum of 
20 Table Map Selection Buttons: 
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IP-2781 – Table Map Setup – Option to set format defaults for new Tables 

This function introduces the ability to set the default format that will be used when creating new tables within the 
Table Map as well as the ability to reset the defaults, should you wish to revert back to the original format.  
The default format used for the creation of new tables includes the default Table Size, default Table Shape, default 
Font Style/Size and default number of Covers. Previous to this change, it was only possible to configure the 
formatting of a table after it was created. With this change, you can now configure a default table style using your 
personal preferences, then anytime a new table is created in the Table Map, it will be created using the defaults 
that have been configured. 
 
To configure and use this function, go to: 
Setup > Restaurant > Table Maps 
From the list of Table Maps, select Table Map you want to modify and press the “Modify” button on the bottom-
right corner of the window. 
To setup a new default table format, you can choose one of three options which are outlined below. The option 
chosen will depend on whether you already have an existing table with the desired formatting to use as the default, 
or whether you want to create a new table, customise it as desired then set its formatting as the default:  
 

• Option 1 - Create a new table and customise the table as desired (set the Table Size, Table Shape, Font 
Style/Size and the Number of Covers), then right-click on the table and select “Make Default”.  
Any new tables created from this point on will use the same formatting as the newly created table. 

• Option 2 - Customise an existing table (set the Table Size, Table Shape, Font Style/Size and the Number of 
Covers), then right-click on the table and select “Make Default”. Any new tables created from this point on 
will use the same formatting as the existing table which you’ve just customised. 

• Option 3 - Right-click on an existing table that has previously been customised, then “Make Default”.  
Any new tables created from this point on will use the same formatting as the existing table. 
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To create a new table, ensure that “Tables” is selected, then press anywhere on the Table Map that doesn’t already 
contain a Table and a new Table will be created. 
 

 
 
A new table will appear in the area of the Table Map that was pressed 
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The table can then be customised as required by following the steps outlined below: 
 
To change the Table Shape, ensure the table is selected, then press the “Toggle Shape” button at the bottom of the 
Map Modify window. 
 

   
 
The Table Shape will change each time the shape button is pressed. There are three different types of shapes 
available (square, circle and diamond) as shown in the below example. 
 

 
 
The Table Size can also be modified by right-clicking on the shape and selecting “Size” (this will allow you to move 
the mouse cursor and see the table size change dynamically, then once the table is the desired size, press the 
mouse button again).  
Image 1 – Right-click the table and select “Size”. 
Image 2 – The table resizes dynamically as you move the mouse cursor. 
Image 3 – Clicking the mouse button will apply the size and the table will be selected with a yellow border 
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The Table Size can also be modified by pressing the “Change Size” option at the bottom of the Table Map, then 
using the on-screen arrow buttons to alter the size. 
Image 1 – Ensure the table is selected. 
Image 2 – Select the “Change Size” option at the bottom of the table map and use the on-screen arrows to change 
the table size 
 

  
 
The left/right arrows will decrease/increase the width of the table. 
The up/down arrows will decrease/increase the height of the table. 
 

The Font (Font Type, Font Style and Font Size) can be modified by right-clicking on the Table and selecting “Font”. 
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Select the desired Font, Font Style and Size, then press “OK”. 
 

 
 
The Font displayed on the Table is now updated. 
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Finally, you can also select the number of Covers for the Table.  
The number of Covers selected will also be included in the default. 
Right-click on the Table, select “Covers”, then click on the number of covers you want to set. 
 

 
 
Now that the table has been customised, this table’s customisation can be set as the default. 
Right-click on the table and select “Make Default”. 
 

 
 
From this point on, any new tables that are created on the Table Map will use the defaults that have been set in the 
above steps (in the below example, tables 87, 88 and 89 have been created using the new default). 
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Should you wish to reset the defaults back to the original settings, right-click on any table on the Table Map and 
select the “Reset Defaults” option. 
 

 
 
A “Defaults Reset” prompt will appear, and the original defaults will be used when creating any new tables from 
this point forward. Note that pressing “Reset Defaults” will not affect the customisation or formatting of any 
existing tables. The original defaults will only be used for the creation of new tables. 
 

 
 
The below example shows the creation of two additional tables (90 and 91) after the defaults were reset. 
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Room Interface 
IP-3616 – Newbook Interface – Tax Amount field 

This function adds the Tax Amount field to the Newbook Interface data export included in the Charges.dat file. 
This ensures that Tax amounts are sent through to the Newbook Interface. 
There is no additional configured required to enable the Tax Amount field. 
Having the Tax Rates/amounts configured in your Stock Items is sufficient for the tax values to be exported to the 
Charges.dat. 
 
Tax Rates/Descriptions are configured in Global Options (Setup > Global Options > Sales > Tax Rates) 
The Room Interface is configured in Setup > Global Options > Interfaces > Rooms 
Stock Item Taxes are configured in the individual Item (File > Stock Control > Stock Items > Select Stock Item > 
Modify > Tax Settings (Selling)) 
 
The below example shows the Journal and the resulting content of the CHARGES.DAT file: 
 
Journal shown in Journal Enquiry (Enquiry > Journal History): 
 

 
 
Note the LATTE is tax free, the CHAI has tax 1 and the SHORT BLACK has tax 1 and 2. 
Also note that the second-last field is only 1 if it is tax-free, the last field is the total tax for that department. 
 
This is the resulting CHARGES.DAT file: 
 
CHARGE,0,CASH SALE,TEA,,1,4.00,1,21/10/20 12:07:27,0,0.20 
CHARGE,0,CASH SALE,COFFEE,,1,3.00,1,21/10/20 12:07:27,0,0.36 
CHARGE,0,CASH SALE,COFFEE,,1,3.50,1,21/10/20 12:07:27,1,0 
PAY,0,CASH SALE,CASH,,1,5.00,1,21/10/20 12:07:27,1,0 
PAY,0,CASH SALE,EFTPOS,,1,6.06,1,21/10/20 12:07:27,1,0 
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IP-3617 – eCommerce Orders – Support for Newbook/GuestCentrix/GuestPoint 

This function adds support for posting sales to Newbook/Guestcentrix/Guestpoint that have been paid for using an 
eCommerce interface such as Mr Yum, Shopify, etc. 
To use this function, you will require the following: 

• An eCommerce Integration such as Shopify, Mr Yum 
• Room Interface enabled and configured (either Newbook, GuestCentrix or GuestPoint) 

 
The steps in the Update History document for using this function only outline the basics due the complexity in 
setting this up in addition to the requirement of already having specific interfaces enabled and configured. 
It is assumed that your system is already configured using one of the available eCommerce Interfaces as well as one 
of the Room Interfaces outlined above. 
 
To configure and use this function, go to: Setup > Global Options > Interfaces > Room Interface 
Ensure that “Post Paid Transactions” is enabled for your Room Interface. 
The below examples show the GuestPoint and Newbook Interfaces with the “Post Paid Transactions” option 
enabled. Note that when enabling the Post Paid Transactions option, other options in your system will already be 
configured and should not be modified unless necessary. 
It is also assumed that you understand the repercussions of enabling this option for your Room Interface. 
If unsure, please consult with your Room Interface provider on whether this will affect your Room Interface. 
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Once the “Post Paid Transactions” option is enabled, any eCommerce orders which are received and processed by 
Idealpos will be written to the CHARGES.DAT file in your Network Path location configured above. 
 
This function supports Pre-Paid Web Orders which have been automatically finalised, Pre-Paid Web Orders which 
are manually finalised as well as Web Orders that are paid for in-store. 
  
Once the eCommerce order has been finalised in Idealpos, the transaction data is exported to the Room Interface 
in the CHARGES.DAT file as per the example shown below. 
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Stock Items 
IP-750 – Stock Item Availability option 

This function adds the ability to control whether a Stock Item is available for sale based on the setting that has 
been selected in the Availability dropdown box. When an Item is available, it can be sold from the POS Screen by 
either pressing the Stock Item’s button on the POS Screen or scanning the Item Barcode/manually entering the 
Stock Code/Barcode. When the Item is unavailable, the Stock Item’s POS Screen button will appear with a red “X” 
through it. An unavailable Item cannot be sold by scanning the Item Barcode/manually or entering the Stock 
Code/Barcode. Attempting to sell an unavailable Item from the POS Screen will result in a prompt being displayed 
“This item is unavailable and cannot be sold”. Attempting to sell a quantity higher than the currently available Stock 
Level via the “X” quantity function will result in a prompt being displayed “You have entered a Quantity that would 
sell the item below Zero”. 
Note that using “Unavailable when Alert Level reaches Zero” can impact POS performance if the option is applied to 
numerous items on the POS Screen. 
 
The options that can be used to control an Item’s availability are outlined as follows: 
 

• Always Available – The item can always be sold, regardless of whether or not the Stock Level and/or Alert 
Level is positive. 

• Unavailable – The item cannot be sold. This option may be useful if you have particular Stock Items that 
don’t have Stock Control enabled/Stock Levels aren’t maintained, however, you know that these items are 
currently unavailable and want to stop them from being sold. Once they become available, you can 
manually change their Availability setting back to “Available”. 

• Unavailable when Stock Level reaches Zero – The Item can be sold provided that the Stock Level is above 
zero. Once the Stock Level reaches zero, the Item will become Unavailable and can’t be sold from the POS 
Screen until the Stock Level is either manually incremented or a Stock Purchase has been processed 
containing the item to increment the Stock Level, making it available. 

• Unavailable when Alert Level reaches Zero – The Item can be sold provided that the Alert Level is above 
zero. Once the Stock Item’s Alert Level reaches zero, it can no longer be sold (until the Alert Level is 
manually incremented, or until the Availability option is changed to Always Available). 

 
Some of the Availability options are only applicable to specific types of Items as outlined below:  
 

• Unavailable when Stock Level reaches zero – Only applicable to Stock Items which have Stock Control 
enabled. This option does not support Indirect items. If you want to control the availability of Indirect 
Items, we recommend setting up Alert Levels for the Stock Item and using the Availability option 
“Unavailable when Alert Level reaches Zero”. 

• Unavailable when Alert Level reaches Zero – Item only becomes available once an Alert Level has been 
configured for the Stock Item and the Alert Level is greater than 0. 
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To configure and use this function, go to: 
Back Office > File > Stock Control > Stock Items 
Either Double-Click on a Stock Item, or select it and press “Modify” on the bottom-right corner. 
 
To use the Availability option “Unavailable when Stock Level reaches Zero”, the “Stock Control” option must be 
enabled as shown in the below example:  
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Go to the “Advanced” tab, then from the Availability dropdown box, select the required Availability option. 
The below example shows all options that are available: 
 

  
 
For this example, we have selected the option “Unavailable when Stock Level reaches Zero”. 
The Stock Level will be used to control the Stock Item’s availability as shown in the below example. 
Once configured, press the “Save” button on the bottom-right corner of the window. 
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The Availability option applies to the Stock Item whether it is sold by scanning the barcode/Stock Code, manually 
entering the Barcode/Stock Code, or sold by pressing the Stock Item button on the POS Screen.  
Go to the POS Screen and navigate to the POS Screen Tab where the Stock Item’s button is located. 
While the Stock Level for the Stock Item is not zero, the POS Screen button for the Stock Item will be displayed 
using the button colour and formatting that was configured when the button was created. 
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Once the Stock Item’s quantity reaches zero, the button will change and will show a red X, indicating that the item 
is no longer available.  
Please note that any items which have been saved to a Pending Sale are deducted from the available Stock Level  
(when using “Unavailable when Stock Level reaches Zero”). 
E.g. If you have 5x Stick Blenders in stock and you save 1x Stick Blender in a Pending Sale, the Availability function 
will only allow you to sell 4x Stick Blenders. After 4x Stick Blenders are sold, the button will become unavailable. 
When the Pending Sale is recalled, the item will be recalled to the POS Screen. 
 

 
 
Attempting to sell the Item once the Stock Level has reached zero will result in the following prompt appearing on 
the POS screen: 
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Idealpos will also prevent the Clerk from selling more than the available Stock Level via the “X” function (select the 
Stock Item in the sale, press the “X” button on the POS Screen and attempt to enter a quantity higher than the 
available Stock Level):  
 

 
 
After entering a quantity that is higher than the available Stock Level and pressing OK, the below prompt will be 
displayed: 
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Should you want to sell an item that is Unavailable, the UNLOCK PERMISSION function can be used to override the 
Unavailable restriction. Please refer to the Unlock Permissions topic in the User Guide for further details on how to 
configure and use this function. 
 
To use the Unlock Permission function to override an Unavailable Item, either press the Unlock Permission button, 
or swipe your Admin Card. 
Idealpos will display a prompt to indicate that the Clerk Permissions have now been UNLOCKED: 
 

  
 
The top-right corner of the POS Screen will also display “UNLOCKED”: 
 

 
 
  

https://userguide.idealpos.com.au/#Unlock%20Permissions/Unlock%20Permissions.htm
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When the Unlocked text appears, you can now sell the Unavailable Item by either pressing the Item’s POS Screen 
Button, or you can either scan/enter the Stock Item Code/Barcode: 
 

 
 
The Item is added to the sale: 
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Should you wish to lock the permissions again to prevent access to any restricted functions and prevent the sale of 
other Unavailable Items, the “UNLOCKED” button on the top-right corner of the POS Screen can be pressed. 
Idealpos will then display “Clerk Permissions have now been LOCKED” as shown in the below example: 
 

 
 
To set an item as Unavailable when Alert Level reaches Zero, enable this setting in a Stock Item’s Advanced Tab. 
This option can be used with any item, however, it is the only way to count the availability of Indirect Items, as these 
types of Items cannot use the option “Unavailable when Stock Level reaches Zero”.  
 
Go to: Back Office > File > Stock Control > Stock Items 
Select an Indirect Item such as Cappuccino and either double click on the item or press the “Modify” button on the 
bottom-right corner of the window. 
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Set the Availability to “Unavailable when Alert Level reaches Zero”, then press the “Save” button on the bottom-
right corner of the window. 
 

 
 
Note that attempting to save an Indirect Item with an Availability option of “Unavailable when Stock Level reaches 
Zero” will produce the following prompt, preventing this availability option from being selected. 
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Once the Alert Levels Availability option has been set within the Stock Item, close the Stock Item windows and 
configure the Stock Item Alert Levels for the Item. 
 
Go to: Back Office > File > Sales > Stock Item Alert Levels 
Press the “Add” button on the bottom-right corner of the Alert Levels window. 
In the Stock Code field, press the “>” button to open the Stock Item Search screen, then add the same Item which 
the Availability setting was configured in the previous step. 
Once the Item has been added, enter a value into the Remaining and Alert Level fields. 
Press “Save” on the bottom-right corner of the window to save the Alert Levels for the Item. 
Note that only the “Remaining” field is used for the purpose of counting the number of available items using the 
Availability function. Once the value remaining reaches the value entered into the Alert Level field, a prompt will be 
displayed warning the Clerk. Once the Alert level has been reached, a prompt will appear each time the item is sold 
until the remaining level reaches zero.  
Once the remaining quantity reaches Zero, the item will become unavailable and cannot be sold. 
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Close the Alert Level windows, then open the POS Screen. 
The POS Screen buttons for the Cappuccino item show an Alert Level counter on the bottom-right corner as shown 
below. 
 

 
 
The Item can be added to a sale until the remaining level reaches zero. Once this occurs, the button appearance will 
change and will appear as per the below example: 
 

 
 
Attempting to sell the item by pressing the Stock Item’s button or entering the Stock Item Code will display the 
following prompt: 
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As shown in the example further above for Unavailable when Stock Level reaches Zero, the Unlock Permissions 
button can be pressed or Admin Card swiped to Unlock Permissions and sell the Unavailable item. 
 

 
 
Once Permissions have been Unlocked, the text “Unlocked” will appear on the top-right corner of the POS Screen. 
 

 
 
The Item can then be sold by either pressing the button on the POS Screen, entering the Scan Code/Stock Code, or 
add the item to the sale via the Stock Item Search screen. 
 

 
 
The Alert Level shown on the Stock Item’s POS Screen button will go into negative, and if the Item’s POS Screen 
button is pressed, an Alert prompt will be displayed. 
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Stock Purchases 
IP-3688 – Stock Purchasing Stock Item Search opens in Single Item Mode with Multi Mode option 

In the previous build of Idealpos, the Stock Purchasing Stock Item Search screen was updated to open in Multi-
Select Mode to allow the selection of more than one item at a time. However, this also removed the ability to 
access specific buttons that are only available on the Stock Item Search - Single Item select mode screen. 
This change restores the Stock Purchasing Stock Item Search screen as the default view, with the ability to press a 
Multi-Mode option on the top-right corner of the screen to access the multi-select functions. 
By having the ability to use either Multi-Select or Single-Mode screens, access to functions that were traditionally 
available have been restored, whilst also enabling the ability to use the Multi-Select functionality if required. 
 
There is no configuration required to use this function. An additional button has simply been instated which can be 
used to open the Multi-Select mode if required. 
To use this function, go to: Back Office > Transactions > Stock Control > Stock Purchases 
Either select an existing Purchase Order, or press the “Add” button on the bottom-left corner of the window to 
create a new Purchase Order. 
Then within the Stock Received/Purchase Order window, click into the Stock Code dropdown box to open the Stock 
Item Search screen: 
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The Single-Mode Search Item screen opens by default which includes access to specific functions that are 
unavailable on the Multi-Select screen. The Single-Mode functions are displayed on the bottom-right corner of the 
Stock Items Search screen as shown in the example below. The Multi-Select button is shown on the top-right corner 
of the Stock Items Search screen which when pressed, will display the Multi-Select Stock Items search screen. 
 

 
 
After pressing the Multi-Select button shown in the example above, the Multi-Select Stock Items Search screen will 
appear as shown in the example below. The Multi-Select screen enables the ability to select more than one item at 
a time to add to the Purchase Order/Stock Receive. Press and hold down the CTRL button and click on multiple 
items to select them all at once. You can also select an item, hold down shift, then select another item further 
below to select the entire block of items between the first item and last item. Finally, you can also filter the Stock 
Items Search screen by entering value(s) into the search fields at the top, then press the “Select All” button at the 
bottom to select all items that match the search criteria. Once the required items have all been selected, press the 
“OK” button on the bottom-right corner of the search window to add them to the Purchase Order/Stock Receive. 
 

  



 Update History 
Return to top 

Idealpos 7.1 Build 13 - Update History Page 82 of 109 

 

Yes/No Options  
IP-3656 – Yes/No Option – Pending Sale Address recorded as Text in Journal 

This function adds the ability to control whether the Pending Sale Address will be copied into the Transaction 
Journal when the Pending Sale is finalised. 
This function may be utilised when you require the ability to view the Customer’s address in the Journal History 
enquiry; particularly useful in environments where you are delivering or shipping orders to a Customer’s address. 
This setting applies to both Pending Sales and eCommerce Orders.  
Note that this setting must be enabled prior to saving and recalling a Pending Sale. Enabling this option will not 
populate the Pending Sale Address into existing Journals that have already been completed. 
 
To configure and use this function, go to: Setup > Yes/No Options > Enter Keyword Search: Pending Sale 
Enable Yes/No Option “Pending Sale Address recorded as Text in Journal” 
 

 
 
Close the Yes/No Options, then restart the Idealpos suite to ensure changes have applied. 
Go to: Start > Idealpos > IPSUtils > Close IPS Utility > Close 
 

 
 
  



 Update History 
Return to top 

Idealpos 7.1 Build 13 - Update History Page 83 of 109 

 

Start Idealpos by double-clicking the Idealpos desktop shortcut, or go to: Start > Idealpos > Idealpos 
From the POS Screen, add items to a sale, then press the “PENDING” button: 
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In the Save Pending Sale window, enter the Customer’s Name, Address and Order Date/Time, then press the “Save” 
button on the bottom-right corner to save the Pending Sale: 
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Once the Pending Sale has been saved, press the “PENDING” button and select the Pending Sale from the list, then 
press the “OK” button on the bottom-right corner of the window to recall the sale to the POS Screen: 
 

  
 
The Pending Sale is recalled to the POS Screen: 
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Press the ENTER button on the POS Screen and tender the sale using the required Tender type. 
In the below example, we will tender with CASH: 
 

 
 
  



 Update History 
Return to top 

Idealpos 7.1 Build 13 - Update History Page 87 of 109 

 

Close the POS Screen, then from the Back Office, go to: Enquiry > Journal History 
Select the finalised transaction from the left-hand side of the Journal History Enquiry window. 
The right-hand side of the window will display the Journal details, including the Customer’s address that was 
entered when the Pending Sale was initially saved. The Customer’s name and address will appear at the top of the 
Journal as shown in the example below: 
 

 
 
When the Yes/No option is disabled, the Customer’s name and address does not appear at the top of the Journal as 
shown in the example below: 
 

 
 
It should also be noted that the Customer’s name and address will not print on the Customer’s receipt if the Yes/No 
Option “Print Text on Bills/Receipts” is disabled. If “Print Text on Bills/Receipts” is enabled, then the Customer’s 
receipt will contain the Customer’s name and address.  
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IP-3677 – Yes/No Option – New Bar Tab Customers default to Allow Prepaid 

This function has been implemented as part of a wider Pre-Ordering function which enables customers to pre-order 
their items with a deposit, then come back at a later date, pickup the order and pay the outstanding balance. 
A complete list of new features that have been implemented which allow this function to be utilised are listed 
below: 
 

• IP-3677 – Yes/No Option – New Bar Tab Customers default to Allow Prepaid 
• IP-3678 – Customer Type – Bar Tab Descriptor tag in User-Defined Text 
• IP-3680 – Pending Sales Report – Filter by Customer Type 
• IP-3681 – Customer Type – Option to Ask for Expected Date on Bar Tabs 
• IP-3686 – Yes/No Option – Pre-paid Bar Tabs recall Bar Tab if no Prepayment has been done 

 
If you’d like to follow an end-to-end list of steps to configure and use this Pre-Ordering function in the User Guide, 
click here. 
Otherwise, please continue below for details about this change (Yes/No Option – New Bar Tab Customers default 
to Allow Prepaid): 
 
This option causes new customers that are set to work as Bar Tabs to also set the Allow Prepaid option by default. 
This can be utilised as part of the Pre-Ordering functionality described above, or alternatively, this functionality can 
also be used in any scenario which requires new Bar Tab Customers to have the ability to pre-pay their Bar Tab. 
When this option is enabled, any new Customers that are created and assigned to a Customer Type which has the 
“New Customers Default to Bar Tab” enabled will also have the “Allow Pre-Paid” option automatically ticked on 
their Customer record. 
This is option applies when the Customer is created either via the Back Office Customers screen (File > Customers > 
Customers > Add), or via the New Customer button on the POS Screen. 
 
Before configuring and using this function, it is assumed that your system has already been configured and ready-
to-use with Pre-Paid Bar Tabs. For further details about configuring and using Pre-Paid Bar Tabs, please visit the 
Pre-Paid Bar Tab topic in the Idealpos User Guide. 
 
 
To configure and use this function, go to: 
Setup > Yes/No Options > Enter Keyword Search: prepaid 
Enable Yes/No Option “New Bar Tab Customers default to Allow Prepaid” 
 

 
 
Close the Yes/No options window. 
  

https://userguide.idealpos.com.au/#Pre-Ordering%20Functionality/Pre-Ordering%20Functionality.htm
https://userguide.idealpos.com.au/#Bar%20Tabs/Pre%20Paid%20Bar%20Tabs.htm
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Then ensure that you have a Bar Tab Customer Type by going to: File > Customers > Customer Types. 
Identify the Customer Type(s) which you are using for Bar Tabs. 
If a Bar Tab Customer Type does not exist, press the “Add” button on the bottom-right corner of the Customer 
Types window. 
Whether you are creating a new Customer Type or modifying an existing Bar Tab Customer Type, ensure that the 
“New Customers Default to Bar Tab” are enabled.  
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Close the Customer Type windows, then either go to:  
POS Screen > Customer > New Customer 
Enter Customer details and select the Bar Tab Customer Type > OK 
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Once created, you can confirm that the Allow Pre-Paid option is enabled by closing the POS Screen and going to: 
File > Customers > Customers > Search for and open the newly created Customer.  
“Allow Pre-Paid” is enabled: 
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The Allow Pre-Paid option is also enabled when creating a Customer via the Back Office Customers screen. 
Go to: File > Customers > Customers > Add > Select Bar Tabs Customer Type. 
The Bar Tab option is automatically enabled (New Customers Default to Bar Tab enabled for this Customer Type) 
and the Allow Pre-Paid option is also enabled (Yes/No Option New Bar Tab Customers default to Allow Prepaid). 
 

 
 
When a Customer in the system has the Pre-Paid option enabled, they will be able to Pre-Pay a Bar Tab. 
For detailed steps outlining the use of Pre-Paid Bar Tabs, refer to the Pre-Paid Bar Tabs topic in the User Guide.  

https://userguide.idealpos.com.au/Default.htm#Bar%20Tabs/Pre%20Paid%20Bar%20Tabs.htm
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IP-3679 – Yes/No Option – Pre-paid Bar Tabs recall Bar Tab after Prepayment 

This function enables the ability to have a Pre-Paid Bar Tab recalled to the sale screen after a pre-payment has been 
applied to the Bar Tab. This function may be useful in bar environments where it is a policy that the customer must 
Pre-Pay their Bar Tab before they can save items to their Bar Tab. By enabling this option, you will first add the Bar 
Tab to the sale, then immediately afterwards, enter an amount to pre-pay and press the Account Payment button.  
After the payment is taken, the Bar Tab will be immediately recalled to the sale screen, ready for the customer of 
the Bar Tab to save their first items to their tab. 

 

Before configuring and using this function, it is assumed that your system has already been configured and ready-
to-use with Pre-Paid Bar Tabs. For further details about configuring and using Pre-Paid Bar Tabs, please visit the 
Pre-Paid Bar Tab topic in the Idealpos User Guide. 
 
To configure and use this function, go to: Setup > Yes/No Options 
Enter Keyword Search: “pre-paid bar” 
Enable Yes/No Option “Pre-paid Bar Tabs recall Bar Tab after Prepayment” 
 

 
 
  

https://userguide.idealpos.com.au/#Bar%20Tabs/Pre%20Paid%20Bar%20Tabs.htm
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Close the Yes/No options window. 
Ensure that you have a Pre-Paid Bar Tab Customer in your system. 
Go to: File > Customers > Customers 
Enable “Include Bar Tabs” on the bottom-left corner of the window. 
A list of Bar Tab Customers will be included in your list of Customers. 
Select a Bar Tab Customer from the list and press “Modify” on the bottom-right corner of the window. 
Alternatively, you can create a new Customer. 
While modifying or creating the Customer, ensure that the “Allow Pre-Paid” checkbox is enabled. 
The “Allow Pre-Paid” checkbox will only be displayed when the “Bar Tab” checkbox is also enabled. 
Also ensure that a Credit Limit has been entered for the purpose of demonstrating and using this function. 
Press the “Save” button on the bottom-right corner once you have finished creating or modifying the customer. 
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Open the POS Screen by pressing the “POS” button on the top-left corner of the Back-Office Dashboard. 
Press the “Bar Tab” button and then select the newly created or modified Bar Tab Customer (which has the Bar Tab 
and Pre-Paid options enabled). 
 

 
 
The Pre-Paid Bar Tab Customer is added to the Sale. 
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Enter any amount then press the “Account Layby Payment” button. 
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Select a Tender method 
 

 
 
The tender screen is cleared and the Bar Tab is then recalled to the POS Screen (as per the enabled Yes/No option 
“Pre-paid Bar Tabs recall Bar Tab after Prepayment”), ready for adding items to the tab: 
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IP-3686 – Yes/No Option – Pre-paid Bar Tabs recall Bar Tab if no Prepayment has been done 

This function has been implemented as part of a wider Pre-Ordering function which enables customers to pre-order 
their items with a deposit, then come back at a later date, pickup the order and pay the outstanding balance. 
A complete list of new features that have been implemented which allow this function to be utilised are listed 
below: 
 

• IP-3677 – Yes/No Option – New Bar Tab Customers default to Allow Prepaid 
• IP-3678 – Customer Type – Bar Tab Descriptor tag in User-Defined Text 
• IP-3680 – Pending Sales Report – Filter by Customer Type 
• IP-3681 – Customer Type – Option to Ask for Expected Date on Bar Tabs 
• IP-3686 – Yes/No Option – Pre-paid Bar Tabs recall Bar Tab if no Prepayment has been done 

 
If you’d like to follow an end-to-end list of steps to configure and use this Pre-Ordering function in the User Guide, 
click here. 
Otherwise, please continue below for details about this change (Yes/No Option – Pre-paid Bar Tabs recall Bar Tab if 
no Prepayment has been done): 
 
If a Pre-paid bar tab transaction has been finalised and the Prepayment has not taken place, then the Bar Tab will 
be brought back for the next transaction when this option is enabled. This can be utilised as part of the Pre-
Ordering functionality described above, or alternatively, this functionality can also be used in any scenario where 
you require customers who have not placed a prepayment on their Pre-Paid Bar Tab to make a payment 
immediately after the Pre-Paid Bar Tab is finalised. 
 
Before configuring and using this function, it is assumed that your system has already been configured and ready-
to-use with Pre-Paid Bar Tabs. For further details about configuring and using Pre-Paid Bar Tabs, please visit the 
Pre-Paid Bar Tab topic in the Idealpos User Guide. 
 
To configure and use this function, go to: Setup > Yes/No Options  
Enter Keyword Search: “pre-paid bar” 
Enable Yes/No Option “Pre-paid Bar Tabs recall Bar Tab if no Prepayment has been done” 
 

 
 
 
  

https://userguide.idealpos.com.au/#Pre-Ordering%20Functionality/Pre-Ordering%20Functionality.htm
https://userguide.idealpos.com.au/#Bar%20Tabs/Pre%20Paid%20Bar%20Tabs.htm
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Close the Yes/No options window. 
Ensure that you have a Pre-Paid Bar Tab Customer in your system. 
Go to: File > Customers > Customers 
Enable “Include Bar Tabs” on the bottom-left corner of the window. 
A list of Bar Tab Customers will be included in your list of Customers. 
Select a Bar Tab Customer from the list and press “Modify” on the bottom-right corner of the window. 
Alternatively, you can create a new Customer. 
While modifying or creating the Customer, ensure that the “Allow Pre-Paid” checkbox is enabled. 
The “Allow Pre-Paid” checkbox will only be displayed when the “Bar Tab” checkbox is also enabled. 
Also ensure that a Credit Limit has been entered for the purpose of demonstrating and using this function. 
Press the “Save” button on the bottom-right corner once you have finished creating or modifying the customer. 
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Open the POS Screen by pressing the “POS” button on the top-left corner of the Back-Office Dashboard. 
Press the “Bar Tab” button and then select the newly created or modified Bar Tab Customer (which has the Bar Tab 
and Pre-Paid options enabled). 
 

 
 
The Pre-Paid Bar Tab Customer is added to the Sale. 
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Add items to the Bar Tab, then press the “ENTER” button. 
 

 
 

 
 
The Bar Tab is recalled to the POS Screen as per the Yes/No option which was enabled for this function. 
 

 
 
When the Bar Tab is recalled to the POS Screen, you have the following options: 

• Take a payment for the Bar Tab by entering an amount then pressing the “Account Payment” button (this 
option will leave all items on the Bar Tab so a full payment can be taken at a later time). 

• Pay the Bar Tab by entering an amount and pressing the “Pay Bar Tab” button (this option will finalise the 
Bar Tab sale, print a receipt and clear any items that were saved to the Bar Tab).  
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If a Pre-Payment is taken for a Pre-Paid Bar-Tab, the Bar Tab will not be recalled to the POS Screen after saving 
items to the Bar Tab. 
To take a Pre-Payment for a Bar Tab, press the “Bar Tab” button from the POS Screen and select the Bar Tab 
Customer. 
 

 
 
The Bar Tab Customer is added to the sale 
 

 
Enter any amount then press the “Account Layby Payment” button. 
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 Update History 
Return to top 

Idealpos 7.1 Build 13 - Update History Page 104 of 109 

 

Select a Tender method 
 

 
 
The sale is cleared and a blank POS screen is displayed: 
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Now that the Bar Tab has had a pre-payment applied, anytime items are saved to the Bar Tab, the bar tab will not 
be recalled. 
Press the Bar Tab button and select the Bar Tab Customer. 
The Bar Tab Customer is added to the sale and the Pre-Paid amount will appear on the bottom-left corner of the 
transaction details area. 
 

  
 
Add items to the Bar Tab then press the “ENTER” button: 
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The POS screen is cleared and a blank sale is displayed, ready to process the next sale. 
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IP-3690 – Yes/No Option – Cash Declaration auto-populates integrated Eftpos totals 

This function adds the ability to toggle whether the Cash Declaration auto-populates the integrated EFTPOS totals. 
When enabled, the EFTPOS label in the Cash Declaration screen at the End of Shift will not contain a field for the 
user to enter the EFTPOS amount as the EFTPOS value will be auto-populated.  
The auto-populated EFTPOS amount will also appear under the Actual EFTPOS amount on the Sales Report printed 
after the Cash Declaration is completed on the POS Screen. 
When this Yes/No option is disabled, a field will appear next to the EFTPOS label in the Cash Declaration screen at 
the End of Shift. The Clerk will need to manually enter the EFTPOS takings into the EFTPOS field, and this value will 
then appear under the Actual EFTPOS amount on the Sales Report printed after the Cash Declaration is completed 
on the POS Screen. It is a requirement that the Include in Banking setting in the EFTPOS function descriptor be 
enabled for this Yes/No option to be applicable. Having the Include in Banking setting disabled will result in the 
EFTPOS Counted Amount being auto-populated, regardless of how this Yes/No Option is configured. 
 
To configure and use this function, go to:  
Setup > Yes/No Options > Enter Keyword Search: integrated eft 
Toggle the Yes/No Option “Cash Declaration auto-populates Integrated Eftpos Totals 
 

 
 
Close the Yes/No options window to save the change. 
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When completing an End of Shift with the Yes/No Option enabled, the Cash Declaration will appear as follows. 
Note that there is no field next to the EFTPOS label; this is because the EFTPOS amount will be auto-populated as 
per the state of this Yes/No Option: 
 

 
 
When completing an End of Shift with the Yes/No Option disabled, the Cash Declaration will appear as follows. 
Note that there is a field next to the EFTPOS label. When the Yes/No option is disabled, you will need to manually 
enter the EFTPOS amount into the EFTPOS field. The amount entered will appear under the Actual EFTPOS amount 
on the Sales Report that is printed after pressing OK on the Cash Declaration window: 
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In addition to the above, the EFTPOS amount will appear in the EFTPOS field of the Edit Cash Declaration window. 
To edit a Cash Declaration, go to: Utilities > Edit Cash Declaration > Select the Cash Declaration from the list > Press 
Edit on the bottom-right corner of the window: 
 

 
 
It should also be noted that the ability to edit the EFTPOS Counted amount on the Edit Cash Declaration window is 
determined based on the EFTPOS Function Descriptor > Show in Banking setting. 
When Show in Banking is enabled, the Counted amount can be edited within the Edit Cash Declaration window. 
When Show in Banking is disabled, the Counted amount will appear as Read-Only in the Edit Cash Declaration 
window. As noted above, if “Include in Banking” is disabled on the EFTPOS Function Descriptor, the EFTPOS amount 
will always be auto-populated for integrated EFTPOS. 


