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Build 7 

Update Details: 

 

** Enhancements 

[IP-3156] - Tax Monitoring Interface - support for A4 Tax Invoices 

[IP-3161] - Xero API - OAuth 2.0 Integration 

[IP-3271] - Requirement of .Net Framework 4.6.1 

[IP-3283] - Tax Monitoring Interface - Auto Fiscal Status functionality 

[IP-3289] - Support For Zebra ZC300 Mag Card printer series 

[IP-3298] - New User-Defined option: Clipp pinpad surcharges are excluded from the Cash Declaration 

[IP-3303] - Konami Interface Machine Lookup - support for Site Id tags as criteria 
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Accounting Interface 

Xero API – Oauth 2.0 Integration 

This function adds the ability to connect Idealpos to Xero’s OAUTH2 API to post sales and purchase data from Idealpos 

directly into Xero. 

The existing Xero (API) integration available in Idealpos will be supported by Xero until December 2020. 

Note that all customers who are currently using the existing Xero (API) Integration are strongly encouraged to 

changeover to Xero (OAUTH2) prior to December 2020. Delaying the changeover until December 2020 will result in 

Idealpos data not posting into Xero accounting. 

Any new customers who wish to start using Xero will need to connect and configure their system using the “Xero 

(OAUTH2)” option in Idealpos which will allow them to connect to Xero now and into the future after December 2020. 

 

To configure this function, first ensure that the system has a licence for Xero. 

This can be confirmed by going to Setup > Licence Gateway and ensuring that Xero is listed for the current terminal. 

 

 
 

If Xero is not listed in the Licence Gateway, please speak to our sales team who can organise the Xero module to be 

added to your licence. After the module has been added, the licence must be reloaded by opening the Licence 

Gateway screen (Setup > Licence Gateway) and pressing the “Reload” button. 

 

To connect Idealpos to Xero, go to Setup > Global Options > Accounting > Connection 

Select “XERO (OAUTH2)” from the Accounting Package dropdown box, then press the “Get Accounts” button. 
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A popup window will appear to Log in to Xero. 

Enter the Email address and Password that you typically use to login to the Xero website, then press the “Log in” 

button. 

 

 
 

The next step may require the entry of an authentication code generated by the authenticator app. 

Open the Authenticator app on your mobile device and enter the code into the window, then press “Log in”. 
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A message will appear indicating that “Idealpos 2” wants access to User account information. 

Press the “Allow Access” button to continue. 

 

 
 

You will then be prompted to Select an organisation from the list. 
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Once the Organisation has been selected, the “Connect” button will become available. 

Press “Connect” to continue with connecting Idealpos to Xero. 

 

 
 

Once connected, the above window will close and the Global Options will be displayed. 

The selected Organisation will appear directly below the selected Accounting Package as per the below example: 
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You may then configure the Account Codes by dragging the codes from the Accounts column located on the right-

hand side to the required Account Codes on the left. 

We strongly recommend that you seek professional advice from your Accountant or Bookkeeper. Linking the 

wrong accounts in Idealpos can result in data being transferred incorrectly. 

 

 
 

Once the Accounts on the right-hand side have been dragged to the correct Account Codes on the left, close the 

Global Options window by pressing the “X” on the top-right corner. This will close the Global Options and save the 

changes. 

 

More information about using the Xero Accounting module can be found in the Xero (OAUTH2) Accounting Interface 

topic of the User Guide. Note that the main difference between the Xero API Accounting Interface and the Xero 

OAUTH2 Accounting Interface is the connection of Idealpos to Xero. Once the connection has been established by 

following the above steps, the remaining processes and procedures that were previously being followed should be the 

same. 
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Installation and Upgrade 

Requirement of .NET Framework 4.6.1 

Starting from this build of Idealpos (Idealpos 7.1 Build 7), .NET Framework 4.6.1 is a requirement for installing Idealpos. 

When installing this build of Idealpos, .NET Framework 4.6.1 will be automatically installed if not already installed on 

the system. If possible, we recommend that you install .NET Framework 4.6.1 manually before running the latest build 

install. 

Please also note that as a result of this requirement, Idealpos 7.1 Build 7 and higher cannot be installed on 

Windows Vista and Windows Server 2008. The last version/build of Idealpos that can be installed on those 

Operating Systems is Idealpos 7.1 Build 6. 

For more information about which versions of .NET Framework are compatible with which version of Windows, refer to 

Microsoft’s .NET Framework System Requirements page here –  

https://docs.microsoft.com/en-us/dotnet/framework/get-started/system-requirements  

 

  

https://docs.microsoft.com/en-us/dotnet/framework/get-started/system-requirements
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Mag Card Printing 

Support for Zebra ZC300 Mag Card Printer Series 

This function adds support for Zebra ZC300 Mag Card Printer Series. 

To configure the connection between Idealpos and the ZC300 Mag Card Printer, it is simply a matter of selecting the 

printer from the Mag Card Format, then entering the IP address of the printer into the Printer Connection field. 

Also note that .NET Framework 4.7.1 is required to use this function. 

 

To configure the ZC300 Mag Card Printer in Idealpos, go to:  

Setup > Global Options > Other Options > Mag Card Printing 

From the Mag Card Format dropdown box, select “Zebra ZC100/300 Series” 

Within the Printer Connection field, enter the Printer IP address. 

 

 
 

Once configured, close the Global Options window. 

To print Mag Cards, go to: File > Customers > Customers 

Select a Customer from the list, then press the “Mag Print” button at the bottom of the screen: 

 

 
 

Further information about the entire Mag Card printing process is available in the User Guide here –  

https://userguide.idealpos.com.au/#Customers/Mag%20Card%20Printing.htm 

 

User manuals for the Zebra ZC300 Mag Card Printer can be downloaded from the below location –  

https://www.zebra.com/us/en/support-downloads/printers/card/zc300.html  

https://userguide.idealpos.com.au/#Customers/Mag%20Card%20Printing.htm
https://www.zebra.com/us/en/support-downloads/printers/card/zc300.html
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Tax Monitoring Interface 

Auto Fiscal Status Functionality 

This function adds the ability to run the Fiscal Status and Verify PIN functions from a button on the POS Screen.  

When the button has been created, the POS Clerk can press the button at any time to run the function and check the 

Fiscal Status/verify the PIN. This also tests to ensure that the connection between the POS Terminal and SDC is still 

working successfully. 

Previous to this change, this function would run automatically in the background when each transaction was 

performed which resulted in slower transaction processing times because the POS would have to keep performing the 

check. 

As part of this change, the function no longer runs automatically after each sale and will instead only be run when the 

button on the POS screen is pressed. 

 

To configure and use this function, go to:  

Setup > POS Screen > POS Screen Setup > Select a layout > Buttons 

 

Find a suitable POS Screen tab at the bottom of the screen where you would like the “Fiscal Status & Verify PIN” 

button to be located and click on it. 

Then find a blank button within the tab to create the button.  

Configure the button as follows:  

Select the “User-Defined” option from the list of available functions, then enter “FISCALSTATUS” into the Automatic 

Text field. 

Enter the desired button caption into the Button Caption field.  The appearance can also be customised as required. 

Once the button has been configured, press “Save” to save the button: 
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Close the POS Screen Layout windows. 

Open the POS Screen, then press the FISCAL STATUS & VERIFY PIN button. 

A message will be displayed showing the Site Name and Last Invoice number along with the Verify Pin result. 

 

 
 

Press OK to close the window and return to the POS screen.  
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Tax Monitoring Interface – Support for A4 Tax Invoices 

This function adds Fiscal Receipt functionality to A4 Tax Invoices when using the Tax Monitoring Interface. 

The Tax Monitoring Interface is used by venues that are located in countries where Tax Monitoring is required by the 

Government or body that is responsible for tracking sales and tax that are collected.  

In such locations, the receipt produced by the system will be referred to as a Fiscal Receipt and will contain a QR code 

which the customer can scan to redirect them to a website which confirms that the sale was received by the 

Government or body tracking the sale. In addition, the website displayed after scanning the QR code will show the 

Location Name, Address, Total Amount, Requested By – Signed By – Counter.  

With this modification, A4 Tax Invoices produced on systems which have the Tax Monitoring Interface configured and 

enabled will have the Fiscal Invoice details included on the A4 Tax Invoice along with the QR Code. The QR code will 

allow the customer to confirm that the sale has been received and recorded by the Government or body that is 

responsible for collecting and tracking sales performed/tax collected in that region. 

 

This function can be used in the following ways: 

• Have the A4 Invoice printed automatically after each sale by enabling the Yes/No Option “Automatically Print 

A4 Invoice after each sale”. 

• Manually produce the A4 Invoice via a button on the POS Screen linked to the Tax Invoice function (this 

option can also be used after an A4 Invoice has been printed when the abovementioned Yes/No Option is 

enabled) 

 

To have the A4 Invoice print automatically after each sale, go to: Setup > Yes/No Options 

Enter Keyword Search: A4, then enable “Automatically Print A4 Invoice after each sale” 

 

 
 

Close Yes/No Options, then complete a sale. 
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After the sale has been tendered/finalised, the Invoice will automatically print to the default Windows Printer. 
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Alternatively, the Invoice can be produced manually via a “Tax Invoice” button on the POS screen. 

To do this, a Tax Invoice button will need to be created. 

Go to: Setup > POS Screen > POS Screen Setup > Select a layout > Buttons 

 

Find a suitable POS Screen tab at the bottom of the screen where you would like the Tax Invoice button to be located 

and click on it. 

Then find a blank button within the tab to create the button.  

Configure the button as follows:  

Select the “Tax Invoice” option from the list of available functions. 

The button caption and appearance can be customised. 

Once the button function has been selected and the appearance customised as required, press “Save” to save the 

button: 

 

 
 

Close the POS Screen Layout windows. 

Open the POS Screen and begin a new sale by adding items to the sale and tender the sale. 

After the sale has been tendered, navigate to the POS Screen Tab which contains the Tax Invoice button and press it. 
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After the button has been pressed, a new “Print Tax Invoice” window will appear. 

By default, the window will show the number of the last transaction. 

 

  
 

Either press the “View” button or the “Print” button, depending on what action you want to take. 

If pressing the “View” button, the invoice will be displayed on-screen and whilst viewing it, you will have the 

opportunity to print it and/or perform other actions as required. 

If pressing “Print”, the invoice will be printed to the default Windows Printer without showing an on-screen preview. 
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The below is an example of the invoice being viewed on-screen after pressing the “View” button. 
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Pressing “Print” will print the invoice to the default Windows Printer. 

 

 


