idealpos 7 Update History
Build 46

Update Details:

** Enhancements
* [IP-562] - Fast Search Customers screen colour coded for quicker identification
* [IP-699] - Handheld supports POS Screen Grid Price Level link
* [IP-1173] - Browse for Windows Folder dialog simplified
* [IP-1184] - Adding Specials into Special Price Schedule can handle Multi-Select
*[IP-1191] - Konami Gaming - option to Combine Accounts into One Total
* [IP-1198] - Yes/No Option - Table Details Hide Paid Items by Default
* [IP-1201] - Option for Shortcut Bar to use Small Font
* [IP-1210] - Backoffice Grid type screens use extra screen height if available
* [IP-1214] - Stock Item Hire Attribute Type
* [IP-1219] - Stock Item Enquiry screen - support for Custom Date option
* [IP-1254] - A4 Tax Invoice - option to Hide Paid Amount/Balance Due
* [IP-1257] - Aristocrat Ordering (Extended Player Services) - Add new members to Idealpos
* [IP-1264] - Global Option - Adult ID Age
* [IP-1292] - Generic Format added to Automatic Sales Export
* [IP-1306] - Support for Kitchen Printing with no error reporting


https://idealpos.freshdesk.com/discussions/topics/6000043974
https://idealpos.freshdesk.com/discussions/topics/24000003610
https://idealpos.freshdesk.com/discussions/topics/24000002242/page/last#post_24000007515

Back Office

Backoffice Grid type screens use extra screen height if available

This feature is now default behaviour. When you enter any screen that is a data grid to view and select, the screen will
display over the full height of the screen. This is for screens such as Departments, Suppliers, Customer Types and more.

departments
Code Drescription Sales Category "
1
101 BREAKFAST FOOoD
102 BREAKFAST MODS FOQD
103 LUMCH FOOD
104 LUMCH MODS FOOD
105 APPETISERS FOOD
106  ENTREE FOOD
107 MAIN FOOD
108 DESSERT FOOD
109 CHEESE FOOD
110 SIDES FOOD
111 PIZZAS FOOD
112 BURGERS FOOD
113 SANDWICHES FOOD
114 SALADS FOQD
115 CAKES FOQD
116 HOTBOX FOOD
17 FRUIT FOOD
118 VEGETABLES FOOD
119 SEEDS NUTS FOOD
120 FROZEM FOOD
121 MEAT & FISH FOOD
122 BREADS FOOD
123 DELI FOOD
124 DAIRY FOOD
125 CONFECTIONARY FOOD
126 BULK FOOD
127 WITH ITEMS FOQD
128 WITHOUT ITEMS FOOD
201 TEA BEVERAGE
202 COFFEE BEVERAGE
203 HOT DRINK MODS BEVERAGE
204 WATER BEVERAGE
205 SOFT DRINK BEVERAGE
206 JUICE BEVERAGE
207 MILKS BEVERAGE
208 BEER KEGS BEVERAGE
200 POTS BEVERAGE
210 SCHOOMERS BEVERAGE
211 PINTS BEVERAGE
212 JuaGs BEVERAGE
213 5INGLE BEER BEVERAGE
214 PACK BEER BEVERAGE
215 CARTOM BEER BEVERAGE
216 RTDS BEVERAGE
217 RTDS PACKS BEVERAGE
218 RTDS CARTONS BEVERAGE
219 SPIRIT BTL BEVERAGE
220 SPIRITS BEVERAGE
221 LIQUEURS BTL BEVERAGE
222 LIQUEURS BEVERAGE
223 APERITIFS BETL BEVERAGE
224 APERITIFS BEVERAGE
225 COCKTAILS BEVERAGE
226 SPARKLIMG BTL BEVERAGE
227 SPARKLING GLS BEVERAGE
228 WHITE WINE BTL BEVERAGE
229 WHITE WIME GLS BEVERAGE b
94 records

Delete
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Browse for Folder

Browse for Windows Folder dialog simplified

Instead of browsing for entire folder in a larger window, this simplified version will make it much easier to find the
location where you want to add the link. Currently this has been added into POS Terminal settings.

Go to Setup > POS Terminals > Modify > Customer Display > Image Location.

Browse For Folder )4

~ O This PC ~
B Desktop
| Documents
“ Downloads
J'ﬂ Music
= Pictures
B videos
=, Local Disk (C:)
o DVD BW Drive (G2)
- Data (H:)
o BO-ROM Drive (2]
'+ Libraries

Make Mew Folder Cancel




Customers

Fast Search Customers screen colour coded for quicker identification

All Customer Types can be configured with a unique button/Text colour that will be represented by the customers that
are displayed when Fast Customer Searching has been configured. This allows for customers to be quickly selected by
the operator when there are a lot of available customer accounts. Once any Customer Type has been given a colour
change, the Customers displayed will be sorted by Customer Type by default, then by whichever selection (Name,
Phone, Company and Code) is made on the screen.

Go to File > Customers > Customer Types > Add / Modify > Fast Customers > Back Colour / Text Colour > Save.

customer types S X

Code 2
Description MEMBERS

E Use Points System

Point Multiplication Factor 10

Auto % Discount

Auto Discount POS Range =
Price Level
Gaming Rating Grade

Auto Populate Tender Spend Limit Credit (1)

Auto Populate Tender Spend Limit Credit (2)

Macro

|:| New Customers Default to Bar Tab

Back

Colour
Fast Customers

Text

Colour

Save

customers

Charlotte Theresa

Sub Account Winters Andrews

Layby Account N . £
Talia Brown Master Accountl] Jamal Singh JRebecca Brinkle Platinum

Ashleigh
Smulders

Jeremy

(Owner) Al

Life Bjorn Hiroku
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Gaming - Konami

Konami Gaming - option to Combine Accounts into One Total

Konami use multiple points from various sources which are referred to as Standard Points and Comp Points. Standard
Points are only accumulated from gaming machines based on the dollar value entered to play the machine, whereas
Comp Points are accumulated only through POS Terminals and other devices on money spent.

Standard Points can be used on a gaming machines to Point Play, which allows the Standard points to be used as
credits on the gaming machine. You cannot use Comp Points to Point Play.

Comp Points and Standard Points can both be redeemed at the POS terminal however; Standard Points should only be
used gafter all the Comp Points value has been exhausted. The number of points available as displayed on the POS

terminal will be the accumulated total of both Standard and Comp.

Go to Setup > Global Options > Gaming > Gaming Points > Combine Accounts into one Redeemable Total.

Gaming Points
Enable  Description Code Points Per 5 Point Yalue
1 o Camp Points Camp 1 0.1
2 o Standard Points Standard 0.017
3
4
5
&
7
&
O
10
v Combine Accounts into one Redeemable Total




Global Options

Adult ID Age

A new field has been added to the General tab of Global Options to allow the date to be changed where the age can
be set. Previously this age was hard-set at 18 years, however many countries have legal drinking age as 21 and
therefore, require a different date.

Go to Setup > Global Options > General > Adult ID Age > Enter the legal adult age that is required.

Aduit 1D Age 21

The date for adults will display at the top of the sales screen on the far left if selected to display with the Yes/No
Option.

01 Sep 08:40 POS1 Adult ID: 01/09/96

Jeremy STAMNDARD
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A4 Tax Invoice - option to Hide Paid Amount/Balance Due

Some business owners only want to display the current sales total, rather than the full account payment required.

Go to Setup > Global Options > Customers > A4 Tax Invoice: Hide Paid/Balance

A4 Tax Invoice

Owerride Header

Show Amounts Ex Tax Hide Header v Hide Paid/Balance
Customer Comments Faorce Stock Codes
Show Tendering Delivery Address
Show Points Remove Scale Text
Includes GST of £0.91
Total $9.'EJ?

With the option not being ticked, the Account balance will display.

Includes GST of £1.21
Total $13.23
Paid $D.ﬂﬂ

Balance Due $13.28




Ideal Handheld

Handheld supports POS Screen Grid Price Level link

When items are sent to the Handheld, any items within a grid that are linked to a specific Price Level will be sent with
that price level.

Code 4
Description BREAKFAST MODS

(¢ Fit Grid to POS Screen
(" Floating Grid with Programmahble Size

Price Level EXTRAS j

Minimum  Maximum

Force Selection #
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Network Printers

Support for Kitchen Printing with no error reporting

This option allows for printers to be set to not print items from the POS terminal, and no errors will display to direct
the print job to a backup.

Go to Setup > Network Printers > Add > Create a printer called NOERRORS.

network printers network printer in Site 1

Printer Name MOERRORS

TyPe Epson TM-T&8 j
Connection  Fthernet j
IP Address

Port 9100

Use in Backup Printer List

Redirect Printer pane j

Keyboard Save



Go to Setup > POS Screen > POS Screen Setup > Layouts > Buttons > Function: User-Defined > Automatic Text:
KP#=NOERRORS (Where # is the Kitchen Printer you want to stop the printing on).

User-Defined

Automatic Text KP4=MNOERRORS

Button Appearance

TURN COFFEE
PRINTER OFF

Graphic

Button Caption
TURM COFFEE PRINTER OFF

Back Colour

Font

Text Colour A i | A

] Double Width
[] Double Height

Visible

=

| User-Defined

Stock Motes S
Subtotal Discount
Table

Table Summary

Tax Invaice

Tax Shift

Tender

Tender Correct
Text Entry (Hash]
Text String
Transfer Mode
Type Text

Unlock Permissions
User-Defined
Yalidation Print
Yoid

Yaoid Entire Sale
Yoid Last tem
Yoid Line

Yoid Mode

Waste Mode

X W

Kitchen Printer 4 has been linked to NOERRORS
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You will need to configure another button to turn the printer back to the standard setting.

User-Defined

| User-Defined

Stock Motes FS
Subtotal Discount

Table

Table Summary

Tax Invaice

Tax Shift

Tender

Tender Correct

Text Entry (Hash]

Text String

Automatic Text KP4=COFFEE

Button A
e Button Caption

TURN COFFEE TURN COFFEE PRINTER OM Transfer Mode
PRINTER ON Back Colour Font Type Text
! - Unlock Permissions
TextColour A =« A = User-Defined

Walidation Print
[J Double Width i 1e Void

D Double Height Woid Entire Sale
Void Last [tem
Yoid Line

Void Mode

Waste Mode
Save ncel | v

Kitchen Printer 4 has been linked to COFFEE

Graphic =

Important Note: When any Network Printer is configured to print to the NOERRORS printer, no printing will take
place to those printers, and no errors will display on the POS screen.



POS Terminals

Option for Shortcut Bar to use Small Font

This function will allow you to change the size of the font when you are using a lot of shortcuts on the Dashboard.
After changing this setting, you will need to enter then exit the POS Screen, or restart the program for the change to
take effect.

Go to Setup > POS Terminals > Modify > Miscellaneous Settings > Dashboard > Tick: Shortcut Bar Small Font.

Dashboard

Sales in Locations )

v Shortcut Bar Small Font

»

Functions

Alert Levels

Custamers

Manufacture [tem

b

Functions

Pos Screen Layouts Alert Levels

Customers

Pos Terminals Manufacture [tem

. Pos Screen Layouts
Promuotions v

Pos Terminals

Stock Items Promotions
Stock ltems
Stock Purchases Stock Purchases
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Generic Format added to Automatic Sales Export

This is simply what we currently export with the Impact Data format with an extra field on the end "Reference" - which
will be the Sales Reference if it was added to the sale. (Otherwise it will be blank).

Go to Setup > POS Terminals > Modify > Import / Export > Automatic Export Settings > Export Sales Format: Generic.

Automatic Export Settings

Export Folder =
Delete files older than 7 days

Export Stock ltems  All [tems j
Department Range
Export Daily at Or every minutes
Filename

Append Date/Time to filename
Append Site Name to filename
Append Venue ID to filename
Include Discontinued ltems

Export Sales Format Generic j

Sales From All POS Terminals j
Daily Export Time

Fields that will be exported are:
AUDIT,POS,LINE,DATE,STOCKCODE,DESCRIPTION,PRICELEVEL,QUANTITY,UNITPRICEBEFOREDISCOUNT, TOTALPRICEBE
FOREDISCOUNT, TAXLABEL, TAXAMOUNT,DISCOUNTEDPRICE,COST,SITE,LOCATION,CUSTOMERCODE,CLERK,DEPARTM
ENT,REFERENCE



Promotions

Adding Specials into Special Price Schedule can handle Multi-Select

When selecting items in the Special price Schedule, you can select multiple items at a time using Ctrl for single items,
or Shift for a block of items.

stock items Code Search
Description 2
I |

Average Last Cost STANDARD Stock Control Indirect

Description Department Standard

101001 EGGS ON TOAST EGGS ONTOAST  BREAKFAST 2.50 2.50 2.50 0
101002 BACON & EGGS BACON & EGGS BREAKFAST 3.00 3.00 3.00 10.00 4.00 No No
0 4.50 4.50 13.00 §.00 No No

101003 EGGS BENEDICT EGGS BENEDICT BREAKFAST 45
AVOCADO ONT 0

065 0.65 085 200 1.00 Ho No
102002 EXTRAEGG EXTRAEGG BREAKFAST MODS 0.23 0.23 023 1.00 0.50 Ho Na
102003 EXTRATOAST EXTRATOAST BREAKFAST MODS 0.10 0.10 010 0.50 0.50 Ho No

102006 EXTRA SALMON EXTRA SALKMON BREAKFAST MODS 1.00 1.00 1.00 3.00 1.50 No No
102007 EXTRA JAM EXTRA JAM BREAKFAST MODS 0.10 010 010 0.50 0.50 No No
102008 EXTRAMAPLE EXTRAMAPLE BREAKFAST MODS 0.50 0.50 0.50 1.00 1.00 No No

09| EXTRA CREAM

102012 WHITE WHITE BREAKFAST MODS 0.00 0.00 0.00 0.00 0.00 Ho No

102013 MULTGRAIN MULTHGRAIN BREAKFAST MODS 0.00 0.00 0.00 0.00 0.00 Ho No
102014 WHOLEMEAL WHOLEMEAL BREAKFAST MODS 0.00 0.00 0.00 0.00 0.00 Ho No
102015 GLUTEN FREE GLUTEN FREE BREAKFAST MODS 0.25 0.25 025 1.00 0.50 Ho No

You will need to edit each item added to set the special price.
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Stock Item Attributes
Stock Item Hire Attribute Type

Using this Attribute Type, you can configure stock items with attributes of hire charges in You can then set any number
of Attributes - Minute, Minutes, Hour, Hours, Days, Weeks, Months, Years. These can also have a number in front of
them i.e. "15 Minutes", "30 Minutes" etc.

When using these Stock Items, you can setup a Stop function to stop the timer, but the customer can continue to use
the Bar Tab or Pending Sale for other purchases.

Setup Attributes
Go to File > Sales > Stock Item Attributes > Add New Attribute Type > Hire (Case sensitive) > Save > Exit.

Add Attribute Type Hire

Select Hire from the Attribute Types and select Add New Hire. Add as many different Hire time functions as required.
Once you have added the Attributes exit the screen.

stock item attributes S X
Aftribute Types Attributes (9)
Container Type
Stock Item Type 1 Hour
Spirit Varietal 1 Week
Wine Varietals 12 Hours
Country of Origin 15 Minutes
Dietry 2 Days
24 Hours
30 Minutes

Add New
Attribute Type

Add New
Hire

Delete Modify

Delete Modify




Setup Stock Items

Go to File > Stock Control > Stock Items > Add > Description: Hire Item > Price: Item Price per Timed Block >

Attributes: Hire 15 Mins.

stock items

General

Advanced

Mew Item

Stock Code 806001
Description KARAOKE ROOM HIRE
Description 2 KARAOKE ROOM HIRE

Selling Prices (inc Tax)

Profit?%

STAMDARD 12,50 100.00
STAFF 0.00
EXTRAS 0.00
BOTTLESHOP 0.00
Price 5 0.00
Price 6 0.00
Price 7 0.00
Price 8 0.00
Price 9 0.00
Price 10 0.00
Price 11 0.00
OWMNERS 0.00

I:‘ Force Selling Price Entry

Cost Prices [ex Tax)

Standard Cost 0.0000
Last Cost 0.0000
Average Cost 0.0000

Department 806 > HIRE
(17) Scan Code Auto
(7
Printer Settings Purchasing
[w] Receipt Printer Purchase Category 1 > FOOD
|:| KITCHEM Default Supplier =
[7] Bar Default Supplier
|:| COFFEE Stock Code
[T 1km
[ ] zEBRA LRBELS
[] Kitchen Printer & Other Options
[] Kitchen Printer 7
[ ] Kitchen Printer & [
[ ] Kitchen Printer 9 W
[] Kitchen Printer 10 IV Non-Accumulating
[] Kitchen Printer 11 W
D Kitchen Printer 12 |:| Indirect Components go to Kitchen Printers
[] can't Buywith GIFT VOUCHER
Tax Settings (Selling) Attributes
W GsT Hire | 15Mins
[] GST-Free ~|
Mot Defined
E Mot Defined j
[] Mot Defined j
[ ] Mot Defined j

I:‘ Instruction

[] Print Red

I:‘ Web Store

[] Inhibit Discounts
[ innhibit voids

I:‘ Manufactured ltem

-+

Lol e be Lo

Code Search

208003 CEMENT MIXER

Description Description 2 Department STANDARD Attribute
06001 KARAOQKE ROOM HIRE KARAOKE ROOM HI HIRE 12.50 15 Mins
208002 POOL TABLE HIRE POOL TABLE HIRE HIRE 5.00 30 Mins

CEMENT MIXER HIRE 48.00 1 Day
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POS Screen Buttons

Create a button for each Stock Item you need. You also need to create a button using the Date function to be able to
Stop the timer if a customer finishes their hire early, but wants to continue with other purchases, such as food and

beverage.

Date

Automatic Text

Auto Days o
Auto Minutes 0

Button Appearance

STOP TIMER

tAll

Graphic

Button Caption
STOP TIMER

Back Colour Font

Text Colour A - | A

[] Double wWidth
Double Height

Save Cancel

Visible

=

|Date
Delivery Docket
Department

Dpt Sales Report
Drawer 1 Clerk
Drawer 2 Clerk
Duplicate Receipt
EAM

EFTPOS CashOut
EFTPOS Functions
EFTPOS RePrint
EFTPOS Settlement
Employee Log

End of Shift

Enter

ESC

External Application
Gift Voucher Enguiry
Hold Print

Home Screen

ltem Discount
lackpaot b

Hire Items need to be saved as a Pending Sale or Bar Tab. It's a good idea to create these buttons also.

KARAOKE

ROOM HIRE

POOL TABLE

STOP TIMER

Pay Bar Tab

Pending
Sale

HIRE

CEMENT

MIXER HIRE




Using Hire Items

Press the hire button for the item you are hiring and add any other items to the sale. As soon as the hire button is
pressed, the time is stamped onto the sale in minutes only, seconds are not recorded. Save the sale to a Pending Sale
or Bar Tab.

015ep 13:24 POS1 Adult ID: 01/09/99
Jeremy STAMDARD

Bar Tab 5001 (Bar Tab) Outstanding $0.00
KARAOKE ROOM HIRE {01 Sep 13:23} RECEIPT CLERK

PRICE LEVEL 5% ST DISC

CUSTOMER 5% ITEM
BAR TAB REFUND
PENDING = VOID SALE

0.00 "TABLE MAP VoID

Pending
Sale

KARAOKE

e STOP TIMER Pay Bar Tab

POOL TABLE
HIRE

CEMENT MIXER
HIRE

CAFE TAP BEER SPIRITS GROCERY RETAIL MANAGER

DRINKS BOTHEBEER COCKTAILS  FRUIT & VEG
RESTAURANT & RTD WINE HIRE SERVICES ADMIN

The price for a full period will be charged automatically when the item is first hired and will increment in time until the
timer is stopped.
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When the customer has returned or finished the hire service, you can stop the hire so that no further charges will take
place. However, the customer can still keep their tab or pending sale open. If the hire extends past the reserved period,
another period will be charged.

Highlight the Hire item within the sale and press Stop Timer. The timer will have stopped and a notification will display.
Any further items purchased will be added to the sale.
01 Sep 14:50 POS1 Adult ID: 01/09/99

Jerermy STANDARD x
Bar Tab 5002 (Bar Tab) Outstanding $27.50

KARAOKE ROOM HIRE RECEIPT CLERK 7 8 9 C |_
TWO BIRDS SUNSET SCH

NEWSTEAD AMBER ALE SCH
PRICE LEVEL 5% ST DISC
CUSTOMER 5% ITEM
BAR TAB REFUND

PENDING = VOID SALE

The Hire Timer has been stopped on this item.

POOL TABLE
HIRE

CEMENT MIXER
HIRE

CAFE TAP BEER SPIRITS GROCERY RETAIL MANAGER

DRINKS e COCKTAILS  FRUIT & VEG
RESTAURANT & RTD WINE HIRE SERVICES ADMIN




To pay the total sale amount, select Enter > select your tender to pay.

3 POS1 Adult ID:
Jer NDARD

Bar Tab 5002 (Bar Tab) Outstanding $127.50
KARAOKE ROOM HIRE

TWO BIRDS SUNSET SCH

NEWSTEAD AMBER ALE SCH

GARLIC BREAD

SMALL CHIPS

TWO BIRDS SUNSET SCH

HOLGATE TEMPTRESS SCH

BAR TAB 5002 PAYING
13x% BAR TAB
CASH
EFTPOS
ACCOUNT
LAYBY

GIFT VOUCHER

ROOM

RECEIPT Employee

Bar Area Log

PRICE LEVEL 5% ST DISC
CUSTOMER = 5% ITEM
BAR TAB REFUND

Clerk VOID SALE

TABLE VoID

127.50

Balance 127.50
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Yes/No Options

Table Details Hide Paid Items by Default

This option allows you to toggle the setting of which default you want to display on Table Details. If selected, Paid
Items will hide by default, if not selected, they will display by default.

Go to Setup > Yes/No Options > Restaurant > Table Details Hide Paid Items by Default.

Table Details Hide Paid [tems by Default

It affects these buttons on the Table Map which can be toggled.

Show Paid Hide Paid

ltems ltems




