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Build 8 

Update Details: 

** Enhancements 

 

[IP-2022] - Support for Points Accrual on Pre-Paid eCommerce Orders 

[IP-3000] - Slyp Integration 

[IP-3048] - Option for Default Aging type for New Account Customers 

[IP-3234] - Department Sales report button in POS: default to only show sales for the current terminal 

[IP-3249] - Stock Remaining Report - ability to specify which Price Level to use 

[IP-3255] - Yes/No Option - Table Details Delete asks Reason for Activity Log 

[IP-3273] - Support for Idealpos Online Shopify Orders 

[IP-3308] - Scanning existing Pending Sale adds into Current Sale 

[IP-3315] - Support for Scheduled POS Screen Layouts 

[IP-3329] - Report Screen - UI Improvements including a Clear Default Export Format button 

[IP-3334] - Inception Door Interface 

[IP-3336] - Dashboard - Last 90 Days chart hover labels shows Day of Week 

[IP-3343] - 70 x 25mm Continuous Labels - Shelf Labels Small Font 

[IP-3375] - Customer Search based on User-Defined Yes/No Fields 

[IP-3385] - Yes/No Option - Skip Post-Transaction Tipping Receipt 

[IP-3388] - Handheld / eCommerce Only Option for Kitchen Printers 
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Customer Loyalty Points 

Support for Points Accrual on Pre-Paid eCommerce Orders 

This function adds the ability for Customers to accrue points on any Pre-Paid eCommerce Orders they place through 

an eCommerce site such as Shopify, Mobi2Go, etc. 

Customer Points accrual is supported for eCommerce Interfaces configured either via Idealpos Online or via Webit. 

As there are a wide variety of eCommerce Integrations, the steps listed here will focus on the Idealpos Configuration 

that is required to support this function.  

 

To configure and use this function, go to: 

Setup > POS Terminals > Select the POS Terminal that is used for processing and handling Web Orders > Modify. 

Select “Miscellaneous Settings”, then ensure that a value other than “0” has been entered into the “Points per Dollar” 

field. The Customer will earn the number of points entered per dollar they spend. 
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Close the POS Terminals windows then go to: 

File > Customers > Customer Types 

Select the Customer Type(s) from the list which your Online Customers are members of, then press “Modify”. 

Ensure that the “Use Points System” checkbox is enabled. 

Also ensure that the “Point Multiplication Factor” is set to 1. 

If required, the Point Multiplication Factor can be adjusted as required. 

The Point Multiplication Factor is based on the Points per Dollar value. 

Example: If the Points per Dollar is set to 1 and the Point Multiplication Factor is set to 2 and the Customer purchases 

an item that is $10.00, they will earn 20 points. 

Example 2: If the Points per Dollar is set to 2 and the Point Multiplication Factor is set to 2 and the Customer purchases 

an item that is $10.00, they will earn 40 points. 

Example 3: If the Points per Dollar is set to 1 and the Point Multiplication Factor is set to 1 and the Customer purchases 

an item that is $10.00, they will earn 10 points. 

 

Once the Customer Type has been configured, press the “Save” button on the bottom-right corner of the window. 

You can repeat this step for each Customer Type that will be ordering their items via the eCommerce Web Store. 
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When a Customer places their order via the eCommerce Site, they will enter their First Name and Last Name. 

If the name that the Customer enters when placing their order matches a Customer in Idealpos, the existing Customer 

in your system will earn points after their order is finalised in your store. 

If the Customer does not exist in your system, they will be created automatically and will be assigned to the Default 

Customer Type configured in the eCommerce settings. 

In order for an existing Customer to accrue points, they will need to be a member of a Customer Type which has the 

“Use Points System” enabled. 

The Customer Type that a Customer is associated with can be viewed by going to: File > Customers > Customers. 

Select the Customer and press “Modify”. 

The Customer Type will appear in the Customer Type dropdown box. If required, the Customer Type can be updated. 

Note that changing the Customer Type may result in the Customer’s benefits changing (e.g. the Price Level they’re 

assigned to may change and they may miss out on promotions that are specific to the Customer Type). 
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The next step is to enable “Use Points” for the Tender method that is used to process eCommerce Orders. 

Go to: Setup > Global Options > Interfaces > eCommerce 

The Web Order Tender will be displayed. 

Take note of the Tender that has been selected. 

If required, you can also take this opportunity to adjust/set the Default Customer Type which will be used when a new 

Customer places a Web Order via your eCommerce site.  

If you want the Default Customer Type to earn points, ensure that “Use Points System” has been enabled for the 

Default Customer Type chosen (File > Customers > Customer Types > Select Type > Modify). 
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Close the Global Options window, then go to:  

Setup > Function Descriptors > Select the Web Order Tender from the list > Modify 

Enable “Allow Points per Dollar?” then press “Save” to save your change. 
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If you want to Inhibit Points from being accrued on Delivery Charges, this can also be achieved. 

Go to: File > Stock Control > Stock Items 

Select the Delivery Stock Item Code that is configured/linked to your eCommerce integration, then press “Modify”. 

From the Advanced Tab of the Stock Item, enable “Inhibit Points Accrual”. 
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To ensure that any changes made have been applied, restart Idealpos via IPSUtils. 

Go to: Start > Idealpos > IPSUtils > Press “Close” to close the Idealpos Suite. 

 

 
 

Start Idealpos and open the POS Screen. 

Add the Customer to the sale to check the Points Balance. 

The Points Balance will appear at the top of the Sale window next to the Customer’s name: 

 

 
 

Void the sale by pressing the Void Sale Button. 
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Go to your eCommerce Site and place a Web Order, entering the Customer Details the same as they’ve been recorded 

in Idealpos. 

Once the order has been placed and the payment has been authorised/captured, the order will be sent to Idealpos. 

After the order is received by Idealpos, the POS Screen will show a “Web Orders” button along with a numeric value 

displayed indicative of the number of Web Orders that are waiting to be processed by the POS. 

Note that if “Automatically Finalise Prepaid Web Orders” is enabled, any prepaid web orders will not trigger the “Web 

Orders” button to be displayed and they will simply auto finalise. Any Customers entered in the sale will automatically 

accrue points if the Customer Type has been configured to Use Points System. 
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Press the “Web Orders” button to view the list of Web Orders awaiting processing. 

Select the Web Order from the list, then press “Finalise” on the bottom-right corner of the window. 

 

 
 

Confirm the prompt to finalise the order: 

 

 
 

After finalising the order, the Customer will accrue the points they earned for their Web Order purchase. 
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This can be confirmed by adding the Customer to a sale. 

The updated Points Balance will appear next to the Customer’s Name as per the below example: 

 

 
 

The Customer’s Points Balance will also appear on the receipt and in Journal Enquiry. 

Go to: Enquiry > Journal History 

Select the Journal from the list.  

The Points accumulated in the current sale will be shown next to “Points” and the Customer’s Total Points Balance will 

be listed next to “Total Accumulated Points”. 

In the below example, Points Accrual was not inhibited on the Delivery Item.  
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Customers 

Option for Default Aging type for New Account Customers 

This function adds the ability to control the Default Aging Type when creating new Account Customers.  

Previous to this change, the Aging Type would default to “30/60/90 – Monthly” when creating a new Account 

Customer and if the other Aging Type of “7-14-21 days” was required, this would need to be changed when creating 

the new Account Customer.  

With this change, you now have the ability to specify which Aging Type will be pre-selected by default when creating a 

new Account Customer. This function is useful for users who consistently use a specific Aging Type for all their 

Customers in line with their Customer accounts policy. 

 

To configure and control the Default Aging Type, go to: 

Setup > Global Options > Customers > Miscellaneous 

Select the Default Aging Type from the Default Aging Type dropdown box as required: 

The options available are: 

• 30-60-90/Monthly 

• 7-14-21 Days 
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Once the Aging Type has been set as required, a new Account Customer can be created and the Aging Type 

configured above will be pre-selected.  

To create a new Account Customer, go to: File > Customers > Customers 

 

From the bottom-right corner of the Customers screen, press the “Add” button: 
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After enabling the “Account” checkbox, the Aging Type and Master Account fields will both appear below the Credit 

Limit field.  

The Default Aging Type that was configured in Global Options will be pre-selected in the Aging Type field when 

creating a new Account Customer as indicated in the below example. 

Enter the Customer Name and any other details as required, then press “Save” to save the customer using the default 

Aging Type that is selected. 
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Dashboard 

Dashboard – Last 90 Days chart hover labels shows Day of Week 

This function adds the ability to show the Day of Week when hovering over the Last 90 Days chart on the Back Office 

Dashboard. 

To use this function, go to: Idealpos Back Office Dashboard. 

At the bottom-portion of the Dashboard, press the button which contains “…” as illustrated below: 
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The Last 90 Days Chart will be displayed. 

Hover over a day and the hover label will show the day of the week: 
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Digital Receipts 

Slyp Integration 

Idealpos now supports integration with Slyp! 

Slyp is a company that has revolutionised the traditional paper receipt into the modern age. 

Instead of printing out a physical receipt at the end of a sale, Slyp enables a digital receipt to be sent to the customer 

either via email or SMS/Text Message. After a sale is completed, a prompt will be displayed at the end of the sale to 

prompt whether or not the customer requires a digital receipt. If the customer requires a receipt, the Clerk/POS 

operator can either enter the Customer’s Mobile Phone Number into the “Text Receipt to” field, or they have the 

option to enter the Customer’s Email Address to have the receipt emailed. 

 

In order to use this integration, you will need to have an account with Slyp and you will need to have the Slyp module 

licenced in the Idealpos Licence Gateway. 

 

Go to Setup > Licence Gateway and ensure that Slyp appears on the current terminal as a licenced module. 

If Slyp does not appear, please contact our Sales team and we will organise to have the Slyp module enabled in your 

licence. Once the module has been enabled in your licence, you will need to reload the licence in Idealpos by going to: 

Setup > Licence Gateway > Reload 

 

Once the Licence has been reloaded, you should see Slyp displayed in the list of modules that have been licenced for 

the current terminal. 

 

 
 

To ensure that the module has been applied, close and re-open Idealpos.  

This can be done by opening IPSUtils, then press the “Close” button to close the Idealpos Suite. 
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You may then start Idealpos by either clicking on the Idealpos shortcut on the Windows Desktop, or alternatively go to 

Start > Idealpos > Idealpos. 

 

 

Once Idealpos has started, go to the Back Office dashboard and select Setup > Global Options > Interfaces. 

From the Interfaces screen, select Slyp, then enter the Merchant ID and API Key as supplied by Slyp. 

The default Domain of https://api.slyp.com.au should be sufficient, however, you may change it if required or 

requested by Slyp. 

Once the details have been entered, press the “Connect” button. 

 

 
 

After a successful connection has been established, the Connect button will be replaced with text that shows 

“CONNECTED” in green which indicates that the connection is now active. 

 

 
  

https://api.slyp.com.au/
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The next step involves Uploading your Store Details and specifying your preference for the Digital Receipt prompt. 

The Store Details that are entered will be displayed on Digital Receipts that are sent to Customers.  

 

Enter your Store Address details and set your preference for the Digital Receipt Prompt. 

The “Prompt for Digital Receipt” checkbox will control whether a prompt for digital receipt is displayed at the end of 

the sale.  

The options available as follows will control the fields that are available on the receipt prompt:  

• SMS and Email – Selecting this option will allow the operator to enter either a Mobile Phone Number to SMS 

the receipt to or to enter an email address to email a copy of the receipt. 

• SMS only – Selecting this option will only display a Mobile Phone Number field to SMS a copy of the receipt. 

• Email only – Selecting this option will only display an Email field to send an email copy of the receipt. 

 

Once these options have been configured, press the “Upload Store” button. 

 

 
 

Close the Global Options window to save the changes. 

To ensure that the Slyp options have been applied, we recommend restarting Idealpos. 

Use IPSUtils to close the Idealpos Suite, then start Idealpos using the desktop shortcut or alternatively, press the 

Windows Start button and go to Idealpos > Idealpos. 
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Open the POS screen, add items to the sale, then press the Enter button to go to the Tender Screen. 

Select a Tender from the list of available Tenders or select one of the Fast Cash buttons. 

 

 
 

  



 Update History 
Return to top 

After selecting a Tender from the list/Fast Cash button, Idealpos will display a Digital Receipt prompt. 

The available methods for sending a digital receipt (Text Receipt To/Email Receipt to) will be reflective of the settings 

that were configured in Global Options earlier above. 

 

 
 

Click or touch the required field, then enter a Mobile Number or Email address, then press the Send Text/Send Email 

button. 

 

A copy of the receipt will be sent to the customer. 
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Your company’s/store’s details that are displayed on the digital receipt (such as the company logo/header background 

colour, etc.) can be controlled by logging into the Slyp website using your details -  https://my.slyp.com.au/auth/signin  

Once you have logged in, click on the Smart Receipt page from the left-hand side menu and adjust as required.  

Contact Slyp for more details regarding your account login details or changes to your digital receipt if you aren’t sure.  

https://my.slyp.com.au/auth/signin
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eCommerce Integration 

Support for Idealpos Online Shopify Orders 

Support for Idealpos Online Shopify Orders has been implemented in Build 8. 

Note that the app is currently unavailable on the Shopify Marketplace.  

Once the app is available on the Shopify Marketplace, we will publish a blog post onto our website and Social Media 

(Facebook, Twitter, etc.) with instructions on how to configure this integration! 

Until such time, we can configure this integration for you via an Unlisted App; contact us for more details.  
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Inception Door Interface 

The Inception Door Interface is an interface which connects to the Inception Controller/Inception Security System and 

is used for intruder detection, access control and automation. 

This initial integration of the Inception Door Interface with Idealpos enables Idealpos to send a command to the 

Inception Interface to unlock a door. This can be used at venues such as tourist attractions or theme parks which have 

a specific area where visitors or customers are required to either purchase or scan a ticket to gain access.  

In addition, this function can be utilised without a ticket and instead, a button can be created on the POS screen which 

will send a command to the Inception Door Interface to trigger a door to unlock, allowing a customer to gain entry. 

For more information about the Inception System, visit: https://www.innerrange.com/Products-Solutions/Inception 

 

The steps included below are based on the assumption that the Inception Controller/Inception Security System is 

already installed at the premises. 

 

To configure and use this function, there are two parts to the configuration process. 

The first part of the process involves the configuration of the Inception Door Interface, and the second part of the 

process involves the configuration of Idealpos so that the Open Door command can be sent to the door to 

unlock/open it. 

 

Firstly, complete the configuration of the Inception Door Interface as follows: 

 

Connect to the Inception Controller via a Web Browser. 

The Inception Controller can be accessed by visiting: 

https://skytunnel.com.au/inception/SERIALNUMBER  

Substitute SERIALNUMBER in the above URL with the Serial Number of your Inception Controller Device.  

 

A Web Interface login screen will be displayed. 

Enter the Username and Password to login: 

 

 
 

 

  

https://www.innerrange.com/Products-Solutions/Inception
https://skytunnel.com.au/inception/SERIALNUMBER
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Once logged in, a connection will need to be created for Idealpos to connect to the Inception Controller. 

Using the menu on the left-hand side, go to: Configuration > General > Connections: 

 

 
 

Press the “Add” button located at the top of the window to add a new Connection: 

 

 
 

Configure a new Connection as follows: 

General  

Name: IDEALPOS 

 

Connection Details 

Connection Type: TCP (Server) 

Port: 3000 

Enable Message Send Retry: Unticked 
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Once the above details have been entered, press the “Save” button from the buttons displayed at the top of the 
browser window: 

 

 
 

After saving, the newly created connection will be displayed on the left-hand side of the window below Connections as 

per the below example: 

 

 
 

The next step involves creating an Automated Action. 

To create an Automated Action, use the menu on the left-hand side to go to: 

Configuration > Automated Actions 
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After selecting the Automated Actions option from the menu, press the “Add” button located at the top of the window 

to add a new Automated Action: 

 

 
 

General 

In the Name field, enter “OPEN DOOR” 

 

 
 

Trigger Condition 

Configure the Trigger Condition as follows: 

 

Enable Action: Enabled 

Trigger Condition: True when ALL of the following are true 

 

 
 

Then press the “+ Trigger” button to add a new trigger. 

Configure the Trigger Condition as follows: 

 

Select an item type to base this trigger on: Connection 

Select an item: IDEALPOS 

Is/Is Not: Is 

State: Received Message 

Message: DOOR 

 

Once configured, press the “Confirm” button to save the Trigger Condition: 
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After pressing “Confirm”, the Trigger Condition will be displayed under the Trigger Condition section of the 

Automated Action screen as per the below example: 

 

 
 

An Action needs to be created for the Trigger Condition. 

Under the “Actions When True” section, press the “Add Items” button: 

 

 
 

Configure the Actions When True as follows: 

What action would you like performed: Control Door 

Door: Inception Controller – Door 1 (or alternatively, select the Door that you want to control) 

How To Control: Grant Access 

 

Press “Confirm” to save the action. 

 

 
 

After the action has been saved, it will appear within the “Actions When True” section as per the below example: 
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Once all the above settings have been entered into the “Automated Actions” page, the “Automated Actions” window 

should appear similar to the below: 

 

 
 

To save the Automated Action, press the “Save” button at the top of the window. 

 

 
 

After saving, the newly created Automated Action will be displayed on the left-hand side of the window below 

Automated Actions as per the below example:  
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The next portion of the configuration involves the setup of Idealpos so that the Open Door command can be sent to 

the Inception Controller. 

 

Open Idealpos and go to: File > Sales > Stock Item Attributes 

Choose “Add New Attribute Type” from the bottom-left corner of the window: 

 

 
 

Add a New Attribute Type: SALE COMMAND (the Attribute Type can be given any name, but for the purposes of 

setting up and demonstrating this function, we will use SALE COMMAND) 
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After the Attribute Type has been added, press the “X” on the top-right corner of the window, then select the “SALE 

COMMAND” Attribute Type from the list and press the “Add New SALE COMMAND” button. 

 

 
 

Enter the command in the format of: 

IPADDRESS:PORT=DOOR 

 

If the IP address is 192.168.1.117 and the Port Number is 3000 (this is the Port Number that was configured earlier in 

the above steps), the Sale Command will need to be entered as: 

192.168.1.117:3000=DOOR 

This is demonstrated in the below example. 

Once entered, press the “Save” button.  
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If you are unsure about what the IP Address of the Inception Controller is, this can be found on the Inception logon 

screen by opening https://skytunnel.com.au/inception/SERIALNUMBER  

Substitute SERIALNUMBER in the above URL with the Serial Number of your Inception Controller Device: 

 

 
 

 

Once the Sale Command has been saved to the Stock Item Attributes, it should appear similar to the below example: 

 

 
  

https://skytunnel.com.au/inception/SERIALNUMBER
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Close the Stock Item Attributes window, then go to: Setup > Global Options > Other Options 

 

Under Special Attribute Types, select the “SALE COMMAND” Attribute Type from the Transaction Event Dropdown box: 

 

 
 

Once the Transaction Event has been set to SALE COMMAND, close the Global Options window. 
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In order to send the Sale Command to the Inception Controller, the SALE COMMAND Attribute Type and the DOOR 

Attribute will need to be assigned to a Stock Item which will trigger the command when a sale containing the Stock 

Item is finalised. 

 

Go to File > Stock Control > Stock Items 

Press the “Add” button on the bottom-right corner of the screen to add a new Stock Item. 

Create the Stock Item and enter the details as required. 

The Stock Item Description can be entered as anything you require but for demonstrating this function, we have used 

a description of OPEN DOOR. 

If Customers are required to pay to enter through the door, you may also enter a Sell Price for the Stock Item. 

Once the Item has been created as required, take note of the Stock Code then press “Save” on the bottom-right corner 

of the window. 
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A button on the POS Screen can also be created for the item which can be used to open the door. 

Note that you have a few options when creating the button as follows: 

 

1. Create a button that calls the “Macro” function to add the Open Door item to the sale, go to the tender screen 

and finalise the sale all with the push of a single POS screen button. This may be useful in environments where 

the Sell Price of the Open Door item is zero and the door needs to be opened frequently without the purchase 

of any other items. Note however that using this method in the middle of a sale will result in the sale being 

finalised using cash. 

 

2. Create a button that adds the item to the sale via the “Stock Item”. This will simply add the item to the sale 

and the clerk will need to press the Enter button on the screen to proceed to the Tender screen, then finalise 

the sale by selecting a Tender from the list. 

 

To create a button on the POS Screen, go to:  

Setup > POS Screen > POS Screen Setup > Select the Layout > Buttons 

 

Navigate to a POS Screen tab that you want the button to be created on and select it. 

Find a blank unused button and click on it. 

 

Using the “Macro” function to open the door: 

If you want to use the Macro method from point 1 above to open the door, select “Macro” from the Function List, then 

enter the following Automatic Text, ensuring that you substitute StockCode with the actual Stock Code of your Open 

Door Item: 

StockCode~~{D}CASH~ 

 

For the demonstration of this function, the Stock Item “OPEN DOOR” that was created earlier above had a Stock Code 

of 20. So, the Automatic Text to enter when using the Macro function will be: 

20~~{D}CASH~ 

 

Take note that this may vary with your setup (e.g. If you have any prompts that appear before the Tender screen is 

displayed, an additional Enter “~” character may be required to dismiss them). 

 

The way the Macro will work is as follows: 

• The Stock Code will be entered first, followed by the Enter key (which will add the item to the sale). 

• The Enter key will be pressed again which will trigger Idealpos to display the Tender screen. 

• A short delay {D} will occur. 

• The text CASH will be entered into the tender field to indicate that the sale will be finalised using the Cash 

Tender. 

• The Enter key will be pressed and this will trigger the sale to be finalised. 
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Using the “Stock Item” function to open the door: 

If you want to use the Stock Item function from point 2 above to open the door, select “Stock Item” from the function 

list. Then either enter the Stock Code into the Stock Item field, or press the “>” button within the Stock Item field and 

search for the “Open Door” item from the Stock Item List.  

Finally, press “Save” to save the button. 

 

 
 

 

 

Once the button has been created, close the POS Screen Layout window, then press the “POS” button from the 

dashboard. 

Select the POS Screen tab which the button was created on, then press the button. 

If using the Macro method, the item will be added and the sale will be finalised automatically. Immediately after the 

sale is finalised, the door will be unlocked/opened. 

If using the Stock Item function to add the item to the sale, you will need to press the ENTER button, then select a 

Tender from the list. After selecting a tender, the door will be unlocked/opened.  
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Kitchen Printers 

Handheld / eCommerce Only Option for Kitchen Printers 

This function adds the ability to configure a Kitchen Printer to only print orders when they have been received from 

Handheld or eCommerce orders. An example of a situation where this function could be utilised includes sending an 

order for a Cappuccino from the Handheld app to the Kitchen compared to placing an order for a Cappuccino from 

the POS Terminal. 

When serving a customer at the table of the Restaurant and they order a Cappuccino, the Clerk is away from the POS 

Terminal and having the order print to the Kitchen will aid in the process of ordering the Cappuccino, whereas if the 

order is placed from the POS Terminal by the Clerk, the Clerk may be in close proximity to the Kitchen and they can 

verbally request the Cappuccino be prepared, saving on receipt rolls. The Clerk serving the Customer at the POS 

Terminal may also be the barista who will prepare the Cappuccino, reducing the need to print the order to the Kitchen 

Printer. 

 

To configure and use this function, go to: Setup > POS Terminals > Select Terminal > Modify 

Navigate to the Kitchen Printers tab, then select the Kitchen Printer that you want to apply the setting to. 

Finally, toggle the “Handheld / eCommerce Only” checkbox. 

When the checkbox is disabled, orders that are sent to the selected Kitchen Printer from Idealpos, Handheld or 

eCommerce will result in the Kitchen Receipt being printed. 

When the checkbox is enabled, only orders that are sent to the selected Kitchen Printer from Handheld or eCommerce 

will result in a Kitchen Receipt being printed (i.e. orders placed from Idealpos will not be printed to the Kitchen Printer). 
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Labels 

70 x 25mm Continuous Labels – Shelf Labels Small Font 

This function adds the ability to select the font size printed on Shelf Labels when Outputting to Idealpos Continuous 

Labels with the Dimensions of 70mm x 25mm. The size of the font is controlled via the Design Dropdown box. 

The Font Size that was previously printed on Shelf Labels will continue to be used when the “Shelf Labels” option is 

chosen from the Design dropdown box. 

The new Small Font Size can be printed on Shelf Labels by selecting the “Shelf Labels Small Font” option from the 

Design dropdown box. The Small Font option is only available for the label dimensions 70mm x 25mm. 

 

To configure and use this function, go to: Utilities > Labels 

Set and configure the dropdown boxes as follows: 

Data Type: Stock Items. 

Output To: Idealpos Continuous Labels. 

Continuous Printer: [Select your Continuous Label Printer from the dropdown box]. 

Dimensions: 70mm x 25mm. 

Design: Shelf Labels Small Font (new small font size introduced with this change)/Shelf Labels (old large font size). 

Price Level: Select the Price Level that you want to be used when printing the Shelf Labels. 

Top Margin/Left Margin: Enter a value to specify the position of the labels. Trial and error may be required to 

determine the correct values for your printer and label stationery. 

Start Position: Set which position the labels from the current selection will print from. 

Use Stock Code as Barcode: Enabling this option will generate the barcode on the labels using the Stock Item Code. 

Show Print Dialog Box: Ticking this option will cause the Print Dialog box to appear when printing labels. 

Barcode Type: Select the Barcode Type from the list. The selected Barcode Type will be printed on the Labels. 

Save Format As: If you want to save this format for later use without having to re-enter the above settings, enter a 

name for the format then press the “Save Format As” button. The format will be added to the list of available formats 

displayed at the top of the screen. When the saved Format is selected, the above settings will be pre-filled. 
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Once the Label Format Settings have been entered and the Format Saved, Labels can be generated using the format. 

From the Right-Hand side of the labels window, you have option to either enter the criteria required for the labels to 

generate, then press the “Add to Grid” button to add the items that fall within the entered criteria to the list of labels 

below. Alternatively, you can use the “Multi Select” button to display the Stock Items search screen which can then be 

used to search and select items to generate labels for. When using Multi Select, multiple Stock Items can be selected 

by holding down the CTRL key on your keyboard, then select the next item from the list. Repeat this until the required 

Stock Items have been selected, then press “OK” to add them to the list of labels to be generated.  

 

After the items have been selected, they will appear in a list similar to the below example: 

 

 
 

Once you’re happy with the list of items displayed, press the “Print” button and they will be printed to the Continuous 

Label Printer. 

It should be noted that in your first print using the new format, you may want to sample the style by only printing a 

handful of Stock Item labels to ensure that they print out as expected and to minimise label wastage in the event the 

labels do not print as expected (e.g. Top/Left margin adjustments may be required, etc.). 
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POS Screen 

Scanning existing Pending Sale adds into Current Sale 

This function enables the ability to scan an existing Pending Sale Code when Items have already been added to the 

current sale; the items from the existing Pending Sale will then be added to the bottom of the current sale.  

Previous to this change, a Pending Sale Code had to be scanned prior to adding any items to the sale and once the 

Items from the Pending Sale Code were added, additional items could then be added to the sale. 

After this change, it is now possible to either scan a Pending Sale Code into a blank sale screen or a sale screen that 

already contains items that have been added. 

 

There are no additional steps required to enable the scanning of a Pending Sale Code to add items to the current sale. 

Idealpos has simply been updated to allow the Pending Sale Code to be scanned either before or after Items have 

been added to the sale. 

 

Before setting up Pending Sales, POSServer must be enabled.  

For more details about setting up POSServer, refer to the POSServer topic in the User Guide.  

Once POSServer has been configured, ensure that POSServer is enabled in Setup > Global Options > Miscellaneous. 

Refer to the Miscellaneous Global Options Topic in the User Guide for more details. 

 

To configure and use this function, go to: 

Setup > Global Options > Sales > Pending Sales 

 

Ensure that the following checkboxes are enabled: 

• Auto Generate Pending Sale Codes  

• Print to Docket Printers 

 

 

https://userguide.idealpos.com.au/#POSServer/POSServer%20Configuration.htm
https://userguide.idealpos.com.au/#Global%20Options/Miscellaneous.htm
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Close the Global Options window, then go to: Setup > Yes/No Options 

Enter Keyword Search: bar code 

Enable “Print Bar Codes on Receipts” 

 

 
 

Close the Yes/No Options window to save the change. 

 

A Pending Sale button also needs to exist on the POS Screen in order to use the Pending Sale Function. 

Go to:  

Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Press “buttons” on the bottom-left corner 

 

Ensure that a Pending Sale button exists on the POS Screen. 

If a Pending Sale button does not exist, click on a blank/unassigned button and select the “Pending Sale” function to 

create the button: 
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Close the POS Screen Layout windows. 

Pending Sales are now ready for use. 

 

Open the POS Screen from the Back-Office Dashboard: 

 

 
 

Add Items to the sale, then press the “Pending” button.  

 

 
 

If required, fill in the required details then press the “Save” button to save the Pending Sale. 

Entering details (Customer Name and Address) is optional, but may be useful for identifying a Pending Sale at a later 

time or date. 
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A Pending Sale will be created and a Pending Sale Code will be printed at the bottom of the Pending Sale receipt. 

The Pending Sale can be resumed by scanning the Pending Sale Code.  

The Pending Sale Code can either be scanned before any items have been added to the sale, or the Pending Sale Code 

can be scanned after Items have been added to the sale. If scanning the Pending Sale Code after items have been 

added, the items from the existing Pending Sale will be added below the items that have been added to the sale.  

 

Alternatively (if you don’t have a scanner connected to the POS terminal), the Pending Sale can be added to the sale 

screen by manually entering the Pending Sale Code. This can be done by entering the Pending Sale Code into the POS 

Screen using the format P[PendingSaleCode]-1 

Example: If the Pending Sale Code is 121, this would be entered as: 

P121-1 

 

This can be entered using the Text String function. 

A button on the POS Screen can be created to utilise this function. 

Go to:  

Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Press “Buttons” on the bottom-left corner 

 

Find an unused/blank button and click on it. 

From the list of available Functions, select “Text String”, configure the Button Caption as required, then press the 

“Save” button to save the change. 

 

 
 

Close the POS Screen Layout windows. 

From the Back-Office Dashboard, press the “POS” button to open the POS Screen. 
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Press the Text String button that was configured above. 

An on-screen keyboard will be displayed. 

Enter the Pending Sale Code in the format of P[PendingSaleCode]-1. 

E.g. For a Pending Sale Code of 125, you will need to enter the below: 

P125-1 

 

The keys on the on-screen keyboard that will be used to enter the Pending Sale Code have been shown below: 

 

 
 

Press the “ENTER” button on the on-screen keyboard to enter the value into the POS Screen. 
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After the ENTER button has been pressed, the items from the Pending Sale will be added to the Sale screen. 

 

 
 

The above process of entering the Pending Sale Code can be performed either when there are no items added to the 

sale or when items have already been added to the sale. 
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POS Screen Functions 

Customer Search based on User-Defined Yes/No Fields 

This function adds the ability to specify a User-Defined Yes/No option when configuring a Customer button on the 

POS Screen. Any Customers that have a Yes/No option enabled which matches the option configured on the button 

will be displayed on the POS Screen when the button is pressed.  

 

Idealpos can support up to five User-Defined Yes/No options which can be assigned to your Customers.  

Each of the five available Yes/No options can be customised for each venue as required. 

After the User-Defined options have been configured, Customers can be assigned to them. 

Once you have assigned your Customers to the required Yes/No options, the Customers button can be pressed.  

Any Customers that match Yes/No option configured on the button will be displayed. 

 

Examples of what the User-Defined Yes/No options can be used for include: 

• Displaying Customers who pay weekly/monthly/quarterly 

• Displaying Customers who are Juniors/Seniors 

• Or any other Categories for a Customer that you require 

 

 

To configure and use this function, go to: Setup > Global Options > Customers > User-Defined > Yes/No Fields 

Enter the required User-Defined Yes/No Options as required: 
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Close the Global Options window to save the changes. 

The next step is to assign Customers to the User-Defined Yes/No Fields. 

Go to: File > Customers > Customers 

Search for a Customer that you want to assign to a Yes/No option and double-click on them.  

Alternatively, click on the Customer once, then press the “Modify” button on the bottom-right corner of the Customers 

screen. 

When modifying the Customer, click on the Advanced tab, then enable the User-Defined option checkboxes that you 

want to assign the Customer to, then press “Save” to save the changes. 

The below example shows a single User-Defined option “Pays Weekly?” enabled. 
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Customers can also be assigned to multiple User-Defined Yes/No Fields as per the below example: 
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After Customers have been assigned to the required User-Defined Yes/No Fields, POS Screen buttons need to be 

created. 

Go to:  

Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Press “Buttons” on the bottom-left corner 

To create the button on a POS Screen Tab, select one of the available tabs at the bottom of the screen. 

Alternatively, the button can be created on the top-right corner of the POS Screen which will ensure that the button is 

always displayed on the POS Screen, regardless of the POS Screen tab that is being viewed. 

Select a blank/unassigned button, then configure by selecting the “Customer” option from the list of functions. 

Then from the User-Defined Yes/No field, select the Yes/No field that you want to display when pressing this button. 

Update the Button Caption to reflect the type of Customers that will be displayed when pressing the button. 

Press “Save” to save the changes. 
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The above process can be repeated to create a new button for each Yes/No Field that you want to use to search for 

Customers on the POS Screen. 

 

 
 
Close the POS Screen Layout windows, then open the POS Screen from the Back-Office Dashboard. 
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Navigate to the POS Screen tab where you created the POS Screen Button, or press the button from the top-right 
corner of the POS Screen. 
The below example shows the “Customers that Pay Weekly” button being pressed. 
 

 
 
A list of Customers which have the User-Defined Yes/No Field enabled will be displayed. 
In this example, two Customers were assigned to the “Pays Weekly” Yes/No Field and includes Customers that are 
assigned to multiple Yes/No Fields. 
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The below example shows the “Senior Customers” button being pressed. 

 

 
 

A list of Customers which have the User-Defined Yes/No Field will be displayed. 

In this example, a single Customer was assigned to the “Senior” Yes/No Field. 
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Department Sales Report Button in POS – Default to only show sales for the current terminal 

This function adds the ability to control whether the Department Sales Report Button on the POS screen shows 

Department Sales from either all POS terminals or just the current POS terminal. 

Previous to this change, only the ability to enter a specific POS Terminal number was available via the Automatic Text 

field. However, this would affect the Department Sales Report button on all POS terminals that used the same POS 

Screen Layout which would result in all terminals displaying the Department Sales Report for the terminal number 

entered in the Automatic Text field. 

With this change, it is now possible to toggle a checkbox called “All POS Terminals” when configuring the Department 

Sales Report Button.  

 

To configure and use this function, go to: 

Setup > POS Screen > POS Screen Setup > Select a layout > Press “Buttons” on the bottom-left corner of the window. 

 

Click on a POS Screen tab at the bottom of the POS Screen Layout where you want to create/modify the Department 

Sales Report button. 

 

If Modifying an existing button, look for the Department Sales Report button and click on it. 

If creating a new button, look for an unused/blank button and click on it. 

Toggle the “All POS Terminals” checkbox as required. 

Details about the way the checkbox works are outlined below: 

 

• When the “All POS Terminals” checkbox is enabled, Department Sales from all POS Terminals will be displayed. 

• When the “All POS Terminals” checkbox is disabled, Department Sales from the current POS Terminal will be 

displayed. 

• If a single numeric value (e.g. 2) is entered in the “Automatic Text” field, it will trigger the report to only show 

Department Sales from POS Terminal 2 and the “All POS Terminals” checkbox will be ignored.  

If a date is entered into the Automatic Text field (e.g. “1/3” or “1,3” or “1-3”), the report will show Department 

Sales from the entered date up to today’s date (the report will display sales figures that took place within the 

date range).  

When a date is entered in the Automatic Text field, the All POS Terminals checkbox will apply. 

 

Once the button has been configured, press the “Save” button. 

 

 
 

Close the POS Screen Layout window, then open the POS Screen from the Back-Office Dashboard. 
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Navigate to the POS Screen tab which contains the “Department Sales Report” Button and press it. 

The report will be displayed on-screen and will reflect the Department Sales Report data as per the button 

configuration that was completed above. 

 

E.g. If the All POS Terminals option was enabled, the report will be displayed and will not show a POS Terminal number 

towards the top of the report (indicating that the report is showing report figures for all terminals). 

 

 
 

If the All POS Terminals option was disabled, the report will be displayed and will show the POS Terminal number 

towards the top of the report (indicating that the report is showing report figures from only the current terminal). 
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Reports 

Clear Default Export Format button on Report Screen 

This function adds the ability to clear the Default Export Format from the Report Screen allowing easier access to this 

function. Previous to this change, the Clear Default Export Format button used to exist in the Global Options > General 

screen. After this change, the Clear Default Export Format button is no longer displayed in Global Options. 

As part of this change, the Default Zoom has also been moved from Global Options to the Report screen. 

 

To use this function, go to: Reports > Select a Report Category > Select a Report Type 

To access the function, you will need to run the selected Report. 

Select the required criteria then press the “View” button to run the report. 

When viewing the Report, press the cog icon on the top-left corner of the screen, then select the “Clear Export Format” 

option. The Default Zoom can also be changed by hovering over the Default Zoom option on the menu and selecting 

a zoom level from the list. 

 

 
 

A confirmation prompt will be displayed. 

Press “Yes” to continue with clearing the export format, otherwise press “No” to cancel without clearing the export 

format. 
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A new Default Export Format can be set by pressing the Export button on the top-left corner of the report screen: 

 

 
 

Select the desired Format from the Format dropdown box, then press OK to continue: 

 

 
 

You may be prompted to select a Page Range. Leave as “All”, or select the desired Page Range then press “OK” to 

continue. 
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Browse to any location required, enter a File name and press the “Save” button. 

 

 
 

After saving the file, you will be prompted “Would you like to keep this as your Default Export Format?”. 

Select “Yes” to have the Default Export Format saved. 

 

 
 

Once the Default Export Format has been set, the next time the Export button is pressed, the below Export Format 

prompt will not be displayed: 
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Stock Remaining Report – Ability to specify which Price Level to use 

This function adds the ability to control which Price Level to use and display on the Stock Remaining Report. 

Prior to this change, the report displayed a Sell Price column which always used the Price Level 1 Sell Price.  

When running the report, a new dropdown option now exists to specify the Price Level to use when running the 

report. The Price Level description will be displayed on the column header that previously displayed “Sell Price”. 

 

To use this function, go to: Reports > Sales > Stock Remaining 

 

Use the Price Level dropdown box to select the desired Price Level. 

Select any other report criteria as required, then press “View” to run the Report. 
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The selected Price Level Description will appear in the column header and the Sell Prices displayed in this column will 

reflect the selected Price Level as per the below example. 
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Restaurant and Table Map 

Yes/No Option – Table Details Delete asks Reason for Activity Log 

This function is applicable to the Restaurant Module and enables the ability to control whether the list of Reasons are 

displayed when item(s) are being deleted from a table.  

Recording the reason why an item was deleted from a table can be useful for reporting purposes. 

 

To configure this function, go to: Setup > Yes/No Options > Enter Keyword Search: Reason 

Toggle the checkbox for the POS Terminals that you want to enable or disable this function 

 

 
 

Close the Yes/No Options window to save the changes. 

At this point, you may also want to review the list of Reasons that will be displayed. 

To do this, go to: Setup > Global Options > Sales > Refund Reasons 

Update the list of reasons as required, then close the Global Options window to save your changes: 
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From the Back-Office dashboard screen, open the POS Screen by pressing the “POS” button. 

 

 
 

Once the POS Screen is displayed, click on the “Table Map” button: 

 

 
 

Select a table from the Table Map, then press the “Details” button: 
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Select one or more item(s) from the table then press the “Delete” button: 

 

 
 

On the Confirmation Prompt that appears, press “Yes”: 
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The list of Refund Reasons will be displayed. 

Select a Refund Reason from the list to continue: 
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The Item will be deleted from the Table. 

The Refund Reason for the item deletion will be recorded in the Activity Log. 

To view the Activity Log, close the Table Details, Table Map and POS Screen, then go to: Enquiry > Activity Log 

 

The Action Description for the deleted item will appear as “Del Item [ITEMCODE] – Table [TableNumber] ($amount)”. 

The Delete Reason will be displayed below the Del Item entry as per the below example. 
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Schedules 

Support for Scheduled POS Screen Layouts 

This function adds the ability to create and configure a schedule that will be used to change the POS Screen Layout at 

specified intervals during the days that have been selected in the schedule.  

The following is a list of various examples that Scheduled POS Screen Layouts can be used for: 

• Venues that have a specific menu or items available for a period of time each day such as happy hour or items 

that are only available for late-night dining, etc.  

• When the POS is being used as a Kiosk and the customers using the Kiosk should only see items applicable to 

the time of day that they’re placing an order (e.g. Breakfast menu, Lunch menu, Dinner menu, etc.). 

• Change the POS Screen Layout as a one-off change on a future date (e.g. setting a POS Screen Layout that will 

contain new Stock Items that will be available in the future). 

 

After POS Screen Layout is changed by a schedule, the new layout will be displayed on the POS Screen and will also be 

reflected in: Setup > POS Terminals > Modify > POS Screen Layout. 

 

Note that Scheduled POS Screen Layouts do not work in the same way as a Special Price Schedule works.  

E.g. With a Special Price Schedule, a Price Level only applies between a start/end time and the Sell Price reverts back to 

the normal price after the Special Price Schedule (Start Time/End Time) is over.  

Whereas a Scheduled POS Screen Layout works by changing the actual POS Screen Layout to the selected layout at 

the date/time/interval configured in the Schedule.  

You will therefore need to create a separate Schedule for each POS Screen Layout that you want to set. 

E.g. Create a Schedule to set the POS Screen Layout to a Happy Hour Layout at the start of the Happy Hour, then 

create another schedule to revert the POS Screen layout back to the standard layout after the Happy Hour is over. 

 

Before configuring this function, ensure that you have created one or more separate POS Screen Layout(s) which will 

be triggered by the schedule. 

You have the option to either create a completely new layout, or alternatively, you can copy an existing layout and 

modify it as required. 
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To create/copy a POS Screen Layout, go to: Setup > POS Screen > POS Screen Setup 

Press the “Add” button on the bottom-right corner of the window to create a new layout. 

Enter a Description for the layout (e.g. Happy Hour, Scheduled POS Screen Layout or whichever description best 

represents the purpose of the layout). 

Press “Save” to create the layout. 
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Press the “X” button on the top-right corner of the window to close the create new POS Screen Layout window. 

You have two options after creating the new layout as follows: 

  

• Option 1 – Create a new layout from scratch 

This can be done by selecting it from the list of layouts, then press the button labelled “Buttons” from the 

bottom-left corner of the window. Then you’ll need to configure the layout. 

 

 
 

• Option 2 – Copy an existing layout to the newly created layout.  

This can be done as follows:  

- Select an existing layout from the list of layouts. 

 

 
 

- Press the “Copy” button on the bottom-left corner of the window. 

 

 
 

- Press the “>” button in the “To” field and select the new layout from the list press and press “OK” to select 

the layout. 
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- Press “Copy” to copy the button layout from the existing layout to the newly created layout. 

 

 
- When confirming the Overwrite, ensure that the Layout Codes displayed on the Confirm prompt are 

reflective of the layouts that you are updating, then press “Yes”. 

 

 
Selecting the wrong layout during the copy operation can result in clearing the existing layout. 

Use caution when copying layouts and ensure that the Layout Code displayed in the confirm prompt 

reflects the action you want to perform!  

E.g. “Are you sure you wish to Overwrite Layout 2 with Layout 1?” means that Layout 2 is going to be 

completely cleared and overwritten using the layout from Layout 1.  

If in doubt or unsure, request assistance to prevent accidentally overwriting the wrong layout!  

 

For more information about creating or modifying POS Screen Layouts, refer to the POS Screen Setup topic in the User 

Guide. 

 

  

https://userguide.idealpos.com.au/#POS%20Screen%20Setup/POS%20Screen%20Setup.htm
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Once the POS Screen Layout has either been copied or created as above, close the POS Screen layouts window.  

The next step involves the creating the schedule(s). 

 

Go to: Setup > Schedules > Add 

From the Type Dropdown box, select POS Screen Layout. 

Then select a POS Screen Layout from the right-hand side of the screen. 

The Description that is displayed above the Type dropdown box will reflect the name of the POS Screen Layout 

selected. 
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POS Screen Layouts can either be scheduled as a one-off occurrence or a recurring schedule. 

 

• If creating a one-off schedule to change the POS Screen Layout, you will only need to create a single Schedule 

entry and enable the “Run Once Only” checkbox. The POS Screen Layout will change at the entered date/time 

and the Schedule will not repeat or execute again. 

 
 

• If creating a recurring schedule to change the POS Screen Layout, the recurring schedule will set the selected 

POS Screen Layout at the entered interval. You will therefore need to create a Schedule for each POS Screen 

Layout that you want to set.  

E.g. If you want to have a specific POS Screen Layout appear daily from 1:00PM until 2:00PM, you will need to 

create two Schedules to run daily.  

 

The first schedule will need to be configured to set the POS Screen Layout at 1:00PM:  

 

 
 

The second schedule will need to be configured to set the POS Screen Layout back to the Normal Layout at 

2:00PM:  
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The options available when creating a Schedule are explained in further detail below: 

 

Run next at: Select the date and time that you want the schedule to occur. 

Run Once Only: Enable the checkbox to only run the schedule once using the date/time entered in the “Run next at” 

field. The Run Once Only option may be useful for scheduling a one-off change to the POS Screen Layout in the future, 

such as the introduction of new items to the POS Screen. 

Repeat Every # Minutes/Hours/Days/Weeks/Months: Enter a value and select the period type (e.g. Minutes, Hours, 

Days, etc.) from the dropdown box. Note that the period type selected will affect the availability of the below options 

as some options are only applicable to specific period types.  

An example of this is if you select Repeat every 1 Days, the From and To time fields will be greyed out. 

From/To: This field only applies to the Repeat Every Minutes and Hours period type.  

Enter the Start/End Time that you want the schedule to trigger. The Time is entered in 24-hour format.  

Mon-Sun – These checkboxes for the days of the week only apply to the Repeat Every: Minutes, Hours and Days 

Period Types. Enable the checkbox next to each day of the week that you want the schedule to be active. 

POS Terminals – Enter the POS Terminal Number(s) that you want the schedule to apply to. Terminal Numbers can be 

entered as a single terminal number to only apply to a single terminal (e.g. 1), a range of terminal numbers (e.g. 1-3) or 

a comma delimited list (e.g. 1,2,3). 

 

 
 

 

 

After the settings for the Schedule have been entered, close the current Schedule by pressing the “X” on the top-right 

corner of the window which will save the Schedule and return to the list of Schedules. 

The newly created Schedule(s) will be displayed in the list of existing Schedules: 

 

 
 

The columns displayed on the Schedules list are: 

Description: Shows the Description of the POS Screen Layout that is selected in the Schedule. 

POS: Shows the POS Number where the Schedule was created on. 

Next Scheduled: Shows the next scheduled Date and Time that the schedule will be executed. 

Type: The Type of Schedule (E.g. Email Reports, Print Reports, Send Message, POS Screen Layout, etc.). 

Send To: The POS Terminals that the POS Screen Layout will be sent to when the schedule is executed. 
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Once Schedules for the POS Screen Layouts have been configured, close the Schedules window. 

When a Schedule is updating the POS Screen Layout, the POS Terminal will briefly display “Loading new POS Layout”. 

 

 
 

If items have been added to the sale and a sale is currently in progress on the POS Screen, the POS Screen Layout will 

only be updated after the current sale has been tendered off and finalised. 

If Idealpos is not running or if the POS Screen is not open at the time the schedule is executed, the next time Idealpos/ 

POS Screen is opened, the new POS Screen Layout will be applied shortly afterwards.  
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Yes/No Options 

Yes/No Option – Skip Post-Transaction Tipping Receipt 

This function adds the ability to disable the printout of a tipping receipt when applying a tip to a sale (post-

transaction). This setting is disabled by default to prevent the modification of the existing post-transaction tipping 

receipt behaviour at any venues that currently rely on them. 

However, if your venue does not require or rely on a printout of a post-transaction receipt, this can be disabled, 

allowing the conservation of receipt rolls so they last longer. 

This setting is only applicable to venues which use an EFTPOS integration that supports Post-Transaction tipping. 

An example of an EFTPOS integration that supports Post-Transaction tipping is First-American. 

 

To configure this function, go to: 

Setup > Yes/No Options 

Enter Keyword Search: skip 

Enable the Yes/No Option “Skip Post-Transaction Tipping Receipt”  

 

 
 

Close the Yes/No options to apply the change. 

A Post-Transaction tip can now be applied to a transaction and after the tip is processed, the receipt will not be 

printed. 

As there may be numerous EFTPOS integrations that support Post-Transaction tipping, please refer to the process that 

is applicable to your EFTPOS integration type. 

For the purpose of referring to an EFTPOS Integration that supports Post-Transaction tipping, the First American Tip 

Adjustment topic can be referred to in the User Guide here, however, the steps for performing a Post-Transaction tip 

may vary depending on the EFTPOS integration you are using.  

https://userguide.idealpos.com.au/#EFTPOS/First%20American/First%20American%20Transaction%20TipAdjust.htm

