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Update Details: 

Important Note: 

This build release will migrate data from various Customer tables in the Access Database into the SQL 

Database. It is therefore recommended that a Customer Database is tested first on a demo system to ensure 

that the migration is completed successfully as well as to gauge the length of time the conversion will take. 

The data conversion will take place the first time Idealpos is started after installing the new build. 
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Alerts 

IP-5257 – Alerts – Support for Refunds 

This function adds the ability to create alerts for the Refund function. 

Once the Refund function has been triggered on the POS Screen the number of times configured in the Alert, the Alert 

action configured in the Alert will be triggered (e.g. Write an entry to Alerts.log and/or Send Email). 

 

To configure and use this function, go to: Back Office > Setup > Global Options > Other Options. 

 

Ensure that the Alerts > Output from POS # is set to a valid POS Number on your network. 

The Alerts.log will be written to the POS Terminal number entered here, and will contain alerts that are triggered 

across all POS Terminals on the network. 

 

If Email functionality is required for alerts, ensure that the Email Settings are also configured as required: 
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Go to: Back Office > Setup > Alerts > Add > Configure Alert as below > Press ‘Save’ on the top-left corner to save. 

 

Alert Description: Enter a Description 

If Function Type: Refunds 

Quantity reaches # in # [Minutes or Days]. This is the number of transactions with a refund, not refund quantity. 

Group By: Clerk or POS 

POS Range: Enter a POS Range, or leave as blank to alert for All POS Terminals 

Clerk: Enter a Clerk Code or leave as blank to alert for All Clerks. 

 

Alert Action: Toggle Checkboxes and configure Email / Log Message as required. 

Write to Alerts.log – This will write the Alert to the Alerts.log in C:\ProgramData\Idealpos Solutions\Idealpos\LOGS\ 

Send Email to – This will send an email alert to the email address(es). Use a comma to separate multiple addresses. 

 

Email / Log Message – This field is where the Alert message can be customised. When the Alert is triggered, the 

message entered in this field will be written to the Alerts.log and/or emailed to the email addresses configured above. 

Two examples of an Email / Log Message have been included below: 

 

Example 1 (Can be used when the Group By option is set to Clerk) 

Refund Limit Alert! 

Total refunds processed by {CLERKCODE} {CLERKNAME} has reached {FUNCTIONQUANTITY} between 

{DATESEARCHFROM} and {DATESEARCHTO}. 

 

Example 2 (Can be used when the Group By option is set to POS) 

Refund Limit Alert! 

Total refunds processed by {POSTERMINALNUMBER} {POSTERMINALDESCRIPTION} has reached 

{FUNCTIONQUANTITY} between {DATESEARCHFROM} and {DATESEARCHTO}. 
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After saving the Refund Alert, close the Alert window then go to POS Screen. 

Trigger the number of refunds configured in the Alert. 

As mentioned previously, the number of refunds configured in the Alert refer to the number of transactions that 

contain a refund within the specified period, not the refund quantity. 

E.g. Using the refund amount shown on the Alerts configuration screenshot on the previous page (5 refunds in 2 

minutes), refunding a quantity of 5x items in a single transaction will not trigger the alert. 

Five separate transactions which contain a refund must be completed within two minutes for the refund alert to 

trigger. 

 

Once triggered, the Alert will be emailed to the email address(es) and/or written to the Alerts.log, as configured in the 

Alert. 

 

Email Alert:  

 

 
 

Alerts.log (located in C:\ProgramData\Idealpos Solutions\Idealpos\LOGS on the POS Terminal that was configured in 

Setup > Global Options > Other Options > Alerts > Output from POS #): 
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Customers 

IP-64 – Customers Search Screen – Support for Field Filtering 

This function will enable the ability to filter the Customer Search Screen by each field, (in the same manner as the field 

filtering which is available on the Stock Items search screen). 

 

This function does not require any additional configuration. 

To use this function, go to: Back Office > File > Customers > Customers. 

The field filters are displayed at the top of each column, just below the column header. 

 

 
 

Enter a search term into any of the available field filters to search for any matching Customers. 
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IP-5282 – Customers/Stock Items – Top N Records Functionality 

This function limits the number of records (to the top 50 records by default) that are displayed when opening the 

Customers function via Back Office > File > Customers > Customers. The top number of records that are displayed 

when opening the Customers screen can be toggled between Top 50 records, Top 1000 records, or All records. 

By selecting a smaller number of top Customer records to display, the amount of time it takes to open the Customers 

screen in venues that contain an excess number of customer records will be greatly reduced. 

When the Top N records function is actively restricting the number of records displayed, a note will appear and will 

specify the number of records currently being shown (e.g. Top 50 records, Top 1000 records). 

 

  
 

If all records are being displayed, the ‘Top’ text will be omitted and the total number of records will be listed, as shown 

below: 

 

 
 

Note that when the number of records is limited to a smaller sample, the search and filter function on the Customers 

screen is not affected; if one or more customers exist which match the entered search criteria, the Customers will be 

displayed in the filtered search results. 

 

On the top-left corner of the Customers window, select from the following options to toggle the number of records to 

display: 

• Top 50 records 

• Top 1000 records 

• All records 

 

 
 

Once an option is selected, that option will be used each time the Customers screen is opened. 

The Top records option is specific to each POS Terminal/Back Office and applies to all users. 

If a user toggles the Top N records option on a terminal, that selection will apply to that terminal for all users of that 

terminal, and the chosen option is persistent, even after restarting Idealpos on the terminal. 
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Export Data 

IP-5343 – Export Stock Item Sales – Option to export every x minutes 

This function adds the ability to Export Stock Item Sales every x minutes, where x is a configurable number of minutes 

that can be customised as required. 

When Stock Item Sales are exported every x minutes, Idealpos will export the Stock Item Sales that have occurred 

between the previous Stock Item Sales Export and the number of minutes interval that has been set.  

If no Stock Item Sales took place between the previous export and the number of minutes configured in this function, 

then no data will be exported. Once Stock Item Sales have taken place, the Stock Item Sales data will be exported at 

the next interval, as configured in this function. 

 

To configure and use this function, go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify. 

 

Within the Import/Export tab, configure the following settings under the Automatic Export Settings section: 

Export Folder: Enter the folder location to where the data should be exported. 

Export Sales Format: Specify a Sales Format from the dropdown list. Available options include Standard Stock Item 

Sales, Impact Data, Live ExternalSales.mdb, TimeTarget, iKnow, Deputy, Tanda, Nielsen or Generic. 

Sales From: Specify where the sales should be exported from. Available options include All POS Terminals, This POS 

Only or This Site Only. 

Export Daily at [daily time in 24 hour format] or every x minutes. If using the export every x minutes, ensure that the 

export daily at is set to blank, or if using export every x minutes, ensure export daily at is set to blank. 
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Once configured, close the POS Terminal configuration windows. 

The Sales Export will be performed at the number of minutes interval configured and the data will be exported to the 

Export Folder configured. 

The below examples show two sets of sales data that was exported at the configured interval of 5 minutes, as 

configured on the previous page. 

 

 
 

 
 

The below shows the folder where the data was exported (C:\Export\) as configured on the previous page. 
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Gaming 

IP-5248 – Gaming – Enable/Disable Customer Type Discounts by Points Bucket 

This function enables the enabling or disabling of Customer Type Discounts by the Points Bucket. 

This function is available when using the following Gaming Integrations: 

• MaxGaming 

• eBet 

• Aristocrat 

• Konami 

 

Refer to the Gaming Integration in use at the venue for further details about using and configuring the Gaming 

Points/Customer Type Discounts for each Gaming Points Bucket. 

 

This function is configured by going to: Back Office > Setup > Global Options > Gaming 
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Some Gaming Integrations (such as Aristocrat or eBet) allow Gaming Override options to be configured. 

The Gaming Override options also contain the ability to toggle Customer Type Discounts for each Points Bucket. 

 

Go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Miscellaneous Options > Gaming 

Override Options: 
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Global Options 

IP-5365 – eCommerce – Option to play Alert Sound every X minutes 

This function adds the ability to play an Alert Sound every X minutes (where X is the number of minutes that can be 

customised, with 5 minutes being the default interval). The Alert Sound will be repeated at the interval configured 

whilst there are any eCommerce Orders which have not been processed or finalised. 

 

To configure and use this function, go to: 

Back Office > Setup > Global Options > Interfaces > eCommerce 

 

Ensure that a sound file is specified in the field ‘Play Sound when Orders Arrive’. 

Set the ‘Repeat Sound every # minutes’ to a value that suits your requirements. 

 

 
 

If the repetition of the Alert Sound every X minutes is not required, set the value to blank or 0. 
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When an eCommerce order arrives, the specified sound file will play, and if the repeat sound option has been 

configured, the sound will be repeated as per the number of minutes which have been configured (the sound will 

repeat whilst there are pending Web Orders which have not been processed or finalised).  
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To stop the sound from repeating, finalise each Web Order (press the Web Orders button at the top of the POS 

Screen, select the Web Order > Finalise and repeat until each Web Order has been finalised):. 
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After all Web Orders have been finalised, the Web Orders button will be cleared from the top of the POS Screen, and 

the sound will no longer repeat. 
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POS Screen 

IP-5084 – POS Screen Support for 1920 x 1280 Resolution 

This function adds support for a POS Screen Resolution of 1920x1280 at either 125% or 150% scaling.  

This resolution is utilised by some devices (such as the Surface Go 3) and this resolution is now available in Idealpos.  

 

To configure and use this resolution, go to:  

Back Office > Setup > POS Terminals > Select the POS Terminal > Modify. 

Within the POS Settings tab > POS Screen section, set the Resolution to one of the following options:  

1920 x 1280 (3:2 @ 125%) 

1920 x 1280 (3:2 @ 150%) 
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To check and set the scaling in Windows (Windows 10 or Windows 11): 

Right-click on the Windows desktop > Select ‘Display Settings’. 

Scroll down to ‘Scale & Layout’ – The current scaling settings that are in use and the recommended scale setting for 

the current screen resolution and screen size will appear; if required, the scale option can be changed. 

Any changes to the scaling options will require the user to Sign Out/Log out of Windows and log back in again.  

 

Windows 11: 

 
 

Windows 10: 
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The below example shows Idealpos running at 1920x1280 (125% scaling): 

 

 
 

The below example shows Idealpos running at 1920x1280 (150% scaling): 
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IP-5261 – POSTEC Integration – POS Screen support for 1920x1080 Resolution 

This function adds support for the 1920x1080 POS Screen Resolution to be used with the POSTEC Fuel Integration. 

When the POSTEC Integration is enabled and the POS Screen Resolution is set to 1920x1080, all elements of the POS 

Screen will now be visible. Attempting to use the 1920x1080 POS Screen Resolution with POSTEC on previous builds of 

Idealpos would result in essential elements of the POS Screen UI being cut off/appearing off the screen. 

 

To use this function, go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > POS Settings. 

Select the 1920x1080 resolution. 

Note – The Retail layout is not supported. 

Also note that when using this resolution with POSTEC, not all POS Screen tabs will be available due to the reserved 

screen real-estate that is required for the POSTEC interface (which will also be displayed on-screen at the same time as 

the Idealpos POS Screen interface). Additional configuration to the POS Screen layout will be required so that all 

required functions/tabs will be accessible from the POS Screen. 
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IP-5290 – Web Page Function 

This function adds the ability to create a POS Screen button that will open a Web Page when pressed. 

The Web Page types available are as follows: 

• Idealpos User Guide – The Idealpos User Guide will be displayed when the button is pressed. 

• eCommerce Order Feed –  

• Custom – When this option is selected, a URL field will be displayed when configuring the button. The website 

address entered in the URL field will be displayed when the button is pressed. 

 

Any web page that is opened via the POS Screen using this function will be displayed within the Idealpos embedded 

web browser window; the browser window does not contain any navigational buttons (e.g. no refresh, back or forward 

buttons, nor does it contain a web address field). This will prevent staff from using the Web Browser function to 

browse various web sites except for the site(s) specified within each Web Page POS Screen Button. 

 

To prevent unauthorised clerks from using the Web Page function, access can be restricted via Clerk Permissions (Back 

Office > Setup > Clerks > Select Clerk > Permissions > Clerk Permissions > POS > Web Page). 

 

To configure and use this function, go to: 

Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

Select an unused/blank button on the desired POS Screen tab and configure as follows: 
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Depending on the Web Page Type that is selected, different configuration options will be available. 

 

 
 
When the button is pressed, this function will open the Idealpos User Guide: 
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When this function is fully configured and the button is pressed, the eCommerce Orders Feed will be displayed: 
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When this function is configured to open a website (e.g. https://www.idealpos.com.au) and the button is pressed, the 

website specified in the URL field will be displayed. 

 

 
  

https://www.idealpos.com.au/
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If access to the Web Page function needs to be restricted, this can be done via Clerk Permissions. 

Go to: Back Office > Setup > Clerks > Select a Clerk > Permissions. 

 

 
 

Toggle the Web Page function as required. 

Note that the Web Page function can also be toggled via User Permissions (Back Office > Setup > Users > Select a 

User > Modify > Clerk Permissions > POS > Web Page).  

If the Web Page function has been disabled for a User, it will also be disabled for all Clerks linked to the User, 

regardless of whether the Clerk has the Web Page function enabled or not.  
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Restaurant & Table Map 

IP-1740 – Ability to Print Seat Bill for Partial Items 

This function enables the ability to Print Seat Bills for Partial Items.  

I.e. from the Table Details screen > Select a partial payment option > Select Items on the Table Details screen > Print 

Bill > Enter Seat Number > Print. 

On previous builds and versions of Idealpos, when performing the above sequence of steps to print a seat bill for 

Partial Items, a prompt ‘Cannot Print Seat Bill for Partial items” would appear, preventing this action from being 

performed. 

This functionality is now available. 

 

This function requires the Restaurant Module enabled in the Licence Gateway and also requires that the POSServer to 

be configured. For further details about configuring POSServer, refer to the POSServer topic in the User Guide. 

For further details about the Restaurant functionality, refer to the Restaurant & Table Map topic in the User Guide. 

To use this function, go to:  

POS Screen > Add Items to sale > Table Map > Select a table > Enter number of Guests if prompted. 

Select the Table from the Table Map and press ‘Details’. 

 

 
  

https://userguide.idealpos.com.au/#POSServer/POSServer.htm
https://userguide.idealpos.com.au/#Restaurant%20and%20Table%20Map/Restaurant%20Table%20Map.htm
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Select the portion for the bill > select the Stock Items > press ‘Print Bill’. 

In this example, the ½ payment option has been selected. 
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The Seat Selection prompt will appear. 

Enter the Guest’s Seat Number > Print. 
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The bill will be printed for the partial payment items: 
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The items will remain selected on the Table Details screen using the partial payment amount so that the Clerk can then 

press the ‘Pay’ button to process the payment for those items. 
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Press ‘Pay’ > The Items are added to the sale screen. 
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Press Enter > Select a Tender Type > The items are partially paid > The Table Details screen is displayed so payments 

can continue to be taken for the outstanding items/amounts on the table. 

The Outstanding amount on the partially paid items has been updated based on the partial payment that was just 

processed. 
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Stock Items 

IP-4538 – Stock Item Variants – Ability to create Indirect Items 

This function adds the ability to create Indirect Stock Items through the Stock Item Variants functionality. 

This enhancement is primarily targeted towards hospitality venues that source alcohol from kegs and sell to their 

customers in Jugs, Pints, Pots or Schooners. 

When using this function, the Keg Stock Item will be the parent item, and each of the tap sizes (Jugs, Pints, Pots, 

Schooners, etc.) will be created as the indirect variant items. The indirect variant items will be created using the indirect 

quantity that makes up the tap size, and the cost of each tap size will be displayed within each tap size item.  

By using this function, the amount of time required to create each of the tap sizes and indirect quantities will be 

greatly reduced.  

 

To configure and use this function, go to:  

Back Office > File > Sales > Stock Item Variants 

 

Beer Kegs will be used to demonstrate this function. 

Select ‘Add New Variant Type’ > Enter ‘Beer Tap Size’ as the Variant Type name > Either press ‘Enter’ or ‘Save’. 
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Select ‘Add New Beer Tap Size’ 
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Add the following Beer Tap Sizes – these sizes can be modified as per the sizes and Indirect Quantities used at the 

venue: 

 

Beer Tap Size Abbreviation Indirect Indirect Quantity 

JUG JUG Yes/Enable Checkbox 1140/49500 

PINT PINT Yes/Enable Checkbox 570/49500 

POT POT Yes/Enable Checkbox 285/49500 

SCHOONER SCH Yes/Enable Checkbox 485/49500 

 

When entering multiple Beer Tap Sizes, start by entering the Beer Tab Size into the Beer Tap Size field, then use the 

Tab key on the keyboard to cycle through each field. After populating all the fields for a Beer Tap Size, the ENTER 

button can be pressed on the keyboard which will add the Beer Tap Size and clear the fields, ready for the entry of the 

next Beer Tap Size. Repeat this process until each required Beer Tap Size has been created. 
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After entering each Beer Tap Size, the sizes will appear in the list, like the below example: 
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Close the Stock Item Variants window, then go to: Back Office > File > Stock Control > Stock Items. 

 

Select an existing Beer Keg Stock Item, ensuring that Stock Items for each Beer Tap Size (Jug, Pint, Pot, Schooner, etc.) 

for that variety of Beer do not already exist (the process outlined below will demonstrate the creation of those Beer 

Tap Size items via the Variants functionality). 

Alternatively, create a new Beer Keg Stock Item via the ‘Add’ button. 

The process outlined below demonstrates the creation of a new Keg Stock Item and the creation of the Beer Tap Size 

items. 

 

Create a new Stock Item and enter a Description/Kitchen Description/Long Description for the Beer Keg Stock Item. 

E.g. ACME BEER KEG 

Note that when entering the Description for the Beer Keg Stock Item, the item should end with the word Keg or KEG. 

This will then ensure that when the variant items for each Beer Tap Size are created, the word ‘Keg’ will be omitted 

from the resulting child or variant items (the resulting variant or child items will contain the Beer Tap Size in place of 

the word ‘Keg’). 

When creating the main Beer Keg Stock Item, ensure that a Cost Price has been entered and set the Department and 

Purchase Category as required. If required, Sell Prices can also be entered for the Beer Keg Stock Item. 

Enter and set any other fields for the item as required. 
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After the required details have been entered for the Keg Stock Item, enable the ‘Has Variants’ checkbox, then click on 

the ‘Variants’ tab. 
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Clicking on the Variants tab will automatically save the Keg Stock Item. 

Within the Variants tab, select the Beer Tap Size option from the Variant Type dropdown box. 
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To create all Beer Tap Sizes for this variety of Keg Beer, enable the checkbox next to the Beer Tap Size dropdown box. 

If only specific Beer Tap Sizes are required, select the individual Beer Tap Size checkboxes instead. 
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After enabling the checkbox(es), each Beer Tap Size will be displayed. 

At this point, the Department of each Beer Tap Size can be specified as well as the Sell Prices for each Price Level.  

The Department will be pre-populated using the Department of the Beer Keg Stock Item. 

The Sell Prices for each Price Level can be entered, or the ‘Inherit Prices from Parent’ option can be selected which will 

automatically set the Prices for each Beer Tap Size using the Sell Prices from the Beer Keg Stock Item. 

If the option ‘Inherit Prices from Parent’ is enabled, all Sell Price Levels will be hidden. 

On widescreen monitors, Sell Prices can be viewed with the Beer Tap Size Description without the need to scroll.  

Lower resolutions may require horizontal scrolling to see the Sell Price Levels. 
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After the required Sell Prices for each Price Level have been entered, press the ‘Create New Variants’ button. 

It should also be noted that prior to pressing the ‘Create New Variants’ button, the Stock Item Description prefix that 

will be used to create the new Beer Tap Size items can be modified if required. 

As noted earlier above, the word ‘KEG’ is automatically omitted, which is evident in the field next to the ‘New Variants 

of’ text. This Description can be modified if required and the text entered here will be used as the basis for the 

descriptions of the new Beer Tap Size Stock Items. 

 

 
 

A confirmation prompt is displayed showing the number of Variants that will be created. 

Press ‘Yes’ to proceed. 
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A confirmation prompt is displayed after the variants have been created. 

Press ‘OK’ to continue. 
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Close the Beer Keg Stock Item via the ‘X’ on the top-right corner of the window. 

The newly created Beer Keg Stock Item will be highlighted on the Stock Items grid. 

Press the dropdown arrow within the Keg Stock Item’s Description field.  
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This will filter the Stock Items grid so that the only Stock Items displayed will be the Keg Stock Item and the child 

variant Stock Items (i.e. the Beer Tap Sizes for the Beer Keg Stock Item) associated with the Keg Stock Item.  
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Select one of the child items (e.g. ACME BEER POT, ACME BEER SCH, ACME BEER PINT or ACME BEER JUG) and press 

‘Modify’. 

Each of the created items are Indirect, and the Cost Price displayed is calculated based on the quantity taken from the 

Keg Stock Item and the Cost Price of the Keg Stock Item. 

Note that additional modifications may be required for each variant item, such as Kitchen Printer settings, Attributes 

and/or any other required values. 
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The Indirect Item tab will also show the quantity that is taken from the Keg Stock Item, along with the Standard Cost, 

Last Cost and Average Cost based on the quantity. 
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IP-5266 – Stock Items – Print Label from within Add/Modify Screen 

This function adds the ability to print a label for the Stock Item from within the Add/Modify Stock Item screen. 

This is done via a new ‘Print Label’ button on the left-hand side of the Add/Modify Stock Item screen; the ‘Print Label’ 

button will only appear when one or more Label Formats have been configured and saved. 

 

To configure and use this function, go to: Back Office > Utilities > Labels 

Ensure that there are one or more Label Formats which appear in the Format dropdown box. 

If there are no Label Formats saved, the Format dropdown box will appear as blank (as shown in the example below): 
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To add a new Label Format, configure the Label Format options as required, enter a name for the Format, then press 

the ‘Save Format As’ button. 

 

 
 

The Label Format Saved prompt is displayed – Press OK. 
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The Format now appears in the Format dropdown box. 
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Close the Labels window, then go to: Back Office > File > Stock Control > Stock Items. 

Select a Stock Item > Modify. 

The ‘Print Label’ button will appear on the left-hand side of the Modify Stock Item window. 
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If more than 1 Label Format exists, the Description of the Label Format will appear in light-grey below the Print Label 

button.  
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To change the Label Format type, click on the light-grey Label Description and a dropdown box will appear, where the 

desired Label Format can be selected. 

 

 
 

Pressing the ‘Print Label’ button will immediately print a label for the currently displayed Stock Item (using the 

currently selected Print Format, or if only one Print Format exists, that single Print Format will be used to Print Labels). 
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IP-5282 – Customers/Stock Items – Top N Records Functionality 

This function limits the number of records (to the top 50 records by default) that are displayed when opening the 

Stock Items function via Back Office > File > Stock Control > Stock Items. The top number of records that are 

displayed can be toggled between Top 50 records, Top 1000 records, or All records. 

By selecting a smaller number of top Stock Item records to display, the amount of time it takes to open the Stock 

Items screen will be greatly reduced. 

When the Top N records function is actively restricting the number of records displayed, a note will appear and will 

specify the number of records currently being shown (e.g. Top 50 records, Top 1000 records). 

 

 
 

If all records are being displayed, the ‘Top’ text will be omitted and the total number of records will be listed, as shown 

below: 

 

 
 

Note that when the number of records is limited to a smaller sample, the search and filter function on the Stock Items 

screen is not affected; if one or more Stock Items exists which match the entered search criteria, the Stock Items will be 

displayed in the filtered search results. 

 

On the top-left corner of the window, select from the following options to toggle the number of records to display: 

• Top 50 records 

• Top 1000 records 

• All records 

 

 
 

Once an option is selected, that option will be used each time the Stock Items screen is opened. The top records 

option is specific to each POS Terminal/Back Office and applies to all users. 

If a user toggles the Top N records option on a terminal, that selection will apply to that terminal for all users of that 

terminal, and the chosen option is persistent, even after restarting Idealpos on the terminal.  
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IP-5301 – Stock Item Modify Screen – Previous/Next/Search Item Functionality 

This function adds the ability to navigate between the Previous and Next Stock Item whilst modifying a Stock Item.  

The previous button will display the previous Stock Item’s description and the next button will display the next Stock 

Item’s description.  

Pressing either of these navigational buttons will switch the Modify Stock Item screen to display the Stock Item. 

The Previous/Next Stock Item buttons are relative to the current Stock Item’s position on the Stock Items grid.  

If the Stock Items grid was filtered/sorted before the currently displayed item was opened for modification, that filter 

or sort order will influence the Stock Items shown on the Previous/Next Item buttons. 

Also note that the Previous/Next Item/Search buttons are only visible when modifying an existing Stock Item. 

When creating a new Stock Item, the Previous/Next/Search functions will be hidden. 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

Select a Stock Item for modification and press the ‘Modify’ button. 

Alternatively, double-click on a Stock Item to open it for modification. 
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After opening the item, the top-right corner of the Modify Stock Item window will display the Previous/Next/Search 

functions. 
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Pressing the ‘<<<’ button will switch the Modify Stock Item window to the previous item. 
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Pressing the ‘>>>’ button will switch the Modify Stock Item window to the next item. 
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The Search function can also be used to switch to another item. 

Click into the search field which appears between the ‘<<<’ and ‘>>>’ buttons, then enter a Stock Item Description to 

search. 

A list of suggested items will appear as the search term is being entered. 

 

 
 

Once the desired Stock Item appears in the list of suggested Stock Items, click on it. 

Alternatively, a Stock Item’s Stock Code can be entered into the search field, followed by pressing the ENTER button.  

This will open the Stock Item for modification. 

 

 
 

The Modify Stock Item window will display the selected Stock Item. 

Note that the Modify Stock Item window screenshot shown below has been cropped for documentation purposes. 

The full Modify Stock Item window will be displayed when opening a Stock Item for modifying using the search 

method outlined above. 

 

 
 
If a Stock Item’s Scan Code or Alternate Codes are known, the code can be entered into the Search field, followed by 
pressing the ENTER button. The Stock Item that matches the entered Scan Code/Alternate Code will be displayed.  
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If the Previous/Next or Search functions are used to switch to another Stock Item and the current Stock Item contains 

any unsaved changes, the changes will be saved automatically and the Previous/Next or Searched item will be 

displayed. 

If the unsaved changes include changes to the Descriptions of the item, the ‘Update Button Captions, Kitchen 

Description, Menu Items and Supplier Links’ prompt will be displayed. 
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Stock Purchases  

IP-5304 – Stock Purchases – Colour Highlight Unit Cost variations 

This function will highlight any Unit Cost variations using one of three different colour highlights. 

The colour highlight used to display the Unit Cost is based on the comparison between the Unit Cost that has been 

entered into the Stock Purchase/Stock Receive and the Last Cost of the Stock Item. 

 

The following outlines the different colours and the trigger to display those colours: 

 

• The Unit Cost Price entered in Purchase/Receive is equal to Last Cost = No Colour Highlight is used. 

• The Unit Cost Price entered in Purchase/Receive is less than Last Cost = Unit Cost is highlighted in green. 

• The Unit Cost Price entered in Purchase/Receive is greater than Last Cost = Unit Cost is highlighted in red. 

 

 

There is no additional configuration required to enable this function; it is hard coded to always highlight the Unit Cost 

Price based on the dot points outlined above. 

 

To use this function, go to: Back Office > Transactions > Stock Control > Stock Purchases > Add 

Purchase Type: Stock Received/Purchase Order 

Supplier: Select Supplier 

 

Add the required Stock Items to the Stock Receive/Purchase Order and update the Unit Cost as required. 

If the Unit Cost Price is less than Last Cost, Unit Cost will be highlighted in green.  

If the Unit Cost Price is greater than Last Cost, Unit Cost will be highlighted in red 

If the Unit Cost Price is equal to the Last Cost Price, the Unit Cost will not be highlighted. 

To demonstrate the different highlight colours in a Purchase Order, each of the following items have had their Last 

Cost Price set to 0.8100 [via File > Stock Control > Stock Items > Modify each Stock Item] and their Unit Cost Prices 

have been entered as follows (for simplicity, the Tax Inc option was unchecked):  

COKE 2L – Unit Cost 0.81 [No highlight as this Unit Cost Price is the same as the Last Cost] 

SPRITE 2L – Unit Cost 0.82 [Red highlight as this Unit Cost Price is greater than the Last Cost] 

FANTA 2L – Unit Cost 0.80 [Green highlight as this Unit Cost Price is less than the Last Cost] 
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IP-5305 – Stock Purchases – Import Custom CSV Formats by Supplier 

This function adds the ability to import a Custom CSV Format Invoice for each Supplier. 

This is achieved via the Import option in Idealpos Stock Purchases by selecting the Supplier, then selecting a CSV file 

from that supplier. 

Each column in the Supplier Invoice then needs to be mapped to the corresponding Idealpos field. 

Once this process has been completed and the defaults saved for that Supplier, any future invoices imported from that 

same Supplier will use the saved mapping. 

As each Supplier will have their own Invoice Format, this process must be repeated for each Supplier and their 

respective Invoice Format, ensuring that defaults are saved after completing the mapping process for each Supplier. 

From that point on, when an Invoice is imported from a Supplier, the required fields in the Supplier’s Invoice Format 

will be mapped correctly, enabling Idealpos to successfully import the Invoice and extract the required data from the 

Invoice to create and update the Stock Items included in the Invoice. 

 

To use this function, go to: Back Office > File > Suppliers > Suppliers. 

Select the Supplier > Modify. 

Alternatively, create a new Supplier by pressing ‘Add’ > Enter Supplier Details. 

 

Whether modifying or creating a new Supplier, ensure that the settings are configured as follows: 

Default Tax Rate – Set the tax rate according to the Supplier. 

Electronic Invoice Format – (None). This must be set to None to Import Custom CSV Formats by Supplier. 

 

Once configured accordingly, press ‘Save’ on the top-left corner of the window to save the Supplier then close the 

Supplier windows. 
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Go to: Back Office > Transactions > Stock Control > Stock Purchases. 

Select ‘Import’. 
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Press ‘>’ in the Supplier field to select a Supplier. 

 

 
 

Select a Supplier from the list > OK. 
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Press ‘Select Import File’. 

 

 
 

Browse to the folder location and select the Invoice > Open. 
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The Invoice is displayed in the Import Invoices window. 
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If required, enable the ‘Add New Stock Items’ option.  

This will trigger Idealpos to Add New Stock Items from the Invoice that don’t already exist in your system. 

When enabling ‘Add New Stock Items’, the following options will need to be configured: 

 

Department – Stock Items that are added will be linked to the specified Department. Press the ‘>’ button in this field 

to display a list of Departments and select the Department to link to new Stock Items created during the Invoice 

Import. 

New Item Codes – Three options are available as follows. 

Auto Create – Stock Item Codes are automatically created for each new item that is added. 

Supplier’s Code – Each new Stock Item that is added will use the Supplier’s Code from the Invoice. 

Supplier’s Code + Suffix – Each new Stock Item that is added will use the Supplier’s Code from the Invoice and the 

Suffix that is entered into the Suffix field (when this option is selected, a Suffix field will appear to the right-side of the 

dropdown box where a custom Suffix can be entered). 

 

Sell Price – Thirteen options are available (All Price Levels, or select from one of the twelve Price Levels). This option 

will specify which Price Levels are to be populated with the Stock Item’s Sell Price.  

Note that Invoices can only specify a single Sell Price for each Stock Item, which means if ‘All Price Levels’ are selected, 

all Price Levels will be populated with the same Sell Price.  
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Each field/column in the Invoice must be mapped to an Idealpos field. 

Each column on the first row of the Invoice will display ‘Unmapped’. 

To map the values in each column, click on the ‘Unmapped’ text and a dropdown list will be displayed. 

Select the option which corresponds to the data that appears in that column below.   

Note that not all fields in a Supplier Invoice will be supported or required by Idealpos. 

In such cases, select the ‘Skip Field’ option. 

 

 
 

When skipping a field, the contents of the column will appear as greyed out and the header will display ‘Skip Field’. 
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Ensure that each column in the Invoice is mapped according to the data that appears in the column. 

Once completed, press the ‘Save Defaults’ option on the top-left corner of the Import Invoices window. 

 

 
 

A ‘Defaults Saved’ prompt will appear to confirm that the Defaults were saved successfully > Press ‘OK’. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 11 - Update History Page 68 of 83 

 

The next time this Supplier is chosen, and an Invoice file selected, the field mappings will be used to link the Invoice 

fields to the Idealpos fields, enabling the data to import correctly. 

 

Select the ‘Import’ button on the top-left corner of the Import Invoices window to Import the Invoice into Idealpos. 

 

 
 

During the Import process, a light orange progress bar will appear within the Invoice Filename button. 
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After the Import has been completed, the Import Invoices window will close, and the Stock Purchases window will 

appear, displaying the newly imported Invoice. 
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Select ‘Modify’ to view the Invoice details and make any required changes. 

 

 
 

Any new items which have been created will have the Unit Cost highlighted in purple. 

 

 
 

An Invoice Number can be manually entered into the ‘Invoice No’ field and any other changes made as required. 

Press ‘Save’ to save any changes made. 
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Ensure that the Invoice is selected/highlighted, then process the Invoice by pressing the ‘Process’ button on the 

bottom-right corner. 

 

 
 

Once processed, the Invoice listing will disappear from the Stock Purchases. 
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The Stock Items from the Invoice have been imported and linked to the Department that was configured during the 

Invoice field mapping process. 
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IP-5332 – Stock Purchases – Live Updating of Sell Price and Department 

This function enables the ability to perform live updating of each Stock Item’s Sell Price and Department whilst in the 

Stock Purchases screen. Prior to using this function, the desired Price Level will need to be configured; the selected 

Price Level will then be displayed in a column in the Stock Purchases screen next to each Stock Item in the Stock 

Purchase. 

 

To configure and use this function, go to: Back Office > Setup > Global Options > Purchases. 

Within the Miscellaneous section, ensure that the ‘Live Stock Updating’ checkbox is enabled, then select the required 

Price Level from the dropdown box. 

If this functionality is not required, uncheck the ‘Live Stock Updating’ checkbox; the Department, Sell Price and Profit 

Margin columns will be hidden in the Stock Purchases function. 
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Go to: Back Office > Transactions > Stock Control > Stock Purchases. 

Select an existing Stock Purchase/Stock Receive, or press ‘Add’ to create a new Stock Purchase/Stock Receive. 

 

The Department, Sell Price and Profit Margin % columns will be displayed on the right-hand side of each row. 
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Select the required Supplier, enter the Purchase Order No, Invoice No, Details, etc., then add the required Stock Items 

to the Stock Purchase Order/Receive. 

The Department, Sell Price and Profit Margin columns will contain the relevant details for each Stock Item in the Stock 

Receive/Purchase Order. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 11 - Update History Page 76 of 83 

 

To modify a Stock Item’s Department, click into the Department field for the required item, then press the dropdown 

arrow. 
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The Department list will be displayed; select the Department for the Stock Item then press ‘OK’.  

If required, the Search function (top-left corner) can be used to filter the list of Departments that are displayed. 
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The Stock Item’s Department is updated on-the-fly, and the change is replicated immediately to all networked POS 

Terminals. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 11 - Update History Page 79 of 83 

 

The Stock Item’s Sell Price can also be modified in a similar manner. 

Click into the Sell Price field of a Stock Item, modify the Sell Price as required, then click into another field to save the 

change. 

 

 
 

After making a change to a Stock Item’s Sell Price, the Profit Margin % will be calculated automatically based on the 

change. The change to the Stock Item’s Sell Price will be replicated immediately to all networked POS Terminals. 

Any changes to a Stock Item’s Sell Price will also be reflected in the Price Changes Report. 

The Price Changes Report is available via Back Office > Reports > Stock Control > Price Changes. 
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Taxes 

IP-5372 – Tax Shift Exemption by Stock Item 

This function is only applicable to regions that support multiple Tax Rates (such as USA, Canada, etc.). 

This function enables the ability to configure specific Stock Items so that they are exempt from the Tax Shift function. 

The Tax Shift function is used via a button on the POS Screen which will toggle a specific Tax Rate on/off and any 

items that are added to the sale after the button is pressed will have their Tax Rates shifted (according to the Tax Rate 

configured within the Tax Shift button). 

When this Tax Shift Exemption function has been configured on one or more Stock Items (and those items are added 

to a sale), pressing the Tax Shift button will not have any effect on those exempt items, and the Tax Rates that were set 

within those exempted items will essentially be locked in and enforced. 

 

To configure and use this function, go to: 

Back Office > File > Stock Control > Stock Items. 

Select a Stock Item that requires the Tax Shift Exemption and Modify the Stock Item. 

In the Advanced Tab > Sales Prompt, enter #NOTAXSHIFT# (as shown in the example below). 

Press ‘Save’ to save the change to the item and repeat the process for any other Stock Items that require the No Tax 

Shift function. 
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Any Stock Items that have the #NOTAXSHIFT# function configured will essentially be locked into using the Tax 

Settings that are configured in the Stock Item’s General tab and the Tax Shift button will not toggle the Tax Settings 

for #NOTAXSHIFT# items. 
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Tax Rates and Descriptions are configured in Back Office > Setup > Global Options > Sales. 

 

 
 

Ensure that a Tax Shift button exists on the POS Screen so that the Tax Shift can be toggled. 

Go to: Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 

Select a POS Screen Tab to create the Tax Shift button, locate a blank/unused button and configure as follows: 

 

Automatic Text: Enter a number between 1 and 6 which corresponds to the number of the Tax Rate that will be 

shifted (looking at the Global Options – Sales screenshot above, 1 corresponds to the 1st Tax Rate (GST), 2 corresponds 

to the 2nd Tax Rate (PST) and so on). 

Button Caption: Enter a caption to make the button’s function recognisable. 

 

Customise the button’s Font, Colour, Text Colour, etc. as required, then press ‘Save’ to save the button. 
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To demonstrate this function, go to: POS Screen. 

From the POS Screen, press the Tax Shift button. 

The sale window on the POS Screen will show ‘Toggle TAX – [TaxRateDescription]’, where [TaxRateDescription] is the 

Description of the Tax Rate being toggled by the button. 

 

 
 

Add the Stock Items to the sale. 

Stock Items which have the #NOTAXSHIFT# option configured will be unaffected by the Tax Shift button/function. 

E.g. In the below example, both Cappuccino and Flat White have Tax Rates 1 (GST) and 2 (PST) enabled. 

However, Cappuccino has the #NOTAXSHIFT# function configured, whereas Flat White does not. 

Cappuccino’s Tax Rates of 1 and 2 will remain enabled (as shown in the bracket next to the Stock Item in the sale 

window). 

Flat White’s Tax Rate 1 will be shifted to off, leaving only Tax Rate 2 enabled for Flat White (as the Flat White Stock 

Item did not have the #NOTAXSHIFT# function configured). 

 

 


