
    Update History 
 

Idealpos 9 Build 12 - Update History  

Update Details: 

FUEL CONSOLE .............................................................................................................................................................. 2 

IP-7461 – ENABLER FUEL INTERFACE – PAUSE/UNBLOCK ALL PUMPS FUNCTIONALITY..................................................................................... 2 
IP-7506 – ENABLER FUEL INTERFACE – PRINT DOCKET AFTER CHANGING FUEL PRICES ..................................................................................... 3 

KIOSK .......................................................................................................................................................................... 4 

IP-7474 – KIOSK – OPTION FOR EXTRA-LARGE BUTTONS ........................................................................................................................... 4 

LABELS ......................................................................................................................................................................... 7 

IP-7473 – STOCK ITEM LABELS – NEW FORMAT 3 FOR 3X11 SIZE A4 LABELS ................................................................................................ 7 

LISTINGS ...................................................................................................................................................................... 9 

IP-7500 – GRIDS LISTING – SHOW STOCK ITEM DESCRIPTION AND DEFAULT PRICE ......................................................................................... 9 

METCASH INTEGRATION .............................................................................................................................................. 10 

IP-7502 – METCASH INTERFACE – SUPPLIER SEARCH FILTER ON PRODUCT LINKING SCREEN ........................................................................... 10 
IP-7503 – METCASH INTERFACE – UNLINKED ITEMS OPTION ON PRODUCT LINKING SCREEN .......................................................................... 11 

PENDING SALES .......................................................................................................................................................... 12 

IP-7451 – PENDING SALE A4 PRINT – INCLUDES TAX AMOUNTS ............................................................................................................... 12 

STOCK PURCHASES ...................................................................................................................................................... 17 

IP-7486 – PURCHASE ORDER – ITEM HISTORY VIEW INCREASED TO 12 PERIODS .......................................................................................... 17 

 

 

 

  



    Update History 
Return to top 

Idealpos 9 Build 12 - Update History Page 2 of 17 

 

Fuel Console 

IP-7461 – Enabler Fuel Interface – Pause/Unblock All Pumps functionality 

This functionality introduces the ability to Pause All/Unblock All Pumps when using the Enabler Fuel Interface. 

The Pause All functionality can be used in emergencies when fuel needs to be paused on all fuel pumps. 

When the situation is safe, the Unblock All functionality can be used to unblock all pumps to resume fuel delivery. 

 

To use this functionality, go to: POS Screen > On the top-right corner of the Fuel pump section, press the cog icon. 

 

 
 

A menu will appear with the following options: 

• X – This option will close the Pause All/Unblock All menu. 

• Pause All – This option will pause all fuel pumps, immediately stopping fuel from being pumped/dispensed 

from every pump. 

• Unblock All – This option will unblock all fuel pumps, enabling fuel delivery to resume. 

 

 
 

After pressing the “Pause All” option, the following prompt will appear; Press “Yes” to Pause All Pumps. 

 

 
 

After all pumps have been paused, all active pumps will be displayed with red nozzle symbols. 

 

 
 

When Pausing All Pumps, if any pumps were not actively in use, they will appear as red lock symbols. 

 

 
 

To Unblock All, select the cog icon on the top-right corner and press “Unblock All”.  

Fuel delivery will be resumed to all active pumps. 
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IP-7506 – Enabler Fuel Interface – Print Docket after changing Fuel Prices 

This functionality will trigger a docket to be printed after changing Fuel Prices using the Change Live Fuel Prices 

functionality that was introduced in Idealpos v9 Build 11. 

 

 
 

After the Fuel Prices are changed using the above function, a docket will be printed with the following information: 

 

• Clerk Code/Name – This will show the Clerk Code and Name of the Clerk which was logged into the POS 

when the Fuel Price Change was completed. 

• POS Code – This will show the POS Terminal Number which actioned the Fuel Price Change. 

• Date/Time – This will show the Date and Time which the Fuel Price Change was completed. 

• Fuel Grades – A list of all Fuel Grades which had their prices changed will be displayed. 

• Old/New Prices – The old and new fuel prices will be displayed next to each Fuel Grade. 

• Signed – The signature of the Clerk which performed the Fuel Price Change can be signed on the docket for 

record keeping purposes. 

 

An example of a Fuel Price Change Docket is shown below: 
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Kiosk 

IP-7474 – Kiosk – Option for Extra-Large Buttons 

This function introduces the ability to enable extra large buttons on the Kiosk screen. 

When this option is enabled, all Stock Item buttons on the Kiosk screen will be displayed as extra large. 

 

To configure and use this function, go to:  

Back Office > Setup > POS Terminals > Select a Kiosk Terminal > Modify > Display/Kiosk tab. 

Enable the “Extra-Large Buttons” checkbox as shown below. 

 

 
 

Close the Modify POS Terminal window. 

If there are multiple Kiosk Terminals, repeat the above step to enable the “Extra-Large Buttons” option on each Kiosk 

that requires this option to be enabled. 

After the option has been enabled, a Close Suite/Open Suite will need to be completed on the Kiosk Terminals. 

Alternatively, the Kiosk Terminals can be completely restarted which will also restart Idealpos on the Kiosk. 
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After the Kiosk has been restarted, press on the Kiosk screen to close the Home Screen Image (if a Home Screen Image 

is enabled). 

The Kiosk Stock Item buttons will be displayed as Extra-Large Buttons. 

The below example screenshots show the Extra-Large Buttons option enabled and disabled for comparison purposes: 

 

Extra-Large Buttons enabled: 
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Extra-Large Buttons disabled: 
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Labels 

IP-7473 – Stock Item Labels – New Format 3 for 3x11 Size A4 Labels 

This function introduces a new Format 3 for 3x11 Size A4 Labels. 

When using this format, the Sell Price will appear on the left-side of the Label. 

An example of a single label is shown below: 

 

 
 

To use this functionality, go to: Back Office > Utilities > Labels. 

Select the following options to use the new format: 

 

Data Type: Stock Items 

Output To: Idealpos A4 Labels 

A4 Printer: Select the desired printer 

Dimensions: 33 labels (3x11) Portrait 

Design: Format 3 

 

Configure the remaining options as required. 

Add Stock Items to the grid by using the selection criteria on the top-right corner of the Labels window > Add to Grid 

button. 

Alternatively, the “Multi Select” button can be pressed which will open the Stock Items grid; multiple Stock Items can 

be selected by holding down the CTRL button while selecting multiple items, or a range of items can be selected by 

clicking on the first item in the range, then holding down the SHIFT key and selecting the last item in the range. 

Or, the Stock Items grid can be filtered by entering search terms, then the “Select All” button can be pressed to select 

all the items that are currently displayed in the grid. 
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The Stock Item Labels using the Dimensions 33 labels (3x11) Portrait with a Format 3 will appear in the Preview: 
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Listings 

IP-7500 – Grids Listing – Show Stock Item Description and Default Price 

This functionality adds the Stock Item Description and the Stock Item’s Default Price to the Grids Listing. 

The Grids Listing produces a list of all the entries that exist in the POS Screen Grid as a listing. 

 

To access this function, go to: Back Office > Setup > POS Screen > Grids Listing. 

The Grids Listing will be produced and displayed on-screen, like the below example, which will now contain the Stock 

Item Description and the Stock Item’s Default Price: 

The newly added information is annotated in the below example: 
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Metcash Integration 

IP-7502 – Metcash Interface – Supplier Search Filter on Product Linking Screen 

This function adds a Supplier Search Filter to the Product Linking screen used for linking Idealpos Stock Items to 

Metcash Products. This can be used to find and display Stock Items that are linked to a specific Supplier as well as 

show which Supplier a Stock Item is currently linked to. 

 

There is no additional configuration required to enable the Supplier Search filter; it will appear when opening the 

Product Linking screen. 

 

To use this function, go to: Back Office > Utilities > Metcash > Product Linking > Idealpos Items. 

The Supplier field appears towards the top-centre of the screen as shown below. 

Enter a Supplier Name into the field to filter Stock Items by the entered Supplier Name. 
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IP-7503 – Metcash Interface – Unlinked Items Option on Product Linking Screen 

This function adds an Unlinked option to the Product Linking screen used for linking Idealpos Stock Items to Metcash 

Products. 

When the Unlinked option is selected, the Product Linking screen will only display Idealpos Stock Items that have their 

MSC (Metcash Standard Commodity) mapping populated but not linked to Metcash Products. 

 

Go to: Back Office > Utilities > Metcash > Product Linking > Idealpos Items tab. 

The following filter options are available at the top of the screen. 

• All Items – This option will show all Idealpos Stock Items (i.e. Items that are not linked to a Metcash Product 

or Metcash Standard Commodity, Items that are linked to Metcash Products and Items that are linked to a 

Metcash Standard Commodity). 

• Linked – This option will show all Stock Items that are linked to a Metcash Product. 

• Unlinked – This option will only show all Stock Items that are linked to a Metcash Standard Commodity (but 

not linked to a Metcash Product). Note that this option will not display Stock Items that are not linked to a 

Metcash Product or not linked to a Metcash Standard Commodity. 

 

 

 
 

The above items shown in the Idealpos Items tab with the Unlinked option only have the MSC Mapping completed 

and are not linked to a Metcash Product. 

I.e. When opening the Stock Items via:  

Back Office > File > Stock Control > Stock Items > Open/Modify the Stock Item > Other tab. 

The MSC Mapping (Department, Category, Commodity, Sub-Commodity) has been populated, but the Stock Items are 

not linked to a Metcash Product as shown in the screenshot below. 
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Pending Sales  

IP-7451 – Pending Sale A4 Print – Includes Tax Amounts 

This functionality includes Tax Amounts at the bottom of a Pending Sale A4 Print. 

The Pending Sale A4 Print supports a maximum of three Tax Amounts. 

The Tax Amounts will be displayed on the Pending Sale A4 Print when the “Inhibit Amounts on Windows Printer” 

option is disabled/unchecked in the Global Options for the Pending Sales functionality. 

 

To configure and use this functionality, go to: 

Back Office > Setup > Global Options > Sales > Pending Sales > Untick “Inhibit Amounts on Windows Printer”. 

The “Inhibit Amounts on Windows Printer” option must be disabled/unchecked for the Tax Amounts to appear at the 

bottom of the Pending Sale. 

 

 
 

 

If Pending Sales will be used in a multiple terminal environment, POSServer will need to be configured. 

Refer to the POSServer topic in the User Guide for information on how to setup POSServer. 

In addition to the above configuration, there are various options that can be configured to customise Pending Sales 

(e.g. Pending Sales From/To codes, the Company Logo, Pending Sale Messages, Pending Sale Type, Pending Sale 

Descriptor, etc.).  

These options are outlined in the User Guide within the Pending Sale Settings page. 

  

https://userguide.idealpos.com.au/Default.htm#POSServer/POSServer.htm
https://userguide.idealpos.com.au/#Pending%20Sales/Pending%20Sale%20Settings.htm
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Once Pending Sales have been configured as outlined on the previous page, the function is ready for use. 

Go to: POS Screen. 

Add items to a sale and press the “Pending Sale” button. 
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Enter the Customer’s details for the Pending Sale, then press the “Save” button. 
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From the POS Screen, press the “Pending” button while there are no items in the sale; this will display a list of Pending 

Sales. 

Select the Pending Sale from the list and press the “Windows Print” button. 

 

 
 

The Pending Sale will be printed to the Windows Printer. 

Any Tax Amounts will be shown on the bottom of the Pending Sale print. 

Note that a maximum of three Tax Amounts/Rates will appear on the bottom of the Pending Sale. 

An example of a Pending Sale with a Tax Amount is shown on the following page. 
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Stock Purchases 

IP-7486 – Purchase Order – Item History View increased to 12 periods 

This functionality increases the Item History View to show the last 12 periods for the currently selected period type 

(e.g. Days, Weeks, Months). 

Prior to this change, the Item History View only showed the last 5 periods, whereas now, the last 12 periods are shown. 

There is no additional configuration required to show the last 12 periods. 

When accessing the Stock Purchases function, the last 12 periods will be shown on the bottom-left corner of the 

window. 

 

To use this functionality, go to: Back Office > Transactions > Stock Control > Stock Purchases. 

Add/Modify a Stock Purchase/Stock Receive > Select a Stock Item in the Purchase Order/Stock Receive. 

The bottom-left corner of the window will show the last 12 periods for the selected period type (Days, Weeks or 

Months) for the currently selected Transaction Type (Sales Quantity, Write-Offs, Transfers, Purchases, Returns or 

Variances). 

 

 


