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Customer Display 

IP-5219 – Customer Display – Support for Type Text Function 

This function introduces the ability display Typed Text on the Customer Display. 

Previously, entering text into a sale via the Type Text Function would only display the text on the POS Screen and not 

on the Customer Display. 

This function is enabled by default and can be toggled on and off as required via a Yes/No Option. 

 

To configure and use this function, go to: Back Office > Setup > Yes/No Options 

Enter Search: “type text”. 

Enable/Disable the ‘Customer Display – show Type Text Lines’ as required. 
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This function also requires a Customer Display as well as a Type Text button on the POS Screen so that text can be 

typed. 

The Customer Display can be enabled via: 

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Display/Kiosk > Customer Display Screen. 

 

Resolution – Select from 800x600, 1024x768, 1280x768, 1024x600 or 1280x800.  

Display Format - Some Display Formats are not available on all resolutions. Available options are - Small Sales with 

Company Logo, Small Sales without Company Logo, Full Height Sales with Company Logo, Half Sales/Half Advertising, 

Full Screen Sales, Full Screen Advertising, Scale Compliance Format. 
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A Type Text POS Screen button can be configured by going to:  

Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 

Locate a blank/unused button on a POS Screen Tab and configure as follows, press ‘Save’ to save the change: 
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Close the POS Screen Layout > Go to Back Office > POS. 

 

Add an item to the sale > The item appears within the POS Screen sale window and Customer Display. 
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Press the POS Screen button linked to the ‘Type Text’ function. 

 

 
 

The on-screen keyboard appears. 

Enter the required text and press ‘Enter’. 
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The entered text will appear within the POS Screen sale window and Customer Display. 
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Gift Vouchers 

IP-5395 – Gift Vouchers – Ability to Edit Gift Voucher Name 

This function introduces the ability to Edit the Gift Voucher Name after the Gift Voucher has been issued to the 

customer. 

This is useful in cases where the Gift Voucher may have been made to the wrong name, or if there were any 

typographical errors made when the Gift Voucher was first sold to the customer. 

 

To use this function, go to: POS Screen > Gift Voucher Enquiry. 

From the Gift Voucher Enquiry screen, either Scan or Enter Voucher Code, or press the ‘Name Search’ button. 

In this example, we have selected the ‘Name Search’ button. 
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Enter the Customer’s Name > Select their name from the list > Press ‘Use’. 

 

 
 

The voucher details will be displayed in the ‘Gift Voucher Enquiry’ window. 

Press the ‘Edit’ button to continue. 
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The current Customer Name and Email Address for the Gift Voucher will be displayed. 

If an Email Address was not entered when the voucher was sold, the Email Address field will be blank. 
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Modify the Name and/or Email Address as required > Save. 

Note that modifying the Email Address will not trigger the voucher to be sent to the newly entered Email Address. 
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After pressing ‘Save’, the modified Name will be displayed in the Gift Voucher Enquiry window. 

 

 
 
If the customer requires the Gift Voucher to be re-emailed to them, the ‘Email’ button can be pressed. 
Any changes made to the Gift Voucher will be sent to the Customer when the voucher is Emailed to them. 
 

 
 
A confirmation prompt will be displayed with the Customer’s email address; press ‘Yes’ to continue: 
 

 
 
After the email is sent, an ‘Email Sent Successfully’ prompt will be displayed: 
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IP-4896 – Gift Vouchers – Ability to Print to Windows Printer 

This function introduces the ability to print Gift Vouchers to a Windows Printer. 

This function is available via an additional ‘Windows Print’ button on the Gift Voucher Enquiry/Redemption screens as 

well as the ability to configure Idealpos (via Global Options > Credit Notes/Gift Vouchers > Print Vouchers on 

Windows Printer) so that Gift Vouchers are printed to the Windows Printer when they are sold.  

 

To configure this function, go to: Back Office > Setup > Global Options > Credit Notes/Gift Vouchers. 

Toggle the ‘Print Vouchers on Windows Printer’ option as required. 

When this option is enabled, Gift Vouchers will be printed to the [Default] Windows Printer when they’re sold. 

Note the following settings that control the printing of Gift Vouchers when configuring this function: 

 

• ‘Print Vouchers on Receipt Printer’ and ‘Print Vouchers on Windows Printer’ can both be enabled 

simultaneously, which will trigger the Gift Voucher to print to both printer types when a Gift Voucher is sold. 

Configure these options as required.  

 

• ‘Only Print Voucher if No Email Address’ will affect the printing of Gift Vouchers; if this option is enabled, a Gift 

Voucher will only print if the Customer’s Email Address has not been entered when selling a Gift Voucher. 
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Close the Global Options window to save changes. 

Go to: Back Office > POS. 

From the POS Screen, press the ‘GIFT VOUCHER’ button to sell a Gift Voucher. 

Enter the Recipient’s Name and Email Address, then press ‘OK’: 
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The Gift Voucher appears in the Idealpos sale window. 

Press ‘ENTER’ to continue to the Tender screen. 
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Finalise the sale by selecting a Fast Cash button or Tender Type. 
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The Gift Voucher is printed to the Default Windows Printer: 
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Gift Vouchers can also be printed to the Windows Printer via the Gift Voucher Enquiry function. 

From the POS Screen, press the GIFT VOUCHER ENQUIRY button. 

Scan or Enter Voucher Code or press the ‘Name Search’ button. 

In this example, we have pressed the ‘Name Search’ button. 

 

 
 

Enter the Customer Name, select the Customer’s Name from the list on the right-hand side then press ‘Use’. 
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The Gift Voucher details are displayed on the Gift Voucher Enquiry window. 

Press ‘Windows Print’ to print the Gift Voucher to the [Default] Windows Printer. 

 

 
 

The Gift Voucher is printed. 
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Import/Export 

IP-5446 – IBA Promotion Import – Allow overwrite of existing Promotions 

This function changes the behaviour when importing IBA Promotions as follows. 

When the ‘Import Promotions’ checkbox is enabled and an IBA Promotion file is imported, it will overwrite any existing 

IBA Promotions in Idealpos that are the same as the promotions in the IBA Promotion file (e.g. if the IBA Promotion file 

was imported with a set of Start Dates, End Dates, Prices, etc. and another Promotion file with altered Start Dates, End 

Dates, Prices for the Promotions is reimported, the existing Promotions in Idealpos will be overwritten). 

 

Prior to this change, when an IBA Promotion file was imported, the Promotions were created, and if another Promotion 

file with the same promotions was reimported again (with altered Promotion Dates, Prices, etc.), the existing IBA 

Promotions in Idealpos would remain unchanged. 

 

Go to: Back Office > Setup > POS Terminal > Modify > Import/Export > IBA Interface. 

Set the Import Promotions checkbox as required. 

There is no option to control the overwrite behaviour. 

All IBA Promotions that are imported will now overwrite any IBA Promotions that already exist in Idealpos. 
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IP-5566 – Stock Item Export/Import – Support for Modifier Grids field 

This function introduces the ability to export the data stored in the ModifierGrids field of each Stock Item when 

running a Stock Item Export. 

Also available is the ability to import Modifier Grid data with each Stock Item being imported via the Stock Item 

Import function. 

 

A Stock Item can be linked to one or more Modifier Grid codes in the Modifier Grids field. 

POS Screen Grids configured in Back Office > Setup > POS Screen > Grids can be used as Modifier Grids by entering 

their POS Screen Grid codes into the Modifier Grid field of a Stock Item (or including this data in the Stock Item import 

file that will be used via the Stock Item function). 

If a Stock Item contains links to one or more Modifier Grids via the Modifier Grids field, those Modifier Grids will be 

displayed on the POS Screen immediately after the Stock Item is added to a sale on the POS Screen. 

The Modifier Grids will be displayed on the POS Screen in the order that they’re listed in the Modifier Grids field. 

 

E.g. POS Screen Grid Code 1 is ‘Cook Types Meat’ and POS Screen Grid Code 10 is ‘Sauce Types’.  

The codes 1,10 are entered in the Modifier Grids field a Stock Item.  

When the Stock Item is added to the sale, the Cook Types Meat POS Screen Grid will be displayed, after the clerk 

selects the required items from that Cook Types grid, the Sauce Types grid will be displayed.  

Once the required Sauce Type items are added to the sale, the POS Screen will return to the main grid. 

The number of items that need to be selected in each grid are configured via the Force Selection Minimum/Maximum 

fields within the configuration of each POS Screen Grid. 
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To use this function to export Stock Item data (including data in the ModifierGrids field), go to:  

Back Office > Utilities > Export Data > Stock Items. 

The way the data in the ModifierGrids field is exported varies depending on the method used to export Stock Items 

which are each outlined below. 

 

• Export: All Items/New Items Only/New and Modified Items Only – When using these options, the data stored 

in the ModifierGrids field is exported as an encrypted value. Idealpos supports importing the encrypted 

ModifierGrids as part of a Stock Item Import file. 

• Export:  Specific Fields by Range – When using this option and the ModifierGrids field is selected in the range, 

the data stored in the ModifierGrids field is exported as a pipe separated list (e.g. 1|10). 

• Export: Automatic Export Format – When the ModifierGrids field is added to the Automatic Export Format and 

the Automatic Export function is configured to run with the ‘Use Saved Automatic Export Format’ option, the 

data stored in the ModifierGrids field is exported as a pipe separated list (e.g. 1|10). 

• Export: Automatic Export without ‘Use Saved Automatic Export Format’ – When the Automatic Export function 

is configured to run without the ‘Use Saved Automatic Export Format’ option, the data stored in the 

ModifierGrids field is exported as an encrypted value. 
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Select the required Export option. 

Using “All Items” will export all items and the ModifierGrids field will be included in the exported data.  

As mentioned previously, using the ‘All Items’ option will encrypt the data stored in the ModifierGrids field. 

 

 
 

If using the ‘Specific Fields by Range’ or ‘Automatic Export Format’ options, the ModifierGrids field will need to be 

selected. Any of the fields between 1 to 24 can be set to export the MODIFIER GRIDS field. 

 

Example showing the Specific Fields by Range with the ‘Modifier Grids’ option selected in one of the fields: 
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Example showing the Automatic Export Format with the ‘Modifier Grids’ option selected in one of the fields: 

 

 
 

Configure the Options (Export Folder, Filename and required checkboxes). 

If using the Automatic Export Format, the OK button and the Options section with the Export Folder/Filename and 

checkboxes will not appear, as the Automatic Export is configured via Back Office > Setup > POS Terminals > Modify > 

Import/Export > Automatic Export Settings. 

The ‘Save Defaults’ button can be pressed to save the selected options as default so that the next time the Export 

Stock Items function is used, these values will be pre-filled. 

Pressing the ‘OK’ button will run the export process and the Stock Items will be exported to the selected Export Folder. 
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After the data has been exported, the ‘Export Complete’ prompt will be displayed. 

Press ‘OK’. This will close the prompt and return to the Back Office window. 

 

 
 

If the ‘Include Headers’ option was enabled, the selected field headers will appear at the top of the Export File. 

 

  
 

Any Modifier Grids in the Stock Item’s MODIFIERGRIDS field will be included as a pipe separated list as shown in the 

example below (the below example shows a Modifier Grid list of 1|10 which means that when the Stock Item is added 

to a sale, Modifier Grid 1 will be displayed, once items from that grid are added, Modifier Grid 10 will be displayed). 
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If the All Items, New Items Only, New and Modified Items Only or Automatic Export (without the ‘Use Saved Automatic 

Export Format’) are used, the Modifier Grids field will be exported as encrypted values. 

The below screenshot shows an example of a Stock Item record with an encrypted Modifier Grid. 

 

 
  

When importing Stock Items, Idealpos supports importing data in the ModifierGrid field as a pipe separated list, or as 

an encrypted value (which would have been previously exported using the Stock Item Export function). 

 

To import Stock Items with Modifier Grid values, use a header of MODIFIERGRIDS and specify the Modifier Grids in 

that field as a pipe separated list. The pipe character is typically available by holding down the SHIFT button on the 

keyboard and pressing the backslash “\” button. This will produce a pipe character “|”. 

 

An example of a basic import file is shown below, where 402 is the Department Code of “GROCERIES” in the Demo 

Database, using Modifier Grids 1|10. 

 

CODE, DESC, DPT, MODIFIERGRIDS 

230, TEST STOCK ITEM, 402, 1|10 

 

To demonstrate this function, create a TXT file with the required Stock Items to import.  

Import the file via Utilities > Import Data > Stock Items. 

Browse to the folder location and select the import file. 

The contents of the file will appear in the Import Stock Items window > Press ‘OK’ to import the data. 
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An Imported Records prompt will be displayed with details about the number of New, Modified and Failed records. 

Press OK to continue. 

 

 
 

Go to: Back Office > File > Stock Control > Stock Items. 

Modify the newly created Stock Item > Advanced tab. 

The Modified Grids field will contain data from the imported record. 

 

 
 

For more information about using the Saved Automatic Export Format with the Automatic Export function, refer to the 

Use Saved Automatic Export Format section in the Import/Export page of the POS Terminal Settings topic. 

The Automatic Export Format is configured as outlined above via Back Office > Utilities > Export Data > Stock Items > 

Select ‘Automatic Export Format’ > configure Export Specific Fields by Range (select Modifier Grids and any other 

required fields) > Press ‘Save Format’.  

The format will be used when the ‘Use Saved Automatic Export Format’ option is enabled in Back Office > Setup > 

POS Terminals > Modify > Import/Export tab > configure Automatic Export Settings and enable ‘Use Saved Automatic 

Export Format’.  

https://userguide.idealpos.com.au/Default.htm#POS%20Terminals/Import%20Export.htm
https://userguide.idealpos.com.au/Default.htm#POS%20Terminals/Import%20Export.htm
https://userguide.idealpos.com.au/Default.htm#POS%20Terminals/POS%20Terminal%20Settings.htm
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Labels 

IP-5488 – Stock Item Labels – Add Items by Recent Price Changes 

This function introduces the ability to print Stock Item Labels based on recent Price Changes. 

Items can be added to the Labels screen by enabling a checkbox for ‘Price Changes since’, selecting a Date/Time from 

the dropdown box and selecting a Price Level. Any Stock Items that have had Price Changes for the chosen Price Level 

since the selected Date/Time will be added to the grid after pressing the ‘Add to Grid’ button. 

 

To use this function, go to: Back Office > Utilities > Labels. 

Enable the ‘Price Changes since’ checkbox. 
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Select the Date/Time. 

The Date can be selected by clicking on the dropdown box and selecting a date from the calendar. 

 

 
 

The time can be selected by clicking onto the time portion and entering the time in 24 hour format. 

There is no requirement to clear or backspace the time when entering the desired time. 

Simply click into the time portion and enter the required time; any existing time shown will be overwritten with the 

entered time. 
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This function will only search for items that have had Price Changes for the specified Price Level. 

Therefore, select the Price Level that is required on the left-hand side of the Labels window as shown below. 

 

 
 

To add items to the grid, press the ‘Add to Grid’ button. 

 

 
 

If no Price Changes have taken place for the selected Price Level since the specified date/time, an “Item not found!” 

prompt will be displayed, and the grid will remain blank. 

 

 
 



 Update History 
Return to top 

Idealpos 8 Build 12 - Update History Page 31 of 99 

 

The Price Level, Date/Time in the ‘Price Changes since’ field can both be adjusted if necessary and the ‘Add to Grid’ 

button can be pressed again.  

If items that have had Price Changes for the selected Price Level since the specified date/time are found, they will be 

added to the grid (a Price Changes Report can be run via Back Office > Reports > Stock Control > Price Changes). 

The below example shows items with Price Changes have been found and added to the grid after pressing the ‘Add to 

Grid’ button. 
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To print the labels, configure/select the following options, then press ‘Print’. 

To demonstrate this function, Output To is set to ‘Idealpos A4 Labels’, A4 Printer is set to ‘Microsoft Print to PDF’, 

Dimensions are set to ’22 labels (2x11) Portrait and the Design is set to ‘Format 1’. 

 

Output To: Select the program to output the labels to. Options available include Idealpos A4 Labels, Idealpos 

Continuous Labels, DesignPro or Text. 

A4 Printer: Select the A4 Printer to print the labels to. 

Dimensions: Select the dimensions to use for printing the labels. This is the number of labels that will be printed to 

each page. 

Design: Select the desired design format.  

 

 
 

Labels for the Stock Items displayed in the grid will be printed to the printer. 
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IP-3938 – Stock Item Labels – Option to Hide Prices 

This function introduces the ability to hide prices on Stock Item Labels. 

This can be used in cases where a venue may want to produce labels for internal use and not want to display the Sell 

Price on the labels that are printed via Idealpos Labels. 

 

To configure and use this function, go to: Back Office > Utilities > Labels. 

Add the required Stock Items to the Labels grid [using the selection criteria at the top-right corner of the Labels 

window, then press the ‘Add to Grid’ button]. 

Once the required Stock Items appear in the grid, enable the ‘Hide Prices’ checkbox, then press ‘Print’. 

 

 
 

The Stock Item labels will be printed without the Sell Prices. 
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POS Screen Setup 

IP-5434 – New Customer Function – Support for default Customer Type 

This function introduces the ability to select the Default Customer Type that will be used when creating a new 

customer via the New Customer Function on the POS Screen. 

 

To configure and use this function, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

Either select an existing ‘New Customer’ button, or select a blank button and link it to the New Customer function. 

When creating a ‘New Customer’ button, the ‘Customer Type’ dropdown box can be used to select the Default 

Customer Type. If a Customer Type is not selected, Idealpos will use the Default Customer Type that is configured in 

Back Office > Setup > Global Options > Customers > Miscellaneous > Default Type. 

 

When creating a New Customer button that is linked to a specific Customer Type, you may want to ensure that the 

caption entered in the Button Caption field is reflective of the selected Customer Type. 
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Save the button, close the POS Screen Layout windows, then go to Back Office > POS. 

Navigate to the POS Screen tab that contains the ‘New Customer’ button and press it. 

The New Customer screen will be displayed, and the Customer Type will be set to the same Customer Type as per the 

button configuration above. 
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IP-5509 – POS Screen Setup – Copy Single Tab to different POS Layout 

This function introduces the ability to copy a single POS Screen Tab and all its contents to a different POS Screen 

Layout. This is useful when the requirement arises to configure multiple POS Screen Layouts where one or more POS 

Screen Tabs need to be replicated consistently across multiple POS Layouts. 

 

To use this function, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Press ‘Add’ to create a new POS Screen Layout > Enter POS Screen Layout Name > Save. 

Select the newly created POS Screen Layout > Buttons. 

 

Alternatively, select an existing POS Screen Layout > Buttons. 
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When modifying the POS Screen Layout, click on any POS Screen Tab at the bottom of the window. 

The POS Screen tab that is clicked will be overwritten with the POS Screen Tab from another POS Layout as outlined in 

the steps further below. 
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The top-left corner of the window will display the Button Appearance screen. 

Press the ‘Copy Single Tab’ button. 

 

 
 

The ‘Copy Single Tab From’ window will appear. 
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Select the POS Layout and Tab from where the POS Screen Tab will be copied from, then press the ‘Copy’ button: 

 

 
 

A confirmation prompt will be displayed. 

Press ‘Yes’ to continue, or press ‘No’ to cancel. 

 

 
 

After confirming the copy operation, the selected POS Screen Tab will be copied from the selected POS Screen Layout. 

The copy operation includes the copying of the POS Screen Tab’s Button Caption, POS Screen Tab’s Button Graphic (if 

a Graphic is set on the source POS Screen Tab button), the Button height (single height or double height) and all the 

POS Screen buttons contained within the POS Screen Tab. 
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Important note when copying POS Screen Tabs. 

When a Double Height POS Screen tab is copied to a POS Screen Tab on the top row, it will be copied as Double 

Height and will cover the POS Screen tab button on the bottom row. 

If the POS Screen tab button on the bottom row has already been configured and contains buttons within that tab, 

that Tab Button will still exist, as will all the POS Screen buttons configured within that tab. 

To regain access to the POS Screen Tab button on the bottom row, simply click on the Double Height POS Screen tab 

button and untick the ‘Double Height’ checkbox, then press ‘Save’ to save the change. 
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After unticking the ‘Double Height’ option and saving the change, the button below will reappear. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 12 - Update History Page 42 of 99 

 

Clicking on the POS Screen tab button on the bottom row will reveal the POS Screen buttons that exist within that tab. 
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POS Terminals 

IP-4615 – POS Options – “Copy from POS” button can copy from specific POS 

This function introduces the ability to copy the User Details from a specific POS Terminal to the current POS Terminal 

being modified. 

Previously, this function was hard-coded to ‘Copy from POS 1’; it is now possible to specify the POS Terminal number 

to copy from. 

 

To use this function, go to: Back Office > Setup > POS Terminals. 

Select a POS Terminal to Modify > Press ‘Modify’. 
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Enter the POS Terminal to copy from, then press the ‘Copy from POS’ button. 
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The User Details are copied from the POS Terminal number into the current POS Terminal that is being modified. 
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IP-5411 – POS Terminals grid – Show POS Layout 

This function introduces the ability to display the POS Screen Layout on the POS Terminals grid (when going to Back 

Office > Setup > POS Terminals). 

There is no additional configuration required to display the POS Screen Layout on the POS Terminals grid. 

 

To use this function, go to: Back Office > Setup > POS Terminals. 

Each POS Terminal’s POS Screen Layout will be displayed in the POS Screen Layout column. 
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Changing the POS Screen Layout assigned to POS Terminal will be reflected in the POS Screen Layout column. 

Select a POS Terminal > Modify. 

In the POS Screen Layout field, select a different POS Screen Layout. 
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After closing the Modify POS Terminal window, the main POS Terminals grid will reflect the POS Screen Layout that 

was just modified. 
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Refunds 

IP-5432 – Refund Reasons – Show on Journal Enquiry/Receipts 

This function introduces the ability to show Refund Reasons on the Journal Enquiry and Customer Receipt. 

Refund Reasons are used for identifying and recording a reason why a refund was processed for the return of a Stock 

Item. 

This function will always display the reason why a refund was performed in a sale when the sale is queried via the 

Journal Enquiry, but the Refund Reason will only appear on the Customer’s receipt if the Yes/No Option ‘Print Text on 

Bills/Receipts’ is enabled. 

 

To configure this function, go to: Back Office > Setup > Global Options > Sales. 

In the Refund Reasons fields, ensure that the required reasons have been entered. 

The “Type Text” checkbox can be enabled if additional information about the refund needs to be entered and captured 

when processing a refund. 
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A refund button may also be required on the POS Screen. 

To create one, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

Select a blank/unused button and assign it to the Refund function. 

The Button Caption, colour, size, and font can be customised as required. 
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Once the button has been created, close the POS Screen Setup windows. 

Then go to: Back Office > POS button. 

 

From the POS Screen, press the ‘REFUND’ button, then add a Stock Item to the sale. 

After selecting the Stock Item from the POS Screen, the Refund Reasons window will be displayed. 

Select the Refund Reason. 

 

 
 

If selecting a reason that has the ‘Type Text’ option enabled, an on-screen keyboard will be displayed so that the Clerk 

can enter a custom description for why the item is being returned. 
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The entered reference will be displayed in the sale window and the amount to be refunded will also appear. 

 

 
 

Press ENTER to go to the Tender screen. 

 

 
 

If Credit Note functionality has been previously configured, a prompt “Would you like to issue a Credit Note?” will be 

displayed. For this example, we’ll press ‘No’. 
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Select a Tender Type that will be used to issue the customer with their refund. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 12 - Update History Page 54 of 99 

 

The change that is to be issued to the customer is displayed: 
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The receipt is printed and will show the Refund Reason. 
Prior to this change, the Refund Reason was not printed on the Customer Receipt (except if the Refund Reason had 
the Type Text option enabled, any Typed Text would appear below the refunded item). 
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Close the POS Screen and go to: Back Office > Enquiry > Journal History. 

The Refund Reason will be displayed in the Journal History Enquiry. 

Refund Reasons are highlighted in red. 

Like the receipt, previous builds of Idealpos did not display Refund Reasons in the Journal Enquiry, with the exception 

being if the Refund Reason had the Type Text option enabled, any Typed Text would appear next to “REF:” in the 

Journal History Enquiry). 

With this change, both the Refund Reason and the typed text will appear in the Journal History Enquiry [if Type Text is 

enabled for the Refund Reason and text is entered when using the Refund Reason].  

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 12 - Update History Page 57 of 99 

 

Reports 

IP-2909 – Stock Item Sales Report – Customer/Customer Type selection range filters 

This function introduces the ability to select a Customer Type and Customer Code in the Selection Range of the Stock 

Item Sales Report. 

This then enables the report to be filtered down to one or more specific Customer Type(s) and/or Customer Code(s). 

The Customer Type and/or Customer Code Selection Range can be used together with the Optional Grouping – 

Customer and Customer Type options. 

 

To use this function, go to: Back Office > Reports > Sales > Stock Item Sales. 

 

If required, the Optional Grouping section can be used to Group by Customer or Customer Type. 
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The new fields added to the Selection Range are the Customer Type and Customer Code, as shown below: 
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When selecting Customer Types or Customer Codes in the Selection Range, Codes can be entered as a comma 

separated list (e.g. 1,2,3,4) or as a range (e.g. 1-4). 

The ‘>’ button can be pressed in each of these fields to display a window where a Customer Type or a Customer can 

be selected from a list. Selecting a Customer Type or Customer from the list and pressing OK will add the selection to 

the Customer Type or Customer Code fields.  

The process can be repeated as often as required to add additional Customer Types or Customers and they will be 

added as a comma separated list. 

 

The below example shows the Group Field set to Customer Type and the Customer Types 2 and 1 in the Selection 

Range. 
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When running the report with the above selections, the Stock Item Sales Report will Group sales by Customer Type, 

and the report will only show sales for Customer Types 2 and 1. 

 

 
 

The below example shows the Group Field set to Customer and the Customer Codes 2 and 1 in the Selection Range. 
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When running the report with the above selections, the Stock Item Sales Report will Group sales by Customer, and the 

report will only show sales for Customer Codes 2 and 1. 
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Restaurant & Table Map 

IP-5410 – Table Details – Print Last Receipt during Partial Payments 

This function introduces the ability to Print the Last Receipt during Partial Payments via a ‘Print Last Receipt’ button. 

After making a Partial Payment on a Table, the Table Details screen will be displayed and will contain a ‘Print Last 

Receipt’ button at the bottom. This button can be used to print the last receipt which would have been for the last 

Partial Payment that was processed. 

 

There is no additional configuration required to enable this button. 

To use this function, go to:  

POS Screen > Add Items to a Sale > Press the Table Map button > Select a Table > Enter Covers if prompted > OK. 

Then from the Table Map, select the same Table > Details. 
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From the Details screen, either make a Partial Payment (i.e. a fractional payment on any items), or only pay some items 

from the Table by selecting the items > Press ‘Pay [Amount]’. 

In the below example, only the Cappuccino item has been selected for payment. 
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The item is shown on the Tender screen. 

Select a Tender Type or one of the Fast Cash buttons to finalise the sale. 
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Idealpos will then return to the Table Details screen. 

The ‘Print Last Receipt’ button is now displayed at the bottom and can be used to print the last receipt to the receipt 

printer. 

Note that if the Table Details screen is closed then reopened, the Print Last Receipt button will disappear and will only 

become available after making another partial payment on the table. 

Also note that the Print Last Receipt button cannot be used after making the final partial payment on a table (because 

after the final partial payment is made on a table, no further payments are required on the Table and the Table Details 

screen will not reappear). 
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Pressing the ‘Print Last Receipt’ button produces a receipt printout. 
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IP-5429 – Table Map 1920/1366 Resolutions – Ability to use Full Screen for Table Map 

This function introduces the ability to set a resolution for a Table Map (using either 1024x768, 1366x768, 1920x1080, 

1920x1280 at 125% scaling or 1920x1280 at 150% scaling) so that when the Table Map is displayed on those 

resolutions, it will be displayed as full screen. 

The resolution for a Table Map is configured via the Table Map Modify window in the Idealpos Back Office.  

The Resolution option is available per-Table Map, meaning that it is possible to set a different resolution for each 

Table Map.  

When setting the resolution for each Table Map, ensure that the resolution used for all Table Maps is equal to or less 

than the lowest screen resolution in use on a POS Terminal on site. This will ensure that all POS Terminals on site will 

have the ability to view all Table Maps in their entirety.  

If a POS Terminal has a screen resolution lower than the Table Map resolution, this will result in the inability to view 

and select tables that appear outside that POS Terminal’s screen resolution area.  

 

To configure and use this function, go to: Back Office > Setup > Restaurant > Table Maps. 

Select a Table Map > Modify. 

On the bottom-left corner of the window, select the desired Resolution from the Resolution dropdown box. 
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After changing the resolution, the Table Map window will increase in size to accommodate the selected resolution. 

Additional tables can be added to the Table Map and placed in the expanded area of the Table Map. 

 

 
 

After making the required changes, press the ‘Save’ button. 

If required, a larger resolution Table Map image can be loaded via the ‘Load Picture’ button at the bottom of the Map 

Modify window. 
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As mentioned previously, it is a requirement that the POS Screen Resolution matches the Table Map resolution so that 

all Tables are visible when viewing the Table Map. 

Go to: Back Office > Setup > POS Terminals > Select a Terminal > Modify. 

From the POS Settings tab, ensure that the resolution is greater than or equal to the Table Map resolution, keeping in 

mind that the POS Terminal’s physical screen resolution needs to be capable of displaying the selected resolution; 

ensure that the resolution is also configured in the Windows Desktop Operating System. 
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Go to: Back Office > POS. 

Press the ‘Table Map’ button 

 

 
 

The Table Map is displayed in its expanded resolution with the newly created Tables shown on the right-hand side of 

the Table Map: 
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The resolution also applies to the Table Details screen as well (select a Table on the Table Map and press ‘Details’): 
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Send Pictures/Display/SendFiles Folder  

IP-5495 – Ability to send the “SendFiles” Folder to all terminals 

This function introduces the ability to send the “SendFiles” Folder from the source Back Office/Terminal to all or 

selected destination terminals. 

The “SendFiles” Folder can be used as a method to transfer any files that are required on multiple terminals, such as 

patches, driver updates, Idealpos Framework updates, Idealpos builds, or any other files that may be required on each 

terminal. 

This function will not run or execute files after the SendFiles folder is sent; the user will need to manually perform the 

required actions with the files after they’ve been transferred. 

Any files copied to a source Back Office/Terminal’s “C:\ProgramData\Idealpos Solutions\Idealpos\SendFiles\” folder 

will be transferred to the same folder location on the selected destination Back Office(s)/Terminal(s). 

 

To use this function, copy the required files to the “C:\ProgramData\Idealpos Solutions\Idealpos\SendFiles\” folder. 

 

 
 

Go to: Back Office > Utilities > Send > SendFiles Folder. 

Confirm the prompt ‘Are you sure you wish to Send your SendFiles folder to other Terminals’: 

Note that the Confirmation prompt can be toggled via the Yes/No Option ‘Confirm you want to Send the ‘SendFiles’ 

folder’. 
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On the left-hand side of the window, enable the checkboxes of the terminals that will receive the SendFiles folder. 

Press ‘OK’ on the bottom-right corner to begin the send process. 
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The copy process will run and once completed, will display the results in the Installation Progress section (right-hand 

side of the window). 

Press the ‘OK’ button to close the IPSDeploy window. 

 

 
 

The SendFiles folder on the destination terminal(s) will now contain the same files as those sent from the source 

terminal. 

 

 
 

Note that as part of this change, the following options have been added: 

 

• Yes/No Option to control the confirmation prompt (Setup > Yes/No Options > Confirm you want to Send the 

‘Send Files’ folder). 

• User Permission to control access to the SendFiles Folder function (Setup > Users > Modify User > Utilities > 

Send > SendFiles Folder). 
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Stock Purchases 

IP-5487 – Importing Custom Invoices – Ability to Merge New Items based on Description/Price 

This function introduces the ability to merge new items based on their description and Sell Price. 

When importing an invoice, the option ‘Add New Stock Items’ is used to create new Stock Items in Idealpos from the 

items in the invoice. Some supplier invoices may contain hundreds of items that are similar (such as greeting cards) 

with slight variations (e.g. Card Deluxe BD Female, Card Deluxe BD Male, Card Deluxe BD Humour, etc.). 

If a site doesn’t want each of these items to be created in Idealpos as individual stock items, they can be merged 

during the import of the invoice using this merge function. 

 

The items will be merged based on the ‘Description Tags’ and ‘Merge Prefix’ entered within the ‘Import Invoices’ 

window (these settings are entered before the import of a Supplier Invoice). 

E.g. Entering “CARD,WRAP” into the ‘Description Tags’ field and “ABC” into the ‘Merge Prefix’ field will trigger Idealpos 

to merge any items which have a description that starts with “CARD” or “WRAP”.  

The Description Tag, Merge Prefix and Stock Item’s Sell Price will each be used as the Stock Code for the merged 

items. 

E.g. Card Deluxe BD Female, Card Deluxe BD Male, Card Deluxe BD Humour all have a Sell Price of $2.00. 

Therefore, these items will be merged into a single Stock Item with a Stock Code of ABCCARD200. 

Any other Stock Items that also have a description starting with “Card” but a sell price of $3.00 will be merged into 

another Stock Item with a Stock Code of ABCCARD300. 

 

As each Stock Item that is merged will contain other details that are unique to each item (such as a Scan Code and 

Supplier Code), these Scan Codes will be added as Alternate Codes to the merged item, and the Supplier Code for 

each item will be added as Supplier Stock Codes to the merged item. The retention of the Scan Codes and Supplier 

Codes will enable the items to be scanned as well as enabling the items to be ordered again from the Supplier by the 

Supplier Code. 

 

To use this function, go to: Back Office > Transactions > Stock Control > Stock Purchases > Import. 
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The Import Invoices window will open. 

Select a Supplier by pressing the ‘>’ button in the Supplier field. 

 

 
 

Select a Supplier from the Suppliers list > OK. 

 

 
 

The Import Invoices window will reappear and will display the selected Supplier in the Supplier field. 

Ensure that the ‘Add New Stock Items’ checkbox is enabled and a Department for the new Stock Items is selected. 

 

 
  

Once the required options have been selected, press the ‘>>>’ button on the right-hand side of the Import Invoices 

window: 

 

  
 

  



 Update History 
Return to top 

Idealpos 8 Build 12 - Update History Page 77 of 99 

 

The Item Merging function will be displayed which can be used to configure the Description Tags and Merge Prefix. 

These settings will be used to determine which Stock Items are going to be merged based on their Descriptions.  

Items that are merged as part of the Import Invoice process will have their Stock Codes in Idealpos set based on the 

Description Tag, Prefix and Sell Price (this information is retrieved from the Invoice). 

E.g. The Item Merging – Description Tags is populated with “CARD” and the Merge Prefix is populated with “ABC”.  

When an invoice contains three items with descriptions of Card Deluxe BD Female, Card Deluxe BD Male, Card Deluxe 

BD Humour and these items have a Sell Price of $2.00, these items will be merged into a single Stock Item with a Stock 

Code of ABCCARD200 (ABC is the Merge Prefix, CARD is the Description Tag, and 200 is the Sell Price without a 

decimal place). 

When configuring the Description Tags, multiple tags can be entered as a comma separated list (e.g. CARD,WRAP). 

 

 
 

If the Item Merging function with the configured Description Tags and Merging Prefix is required for all future Invoices 

from this Supplier, the ‘Save Defaults’ button can be pressed (left-hand side) and anytime this Supplier is selected, new 

Items in the Supplier Invoice will be created and merged as per the configured Item Merging settings. 

 

Press the ‘Select Import File’ button to continue. 

 

 
 

Browse to a folder that contains the Supplier Invoice, select the Invoice file and press ‘Open’. 
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The Supplier Invoice is displayed. 

Note that if the fields from the Supplier Invoice have not been mapped, this will need to be done before importing the 

Supplier Invoice. This can be done by clicking on each of the headings in the Import Invoices window and selecting the 

Idealpos data type that corresponds to the data shown in the column below. Any columns in the invoice that do not 

have a corresponding data type in Idealpos can be skipped via the ‘Skip Field’ option. 

 

To continue with the import, press the ‘Import’ button. 

 

 
 

While the invoice is importing, a progress bar will be displayed within the button that contains the filename of the 

Supplier Invoice. 
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After the Invoice is imported, the main Stock Purchases window will be displayed and will show the newly imported 

Supplier Invoice. 

 

 
 

Ensure that the Invoice is selected and press the ‘Modify’ button. 
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The below example shows the Stock Items that have been merged (ABCCARD200, where ABC is the Merge Prefix, 

CARD is the Description Tag and 200 is the Sell Price without a decimal place). 

 

 
 

When going to Back Office > File > Stock Control > Stock Items > Code > Enter ABCCARD, the newly created Card 

Stock Items are displayed: 
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Selecting one of these Stock Items from the Stock Items grid and pressing the ‘Alternate Codes’ button (located on the 

left-hand side of the Stock Items grid window) will show all the Alternate Codes (these are the Scan Codes of the 

merged Stock Items). 
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Selecting one of these Stock Items from the Stock Items grid and pressing the ‘Supplier Codes’ button (located on the 

left-hand side of the Stock Items grid window) will show all the Supplier Codes (these are the Supplier Codes of the 

merged Stock Items). 
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IP-5415 – Stock Purchases – MDI Functionality 

This function introduces MDI (Multiple Document Interface) Functionality to Stock Purchases. 

MDI functionality enables the ability to resize the Stock Purchases window so that other applications can be displayed 

side-by-side with Idealpos, facilitating the process of performing manual data entry into an Idealpos Purchase Order or 

Stock Received. MDI functionality in the Stock Purchases function also enables the ability to access other Idealpos 

functions while the Stock Purchases window is open or while creating/modifying a Purchase Order/Stock Receive. 

A screen resolution of 1024x768 does not support the MDI function, therefore, the button to resize the Stock 

Purchases window will be hidden when using the Stock Purchases function on this screen resolution. 

 

Examples of screen resolutions which support the resize function include: 

• 1280x720 

• 1280x768 

• 1366x768 

• 1440x900 

• 1920x1080 

• 3840x2160  

 

To use this function, go to: Back Office > Transactions > Stock Control > Stock Purchases. 

The Stock Purchases window displays a resize button on the top-right corner. 
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Pressing the button will resize the Stock Purchases grid to a smaller sized window and the main Idealpos Back Office 

dashboard will be visible behind the Stock Purchases window. 

 

 
 

The Stock Purchases window can be repositioned to the desired location by clicking the mouse cursor on the title bar 

area of the Stock Purchases window and holding down the mouse button while dragging the window to another 

position on-screen. The rectangles drawn on the below screenshot show the title bar area of the Stock Purchases 

window (click and hold the mouse button on these areas then drag the window to the desired position on the screen): 
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When dragging the Stock Purchases window, an outline of the window will be displayed which indicates where the 

Stock Purchases window will be displayed if the mouse button is released. 

 

 
 

Releasing the mouse button will move the window to the new location on the screen: 
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When a Purchase Order or Stock Receive is being created or modified, the Purchase Order/Stock Receive window will 

appear as the same size as the Stock Purchases window.  

If required, the Purchase Order/Stock Receive window can be maximised to occupy the full screen or resized back to a 

smaller window.  

Also note that the main Stock Purchases grid is not viewable or accessible while a Purchase Order or Stock Receive is 

displayed; this is by design (the Purchase Order/Stock Receive window will take the place of the Stock Purchases 

window; after saving a Purchase Order/Stock Receive, the Purchase Order/Stock Receive will close and the main Stock 

Purchases grid will reappear. 

 

The below example shows a Purchase Order being displayed.  

While a Purchase Order is displayed, the main Stock Purchases grid that shows all Stock Purchases/Stock Received will 

not be accessible or visible. 
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The Stock Purchases windows appear while the main Idealpos Back Office window is visible. 

In the screenshots shown on the previous pages, the Idealpos Back Office window was maximised and occupied the 

entire screen, with the Stock Purchases windows appearing on top of the Back Office. 

Resizing the Idealpos Back Office window using the maximise/restore button will enable the ability to open other 

applications side-by-side with Idealpos, facilitating the entry of Stock Items into a Stock Receive or Purchase Order 

(e.g. a PDF invoice, email, web browser window, etc. with your invoice/purchase order can be opened in a window next 

to Idealpos, enabling the manual entry of data into Idealpos if required). 

 

On the top-right corner of the Idealpos Back Office window, click on the restore button to resize the Back Office to a 

smaller window. 

 

 
 

The Back Office is resized whilst also displaying the Purchase Order at the same time. 
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At this point, the Idealpos Back Office is a smaller window along with the Purchase Order/Stock Receive, with the 

Windows desktop (or any other applications) visible behind the Idealpos Back Office. 

 

 
 

 Other windows or applications can be started/opened and shown next to Idealpos. 
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Yes/No Options 

IP-5444 – Yes/No Option – Import Promotions default to Inhibit Points 

This function introduces the ability to control whether the Inhibit Points option is enabled by default when Importing 

new Promotions into Idealpos. When the option is enabled, any new promotions that are imported will have the Inhibit 

Points option enabled, and when disabled, any new promotions that are imported will have the Inhibit Points option 

disabled. Previously, this option was not configurable and all promotions that were imported had the Inhibit Points 

option unchecked. 

 

To configure and use this function, go to: Back Office > Setup > Yes/No Options. 

Enter Search: “import promotions”. 

Enable the option “Import Promotions default to Inhibit Points”. 

Note that while the option can be enabled for specific terminals, importing a promotion on a terminal that has the 

Inhibit Points option enabled will result in the promotion being created on all networked Terminals with the Inhibit 

Points option enabled. The same applies in the reverse; importing a Promotion on a terminal that has the Inhibit Points 

option disabled will result in the promotion being created on all networked Terminals with the Inhibit Points option 

disabled. 
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Go to: Back Office > File > Sales > Promotions > Promotions > Import. 

Browse to a folder location that contains a Promotion file. 

The import format of Promotion files is outlined in the User Guide - 

https://userguide.idealpos.com.au/#Import%20Data/Promotions.htm  

 

For this example, we are using “Wine Promo.csv”. 

This Import file will create multiple promotions for the Wine Stock Item Codes (228001, 228002, 228003, 228004, 

228005, 228006, 228007, 228008), all of which are included in the Idealpos Demo Database: 

 

ZONE,DESCRIPTION,TRIP_QUANTITY,PROMO_PRICE,START_DATE,END_DATE,ITEM_CODE 

1,Z3-S20-WINE-3FOR20,3,20,01-Jan-21,30 Jun 2023,228001 

1,Z3-S20-WINE-3FOR20,3,20,01-Jan-21,30 Jun 2023,228002 

1,Z3-S20-WINE-3FOR20,3,20,01-Jan-21,30 Jun 2023,228003 

1,Z3-S20-WINE-3FOR20,3,20,01-Jan-21,30 Jun 2023,228004 

1,Z3-S20-WINE-2FOR10,2,10,01-Jan-21,30 Jun 2023,228005 

1,Z3-S20-WINE-2FOR10,2,10,01-Jan-21,30 Jun 2023,228006 

1,Z3-S20-WINE-2FOR10,2,10,01-Jan-21,30 Jun 2023,228007 

1,Z3-S20-WINE-2FOR10,2,10,01-Jan-21,30 Jun 2023,228008  
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After selecting the Promotion file and pressing the ‘Open’ button, the promotion will be imported and the Promotions 

grid will display the newly imported Promotions at the bottom of the list, similar to the below example. 

Select either of the newly imported Promotions, then press the ‘Modify’ button on the top-left corner of the window. 

 

 
 

Within the ‘Advanced’ tab of the Modify Promotion window, the ‘Inhibit Points’ option will be enabled, as per the 

Yes/No option configured above. 
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IP-5210 – Yes/No Option – Prompt to Print Receipt 

This function introduces the ability to display a prompt to print a receipt at the end of the sale. 

This function is useful in environments where the venue doesn’t want to automatically print a receipt for every 

transaction, but still wants to display a reminder to the clerk to ask the customer if they want a receipt, and if the 

customer requires a receipt, the Clerk can press the ‘Yes’ button to the prompt and a receipt will be printed. 

The Print Receipt prompt will be displayed for 10 seconds and if an option is not chosen, the prompt will be closed, 

and a receipt will not be printed. 

 

To configure and use this function, go to: Back Office > Setup > Yes/No Options. 

Enter search: “prompt to print”. 

Enable “Prompt to Print Receipt” for the terminals that require this function. 

 

 
 

Note that additional steps are required for the prompt to be displayed: 

• A receipt printer must be configured (Go to Setup > Network Printers > drag a Receipt Printer into the Receipt 

slot for each POS Terminal) 

• Receipt Printing needs to be turned off via the Receipt On/Off button (to create the button, go to Setup > 

POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons > click on a blank/unused button 

and link it to the ‘Receipt On/Off’ function). 

 

Once the Prompt to Print Receipt Yes/No Option has been enabled (along with the additional steps listed above), 

open the POS Screen from the main Back Office window. 
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From the POS Screen, ensure that Receipt Printing is off via the Receipt On/Off button (the button must show ‘RECEIPT 

IS OFF’ – If RECEIPT IS ON, press the button to toggle receipt printing so that it is turned off). 

 

 
 

Add the required items to the sale: 

 

 
 

Press the ENTER button to go to the Tender screen, select an amount/Tender Type to finalise the sale. 
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After selecting a Tender Type/Tender button, the Print Receipt prompt will be displayed. 

As mentioned earlier, the prompt will be displayed for approximately 10 seconds.  

If Yes/No is not chosen before the 10 second timeout has lapsed, the prompt will automatically close, and a receipt will 

not print. 

 

 
 

Pressing Yes will print a receipt for the customer. 
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IP-5543 – Yes/No Option – Stock Item Search from POS Screen Resets Filters 

This function introduces the ability to control whether performing a Stock Item Search from the POS Screen will reset 

the search filters the next time the Stock Item Search function is opened from the POS Screen. 

Prior to this change, previous builds of Idealpos v8 were hard-coded to reset the Stock Item Search from POS Screen. 

 

Example 1: When this Yes/No Option is enabled (this option is enabled by default) and the Stock Item Search function 

is opened from the POS Screen, a search term of “COKE” is entered into the Description field and a Coke Item is added 

to the sale. 

The next time the Stock Item Search function is opened from the POS Screen, the “COKE” search term is cleared from 

the Description search field and the Stock Item list is unfiltered. 

 

Example 2: When this Yes/No Option is disabled and the Stock Item Search function is opened from the POS Screen, a 

search term of “COKE” is entered into the Description field and a Coke Item is added to the sale. 

The next time the Stock Item Search function is opened from the POS Screen, the “COKE” search term will remain in 

the Description search field and the Stock Item Search window will still be filtered and only show items that contain 

“COKE” in their description. 

 

To configure this function, go to: Back Office > Setup > Yes/No Options. 

Enter “Stock Item Search” into the Search field > Toggle the option “Stock Item Search from POS Screen Resets Filters”. 

When this option is enabled, any search terms entered into the Stock Item Search function will be cleared the next 

time the Stock Item Search function is opened from the POS Screen. 

When this option is disabled, any search terms entered into the Stock Item Search function will be retained the next 

time the Stock Item Search function is opened from the POS Screen. 

By default, this option is enabled/checked. Toggle the option to the desired setting as required. 

 

To demonstrate this functionality, the option has been unchecked as shown below. 
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To utilise this function, a Stock Item Search button is required on the POS Screen. 

If this button does not exist or if it needs to be created, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

Locate a blank/unused button, click on it and link it to the “Stock Item Search” function as shown below: 

 

 
 

Press the ‘Save’ button to save the change. 

Close the POS Screen Layout windows.  
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Go to: Back Office > POS. 

 

Click on the “Stock Item Search” button. 

Enter a search term into one of the filter fields at the top of the Stock Item Search window, select an item from the list 

and press ‘OK’ to add it to the sale. 
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The Stock Item is added to the sale. 
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Press the ‘Stock Item Search’ button. 

The Stock Item Search window is displayed and will contain the previously searched Stock Item description in the 

search filter. 

If the Yes/No option was enabled, the Stock Item Search window would have displayed an unfiltered Stock Item Search 

window without the previously entered description in the Description filter field. 

 

  
 

This function also supports the search filter that appears on the left-hand side menu of the Stock Item Search window. 

 

 


