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Installation and Upgrade 

IP-4182 – v8 Framework and Build Installers 

Before jumping in and installing the Idealpos v8 Framework and the build, there are some important steps and points 

that need to be covered off regarding the installation and upgrade process. 

 

Idealpos v8 Licence 

Idealpos v8 requires a v8 licence. Simply installing Idealpos v8 on your terminal without having your licence updated 

will result in a Licence Expired prompt and an unusable terminal (until you pay for a v8 licence). 

Idealpos v8 is also not a free upgrade from Idealpos v7. You will need to speak to our sales team so they can organise 

a v8 license for your terminals and obtain payment for the upgrade. 

 

SQL Server version installed by the Idealpos v8 Framework 

When the Idealpos v7 Framework was installed, it installed SQL Server 2008 R2. 

This behaviour has now changed with the Idealpos v8 Framework Installation. 

Depending on whether you are installing the Idealpos v8 Framework on a system that doesn’t contain an existing 

v7/v7.1 installation (clean install) or installing the Framework on an existing v7/v7.1 system (upgrade), the behaviour 

will vary and is outlined further detail as follows:  

 

• Existing Idealpos v7/v7.1 Installation – Running the v8 Framework installer on a terminal that contains 

existing Idealpos v7.1 installation will keep the existing SQL Server 2008 R2 in place and will not display a 

prompt asking the user which SQL Server version they want to install. 

 

• New Framework Installation on a system that already has SQL Server installed – The v8 Framework will 

use the existing SQL Server installation and will not display a prompt asking the user which SQL Server version 

they want to install. 

 

• New Framework Installation on a system that doesn’t already have SQL Server or Idealpos v7/7.1 

installed – The v8 Framework installer will install SQL Server 2019 on a 64-bit Operating System or SQL Server 

2014 on a 32-bit Operating System. If Advanced SQL Server Options is selected during the Framework install, 

the user can select the SQL Server version they want to install. The version that is selected will be downloaded 

and installed as part of the Framework installation. Note that SQL Server 2019 is only supported on terminals 

running a 64-bit Operating System. When the Framework install is run on a 32-bit Operating System, the SQL 

Server 2019 option will be greyed out in the Advanced SQL Server Options.  

 

To minimise any problems and to reduce the amount of time spent on upgrading to Idealpos v8, we recommend that 

you leave your existing Idealpos v7/v7.1 and SQL Server installations in place, then follow the recommended steps 

listed for each of the below scenarios. 

If you would like to take the opportunity to upgrade your SQL Server version, you will need to uninstall Idealpos 

v7/v7.1 and SQL Server. You can then run the Idealpos v8 Framework which will perform a clean install, at which point 

you will be given the option to select your desired version of SQL Server to install. 
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Upgrade/Install processes 

Follow the recommended list of steps for your current environment from one of the below headings: 

 

Recommended upgrade process for sites already running Idealpos v7 

- Do not uninstall Idealpos v7 or the Framework 

- We recommend that you upgrade to the latest build of Idealpos v7.1 

- Install the new Idealpos v8 Framework, then install the Idealpos v8 build. 

- The SQL Server will not be upgraded.  

 

Recommended upgrade process for sites already running Idealpos v7.1 

- Do not uninstall Idealpos or the Framework 

- Install the new Idealpos v8 Framework, then install the Idealpos v8 build. 

- The SQL Server will not be upgraded 

 

Recommended install process for new sites that are not running Idealpos 

- Check the Windows architecture (32-bit or 64-bit) of each POS terminal and Back Office system. 

- If all systems are running a 64-bit version of Windows, you can select “Download SQL Server 2019 (64-bit 

only)” [from the “Advanced SQL Server options”]during the Idealpos v8 Framework install, then run the 

Idealpos v8 build install.. 

- If there is a mix of systems running 32-bit and 64-bit versions of Windows, you will need to run the v8 

Framework installer and select either “Download SQL Server 2014” or “Download SQL Server 2008 R2”, 

ensuring that whichever version is selected is then consistently selected and installed on all terminals across 

your site. Once the Idealpos Framework install has been completed, run the Idealpos v8 build install . 

 

Recommended install process for adding new terminals to an existing v8 installation 

- When additional terminals are being added to an existing Idealpos v8 environment, they will also need to be 

running the same SQL Server version as your existing systems. 

- You will need to determine which version of SQL Server is installed on the existing terminals before installing 

Idealpos onto your new terminals. 

- There are a couple of different ways to determine which SQL Server version is currently running on a terminal. 

 

IPS Client Method – Open the IPS Client by clicking on the system tray icon. 

If the icon doesn’t appear in the system tray as shown in the below example, you may need to press the up arrow to 

display hidden icons. If the IPS Client icon does not appear in the Windows System Tray, Idealpos might be closed. 

Start Idealpos which will also start IPS Client. 
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Click on any terminal shown in the list. 

 

 
 

The IPS Client – Terminal Overview window will be displayed. The version will appear in brackets next to the CPU name. 
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SQL Query Method – You can determine the SQL Server version by running an SQL Query (SELECT @@VERSION) via 

the SQLCMD tool.  

Go to: Start > Idealpos > IPSUtils. 

Within the IPS Utility, go to: Advanced > SqlCmd Line. 

 

 
 
Within the SQLCMD window, enter the following commands, ensuring that you press ENTER after each line. 
SELECT @@VERSION 
GO 
 
The SQL Server version will be displayed as shown in the example below: 
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IP-4240 – SQL Server 2019 Support 

Idealpos v8 now supports SQL Server 2019. 

The Idealpos Framework installer will give the option to install SQL Server 2019 Express when each of the following 

conditions are met: 

• A clean system which does not already contain Idealpos v7 or v7.1 

• Idealpos v7 Framework has not been installed (if the Idealpos v7 Framework has been installed, SQL Server 

2008 R2 Express will also be installed) 

• SQL Server is not already installed on the system 

• The PC or POS Terminal is running a 64-bit version of Windows 

 

If the above conditions are not met, the Idealpos Framework installer will either keep the existing SQL Server 

installation in place, or will display a prompt for you to select which SQL Server version to install depending on the 

current environment: 

 

• New Framework Installation on a 32-bit version of Windows that doesn't already have SQL Server 

installed – The Framework installer will display a list of SQL Server versions for you to select the required 

version (excluding SQL Server 2019 which will be greyed out/unavailable for 32-bit Operating Systems). 

 

• New Framework Installation on a 64-bit version of Windows that doesn't already have SQL Server 

installed – The Framework installer will display a list of SQL Server versions for you to select the required 

version. SQL Server 2019 can be selected from the “Advanced SQL Server Options”. 

 

• New Framework Installation on a system that already has SQL Server installed – The Framework installer 

will not prompt you to select a version of SQL Server and will keep the existing SQL Server installation in place. 

 

• Existing Idealpos v7.1 Installation – The Framework installer will keep the existing SQL Server in place and 

will not prompt you to select a version of SQL Server to install. 

 

 

 

Ensure that you take the necessary steps to ensure that the correct version of SQL Server is installed across all 

your terminals. 

To ensure all POS Terminals and Back Office systems can support SQL Server 2019, ensure that all systems are 

currently running a 64-bit version of Windows. If all terminals are not running a 64-bit Operating System, 

select “Download SQL Server 2014” during the Framework installation. 

   



 Update History 
Return to top 

Idealpos 8 Build 1 - Update History Page 8 of 198 

 

Accounting 

IP-2560 – Xero Accounting – Support for default Due Date for Customer Invoices 

This function adds support for the Default Due Date Payment Terms that are configured in Xero when exporting 

Customer Invoices from Idealpos into Xero. Previous to this change, the Default Due Date Payment Terms configured 

in Xero were not used when exporting Customer Invoices from Idealpos into Xero; the original Invoice Date would be 

posted into Xero. 

 

To configure this function, login to Xero > Select the Organisation Name on the top-left corner > Settings 
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Select “Invoice Settings” 

 

 
 

Select “Default Settings” 
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The Default Settings window will appear. 

Configure your Payment Terms as required, then press “Save”. 
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Customer Invoices will be exported to Xero when one or more Account Customers have made a purchase on Account 

and the following steps have been completed: 

- An End of Shift is performed on the POS 

- End Sales Period is run via Back Office > Accounting > End Sales Period  

- Sales Reconciliation is run via Back Office > Accounting > Sales Reconciliation 

 

Note that all Customer Invoices from Idealpos are exported to Xero under a single Debtor called “POS Debtor”.  

 

After the transactions have been exported, Customer Invoices will appear in Xero under Business > Invoices. 

The “Due Date” will be set as per the Default Settings that were configured further above: 
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Back Office 

IP-4007 – New Backoffice UI Design 

In Idealpos v8, the Backoffice has had a UI Design overhaul. 

Buttons on most screens have been moved from the bottom of the screen over to the left-hand side. 

As part of the design overhaul, the colour scheme in the Idealpos application has been changed from the Charcoal-

Grey colour to Navy-Blue, with a few light Mandarin-Orange accents also being used. This colour scheme change 

includes changes to popup prompts and POS Screen buttons.  

 

A bullet-point list of changes is listed below: 

• Back Office screens now occupy the entire screen resolution (except for the main Back Office window which 

can be run at either the traditional 1024x768 windowed state, or maximised to occupy the entire screen) 

• Buttons have been moved from the bottom of the screen to the left-hand side 

• Colour scheme changed from Charcoal-Grey to Navy-Blue 

• The Idealpos logo on the top-left corner of each screen can be pressed to close the screen and return to the 

Back Office Dashboard. 

 

To experience the User Interface changes, open any screen from the Back Office. 

For this example, we will demonstrate the change on the Stock Items grid as well as the Financial Report, however, 

most screens have been overhauled, with only some screens retaining their previous layout (such as Global Options). 

 

Go to: Back Office > File > Stock Control > Stock Items. 

The Stock Items grid is displayed. 

All buttons that used to appear at the bottom of the Stock Items grid are now located on the left-hand side. 
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Another example is the Financial Report. 

Go to: Back Office > Reports > Financial Report. 

The View and Print buttons are now located on the top-left corner of the window. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 1 - Update History Page 14 of 198 

 

Pressing the Idealpos logo on the top-left corner of the screen will close the window and return to the Back Office 

Dashboard. This behaviour applies to all screens that display the Idealpos logo on the top-left corner. 
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IP-4008 – ‘Save Changes’ Prompt when exiting any Add/Modify screen 

This function triggers a ‘Save Changes’ prompt to be displayed when exiting any Add/Modify screen. 

The screen is only triggered when changes have been made and the Add/Modify window is closed without saving the 

changes. 

 

To trigger this function, open any Add/Modify screen, make changes and close the window without pressing “Save”.  

For the below example, go to: File > Sales > Departments. 

Press the “Add” button on the top-left corner > Enter a Description > Select a Sales Category > Press “X”. 

 

 
 

The Save Changes prompt is displayed. 

Press “Yes” to save your change, or press “No” to abandon any changes. 

This prompt will be displayed when creating a new record and not saving changes as well as modifying an existing 

record and not saving changes. If a window is closed without any changes being made, the prompt will not appear. 
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IP-4218 – Dashboard Themes 

This function adds the ability to select from one of three colour schemes (Dark Theme, Light Theme and Blue Theme) 

change the appearance of the Back Office Dashboard. 

Dashboard Themes are system/terminal specific which means that setting the Dashboard Theme on one PC or 

terminal will not set the same theme for all other networked Idealpos systems. The selected Dashboard Theme applies 

to all Users of the terminal. 

To select the Dashboard Theme, click on the Cog icon shown at the top of the Dashboard, then from the Dashboard 

Theme menu, select the desired theme. 

The currently selected theme will contain a checkbox next to it: 

 

 
 

Each of the available themes are illustrated below. 

 

Dark Theme: 
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Light Theme (the same theme as the traditional Idealpos V7 Dashboard): 
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Blue Theme: 
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IP-4219 – Shortcut Groups 

This function adds support for Shortcut Groups to the Back Office Dashboard. 

Shortcut Groups can be created and any new or existing shortcuts can then be saved or moved into those groups.  

Shortcut Groups are stored globally and individual Shortcuts are site specific. 

When a Shortcut Group is created in Site 1, the Shortcut Group will also appear at other sites. However, the Shortcuts 

that have been saved into the Shortcut Groups will only be site specific. 

This function is especially useful for customers that have numerous shortcuts on their Back Office Dashboard and find 

it difficult find a particular shortcut in the list. 

 

In order to use this function, the Back Office must be able to view the Dashboard.  

Go to the Back Office. 

At the top of the Dashboard, press the cog icon, then select Shortcuts > Add New Group: 

 

 
 

An “Add New Shortcut Group” window will appear.  

Enter the name of the Shortcut Group that you want to create, then press the “+” button to the left-hand side of the 

field to create the Shortcut Group. 

For this example, we have created a Shortcut Group called “Sales Reports”. 

 

 
 

The Add New Shortcut Group window will remain open after the Shortcut Group has been created.  

Create additional Shortcut Groups if required.  

Press the “X” button on the top-right corner of the window once you have created your required Shortcut Groups. 
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The newly created Shortcut Group(s) will appear on the left-hand side of the Back Office Dashboard in the Shortcut 

area: 

 

 
 

Now that the Shortcut Group(s) have been created, you can either move existing Shortcuts into the Shortcut Groups, 

or you can save Report Shortcuts into the Shortcut Groups. 

 

To save a Report Shortcut into the Shortcut Group, run any report as required from the Reports menu in the Back 

Office. 

For this example, we have run the Stock Item Sales Report from the Reports > Sales > Stock Item Sales menu. 

Select the “S” shortcut button on the top-right corner of the report.  

Enter a name for the Shortcut and select the Shortcut Group that you want to save the report into. 
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You may then close the Report and return to the Back Office Dashboard. 

The newly created Shortcut will appear within the Shortcut Group. 

 

 
 

The above process can be repeated to save additional shortcuts into the required Shortcut Groups. 

 

If you already have existing Shortcuts that you want to move into a Shortcut Group, right click on the Shortcut from 

the Back Office Dashboard and select Move to… > Shortcut Group name. 

In the below example, we have right-clicked on the Financial Report Daily Shortcut and moved to the Sales Reports 

Shortcut Group. 

 

 
 

The Shortcut is then moved into the Shortcut Group as shown in the below example:  
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Additional functions available within Shortcuts are outlined below:  

 

• Ability to delete Shortcuts and Shortcut Groups by right-clicking on them within the left-hand side Shortcut 

menu and selecting the "Delete Shortcut" option. A confirmation prompt is displayed when deleting 

Shortcuts/Shortcut Groups. 

It is not possible to delete a Shortcut Group that still contains Shortcuts; attempting to do this will display a prompt 

“Cannot delete Shortcut Groups with Items.”. When Shortcut Groups are in use at a Multi-Site environment,  

 

• Ability to Expand All/Collapse All Shortcut Groups by clicking on the cog icon at the top of the Dashboard and 

selecting Shortcuts – Expand All/Collapse All – Selecting Expand All will expand all the Shortcut Groups so that 

all the Shortcuts contained within each group are visible. Selecting Collapse All will collapse all the Shortcut 

Groups so that all the shortcuts contained within each group are hidden/collapsed. 

 

• Ability to Hide Empty Groups/Show Empty Groups – As Shortcut Groups are stored globally (Shortcut Groups 

created at Site 1 will appear in Site 2, Site 3 and so on), and individual Shortcuts are site specific, the ability to 

Hide and Show Empty Groups is available via the Shortcuts menu. 

 

• Right-click on a Shortcut Group > Move to… - Right-clicking on a Shortcut Group on the left-hand side of the 

Back Office Dashboard will show a “Move to…” menu option. From this menu, you can move the Shortcut 

Group. The options available are: 

Top – Moves the Shortcut Group to the very top of the list. 

Up - Moves the Shortcut Group up one line. 

Down – Moves the Shortcut Group down one line. 

Bottom – Moves the Shortcut Group to the very bottom of the list. Note that when moving to the bottom, the 

Activity Log will always be the last option shown at the bottom of the list. 

 

• Right-click on a Shortcut > Move to… - Right-clicking on a Shortcut on the left-hand side of the Back Office 

Dashboard will show a “Move to…” menu option. This menu will display a list of Shortcut Groups that the 

Shortcut can be moved to. 
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IP-4246 – Support for Fast Lookup Textboxes [beta] 

This function adds the ability to perform a fast lookup within text fields without having to open the full list ing via the 

“>” button. As a value is entered into the textboxes, a list of options which match the entered value will be displayed 

and the required option can then be selected from the list.  

This functionality supports looking up data either using a numeric value (e.g. Stock Code) or a text value (e.g. the Stock 

Item Description). 

 

This functionality has initially been enabled in the following reports: 

• Stock Item Sales Report (Reports > Sales > Stock Item Sales) 

• Stocktake Forms (Stocktake > Stocktake Forms) 

• Stock Item Enquiry (Enquiry > Stock Items) 

 

To use this function, open any of the above reports.  

To demonstrate this function, we will open the Stock Item Sales Report. 

Go to: Back Office > Reports > Sales > Stock Item Sales 

 

In any of the text/numeric fields displayed within the Selection Range area of the Stock Item Sales Report window, you 

may enter either a text or numeric value.  
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As you enter a value, any records that match what has been entered so far will be displayed in the list. You may then 

select the required entry from the list to populate the field. To select a value from the list, either click on it or use the 

down arrow key until the required entry has been highlighted, then press Tab or Enter. 

 

 
 

The selected entry is then populated into the field. 
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Text values can also be entered into a field to search by description.  

A text description may be entered, including text entry in a code field.  

E.g. Entering “Lift” into the Code field will show any items that contain a description of “Lift”, and when any of these 

entries are selected, the Code for the selected item will be entered into the Code field. 

 

 
 

A code of “205305” for the Stock Item “LIFT 1.25L” is entered into the Code field. 
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Once the required criteria have been entered into the Selection Range, run the report by pressing the “View” button 

on the top-left corner of the window. 

 

 
 

The report is displayed: 
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IP-4254 – Shortcuts – Support for multiple shortcuts of the same Function 

This feature adds the ability to create multiple shortcuts to the same function. 

When pressing the “S” button (on the top-right corner of the window) to create a Shortcut, Idealpos will display a 

prompt allowing you to choose a Shortcut name as well as a Shortcut Group where you’d like to create the Shortcut.  

Prior to this change, it was only possible to create a single shortcut for each function.  

The ability to create multiple shortcuts for the same function can be used when you want to specify a filter within the 

shortcut function (such as creating a Shortcut for Journal History Last Week and another Shortcut for Journal History 

Last Month).  

 

There is no additional configuration to enable this functionality. 

To use this function, open any function from the Idealpos menu such as Journal History Enquiry.  

Go to: Enquiry > Journal History Enquiry 

Select the Period from the period dropdown, then press the “S” button on the top-right corner. 
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A window is displayed prompting you to enter a Shortcut Name and Shortcut Group to save the shortcut to. 

Enter a name that resembles the function along with the Period that was selected , then press “Save”.  

Note that the Shortcut Name is limited to a maximum of 27 characters, so you may need to abbreviate the Shortcut 

Name description. 

E.g. Journal Hist Enquiry Lst Wk 

 

 
 

Once the Shortcut has been saved, select another period, then press the “S” button to create another Shortcut.  
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Enter a name for the Shortcut, select the Shortcut Group, then press “Save”. 

 

 
 

Close the Journal History Enquiry window. 

The new Shortcuts will appear within the Shortcut Group that was selected above. When selecting either of these 

shortcuts, the period that was selected will be used to display the Journal History Enquiry.  

The period is always relative to the current date on which the shortcut is being run. 
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IP-4370 – Dashboard KPI – Support for Profit Amount 

This function adds the ability to display the Profit Amount on the Back Office Dashboard. 

The Profit Amount is the amount of profit that has been made after deducting tax and cost of items that have been 

sold. The Profit Amount shown on the Back Office Dashboard is the same as the $ Margin shown in the Financial 

Report. 

 

To use this function, ensure that the terminal is licensed for the Back Office Module and the Dashboard is configured 

to appear. 

The option to Show Dashboard is available by going to:  

Back Office > Setup > Yes/No Options > Search: dashboard 

Enable “Show Dashboard” 

 

 
 

The User which is logged into Idealpos will also need to have permission to view the Dashboard. 

This can be configured or confirmed by going to: Back Office > Setup > Users. 

Select a User > Modify. 

Ensure that the “Dashboard” option is enabled as shown in the example below: 
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When viewing the Dashboard, the first button towards the top-left corner of the Dashboard graphs/charts can be 

pressed repeatedly to toggle the data that is represented on the chart. 

The button will toggle between the following options (with the new option that was added in this change being “Profit 

Amount”)… 

 

• Sales Amount 

• Profit Amount 

• Number of Sales 

 

The below example shows the new Profit Amount option selected, showing a Profit Amount of $16: 
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The Period buttons can also be pressed to toggle between the following period options: 

 

Today: 

 

 
 

This Week: 

 

 
 

This Month: 
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The Profit Amount shown on the Dashboard (whole amount without decimal or rounding) is the same as the amount 

shown in the Financial Report - $ Margin. 

 

 
 

Reports > Financial > Financial Report > Date Range: Today > View 

 

  



 Update History 
Return to top 

Idealpos 8 Build 1 - Update History Page 34 of 198 

 

Docket Printing 

IP-4281 – Docket Receipts – Trading Name and Business ID locked in Header/Footer 

This functionality forces the Trading Name and Business ID to be printed at the bottom of the receipt if the Trading 

Name and/or Business ID have not been entered into the Receipt Header or Receipt Footer. 

If the Trading Name and/or Business ID do not match the details stored in the Licence Gateway, Idealpos will print the 

Trading Name and Business ID at the bottom of the receipt. 

Each set of data is treated independently, meaning that only the missing or mismatching Trading Name or Business ID 

will be printed at the bottom of the receipt.  

E.g. The Trading Name in the Receipt Header/Footer matches the Licence Gateway, but the Business ID is missing, then 

only the Business ID will be printed at the bottom of the receipt. 

 

When entering your Trading Name into the Receipt Header/Footer, the name must be the same as the details stored 

in the Licence Gateway. For the Business ID, you are permitted to enter the ID without spaces, enter spaces between 

each set of numbers within the ID or you may place a hyphen “-“ between each set of numbers. 

 

To ensure that your Receipt Header/Footer contains your Trading Name and Business ID, go to: 

Back Office > Setup > Licence Gateway 

Note down the Trading Name and the Business ID as shown in the below example: 
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Close the Licence Gateway, then go to: Setup > POS Terminals > Select POS Terminal > Modify 

In the “Receipt Printer” tab, ensure that your Trading Name and Business ID have been entered into either the Header 

or Footer. 

In the below example, the Trading Name “Idealpos User” has been entered into the Header field .  

The characters @# have also been appended to the start of the name to centre and bold the text when printed to a 

receipt printer. 

The Business ID has been entered and the @ character has been appended to the start of the ID to centre it when it is 

printed on the receipt. 
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When both the Trading Name and Business ID have been entered correctly, these details are not printed at the bottom 

of the receipt: 

 

 
 

If the Trading Name and/or Business ID are either missing from the Receipt Header/Receipt Footer or the details 

entered into the Receipt Header/Footer do not match the Licence Gateway, the correct details will be printed at the 

bottom of the receipt as shown in the example below: 
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IP-4389 – Receipt QR Codes – Support for more embedded data 

This function adds the ability to include more embedded data within receipt QR Codes. 

When the new data tags have been configured and a customer scans the QR Code at the bottom of their receipt, the 

data will be displayed as text on their device. 

This data may also be used for other purposes such as querying data from or posting data to a website as part of a 

URL. 

E.g. www.mycompany.com/[CUSTOMERCODE] 

This will result in the [CUSTOMERCODE] tag being replaced with your customer’s code in the website URL. 

If your website supports functionality where the Customer’s Code can be posted for them to lookup their details on 

your site, register for a competition, etc., it is possible to do this with the additional embedded data which can now be 

utilised. Any of the other tags can also be used as part of the website URL. 

 

The additional data which can now be embedded into the receipt QR Code is listed as follows: 

 

[DATE] – This will embed the date of the sale in the format of DD MMM YYYY HH:MM:SS (e.g. 01 Sep 2021 15:53:25). 

[CUSTOMERCODE] – This will embed the Customer Code. 

[CUSTOMERNAME] – This will embed the Customer Name. 

[TAX] – This will embed the Tax amount for the sale. 

[AMOUNT] – This will embed the total amount for the sale. 

[ddMMyy] – This will embed the date in the short format of ddMMyy. E.g. 010921, where dd is the day of the month, 

mm is the month number and yy is the year. 

[INV] – This will embed the invoice number. E.g. 000731-2. This is essentially the Audit Number and POS Terminal 

number which performed the sale (as shown in the Journal History Enquiry). 

 

  

http://www.mycompany.com/%5bCUSTOMERCODE
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To configure and use this function, go to: Idealpos Back Office > Setup > Global Options > Printing 

 

Enable Print on Receipt Footer 

QR Code Size: We recommend entering a number of 4 or greater so that the QR Code is prominent on the receipt, 

however, you may enter any size that you desire. This may require trial and error to find a size which is suitable for 

your requirements. 

 

Receipt QR Code Data: Enter the tags that you require to be embedded in the QR Code data. 

Text underneath Code: There are two fields available for you to enter any text that you’d like to have printed below 

the QR Code. You can enter A message to your customer to scan the QR Code for more information, Scan QR Code to 

go to your website, etc.  
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The below example shows each of the new tags entered into the Receipt QR Code Data field: 

 

 
 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 1 - Update History Page 40 of 198 

 

When a sale is completed and receipt printed, the QR Code will be printed at the bottom of the receipt. The QR Code 

will contain the embedded data as configured above. In the event that no data is available for an entered tag (such as 

when a customer has not been added to the sale but the Customer Tag exists in the QR Code Data), the 

[CUSTOMERCODE] and [CUSTOMERNAME] tags/data will not appear in the QR Code. 

 

The below example shows a receipt for a sale which did not have a customer entered and the resulting QR Code text. 
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 The below example shows a receipt for a sale which had a customer entered and the resulting QR Code text. 
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IP-4391 – Saudi Arabia region – Support for QR Codes on Arabic receipts 

This function adds the ability to print QR Codes on receipts that contain Arabic characters. 

Note that this function is only applicable to the Saudi Arabia region. 

 

In order to use this functionality, some additional configuration is required which has been summarised and outlined 

below: 

 

- The Receipt Printer must be installed as a Windows Printer with the correct Windows Printer Driver (do not use 

Generic Text Only), and the printer must be shared. You will need to obtain the relevant Windows Printer 

Driver for your receipt printer. 

- Use the Windows Shared Printer method to add the printer via POS Terminal Setup (Back Office > Setup > 

POS Terminals > Select Terminal > Modify > Receipt Printer > Type = Select Printer, Connection = 

\\PCIPADDRESSWherePrinterIsShared\SharedPrinterName) 

- In the Windows Printer Driver, turn off “Automatic Paper Cut” – This results in two separate print jobs being 

sent to the printer then a cut to make it appear as one receipt. 

- Enable “Arabic Print Style” and “Use Windows Driver” in Setup > Global Options > Printing 

- QR Code data is configured via Setup > Global Options > Printing 

 

Each of the above points are outlined in further detail as follows: 

 

- Obtain the required Windows Printer Driver for your Receipt Printer.  

In this example, a TP-100 printer was used and the Printer Driver was obtained from www.senortech.com.au, 

however, this will differ depending on the make and model of the printer being used. 

The below steps are for the TP-100 Printer: 

Install the TP-100 Printer Driver by pressing “Next” through the installation process. 

Once the Printer Driver install program is displayed, select the Printer from the dropdown box, then press the 

“Add Port” button as shown in the example below: 

 

 
 

  

file://///PCIPADDRESSWherePrinterIsShared/SharedPrinterName
http://www.senortech.com.au/
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Select “Standard TCP/IP Port” 

 

 
 

Press “Next” on the “Add Standard TCP/IP Printer Port Wizard” 
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Enter the IP Address of the printer, then press “Next” 

 

 
 

It is more than likely that the device won’t be found on the network. 

Select “Custom” and press “Settings” 
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A window similar to the following will be displayed. Confirm that Printer IP Address appears in the Port Name 

and Printer Name or IP Address fields as shown in the below example, then press OK:  

 

 
 

Press “Next” on the “Add Standard TCP/IP Printer Port Wizard” 
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Press “Finish” to complete the “Add Standard TCP/IP Printer Port Wizard” 

 

 
 

The Printer Driver install program will show the IP address of the printer next to the Port field. 

Press the “Install” button to install the Printer Driver using the IP address settings that were just configured. 
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After the driver has been installed, a SUCCESS prompt will be displayed. Press “OK” to continue. 

 

 
 

The Printer Driver install program will appear. 

Press the “Exit” button to close the driver installer 
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Press the “Exit” button on the Senor Printer Driver installer. 

 

 
 

Now that the Printer Driver has been installed, you will need to Share the Printer, enable “Allow” access on the 

Printer Security settings and disable printer cut. 

Go to: Windows Start button > Settings 
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Select “Devices, Bluetooth, printers, mouse” 

 

 
 

Select “Printers & scanners” from the menu on the left-hand side, then select the TP100 Printer on the right-

hand side: 
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After selecting the TP100 Printer, additional buttons will appear.  

Select “Manage”. 

 

 
 

Select “Printer properties”. 
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Go to the Sharing tab, enable “Share this printer” and enter a Share name of “TP100”. 

 

 
 

Go to “Device Settings” and set the Paper Cut setting to “No cut” 
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You will also need to enable Allow access to the printer for all users. 

Go to the “Security” tab and enable all checkboxes in the “Allow” column for Everyone and each User. 

 

 
 

Press “OK” to close and save all changes to the TP100 Printer properties. 
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Go to Idealpos > Back Office > Setup > POS Terminals > Select POS Terminal > Modify. 

In the “Receipt Printer” tab, configure the Receipt Printer. 

Set type to “Epson TM-T88”. 

Set Connection to: \\IPADDRESS\SHARENAME 

Replace IPADDRESS with the IP Address of the POS terminal which the printer driver was installed onto and 

replace SHARENAME with the name of the Printer Share. E.g. \\192.168.1.83\TP100  

You should ensure that the POS Terminal/PC IP Address is set to static, or has an IP Address reservation. 

NOTE – If you enter incorrect details into the Connection field and press the “Test” button (which results in a 

failed test print), entering correct details and pressing “Test” may also result in a failed test print, even though 

the Connection setting was corrected and should have yielded a successful result. To ensure that the printer 

connection settings have been applied, you may need to close the POS Terminals setup window, re-open the 

POS Terminals setup window, then try the Test button again to ensure that the updated Receipt Printer 

Connection settings are being used for the test print.   

 

 
 

  

file://///IPADDRESS/SHARENAME
file://///192.168.1.83/TP100
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- In Idealpos, go to: Setup > Global Options > Printing > Enable “Arabic Print Style” and “Use Windows Driver” . 

To enable QR Codes on your receipt, also ensure that you enable and configure the following settings: 

QR Code Size (to ensure that the size of the QR Code is prominent on the receipt, we recommend a size of 4 

or greater). 

Enable Print on Receipt Footer 

Enter the Receipt QR Code Data – This can be any data you want to embed in the QR Code such as your 

company website, etc. When the Customer scans the QR Code, their mobile device will read the data. 

Text underneath Code – This is any text that you want printed below the QR Code (e.g. Scan the QR Code to 

visit our website!). 
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- This concludes the configuration required for setting up a printer with QR Codes on Arabic Receipts. 

When a receipt is printed, it will contain the QR Code at the bottom of the receipt. 
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eCommerce Interface 

IP-4114 – eCommerce Option – Receive Prepaid Orders as Unpaid 

This function adds the ability to receive Prepaid Orders as Unpaid. 

This may be beneficial to customers who want the ability to recall and tender a prepaid order from a particular POS 

Terminal. 

When enabling this option, “Automatically Finalise Prepaid Orders” will be unticked if it was initially enabled.  

 

To enable this function, go to: Setup > Global Options > Interfaces > eCommerce 

Enable the option “Receive Prepaid Orders as Unpaid” 
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Prepaid Web Orders can be retrieved by pressing the Web Order button at the top of the POS Screen. 
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EFTPOS 

IP-101 – Quest WEX Australia Integrated Fuel Cards 

This function adds support for Quest WEX Australia Integrated Fuel Cards to Idealpos. 

Before proceeding with the below steps, be aware that you may need to contact Quest so that they can perform any 

additional configuration on their end to enable Quest WEX Australia Integrated Fuel Cards. 

 

To configure and use this function, ensure that your Quest EFTPOS terminal is configured and communicating with 

Idealpos. 

Then go to: Back Office > Setup > POS Terminals > Select Terminal > Modify. 

In the EFTPOS Settings tab, ensure that “WEX Fuel Cards” have been enabled . 

 

 
 

You will also need to ensure that your Stock Items have been mapped to the appropriate Quest Product Code. 

Go to: File > Stock Control > Stock Items. 

Double-click on an item or select an item and press “Modify”. 

In the Stock Item window, go to the “Advanced” tab. 
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Towards the bottom-right corner of the window, enter the Quest Product Number, then press the “Save” button  on 

the top-left corner of the window. 

The Quest Product Number entered below is simply an example; ensure that you refer to your Quest Product Details 

for the correct number, then enter it into the field shown below. 

 

 
 

Repeat this process for each Stock Item which has a corresponding Quest Product Number. 

Once the Quest Product Numbers have been entered for all the applicable items, we recommend restarting Idealpos 

to ensure that the WEX Fuel Cards setting has been applied. 

 

This concludes the Idealpos configuration for this function. 

As noted further above, Quest may need to be contacted so they can perform additional configuration which may be 

required to enable this functionality. 
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IP-4330 – Vault EFTPOS – Support for v4.5 API including Pinpad Tips/Surcharges 

This function adds support for the V4.5 API which includes Pinpad Tips and Surcharges. 

Pinpad Tips and Surcharges can be configured via the EFTPOS GUI Interface, typically accessible by right-clicking on 

the Vault icon on the Windows Taskbar. 
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Export Data 

IP-4307 – Support for AutoDiscount field in Customer Export 

This function adds the AutoDiscount field to the Customer Export format. 

The Auto Discount field stores the automatic percentage discount value that is applied to items purchased by the 

Customer. 

Previous to this change, the AutoDiscount field was only supported when importing Customers, however, the 

AutoDiscount field was not exported when performing a Customer Export. 

 

There is no additional configuration required to enable the exporting of the AutoDiscount  field. The field will be 

included in the exported data, and if the customer has an Auto Discount entered, this will be included in the exported 

data. 

 

Go to: File > Customers > Customers 

Select a Customer from the list > Modify. 

Ensure that a value has been entered into the Auto % Discount field as shown in the below example: 
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Perform a Customer Export by going to: Back Office > Enquiry > Customers 

Press the “Export” button on the bottom-left corner of the Customer Enquiry window. 
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Browse to a folder where you want the data to be exported. 

When saving the Customer Export, you can either save it as a Microsoft Access (.mdb) file, or a Text File (.txt).  

Enter a File name, then press “Save”. 

 

 
 

The data will be exported and will include the AutoDiscount field.  

The AutoDiscount field is the last field in the Export File: 

 

CODE,LASTNAME,FIRSTNAME,MIDDLENAME,TITLE,ADDRESS1,ADDRESS2,SUBURB,STATE,POSTCODE,PHONE,MOBILE,F

AX,EMAIL,GENDER,COMPANY,OCCUPATION,MARITALSTATUS,DOB,DOB2,NEXTOFKIN,CONTACTNO,COMMENTS1,CO

MMENTS2,TYPE,PASSWORD,MAILOUT,ACCOUNT,CREDITLIMIT,PRICELEVEL,ABN,POINTS,SCAN,SALESPROMPT,UDTEXT

1,UDTEXT2,UDTEXT3,UDTEXT4,UDTEXT5,UDTEXT6,UDTEXT7,UDTEXT8,UDTEXT9,UDTEXT10,UDYESNO1,UDYESNO2,UDY

ESNO3,UDYESNO4,UDYESNO5,AUTODISCOUNT 

 

The following line is an extract from the Customer Export file for the Customer shown further above, with the 

AutoDiscount value highlighted. 

 

"         2","Charlton","Sarah","","Miss","42 Wallaby 

Way","","Hampden","NSW","","0765536455","0499754163","","","F","","","","06-Sep-1987","02-Mar-

2015","","","","","2","","1","0","0","1","","580","9850859357357","","","","","","","","","","","","False","False","False","False","Fa

lse","5"  
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Gaming 

IP-4402 – Max Gaming – MembershipTypeID support for Promotions 

This function only applies to Max Gaming and adds the ability to assign promotions to a Membership Type.  

The Promotions will then only trigger for members that are in the Membership Type specified within the Promotion. 

Promotions are assigned to a Membership Type ID via a User-Defined option in the Promotion Advanced tab. 

 

To configure this function, go to: Back Office > File > Sales > Promotions > Promotions. 

Select a Promotion from the list > Modify 

 

 
 

Within the Modify Promotion window, press the “Advanced” tab. 

In the User-Defined Text field, enter [MEMBERSHIPTYPEID=ID]. 

Replace ID with the Membership Type ID from Max Gaming. 

E.g. If the Membership Type ID was 123456, you would enter [MEMBERSHIPTYPEID=123456]. 

Once you have entered the Membership Type ID, either press the “Save” button on the top-left corner of the window 

(the Save button is only displayed on larger screen resolutions), or close the window. 

 

 
 

When closing the window without using the Save button, a Save Changes prompt will be displayed. Press “Yes”. 
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Gift Vouchers 

IP-3895 – Gift Voucher – Site Identification 

This function adds details to the bottom of the Gift Voucher which identify the Site and POS Terminal which issued the 

Gift Voucher. If a Site does not have their Gift Vouchers configured correctly or if there is any confusion in regards to 

where a Gift Voucher was issued, this functionality will enable both the Support Staff and Clerk to easily determine the 

issuing site. 

The Site Name that will be displayed on the bottom of the Gift Voucher is retrieved from the Trading Name in the 

Idealpos Licence Gateway. 

 

To use this function, ensure that the following conditions are met: 

 

Email is configured in Idealpos 

Customer has an email address entered either in their Customer Record or email address is entered when selling the 

Gift Voucher. 

For more details on how to setup and use Gift Vouchers, refer to the Gift Voucher topic in the Idealpos User Guide – 

https://userguide.idealpos.com.au  

 

Once the Gift Voucher is sold and emailed to the Customer as a PDF file, the name of the issuing site will appear at the 

bottom of the Gift Voucher as per the below example: 

 

  

https://userguide.idealpos.com.au/
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Ideal Kitchen Monitor 

IP-4160 – Ideal Kitchen Monitor – Rush Order Function 

This function adds the ability to rush or expedite an order sent from Idealpos to Ideal Kitchen Monitor.  

This is achieved by adding a Stock Item containing either of the following descriptions:  

EXPEDITE ORDER  

RUSH ORDER 

 

Any order that is sent to Ideal Kitchen Monitor which contains an item with the above descriptions will trigger that 

order to be moved to the front of the other orders that have already been placed. 

The first rushed/expedited order will appear on the top-left corner of the Ideal Kitchen Monitor and other orders will 

be moved across as shown in the example below. Any additional rushed/expedited orders that are sent will be 

displayed next to the first rushed/expedited order. 
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In order to use this function, you must have Ideal Kitchen Monitor 3 installed; this functionality is not available or 

supported on Ideal Kitchen Monitor versions older than 3.0.0.1.  

 

To configure this function, go to: Back Office > File > Stock Control > Stock Items 

Press the “Add” button on the top-left corner of the Stock Items window. 

Create a new Stock Item with a description of either RUSH ORDER or EXPEDITE ORDER 

Enter the description into all description fields (Description, Kitchen Description, Long Description/Description 3). 

Note that you do not need to enable the IKM printer in the Printer Settings, however, doing so will not affect this 

function but rather will also trigger RUSH ORDER to appear as an item within the order sent to Ideal Kitchen Monitor. 

Once complete, press the “Save” button on the top-left corner of the window to create the item. 
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In order to trigger this function, a button will also need to be created on the POS Screen. 

Close the Stock Items windows, then go to:  

Back Office > Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 

 

 
 

Select a suitable POS Screen tab which contains a blank POS Screen button which you’d like to assign to the Rush 

Order/Expedite Order function. 

The below example shows the Admin tab which has several unused blank buttons that can be assigned. 
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Select a button and link it to the Stock Item function. 

In the Stock Item field, press the “>” button and search for the RUSH ORDER/EXPEDITE ORDER Stock Item that was 

created further above. 

Ensure that you press “Save” to create the button on the POS Screen. 

 

 
 

Close the POS Screen Layout windows, then return to the POS Screen by pressing the “POS” button on the top -left 

corner of the Back Office dashboard. 
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Add the required Stock Items to the sale, then ensure that the “RUSH ORDER” or “EXPEDITE ORDER” button has been 

pressed. Finally, either save the sale to a table or finalise the order and pay for it. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 1 - Update History Page 71 of 198 

 

The order will be rushed/expedited ahead of the other orders which have already been sent to the Ideal Kitchen 

Monitor. 

In the below example, the order shown on the top-left corner of the Ideal Kitchen Monitor shows “###RUSH 

ORDER###” in the header and it was the last order that was sent to the IKM (as indicated by the time lapsed shown on 

the top-right corner of that order). 
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Import Data 

IP-4097-Import File Filters – Default includes CSV 

This function enhances the Import File window that is used when you are importing data into Idealpos via the Back 

Office > Utilities > Import Data menu. 

Previous to this change, the “Text files” filter would only include files with a .txt file extension.  

In order to import a file containing a .csv file extension, you would have to select the File type dropdown box, then 

select the CSV option. When CSV data is being frequently imported into Idealpos, this would result in an extra step of 

having to select the dropdown box each time and change to the CSV format. 

 

This change now includes files with extensions of both .txt and .csv.  

It is no longer necessary to select the file type dropdown box and specifically choose “CSV”.  

 

To use this function, go to: Back Office > Utilities > Import Data. 

Select any required option to open the Import data window. For this example, we’ll select “Departments”. 

 

On the Import Departments window, press the small magnifying glass icon: 

 

 
 

The “Select a source file” window will appear. 

The Text files option now includes both .txt and .csv file extension files, making it unnecessary to have to change the 

file type when importing data. 
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IPS Client 

IP-4262 – IPSClient displays SQL Server version and blocks invalid overwrites 

This change adds additional functionality to the IPS Client to assist with the process of identifying terminals at a site 

that may be running different versions of SQL Server.  

As part of this change, the Standard, Filtered and Offline overwrite functions in IPS Client will now block overwrites 

from being sent to destination terminals which are running an SQL Server version that is older than the SQL Server 

version installed on the source terminal. This change has been made to prevent issues with data caused by invalid 

overwrites from occurring. We recommend that all terminals are running matching versions of SQL Server. 

 

To view SQL Server versions of other terminals in the IPS Client, go to:  

Windows System Tray > Click on the IPSClient icon. 

If the icon is hidden, you may need to press the up arrow in the system tray to show any hidden icons. 

 

 
 

After pressing the IPS Client in the Windows System Tray, the IPSClient window will appear. 

 

 
 

Click on any terminal in the list to display the IPS Client – Terminal Overview. 

The SQL Server version will appear next to the CPU details as shown in the below example: 
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Close the IPS Client – Terminal Overview window. 

The Standard, Filtered and Offline overwrite functions will prevent overwrites from being sent to terminals that are 

running an SQL Server version that is older than the source terminal. 

In the IPS Client window, go to: Network > Overwrite > Standard… 

 

 
 

The Overwrite Database Select window will not allow overwrites to be sent to terminals which are running SQL Server 

versions older than the source terminal. Attempting to enable the “Include” tickbox on terminals running older SQL 

Server versions will result in nothing happening and the tickbox not being enabled. 

This functionality applies to Standard, Filtered and Offline overwrites. 

The SQL Server version running on the current terminal that is performing the overwrite is displayed in brackets next 

to the text “Select terminals to receive overwrite”.  

The below example shows the source terminal running SQL Server 2019: 
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Kiosk 

IP-3826 – Kiosk Module – Lock Floating Grids in place 

This function locks floating grids in place only on the Kiosk module. 

As the Kiosk module is a customer-operated function, customers tend to use the system differently to standard clerks. 

One of the capabilities of the Idealpos POS Screen is the ability to click and hold on the title bar of a floating grid, then 

drag it anywhere on the screen. This poses a problem on Kiosk terminals as the next time the floating grid is displayed; 

it reappears in the location where it was moved to by the previous customer. 

 

To prevent customers from moving floating grids around on Kiosks, the ability to move floating grids on Kiosks has 

been disabled by completely hiding the title-bar of the floating grid.  

There is no additional configuration required on terminals running the Kiosk module. 

Any standard POS terminals which are not operating in Kiosk mode will still display the title-bar on the floating grid, 

enabling them to be dragged around, whereas on Kiosk terminals, the title-bar will be hidden, making it impossible to 

move the floating grid around the screen. 

 

A grid can be set to display as a floating grid by going to: Back Office > Setup > POS Screen > Grids 

Select a POS Screen Grid from the list > Modify 

Enable the option “Floating Grid with Programmable Size”.  

Press the “Save” button on the top-left corner of the window to save the change. 
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The Floating Grid title bar is displayed on standard POS Screens (non-Kiosk) as per the below example: 

 

 
 

The Floating Grid title bar is hidden on Kiosk screens as per the below example: 
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Licensing 

IP-4270 – Licensing – Stock Control Module 

This function adds a new Stock Control module to Idealpos Licensing. 

In order to access Stock Control functionality, this module will need to be enabled in the Licence Gateway. 

In addition to the implementation of Stock Control functionality to the Idealpos Licence Gateway, the following 

EFTPOS integration names have been updated in the Licence Gateway and the EFTPOS dropdown box in Setup > POS 

Terminals > Modify > EFTPOS Settings: 

- DPS has been renamed to Windcave 

- PC-EFTPOS AU has been renamed to Linkly 

 

The Stock Control module will control whether the following options are available or not (when Stock Control is 

enabled in the licence, the below options and functions will appear, when disabled, the following menus and functions 

will be hidden and unavailable).  

 

File > Stock Control > Write-Off Categories 

File > Stock Control > Stock Items by Location 

File > Sales > Stock Item Variants 

File > Purchases > Purchase Categories 

File > Suppliers > Suppliers 

File > Suppliers > Supplier Stock Codes 

 

Enquiry > Suppliers 

 

Transactions > Stock Control > Stock Purchases 

Transactions > Stock Control > Stock Write-Offs 

Transactions > Stock Control > Stock Transfers 

Transactions > Stock Control > Manufacture Items 

Transactions > Suppliers > Supplier Payments 

Transactions > Suppliers > Supplier Adjustments 

 

Listings > Stock Control > Write-Off Categories 

Listings > Purchases > Purchase Categories 

Listings > Suppliers > Suppliers 

Listings > Suppliers > Supplier Stock Code 

 

Reports > Stock Control > Stock Movement 

Reports > Stock Control > Stock Transaction 

Reports > Stock Control > Stock Valuation 

Reports > Stock Control > Stock Levels by Location 

Reports > Stock Control > Stock Transfers 

Reports > Stock Control > Stock Write-Offs 

Reports > Stock Control > Write-Off Category 

Reports > Stock Control > Re-Order 

Reports > Stock Control > Stock Ordered 

Reports > Stock Control > Price Changes 

Reports > Stock Control > Archived Stocktakes 

Reports > Purchases > Purchase Category 

Reports > Purchases > Stock Purchases 

Reports > Purchases > Purchase Orders 

Reports > Purchases > Supplier Transaction 

Reports > Purchases > Supplier Tax Report 

Reports > Purchases > Supplier Trial Balance 
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Stocktake > Start Stocktake 

Stocktake > Stocktake Forms 

Stocktake > Enter Stocktake 

Stocktake > Stocktake Variance Report 

Stocktake > Stocktake Valuation Report 

Stocktake > Generate Stock Transfer 

Stocktake > Update Stock Levels 

Stocktake > Clear Stocktake 

 

Utilities > Calculate Recommended Stock Levels 

Utilities > Export Data > Supplier Invoices and Credits 

Utilities > Import Data > Suppliers 

 

Within the Stock Items screen (File > Stock Control > Stock Items), the following functions are also controlled via the 

Stock Control Module: 

 

Locations/Stock Items by Location 

Supplier Codes 

Default Supplier 

Default Supplier Stock Code 

Stock Control checkbox 

Variants checkbox and Variants tab 

Indirect Item checkbox and Indirect Item tab 

Stock Item Manufacturing (Manufactured Item checkbox)  
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Multi-Site Management - Head Office  

IP-3861 – Head Office – Support for Site Groups 

This functionality is only available on an Idealpos system which has the Head Office module enabled in the Licence 

Gateway. 

This function adds the ability to group each Site into a maximum of 10 Site Groups. 

This can then be used to filter the list of sites by the configured Site Groups when viewing a list of Sites via the Sites 

function (Setup > Sites) as well as used for filtering sites by Site Group when running reports from the Head Office 

which support the Sites field. 

Each of the 10 Site Groups can be given a name (e.g. State, Region, Location, Brand, Business Type, etc.) of up to 30 

characters in length. 

Once the Site Group names have been created, you can then modify each Site and enter the details that pertain to the 

Site Group name. 

E.g. Create or modify a Site and enter “Queensland” into the State field, “Brisbane” into the Region field, “River Mall 

Shopping Centre” into the Location field, “ACME” into the Brand field and “Restaurant” into the Business Type field. 

This process can be repeated for each Site in your system, then once they have been configured with this functionality, 

it will be possible to run reports by Site and filter by Site Group. 

 

To configure and use this function, go to: 

Back Office (on a Head-Office system) > Setup > Sites 

On the bottom-left corner of the Sites window, press the cog icon: 
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The Site Groups window is displayed. 

Enter the Site Groups that you want to create, then press the “Save” button on the top-left corner of the window. Note 

that each Site Group is limited to 30 characters. Also note that when you enter details into each of these Site Groups, 

there is also a 30-character limit  

Using all 10 Site Groups is not compulsory. The below example shows the following Site Groups: 

• State 

• Region 

• Location 

• Brand 

• Business Type 
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After pressing “Save”, the Sites window will be displayed and a column for each Site Group will appear at the top of 

the window. 
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Details can now be recorded against the new Site Groups. 

Select a Site from the list then press the “Modify” button on the top-left corner of the window. 

Fill in the required details that pertain to the Site into each of the Site Group fields, then press the “Save” button on 

the top-left corner of the window to save the changes. 

 

 
 

Repeat the above step for each site, entering details that are relevant to each site into the Site Group fields. 

In order for Site Group filtering to work correctly, ensure that you enter each Site Group name consistently.  

E.g. If you are entering "Bake Shop" into the "Brand" Site Group field, ensure that you consistently enter "Bake Shop" 

for each site that is part of the "Bake Shop" brand (don't enter "Bakeshop"). Entering inconsistent names for each site 

will result in each unique variation of the Site Group name appearing in the Site Group dropdown box, defeating the 

purpose of utilising the Site Groups function. 

Press the "Save" button on the bottom-right corner of the window to create a new site. 
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Once the Site Groups have been filled out for each Site in your system, each Site will contain a Site Group and it will be 

possible to filter the list using the dropdown boxes located at the top of the window. 

 

 
 

The below example shows the Region dropdown box which contains a listing of the regions which have been assigned 

to the Sites 
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Selecting an option from the dropdown box will filter the results shown: 
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In addition to utilising the Site Groups function for the Sites list (accessible via Back Office > Setup > Sites), it can also 

be used when running reports that support the Sites field from the Head Office and filtering by Sites. 

An example of such a report that allows filtering by Site is the Stock Item Sales Report. 

Go to: Back Office > Reports > Sales > Stock Item Sales 

In the Site field, click on the “>” button to display the Site list: 
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A list of Sites is displayed. 
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Filter the list by selecting one or more options from the dropdown boxes at the top of the window, then press the 

“Select All” button on the bottom-left corner of the window. This will select all Sites which are currently being 

displayed by the filter and move them into the Sites field in the report selection criteria. 
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After pressing “Select All”, the Site field will be updated using the range selected . 

Press the “View” button on the bottom-right corner to run the report: 

 

 
 

The Stock Item Sales Report is displayed and shows the Site Groups that were selected when running the report. 
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POS Screen 

IP-3805 – Add-On Taxes – Show current Tax Subtotal as sale is entered 

This function will display a combined tax total for all Stock Items that have been added to the sale below the sale 

window. 

This functionality only applies to regions that utilise add-on taxes (such as in the USA where the sell price of the item 

printed on the shelf excludes tax and when the customer pays for the item at the checkout, the tax is then added onto 

the item). The Tax Rate must also have the “Inc” option unticked, which implies that the tax is not included in the sale 

price and hence, the tax will be added to the item during payment. 

 

There is no additional configuration required to display the Tax Subtotal when the sale is entered, other than ensuring 

your Tax Rate is configured so that it is an “Add-On Tax” which adds the tax on when the items are added to a sale .  

You will also need to ensure that your Stock Items have the applicable tax rates enabled. 

 

To check your Tax Rates, go to: Setup > Global Options > Sales. 

Any Tax Rate which has the “Inc” option checked will mean that the tax is already included in the Stock Item Sell Price 

and will not be added onto the item when it is sold. 

Any Tax Rate which has the “Inc” option unchecked will mean that the tax will be added onto the Stock Item when the 

item is sold. 
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In order for the Tax Rate to apply to an item when the item is sold, the Stock Item must also have the applicable Tax 

Rate(s) enabled. 

Go to: File > Stock Control > Stock Items > Select a Stock Item > Modify (or double-click on the item). 

Ensure that the Tax Rates which are applicable to the Stock Item have been enabled. 

Check each item’s Tax Settings and ensure they’re configured as required. 

Alternatively, Range Programming can be used to enable the required Tax Settings for a range of items as a batch 

operation.  

Range Programming is available via Back Office > Utilities > Range Programming > Stock Items. 

Please use caution when using Range Programming as it is possible to modify all items as a batch operation; any 

mistakes made when using Range Programming cannot be easily undone. 
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Once the Tax Rates have been configured at the Global Options level and the Stock Item level, open the POS Screen 

by pressing the “POS” button on the top-left corner of the Back Office Dashboard. 

 

Add Items to the sale. 

The Tax will appear on the bottom-left corner of the sale window ($1.22 in the below example). The Total sale amount 

shown on the right-hand side of the sale window ($11.22 in the below example) is inclusive of the $1.22 Tax amount 

shown on the bottom-left corner of the sale window. 
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After the ENTER button is pressed and the Tender screen is displayed, the Total amount shown remains the same as it 

did during the sale, as shown in the example below. 
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IP-3602 – POS Screen support for 1366 x 768 resolution 

This function adds the ability to set the POS Screen Resolution to 1366 x 768. 

When using this POS Screen Resolution, the Sale Details area of the screen appears as a taller portrait -type area which 

enables the Clerk to see a longer list of items that have been added to the sale. 

 

 
 
  



 Update History 
Return to top 

Idealpos 8 Build 1 - Update History Page 95 of 198 

 

To use this POS Screen Resolution, go to:  
Setup > POS Terminals > Select the POS Terminal that you want to apply the resolution to > Modify 
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Go to the POS Settings tab, then from the POS Screen section, select resolution ‘1366 x 768 (16:9)’ from the 
Resolution dropdown box. 
 

 
 
Close the POS Terminals window to apply the change. 
If the POS Screen Resolution was changed for another POS Terminal, the POS Screen on the modified terminal may 
need to be closed then opened again in order to apply the change. 
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The POS Screen will now use the selected resolution: 
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IP-3963 – POS Screen support for 1920 x 1080 resolution 

This function adds the ability to set the POS Screen Resolution to 1920 x 1080. 

For optimum sizing and appearance, this POS screen resolution requires Windows screen scaling to be set to 125%. 

POS hardware that is being supplied by Idealpos which supports 1920x1080 will also have a Windows recommended 

screen scaling setting of 125%. 

This type of scaling is recommended on POS Screens at this resolution as POS Terminals typically have smaller screen 

sizes compared to standard desktop PCs. 
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To use this POS Screen Resolution, go to:  
Setup > POS Terminals > Select the POS Terminal that you want to apply the resolution to > Modify 
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Go to the POS Settings tab, then from the POS Screen section, select resolution ‘1920 x 1080 (16:9)’ from the 
Resolution dropdown box. 
 

 
 
Close the POS Terminals window to apply the change. 
If the POS Screen Resolution was changed for another POS Terminal, the POS Screen on the modified terminal may 
need to be closed then opened again in order to apply the change. 
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The POS Screen will now use the selected resolution: 
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IP-4123 – POS Screen support for 1920 x 1080 Retail Layout 

This function adds the ability to set the POS Screen Resolution to 1920 x 1080 (Retail Layout). 

This layout includes a sale window that occupies the entire width of the POS screen, allowing long Stock Item 

Descriptions to be displayed (when the Yes/No Option “Stock Item Long Descriptions on POS Screen” is enabled). 

For optimum sizing and appearance, this POS screen resolution requires Windows screen scaling to be set to 125%. 

POS hardware that is being supplied by Idealpos which supports 1920x1080 will also have a Windows recommended 

screen scaling setting of 125%. 

This type of scaling is recommended on POS Screens at this resolution as POS Terminals typically have smaller screen 

sizes compared to standard desktop PCs. 
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To use this POS Screen Resolution, go to:  
Setup > POS Terminals > Select the POS Terminal that you want to apply the resolution to > Modify 
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Go to the POS Settings tab, then from the POS Screen section, select resolution ‘1920 x 1080 (16:9) Retail’ from the 
Resolution dropdown box. 
 

 
 
Close the POS Terminals window to apply the change. 
If the POS Screen Resolution was changed for another POS Terminal, the POS Screen on the modified terminal may 
need to be closed then opened again in order to apply the change. 
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The POS Screen will now use the selected resolution: 
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IP-4159 – POS Screen – Support for Light Colour Theme 

This function adds the ability to change the colour theme used on the POS Screen. 

By default, the Standard Colour Theme is used which uses a darker blue colour. 

This can be changed to a Light Colour Theme which consists of a much lighter white colour. 

This function can be configured on a per-terminal basis, so depending on which area of your venue your POS Terminal 

is placed, the colour theme can be changed to match the surrounding environment. 

 

The below examples show the Light and Standard Colour Themes side-by-side: 

 

Light Colour Theme | Standard Colour Theme: 

 

 
 

To configure this function, go to: 

Setup > POS Terminals > Select POS Terminal > Modify 
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Within the POS Screen section of the POS Settings tab, set the Colour Theme to Light, then close the POS Terminals 

window to save the change. 
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From the Back Office, press the POS button on the top-left corner to open the POS Screen. 

 

 
 

The new Light Colour Theme has now been applied to the POS Screen: 
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IP-4269 – POS Screen – 3D button option removed in favour of Flat button performance 

3D buttons have been removed in favour of flat button performance. 

In previous builds/versions of Idealpos, configuring POS Screen Buttons to display in 3D would result in slower POS 

screen performance when opening and navigating between POS screens. This is due to embedded/built-in graphics 

cards in POS Terminals taking longer to render additional button effects. 

In order to increase POS Screen performance, 3D buttons have been removed. 

There are no additional steps required when upgrading an existing v7 system with 3D buttons to Idealpos v8. 

As part of the upgrade, 3D buttons will be automatically set to 2D buttons. 

It should also be noted that in Idealpos V7, in order to display PNG images on POS Screen buttons, you needed to 

have 3D buttons enabled. Therefore, as part of the upgrade process, any PNG images will be converted to JPG format 

and the button configuration will be automatically updated so that the converted images will be displayed on the POS 

Screen buttons. 

 

As a result of this change, the POS Button Type configuration option in the General tab of Global Options has been 

removed. 

 

Go to: Setup > Global Options > General.  

The “POS Button Type” configuration option is no longer available: 
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POS Screen buttons will appear in 2D format as shown in the example below: 
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IP-4291 – Customer Display – Support for 1280x800 resolution 

This function adds support for Customer Displays running at a screen resolution of 1280x800. 

This resolution is enabled by selecting the new resolution from the resolution dropdown box in the Display/Kiosk tab 

of the POS Terminal settings. 

 

To enable this function, go to: 

Back Office > Setup > POS Terminals > Select POS Terminal > Modify > Display/Kiosk 

Select the ‘1280x800’ option from the Resolution dropdown box. 

Select the required format from the Display Format dropdown box. 

 

 
 

Once the required selections have been made, close the POS Terminal window to save the change. 
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A Close Suite/Open Suite will also be required. 

Go to Start > Idealpos > IPSUtils > Close 

 

 
 

Start Idealpos either via the Idealpos Desktop Shortcut, or go to: Start > Idealpos > Idealpos. 

When the POS Screen is displayed, the Customer Display will appear using the selected screen resolution. 
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When items are added to the sale, items will appear using the selected Customer Display Format. 
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IP-4331 – Dynamic POS Menus by Attributes 

This function adds the ability to create and display dynamic POS Screen Menus by utilising the existing Stock Item 

Attribute Types function. When a POS Screen button has been linked to one or more attribute types (a maximum of 

three Attribute Types can be linked to the POS button) and the clerk presses the POS Screen button, a dynamic POS 

Screen Menu will be displayed. The menu will contain a list of all the Stock Items that are linked to the Stock Item 

Attributes which were configured on the POS Screen button. 

A dropdown box for each Attribute Type linked to the button will be displayed at the top of the POS Screen menu. 

The dropdown boxes can be used to filter the list down to the individual Attribute. 

 

The process for configuring this function may vary depending on whether or not you already have the required 

Attribute Types/Attributes created and assigned to your items. 

For the purpose of demonstrating this function, each step required to configure this function is outlined below, using 

Soft Drinks as an example (Attribute Types: Container Type and Sugar Free?).  

However, you can use this function for any other items such as wine 

 

The first step to setting up this function is ensuring that you have the required Stock Item Attributes in your system. 

Go to: Back Office > File > Sales > Stock Item Attributes. 

The Attribute Types are shown on the left-hand side column, and the Attributes for the currently selected Attribute 

Type will be shown on the right-hand side column. 

For the purposes of demonstrating this function, we will create two Attribute Types –  

• Container Type – Used to filter the list by container type/size of container 

• Sugar Free – Used to filter the list by whether or not the item is sugar free (e.g. Diet Soft Drinks) 

 

Press the “Add New Attribute Type” button on the top left-hand side of the window, then enter a description for the 

Attribute Type (e.g. Container Type or Sugar Free); Press “Save” on the top-left corner.  

After creating a new Attribute Type, it will be highlighted automatically – Press the “Add New Container Type” or “Add 

New Sugar Free?” button on the top-left corner to add new Attributes to the Attribute Type.  

E.g. For Container Types, create attributes such as 600ml Bottle, 1L Btl, etc.  

For Sugar Free?, create attributes Yes and No.  

Take note of the Type Code shown next to the Attribute Type and the Code shown next to the Attribute (these will be 

used later when creating a POS Screen button). 

 

The below example shows the Container Type Attribute Type on the left, with each Container Type on the right. 
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The below example shows the Sugar Free Attribute Type on the left, with the No and Yes Attributes on the right. 
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Once Attribute Types and Attributes have been created, Stock Items will need to be assigned to the corresponding 

Attribute Types and Attributes (e.g. COKE 2L will need to be linked to Container = 2L Bottle, Sugar Free? = No). 

Go to: File > Stock Control > Stock Items 

Search for the required items (e.g. by Department), select the required item from the Stock Items grid > Modify.  

From the Attributes section on the bottom-right corner of the window, select the Attribute Type from one of the first 

dropdown boxes on the left (e.g. Container Type), then select the Attribute from the corresponding dropdown box on 

the right (e.g. 2L Bottle). 

 

Take note that when configuring Attribute Types, you may want to ensure that you always assign the same Attribute 

Type to the same Attribute Slot across all your items (e.g. Attribute 1 for Container Type, Attribute 2 for Sugar Free?, 

etc.). This is not explicitly required for this function; however, it will be beneficial utilising the same Attribute Slots for 

the purpose of filtering the Stock Items grid by Attributes. 

 

 
 

Repeat the above process to link other items to the required Attribute Types/Attributes. 
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Alternatively, you can utilise the Range Programming function to assign items by range to the required Attributes and 

Types. However, your items will need to be within a specific range (whether a Code, Description, Department and/or 

Supplier Range). 

Range Programming is an advanced feature and should be used with caution; incorrect use of Range Programming 

can result in the wrong items being modified. 

Range Programming is accessible via Back Office > Utilities > Range Programming > Stock Items 
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Once your Stock Items have been linked to the required Attribute Types/Attributes, you will need to create one or 

more POS Screen buttons. 

Go to: Back Office > Setup > POS Screen > POS Screen Setup 

Select a POS Screen Layout > Buttons 

On the POS Screen Layout, select a POS Screen tab where you’d like to create the button, then find an unused button 

and click on it. 

A button can be configured in the following ways: 

 

• Display all Stock Items linked to one or more Attribute Types, regardless of their Attribute Code.  

E.g. Entering both the Container Type and Sugar Free? Attribute Type codes will show a dynamic POS Screen 

containing any Stock Items linked to these types, and the menu will allow you to select an Attribute from the 

Attribute Type dropdown box at the top of the POS menu. 

 

Function: POS Screen Menu  

Attribute: T{ENTER ATTRIBUTE TYPE CODE}. Alternatively, press the ">" button to open the Stock Item 

Attributes window and select the Attribute Type or Attribute. In the Attributes window, you will need to select 

the required Attribute Type or Attribute, press OK. If additional Attribute Types or Attributes need to be 

added, press the ">" button again and repeat the process until you have added each of the required Attribute 

Types/Attributes. 

E.g. Enter “T1,T10” into the Attribute field to link to Container Type and Sugar Free (if your system is 

configured the same as the Stock Item Attributes further above). A maximum of three unique Attribute Types 

can be entered, separated by commas. 

POS Screen Menu: Leave Dropdown option blank (not used for this function) 

Button Caption: Container Types 
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• Display Stock Items linked to a specific Attribute.  

E.g. Entering the Attribute Code that’s linked to the 2L Bottle Attribute will only show a dynamic POS Screen 

menu containing Stock Items that are 2L Bottles, and the dynamic POS Screen menu will be locked to this 

Attribute Code. 

 

Function: POS Screen Menu 

Attribute: A{ENTER ATTRIBUTE CODE}. Alternatively, press the ">" button to open the Stock Item Attributes 

window and select the Attribute Type or Attribute. In the Attributes window, you wil l need to select the 

required Attribute Type or Attribute, press OK. If additional Attribute Types or Attributes need to be added, 

press the ">" button again and repeat the process until you have added each of the required Attribute 

Types/Attributes. 

E.g. Enter “A5” into the Attribute field to link to the “2L Bottle” Attribute. A maximum of three unique Attribute 

Codes can be entered, separated by commas. 

POS Screen Menu: Leave Dropdown option blank (not used for this function) 

Button Caption: 2L Bottles 
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• Display Stock Items linked to Attribute Types and Attribute Codes. 

E.g. Entering the Attribute Type Code that’s linked to the Container Type and entering the Attribute Code 

that’s linked to “Yes” (in the Sugar Free? Attribute Type) will show a dynamic POS Screen menu containing any 

item that is associated with the Container Attribute Type AND has the Sugar Free? Attribute Type set to “Yes”. 

 

Function: POS Screen Menu 

Attribute: T{ENTER ATTRIBUTE TYPE CODE},A{ENTER ATTRIBUTE CODE}. Alternatively, press the ">" button to 

open the Stock Item Attributes window and select the Attribute Type or Attribute. In the Attributes window, 

you will need to select the required Attribute Type or Attribute, press OK. If additional Attribute Types or 

Attributes need to be added, press the ">" button again and repeat the process until you have added each of 

the required Attribute Types/Attributes. 

E.g. Enter “T1,A59” into the Attribute field to link to the “Container Type” Attribute Type and to the “Yes” 

Attribute Code (located in the Sugar Free Attribute Type). 

POS Screen Menu: Leave Dropdown option blank (not used for this function) 

Button Caption: Sugar Free Container Types 

 

 
 

Once the POS Screen buttons have been configured as required, close the POS Screen Layout screens, then open the 

POS Screen by pressing the “POS” button on the top-left corner of the Dashboard. 

 

Navigate to the POS Screen tab which the button(s) were created, then press them. 

 

Depending on whether the button was linked to an Attribute Type, Attribute Code, or both, the window that appears 

in the POS Screen will be similar to the below example and will contain a list of items that are associated with the 

Attribute Types/Attributes linked to the POS Screen button: 
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The top-left corner of the window contains a dropdown box for each Attribute Type. 

The number of dropdown boxes shown will vary depending on the number of Attribute Types and/or Attribute Codes 

that were configured, with a maximum number of three dropdown boxes. 

The dropdown boxes can be pressed to display a list of all the available Attributes for the Attribute Type.  

Selecting an Attribute from the dropdown list will filter the POS Screen Menu so that only items that are associated 

with the selected Attribute Type will be displayed.  

The list can be filtered further by selecting another Attribute option from the remaining dropdown boxes 

 

 
 

Selecting an item from the list will highlight it.  

 
 
Once an item has been selected, additional options (Locations and Sell Item) will be displayed at the bottom of the 
window. To see the Locations which the item is available, press the “Locations” button on the bottom-left corner of 
the window. To add the item to the sale, press the “Sell Item” button on the bottom-right corner of the window. 
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If an Attribute Code was entered into the POS Screen button configuration, the dropdown box for that Attribute Code 

will be locked/read-only. 

The below example shows the “Sugar Free?” Attribute Type dropdown box locked to the “Yes” Attribute option . The 

Container Type option is available and can be selected to filter by Container Type. 
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IP-4401 – Tender Finalise warning includes tenders and amounts 

This function will display a Tender Finalise warning containing the tender types and amounts that were used to tender 

the sale. The Tender Finalise warning will be displayed and will show all tender types and amounts used to tender the 

sale when the Tender Finalise warning has been enabled for at least one of the tender types that were used to tender 

the sale.  

 

To configure this function, go to: Setup > Yes/No Options. 

In the Search, enter “warning” 

Ensure that the Finalise Warning option has been enabled for the Tender Types which you want to receive the warning. 

As mentioned above, if your sale has been tendered using multiple tender types with at least one tender type having 

the warning enabled, then the warning will include ALL tender types and amounts that were used to tender the sale. 
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Close the Yes/No Options window once the Finalise Warnings have been configured as required. 

Go to the POS Screen (press “POS” button on the top-left corner of the dashboard), add items to the sale, then press 

the “ENTER” button to go to the Tender screen. 

To split the payment across multiple tenders, ensure that you enter an amount that is less than the total sale amount, 

then press a Tender button to tender the entered amount.  
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The amount entered will be allocated to the tender pressed, then the remaining due amount will be displayed.  

When tendering the sale, ensure that at least one of the tenders used has the finalise warning enabled. 

In the below example, $5.00 has been tendered against Cash, $5.00 is outstanding which will be tendered against 

AMEX/DINERS. 

 

 
 

If you want to split the remaining amount between more than one tender, ensure that you enter an amount that is less 

than the remaining amount and press a tender. The entered amount will be tendered against the next selected tender. 

Repeat the process until the entire sale amount has been tendered. 

 

Once the last outstanding amount has been tendered (and at least one of the tenders used had the finalise warning 

enabled), the finalise warning will be displayed and will contain a list of all tenders which have been used and their 

respective amounts. 

To finalise the sale, press Yes. 
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POS Screen Setup 

IP-4351 – Repeat Item Function 

This function will enable you to repeat any item in the sale along with any related instruction items that were added 

with the item. 

This function is useful when multiple customers are placing an order together, one of the customers requests an item 

with specific instructions, then the next customer in the same group asks “Can I have the same?”. In this scenario, the 

clerk can select the item that is already listed in the window, then press the “Repeat Item” button. This will add the 

same item to the sale along with the same set of instructions. 

 

To configure and use this function, go to: Back Office > Setup > POS Screen > POS Screen Setup 

Select a POS Screen Layout > Press “Buttons” on the top-left corner of the window. 

Find a suitable POS Screen tab where you’d like to create the “Repeat Item” button, then find a blank button and select 

it. 

Configure the button as follows. 

Function: Repeat Item 

Button Caption: Repeat Item 

 

You can enter a different Button Caption and customise the Appearance if required. 

 

 
 

Once the button has been configured and saved, close the POS Screen Layout windows and return to the Back Office 

screen. 
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Open the POS Screen by pressing the POS button on the top-left corner of the Back Office Dashboard. 

Add a Stock Item to the sale along with any required instruction items. 

 

 
 

Select the main item in the sale as shown in the below image, then press the “Repeat Item” button.  
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The item will be repeated in the sale, along with all the instruction items: 
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POS Terminals 

IP-4426 – Support for Idealpos Ark RFID Reader 

This function adds RFID reader support for the Idealpos Ark terminal. 

To enable the Idealpos Ark RFID Reader, go to:  

Back Office > Setup > POS Terminals > Select Terminal > Modify. 

Within the “Customer Readers” tab, select the RFID Reader Type “Idealpos Ark”. 

Select the type of Connection. 

Enable “Clerk Wrist Bands” and/or “Customers”, depending on what function you want the RFID reader to be used for.  

Clerk Wrist Bands will have unique codes assigned to them.  

 

A Wrist Band can be assigned to a Clerk via the Login Code field which is accessed via Back Office > Setup > Clerks > 

Add/Modify. 

To assign a Wrist Band to a Clerk, ensure that the cursor is currently active in the Login Code field and ensure that 

there is no old data in the field, then scan the Wrist Band against an RFID reader that has been configured. The Wrist 

Band Code/Data will be entered into the Login Code field and the Clerk will be able to login to a POS Terminal, 

providing that the “Clerk Wrist Bands” option has been enabled as shown in the example below.  

 

 
 

Once the setting has been configured, you may need to restart Idealpos for this change to take effect. 
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Reports 

IP-4290 – Stock Levels by Location Report – Save Defaults functionality 

This function adds the ability to Save Defaults on the Stock Levels by Location Report. 

Previous to this change, default options could not be applied to this report and the report would always pre-populate 

each dropdown box using the first fourteen Locations, regardless of whether or not you wanted them. 

The ability to save default options enables the user to apply the options they want to be selected by default each time 

the Stock Levels by Location Report is opened. 

 

To use this function, go to: Back Office > Reports > Stock Control > Stock Levels by Location 
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Select the options that you want to be used each time the report is opened, then press the “Save Defaults” button 

located on the top-left corner of the window. 

 

 
 

A confirmation prompt of “Defaults Saved” will appear. 

Press “OK” to continue. 
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You may confirm that the new defaults are used by closing the Stock Levels By Location window, then opening it again 

by going to: Back Office > Reports > Stock Control > Stock Levels by Location 

 

The new default will now be used each time the report is opened on the current terminal. 

Note that each Terminal/Back Office has its own Report Defaults. 
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IP-4385 – Improved Date Range drop-down boxes 

This function improves the drop-down boxes that are displayed on the Idealpos Report screens. 

Previous to this change, the report drop-down boxes would only occupy a small portion of the entire window, with 

scroll-bars displayed to scroll down through the available options. 

This function has been improved so that the date range drop-down boxes will now occupy the available space, 

enabling the quick selection of the required period without having to use scroll-bars to view all available date ranges. 

 

This change is available on many screens in Idealpos which has the option to select a date range from a drop-down 

box. Some examples of the many available screens which have a date range drop-down box are: 

 

• Back Office > Enquiry > Stock Items, Customers, Suppliers, Journal History, Activity Log 

• Back Office > Reports 

• Back Office > Enquiry > Journal History 

 

To compare the Date Range dropdown box between v7 and v8, see examples below. 

The first image is taken from Idealpos v7.1, the second image is taken from Idealpos v8.  
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Reservations 

IP-4318 – Reservations – User Permission support for modifying Customer Types 

This function adds the ability to control whether or not a User can modify a Customer’s Customer Type during the 

process of booking a reservation. 

This function leverages the existing “Modify Customer Type” User Permission option. 

If you’ve already configured access to the “Modify Customer Type” permission as required, no additional configuration 

steps are required, as the system will use the current configuration to either allow or deny a user to modify Customer 

Types as part of the reservation booking process. 

 

To configure this function, go to: Back Office > Setup > Users. 

Select a User from the list, then press the “Modify” button on the top-left corner. 

Note that the Reservations function can be accessed from both the Back Office and the POS Screen (provided that the 

User has permission to access the Reservations module). 

Therefore, ensure that you configure this permission for Users which login to the Back Office as well as Users which are 

linked to Clerks (so that access to this function is controlled for the required Clerks).  

 

  
 

In the tree view, toggle “Modify Customer Type” which is located under File > Customers > Customers.  

Press “Save” on the top-left corner to save the change. 
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To check which User a Clerk is linked to, go to: Setup > Clerks. 
The User Link column will show the User each Clerk is linked to: 
 

 
 
You can modify which User a Clerk is linked to by selecting the Clerk from the list, pressing the “Modify” button on 
the top-left corner of the window: 
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Then select the User from the User Permissions Link dropdown box that you want to link the Clerk to: 
 

 
 
If required, you can then return to the User Permissions window (Setup > Users > Select User > Modify) to configure 
access to the “Modify Customer Type” option for any other remaining Users which are linked to Clerks.  
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Once the User permission configuration has been completed, go to either: 
Back Office > Reservations > Reservations 
OR 
POS Screen > Table Map > Reservations 
 

 
 
Select a block of time for any table, then press the “Reserve” button on the bottom-right corner of the window. 
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Enter an existing Customer’s Surname, select the Customer from the list on the right-hand side, then press “Use This 

Customer”. 
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The User Permission “Modify Customer Type” that was configured in the above steps will control whether or not the 

Customer Type is read-only or not. 

 

The below example shows the Customer Type dropdown box as read-only (greyed out). 

 

 
 

The below example shows the Customer Type as editable: 
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Room Interface 

IP-3660 – Motelmate – Room Interface Support 

This function adds support for the Motelmate Room Interface to Idealpos. 

In order to use this function, you will need to have this module enabled in your Licence Gateway. 

This interface works similar to the StarFleet Room Interface. 

 

To enable this function, go to:  

Setup > Global Options > Interfaces > Rooms.  

Select “Motelmate” from the Interface Type. 

Enter the POS Number into the Output from POS# field. This is the terminal that produces the output data. 

Enter the network path to the database of the Room Interface into the Network Path field. 

Select the Tender Type for the Room Charge.  

The Tender is configured via Setup > Function Descriptors > Select an unused Tender. 
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Schedules 

IP-4108 – Schedules – Automatic Software Update functionality 

This function enables you to create a one-off schedule which will trigger Idealpos to download the latest available 

build and then install it on all the networked Idealpos terminals. 

This will occur automatically at the time which has been specified in the schedule for all the networked Idealpos 

Terminals/systems. 

Note that Software Update Schedules are a once-off schedule and cannot be configured to repeat at any interval. 

Once the Schedule has been executed, it will be automatically removed from the list of Schedules. 

Also note that in order for the Automatic Update Schedule to successfully update Idealpos, the IPS.exe and 

IPSDeploy.exe must be set to run as Administrator on each POS Terminal/Back Office. 

 

Browse to one of the following locations, then right click on each of these EXEs and select Properties. 

 

64 BIT Versions of Windows - C:\Program Files (x86)\Idealpos Solutions\Idealpos\ 

32 BIT Versions of Windows - C:\Program Files\Idealpos Solutions\Idealpos\ 

 

In the Compatibility tab, ensure that the “Run this program as an Administrator” is enabled. 

Once this change has been applied, you will need to ensure that you Close Suite/Open Suite before using the Software 

Update Schedule functionality outlined further below. 
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When the Software Update Schedule is triggered, it will close down Idealpos and automatically commence the update 

process. Therefore, when creating the schedule, it is important that you choose an appropriate date and time when the 

POS terminals/systems are not being used. If a terminal is in use when the Software Update Schedule executes, 

Idealpos will be closed automatically, regardless of whether or not the terminal is in use. 

 

To configure and use this function, go to: Back Office > Setup > Schedules 

Press the “Add” button on the top-left corner of the window. 
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Type – Select “Software Update” 

 

Run next at - Enter the Date/Time that you want the Update Schedule to run. 

Ensure that you select a Date and Time when all Idealpos systems/terminals will be switched on and not in use. 

Choosing a date and time when systems aren’t in use is crucial, as Idealpos will be closed on all POS Terminals/Back 

Offices during this time for the Scheduled Software Update to take place. Idealpos will be unavailable until the update 

has completed. 

 

From POS – Enter the POS terminal number that will trigger the schedule to run. Note that despite the terminal 

number entered into this field, all networked POS terminals/Back Offices will receive the Software Update 

 

Email Options (To) – Entering an email address will trigger Idealpos to send an email once the Software Update 

Schedule has been executed. If using this email function, you will need to ensure that you have configured your email 

settings in Setup > Global Options > Other Options > Email Settings 
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The Schedule will run at the specified date and time. 

When the Schedule runs, Idealpos will close and IPSDeploy will appear on each terminal. 

Each POS Terminal/Back Office will download the latest available build from Idealpos and will then install the build 

silently. 

Once the installation has been completed, Idealpos will start automatically, ready for use. 
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Stock Items 

IP-3759 – Stock Item Variants 

This function adds the ability to create Variant Stock Items in Idealpos. 

The Variants function is used when a Stock Item comes in a variety of colours, sizes, materials and any other options. 

An example of this may be a clothing store which sells a particular brand of shirt that comes in various colours, sizes, 

materials and gender (e.g. some clothing items such as shirts come in a women’s variety or men’s variety). 

Idealpos supports a maximum of three Variant Types per Stock Item (e.g. Colour, Size, Material), however, it is not 

necessary to use all three Variant Type options in a Stock Item. 

To create Variant Stock Items in Idealpos, the Variant Types (Colour, Size, Material, etc.) and Options (Blue, Red, Green, 

Small, Medium, Large, Wool, Cotton, etc.) need to be created first. 

Once the Variant Types and options have been created, the parent or main item (e.g., the shirt) can be created. 

The “Has Variants” option can be enabled in the parent item which will enable access to the Variants tab within the 

Stock Item, from where the Variant Stock Items can be created.  

In the Variants tab, you will need to select the Variant Types the item is available in (such as Colour, Size, etc.). 

Once the Variant Types have been selected, the options for each Variant Type can be enabled. 

A preview of each Variant Stock Item that will be created will appear on-screen. Finally, you can either press the 

“Create New Variants” button to proceed, or you can uncheck any variant types that are unavailable.  

 

Creation of Variant Items on Site Management terminals that are being managed from a Head Office is not 

supported. The Head Office must create the Variant Items and choose which Sites to send the Variant Items to. 

 

Go to: Back Office > File > Sales > Stock Item Variants. 

This screen is similar to the Attribute Type window, except that it is used for creating and maintaining Stock Item 

Variants and Variant Options. 

The left-hand side column is reserved for displaying the Variant Types (Colour, Size, Material, etc.) and the right-hand 

side column is reserved for displaying the list of options that are available for the currently selected Variant Type. On a 

system which hasn’t been configured for Variants, both the left-hand side and right-hand side columns will be empty. 
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To begin, press the “Add” button on the left-hand side of the window. 

 

 
 

An “Add Variant Type” field will appear at the bottom of the window. 
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Enter a name for the Variant Type (e.g. Colour, Size, Material, or any other Variant Type that you need to create).  

 

 
 

On the top-left corner of the window, press the “Save” button to create it. 
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After the Variant Type has been saved, Idealpos will automatically select it. 

 

 
 

To add options to the selected Variant Type, press the “Add New [Variant Type]” button located on the left-hand side 

of the window. The button in the below example shows “Add New Size” as the Size Variant Type is currently selected. 
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The two following fields will be displayed: 

• Add [Variant Type] – Enter the option for the Variant Type (e.g. If you’re adding size options to a Variant 

Type of ‘Size’, you would enter a size such as Small into this field). 

 

• Abbreviation – Enter the abbreviation for the Variant Option into this field. The abbreviated description will 

be used when creating Variant Stock Items where the long description would result in the description 

exceeding the maximum allowable length. E.g. If you were creating a size of “Small”, you could enter SML as 

the abbreviation, this is entirely up to you. Idealpos will use the abbreviation when creating child Variant Stock 

Items. 

 

 
 

 
 

Once the Variant option and Abbreviation has been entered, press the “Save” button located on the top-left corner of 

the window to create the option. 

 

 
 

Repeat the above steps to create the required Variant Types and Options for each Variant Type that you require. 
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Close the Stock Item Variants screen. 

If you want Idealpos to automatically pre-select specific Variant Types (e.g. Size, Colour, Material) when you’re creating 

new Variant Items, this can be configured in the Global Options. If this is not required, you may skip this step. This is 

beneficial if all your Variant Stock Items always come in a standard set of Variant Types (e.g. all items have a unique 

Colour, Size and Material). If you have a wide range of Variant Types that are used for your variants (e.g. Drink Bottle 

Sizes, Drink Bottle Colours, Sports Bag Sizes, Sports Bag Colours, etc.), it may be necessary to manually select your 

Variant Types each time you’re creating Variant Stock Items from the parent Stock Item. 

 

To set the Default Variant Types, go to: Setup > Global Options > Other Options 

Within the Other Options tab, select the Default Variant Types that will be pre-selected when creating Variant Stock 

Items from the parent Stock Item. 
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You can now proceed to creating the parent Stock Item/Variant Stock Items. 

Close the Global Options window and go to: File > Stock Control > Stock Items 

 

If you have an existing Stock Item that you want to use as the parent item, you can modify it and enable the “Has 

Variants” option, then create Variants. 

Otherwise, press the “Add” button on the top-left corner of the Stock Items window to create a new Item. 

This will be the parent or main Stock Item. 

For this example, we’ll enter “BOYS SHIRT” into the Description fields. 

Whilst in the General tab, enter any other options that are required (Selling/Cost Prices, Tax Settings, Printer Settings, 

Tax Settings, Purchasing details, Other Options). Note that if your system is integrated with Shopify via Idealpos Online 

eCommerce, any Variant Stock Items that are created in Idealpos can be exported to Shopify by enabling the “Web 

Store” checkbox. 

If your Variant Stock Items all share the same barcode, enter the Barcode into the Scan Code field in the parent item 

and leave the Scan Code field as blank on the child items. If each Variant Stock Item has a unique barcode, leave the 

Scan Code field as blank for the parent Stock Item and enter each item’s barcode into the Variant Stock Item in 

Idealpos that corresponds to the physical item. 

When creating the parent Stock Item, ensure that the “Has Variants” option is also enabled. This will enable access to 

the Variants tab, from where you will create your Variant Stock Items. 
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If each of your Variant Items will have the same Recommended Level, Reorder Level and Carton Quantity, it is a good 

idea to enter these details into the Parent Item. This way, Idealpos will replicate these values to each of the child items, 

saving you from having to enter these details repeatedly for each child item.  

Go to the Advanced tab of the item, then next to the Stock Level field, press the “>>>” button. 
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Enter the Recommended Level, Reorder Level and Carton Quantity and save the change. 

These values will be replicated down to each of the child variant items. 

 

 
 

Press the “Save” button on the top-left corner to save the changes. 
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Go to the Variants tab to create the Variant Stock Items (i.e. the child items). 

If you configured the Default Variant Types in Global Options, the Variant Type dropdown boxes will be pre-filled as 

shown in the below example: 
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If the Default Variant Types were not configured, each Variant Type dropdown box will be empty and you’ll need to 

manually select the Variant Types from the dropdown boxes that you want to use in this instance to create the Variant 

Items. 
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To create the Variant Stock Items, ensure that the required Variant Types have been selected from the drop-down 

boxes on the left-hand side, then enable the checkboxes for each option that you want to create. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 1 - Update History Page 161 of 198 

 

If you want to enable all options for a Variant Type, you can enable the checkbox that appears next to the Variant Type 

dropdown box. This will enable all Variant Option checkboxes as shown in the below example: 
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If the Variant Stock Item comes in numerous Variant Types (i.e. various Colours, Sizes, Materials, etc.), then ensure that 

you select a Variant Type in each of the available dropdown boxes. Note that you have a maximum of three Variant 

Types that can be selected. When Variant Options have been enabled for multiple Variant Types, Idealpos will build a 

list of all the possible variations that are available for the enabled selection. A preview of the Stock Items which will be 

created will be displayed towards the right-hand side of the window as shown below: 
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If required, you can uncheck any Variant Options that are not required, or you can leave all options enabled to create a 

child variant item for each possible variant combination. 
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Should you have any existing child items that you want to link to a particular Variant Type, this can be done by 

pressing the “+” button next to the Variant Type in the Stock Code column , then the Stock Items screen will be 

displayed from where you can search for the Stock Item. 

Any Stock Items that you link will have their Stock Code displayed in the Stock Code field. 

 

 
 

Idealpos will display a confirmation prompt, press “Yes” to continue. 
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Select the item that you want to link to, then press the “OK” button on the top-left corner of the Stock Items window. 

 

 
 

The Stock Code field will then show the Stock Item Code of the item that was linked: 

 

 
 

You can also view the Stock Item’s Description by hovering the mouse cursor over the Stock Code field and the 

Description will be displayed. 
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Once you’re ready to create the Variant Stock Items, press the “Create New Variants” button located on the bottom-

right corner of the window. 

 

 
 

Idealpos will display a prompt listing the total number of Variants that will be created and will require confirmation to 

proceed.  
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After pressing “Yes” on this prompt, the creation of the Variant Stock Items will begin. 

Depending on the number of Variant Stock Items that need to be created, this process may take some time. 

A progress bar will be displayed at the bottom of the window to show the current progress. 

 

 
 

Once the Variant Stock Items have been created, a prompt will appear to confirm that the creation was successful. 

 

 
 

When the child Variant Stock Items are created, they’re linked back to the parent Stock Item that they were created 

from. 

 

You may repeat the above process to create the remaining parent Stock Item/child Variant Items that are required. 
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If your Variant Stock Items have Stock Control enabled, you may want to enter the current Stock Level that you have 

for each child Variant Item. This can either be done using a number of methods. You can manually select the Item from 

the Stock Items screen, press “Locations”, Modify the Location and fill in the Stock Level. 

 

 
 

You could also create a purchase order by going to Transactions > Stock Control > Stock Purchases, then create a new 

Stock Purchase and add the Variant Items to the order, along with the Costs and quantities that you’re ordering. After 

this Purchase Order is received into Idealpos, the Stock Levels of all the Variant Stock Items will be updated. 
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Buttons for Variant Stock Items can be added to the POS Screen, however, this is not necessary if all your Variant Stock 

Items contain barcodes that will be scanned by the Clerk. 

Go to: Setup > POS Screen > POS Screen Setup 

Select the POS Screen Layout, then press “Buttons” on the left-hand side of the window. 

 

 
 

When creating a button for your Variant Stock Items on the POS Screen, you have the option to create a button that 

links to the parent Stock Item, or to create multiple buttons and link each of them to the individual child items. 

The advantage of linking a button to the parent Stock Item is that when the Clerk presses the button for the parent 

Stock Item, Idealpos will display a list of all the Variant Stock Items that are available, along with their Stock Level. 

If you link the Stock Item button to the child variant item, you will need to create a separate button for each of the 

variant Stock Items that are available, occupying more space on the POS Screen and increasing the amount of time 

spent configuring the POS Screen. 
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When selling Variant Stock Items, you have the following options: 

 

• Scan the item using the scanner at the POS terminal (each variant item has a unique barcode). 

The item will be added to the sale without any additional intervention from the Clerk. 
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• Scan the item using the scanner at the POS terminal (each variant item has the same barcode). 

Idealpos will display a list of Variant Stock Items when the item is scanned and the Clerk will need to manually 

select the corresponding item from the list. 
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• Add the item to the sale via a button (button linked to the parent Stock Item) on the POS Screen. 

Idealpos will display a list of all the available items. 

The Clerk will need to select the item from the list, then press the “Sell Item” button. 
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• Add the item to the sale via a button (button linked to the child Stock Item).  

Idealpos will simply add the item to the sale without any additional prompts. 
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In addition to selling Variant Items, Idealpos also has added functionality for Variants in the Stock Item Sales Report. If 

you want to see each individual child Variant Item on the Stock Item Sales Report, leave the Consolidate Variants 

checkbox unticked. 
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If you want Variant Stock Items to be consolidated into the parent item, enable the “Consolidate Variants” checkbox.  

 

 
 

 
 

 

  



 Update History 
Return to top 

Idealpos 8 Build 1 - Update History Page 176 of 198 

 

 

IP-4077 – Automatic Stock Item Scan Codes built from Predefined Text File 

This function enables Stock Codes to be retrieved from a pre-defined text file and entered into the Stock Code field 

when the user presses the Auto button on the Create New/Modify Stock Item screen. Once all the Stock Codes from 

the pre-defined text file have been exhausted, the next time the Auto button is pressed, a prompt will be displayed 

“No valid Scan Codes remain!”. 

Either a new file can then be created with a new set of scan codes, or new scan codes can be appended to the bottom 

of the existing file. 

This function is particularly useful if you have a batch of pre-printed scan code labels which you’d like Idealpos to 

automatically populate into the Scan Code field via the Auto button. 

 

To use this function, create a text file named “AutoScanCodesStockItems.txt” and place it into the following folder: 

 

C:\ProgramData\Idealpos Solutions\Idealpos 

 

Each Idealpos terminal that has the Back Office module enabled can have the same file copied to the above location, 

enabling each terminal to assign scan codes from the same scan code file. 

If you prefer to have a unique set of scan codes for each terminal, this can also be achieved by creating a 

AutoScanCodesStockItems.txt file for each POS terminal and placing the file into the above folder location on each 

terminal. Ensuring that each file contains a unique set of Scan Codes. 

The format of the file should contain a list of Scan Codes, with each Scan Code listed on a separate line without 

commas. The below is an example list of Scan Codes in the correct format: 

 

9100000000008 

9100000000015 

9100000000022 

9100000000039 

9100000000046 

9100000000053 
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Once the file has been created in the above location, go to: Back Office > File > Stock Control  

Either create a new Stock Item by pressing the “Add” button on the top-left corner of the window, or select an existing 

Stock Item from the list and press Modify. 
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Pressing the “Auto” button within the Scan Code field will populate the Scan Code field using the first unused Scan 

Code from the “AutoScanCodesStockItems.txt” file. 

Note that when the AutoScanCodesStockItems.txt file exists, pressing the Auto button repeatedly will not keep 

retrieving the next available Scan Code.  

When the file does not exist, the Auto button can be pressed repeatedly and a new code is generated each time. 
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IP-4369 – Stock Item Search text boxes – Support for On-Screen Keyboard 

This function adds the ability to display the On-Screen Keyboard on the Stock Item Search Grid. 

This enables the user to enter values into the search fields to search for specific Stock Items on systems such as POS 

Terminals which do not have a keyboard attached. 

 

This function does not require any configuration to be performed. 

Simply double-click or double-tap inside any of the search fields shown at the top of the Stock Items grid to display 

the on-screen keyboard. 

 

To use this function, go to: File > Stock Control > Stock Items. 

Double-click into any of the fields shown at the top of the Stock Item grid. 
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The on-screen keyboard will be displayed. 

 

 
 

Enter the search criteria you want to search for, then press the Enter button. 

For this example, we’ve double-clicked into the Description field, so we’ll enter a Stock Item description. 
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After pressing Enter, the value that you entered with the on-screen keyboard will appear in the field which was double-

clicked above and the Stock Items grid will filter the results based on the entered search criteria. 

  

 
 

If you want to perform additional searching/filtering within any other search fields, double-click into any other field 

and enter the required search criteria using the on-screen keyboard. 

 

If you want to clear the value that has been entered into a search field, double-click on any field that contains an 

entered search value and backspace the value.  
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Press the Enter button on the on-screen keyboard. 

 

 
 

The value will then be cleared from the field in the Stock Item grid, expanding the results displayed in the Stock Items 

grid. 
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IP-4371 – Stock Items Screen – Calculate Price by Profit Amount 

This function adds the ability to calculate and view how much profit is being made on an item based on the Cost Price, 

Sell Price and Tax Settings all within the Modify Stock Item window. 

Previous to this change, only a Profit % column was available which could be used to see how much profit as a 

percentage was being made based on the Sell Price, Cost Price and Tax Settings. 

With the addition of the Profit $ column, you can now see how much profit is being made on an item based on the 

currently entered Sell Price, Cost Price and Tax Settings. 

If you want to make a specific dollar amount of profit on an item, you can enter the profit value you want to make into 

the Profit $ field and Idealpos will automatically calculate a Sell Price which achieves the desired profit amount. 

 

To use this function, go to: File > Stock Control > Stock Items. 

Open any Stock Item from the Stock Items grid by double-clicking on an item. Alternatively, select a Stock Item, then 

press the “Modify” button located towards the top-left corner of the Stock Items grid. 

 

The Profit $ column will be displayed next to the Profit % column and will have a value for each Price Level that’s 

currently populated. 

The column will contain the current Profit $ amount being made. The Profit $ amount is calculated using the current 

Sell Price, Cost Price and Tax Settings which have been set for the item. 
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Modifying the currently enabled checkbox in the Tax Settings section will result in different Profit $ amounts being 

displayed.  

 

  
 

If an amount is entered directly into the Sell Price, the Profit % and Profit $ will be calculated automatically.  

Note that in order for the amounts shown in the Profit % and Profit $ fields to be calculated based on the amount 

entered into the Sell Price, you must click into another field after entering the Sell Price. 
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Entering a value directly into the Profit % field will automatically calculate the Sell Price and the Profit $. 
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If you want to make a specific Profit $, enter the required amount into the Profit $ field and a Sell Price will be 

calculated and filled into the Sell Price field automatically. 
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If required, the tax amounts used in the Tax Settings can be configured by going to:  

Setup > Global Options > Sales > Tax Rates. 
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Yes/No Options 

IP-1233 – Yes/No Option – Inhibit Refunds in Void Mode 

This function adds the ability to control whether or not refunds are inhibited in Void Mode. 

By default, this Yes/No Option is enabled, inhibiting refunds from being performed while Void Mode is active on the 

POS Terminal. 

Previous to the implementation of this Yes/No Option, it was possible to perform refunds while the Void Mode was 

active. 

 

To control whether or not the Inhibit Refunds in Void Mode option is enabled, go to: 

Setup > Yes/No Options 

Enter Search: Inhibit Refund 

Toggle the option on or off.  

 

 
 

When the “Inhibit Refunds in Void Mode” option is enabled (checkbox ticked), Idealpos will display a prompt 

preventing the use of the Refund function while Void Mode is active. If the Clerk attempts to press the Refund button 

while Void Mode is active, Idealpos will display a prompt and will prevent the Refund function from being enabled. 
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When the “Inhibit Refunds in Void Mode” option is disabled (checkbox unticked), Idealpos will allow the Refund button 

to be pressed when the Void Mode is active. 
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IP-3920 – Yes/No Option – Table Details Group by Order Time 

This function adds the ability to control whether or not Idealpos will group table details by the Order Time. 

A new feature (IP-1315 – Table Details screen – Items grouped by Order Time) was introduced in Idealpos 7.1 Build 12, 

however, this function was hard-coded as always enabled. 

 

With this change, the grouping of table details by Order Time can now be toggled via a Yes/No Option. 

To configure this function, go to: Back Office > Setup > Yes/No Options. 

Enter Search: “group by”. 

Enable or disable the option “Table Details – Group by Order Time. 

When enabled, items will be grouped by the time that they were saved to the table. 

When disabled, items will be displayed in the order that they were saved to the table. 

 

 
 

Close the Yes/No Options window to save your change. 

A Close Suite/Open Suite should not be required. 

 

Place multiple orders to a table by adding items to the sale, press the “Table Map” button, select a table and if 

prompted, enter the number of Covers/Guests. 

Repeat the process again, ensuring that you select the same table number. 
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If the Yes/No Option is enabled, items will be grouped as per the below example: 

 

 
 

If the Yes/No Option is disabled, items will be displayed in the order they were saved to the table. 
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IP-4146 – Yes/No Option – Show Tender Surcharge Prompts 

This function enables the ability to configure whether or not prompts will be displayed on the POS Screen when a 

surcharge is applied to the tender function that has been selected. 

An example of this may include having a surcharge configured on the AMEX/DINERS function and display an on-

screen prompt when the AMEX/DINERS function is pressed on the Tender screen. 

 

To configure this function, go to:  

Back Office > Setup > Yes/No Options 

Enter “surcharge” into the Search field, then toggle the Yes/No Option “Show Tender Surcharge Prompts” depending 

on whether or not you want Idealpos to display a prompt when a surcharge is applicable to the Tender function 

selected. When the option is checked, a prompt will appear on the POS Screen when the Clerk selects a Tender 

function which has a surcharge enabled. When the option is unchecked, all Tender Surcharge prompts will be hidden 

when selecting a Tender function that has a surcharge enabled. 
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Surcharges for Tenders are configured by going to: Back Office > Setup > Function Descriptors. 

Select a Tender between 2 and 18, then press the “Modify” button on the top-left corner of the screen. 

Enter the Surcharge amount into the Surcharge field, and select the Surcharge Type.  

When “%” is selected and a value is entered into the Surcharge field, Idealpos will apply a percent surcharge to the 

tender. E.g. A $10.00 sale with a 10% surcharge will result in a surcharge of $1.00 being added to the total amount, 

bringing the amount to $11.00. 

When “$” is selected and a value is entered into the Surcharge field, Idealpos will add the entered $ value amount to 

the tender. E.g. A $10.00 sale with a $2.00 surcharge will result in a surcharge of $2.00 being added to the total 

amount, bringing the amount to $12.00. 

 

Press the “Save” button on the top-left corner of the Function Descriptors window to save your change. 
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When tendering off a sale with the Y/N Option “Show Tender Surcharge Prompts” enabled, the prompt will appear 

similar to the below: 

 

 
 

When tendering off a sale with the Y/N Option “Show Tender Surcharge Prompts” disabled, the surcharge prompt will 

not appear and the sale will simply be finalised, displaying an empty sale screen afterwards. 

 

 
 

 

  



 Update History 
Return to top 

Idealpos 8 Build 1 - Update History Page 195 of 198 

 

IP-4188 – Yes/No Option – Stock Item Long Descriptions on POS Screen 

This function enables the ability to view Stock Item Long Descriptions on the POS Screen. 

In order to take full advantage of this function and display the entire Stock Item Long Description on the POS Screen, 

the Retail POS Layout should be enabled on your POS Screen. Note that the Retail POS Layout is only available on 

1920 x 1080 resolution screens. 

 

To configure this function, go to: 

Setup > Yes/No Options > Enter Search: “stock item long” 

Enable the option “Stock Item Long Descriptions on POS Screen” . 

 

If your venue has a mixture of different sized POS Screens (e.g. traditional 1024 x 768 and the new 1920 x 1080 

resolution) and you only want to enable this option for POS terminals that have the larger 1920 x 1080 resolution 

screens, ensure that you only enable the tickbox for the POS Terminals that support the larger resolution screens. 
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Once this option is enabled, ensure that your system is configured to utilise the Retail POS Layout (only available on 

1920 x 1080 resolution POS Screens). 

 

To enable the Retail POS Layout, go to:  

Setup > POS Terminals > Select the POS Terminal from the list > Modify (or double-click on the POS Terminal to 

modify it). 

 

From the POS Settings tab, select the resolution labelled as “1920 x 1080 (16:9) Retail”. 
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The final step to configuring this function is to ensure that you have Stock Items which contain a Long Description. 

All your Stock Items should, by default, already contain a description in the Long Description field, however, it will 

likely be a short description that resembles the same description shown in the Description 1 and/or Description 2 

fields. The Long Description field (Description 3 field) supports a maximum limit of 100 characters that can be utilised 

to fully describe the Stock Item.  

This requirement for displaying a long Stock Item Description may be necessary when selling items that cannot be 

clearly described using the previous limit of 30 characters available in the first description field. Examples of such items 

may include jewellery that requires a detailed description (due to similar items that have a slight variation of different 

coloured diamonds, jewels, etc.). 

 

Go to: Back Office > File > Stock Control > Stock Items 

Search and select the Stock Item from the list by either double-clicking on it, or select the item and then press the 

“Modify” button on the top-left corner of the Stock Items window. 

Enter a long description into the Long Description/Description 3 field. 

Press the “Save” button on the top-left corner of the window to save your change. 

You may repeat this process to update the long descriptions for the required items. 

 

 
 

 

  



 Update History 
Return to top 

Idealpos 8 Build 1 - Update History Page 198 of 198 

 

When adding a Stock Item to a sale which contains a long description, the long description will be displayed within the 

sale window as per the below example: 

 

 


