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Automatic Export Settings – POS Terminal 

IP-6299 – Avery Berkel Export 

This function introduces a new “Avery Berkel Export” Export Stock Item Format that can be used to Export Stock Items 

for use with Avery Berkel scales. 

This format also includes the ability to export the “Best Before Days” Attribute Type/Attribute. 

E.g. Create an Attribute Type of “Best Before Days” with separate Attributes for the number of days – e.g. 1, 2, 7, 14 

(the number of Best Before Days that the Stock Item can be consumed after the Scale Label is printed).  

When a Stock Item has the “Best Before Days” Attribute Type assigned along with the number of days, this Attribute 

Type/Attribute information will be included in the Exported Data that can then be utilised by the Avery Berkel Scale 

when printing a label from the Avery Berkel Scale at the time the customer acquires the item. 

 

When configuring this function, it is recommended that the Attribute Type and Attribute is configured first, then 

configure the Stock Items with the Attribute Type/Attribute as required. 

Once this has been done, then finally configure and enable the Avery Berkel Export Format. 

This will ensure that the first set of Stock Item data which is exported will include the Best Before Days. 

 

If Best Before Days is not required, then the creation of the Attribute Type/Attribute and assignment of this Attribute 

Type to Stock Items can be skipped. 

 

To configure this function, go to: Back Office > File > Sales > Stock Item Attributes. 

Create a new Attribute Type by pressing the “Add New Attribute Type” button. 

 

 
 

Enter “Best Before Days” into the Add Attribute Type field, and if required, the Available in Columns checkboxes can be 

toggled to only enable the usage of this Attribute Type in specific Attribute Type slots in the Stock Items. 

 

 
 

Press ENTER or press “Save” on the top-left corner to save the new Attribute Type. 
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Press the “Add New Best Before Days” button on the top-left corner. 

 

 
 

Enter the Best Before Days (ensure that each Best Before Days Attribute is a separate Attribute).  

DO NOT create a comma separated Attribute with multiple days e.g. “1, 7, 14, 20”. 

 

E.g. Create separate Best Before Days Attributes > Press “Save” on the top-left corner after creating each Best Before 

Days Attribute, or press Enter to save the currently entered Attribute. 

 

 
 

Once completed, the Best Before Days Attribute Type should appear on the left-hand side column, and when that 

Attribute Type is selected, a list of Best Before Days should appear within the right-hand side column. 
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Close the Stock Item Attributes window, then go to: Back Office > File > Stock Control > Stock Items. 

Modify the required Stock Items and assign the “Best Before Days” Attribute Type, then select the number of days that 

the Stock Item is Best Before from the day it is sold. 

 

 
 

Repeat the process for all Stock Items that require this Attribute Type. 

Close the Stock Items window once this has been completed for all the required Stock Items. 

Open Windows File Explorer and create a folder for the Stock Item Export. 

An existing folder may also be used – if a folder already exists where the Exported Stock Item data will be exported to, 

continue to the next step. 

This folder may be a location that is configured with third-party software from Avery Berkel Scales which may be used 

to export to the scales – this is outside the scope of this document; refer to Avery Berkel whether this is a manual or 

automated process. 
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Once a folder for the exported Stock Items has been created or located, go to:  

Back Office > Setup > POS Terminals > Modify > Import/Export > Automatic Export Settings > Configure as follows. 

 

Export Folder – This is the folder location that was created or identified in the previous step. 

Export Stock Items – Select “Avery Berkel Export” 

Department Range – If a Department Range is required, enter it here. Department Range can be entered as a comma 

separated list (e.g. 1,2,3) or as a range (e.g. 101-105), or as a combination of both (e.g. 101-105,110). 

Filter by Attribute Type – This can be used to filter the Exported Stock Items to only include items that are assigned 

to a specific Attribute Type (e.g. Best Before Days). 

Export Daily at or every minutes – Configure this setting as required. If Exporting Daily at, enter the time in 24 hour 

format; the data will only be exported once a day at the specified time. Or if exporting every X minutes, leave the 

Export Daily field at as blank and enter the minute interval required. The data will be exported at the entered minute 

interval. 

Filename – Enter the required filename. Entering a filename without a file extension (e.g. StkItem) will create a file 

using the entered filename without a file extension. If a file extension is required, enter the file extension after the 

filename (e.g. StkItem.txt). 

Append Date/Time to filename – This will append the date and time to the filename (the date and time when the 

data is exported) using the format of YYYYMMDDHHMMSS, where YYYY is the year, MM is the Month, DD is the Day, 

HH is the hour in 24 hour format, MM is the minute, and SS is the seconds. The Date/Time is appended to the end of 

the filename. E.g. StkItem_20240516101213.txt. 

Append Site Name to filename – This will append the Site Name to the filename (the Site Name is inherited from 

Setup > Sites and is whichever Site the POS Terminal is located in). 

Append Venue ID to filename – This will append the Venue ID to the filename. 

Include Discontinued Items – This will include Stock Items in Idealpos that have been marked as being Discontinued. 

Scale Items Only – This will only include Stock Items that have the scale checkbox enabled. 

 

The minimum required fields for this function have been annotated in the screenshot below: 
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Once configured, close the POS Terminal Settings. 

The Stock Items will be exported using the interval configured. 

 

When the data is exported, the data is exported in the following order/format as follows: 

 

ADD/DELETE,CODE,DESC,PRICE,SCALE,BESTBEFOREDAYS 

 

The below is an example of a Stock Item from the Stock Item Export: 

 

A,315,TASTY CHEESE,0.00,n,7  
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Departments 

IP-6291 – Departments – Support for Special Points for Stock Items 

This function introduces the ability to set a Special Points value for a Department. 

When this option is enabled and a Special Points value is entered, each Stock Item that is purchased from the 

Department will earn the customer the Special Points value that has been set against the Department. 

If a Stock Item within the Department has its own Special Points value configured, then the Stock Item Special Points 

value will override the Department’s Special Points value. 

Also note that the Point Multiplication Factor that has been set against the Customer Type will affect the Special Points  

as well as the “Use Points System” option set within the Customer Type . 

E.g. 1 – If the Point Multiplication Factor is set to 1 in the Customer Type and the Special Points has been set to 100 in 

the Department, the Customer will earn 100 points for each Stock Item purchased from the Department. 

 

E.g. 2 – If the Point Multiplication Factor is set to 2 in the Customer Type and the Special Points has been set to 100 in 

the Department, the Customer will earn 200 points for each Stock Item purchased from the Department. 

 

E.g. 3 – If the Use Points System is disabled in the Customer Type and the Special Points has been set to 100 in the 

Department, the Customer will not earn any points due to the Use Points System option being disabled. 

 

To configure this function, go to: Back Office > File > Sales > Departments > Select a Department > Modify. 

Enable the “Special Points” checkbox and enter a value. 

The Customer will accrue the entered value when they purchase a Stock Item from the Department. 

As noted above, the Point Multiplication Factor set within the Customer Type will also determine the final number of 

Special Points (refer to File > Customers > Customer Types > Select a Customer Type > Modify > Point Multiplication 

Factor). 
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Save any changes to the Department. 

When a Customer purchases a Stock Item from the Department, they will accrue the number of Special Points 

configured in the Department. 

 

E.g. A new Customer with no points makes a purchase of a Soft Drink Stock Item. 

Before the sale is finalised, the Points Balance is 0. 

 

 
 

 
 

After the sale is finalised, the next time the same customer is added to a sale, they have a Points Balance of 100. 
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Gaming 

IP-6233 – Aristocrat S7000 Interface 

This function introduces the ability to configure the Aristocrat S7000 Interface in Idealpos. 

Before configuring this interface, ensure that the Aristocrat module is enabled in the Licence Gateway. 

 

Go to: Back Office > Setup > Licence Gateway > Check that Aristocrat is enabled. 

If not, contact Idealpos or your Idealpos reseller to purchase the module. 

 

To configure this interface, go to: Back Office > Setup > Global Options > Gaming. 

Select “Aristocrat S7000” from the Interface Type dropdown box. 

Configure the following options: 

Redeem Tender – Select the Tender that has been created for Points. 

Username – Enter the Username supplied by Aristocrat. 

Password – Enter the Password supplied by Aristocrat. 

Registration Code – Enter the Registration Code supplied by Aristocrat. 

IP Address/Host – Enter the IP Address/Host supplied by Aristrocrat. 

Port – Enter the Port number supplied by Aristocrat. 

Add Members to POS – Select this field to add the members to the Idealpos Database if they are not already. If you 

are using ratings grade from Aristocrat, you will need to create a Customer Type for each grade you will use. 

Code Length – This is the length of the Code that will be entered into the Idealpos database. 

Customer Type – This is the Customer Type the new members will be added to in Idealpos. 

Update Customer Type from Member Analysis – This will determine if the Customer Type will be changed. 

Analysis Number – Enter the Analysis Number. 

Use Price Level Schedule – Check this if you want to use the Price Level Schedule function. 

Redemptions treated as Discounts – Toggle this setting on or off. 

Trigger Card Swipe manually using [ ; ] Prefix – This setting will trigger any input received via the Keyboard Wedge 

which contains this prefix as a Card Swipe. 
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Within Global Options > Gaming, configure the Gaming Points as required. 

Place a tick into the Enable option next to each account type that is configured. 

When the “Combine Accounts into one Redeemable Total” checkbox is enabled, the Gaming Points accounts will be 

combined into one redeemable total. 

When multiple points balances are configured for redemption within Idealpos and the Combine Accounts into one 

Redeemable Total is ticked, Idealpos will display the points as one total at the top of the POS Screen when added to 

the sale. 

Then when a redemption occurs, a prompt to select the points account is not displayed. 

The system will draw from the POS Points first, with the remainder points being pulled from the Gaming Points if there 

are insufficient POS Points available. 

 

The Customer Type Discounts checkboxes enable the ability to toggle Customer Type Discounts for each Gaming 

Points Bucket. 

 

 
 

Further information about configuring Aristocrat is available in the User Guide (https://userguide.idealpos.com.au) 

within the Gaming > Aristocrat topic.  

https://userguide.idealpos.com.au/
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GiveX Interface 

IP-6232 – GiveX Interface 

This function introduces the ability to connect Idealpos to the GiveX system to sell GiveX Gift Cards as well as redeem 

GiveX Gift Cards. GiveX Loyalty can also be used and supported with this interface. 

 

For information on how to configure this interface, refer to the GiveX Interface > Setting up the GiveX Interface topic 

in the Idealpos User Guide (https://userguide.idealpos.com.au).   

https://userguide.idealpos.com.au/
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Journal History Enquiry 

IP-6173 – Journal Enquiry – Ability to see specific Scan Codes used in Transactions 

This function introduces the ability to see specific Scan Codes that are used in Transactions when viewing them in the 

Journal History Enquiry. 

There is no additional configuration required to enable this functionality. 

To use this function, go to: Back Office > Enquiry > Journal History > Select a Journal from the list. 

The Stock Item Scan Code (Bar Code) will be displayed to the left of the Stock Item. 

Note that if a Stock Item is added to a sale by pressing the Stock Item’s button on the POS Screen or if the Stock Item 

Code is manually entered into the sale, then the Stock Item Code will be displayed in the Journal History Enquiry. 

Also note that if multiples of the same Stock Item are added to the sale using a mix of POS Screen Button, Scan Code 

or Stock Item Code for the same item (and accumulate item is enabled), the Journal History Enquiry will display the 

code that corresponds to whichever method was used to add the first instance of the item to the sale (if the first 

instance of the item was added to the sale using the Scan Code, then the Scan Code will appear in the Journal History 

Enquiry for that sale, if the first instance of the item was added to the sale using a POS Screen button or the Stock Item 

Code, then the Stock Item Code will be displayed in the Journal History Enquiry for that sale). 

If accumulate item is turned off, then each instance of the item in the Journal History Enquiry for the sale will show 

whichever code was used to add the item to the sale. 

 

The below example shows the Journal History Enquiry with a sale that had the same Stock Items added multiple items 

using different methods (Non-Accumulating was enabled so that each instance of the item appears on a separate line). 

The instances where the item was added via a POS Screen Button/Scan Code entered manually show the Stock Item 

Code, and any instances where the Stock Item was added by scanning or entering the Scan Code show the Scan Code 

next to the Stock Item. 

 

 
 



    Update History 
Return to top 

Idealpos 9 Build 1 - Update History Page 13 of 38 

 

Mag Card Printing 

IP-6361 – Zebra ZC300 Mag Card Printer – User-Defined Options to change field locations 

This function introduces the ability to change the field locations printed by the Mag Card Printer. 

This functionality can be used if the default field positions prohibit the correct printing of data (e.g. long customer 

names printing off the edge of the printout). 

The X at the end of the User-Defined Option refers to the X coordinate and Y refers to the Y coordinate. 

Also note that a User-Defined option does not need to be created for each field. 

I.e. If a User-Defined option is not created for a field, then the default coordinates for that field will be used. 

 

To create User-Defined Options to adjust the field locations of the Mag Card Printer, go to: 

Back Office > Setup > POS Terminals > Select POS Terminal > Modify > POS Settings > User-Defined Options. 

 

The following is a list of the User Defined Options and their default values. 

Trial and error may need to be used to determine the best settings to print the fields in their desired positions. 

 

Description: ZEBRACODEX 

Setting: 355 

  

Description: ZEBRACODEY 

Setting: 440 

  

Description: ZEBRANAMEX 

Setting: 355 

  

Description: ZEBRANAMEY 

Setting: 480 

  

Description: ZEBRACUSTTYPEX 

Setting: 166 

  

Description: ZEBRACUSTTYPEY 

Setting: 560 

  

Description: ZEBRADATEX 

Setting: 740 

  

Description: ZEBRADATEY 

Setting: 560 

  

Example (the User-Defined settings shown in the example contain the default X/Y Coordinates – the Settings will 
need to be adjusted using trial and error to determine the best position for each field): 
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Metcash Integration 

IP-6021 – Metcash Integration (Host V7, Scan Data 2.5, Loyalty) 

This function introduces the ability to configure Idealpos to utilise the Metcash Integration. 

The Metcash Integration enables the retrieval and processing of Metcash V7 Host (the Metcash Host contains Product 

data, Product Prices, Product Costs, etc.), Scan Data (sending Scan Data to Metcash) and Loyalty. 

 

As the process to configure and use this function is quite extensive, these details are being omitted from the Update 

History. Please refer to the Metcash Integration topic in the User Guide (https://userguide.idealpos.com.au) for further 

details on how to configure and use this function.  

https://userguide.idealpos.com.au/
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Pocket Pad 

IP-6196 – Pocket Pad - Support for Course Separator Item (Group Instructions by Seat) 

This function introduces the ability to use the Course Separator Item (Group Instructions by Seat) when using Pocket 

Pad to save items to a table. This is done by enabling the existing “Use Course Separator instead of Print Groups” 

checkbox in the Global Options > Printing > Print Formats. 

If the checkbox is already checked, then this option will also apply to orders saved from Pocket Pad. 

Pocket Pad will use a Stock Item with description “====================” (20 equal signs) to mimic the POS 

“Course Separator” function. 

 

To configure this function, go to: Back Office > Setup > Global Options > Printing > Print Formats. 

Enable the checkbox “Use Course Separator instead of Print Groups”. 
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After the option has been enabled, Idealpos will need to be restarted for the change to affect orders that are sent from 

Pocket Pad/Ideal Handheld. 

Perform a Close Suite/Open Suite or restart the Back Office PC/Terminal. 

 

When Pocket Pad sends an order to a table that contains Stock Items from different Print Groups, Pocket Pad will use a 

Stock Item with description “====================” (20 equal signs) to mimic the POS “Course Separator” 

function. 

 

To demonstrate this function, two orders were placed with a variety of Stock Items from two different Print Groups. 

One order was placed while the “Use Course Separator instead of Print Groups” option was enabled. 

The second order was placed while the “Use Course Separator instead of Print Groups” option was disabled. 

The Kitchen Docket Format “Group Instructions by Seat” was used to demonstrate this function. 

 

The two screenshot examples shown below demonstrate how this option affects the Kitchen Docket. 

 

Use Course Separator instead of Print Groups enabled: 

 

 
 

Use Course Separator instead of Print Groups disabled: 
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POS Screen 

IP-6245 – New Home Screen Design 

This function introduces a new Home Screen Design to complement the rebranding of Idealpos v9. 

The new design incorporates a new colour scheme and design. 

Note that the following Yes/No Options have been removed. 

• Show 2 rows of Fast Clerks, 

• Show Employee Log on Home Screen 

• Show Exit button on Home Screen 

• Show Last Transaction 

• Show Receipt Button on Home Screen 

 

The changes that have been made to the Home Screen are listed as follows: 

 

• When enabled, the Fast Clerk Buttons will appear on the right-hand side of the Home Screen. A toggle 

between Fast Clerk buttons and the numeric keypad is available via an arrow button that appears on the 

bottom-right corner of the Home Screen. 

 

• Current POS Terminal details (Licensed To, POS Terminal Number, Site Name/Number, POSServer IP, Local IP) 

are shown on the bottom-right corner of the Home Screen after pressing the Home Screen Menu button (≡). 

 

• Print Last Receipt and Employee Log are shown after pressing the Home Screen Menu button (≡). 

 

• When enabled, the Blackboard is shown on the left-hand side after pressing the Home Screen Menu button 

(≡). 

 

• Last Transaction is shown on the bottom-right corner of the Home Screen 

 

• Home Screen Graphic – When a Home Screen Graphic is configured in Setup > Global Options > Other 

Options > Home Screen > Home Screen Graphic, the Home Screen Graphic will appear on the left-hand side 

of the Home Screen. If a Home Screen Graphic is not configured, then the Idealpos logo will appear in place of 

the graphic. 

 

To enable the Home Screen, go to: Back Office > Setup > Yes/No Options > Enable “Allow Home Screen”. 

Any other Home Screen related Yes/No Options that control the behaviour of the Home Screen can also be configured 

as required. 
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The below are various examples of the Home Screen.  

 

Home Screen with no Home Screen Graphic configured in Back Office > Setup > Global Options > Other Options > 

Home Screen > Home Screen Graphic field is blank). 

 

 
 

Home Screen showing the Blackboard (Y/N Option “Show Blackboard” enabled) 

When the Yes/No Option is enabled, the menu button at the top of the Home Screen (≡) will need to be pressed to 

reveal the Blackboard on the left-hand side. 

Also note that the POS Terminal information will also appear on the bottom-right corner after pressing the menu 

button (≡) – this information will appear regardless of the “Show Blackboard” Yes/No Option being enabled.  

 

 
 

Home Screen with Home Screen Graphic configured (Setup > Global Options > Other Options > Home Screen > 

Home Screen Graphic). 
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Yes/No Option “Fast Clerk buttons” enabled and Clerk Images configured (Clerk Images with filenames that match the 

Clerk Codes placed in C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\Clerks): 

 

  
 

Yes/No Option “Fast Clerk buttons” enabled and Clerk Images not configured (Clerk Names are shown instead): 

 

 
  



    Update History 
Return to top 

Idealpos 9 Build 1 - Update History Page 20 of 38 

 

IP-6281 – Department Sales Report button – Option to filter Departments 

This function introduces the ability to configure a Department Sales Report button on the POS Screen so that it will 

filter only by specific Department Codes that have been configured within the POS Screen button. 

 

Before configuring this function, you may need to identify the Department Codes for the Departments that you want 

the button to report on. 

A list of Departments and Department Codes can be viewed by going to: Back Office > File > Sales > Departments. 

The Department Codes will appear within the first column with a header of “Code”. 

The Department Descriptions will appear within the second column with a header of “Description”. 

Make a note of the Department Codes that will be required for the Department Sales button. 
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Close the Departments window, then go to:  

Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

Select a POS Screen tab > Locate a blank button > Configure as follows: 

 

Function: “Dpt Sales Report”. 

Button Caption: Enter a caption for the button, and you may want to include the Department that is being reported 

on in the Description. E.g. Coffee DPT Sales Rpt. 

Automatic Text: Enter the Department Codes into this field within square brackets. 

E.g. If only one Department is required, enter [202] into the Automatic Text field (replacing the code with the 

Department Code). 

 

If multiple Departments are required, they can be entered as a comma separated list. 

E.g. If Department Codes 106 and 202 need to be reported on, enter [106,202] into the Automatic Text field.  

 

A range of Departments is also supported. 

E.g. If Department Codes 201 to 205 need to be reported on, enter [201-205] into the Automatic Text field. 

 

A mix of both comma separated and a range of Departments is also supported. 

E.g. If Department Codes 101, 103 and 201 to 205 need to be reported on, enter [101,103,201-205] into the Automatic 

Text field. 

 

All POS Terminals: If the Department Sales Report needs to report on sales from all POS Terminals, enable this 

checkbox. 

 

Group by Sales Category: This option will group the Department Sales Report by Sales Category. 

 

 
 

Once the button has been configured as required, press the “Save” button. 

Then close the POS Screen Layouts window and go to: POS Screen 
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Navigate to the POS Screen tab where the button was created and press it. 

The Department Sales Report will be displayed and will be filtered by the Department Codes that were entered into 

the Automatic Text field. 

The Report will also display the Department Codes that it is reporting on. 
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Printing  

IP-6149 – Customer Receipt Footer 

This function introduces the ability to configure a Customer Receipt Footer on the Customer Receipt that will be 

printed when a Customer is added to the sale. 

The Customer Receipt Footer can be configured to include tags that will be substituted with the relevant information 

(such as printing the Customer’s Name, Date, Customer Code, Tax Amount, Sale Amount, Date, Invoice Number, 

Customer Scan Code). 

 

To configure this function, go to: Back Office > Setup > Global Options > Printing. 

Within the Other Options area, populate the Customer Receipt Footer field with the details that will be printed on the 

footer of the Customer Receipt. 

The following tags/variables can be entered (including the surrounding square brackets), and these will be substituted 

with the relevant details when the Customer Receipt is printed. 

 

[CUSTOMERNAME] 

[DATE] 

[CUSTOMERCODE] 

[CUSTOMERSCANCODE] 

[TAX] 

[AMOUNT] 
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The following screenshot examples show all the available tags/variables being used in the Customer Receipt Footer. 

 

 
 

Once the Customer Receipt Footer has been configured as required, close the Global Options window to save the 

changes. 

 

A Receipt Printer needs to be enabled and turned on for this function to work. 

This is outside the scope of this document, however, if required, the User Guide can be referenced for further details. 

Network Printers are outlined in the User Guide by clicking here. 

A Receipt On/Off button may also be required to toggle the receipt printing on/off. This is outlined in the User Guide 

by clicking here. 

 

  

https://userguide.idealpos.com.au/Default.htm#Network%20Printers/Network%20Printers.htm
https://userguide.idealpos.com.au/Default.htm#Receipt%20On%20Off/Receipt%20On%20Off.htm
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Go to: POS Screen > Add a Customer to the Sale > Perform a sale > Tender the sale > Receipt is printed with the 

Customer Receipt Footer. 

When a Customer hasn’t been added to the sale, the Receipt is printed without the Customer Receipt Footer. 

The below-left example shows the Customer Receipt with the Customer Receipt Footer (Customer added to sale). 

The below-right example shows the Customer Receipt without the Customer Receipt Footer (no Customer in sale). 
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IP-6160 – Kitchen Printer Beeper – via Cash Drawer Port functionality 

This function introduces the ability to configure Idealpos to trigger the Beeper connected to the Kitchen Printer Cash 

Drawer port when a print job is sent to the Kitchen Printer. 

 

To configure this function, first ensure that the Kitchen Printer Beeper is connected to the Kitchen Printer’s Cash 

Drawer Port.  

Do not connect the beeper to the Cash Drawer Port on the POS Terminal as this will not trigger the beeper. 

 

Once the beeper is connected to the Cash Drawer Port on the Kitchen Printer, go to:  

Back Office > Setup > POS Terminals > Select the POS Terminal > Modify. 

Within the Kitchen Printers tab, select the Kitchen Printer which the Beeper is connected to from the dropdown box on 

the top-left corner > Enable the “Activate Beeper” and “via Cash Drawer Port” checkboxes. 
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Also ensure that the Stock Items are configured to print to the required Kitchen Printer(s) with the beeper(s) attached. 

Go to:  

Back Office > File > Stock Control > Stock Items > Modify a Stock Item > Configure the Printer Settings as required. 

 

 
 

When the Stock Item is added to a sale and finalised, or saved to a table, the Kitchen Docket will be printed, and the 

Kitchen Printer Beeper will be triggered. 
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Programmable Barcodes 

IP-6231 – Programmable Barcodes – User-Defined Settings 

This function introduces the ability to configure an additional Programmable Barcode format (in addition to the 

already configured Programmable Barcode format in Global Options > Sales > Programmable Barcodes). 

This function can be utilised when the Programmable Barcode format is already in use in Global Options > Sales > 

Programmable Barcodes but an additional Programmable Barcode format needs to be enabled. 

 

To configure this function, go to: Back Office > Setup > Global Options > Sales > Programmable Barcodes. 

Ensure that the “Use Hardwired?” option is enabled. 
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Close the Global Options window, then go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > POS Settings. 

New User-Defined Settings will need to be created. 

The User-Defined Settings will vary depending on the type of Programmable Barcode that needs to be supported. 

Therefore, an example of a Programmable Barcode, Stock Item and the required User-Defined Settings to support that 

Programmable Barcode are included as follows: 

 

Stock Item Description: TASTY CHEESE 

Stock Item Programmable Barcode: 240|0315|02884|9 

PREFIX+PLUCODE+PRICE+CHECKDIGIT 
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User-Defined Options: 

 

Description: PB-PREFIX 

Setting: 24 

 

Description: PB-AMOUNTSTART 

Setting: 8 

 

Description: PB-AMOUNTLENGTH 

Setting: 5 

 

Description: PB-ITEMSTART 

Setting: 4 

 

Description: PB-ITEMLENGTH 

Setting: 4 

 

User-Defined Options as shown configured in Setup > POS Terminals > POS Settings > User-Defined Options: 
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Close the POS Terminal settings. 

If required, repeat the creation of the User-Defined Options on each POS Terminal that needs to support the 

Programmable Barcode. 

 

Go to: POS Screen. 

When the example Programmable Barcode is entered/scanned into the POS Screen, the example Stock Item is added 

to the sale using the Price that is embedded in the Programmable Barcode: 

 

Enter/Scan the Programmable Barcode into the sale window: 

 

 
 

After pressing ENTER/scanning the barcode, the Stock Item is added to the sale using the Price that is embedded in 

the Programmable Barcode: 
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Promotions 

IP-6147 – Promotions – Ability to Search by Customer Type 

This function introduces the ability to search by Customer Type Code when in the Promotions window. 

This is useful when searching for specific Promotions that are targeted at a specific Customer Type. 

 

There is no additional configuration required to enable this function; simply having Promotions linked to one or more 

Customer Types is sufficient to use this functionality. 

 

Go to: Back Office > File > Sales > Promotions > Promotions. 

Ensure that there is at least one or more promotions that are linked to a specific Customer Type. 

When modifying a Promotion, the Customer Type is specified within the Customer Type field: 
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To use this function to search for Promotions that are linked to a specific Customer Type, click on the Description text 

on the top-left corner of the Promotions window > Select “Customer Type Code”. 

 

 
 

The text shown will change to “Cust Type”. 

 

 
 

Enter a Customer Type Code into the search field below, and the list of Promotions will be filtered to only show 

Promotions that are linked to the entered Customer Type Code. 

 

 
 

The Customer Type search function will also find Promotions that are linked to multiple Customer Types. 

E.g. If a Promotion is linked to Customer Type 1 and 2, entering either 1 or 2 into the Cust Type search function will 

find and display the Promotion. 

Note that the Search Cust Type only supports searching by one Customer Type Code – a range cannot be entered. 
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Reports 

IP-6194 – Stock Item Sales – Top N programmable for Best/Worst Reports 

This function introduces the ability to specify how many records will be displayed when using the Best/Worst options 

in the Sort Order section of the Selection Criteria when running the Stock Item Sales Report. 

This is done via a new field that appears next to the dropdown box which is used to select the Worst or Best data to 

report on. 

E.g. Selecting the “Best” or “Worst” options will display a blank field which can be used to specify the number of 

records that will be shown – enter the number of records that are required to be displayed. 

 

Note when using this Top N records function with Grouping, this will display the entered number of records for each 

group. 

E.g. When grouping by Department with the Best/Worst functions and entering a number, that entered number of 

records will be displayed for each Department that appears in the Stock Item Sales Report. 

 

Go to: Back Office > Reports > Sales > Stock Item Sales. 

Select Best or Worst from the Sort Order section. 

Select the desired type of data to report on (Quantity, Sales Amount, Cost of Sales, Profit Amount or Discounts). 

In the field located to the right of the dropdown box, enter the number of records that are required for the selected 

Best or Worst option. 

As mentioned above, if grouping by Department, that entered number of records will be displayed for each 

Department that appears in the Stock Item Sales Report. 
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E.g. With Department Grouping, selecting Best > Quantity > 2.  
This will display two of the best Quantity records for items in each Department. 
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When Grouping is not used, the report will only show the overall top N of records for the Best/Worst. 
E.g. Without Department Grouping, selecting Best > Quantity > 2.  
This will only display two of the overall best Quantity records. 
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IP-6346 – Stock Item Sales Report grouped by Attribute – Option to Include Non-Attributed Items 

This function introduces the ability to include Non-Attributed Items when grouping the Stock Items Sales Report by an 

Attribute. This is possible via a new “Include Non-Attributed” checkbox which appears when a Group Field includes an 

Attribute. 

When the “Include Non-Attributed” checkbox is unchecked, the report will only include Stock Items that are linked to 

an Attribute. 

When the “Include Non-Attributed” checkbox is checked, the report will group any Non-Attributed Items under “No 

Attribute”. 

 

To use this function, go to: Back Office > Reports > Sales > Stock Item Sales. 

From the Group Field section, select an Attribute. 

This will display an additional checkbox “Include Non-Attributed”. 

Toggle the checkbox as required > Press “View” to run the report. 
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When running the report, the report will include items with a Dietary Attribute, and any items that are not linked to the 

Dietary Attribute will be grouped together as “No Attribute”. 

 

 


