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Clerks 

IP-5737 – Clerks – Support for Alternate Login Code 

This function introduces the ability to create Alternate Login Codes for each Clerk so that the Clerks can login using a 

code other than their standard login code. 

This functionality has been added for sites which are running two different types of terminals where the different RFID 

readers are reading a different code from the same wrist band. 

E.g. The code readout for each wrist band from the first reader type can be entered into the Login Code field, and the 

code readout from the second reader type can be entered into the Alternate Login Code field. The wristband can then 

be scanned by either reader type and will enable the Clerk to login successfully. 

 

To use this function, go to: Back Office > Setup > Clerks. 

Select a Clerk from the list > Modify. 

A new ‘Alternate Login Code’ field will be displayed below the Login Code field. 

Enter the Alternate Login Code into the Alternate Login Code field > Press ‘Save’. 
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Open the POS Screen > Press the ‘Clerk’ button > Enter/Scan the Alternate Login Code > ENTER. 

If scanning a wristband, the ENTER button shouldn’t need to be pressed. If manually entering an Alternate Login Code, 

press ENTER after the code has been entered. 

 

 
 

The Clerk is logged in using the Alternate Login Code. 
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The Alternate Login Code can also be entered via the Home Screen. 

To enable the Home Screen, go to: Back Office > Setup > Yes/No Options > Enter Keyword Search: “home”. 

Enable “Allow Home Screen”. 

If required, enable “Return to Home Screen after Each Sale” which will display the Home Screen after each sale. 

 

 
 

 
 

The Clerk is logged in using the Alternate Code. 
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Customers 

IP-4085 – Favourite Transaction Function – Play transaction at Current Prices 

This function changes the behaviour of the Customer’s Favourite Transaction function so that when a Favourite 

Transaction is replayed on the POS Screen, the items will be added to the sale using their current Sell Prices instead of 

the Sell Prices that were current at the time when the Favourite Transaction originally took place. 

 

There is no configuration to toggle between replaying transactions using the original Sell Price or the current Sell Price. 

All Customer Favourite Transactions will now be replayed using the current Sell Prices. 

 

Note that the Customer’s Favourite Transaction function may require configuration if this functionality hasn’t been 

previously used or configured at the venue. 

The process on how to configure a Favourite Transaction is outlined in the Customer’s Favourite Transaction topic in 

the Idealpos User Guide. 

 

To use this function, go to: POS Screen > Press Customer Button > Add a Customer to the sale [or scan the Customer’s 

Code] > Add the Stock Items to the sale that are to be included in the Favourite Transaction > Tender the sale. 

 

 
 

  

https://userguide.idealpos.com.au/#Customers/Customers%20Favourite%20Transaction.htm
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After the sale has been completed, go to: Back Office > Enquiry > Journal History. 

Select the Journal from the Journal History Enquiry for the sale that was just performed > Favourite. 

 

 
 

A confirmation prompt will be displayed > Press ‘Yes’ to continue. 

If the Customer previously had a Favourite Transaction, this transaction will replace their previous Favourite. 

 

 
 

After confirming the prompt, a final prompt will appear to confirm that the Favourite Transaction has been saved. 
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A Favourite Transaction has now been set for the Customer; close the Journal History Enquiry window. 

If the Sell Prices change for the items in the Favourite Transaction, the next time the Favourite Transaction function is 

used to recall those items to the sale, they will be added at their current Sell Prices. 

 

To demonstrate this function, the Sell Prices of each item in the Favourite Transaction have been modified and had 

their Sell Prices doubled, so that the total amount will be $20.00 instead of $10.00 as shown in the previous 

screenshot. Stock Item Sell Prices can be modified via Back Office > File > Stock Control > Stock Items > Search for 

the item > Modify > Update Sell Prices as required > Save > repeat the process to modify the Sell Price of other items. 

 

When the Customer is added to a sale, the following prompt will be displayed > Pressing ‘Yes’ will add the items from 

their Favourite Transaction to the sale. 

 

 
 

The Stock Items from their Favourite Transaction are added at the current Sell Prices. 

As mentioned above, the Sell Price for each item in the Favourite Transaction has been modified to be double of the 

previous Sell Price to demonstrate this function. 

The screenshot shown below shows the Total amount now being $20.00 instead of $10.00 as shown in the previous 

screenshot when the Favourite Transaction was originally being created.  
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EFTPOS  

IP-5761 – Idealpos Payments module renamed ‘Oolio Pay Global’ 

The Idealpos Payments module has been renamed to ‘Oolio Pay Global’. 

Oolio Pay Global is an EFTPOS integration available direct from Idealpos. 

Contact Idealpos or your reseller for further information about this integration. 

The Oolio Pay Global integration is listed in the Idealpos User Guide – click here. 

Please contact Idealpos or your reseller for assistance with configuring this EFTPOS integration. 

 

 
  

https://userguide.idealpos.com.au/#EFTPOS/Oolio%20Pay%20Global/Oolio%20Pay%20Global.htm
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IP-5762 – Oolio Pay AUS/NZ EFTPOS Interface 

This adds support for the Oolio Pay AUS/NZ EFTPOS Interface to Idealpos. 

Oolio Pay AUS/NZ EFTPOS is an EFTPOS integration available direct from Idealpos. 

Contact Idealpos or your reseller for further information about this integration. 

Further information about configuring Oolio Pay AUS/NZ EFTPOS is listed in the Idealpos User Guide – click here to go 

to the Oolio Pay AUS/NZ EFTPOS topic in the User Guide. 

 

  

https://userguide.idealpos.com.au/#EFTPOS/Oolio%20Pay%20AUS%20NZ/Oolio%20Pay%20AUS%20NZ.htm
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Labels 

IP-5839 – Stock Item Labels – Support for Cipherlab 8200 Series Mobile Computers 

This function introduces the ability to generate Stock Item Labels using label data sent from Cipherlab 8200 Series 

Mobile Computers. 

When this type of device sends label data to the POS System, it sends the data in the following sequence: 

[Scancode][Space][Quantity][CarriageReturn/Enter] 

 

E.g. If labels are requested for the following items…  

Coke 2L has a scancode of 9861576846574 and a quantity of 5 labels requested. 

Sprite 2L has a scancode of 9840964095909 and a quantity of 2 labels requested. 

The data that is sent to Idealpos will look like this… 

 

9861576846574 5 

9840964095909 2 

 

To send label data from this type of device, go to: Back Office > Utilities > Labels. 

Select the Scan Code field in the Labels window, then send the data to the POS System from the device. 

As the data is sent to Idealpos, the device will send/enter the data for each item one at a time; as the data is being 

entered, the items will gradually populate the grid, showing the Stock Item Code, Description and the Label Quantity. 

 

The same process can be simulated without using a Cipherlab 8200 device by simply manually entering or pasting the 

Scan Code followed by the quantity into the Scan Code field, then pressing ENTER. 
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After pressing ENTER, the Stock Item will be added to the list of labels using the quantity entered. 

 

 
 

When using the Cipherlab 8200 series device, the above process will occur as the data is sent/entered from the device.  
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Reports 

IP-5864 – Stock Item Sales Report – Use Stock Item Last Cost for costings (User-Defined) 

This function introduces the ability to specify which Cost will be used on the Stock Item Sales Report via a User-

Defined Option. 

When the User-Defined Option isn’t configured or is set to 0, the Standard Cost will be used. 

When the User-Defined Option is configured and set to 1, the Last Cost will be used. 

 

To configure and use this function, go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > POS Settings tab. 

 

Create the following User-Defined Option: 

Description: STOCKSALESREPORT-LASTCOST 

Setting: 1 

 

 
 

Close the POS Terminals window to save the change. 
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To demonstrate this function, the Idealpos Demo Database contains a “MICROWAVE” Stock Item with a Stock Item 

Code 303004. 

The Stock Item’s Standard Cost has been set to 71.2000 and the Last Cost has been set to 61.2000. 
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Ensure that the Stock Item has been sold/contains sales for the period that is selected in the Stock Item Sales Report. 

Run the Stock Item Sales Report by going to Back Office > Reports > Sales > Stock Item Sales. 

 

Select the “Cost of Sales” option > Run the Report. 
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The Last Cost will be displayed in the report. 

 

 
 

If the User-Defined Option STOCKSALESREPORT-LASTCOST doesn’t exist or is set to 0, the Standard Cost will be 

displayed in the report. 
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Room Interface 

IP-5825 – Newbook API – Support for GL Category ID 

This function introduces the ability to set a GL Category ID for data being posted from Idealpos to Newbook via the 

Newbook API connection. 

 

To configure this function, go to: Back Office > Setup > Global Options > Interfaces > Rooms. 

Set the GL Category ID to an ID that exists in Newbook. 

 

 
 

An example of the GL Category that appears in Newbook charges. 
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Stock Items 

IP-5814 – Alternate Codes – Ability to search 

This function introduces the ability to search for Alternate Codes within the Alternate Codes window. 

This is useful in situations where a Stock Item contains numerous Alternate Codes, such as Stock Items that have been 

merged into one Stock Item using the Import Custom CSV Format by Supplier function. 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

Select a Stock Item and press the ‘Alternate Codes’ button on the left-hand side menu. 

 

 
 

Entering an Alternate Code into the Search field will search the entered Alternate Code against the currently displayed 

Stock Item. 

The list of Alternate Codes will be filtered as the code is entered and any matches will be displayed. 

 

 
 

Wildcard (*) searching is also supported. 

E.g. to search for an Alternate Code that contains 79 anywhere in the code, enter *79. 

The list of Alternate Codes will be filtered to show matching results. 

 

  

https://userguide.idealpos.com.au/Content/Stock%20Purchases/Import%20Custom%20CSV%20Format%20by%20Supplier.htm#Merging_New_Items_based_on_Description_Price
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Stock Purchases 

IP-5766 – Import Custom Invoice – Update existing Stock Descriptions (User-Defined) 

This function introduces the ability to update existing Stock Descriptions when using the Import Custom CSV Format 

by Supplier function. 

 

When an existing Stock Item in a Stock Purchase has an updated Description from the Supplier, the Description for the 

corresponding Stock Item in Idealpos will have its Description updated when this option is enabled. 

 

To enable this function, go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > POS Settings tab > User-Defined Options. 

 

Create a User-Defined setting as follows: 

 

Description: IMPORTINVOICE-UPDATEDESC 

Setting: 1 
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Yes/No Options 

IP-5821 – Yes/No Option – Bypass QR Code Web Link Scanning in POS 

This function introduces the ability to ignore QR Codes that contain web links when scanned via the scanner. 

This can be used to prevent the scanner from scanning the QR Code in situations where Stock Items contain a 

standard barcode and a QR Code too close together, triggering the scanner to scan the QR Code instead of the 

barcode. 

 

To configure this function, go to: Back Office > Setup > Yes/No Options > Search: bypass. 

Toggle the Yes/No Option “Bypass QR Code Web Link Scanning in POS” as required. 

 

 
 

Note - A Close Suite/Open Suite will be required for this option to take effect. 


