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Customers  

IP-4768 – Customer Email – Increased field length to support multiple email addresses 

This function increases the character length allowed in the Email Address field when modifying a Customer.  

By increasing the Email address field length, it is possible to enter longer email addresses into this field, as well as the 

ability to enter multiple email addresses, each email address being separated by a semicolon (;). 

All email address entered in the email field will receive Customer Statements and/or Invoices when they’re emailed. 

 

To configure and use this function, go to: 

Back Office > Setup > Global Options > Other Options > Email Settings 

Ensure that your Email Settings have been configured (so that emails can be sent to the email addresses entered in the 

next step). 

You may need to source the required details from your Internet Service Provider or from the email service that you are 

utilising. 
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Close the Global Options window, then go to: Back Office > File > Customers > Customers 

 

Select a Customer > Modify 

 

In the Email field, enter the email addresses that you want included in the customer record, ensuring that each email 

address is separated by a semicolon. There is no limit to the number of email addresses that can be entered, but 

instead, you have a maximum limit of 255 characters in the Email field. Note too that the visible area of the Email field 

remains unchanged, so when reviewing the entered addresses, you will need to click into the field, then use your 

left/right arrow keys to scroll through all email addresses. 

The below is an example of how to separate each email address entered in the Email field. 

 

E.g. john@company.com; joe@company.com 

 

Each email address that is entered will receive an email when Invoices or Customer Statements are emailed to this 

customer. 
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Press the ‘Save’ button on the top-left corner of the Modify Customer window to save your change. 

To email Customer Statements, go to: Back Office > Reports > Customers > Customer Statement. 

 

To Email Customer Statements to all Customers, adjust the report criteria to include the data you want included, then 

press the ‘Email’ button. 

If you only want to email Customer Statements to one or more specific Customers, ensure that you specify the details 

of those Customers in the ‘Selection Range’. 

Then press the ‘Email’ button, and those Customers will be emailed. 

In the case of the Customer which had multiple email addresses added in the previous step, each email address will 

receive the Customer Statement. 
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The Customer Statement for each customer in the Selection Range is emailed to the respective Customer’s email 

address(es). 
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Reports 

IP-5087 – Stock Movement Report – Site Grouping/Selection Range 

This function adds the ability to group the Stock Movement Report by Site. 

It also adds the ability to select the Site(s) in the Selection Range so that the report only includes report data that 

matches the specified Site(s). 

 

To use this function, go to: Back Office > Reports > Stock Control > Stock Movement.  

 

To group by Site, enable the ‘Site’ checkbox in the Group by section. 

The Group by ‘Site’ checkbox can be used in combination with the following Group by options: 

 

• Department + Site 

• Sales Categories + Site 

• Supplier + Site 

 

To report on specific Site(s), enter the Site(s) into the Site field. 

Sites can be entered as a comma separated list (e.g. 1,2,3) or as a range (e.g. 1-3). 
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The report will be grouped by Site. 

If any specific Sites were entered into the Selection Range, only the Stock Movement data that is relevant for those 

Sites will be displayed in the report (and if the Group by Site option was also enabled with the Sites Selection Range, 

those sites will be grouped). 
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IP-5088 – Stock Movement Report – Supplier Grouping/Selection Range 

This function adds the ability to group the Stock Movement Report by Supplier. 

It also adds the ability to select the Suppliers in the Selection Range so that the report only includes report data that 

matches the selected Supplier Range. 

 

To use this function, go to: Back Office > Reports > Stock Control > Stock Movement. 

 

To group by Supplier, enable the ‘Supplier’ checkbox in the Group by section. 

The Group by ‘Supplier’ checkbox can be used in combination with the following Group by options: 

 

• Location + Supplier 

• Supplier + Site 

 

To report on specific Suppliers, enter the Supplier Code range into the Supplier From/To fields. 
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The report will be grouped by Supplier. 

If any specific Supplier Codes were entered into the Selection Range, only the Stock Movement data that is relevant for 

those Suppliers will be displayed in the report (and if the Group by Suppliers option was also enabled with the 

Suppliers Selection Range, those Suppliers will be grouped). 
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Stock Items 

IP-3344 – Sell Prices automatically change based on Profit when Cost is modified 

This function adds the ability to automatically change a Stock Item’s Sell Prices when the Stock Item’s Cost is modified, 

based on the Profit % or Profit $ (the choice between using Profit % or Profit $ is available in the Stock Items screen 

when modifying the Stock Item). 

This function also introduces the ability to select which Cost (Standard Cost, Last Cost or Average Cost) Idealpos uses 

to calculate and display the amounts in the Profit % and Profit $ fields.  

Prior to this change, Idealpos was hard-coded to calculate Profit % and Profit $ based on the Average Cost price.  

The Average Cost is set as the default, but this can now be changed to suit your requirements. 

 

To specify which Cost Idealpos will use to calculate the Stock Item Profit %/Profit $, go to: 

Back Office > Setup > Global Options > Sales. 

In the Miscellaneous section, set the ‘Stock Item Profit Based On’ to either Standard Cost, Last Cost or Average Cost. 
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Close the Global Options window then go to: 

Back Office > File > Stock Control > Stock Items > Select Stock Item > Modify. 

 

The Profit % and Profit $ are calculated based on either the Standard Cost, Last Cost or Average Cost (based on the 

option that was selected in Global Options in the previous step listed above). 

In the screenshot example shown below, the Stock Item Profit Based On setting was set as ‘Average Cost’. 

This is reflected in the Profit % and Profit $ fields. 
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In addition to the ability to control which Cost is used to calculate the Profit %/Profit $, the ability to change the Sell 

Prices automatically when the Cost price is changed (based on Profit) is now possible. 

 

Within the Cost Prices – Recalculate Sell Prices section of the Modify Stock Item screen, select one of the following 

options: 

 

Don’t Recalculate Sell Prices – Selecting this option will not recalculate the Sell Prices when the Cost Price is 

changed. 

Based on Profit % - Selecting this option will recalculate the Sell Prices for each Price Level based on the percentage 

values in the Profit % fields when the Cost Price is changed. 

Based on Profit $ - Selecting this option will recalculate the Sell Prices for each Price Level based on the values in the 

Profit $ fields when the Cost Price is changed. 
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To use this function, select the desired Recalculate Sell Prices option. 
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Modify the Cost Price option that was selected in Global Options (e.g. Average Cost). 
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Click the cursor into another Cost field (e.g. Last Cost).  

The Sell Prices in each Price Level will be recalculated based on the Recalculate Sell Prices option that was selected and 

the Cost Price that was entered. 

 

 
 

If any further changes are required to the Stock Item, change them as required. 

Once completed, press the ‘Save’ button to save the changes to the Sell Prices. 
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Stock Purchases 

IP-5102 – Stock Purchasing – When adjusting Sell Prices, option to copy current Profit Margins 

This function adds the ability to copy the current Profit Margins when adjusting Sell Prices in the Stock Purchases 

screen – available when using either Purchase Order or Stock Received. 

When the Cost Price of a Stock Item in a Stock Purchase [New Cost Price] differs to the Current Cost Price, the Profit 

Margin % of the Stock Item will change after the Stock Purchase is processed (if the Sell Price is not adjusted 

accordingly).  

If a Stock Item’s Profit Margin % is required to be maintained at the same percentage after processing a Stock 

Receive/Purchase Order, the user will need to press the Prices button in the Stock Purchases screen, then they have to 

manually copy the Current Profit Margin % into the New Profit Margin % for each Price Level. 

With this change, a new ‘Copy Profit’ button has been added to the Selling Prices screen, which will save the user from 

having to manually copy the Current Profit Margin % into the New Profit Margin %. 

The ‘Copy Profit’ button will only appear in the Selling Prices screen when the Stock Item’s Cost in the Stock Purchase 

varies to the Stock Item’s Current Cost. 

 

To use this function, go to: Back Office > Transactions > Stock Control > Stock Purchases. 

Create a new Purchase Order or Stock Receive > Add Item to the Purchase Order/Stock Receive.  

Alternatively, select an existing Purchase Order/Stock Receive > Modify. 

 

Within the Stock Received/Purchase Order, select the line that contains the Stock Item that Sell Prices need to be 

reviewed, then press the ‘Prices’ button. 
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The Selling Prices window will appear. 

The Current Sell Prices/Current Profit Margin % will appear on the left-hand side, and the New Sell Prices/Profit Margin 

% will appear on the right-hand side. 

The New Profit Margin % shown (after opening the Selling Prices screen and before any changes have been made) is 

calculated and displayed based on the Current Sell Prices for each Price Level. 

In the example shown below, the ‘Copy Profit’ button is displayed as the Last Cost (0.75) differs to the New Cost (0.83). 
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Pressing the ‘Copy Profit’ button will copy each Price Level’s Current Profit Margin % into the New Profit Margin % 

field. This in turn will calculate the New Sell Price for each Price Level as shown in the example below. 

 

 
  

To save the new Sell Prices, press the ‘Save’ button. 

To back out of the change and cancel without changing the Profit Margin % or Sell Prices, press the ‘X’ button on the 

top-right corner of the Selling Prices window. 

 

Note that the Sell Prices will be changed immediately after the ‘Save’ button is pressed. 

 

The above process can be repeated for each Stock Item in the Purchase Order/Stock Receive.  
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When ready to finalise the processing of the Purchase Order/Stock Receive, select the Purchase Order/Stock Receive 

from the main Stock Purchases screen, then press the ‘Process’ button.  

 

 
 

If processing a Stock Receive/Invoice, the entry will be cleared from the Stock Purchases screen. 
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If processing a Purchase Order, Idealpos will open the Purchase Order so that any final adjustments can be made, then 

press the ‘Process’ button to finalise the order. 

 

 
 

A final prompt will be displayed to confirm that the Purchase Order was fully received. 

Select ‘Yes’ to delete the Purchase Order or select ‘No’ to retain the Purchase Order in the Stock Purchases screen. 

If ‘No’ is selected at this stage, the Purchase Order can be deleted at any time from the Stock Purchases screen. 
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POS Screen 

IP-5076 – Switch POS Layout Function 

This function adds the ability to switch between POS Screen Layouts from within the POS Screen. 

An example environment where this function may be utilised is outlined as follows. 

A venue that has POS Terminals in the Bar area (Bar POS Screen Layout) and POS Terminals in the Café area (Café POS 

Screen Layout), with some POS terminals located in close proximity to both the Bar and Café area.  

In this type of environment, Clerks may require the ability to toggle between the Café and Bar POS Screen Layout, 

depending on the area that the customer is wanting to purchase items from. With this function, this can now be 

achieved. 

Note that this function can only be used when a sale is not currently in progress on the POS Terminal. 

 

Before configuring this function, ensure that you have multiple POS Screen Layouts, as this function enables the ability 

to toggle between each POS Screen Layout.  

Refer to the POS Screen Setup topic in the User Guide for further details about creating POS Screen Layouts. 

 

To configure this function, go to: 

Back Office > Setup > POS Screen > POS Screen Setup. 

 

Take note of the Code displayed next to each POS Screen Layout, as these Codes will be required when creating the 

Switch POS Screen Layout buttons within your layouts. 

 

Select the POS Screen Layout which you want to create the Switch POS Layout button, then press ‘Buttons’. 

 

 
  

https://userguide.idealpos.com.au/#POS%20Screen%20Setup/POS%20Screen%20Setup.htm
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Select a POS Screen Tab where you would like to create your Switch POS Screen Layout button. 

When selecting a POS Screen tab to create the button, consideration should be made on whether you want all staff to 

have the ability to access the button or not. If only certain staff require access to this function, consider creating the 

button on a POS Screen tab that is secured via User Permissions for only specific staff to access. 

User Permissions to each POS Screen Tab can be configured via Back Office > Setup > Users > Select User > Modify > 

POS > Layers > Toggle the checkboxes for each Tab that the User should/should not have access to.  

 

Select a blank/unused button within the desired POS Screen tab, and configure the button as follows: 

 

Function: Switch POS Layout. 

POS Layout: Enter the Code of the POS Layout that you want this button to switch to. Note that if you want your staff 

to manually enter the POS Layout Code, you can leave this field blank, however, the staff will need to be aware of the 

Codes that correspond to each POS Screen Layout that they will be switching to. 

Button Caption: Enter the text label that you want to appear on the button (e.g. Café POS Screen, Bar POS Screen, 

etc.). 

 

 
 

Save the button. 

Multiple buttons can be created within the current POS Screen Layout if you have more than one POS Screen Layout 

that you want to be able to switch between. 
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Once the Switch POS Layout buttons have been created for the current POS Screen Layout, repeat the above process 

and create the Switch POS Layout button(s) within each POS Screen Layout (so that after a Clerk switches to a different 

POS Screen Layout, they can switch to the previous layout). 

 

E.g. From the POS Screen Layouts window, select the other POS Screen Layout > Buttons.  

 

 
 

Configure the button to switch to the opposite POS Screen Layout: 
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Close the POS Screen Layout windows once the configuration has been completed. 

From the POS Screen, navigate to the POS Screen tab that contains the Switch POS Layout button and press it. 

 

 
 

The POS Screen Layout will change. 

 

Note that as described earlier, the ability to change POS Screen Layouts is only available when there is no active sale 

taking place (no items or customer added to the sale). 

Attempting to change the POS Screen Layout while a sale is in progress will produce the following prompt (and the 

POS Screen Layout will not switch). 
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IP-5107 – Fast Add Stock Items – Ability to select Department 

This function adds the ability to select the Department from a dropdown list when adding a Stock Item to the sale 

using the Fast Add Stock Items function. When the Stock Item is added to the database via the Fast Add Stock Items 

function, the item will be assigned to the Department that was chosen from the dropdown box in the Fast Add Stock 

Item screen.  

Previous to this change, all Stock Items that were added via the Fast Add Stock Items function were assigned to the 

Default Department configured in Global Options > Sales > Fast Add Stock Items function. 

 

To configure and use the Fast Add Stock Items function, go to: 

Back Office > Setup > Yes/No Options. 

Enter Search: force stock item. 

Disable ‘Force Stock Item Search if Item not found’ as this option is not compatible with the Fast Add Stock Items 

function. 
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Go to: Back Office > Setup > Global Options > Sales. 

Within the Fast Add Stock Items section, configure the following: 

Fast Add Stock Items when not found – Enable checkbox 

Default Department – Specify the Default Department that Stock Items should be added to. The Department 

specified here will be the default Department that appears in the Department dropdown box of the Fast Add Stock 

Item screen. 

Stock Code/Scan Code – Select the field that the Scan Code/Barcode will be entered into.  
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Close the Global Options window. 

Go to: POS Screen. 

Within the POS Screen, scan or enter a Scan Code/Barcode that does not exist. 

The POS Screen will display the Fast Add Stock Item window. 

 

 
 

Description – Enter the Stock Item Description 

Price – Enter the Sell Price of the Stock Item. The Price entered here will be entered into all Price Levels for this Stock 

Item. 

Department – Select the desired Department to assign the Stock Item to. 

GST Type – Enable the checkbox next to the GST/Tax Type that should apply to this item. 

 

Press ‘Proceed’ to continue. 
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The Stock Item will be added to the database as well as being added to the sale. 

 

 
 

If the Stock Item is scanned again on this POS terminal or any other networked POS Terminals in the venue, the Fast 

Add Stock Item window will not be displayed, and the Stock Item will be added to the sale. 
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The Stock Item will be available via Back Office > File > Stock Control > Stock Items > Modify. 
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Quick Stocktake 

IP-2941 – Quick Stocktake – Ability to Clear Stocktake and Exit 

This function adds the ability to Clear Stocktake and exit from the Quick Stocktake screen. 

Prior to this change, the ‘Update Stock Levels’ button had to be used, even if there were no changes made. 

This introduced a level of risk if a Clerk accidentally entered the Quick Stocktake screen, performed an accidental 

button press on the numeric keypad, then had no way to cancel any changes and exit the Quick Stocktake screen. 

 

This has been improved via the addition of a ‘Clear Stocktake and Exit’ button. 

 

To configure and use this function, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

Select a suitable POS Screen Tab that contains unused/blank buttons, and create a ‘Quick Stocktake’ button as follows: 

 

Function: Quick Stocktake 

Department Range: Enter the Department Range to restrict the Quick Stocktake to. When this Quick Stocktake button 

is pressed on the POS Screen, it will only display Stock Items that fall within the entered Department Range. The 

example below shows a Department Range of 205 which is the Soft Drinks Department Code in the Idealpos Demo 

Database. 

Print Stocktake on Receipt Printer: Toggle the checkbox to control whether the Stocktake will print to the Receipt 

Printer. 

Button Caption: Enter a caption for the button (e.g. Quick Stocktake, Quick Stocktake – Soft Drink, etc.). 

 

 
 

Close the POS Screen Layout windows. 
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Go to: POS Screen. 

Navigate to the POS Screen tab where the Quick Stocktake button was created and press the button to access the 

Quick Stocktake function. 

The Quick Stocktake screen is displayed and is restricted to the Department/Department Range that was entered in 

the Department Range field of the button configuration. 

The ‘Clear Stocktake and Exit’ button can be pressed to clear any accidental entries and to Exit the Quick Stocktake 

screen. 

 

 
 

The ‘Stocktake has been Cleared’ prompt will be displayed. Press ‘OK’ to close the prompt and return to the POS 

Screen. 
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If the venue requires a confirmation prompt to Clear Stocktake and Exit (e.g. if the Clerk accidentally presses the ‘Clear 

Stocktake and Exit’ button instead of the ‘Update Stock Levels’), this can be configured by going to: 

Back Office > Setup > Yes/No Options > Enter Search: ‘confirm you want’. 

Enable the option ‘Confirm you want to Clear Stocktake’. 

 

 
 

When pressing the ‘Clear Stocktake and Exit’ button on the Quick Stocktake screen, the following prompt will be 

displayed, which can be used to prevent the accidental clearing of a Quick Stocktake. 

 

 
 

Pressing ‘Yes’ will Clear the Quick Stocktake and display the ‘Stocktake has been Cleared prompt’. 

Press ‘OK’ to close the prompt and return to the POS Screen. 
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Yes/No Options 

IP-5092 – Yes/No Option – Force Receipt when Order Number is used 

This function will force a receipt to be printed for the sale when an Order Number has been added to the sale, 

regardless of whether receipt printing is enabled or disabled. 

 

For this function to work, it requires the following options to be configured: 

• Enable Yes/No Option ‘Force Receipt when Order Number used’ 

• Receipt Printer configured for the POS Terminal 

• Order Number POS Screen button 

• Receipt On/Off POS Screen button 

 

To configure and use this function, go to: Back Office > Setup > Yes/No Options 

Enter Search: “force receipt when” 

Enable Y/N Option ‘Force Receipt when Order Number used’ 

 

 
 

Close the Yes/No Options window. 
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Go to: Back Office > Setup > Network Printers. 

Ensure that the POS Terminal(s) have Network Printer(s) configured. 

If required, press the ‘Add’ button to add Network Printers, then drag and drop the Network Printers from the top-

section of the Network Printers screen to the required printer slots for the POS Terminals listed at the bottom of the 

Network Printers window. 

 

 
 

Close the Network Printers window. 
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Go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

 

Ensure that a Receipt On/Off button exists within one of the POS Screen Tabs. 

If a Receipt On/Off button does not exist, select an unused/blank button and configure as follows: 

 

 
 

An Order Number Button also needs to exist within one of the POS Screen Tabs so that an Order Number can be 

assigned to a sale/order when required. 

If an Order Number Button does not exist, select an unused/blank button and configure as follows: 

 

 
 

Once the buttons have been configured as required, close the POS Screen Layout windows. 
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Go to: POS Screen. 

Navigate to the POS Screen tab that contains the ‘Receipt On/Off’ button.  

Ensure that the button displays ‘RECEIPT IS OFF’. 

If the button shows ‘RECEIPT IS ON’, press the button which will act as a toggle to enable or disable receipt printing.  
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Navigate to the POS Screen Tab that contains the ‘Order Number’ button and press the button. 
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ENTER ORDER NUMBER will be displayed in the sale window. 

 

 
 

An Order Number can be entered manually, or the ENTER button can be pressed and an Order Number will be 

automatically entered. 

 

The Order Number will appear above the sale window. 

 

 
 

Add the required items to the sale. 
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Press the ENTER button to go to the Tender screen > Press CASH to finalise the sale. 
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The Customer Receipt is forced as per the Yes/No Option ‘Force Receipt when Order Number used’. 

The Order Number is also printed towards the top of the receipt. 

 

 
 

  


