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Accounting Interface 
IP-3642 – Xero API – Improved flow of connection and disconnection to Xero 

This function has improved the flow of connection and disconnection to Xero when configuring the Xero OAuth 2.0 
Integration with your system. 
Changes you will note are new buttons “Connect to Xero” and “Disconnect from Xero”.  
Note that the “Get Accounts” button will now appear on the bottom-right corner of the window after your system 
has been connected to Xero. Also note that after your system has been connected to Xero, the accounts will 
automatically be retrieved and displayed on the right-hand side.  
The “Get Accounts” button can be used in the event that you need to retrieve a list of Accounts at a later date once 
your system has already been configured. The “Get Accounts” button can also be used to retrieve the latest 
Accounts from Xero if you’ve just made changes to your Chart of Accounts after connecting Idealpos to Xero. In this 
case, the “Get Accounts” button can be pressed to retrieve the latest Accounts from Xero. 
 
The process to follow when configuring your system with the Xero OAUTH2 Integration is as follows: 
Go to: Setup > Global Options > Accounting > Select XERO (OAUTH2) from the Accounting Package dropdown box > 
Press “Connect to Xero” 
A pop-up window will appear where you will need to login to Xero using your Xero Username and Password. 
Once logged in, you will need to select your Organisation. 
Once the above steps have been completed, the pop-up window will close and you will return to the Idealpos 
Global Options window. Shortly thereafter, the list of Accounts will be retrieved and displayed along the right-hand 
side of the window.  
The process from this point on is to assign the Account Codes in Idealpos with the Accounts from Xero. 
This is done by dragging the Account code from the right-hand side into the Idealpos Account Codes shown on the 
left-hand side. 
When configuring your system with Xero Accounting, we strongly recommend that you seek professional advice 
from your Account or Bookkeeper.  
Linking the wrong Accounts in Idealpos can result in data being transferred incorrectly. 
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Gift Vouchers 
IP-3605 – Gift Vouchers – Option to set specific Expiry Date per Gift Voucher Type 

This function adds the ability to specify a specific Expiry Date per Gift Voucher Type. 
This may be useful at venues where a Gift Voucher is given to new Members when they sign up with the 
requirement to have all Member’s Gift Vouchers expire on the same day of the year (e.g. at the end of the year or 
end of financial year). 
 
To configure and use this function, go to: Setup > Global Options > Credit Notes/Gift Vouchers 
In the Expiry Days/Date column of the Gift Voucher Type that you want to assign an Expiry Date, enter the Expiry 
Date. Enter an expiry date in the future using the format either dd/mm/yyyy or mm/dd/yyyy depending on your 
region. 
 
The date entered will be automatically converted into dd Month YYYY after you click into another field. 
E.g. For the Australian region, entering 25/12/2020 (dd/mm/yyyy) will result in the Expiry Date appearing as 25 Dec 
2020. 
Entering a past date will result in the date automatically adjusting to the following year.  
E.g. If the current date is 14th September 2020 and entering a past expiry date of 01/09/2020 (using date format 
dd/mm/yyyy) will result in the date automatically adjusting to 01 Sep 2021. 
Entering an invalid date (e.g. 35/12/2020) will result in the dd portion of the expiry date being converted into 35 
expiry days (where the Gift Voucher will expire the number of days after the issue date). 
 
In the below example, we have entered 25/12/2020 using a format of dd/mm/yyyy into Gift Voucher Type 3. 
You may enter the Expiry Date into the Expiry Days/Date field of the required Gift Voucher Type.  
If your region uses a different format, enter a date using the format that’s specific to your region: 
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To confirm and ensure that the date has been converted correctly, click into any field other than the current Expiry 
Days/Date field. The Expiry Date will be converted to appear showing the date as a numeric value, the month will 
appear as text and the year will appear as a numeric value. In our example of 25/12/2020, the date will appear as  
25 Dec 2020. 
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In order to be able to sell the Gift Voucher Type, ensure that you have a Gift Voucher button configured. 
Go to: Setup > POS Screen > POS Screen Setup > Select POS Screen Layout > Buttons 
Locate the POS Screen tab that contains your Gift Voucher button, or locate a POS Screen tab to create the new 
button. The button can be configured in one of the following ways: 
 
Function: Received on Account 
Received on Account: GV Purchase 
Gift Voucher Type [Blank] – When this type of button is pressed from the POS screen during a sale, the Gift Voucher 
Type dropdown box will be available and can be used to select the Gift Voucher Type which the Expiry Date was 
configured: 
 

 
 
Gift Voucher Type [Type that matches the Gift Voucher which the Expiry Date was set above] –  
When this type of button is pressed from the POS screen during a sale, the Gift Voucher Type dropdown box will be 
greyed out/read-only and locked to the Gift Voucher Type configured for the button: 
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Note that when you’re configuring the Gift Voucher button, once a Gift Voucher type has been selected, it cannot 
be changed to a blank value. Therefore, if you wish to allow the Clerk to select the Gift Voucher Type when using 
the Gift Voucher button during a sale, do not select a Gift Voucher Type from the dropdown box. If you accidentally 
select a Gift Voucher Type during the button configuration and you want to clear the type, you will need to remove 
the button and create a new Gift Voucher button again.  
 
If your system hasn’t previously been used to sell Gift Vouchers, additional setup steps may be required. 
These include Function Descriptor settings for the Received Account function, Gift Voucher Redemption tender and 
other additional settings. For a more detailed set of steps to enable the sale of Gift Vouchers in Idealpos, please 
refer to the Setting Up Gift Vouchers topic in the Idealpos User Guide for more information. 
For more general information about Gift Vouchers in Idealpos, please refer to the Gift Vouchers topic in the 
Idealpos User Guide. 
 
Once the buttons have been created, go to the POS Screen > Navigate to the Tab containing your GIFT VOUCHER 
button > Press the “GIFT VOUCHER” button. 
Idealpos will display a GIFT VOUCHER sale prompt. 
Enter the Gift Voucher Amount, Recipient Name and select the GIFT VOUCHER type which matches Type that the 
Expiry Date was configured in the above steps.  
If you set a Gift Voucher Type during the button configuration, the Gift Voucher Type will be locked to the selected 
type and the Gift Voucher Type dropdown box will be read-only. 
If the Recipient has an Email Address, it may also be entered and the Gift Voucher will be emailed to them. Note 
that using the Email Address functionality requires that you have setup an Email Account in Idealpos (Setup > 
Global Options > Other Options > Email Settings). If an Email Account has not been configured in Idealpos and an 
Email Address for the recipient is entered, they will not receive the Gift Voucher email. 
 

 
  

https://userguide.idealpos.com.au/#Gift%20Vouchers/Setting%20up%20Gift%20Vouchers.htm
https://userguide.idealpos.com.au/#Gift%20Vouchers/Gift%20Vouchers.htm
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Press the OK button to add the Gift Voucher to the sale. 
The Gift Voucher appears in the sale window as per the below example: 
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Press the ENTER button then select a Tender Type to finalise the sale. 
If an email address was entered, the Gift Voucher will be emailed to the recipient. 
If no email address was entered, the Gift Voucher will be printed to the receipt printer. 
 
The below is an example of the Gift Voucher printed from the Receipt Printer. 
 

 
 
 
Any Gift Vouchers sold using the selected Gift Voucher Type will all expire on the entered Expiry Date. 
Note that the Expiry Date which is configured in Setup > Global Options > Credit Notes/Gift Vouchers does not 
auto-change once the current date is equal to or greater than the Expiry Date. This means that if you attempt to sell 
the Gift Voucher Type once the current date is greater than or equal to the Expiry Date configured in Global 
Options, a prompt similar to the below will be displayed.  
The date shown in the prompt will be reflective of the Expiry Date for the Gift Voucher Type:  
 

 
 
In order to sell the Gift Voucher Type, you will need to go to: Setup > Global Options > Credit Notes/Gift Vouchers  
Then modify the Expiry Date for the Gift Voucher Type so that it falls on a future date. 
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Range Programming  
IP-3595 – Stock Item Range Programming – Added Changed field 

This function adds the ability to modify the Changed field via the Range Programming facility. 
When Stock Items are modified, a flag is set against the Changed field. The Changed field can then be used to 
generate Labels for Stock Items which have the Changed field enabled.  
With this change, you can perform Range Programming to either enable or disable the Changed flag against Stock 
Items. 
This can be useful in cases where you are performing a range of changes to Stock Items, but then want to disable 
the Changed flag for those items. In the same way, you may want to manually enable the Changed flag for a range 
of items and those items which contain an enabled changed flag can then have labels generated/printed. 
 
To use this function, go to: Utilities > Range Programming > Stock Items 
 
Enter the Stock Item Range that you want to apply this change to by entering value(s) into the 
Code/Description/Department/Supplier fields.  
For the purpose of demonstrating this function, we will use the Demo Database and will set the Department to 205 
(Soft Drinks). 
 
Then from any of the twelve available Fields, select the “Changed” option. 
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Once “Changed” has been selected, a blank checkbox field will appear to the right of the “=” symbol. 
To clear the Changed field so that the Stock Items are marked as unchanged, leave the checkbox blank/unchecked 
as per the below example: 
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To set all Stock Items as Changed, enable the checkbox as per the below example: 
 

 
 
To demonstrate this function, we will leave the Changed field enabled along with the Department 205 (Soft Drink) 
set and will press “Proceed” on the bottom-right corner of the window. 
A prompt will appear “Are you sure you wish to proceed?”. Press “Yes” to continue. 
 

 
 
After programming has been completed, “Programming Completed” will be displayed. Press “OK” to continue: 
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Close the Range Programming window, then go to: Utilities > Labels 
In the Labels window, select the desired label format and enable the tickbox “Modified Stock Items Only”. 
Finally, press “Add to Grid” 
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Stock Items which had the Changed flag enabled will be added below as per the example shown below. 
The Preview/Print buttons can be used to preview and print the labels. Note that the behaviour of the Print 
function can vary depending of the Output To setting. 
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When previewing the labels, they will appear in a new window similar to the below. 
Labels can also be printed from this window via the Printer button on the top-left corner of the window. 
 

 
 
Close the Preview window once labels have been previewed/printed. 
The labels window may be minimised within the Idealpos window as per the below example: 
If this occurs, double click on the title to display the Labels window. 
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To Clear the labels, press the “Clear” button. 
The Changed flag will now be set to 0 for the Stock Items which have had labels printed 
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After pressing Clear, the Labels window will return to a cleared state where no items are shown in the grid. 
 

 
 
You can confirm that the changed flag has been cleared by enabling the “Modified Stock Items Only” checkbox then 
press “Add to Grid”. If no items are added to the grid after pressing “Add to Grid”, the Changed flags have been 
successfully cleared. 
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Restaurant and Table Map 
IP-1315 – Table Details screen – Items grouped by Order Time 

This function adds an Order Time to the Table Details screen which groups items together using the time that they 
were saved to the table. When items are saved to a table, they will be grouped based on the time they were saved.  
If items are saved to the table at different times, multiple groups will appear in the table details screen, each 
representing the time that the items were saved. 
The Order Times can also be clicked on which will select all items that were placed at the selected time. 
This function does not need to be configured or enabled as it has been hard-coded so that it will always appear. 
 
To use this function, go to:  
POS Screen > Add Items to the sale > Table Map 
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Select a Table from the Map > Enter Covers (if prompted) > OK 
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Then from the Table Map, double-click on the Table.  
Alternatively, select the Table from the Table Map > Press Details from the bottom-left corner of the Table Map 
The Table Map Details are displayed which now group items by Order Time: 
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Additional Items can be saved to the table by repeating the above process.  
Every time Items are saved to the table, a new group will be formed which will be reflective of the time they were 
saved to the table: 
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All items that exist within a group can be selected by simply clicking on the time which they’re grouped by. 
Once a selection has been made, the selected items can either be Paid, Deleted, Transferred to another table or Re-
Ordered. 
For further information about using the Table Details screen, please click here to visit the topic in the Idealpos User 
Guide.  
 

 
 
 
  

https://userguide.idealpos.com.au/#Restaurant%20and%20Table%20Map/Table%20Details.htm
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IP-2521 – Support for Direct Table Sales from POS Screen 

This function adds the ability to open or start Table Sales by simply entering the Table Number and pressing the 
Table Number button. Any items currently in the sale will be saved to the entered Table Number without having to 
open the Table Map. This function can either be used before items are added to the sale or it can be used after 
items have been added to the sale, as outlined in the two bullet points below: 
 

• Method one 
Before adding items to the sale, enter the Table Number > Press Table Map Button > Add Items to sale > 
Press Table Map button > Enter Covers if prompted > Items are saved to the Table Number 
 

• Method two 
Add Items to the sale > Enter Table Number > Press Table Map button > Enter Covers if prompted > Items 
are saved to the Table Number 

 
Each of the above methods are outlined below: 
 
To use method one (specifying table number before items are added to the sale), follow the below steps: 
From the POS Screen, enter the Table Number you want to save the items to. 
The Table Number is shown in the sale screen. If any mistakes are made while entering the Table Number, press the 
“CL” button on the on-screen numeric keypad. 
Press the Table Map button: 
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If Prompt for Covers is enabled, a Covers prompt will appear on the bottom-left corner of the POS screen. 
If Items have already been saved to the entered Table Number, the Covers prompt will not appear. 
Enter the number of Covers, then press “OK” to continue: 
 

 
 
The POS Screen will now show the Table Number along with the number of Covers that were entered: 
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Now add the required items to the sale. 
Once the required items have been added, press the “Table Map” button: 
 

 
 
A confirm prompt may be displayed if enabled in Yes/No Options (Warn when Saving Tables).  
Press “Yes” to continue: 
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Idealpos returns to a new sale screen ready for the next sale: 
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To use method two (specifying table number after items are added to the sale), follow the below steps: 
From the POS Screen, add the items required to the sale: 
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Once the required items have been added to the sale, enter the Table Number. 
The Table Number entered will appear in the sale screen. If any mistakes are made while entering the Table 
Number, press the “CL” button on the on-screen numeric keypad and try again. 
Once the correct Table Number has been entered, press the “Table Map” button: 
 

 
 
A confirm prompt may be displayed if enabled in Yes/No Options (Warn when Saving Tables).  
Press “Yes” to continue: 
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If Prompt for Covers is enabled, a Covers prompt will appear on the bottom-left corner of the POS screen. 
If Items have already been saved to the entered Table Number, the Covers prompt will not appear. 
Enter the number of Covers, then press “OK” to continue: 
 

 
 
Idealpos returns to a new sale screen ready for the next sale: 
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IP-2679 – Table Details – When splitting by Quantity, display outstanding quantity 

This function displays additional details on the Table Details screen when splitting payments by quantity.  
With this change, Idealpos will display the outstanding or remaining quantity that needs to be paid by the 
Customer. 
This allows the Clerk to inform the customer as to the remaining quantity that is required for payment. 
This function does not need to be enabled nor does it require additional configuration. 
The remaining quantity that requires payment will always be displayed on the Table Details screen when a portion 
of an item has been paid. Note that the outstanding quantity is displayed as a whole number without decimal 
places.  
E.g. If a table contains 5x Bottle of water valued at $1.00 each (total $5.00), should the customer make a 0.50cent 
payment towards the items, the outstanding quantity will reduce to 4 (as decimal places on the outstanding 
quantity are not displayed).  
 
To use this function, go to POS Screen, then order at least 2 qty or more of an item. 
Enter the QTY to be ordered > Press “X” > Select item from the POS Screen 
In this example, we have ordered 5 x Cappuccino: 
 

 
 
Once the items have been entered into the sale, press the “Table Map” button, then select a Table from the Table 
Map to save the sale to a Table. 
 
  



 Update History 
Return to top 

Idealpos 7.1 Build 12 - Update History  Page 30 of 52 

 

If prompted, enter the number of Covers: 
 

 
 
Select the table from the Table Map > Details, or alternatively, double-click on the table from the Table Map to view 
the Items saved to the table. 
Press the “Quantity” button at the bottom of the screen, then enter a Quantity to pay. 
We’ll simply enter a quantity of 1 to pay off a single Cappuccino. 
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Once the Quantity has been entered, select the item from the Table Details screen, then press “Pay” 
 

 
 
  



 Update History 
Return to top 

Idealpos 7.1 Build 12 - Update History  Page 32 of 52 

 

Pay off the item from the Tender screen using the desired tender type. 
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Then return to the Table Map screen via the Table Map button, select the same Table Number as used above, then 
press “Details” to view the details of the Table. 
The outstanding/remaining quantity will appear next to the item as shown in the below example: 
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Stock Purchases 
IP-3550 – Stock Purchases – Ability to Multi-Select items 

This function adds the ability to select and add multiple Stock Items to a Purchase Order via the Purchase Order > 
Stock Items window. 
 
To use this function, go to: Back Office > Transactions > Stock Control > Stock Purchases. 
Either select an existing Stock Purchase > Modify, or press the “Add” button to create a new Purchase Order or 
create a new Stock Receive. 
Select a Supplier from the Supplier field (this step isn’t necessary, however, by enter in a supplier, you can use the 
“Supplier Items Only” option when adding items to the order). 
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Select a Supplier from the list, then press “OK on the bottom-right corner of the window: 
 

 
 
In the Stock Received/Purchase Order, press the dropdown-arrow in the Stock Code field to open the Stock Items 
window. 
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Within the Stock Items window, multiple Stock Items can now be selected. 
The following methods are available for selecting multiple items at once: 
 

• Select All Items – All Stock Items can be selected via the “Select All” button at the bottom of the window. 
This button is useful when used in combination with the “Supplier Items Only” checkbox, which can be used 
to order all items from the selected supplier. This button can also be used when filtering the Stock Items 
screen to Select All Items shown using the current filter. 
 

 
 

• Select multiple individual items – Multiple individual items can be selected by holding down the CTRL 
button on your keyboard and clicking on each Stock Item that is required. The items clicked will be 
highlighted.  
 

 
 

• Select a range of items – A Range of items can be selected all at once. First, click on the first item in the 
range, then hold down the SHIFT button on your keyboard and press the last item. The first and last items 
clicked, as well as any items in between will be selected. 
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To demonstrate this function, we will use the “Supplier Items Only” checkbox together with the “Select All” button 
as per the below example. 
Enable the “Supplier Items Only” checkbox and press “Select All” button to add all items from the supplier to the 
order: 
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Press OK on the bottom-right corner of the window to add the selected items to the order. 
The selected items will now appear in the Purchase Order or Stock Receive: 
 

 
 
The Invoice Number, Invoice Details and any other required details such as Order Date/Process Date/Due Dates can 
be filled out and once done, press the “Save” button on the bottom-right corner of the window to save the 
Purchase Order/Stock Receive.  
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IP-3589 – Stock Purchases – Support for receiving Indirect Items 

This function adds the ability to receive Indirect Items in Idealpos. 
When Indirect Items are added to a Stock Receive or Purchase Order, the Cost price is calculated using the price of 
the “non-indirect item” which the Indirect Item is linked to. 
 
Previous to this change, Indirect Items could be received via the Stock Manage app, however, once the data was 
imported into Idealpos, the Indirect Items would appear in Stock Received as an “Invalid Item”. In addition, if you 
previously tried to enter an Indirect Item Stock Code, it could not be added to the Stock Receive or Purchase Order. 
With the ability to receive Indirect Items in Idealpos being enabled, it is now possible to have those Indirect Items 
successfully appear in Idealpos when they’ve been received via the Stock Manage app. 
If you don’t use the Stock Manage app, you can also add Indirect Items to the Idealpos Stock Receive or Purchase 
Order screens without Stock Manage. 
 
If you want to add indirect items via Stock Manage, you will need to ensure that the “Indirect” option has been 
enabled in the Idealpos POSServer Configuration. 
To do this, go to: Start > Idealpos Solutions > POSServer > POSServer Configuration 
Within the Idealpos POSServer Configuration window, click on the “Stock Manage” option, then press 
“Configuration” as shown in the below example: 
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After selecting “Configuration”, ensure that “Indirect” is enabled as shown in the example below. 
If Indirect is set to “False”, click into the dropdown box and select “True” from the list, then press “OK” to save 
changes. 
 

 
 
You will need to perform a Download Program Data from the Stock Manage app to download the Indirect Items 
into the Stock Item data stored in the app. 
To do this, open the Stock Manage app on your device, then select “Data Control” and press “Download”. 
Note that if you have pending data that is waiting to be uploaded, you may see an “Upload” button instead. 
If required, upload this data, otherwise you may choose the option “Replace existing data”. 
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Once the data has been downloaded to the app, you can now add indirect items to a Stock Receive. 
From the Stock Manage main menu, select “Stock Receive” >  
 

 
 
In the Receive Screen, press “+” 
 

 
 
In the “Details” screen, fill in the fields as required: 
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Press the “+” button on the right-hand side to add items to the Stock Receive: 

 
 
When searching for items, Indirect Items now appear in the search results. 
Select the Indirect Item. In this example, we’ll be selecting “Corona Pack”: 
 

 
 
Enter a quantity and cost (if the pre-populated cost is incorrect), then press “Save” to add the item to the Stock 
Receive: 
 

 
 
The Indirect Item appears in the Stock Receive: 
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Press the “Save” button at the bottom of the Details screen to save the Stock Receive: 
 

 
 
Finally, you can upload the Stock Receive to Idealpos. 
From the Stock Manage main menu, press “Data Control”, then press “Upload”. 
 

 
  



 Update History 
Return to top 

Idealpos 7.1 Build 12 - Update History  Page 44 of 52 

 

Data Uploaded will be displayed; press “OK” to continue: 
 

 
 
From the Idealpos Back-Office, go to: Stock Manage > Process Stock Received: 
 

 
 
“Process Stock Received” will be displayed and will contain the items from the Stock Receive. 
Press “Process” on the bottom-right corner to continue: 
 

 
  



 Update History 
Return to top 

Idealpos 7.1 Build 12 - Update History  Page 45 of 52 

 

The Stock Received window is displayed and the Indirect Item details will also appear. 
Prior to this build of Idealpos, the Item Description would previously show “Invalid Item”, however, this is now 
supported as shown in the below example: 
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In addition to using Stock Manage for adding Indirect Items to a Stock Receive, they can also be added manually to a 
Stock Receive or Purchase Order. 
To do this, go to: Idealpos Back-Office > Transactions > Stock Control > Stock Purchases 
Within the Stock Purchases window, press the “Add” button on the bottom-left corner of the window. 
Fill in the details at the top of the Stock Received/Purchase Order window as required. 
Then press the dropdown box in the “Stock Code” field: 
 

 
 
A list of Stock Items will be displayed. 
In the Stock Items window, you can now search for Stock Items which are Indirect and they will be displayed, making 
it possible to add them to your Stock Receive or Purchase Order. 
Note that Indirect Items will not appear if the “Supplier Items Only” checkbox has been enabled on the bottom-left 
corner of the Stock Items window. 
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Double-clicking on the “Corona Carton” item will add it to the Stock Receive/Purchase Order: 
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Suppliers 
IP-3556 – Supplier Payment Due Date – Option for Specific Day of Month 

This function adds the ability to set the Supplier Payment Due Date to a Specific Day of Month. 
When a Purchase Order is created using a Supplier which has the Payment Due Date set to Specific Day of Month, 
the Payment Due Date will be automatically set to the specified day of the month for the following month. 
E.g. Payment Due Date is set to Day of Month with a value of 15. If a Purchase Order is created on any day in the 
month of January, the Payment Due Date of the Purchase Order will be set to 15th February. 
If the Day of Month entered is greater than the number of days in the following month, the Payment Due Date for 
the Purchase Order will be set to the last day of the following month. E.g. If Payment Due Date is set to 31 Day of 
Month and a Purchase Order is created in the month of January, the Payment Due Date will be set to 28th February 
(common year) or 29th February (leap year). 
 
Access to the original Payment Due Date Days setting is also retained and can continue to be used. The original 
Payment Due Date Days setting will simply add the number of days in the Payment Due Date Days field to the 
current date that the Purchase Order was created. 
 
Please note that the Supplier Payment Due Date is only exported and sent to the Xero Accounting package. 
The Payment Due Date from your Purchase Order will not be sent to any other accounting packages. 
 
To configure and use this function, go to: File > Suppliers > Suppliers 
Select a Supplier from the list, then press the “Modify” button on the bottom-right corner of the window. 
In the Supplier window, set the Payment Due Date to Day of Month and enter the desired Day of Month that you 
want to use for your Supplier Payment Due Date. As mentioned above, when Day of Month is used, the Due Date 
will be set to the entered Day of Month for the next month, meaning that regardless of what date in the month the 
Purchase Order is created, the Due Date will always be set to the Day of Month entered for the next month. 
Press “Save” on the bottom-right corner of the window to save your change and close the Suppliers window. 
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Close the remaining Supplier window, then go to: Transactions > Stock Control > Stock Purchases > Add 
Set the Purchase Type to either Stock Received or Purchase Order depending on which option is required. 
Then in the Supplier field, press the “>” button to open the Supplier list: 
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From the Supplier list, select the Supplier that you set the Payment Due Date to Day of Month, then press “OK” on 
the bottom-right corner of the window. 
The Due Date will be set using the Day of Month setting. 
In the below example, the Purchase Order was created on the 1st September and the Due Date has been set to the 
14th October which is the Day of Month for the month after the current Purchase Order.  
 

 
 
The remainder of the Purchase Order or Stock Received can be completed as per usual. 
For more information about Purchase Orders, click here to visit the Stock Purchases topic in the Idealpos User 
Guide. 
  

https://userguide.idealpos.com.au/#Stock%20Purchases/Stock%20Purchases.htm
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Yes/No Options 
IP-3596 – Yes/No Option – Show Unit Price of Items on POS Screen 

This function adds the ability to control whether or not the Stock Item Unit Price is displayed on the POS Screen 
when an item is added to the sale in the same way as the Unit Price is printed and shown on the Customer Receipt. 
The Unit Price is used to convey the price of each unit and is most beneficial when used with Stock Items which have 
the Non-Accumulating option disabled or when an item is entered using the Quantity button (i.e. multiples of the 
same Stock Item occupy a single sale line on the POS screen). 
By default, this Yes/No option is disabled, however, can be turned on if you require the Unit Price to be displayed 
on the POS Screen. 
An example of the Unit Price being shown on the POS Screen is as follows: 
 

 
 
To configure and use this function, go to: Setup > Yes/No Options.  
Enter Keyword Search: “show unit” and enable “Show Unit Price of Items” 
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Close the Yes/No Options window, then open the POS Screen. 
The Unit Price will appear when adding Stock Items to the sale (either a single item or multiple items). 
However, this option provides the most benefit to the Clerk when accumulating items are added to the sale, or 
when the quantity key is used to enter multiples of the same item. 
 

 
 
Note that the Unit Price displayed does not factor in any discounts which have been applied and will therefore 
show the Unit Price pre-discount. 
However, when using the Amount Override function to enter a Price for the Stock Item, the Unit Price will be 
reflective of the overridden price. 


