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Build  

Update Details: 

** Enhancements 

    * [IP-145] - POS Screen setup - allow stock item buttons to link directly to Grids 

    * [IP-165] - PC-EFTPOS Aus - Support for MOTO transactions 

    * [IP-175] - Promotions screen - filter by Expiry Date 

    * [IP-192] - Paymentree Eftpos support for Pinpad Surcharge 

    * [IP-193] - Stock Item Sales Report - Gross Amount and Discount fields added 

   * [IP-201] - Export 'Tare' value for items that are marked as scale 

    * [IP-203] - Option to Exclude Barcodes during POS Screen Button Programming 

    * [IP-205] - Emailed Customer Invoices include Invoice number in the Filename  

    * [IP-210] - Open Stock Item - option to get Description before the Price 

    * [IP-211] - Yes/No Option - New Customers require entry of Email address 

    * [IP-216] - Stock Valuation Report - support for Attribute Grouping and Filtering 

    * [IP-217] - Stocktake Forms - ability to Group by Attribute 

    * [IP-219] - Stock Item Sales - support for Multiple Attributes in Selection Criteria 

    * [IP-223] - Ability to create Shortcut to Clerks Add/Modify screen 

    * [IP-226] - Stock Item Filter numeric fields support Greater/Less Than (<>) symbols 

    * [IP-228] - Yes/No Option - Fast Customer Modify can modify Credit Limit 

    * [IP-229] - Customer Type Macro functionality 

    * [IP-230] - Clipp Discounts can be linked to Promotion Reports 

    * [IP-239] - Export Stock Items supports Stock Level Total for All Locations 

    * [IP-243] - Export Stock Items supports Department Description and Supplier Name 

   * [IP-249] - Gift Voucher Redemptions Report can be Grouped by POS  

    * [IP-252] - Grid Link removed from Grid "None" function 

    * [IP-255] - Description2 field displays next to Description field in Stock Item List 

    * [IP-256] - Grid File Data available on Grids, Functions, Table Maps and Users screens 

    * [IP-258] - Modified Handshaking between POS and Handhelds 

    * [IP-266] - Customer Name and Type on POS Screen - small font is blurry 

    * [IP-282] - Dynamic Search Delay support for Stock Item field search fields 

    * [IP-283] - Customer Account Transactions Report - Grouped by Location 

    * [IP-285] - Financial Summary Report - added Tender Banking figures 

 

 

 

  



Reports 

Stock Item Sales Report - Gross Amount and Discount fields added 

This report now includes additional fields for each item to show more information.  
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Gift Voucher Redemptions Report can be Grouped by POS 

This feature allows you to group only Gift Voucher Redemptions by POS terminal.  

 

Go to Reports > Sales > Gift Voucher Report > Gift Voucher Redemptions > Tick: Group by POS.  

 

 
 

 
 

  



Stock Item Sales - support for Multiple Attributes in Selection Criteria 

There is a new field on the Stock Item Sales Report which allows you to filter the report to include or exclude 

Attributes.  

 

Go to Reports > Sales > Stock Item Sales Report > Selection Range > Attributes.  

 

 
 

Select the Attribute Type and the corresponding Attribute and press the + to add them to the report. The Attribute will 

be added to the box below, and you can select more.  
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Select on the left to Show or Exclude these attributes from the report and press View.  

 

 
 

  



Stock Valuation Report - support for Attribute Grouping and Filtering 

There is a new field on the Stock Valuation report which allows you to filter the report to include or exclude Attributes.  

 

Go to Reports > Stock Control > Stock Valuation > Selection Range > Attributes.  

 

 
 

Select the Attribute Type and the corresponding Attribute and press the + to add them to the report. The Attribute will 

be added to the box below, and you can select more.  

 

 
 

 
 

Only the items linked to the attributes will display, or be excluded.  
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Customer Account Transactions Report - Grouped by Location 

This report allows you to see the Customer Account Transactions by Location. You cannot view the report grouped by 

Customer and Location. To view the report by Location, untick the Group by Customer option.  

 

Go to Reports > Customers > Customer Account Transactions > Group by: untick Customer.  

 

 
 

 
 

  



Financial Summary Report - added Tender Banking figures 

This report now has the ability to view the Tenders with all grouping options.  

 

Go to Reports > Financial > Financial Summary Report > Report Options > Tender (1-18).  
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Back Office 

Ability to create Shortcut to Clerks Add/Modify screen 

The Clerks can now be selected to be added as a shortcut to the Dashboard to quickly access them for adding/editing 

Clerks.  

 

Go to Setup > Clerks > “S” create shortcut.  

 

 
 

Clerks will be added to the list of available shortcuts.  

 

 
 

  



Grid File Data available on Grids, Functions, Table Maps and Users screens 

The additional screens are all now able to print the grid data that is displayed. To view the data go to any of the 

screens and press the eye icon. From there you can print the details.  
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Stock Items 

Stock Item Filter numeric fields support Greater/Less Than (<>) symbols 

This feature allows you to search for items in the Stock List that are Greater/Less Than using the (<>) symbols to 

narrow down the items you are looking for. It will only work for fields that are numerical such as Price, Cost, Points, 

and Stock Level etc. Multiple fields can be used at the same time with this filtering.  

 

Go to File > Stock Control > Stock Items.  

 

 
 

Description 2 field displays next to Description field in Stock Item List 

The Description 2 field has been moved to display next to Description on the Stock Item List. It does not need to 

display and can be toggled on/off in User Permissions. In User Permissions it is now located directly after Description 

and is a permanent change.  

 

Go to File > Stock Control > Stock Items.  

 

 
 

Go to Setup > Users > select User > File Fields > Stock Items.  

 

 
 

  



Dynamic Search Delay support for Stock Item field search fields 

This feature slows down the searching so that more characters can be entered before searching starts. In large 

databases with a lot of stock items, you want to be able to type a few characters before searching starts, otherwise it 

can cause your system to lag just a little while it re-displays all the matching products. This function has now been 

added to include the search boxes located at the top of each Stock Item field in the Stock List.  

 

 
 

Go to Setup > Global Options > General > General > Dynamic Search Delay > Enter a value in milliseconds. The value 

is 50 by default, but for larger databases we would recommend 200.  
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Customers  

Customer Type Macro functionality 

This function is used to trigger a macro whenever a customer linked to this Customer Type is added to the sale.  

 

Go to File > Customers > Customer Types > Add/Modify > Macro > enter the macro that you have created. You may 

need to create a keyboard program to use all the features you want.  

 

 
 

  



In our example, every time a customer linked to Members is linked to the sale, 10 raffle tickets will be printed.  

 

 
 

 

  



 Update History 
 

Emailed Customer Invoices include Invoice number in the Filename 

Go to Reports > Customers > Customer Invoices > Selection Range > Code: enter the range of codes required > press 

Email at the bottom of the page.  

 

 
 

The .pdf file attached to the email will be named “Customer Invoice x-y.pdf” where x is the Invoice Number and y is the 

POS Terminal code.  

 

 
 

If you have the Yes/No Option selected (Automatically Email Customer Invoices) and there is an email address linked 

to the customer, the email will send the invoice straight away at the end of the sale processing.  

 

 
 



EFTPOS 

PC-Eftpos Aus - Support for MOTO transactions 

Go to Setup > Functions > Tender (select a spare Tender) > Desc: MOTO > EFTPOS: tick.   

 

 
 

Go to Setup > Yes/No Options > Tenders > Ensure MOTO is not inhibited.  
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Process a sale and press the MOTO tender.  

 

 
 

  



Export Data 

Export 'Tare' value for items that are marked as scale 

The Tare figure has always been exported under a different heading, but has now been renamed to make it easier to 

use. This can be used if you need to check the data for NMI audit purposes.  

 

Go to Utilities > Export Data > Stock Items > Export: All Items > Options: Select Export Folder and Filename.  

 

 
 

The Tare field should be located at position CF. You can delete any unnecessary columns to more easily view the data 

you wish to use.  
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Export Stock Items supports Stock Level Total for All Locations 

This function allows you to export the Stock Level Total for All Locations using the Specific Fields by Range option 

only.  

 

Go to Utilities > Export Data > Stock Items > Export: Specific Fields by Range > Export Specific Fields by Range: Stock 

Level Total.  

 

 
 

 
 

  



Export Stock Items supports Department Description and Supplier Name 

This option allows the Department Description and Supplier Name to be exported alongside fields such as Department 

(Code) and Supplier (Code). These options are available only when using the Specific Fields by Range option.  

 

Go to Utilities > Export Data > Stock Items > Export: Specific Fields by Range > Export Specific Fields by Range: 

SUPPLIER NAME, DPT DESCRIPTION.  

 

 
 

 
 

  



 Update History 
 

Yes/No Options 

Yes/No Option - New Customers require entry of Email address 

When a new customer is added, this option forces the user to enter an Email address.  

 

Go to Setup > Yes/No Options > Customers > New Customers Require Email Address.   

 

 
 

Attempting to save a customer without an email address will display the following message.  

 

 
 

Customer imports will not require an email address to be entered, only customers entered through the POS screen will 

be forced.  

 

Open Stock Item - option to get Description before the Price 

Open Stock Items ask for the Description before the Price.   

 

Go to Setup > Yes/No Options > POS Screen > Open Stock Items get Description First.  

 

 
 

  



Yes/No Option - Fast Customer Modify can modify Credit Limit 

When modifying a Customer through the Fast Customer screen, this option allows the Credit Limit to be modified. Any 

Customer Type that has a credit limit (Bar Tabs, Accounts) can be affected by this selection.  

 

Go to Setup > Yes/No Options > Customers > Fast Customer Modify can modify Credit Limit.  

 

 
 

Go to POS > Customer > When you edit a Customer and this option is selected, the Credit Limit field will be visible.  
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POS Screen Setup 

Option to Exclude Barcodes during POS Screen Button Programming 

A new option has been added to the drop-down menu on the POS Screen Setup to Exclude Barcodes. Items that do 

not contain a barcode will not display in the list, as they do not need a button made for them.  

 

Go to Setup > POS Screen Setup > POS Screen > Layouts > Buttons > drop-down.  

 

 
 

  



Grid Link removed from Grid "None" function 

This function has been updated so that when copying grids, buttons do not have to be re-programmed with the Grid 

Link for the new grid. This will allow for faster programming of the POS Screen.  
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POS Screen setup - allow stock item buttons to link directly to Grids 

This allows Stock Items that are programmed on the POS Screen Tabs to link directly to a grid. This makes it easier to 

configure rather than having to go into the Stock Item programming and link it through there.  

 

Go to Setup > POS Screen > POS Screen Setup > Layouts > Buttons > Stock Item Button > POS Screen Grid.  

 

 
 

  



Stocktake 

Stocktake Forms - ability to Group by Attribute 

This option allows you to group the Stocktake forms and print them out by Attribute. You are able to use Department 

or Supplier in conjunction with the Attribute grouping.  

 

Go to Stocktake > Stocktake Forms > Group By > Attribute: Select from the drop-down menu.  
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Promotions 

Promotions screen - filter by Expiry Date 

This feature allows you to filter your promotions by the expiry date. A drop-down menu is available at the top of the 

screen where you can choose from This Week, Next Week, This Month, Next Month and This Year. When selected, only 

those promotions within that selection will display. This field can be used in conjunction with all other fields.  

 

Go to File > Sales > Promotions > Promotions > Expiring.  

 

 
 

 
 

 
 

 
 

 
 

  



Clipp Interface 

Clipp Discounts can be linked to Promotion Reports 

When you are running promotions through the Clipp app, they will be recorded and processed through Clipp, and the 

discounts reported on the Promotions Report.  

 

Go to your Clipp Admin Portal > Select Venue > Setup Promotions.  
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When a Customer opens a tab and is linked to one of the promotions, their tab will open and display on Idealpos 

through Clipp Tab Enquiry. If the Customer opens a tab for $50 and receives a Corporate Discount of 25%, the Clipp 

tab in Idealpos will show a total of $66.67.  

 

 
 

Where x is the total able to spend in Idealpos, y is the tab amount and z is the discount amount.  

 

𝒙 = 𝒚/(𝟏 − 𝒛) 

 

𝟔𝟔. 𝟔𝟕 = 𝟓𝟎/(𝟏 − 𝟎. 𝟐𝟓) 

 

Go to File > Stock Control > Stock Items > Add > Create a Stock Item for the Discount to be allocated to so the Sales 

Reports match the Financial Reports, or all discounts will be allocated to the first Stock Item in the database.  

 

 
 

  



Go to File > Sales > Promotions > Promotion Groups > CLIPP is added automatically when a Promotion has been 

triggered.  

 

 
 

Go to File > Sales > Promotions > Promotions > Any Promotions used from Clipp will be created.  
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Go to Reports > Sales > Promotions > Report Type: Promotion Summary by Type.  

 

 
 

 
 


