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Back Office 

IP-5931 – POS Options – Ability to adjust UI components of File Grids 

This function introduces the ability to adjust the User Interface components of File Grids. 

The customisation options that are now available include selecting the type of grey that’s used to colour the 

alternating rows (Very Light Grey, Light Grey or Grey) and configuring the Grid Row Height and Grid Font Size. 

These options are configurable at the POS Terminal level, meaning that each POS Terminal can have a unique set of 

options as required at each POS Terminal.  

The customisations that are configured will apply wherever the File Grids component is used throughout the entire 

Idealpos User Interface.  

The below is a list of just some windows in Idealpos that will use these customisable settings: 

• Locations (File > Stock Control > Locations) 

• Stock Items Grid (File > Stock Control > Stock Items) 

• Write-Off Categories (File > Stock Control > Write-Off Categories) 

• Promotions (File > Sales > Promotions > Promotions) 

• Customer Enquiry (Enquiry > Customers) 

• Journal History (Enquiry > Journal History) 

• Stock Purchases (Transactions > Stock Control > Stock Purchases) 

 

And many more. 

 

To configure this function, go to: Back Office > Setup > POS Terminals > Select the POS Terminal > Modify. 

(The POS Terminal that’s selected will be POS Terminal that the customisations will be applied to). 

Select the POS Settings tab, then within the User-Interface section on the bottom-right corner of the window, 

configure the following options as required: 

 

Note – When configuring the Grid Font Size/Grid Row Height, setting values that are too large will affect the User 

Interface as well as the readability of text in the User Interface (e.g. displaying text in a larger font size will prevent the 

entire Stock Item Descriptions from viewable on each row as they will be too large). Trial and error may be required by 

setting the desired values, test the change to see if it is suitable and if not, then continue adjusting these settings until 

the desired appearance has been attained. 
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Grid Font Size – This is the size of the font used to display each row entry in the grid. 

Grid Row Height – This is the height of the rows in the grid. 

Alternating Row Colour – This is the colour of the alternating row (options available are Very Light Grey, Light Grey 

and Grey). 

Restore Defaults – This button can be pressed to restore the default settings. 
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To demonstrate and illustrate this functionality, these options have been customised and example screenshots of the 

Stock Items grid (File > Stock Control > Stock Items) have been included below to show how the changes affect the 

User Interface. 

 

Default Settings: 

 

 
 

Alternating Row Colour set to Light Grey: 
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Alternating Row Colour set to Grey: 

 

 
 

Large Grid Font Size and Grid Row Height: 
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IP-5993 – Activity Log Search Functionality 

This function introduces the ability to search through the Activity Log via a new Search field. 

This can be used in cases where any instances of a specific record in the Activity Log need to be found. 

The search function includes the ability to enter a search term into a search field as well as a find next and find 

previous button to cycle through each record that matches the entered search term. 

 

To use this function, go to: Back Office > Enquiry > Activity Log. 

In the Search field, enter the desired Search term and press the on-screen down arrow to find next. 

The on-screen down arrow can be pressed repeatedly until the desired record is located. 

When Idealpos finds a record that matches the entered search term, the record will be highlighted in blue. 

The on-screen up arrow can also be pressed to go to the previously found record. 

The Search function can also be used in combination with the options listed in the Selection Criteria. 

 

 
  



 Update History 
Return to top 

Idealpos 8 Build 17 - Update History Page 7 of 36 

 

Enter a search term into the Search field and press the on-screen down arrow.  

The first record that matches the entered search term will be highlighted in the Activity Log.  

 

 
 

 

The on-screen up/down arrows can be used repeatedly to cycle through the next and previous instances of the search 

term that have been found. 
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Bills/Receipts 

IP-6106 – Bills/Receipts – Option to Group by Sales Category 

This function introduces the ability to configure Bills/Receipts so that Stock Items are grouped by their Sales Category. 

To configure this function, go to: Back Office > Setup > Global Options > Printing. 

Within the Print Group Header Format – Receipts/Bills section, enable the “Group by Sales Category” option. 

If Group by Sales Category is required on the Bill, ensure that the Bill Format is set to “Order by Print Group” or “Order 

by Print Group/Seat”. 

 

 
 

Close the Global Options to save the change. 
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When the “Group by Sales Category” option is disabled, the Customer Receipt will group by Print Group. 

 

 
 

When the “Group by Sales Category” option is enabled, the Customer Receipt will group by Sales Category. 
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Customers 

IP-5548 – Customer Enquiry – Filter Customers by Sales on POS/Location 

This function introduces the ability to filter Customers by Sales that took place at the POS Terminals and/or Locations 

that are specified in the Selection Criteria within the Customer Enquiry window. 

 

To use this function, go to: Back Office > Enquiry > Customers. 

On the bottom-right corner of the Customer Enquiry window, enter the POS Terminal and/or Locations to filter the 

Customer Enquiry window. The “>” button within each field can be used to display a list of POS Terminals or Locations 

to select from a list. When entering values into the POS or Location fields, they can be entered as a comma separated 

list (e.g. 1, 2, 3) or as a range (e.g. 1-3). 
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After entering values into the POS and/or Location fields, press the “Apply Filter” button to filter the list of Customers 

displayed. 

The window will only display Customers that were included in a sale that was performed at either the POS Terminals 

and/or Locations that were specified. 
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IP-5852 – Customers – Ability to Set Points Limit 

This function introduces the ability to set a Points Limit on each customer. 
When a Points Limit has been set for a Customer, they will be unable to earn points beyond the Points Limit that has 
been set within their customer record. 
 
To configure this function, go to: Back Office > File > Customers > Customers. 
Select a Customer from the list > Modify. 
In the Points Limit field, enter a limit > Press “Save” on the top-left corner of the window. 
Note that if a Points Limit is entered that is less than the Customer’s currently accrued points balance, the Customer 
will retain their currently accrued points balance and they will not accrue additional points on future purchases.  
 

 
 
The Customer’s Points Balance will stop accruing once the Points Limit has been reached. 
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Import Data 

IP-5579 – Promotions Import – Support for Departments 

This function introduces the ability to Import Promotions that include Departments in the Trip Condition Sets when 

using the Promotions Import function. Prior to this enhancement, only Stock Items could be included in the Trip 

Condition sets when Promotions were added via a Promotion Import file. 

 

Two examples of this are creating a Promotion via a Promotion Import File that will be tripped:  

• When a customer spends $10.00 on items from Department XYZ, or  

• When a customer purchases a specific number of items from Department XYZ. 

 

To use this function, first, create a Promotion Import File. 

A Department is specified in the Promotion Import File via a “DPT” header, with the Department Code being placed 

within the DPT field of the Import File. 

E.g. Using the Idealpos Demo Database, create a Promotion that will be tripped when 5 items from the Coffee 

Department (Department Code 202) are purchased. When tripped, the promotion will trigger a sell price of $2.00 for 

each Coffee Item purchased. 
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The below is a Promotion File to demonstrate the above example (this can be created as a TXT file). 

Note that when a Trip Condition Set (TRIP_GROUP) is not specified, all the items and/or Departments will be added to 

the Trip Condition Set 1 by default. 

 

ZONE,DESCRIPTION,TRIP_QUANTITY,PROMO_PRICE,START_DATE,END_DATE,DPT 

1,Coffee Promo,5,2,1-Nov-23,1-Jan-24,202 

 

To import the Promotion, go to: Back Office > File > Sales > Promotions > Promotions > press “Import” on the left-

hand side > Browse to the folder location that contains the import file > Open. 

The Promotion will be imported and will appear as follows: 

 

 
 

When 5x Coffee Items are purchased, they will be sold at the Promotion Price of $2.00 each. 
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To specify multiple Departments in the Trip Condition Set, simply copy the line in the Promotion Import file and 

modify the Department Code on the copied line to match the Department that needs to be included in the Trip 

Condition Set. 

 

ZONE,DESCRIPTION,TRIP_QUANTITY,PROMO_PRICE,START_DATE,END_DATE,DPT 

1,Coffee and Tea Promo,5,2,1-Nov-23,1-Jan-24,201 

1,Coffee and Tea Promo,5,2,1-Nov-23,1-Jan-24,202 
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It is also possible to create a Promotion that uses all three Trip Condition Sets. 

The below is an example demonstrating this: 

 

ZONE,DESCRIPTION,TRIP_QUANTITY,PROMO_PRICE,START_DATE,END_DATE,DPT,TRIP_GROUP 

1,Tea Coffee and Water Promo,5,2,1-Nov-23,1-Jan-24,201,1 

1,Tea Coffee and Water Promo,5,2,1-Nov-23,1-Jan-24,202,2 

1,Tea Coffee and Water Promo,5,2,1-Nov-23,1-Jan-24,204,3 
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Here is one last example showing that it is possible to combine Trip Quantity and Trip Amount in the one Promotion 

as well as having multiple Departments in each Trip Condition Set. 

 

ZONE,DESCRIPTION,TRIP_QUANTITY,TRIP_AMOUNT,PROMO_PRICE,START_DATE,END_DATE,DPT,TRIP_GROUP 

1,Mega Promo,3,,5,1-Jan-21,30-Jun-24,101,1 

1,Mega Promo,3,,5,1-Jan-21,30-Jun-24,103,1 

1,Mega Promo,3,,5,1-Jan-21,30-Jun-24,106,1 

1,Mega Promo,,2.50,5,1-Jan-21,30-Jun-24,107,2 

1,Mega Promo,,2.50,5,1-Jan-21,30-Jun-24,108,2 

1,Mega Promo,,2.50,5,1-Jan-21,30-Jun-24,109,2 

1,Mega Promo,3,,5,1-Jan-21,30-Jun-24,111,3 

1,Mega Promo,3,,5,1-Jan-21,30-Jun-24,112,3 

1,Mega Promo,3,,5,1-Jan-21,30-Jun-24,113,3 
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Kiosk 

IP-6058 – Kiosk – Option for Order Number Prompt 

This function introduces the ability to display an Order Number Prompt on the Kiosk which will prompt the customer 

to enter an Order Number. 

The Kiosk supports an Order Number with a maximum length of 10 digits; after an Order Number is entered, it will 

display at the top of the Kiosk screen and will be printed on the Kitchen Docket/Customer Receipt. 

The Order Number can be something that can be used to identify the Customer that placed the Order (such as the 

Customer’s Mobile Phone Number or any other number that the venue may want to use to identify the customer by). 

 

To configure and use this function, go to: Back Office > Setup > POS Terminals > Select the Kiosk Terminal > Modify. 

Within the Display/Kiosk tab, enable the “Order Number Prompt” option. 

This will trigger the Order Number prompt to appear on the Kiosk when a customer starts placing their order. 

If the customer skips the Order Number Prompt by either pressing “OK” or the “X” button on the top-right corner 

without entering a number, they will be prompted to enter an Order Number again at a later stage when proceeding 

to make the payment for the order. 
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After enabling the “Order Number Prompt” option, close the POS Terminals configuration window, then restart the 

Kiosk terminal. 

After the Kiosk starts, the Kiosk will display the Home Screen Image (an image that welcomes the customer to the 

Kiosk and typically shows a message “Touch to start” or similar). 

After pressing the screen on the Kiosk, the “Enter Order Number” prompt will be displayed. 

Entering an Order Number and pressing the “OK” button will trigger the entered Order Number to appear at the top 

of the Kiosk. The Kitchen Docket(s)/Customer Receipt will also show the entered Order Number. 

If the Order Number needs to be changed after it has been entered, press the Order Number at the top of the Kiosk 

screen and it will display the Enter Order Number prompt again; re-enter the correct Order Number and press OK. 

 

 

   
 

After pressing the screen on the Kiosk, the “Enter Order Number” prompt will be displayed. 

Entering an Order Number and pressing the “OK” button will trigger the entered Order Number to appear at the top 

of the Kiosk. The Kitchen Docket/Customer Receipt will also show the entered Order Number. 
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POS 

IP-6108 – Default Sale Type Option by POS Terminal 

This function enables the ability to set a Default Sale Type for each POS Terminal that will apply for all sales performed 

at the POS Terminal. When this function is configured, the Default Sale Type can temporarily be disabled for the 

current sale (if required) or a different Sale Type can be selected via a Sale Type POS Screen button which will override 

the Default Sale Type for the sale.  

When the next sale commences, the Default Sale Type will automatically apply. 

 

To configure and use this function, go to: Back Office > Setup > Global Options > Sales. 

Ensure that the required Sale Type Statuses are configured as required. 

If required, create additional Sale Type Statuses as required. 

Take note of the slot numbers for Sale Types which will be set as Default Sale Types on the POS Terminals, with the 

first Sale Type slot at the top of the list being “1” and the last Sale Type slot at the bottom of the list being “9”.  

E.g. In the screenshot below, Takeaway is in slot 1, Delivery is in slot 2, Pickup is in slot 3, Cater is in slot 4, so the 

corresponding slot number will need to be entered in the next step when configuring the Default Sale Type for each 

POS Terminal that will have a Default Sale Type configured. 
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Go to Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Miscellaneous Settings. 

In the “Default Sale Type” field, enter the Sale Type slot number that corresponds to the Sale Type that will be used as 

the Default. 

For this example, we’ll enter 1, which corresponds to the first Sale Type “Takeaway” in the Global Options. 

 

  
 

After the desired Default Sale Type has been configured for the POS Terminal, close the POS Terminal configuration 

window and if required, configure any remaining POS Terminals that also require a Default Sale Type. 
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When the POS Screen is displayed on the POS Terminals that have a Default Sale Type configured, the Default Sale 

Type will be displayed at the top of the POS Screen, which indicates that the Sale Type will apply to that sale. 

If the Sale Type is not required, press the Sale Type at the top of the POS Screen to clear it from the current sale. 

 

 
 

When a Kitchen Docket is printed, the Sale Type will be displayed (example shown below-left). 

If the Sale Type is also required on the Customer’s Receipt, this can be enabled via the Yes/No Option “Show Sale Type 

on Receipt” (go to Back Office > Setup > Yes/No Options > Search “Sale Type” > Enable “Show Sale Type on Receipt”). 

The Customer Receipt will show the Sale Type as per the below-right example.  
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Promotions 

IP-4427 – Points Multiplier – Use Promotions to increase Points Multiplication Factor 

This function introduces the ability to use promotions to increase the Points Multiplication Factor (e.g. when a 

customer trips the Points Multiplication Factor promotion, they will earn points at the Points Multiplication Factor 

that’s set within the Promotion for the entire sale). 

 

To use this functionality, go to: Back Office > File > Sales > Promotions > Promotions. 

Create a new Promotion or modify an existing Promotion. 

In the Discount Type dropdown box, select “Point Multiplication Factor”.  

Enter the Point Multiplication Factor to use next to the dropdown box. 

Configure the remaining fields required to trip the promotion such as the Description, Date Range and Trip Condition 

Set(s) as required (add the Items/Departments and select the Trip by Quantity/Trip by Amount and specify the 

required quantity/amount to trip the promotion). 

 

 
 

When a customer is added to a sale and the Promotion is tripped, the customer will earn points using the Point 

Multiplication Factor that has been set within the promotion. 

Note that when the promotion is tripped, the Point Multiplication Factor will be applied to the entire sale.  
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Reports 

IP-3918 – Stock Valuation Report – Support for Department/Location Ranges 

This function introduces the ability to specify Department and Location Ranges when running the Stock Valuation 

Report. 

Prior to this change, the Department and Location Ranges only allowed values to be selected in the From and To 

fields, which would include all Departments and/or Locations that were included between the range in the From/To 

fields. 

This change has replaced the individual Department/Location From/To fields with a single field for these options. 

Having a single field will enable the entry of one or more ranges in each field, enabling specific Departments or 

Locations to be excluded from the report, as well as the ability to enter a list of specific Departments or Locations as a 

comma separated list (e.g. 1, 2, 3) or a range (e.g. 1-3), or a mixture of two methods to exclude specific values (e.g. 1-2, 

4-5). 

 

To use this function, go to: Back Office > Reports > Stock Control > Stock Valuation. 

The Department and Location fields are now a single field instead of separate From/To fields. 

Enter a Department range into the Department Field and enter a Location Range into the Location field. 

Press the “View” button on the top-left corner to run the Stock Valuation Report. 
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The report will run using the values entered in the Selection Range for the Department and/or Location fields. 

The specified Selection Range will also be displayed at the top of the Stock Valuation Report. 
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IP-5763 – Stock Item Sales Report – Option to show Supplier Stock Code 

This function introduces the ability to show Supplier Stock Codes on the Stock Item Sales Report. 
When enabling the option “Show Supplier Stock Code”, the column in the report that typically displays the Stock 
Code will instead display the Supplier Stock Code (due to the limited amount of space available on the report). 
 
To use this function, go to: Back Office > Reports > Sales > Stock Item Sales. 
Toggle the option “Show Supplier Stock Codes” on or off as required. 
As mentioned above, when the option is unchecked, the Stock Item Code will be displayed and when the option is 
checked, the Supplier Stock Code will be displayed instead. 
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The Stock Item Sales Report with the “Show Supplier Stock Codes” disabled/unchecked: 
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The Stock Item Sales Report with the “Show Supplier Stock Codes” enabled/checked: 
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IP-6052 – Shortcut Reports – Ability to Edit/Copy existing Shortcut 

This function introduces the ability to Edit/Copy existing Shortcuts that have been created for Reports. 

This may be useful when the Selection Criteria that was originally used to create a Shortcut needs to be altered so that 

the Shortcut displays the desired data. 

 

To use this function, go to:  

Back Office > Right-click on a report Shortcut on the left-hand side > Select “Edit Shortcut”.  
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The Report window will open where the “S” shortcut button will appear as red on the top-right corner, which indicates 

that the Shortcut is being modified. 
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Make the required changes to the report (e.g. change the Date Range or any other required Selection Criteria). 

Once the changes have been made as required, press the red “S” shortcut button on the top-right corner. 
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A window will appear where the Shortcut Name and Shortcut Group fields will be displayed. 

By default, the values in these fields will be pre-populated using the details of the Shortcut that is currently being 

modified. After the “Save” button is pressed, the Shortcut will be updated or copied as per the behaviour outlined 

below: 

• If the same Shortcut Name is used, the Shortcut will be updated with the modified Selection Criteria. 

• If a different Shortcut Name is entered, the existing Shortcut will be retained, and a new Shortcut will be 

created with the current Selection Criteria. 

 

 
 

In this example, we have modified the Date Range to “All Dates”, so we will enter “Financial Report All Dates”; this will 

create a new Shortcut called “Financial Report All Dates” with the current Selection Criteria, and the “Financial Report 

Daily” Shortcut will also remain in place. 

Press the “Save” button to save the Shortcut. 
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After pressing the “Save” button, close the Report window to return to the Back Office Dashboard. 

The newly created report will appear within the Shortcut Group that was selected when the Shortcut was saved. 

 

 
 

Running the Report via the newly created Shortcut will use the Selection Criteria that was entered when the Shortcut 

was modified/saved. 
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Suppliers 

IP-3650 – Suppliers – Support for Notes field 

This function introduces a new Notes field for each Supplier record that exists in Idealpos. 

The Notes field can be used to store information about the Supplier, any specific instructions relating to placing orders 

with the Supplier or any other notes that are required when interacting or ordering from the Supplier. 

 

To use this function, go to: Back Office > File > Suppliers > Suppliers. 

Select a Supplier > Modify or create a new Supplier. 

In the Notes field, enter any required notes for the Supplier > Save. 
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The Supplier Notes can be viewed by either:  

• Modifying the Supplier via Back Office > File > Suppliers > Suppliers > Select Supplier > Modify. 

 

 
 

• Via the Supplier Listing – Go to: Back Office > Listings > Suppliers > Suppliers. 
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Yes/No Options 

IP-6044 – Yes/No Option – Adding new Promotions default to local Site 

This function introduces the ability to automatically populate the Site field with the local Site when creating new 

Promotions. 

 

To configure this function, go to: Back Office > Setup > Yes/No Options. 

Search: Adding new Promo 

Enable the Yes/No Option “Adding new Promotions default to local Site” 

 

 
 

Close the Yes/No Options. 

 

Go to: Back Office > File > Sales > Promotions > Promotions. 

Press the “Add” button on the left-hand side of the window. 

The Site field will be automatically populated with the local Site code. 

 

 
 


