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Coupon Promotions 

IP-7024 – Coupon Promotions – External Description Field 

This function introduces the ability to configure Coupon Promotions using an External Description field. 

The External Description field is used to link Coupon Promotions in Idealpos to external coupon integrations so that 

the coupon is triggered correctly during a sale. 

E.g. Talkbox for Idealpos Engage requires an exact alphanumeric case sensitive match of the coupon name configured 

in Talkbox to the coupon name configured in Idealpos.  

The coupon names that are used in Talkbox aren’t the desired coupon name that the store wants to use for the 

coupon in Idealpos. 

Therefore, the new “External Description” field can be used to link the Idealpos Coupon Promotion to the Talkbox 

Coupon via the External Description field. 

 

To use this functionality, go to: 

Back Office > File > Sales > Promotions > Coupon Promotions. 

Modify an existing Coupon Promotion or create a new Coupon Promotion. 

When modifying or creating a new Coupon Promotion that needs to be linked to an External Coupon Integration, click 

on the “Advanced” tab. 

Within the External Description field, enter the Description of the Coupon Promotion as it appears in the External 

Coupon Integration, then save the Coupon Promotion. 

The Coupon Promotion should now trigger during a sale via the External Coupon Integration. 

E.g. Scan or enter the External Coupon into the sale using the External Coupon Integration and the Coupon will trigger. 
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EFTPOS 

IP-7058 – Secondary Integrated EFTPOS Support 

This function introduces the ability to configure Idealpos with a Secondary EFTPOS Type. 

This enables two EFTPOS Integrations to be configured on the same POS Terminal. 

Note that this functionality has been implemented primarily for sites that have a main Integrated EFTPOS Type that 

does not support specialised cards (such as WEX Fuel Cards). 

Due to the number of EFTPOS Integrations supported, every possible combination of EFTPOS Integration configured 

as Main/Secondary EFTPOS Types has not been tested. 

The Main/Secondary EFTPOS Type functionality has been tested with Linkly, Oolio Pay Global, Wex/Quest. 

Therefore, if this functionality is required for other EFTPOS Integrations that are not listed above, we recommend that 

the two required EFTPOS Integrations are configured and tested on a test environment prior to configuring and using 

on a production environment. 

 

To configure and use this functionality, go to: 

Back Office > Setup > POS Terminals > Select POS Terminal > Modify > EFTPOS Settings. 

Ensure that the “Disable” checkbox is unchecked (this checkbox enables EFTPOS and is not specific to the Main or 

Secondary EFTPOS Type). 

Configuring the Main EFTPOS Type 

Select “Main EFTPOS Type” from the first dropdown box. 

From the second dropdown box, select the EFTPOS Integration that will be used as the Main EFTPOS Type. 

Configure the EFTPOS Integration as per the instructions outlined in that EFTPOS Type’s respective topic in the User 

Guide. 

Go to Back Office > Setup > Function Descriptors > Select the next unused Tender Type > Modify. 

Enter a Description for the Tender and ensure that the EFTPOS checkbox is enabled > Save the Function Descriptor. 

Go to: Back Office > Setup > yes/No Options > Tenders > Untick the checkbox next to “Inhibit [Tender Description]” 

for the Tender Type. 
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Configuring the Secondary EFTPOS Type 
Select “Secondary EFTPOS Type” from the first dropdown box. 
From the second dropdown box, select the EFTPOS Integration that will be used as the Secondary EFTPOS Type. 
From the third dropdown box (Secondary EFTPOS Tender), select the Function Descriptor/Tender Type that will be 
linked to the Secondary EFTPOS Type. 
Note that this Tender Type will also need to have the “EFTPOS” checkbox enabled (go to: Back Office > Setup > 
Function Descriptors > Modify the Tender used for the Secondary EFTPOS Type > Ensure that the “EFTPOS” checkbox 
is enabled). 
Ensure that the Tender Type used for the Secondary EFTPOS Type is enabled on the POS Screen (Back Office > Setup 
> Yes/No Options > Tenders > Untick the checkbox next to the “Inhibit [Tender Description]” for the Tender Type. 
Configure the EFTPOS Integration as per the instructions outlined in that EFTPOS Type’s respective topic in the User 
Guide. 
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The Secondary EFTPOS Type is supported for the EFTPOS Functions, EFTPOS RePrint and EFTPOS Settlement POS 
Screen buttons. When configuring these buttons/functions on the POS Screen, enable the “Secondary EFTPOS Type” 
checkbox. Note that these functions may not be supported by every EFTPOS Integration. 
To configure these buttons, go to:  
Back Office > Setup > POS Screen > POS Screen Setup > Select Layout > Buttons > Select POS Screen Tab > Select 
blank/unused button and link to the following functions: 
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IP-7091 – Oolio Pay Verifone – Support for MOTO transactions 

This function introduces the ability to perform MOTO transactions with the Oolio Pay Verifone EFTPOS Integration. 

A MOTO transaction (Mail Order/Telephone Order) is a transaction where the customer’s card is not present during 

the transaction. 

The transaction is completed by pressing a MOTO Tender button on the POS Screen. 

The pinpad then displays prompts for the clerk to manually input the credit card details into the pinpad. 

After entering the details, the pinpad processes the payment and if successful, the sale is finalised and money 

deducted from the customer’s card. 

As implied by the MOTO acronym (Mail Order/Telephone Order), this transaction type is used for mail orders or 

telephone orders when the customer’s card is not physically present at the time the transaction is being 

processed/tendered. 

 

To configure this functionality, go to: 

Back Office > Setup > Function Descriptors > Locate the next available unused Tender and modify it. 

Unused tenders are named “Tender #”, where # corresponds to the number of the unused tender. 

Configure the tender as follows, ensuring that the “Save” button is pressed after configuring the Function:  

Description: MOTO 

EFTPOS: Enable checkbox 
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The MOTO Tender will need to be enabled on the POS Screen. 

Go to: Back Office > Setup > Yes/No Options > Tenders. 

Ensure that “Inhibit MOTO” is unchecked. 

This will enable the MOTO Tender Type to appear on the Tender screen of the POS. 

 

  
 

Close the Yes/No Options. 

The MOTO Tender will now appear as a Tender on the POS Screen when tendering a sale. 

Add items to a sale and press the ENTER button to go to the Tender screen. 

Select the MOTO Tender Type 
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The POS Screen will display “EFTPOS Communications… Finalize on Pinpad” with the sale amount. 

 

 
 

Complete the prompts on the Oolio Pay Verifone pinpad (enter the customer’s card details) to finalise the sale. 
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Export Data 

IP-7160 – Peiso Stock Sales Export Format 

This function introduces the ability to export Stock Sales data so that it is compliant with Peiso. 

The format of the exported data is the same as the Generic Export Format, with the main difference being the Peiso 

format only supports CSV file extension, and the filename of the exported file does not have/allow any spaces. 

 

To configure this function, go to: 

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Import/Export. 

Export Folder: Browse to the required folder to export the data to. 

Export Daily at/Or every minutes: Enter the required interval to export the data. 

Export Sales Format: Select “Peiso”. 

Sales From: All POS Terminals, This POS Only or This Site Only. 

 

The filename created by the export will be: 

TradingName_YYYYMMDDHHMM.csv. 

E.g. If the Trading Name is Idealpos User and the data is exported on the 18th June 2025 at 10:34AM, the resulting 

filename will be: 

Idealposuser_202506181034.csv 
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The below is a sample set of data that has been exported using the Peiso format: 

 

AUDIT,POS,LINE,DATE,STOCKCODE,DESCRIPTION,PRICELEVEL,QUANTITY,UNITPRICEBEFOREDISCOUNT,TOTALPRICEBE

FOREDISCOUNT,TAXLABEL,TAXAMOUNT,DISCOUNTEDPRICE,COST,SITE,LOCATION,CUSTOMERCODE,CLERK,DEPARTM

ENT,REFERENCE 

1263,"POS 1",1,18/06/2025 10:33,202001,"CAPPUCCINO",STANDARD,1.00,3.50,3.50,GST,0.32,3.50,0.29,Site 1,Location 

1,,1,COFFEE,"" 

1263,"POS 1",2,18/06/2025 10:33,202002,"FLAT WHITE",STANDARD,1.00,3.50,3.50,GST,0.32,3.50,0.29,Site 1,Location 

1,,1,COFFEE,"" 

1263,"POS 1",3,18/06/2025 10:33,202004,"SHORT BLACK",STANDARD,1.00,3.00,3.00,GST,0.27,3.00,0.20,Site 1,Location 

1,,1,COFFEE,"" 
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Import Data 

IP-7109 – Automatically Import Gift Vouchers 

This function introduces the ability to automatically import Gift Vouchers. 

When this functionality is configured, Gift Voucher files that are placed into the Import Folder (configured in 

Automatic Import Settings) will be imported automatically. 

 

To configure and use this function, go to: 

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Import/Export. 

 

Automatic Import Settings 

• Import Folder – Specify a folder where the Gift Voucher File will be imported from. E.g. C:\Temp 

• Delete files after importing – Enable this checkbox to delete the file after it is imported. Note that the 

behaviour of the Auto Import function varies depending on whether this checkbox is turned on or off.  

o Enabled - When this checkbox is enabled, there is no limit to the number of times a Gift Voucher file 

can be imported using the filename that is specified in the Import Gift Vouchers Filename field. 

o Disabled - When this checkbox is disabled, a Gift Voucher file can only be imported once using the 

filename that is specified in the Import Gift Vouchers Filename field. E.g. Once a Gift Voucher file has 

been imported, the Import Gift Vouchers Filename will need to be changed so that another automatic 

import of a file can be processed. The previously used filename will no longer allow Gift Vouchers to 

be imported while the Delete files after importing option is disabled. 

• Import Gift Vouchers Filename – Enter the filename of the Gift Voucher Import File.  

E.g. GIFTVOUCHERIMPORT.TXT 
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Once the Automatic Import Settings have been configured as required, place a Gift Voucher Import file into the Import 

Folder using a filename that matches the Import Gift Vouchers Filename configured above. 

The fields of the Gift Voucher Import file are as follows (note that the Gift Voucher Import File should not include any 

headers): 

Code,Name,Type [1-10],Balance,ExpiryDate[YYYY-MM-DD],Site [0 for Global Redemption] 

 

The following is a sample of a Gift Voucher File that can be used to demonstrate this functionality: 

 

10000,John Smith,1,50.00,2025-12-30,0 

10001,Joanne Smith,1,100.00,2025-12-30,0 

10002,Joe Blow,1,200.00,2025-11-01,0 

10003,Joanne Blow,1,200.00,2025-11-01,0 

 

Create a file using a filename that matches the Gift Vouchers Filename configured in the Automatic Import Settings 

and copy the file into the Import Folder. 

 

 
 

After the Gift Voucher file is imported automatically, it will be deleted from the Import Folder (provided that the 

“Delete files after importing” option has been enabled. 

The import of the Gift Voucher file will be recorded in the Activity Enquiry (go to: Back Office > Enquiry > Activity Log). 
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The Gift Vouchers that were imported can be viewed by going to: 

Back Office > Reports > Sales > Gift Voucher Report. 

Set the GIFT VOUCHER Bought Date to the current date (Today) and run the report (the date which the Gift Vouchers 

are imported will be recorded as the Bought Date). 

 

 
 

The Gift Voucher Report will show the imported Gift Vouchers 
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IP-7155 – Promotions Import – Option to set Priority of newly imported Promotions (User-Defined) 

This User-Defined option adds the ability to trigger Imported Promotions to appear at the top of the Promotion list, 

therefore giving Imported Promotions a higher priority over the already existing Promotions. 

Without the User-Defined Option, imported Promotions will appear at the bottom of the Promotion list. 

With the User-Defined Option, imported Promotions will appear in the Promotions list using the Priority that has been 

entered in the User-Defined Option. 

Note that the User-Defined Option must be created prior to importing Promotions for the Imported Promotions to 

appear at the top of the Promotion list. 

 

To configure this function, go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > POS Settings > User-Defined Options. 

Create the following User-Defined Option: 

• Description: IMPORTPROMOSPRIORITY 

• Setting: xxx 

 

Xxx is the priority that newly imported Promotions will be set to; enter the required priority. 

E.g. If a value of 1 is entered as the Setting for the User-Defined Option, this will set all new Promotions to Priority 1 

and push all the other Promotions down the list (so in an Import File, the last imported record will become the highest 

priority Promotion). 
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Once the User-Defined Option has been created as required, Promotions can be imported by going to: 

Back Office > File > Sales > Promotions > Promotions > Import. 

 

 
 

Browse to the Import file and press “Import”. 

Imported Promotions will be assigned to the priority as per the User-Defined Option. 

The Promotion File Format is outlined in the User Guide by clicking here. 

  

https://userguide.idealpos.com.au/Default.htm#Promotions/Import%20Promotions.htm
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Kiosk 

IP-7093 – Kiosk – Checkout Upsell Grid Functionality 

This function introduces the ability to trigger a Checkout Upsell Grid on Kiosk screens to appear after the consumer 

presses the “CHECK OUT” button. 

The Checkout Upsell Grid can be used as a method of “upselling” additional items to the consumer prior to taking 

payment. The Upsell Grid can be useful to draw attention towards a product or service that is available that the 

consumer may have overlooked while they were placing their order (e.g. a range of new products or services that have 

recently been added to the menu). 

 

To configure and use this functionality, go to:  

Back Office > Setup > POS Screen > Grids > Add. 

Description – Enter a Description for the Checkout Upsell Grid. The Description will be displayed at the top of the Kiosk 

when the Checkout Upsell Grid is triggered. 

Therefore, a Description such as “Would you also like?” or “Have you considered?” can be used. 

The Description field is limited to 30 characters. 

Press the “Save” button on the top-left corner to save the new POS Screen Grid. 
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Close the Add New POS Screen Grids window, then select the newly created POS Screen Grid > Items. 
 

 
 
Note that the Grid Layout is shown horizontally when configuring the buttons, whereas the Kiosk is displayed 
vertically. 
Therefore, when adding Stock Items to the POS Screen Grid, add the items in a vertical fashion from top-down 
starting from the far left-hand side of the POS Screen Layout and working across the layout towards the right. 
The Kiosk will display items in that order; noting that the Kiosk displays 3 items per row. 
Search for the required items within the grid on the top-left corner and drag them to the desired button position, 
remembering the above info regarding the sorting of items on the Kiosk screen. 
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Images can be set for the items by clicking on each item in the POS Screen Grid and assigning a graphic in the 
Graphic field. 
The images must be stored in the folder “C:\ProgramData\Idealpos Solutions\Idealpos\Pictures” on each POS 
Terminal/Kiosk. 
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Go to: Back Office > Setup > POS Terminals > Select the Kiosk POS Terminal > Modify > Display/Kiosk tab. 

Within the Checkout Upsell Grid dropdown box, select the newly created POS Screen Grid. 

 

 
 

Close the Modify POS Terminal window. 

If the venue or site contains multiple Kiosk Terminals, repeat the above step to set the Checkout Upsell Grid for each 

Kiosk Terminal that requires this functionality. 

The change should take effect without restarting the Kiosk. 
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Go to the Kiosk and start a sale > Add an item to the order. 

 

   
 

Press the “CHECK OUT” button at the bottom of the screen > the Checkout Upsell Grid is displayed. 

Any items that are required from the Checkout Upsell Grid can be pressed and added to the sale. 
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After adding an item from the Checkout Upsell Grid to the order, the Checkout Upsell Grid is displayed again and any 

other items from the grid can be added to the sale if required. 

To proceed, press the “CHECK OUT” button > items in the order are displayed > Press “Pay by Card” to finalise > Kiosk 

takes payment and returns to the Home Screen. 
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POS Screen 

IP-7055 – Show IPSClient Screen from POS Connectivity Indicator 

This function introduces the ability to show the IPSClient Screen from the POS Connectivity Indicator. 

To enable the Internet Connectivity Indicator on the POS Screen, follow the steps that are outlined in this Update 

History Document under IP-7043 – Yes/No Option – Show Internet Connectivity Indicator on POS Screen. 

Once the Internet Connectivity Indicator appears on the top-right corner of the POS Screen, press on the indicator. 

 

 
 

After pressing on the Internet Connectivity Indicator, the IPSClient Screen will be displayed. 

This can be used to see whether there are any connectivity issues with other POS Terminals on the network. 

 

Note - This is a reduced functionality IPSClient screen that intentionally has the menu hidden (to prevent unauthorised 

access to advanced features in the IPSClient screen). 

To gain access to the full IPSClient screen that contains the menu at the top, close the POS Screen and open the 

IPSClient via the Windows System Tray. 
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Room Interface 

IP-7057 – Generic Room Interface 

This function introduces the ability to configure Idealpos to use a Generic Room Interface. 

The Generic Room Interface is based on the Newbook (File) Room Interface. 

This interface will require the Generic module to be enabled in the Idealpos License to function. 

 

In summary, the Generic Room Interface works as follows: 

• A shared network path is configured where a GUEST.DAT file is created and stored – the file contains the 

guest’s names and room numbers. 

• The shared network path is also used to write charges to a CHARGES.DAT file. 

• A Tender Type is linked to the Generic Room Interface. 

• When tendering a sale and selecting the Tender Type that’s linked to this interface, a prompt is displayed 

where the guest’s room number is entered, and the guest’s name is selected. 

• The resulting charge is written to the CHARGES.DAT file in the shared network path. 

• When tendering a sale using the tender linked to the Generic Room Interface, one or more lines with a single 

Transaction Type of “CHARGE” are written to the CHARGES.DAT file (one line for each Department). 

• When tendering a sale using a tender not linked to the Generic Room Interface, one or more lines with a 

Transaction Type of “CHARGE” (one line for each Department), and a single line with a Transaction Type of 

“PAY” are recorded to the CHARGES.DAT (the CHARGES.DAT file is written to for all transactions). 

 

The steps outlined on the following pages outlines the setup of this interface in a summarised version. 
For a more extensive guide with complete screenshots, refer to the Idealpos User Guide – 
https://userguide.idealpos.com.au 
Within the User Guide, go to Room Interface > Generic Room Interface.  

https://userguide.idealpos.com.au/
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Licence Gateway 

Go to: Back Office > Setup > Licence Gateway. 

Ensure that the Generic module appears in the Options column for each POS Terminal that will utilise the Generic 

Room Interface. Contact Idealpos or your Idealpos Reseller to purchase the Generic module. 

 

Configure a shared network path for the Generic Room Interface 

The Generic Room Interface will require a shared network path/location that is accessible to all POS Terminals that will 

utilise the Generic Room Interface. 

After a shared network path has been configured, take note of the network path (e.g. \\HOSTNAME\ShareFolder) as 

this will be required when entering the network path.  

Note that additional configuration may be required, such as User Accounts and Share Pemission configuration. This is 

outside the scope of the Update History or User Guide. 

 

Configure a Tender Type for the Generic Room Interface 

Go to: Back Office > Setup > Function Descriptors. 

Locate the next available and unused Function Descriptor > Modify > Enter a Description (e.g. PMS CHARGE or ROOM 

CHARGE) > Save the change. 

 

Configure the Generic Interface in Global Options 

Go to: Back Office > Setup > Global Options > Interfaces > Rooms. 

Interface Type: Generic 

Output from POS: Enter the POS Terminal number of the main POS that will handle the outputting of data to the 

Generic PMS. 

Network Path: Enter the network path that has been configured. Note – Ensure that the network path does not 

contain a backslash at the end of the path as this will prevent the functionality from working successfully. 

Tender Type: Select the PMS CHARGE or ROOM CHARGE Tender Type that was configured above. 

 

Restart Idealpos to apply changes 

For all the above changes to apply, it is recommended that Idealpos is restarted on all POS Terminals and the Back 

Office. 

Go to: Start > Idealpos > IPSUtils > Press “Close” > Confirm. 

Start Idealpos via the “Idealpos” desktop shortcut, or go to: Start > Idealpos > Idealpos. 

 

GUEST.DAT file information 

A GUEST.DAT file is required for this functionality. 

The GUEST.DAT must be placed in the network path that configured above. 

The GUEST.DAT file will store information about Room Numbers/Guests and will be used when tendering to the PMS 

CHARGE/ROOM CHARGE Tender Type. 

The format of the GUEST.DAT is as follows: 

RoomNumber,CustomerName,CreditLimit,CurrentBalance,ScanCode 

 

An example GUEST.DAT has been listed below that can be used to demonstrate this functionality: 

 

100,Joe Blow,1000,0,123123123123 

101,Joanne Blow,1000,500,234234234234 

 

CHARGES.DAT file information 

A CHARGES.DAT file is created automatically in the network path location and records all charges/transactions. 

The format of the data stored in this file is as follows: 

TransactionType,RoomNumber,CustomerName,Department,GLCode,QTY,Amount,Location,DateStamp,DepartmentTot

alAddOnTaxAmount,DepartmentTotalInclusiveTaxAmount,AuditNumber 

  

file://///HOSTNAME/ShareFolder
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Using Generic Room Interface 

After this functionality has been configured, add items to a sale and press the ENTER button to go to the Tender 

screen. 

Within the Tender screen, press the PMS CHARGE or ROOM CHARGE button. 

A “Post Transaction To PMS” window will be displayed. 

Enter the guest’s room number and press “Proceed”. 
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The guest’s name will be displayed – press the guest’s name to post the transaction to their room. 

A confirmation prompt will be displayed – accept the confirmation prompt to post to their room. 

 

 
 

The CHARGES.DAT file will be written to (in the network path configured in Global Options > Interfaces > Rooms). 

If the file does not exist, it will be created automatically in the network path. 
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Yes/No Options  

IP-7043 – Yes/No Option – Show Internet Connectivity Indicator on POS Screen 

This function introduces the ability to show an Internet Connectivity Indicator on the POS Screen. 

The indicator will appear on the top-right corner of the POS Screen and will indicate whether the internet connection 

is working. 

When internet connectivity is available, the indicator will appear as blue, and when internet connectivity drops, the 

indicator will change to red. 

To configure this function, go to: Back Office > Setup > Yes/No Options.  

In Yes/No Options, search “Internet”.  

Enable the option “Show Internet Connectivity Indicator on POS Screen”. 

 

 
 

After enabling the Yes/No Option, Idealpos will need to be restarted for the change to take effect. 

Go to Start > Idealpos > IPSUtils > Close > Confirm the closure of Idealpos Suite of programs by pressing “Yes”. 

Start Idealpos via the Desktop Shortcut (or via Start > Idealpos > Idealpos). 

The top-right corner of the POS Screen will display an internet connectivity indicator. 

 

When internet connectivity is available, the indicator will appear as blue as per the below example: 

 

 
 

When internet connectivity is unavailable, the indicator will appear as red as per the below example: 

 

 
 

 


