
 Update History 
 

Idealpos 7.1 Build 3 

Update Details: 

[IP-2646] - Yes/No Option - 24 Hour Time Format for Kitchen Prints 

[IP-2746] - User Permission to modify Stock Item Grid Default Settings 

[IP-2747] - Total Stock Level on Stock Items by Location form 

[IP-2771] - Supplier Enquiry to Allow for Filtering by stock location. 

[IP-2801] - Fast Pending Sale Function 

[IP-2811] - Stock Item - Long Description (Description3) Field 

[IP-2823] - Option to Inhibit ability to add value to existing Gift Vouchers 

[IP-2824] - Option to Expire Gift Vouchers after a Single Redemption 

[IP-2833] - Pending Sales - Voided Items sent to Kitchen Printers 

[IP-2834] - Over-Tendered Tenders can convert balance to Tips 

[IP-2852] - Home Screen support for Exit POS Password 

[IP-2864] - Pending Sales - Reprint to Kitchen Function 

[IP-2869] - Activity Enquiry - option to Show Only the Selected Type 

[IP-2870] - Dry Cleaning - Option to Only Print Receipt on Printer 2 when Tabs printed 

[IP-2881] - Birthday Coupon Promotions can be valid for a set number of days 

 

 

  



Back Office 

Activity Enquiry – Option to Show Only the Selected Type 

The Activity Enquiry function allows any activity or event that took place on an Idealpos terminal to be viewed. 

This function adds a new option to the Activity Enquiry to show only the selected type of event. This can be useful 

when tracking down the same type of event and finding the exact dates and times of when the event occurred such 

settings being modified or an Incorrect Password attempt 

 

To use this function, go to: Enquiry > Activity Log 

The Activity Enquiry will be displayed. 

If required, make any required selections in the Selection Criteria, including the date range that you want to query, 

then press the “Select” button to update the results in the Activity Enquiry.  

Select an event from the list of events on the left-hand side, then enable the “Show Only the Selected Type” checkbox 

and press “Select”. 

 

The below example shows the “Incorrect Password” event selected from the list of events. 
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After pressing the “Select” button, the list of events will be updated and will only show the event type that was 

selected. It is also possible to keep adjusting the Selection Criteria whilst the  

The below example shows all the occurrences of the Incorrect Password event. 

 

 
 

 

  



Coupon Promotions 

Birthday Coupon Promotions can be valid for a set number of days 

This function adds the ability to configure the number of days that you want a Birthday Coupon Promotion to be valid 

for. This feature can be used to force the customer to use their Birthday Coupon only on the day of their actual 

birthday or it can be used to specify a number of days after their birthday which the coupon is valid.  

This ensures that the customer only redeems their Birthday Coupon within the allowed number of days as per your 

store policy. 

 

To configure and use this function, go to:  

File > Sales > Promotions > Coupon Promotions 

Either select an existing Coupon Promotion from the list, then press the “Modify” button on the bottom-right corner. 

Alternatively, press the “Add” button on the bottom-right corner of the screen to create a new Promotion. 

 

If creating a new Coupon Promotion, you will need to specify the Trip by Quantity (specify the number of items which 

need to be purchased from the list) or Trip by Amount (specify the dollar value that needs to be spent on the items 

from the list). 

The below example shows a Birthday Bottle House Wine Coupon Promotion. 

In the below example, when the customer purchases any item from the list of items under the Trip Conditions Set 1 

(left-hand side of the screen), they will receive a 100% discount on a single item from the list of items that are 

displayed on the right-hand side (only applicable when triggered by the Birthday Coupon – more on this below). 
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Once the Promotion has been created, click on the “Advanced” tab. 

In the User-Defined Text field, enter [BIRTHDAY#], ensuring that you substitute # with the number of days after the 

Customer’s birthday date which you want the Birthday Coupon to be available. 

Examples: 

[BIRTHDAY1] will allow the customer to redeem their Birthday Coupon Promotion only on the day of their birthday. 

[BIRTHDAY30] will allow the customer to redeem their Birthday Coupon Promotion 30 days after their birthday has 

occurred. 

[BIRTHDAY] will allow the customer to redeem their Birthday Coupon Promotion anytime within the calendar month 

that their birthday falls in. 

The number of days that can be used in this setting are not restricted to 1 or 30 days; you can enter any number of 

days as required. 

The below example shows the User-Defined configured with a [BIRTHDAY1] value, which will only allow the customer 

to redeem on the day of their Birthday. 

 

 
 

After the User-Defined text has been updated, close the Coupon Redemption screen and when prompted, ensure that 

you press “Yes” to confirm and save any changes. 

 

 
  



The next step is to ensure that you have a Customer which has a Birthday occurring on the current day. 

Go to: File > Customers > Customers 

Select a Customer from the list, then press the “Modify” button on the bottom-right corner of the screen. 

 

In the Birth Date field, ensure that the date and month matches the current date. 

The below example shows a Birth Date of 08/08/1980 (8th August 1980). 

 
 

Close the Modify Customer and Customers screens. 
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In order to redeem Customer Coupons, you will need to ensure that you have a Customer Coupon button on your POS 

Screen. 

This can be created by going to: Setup > POS Screen > POS Screen Setup > Select the POS Screen Layout > Buttons 

Find an available/blank button on any desired POS Screen tab, then create the button as follows: 

Select the “Customer Coupons” from the list of available functions in the list, enter a Button Caption “CUSTOMER 

COUPON” and update the button appearance if required/as necessary. 

Once completed, press the “Save” button. 

 

 
 

Close the POS Screen Layout, then go to the POS Screen.  

  



Add a Customer to the sale which has a birthday that falls on the current day. 

After adding the Customer to the sale, add any item to the sale which was included in the Birthday Coupon. 

 

 
 

Add the Coupon Promotion to the sale by going to the POS screen tab where the Customer Coupon button was 

created, then press the button. 
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A screen similar to the below will be displayed containing a list of Coupons that the customer is entitled to redeem. 

Select the Birthday Coupon from the list, then press the “Redeem Selected Coupon” button on the bottom-right 

corner of the screen. 

 

  
 

  



The Stock Item(s) that were included in the Coupon will be discounted by the amount configured in the Coupon 

Promotion and the Total amount displayed on the bottom-right corner of the transaction details. 

 

 
 

To finalise the Sale, press the “ENTER” button, then enter the amount. 

If the Total amount is 0.00 (due to a 100% discount), press CASH to finalise the sale. 
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When attempting to redeem a Birthday Coupon using a Customer who has a birthday which has occurred after the 

number of days specified in the promotion, the Birthday Coupon will not be displayed and therefore unavailable for 

redemption. 

The below example shows a Customer whose Birthday occurred on the 07/08/1980 (7th August 1980). 

 

  
 

  



With the current date being 08/08/2019, when adding the above Customer to the sale and attempting to trigger the 

Birthday Coupon Promotion, the Customer Coupons screen will show no available Coupons in the list. 
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In addition, attempting to redeem a Birthday Coupon for a Customer who has already redeemed their Birthday 

Coupon for the current year will display the date and time when it was redeemed. The customer will need to wait for 

their next year’s birthday before they can redeem the Birthday Coupon again. 

 

  



Function Descriptors 

Over-Tendered Tenders can convert balance to Tips 

This function adds the ability to configure specific Tender Types to allow overcharging to tips.  

Any amount that exceeded the required total will be converted to a tip and a prompt will be displayed advising the 

clerk of the amount they have overtendered and whether they’d like to convert the amount to a Tip.  

This function is useful in regions or industries that encourage or rely on tipping. 

 

To configure this function, go to:  

Setup > Function Descriptors > Select a Tender between Tender 2 and Tender 18 > Modify 

Enable “Allow Overcharging To Tips” then press “Save” 
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Ensure that the Tender being configured is enabled. 

Go to: Setup > Yes/No Options 

Enter Keyword Search: Inhibit tender  

Ensure that you remove the checkbox for the Tender that you want to enable. 

For this example, we’ll be using EFTPOS 

 

 
 

Close the Yes/No options, then go to the POS Screen. 

 

  



Add items to the sale, then press the “ENTER” button to go to the Tender screen 
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Enter the amount that you want to over-tender by using the on-screen numeric keypad.  

The amount entered will appear in the amount field next to the Fast-Cash tender buttons. 

After entering the amount, press the Tender Type that was configured above.  

In this example, the total amount due is $10.00 and a tender amount of 20.00 has been entered. 

 

 
 

After selecting the Tender, Idealpos will display a prompt “You have OverTendered by $##.## - Would you like to 

convert this to a Tip?”. Press “Yes” to convert the overtendered amount into a Tip and proceed to Payment. 

 

 
 

  



Pressing No will result in the extra amount being tendered towards the sale.  

Any overtendered amount will be counted as Change that is due to be given back to the customer. 
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Any Tips that have been received will appear in the Financial Report under TIPS IN. 

Go to: Reports > Financial > Financial Report > Select the Period Required > View 

 

  



Gift Vouchers 

Option to Expire Gift Vouchers after a Single Redemption 

This option adds the ability to Expire Gift Vouchers after a Single Redemption. This may be useful when you want to 

force customers to spend the entire value of their Gift Voucher in a single redemption. If the entire value of the Gift 

Voucher is not redeemed in the single redemption, any amount remaining on the voucher will be forfeited and no 

longer available after the single redemption has been performed.  

When configuring and selling Gift Vouchers, it is important that you comply with any laws that govern the sale of Gift 

Vouchers in your Country or State that you reside.  

As an example, you can view the requirements for Australia, New Zealand and Canada, however, this is obviously not 

an extensive list and you need to ensure that you research and understand the laws in your area. 

 

As the complete end-to-end configuration of Gift Vouchers can be quite extensive and customisable, covering the 

complete setup and configuration of a Gift Voucher in the Update History is outside the scope.  

The basics of selling and redeeming a Gift Voucher will be covered for the purposes of demonstrating this function. 

For complete details about setting up and configuring Gift Vouchers, refer to the Gift Voucher topic in the Idealpos 

User Guide by clicking here. 

 

To enable/toggle this option, go to:  

Setup > Global Options > Credit Notes/Gift Vouchers > Gift Vouchers.  

Enable checkbox: Expire Gift Voucher after a Single Redemption 

 

 
 

  

https://www.accc.gov.au/consumers/misleading-claims-advertising/gift-cards-discount-vouchers#gift-cards-and-vouchers
https://www.consumerprotection.govt.nz/general-help/ways-to-buy-and-pay/gift-vouchers-and-pre-loaded-cards/#your-rights
https://www.canada.ca/en/financial-consumer-agency/services/payment/gift-cards.html
https://userguide.idealpos.com.au/#Gift Vouchers/Gift Vouchers.htm
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After enabling the above option, close the Global Options window. 

 

Gift Vouchers are sold via the Received Account function. Idealpos supports up to four Received Account functions. 

At least one Received Account function must be enabled for GIFT VOUCHERS. 

 

Go to: Setup: Function Descriptors > Received Account 1-4 

Any Received Accounts that are already configured or used will contain a description representing the purpose that 

the function is being used for. Any unused Received Account Functions will typically have RA followed by the Received 

Account Number. 

Find the next available and unused Received Account Function, then either select it and press the Modify button on 

the bottom-right corner of the screen, or double click on it to modify the function descriptor. 

The below example shows the next available Received Account Function is 3, as highlighted below. 

 

 
 

  



When modifying the function, enter a Description and enable the GIFT VOUCHER checkbox. 

For this example, we will use a Description of GV PURCHASE  

Once the change has been made, press the “Save” button on the bottom-right corner. 
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A Gift Voucher Tender will also need to be configured. 

From the Function Descriptors screen, find the next available Tender. 

Any unused Tenders will appear as TENDER ##. 

In the below example, the next available tender is TENDER 7. 

 

 
 
  



Either double-click on the next available tender, or select the tender then press the “Modify” button on the bottom-
right corner of the screen. 
Configure the tender as follows: 
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After the Tender has been configured, it will need to be enabled in the Yes/No Options. 
Go to: Setup > Yes/No Options > Tenders > Inhibit GIFT VOUCHER: Remove Tickbox 
 

 
 
  



Before a Gift Voucher can be sold and redeemed, Gift Voucher and Gift Voucher Enquiry buttons need to be created 

on the POS screen.  

Go to: Setup > POS Screen > POS Screen Setup > Select the POS Screen Layout > Buttons 

 

Click on a suitable POS Screen tab where you’d like the buttons created, then locate at least two blank POS Screen 

buttons on the tab. Configure the two available buttons as follows, ensuring to press “Save” when configuring each 

button: 

 

The following button will be used for selling Gift Vouchers. 

Button Function: Received on Account 

Received on Account: “GV PURCHASE” 

Gift Voucher Type: “Gift Voucher” 

Button Caption: “GIFT VOUCHER” 

 
 

The following button will be used for Enquiring a Gift Voucher 

Button Function: Gift Voucher Enquiry 

Button Caption: “GIFT VOUCHER ENQUIRY” 
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Once the POS Screen buttons have been configured, close the POS Screen Layout windows, then go to the POS 

Screen. 

Click on the GIFT VOUCHER button created above. 

Idealpos will display the following prompt to Scan or Enter Voucher Code, Enter the Amount, Customer Name and 

Email Address. Entering the Name and Email address is optional. If you enter an email address, the voucher will be sent 

to the entered email address. In order to use the Email Address, you need to configure Email Settings in Idealpos. 

Refer to Setting up Gift Vouchers in the User Guide for more details. 

Enter the Amount, then press OK. 

 

 
 

The Gift Voucher will appear in the Idealpos Sale Screen. 

 

 

https://userguide.idealpos.com.au/#Gift%20Vouchers/Setting up Gift Vouchers.htm


Press the “ENTER” button to proceed to the Tender screen. 

Finally, select a Tender amount to finalise the sale. 

 

The Gift Voucher will be printed and will include the amount, Gift Voucher Number and Voucher barcode.  

 

 
 

When redeeming the Gift Voucher, it will expire after a single redemption, meaning that any unspent and remaining 

value will be forfeited. 
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To redeem the voucher, first add any required items to the sale.  

In the below example, $10.00 worth of items have been added to a sale. 

 

 
 

Press the ENTER button to go to the Tender screen, then press the “GIFT VOUCHER” button. 

 

 
  



A GIFT VOUCHER prompt will be displayed to Scan or Enter the Voucher Code and will also show the Amount to 

Tender. 

 

 
 

If a Customer Name was entered at the time the Gift Voucher was sold, you have the option to click on the “Name 

Search” button to find the voucher from the list. Otherwise, Scan or Enter the Voucher Code to proceed. 

 

Once the Voucher Code has been scanned or entered, the balance of the voucher will be displayed along with buttons 

to Print, View History, Edit, Add or Email. 

To add the Voucher to the sale, press the “Add” button. 
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After adding the Gift Voucher, the GIFT VOUCHER screen will show the Voucher Code, Redeeming Amount and the 

Total Voucher Redemption. Press the “Finalise” button to finalise the sale. 

 

 
 

  



If Receipt printing is enabled, the Customer Receipt will print out showing the amount that was redeemed, along with 

the Voucher Code. If Receipt Printing is turned off, you can press the RECEIPT button on your POS Screen to print out 

a receipt. 

 

 
 

Should any attempts be made to redeem the Gift Voucher after the single use redemption, the GIFT VOUCHER 

redemption screen will show the date which the voucher was used next to Expires. 

 

 
 

Any attempts made to press the “Add” button as shown above will result in the following Gift Voucher expired 

message: 
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Should any special circumstances arise where you want to allow the customer to spend the remaining amount of the 

expired Gift Voucher, you have two options. Either edit the Expired Gift Voucher and adjust the expiry date to a future 

date, or you can add value to the expired Gift Voucher which will extend the Expiry Date by the number of days 

configured for the Gift Voucher Type. 

 

To adjust the expiry date, the “Edit” button can be used to modify the expiry date of the Gift Voucher to a future date. 

 

 
 

The Edit GIFT VOUCHER screen will be displayed. Select a future date that you want the GIFT VOUCHER extended to, 

then press “Save”. In this example, the next day of 25/07/2019 has been selected. 

 

 
 

  



After pressing “Save”, the GIFT VOUCHER redemption screen will show the new Expiry Date next to “Expires”. 

After this point, you have the option to either close the GIFT VOUCHER redemption screen to allow the customer to 

come back at a date before the new expiry date to redeem the remainder of their Gift Voucher, or they can spend the 

remainder of the Gift Voucher by pressing the “Add” then “Finalise” buttons. If required, the Gift Voucher can also be 

re-printed by pressing the “Print” button.  

Note that the next time the Gift Voucher is redeemed, it will be subjected to the same setting/rule of being expired 

after a single redemption, regardless of whether or not the entire remaining balance is spent. 

 

 
 

Adding value to an existing Gift Voucher which has been expired will also trigger the Expiry Date of the voucher to be 
extended by the number of days that have been configured for the Gift Voucher Type.  
This is provided that the “Inhibit ability to add value to existing Gift Vouchers” option has not been enabled. 
The default number of days for each Gift Voucher Type and the “Inhibit ability to add value to existing Gift Vouchers” 
are both configured by going to: Setup > Global Options > Credit Notes/Gift Vouchers > Gift Vouchers 
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Option to Inhibit ability to add value to existing Gift Vouchers 

This function adds the ability to stop additional value from being added/loaded onto any existing Gift Vouchers which 

have already been sold. This may be useful for any venues or stores that want to force their customers to purchase 

additional Gift Vouchers rather than adding value to existing vouchers that have already been sold. 

When configuring and selling Gift Vouchers, it is important that you comply with any laws that govern the sale of Gift 

Vouchers in your Country or State that you reside.  

As an example, you can view the requirements for Australia, New Zealand and Canada, however, this is obviously not 

an extensive list and you need to ensure that you research and understand the laws in your area. 

 

Before enabling this option, it is assumed that your system is already configured for the sale and redemption of Gift 

Vouchers. If you need information on setting up Gift Vouchers, you can either refer to the Setting up Gift Vouchers 

topic in the User Guide. Alternatively, you can refer to the topic “Option to Expire Gift Vouchers after a Single 

Redemption” in this Update History document which also outlines the basics of setting up and enabling your system 

for the sale and redemption of Gift Vouchers. 

 

To enable this function, go to:  

Setup > Global Options > Credit Notes/Gift Vouchers > Gift Vouchers 

Enable the checkbox: “Inhibit ability to add value to existing Gift Vouchers” 

When the tickbox is ticked/enabled, the ability to add value to existing Gift Vouchers will be disabled/inhibited. 

When the tickbox is unticked/disabled, the ability to add value to existing Gift Vouchers will be enabled/allowed. 

 

 
 

  

https://www.accc.gov.au/consumers/misleading-claims-advertising/gift-cards-discount-vouchers#gift-cards-and-vouchers
https://www.consumerprotection.govt.nz/general-help/ways-to-buy-and-pay/gift-vouchers-and-pre-loaded-cards/#your-rights
https://www.canada.ca/en/financial-consumer-agency/services/payment/gift-cards.html
https://userguide.idealpos.com.au/#Gift%20Vouchers/Setting up Gift Vouchers.htm
https://userguide.idealpos.com.au/#Gift%20Vouchers/Setting up Gift Vouchers.htm


Close the Global Options window to save the change. 

 

To demonstrate this function, we will need to have an existing Gift Voucher that contains value. 

Go to the POS Screen and press the GIFT VOUCHER button to purchase a GIFT VOUCHER. 

 

Enter an amount, then press OK. 

 

 
 

The Gift Voucher will be added to the sale. 

 

 
  

 

  



 Update History 
 

Press the ENTER button, then tender the sale. 

The Gift Voucher will be printed. 

 

 
 

  



After the Voucher has been printed and the sale finalised, press the “GIFT VOUCHER” button on your POS screen to 

sell another Gift Voucher. 

Enter the Barcode of the existing Gift Voucher into the Scan or Enter Voucher Code field, then enter an amount. 

Finally, press the “OK” button. 

 

 
 

After pressing “OK”, Idealpos will display the following prompt, preventing any additional value from being added to 

the Gift Voucher. 
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Home Screen 

Home Screen support for Exit POS Password 

This function adds the ability to close the Home Screen when an Exit POS Password is configured by pressing the 

Exit/X button on the top-right corner of the Home Screen. The password prompt will appear and after entering the 

correct password, the Home Screen will close and the Back-Office dashboard will be displayed. 

 

Prior to this change, if an Exit POS Password was configured and the “Show Exit button on Home Screen” Yes/No 

option was enabled, the Clerk would still have to first login by entering their Clerk ID into the Home Screen, then they 

would have to press the “X” on the top right corner and enter the Exit POS Password. This change reduces the number 

of steps required to close the Home Screen, thereby speeding up this process.  

 

In order to use this function, the following options must be enabled: 

 

- Global Options – Exit POS Password 

- Yes/No Options – Allow Home Screen and Show Exit button on Home Screen 

 

Go to: Setup > Global Options > General 

In the Exit POS Password, enter any password you’d like to use to exit the POS screen. 

 

 
 

Enter a password into the Exit POS Password field. 

Note that the password will be displayed as plain text in the Exit POS Password field. 

Only users which have access to the Setup > Global Options screen will be able to view it. 

 

Close the Global Options window to save the change.  



Go to: Setup > Yes/No Options > Enter “Home” into the “Enter Keyword Search” field 

Then enable the following Yes/No Options: 

- Allow Home Screen 

- Show Exit button on Home Screen 

 

 
 

Close the Yes/No Options window, then go to the POS Screen. 

Click on the Exit/X button located on the top-right corner of the Home Screen. 

 

 
 

A Password prompt will be displayed. 
Enter the Password that was configured in Setup > Global Options > General > Exit POS Password 
Then press OK 
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The Back-Office dashboard will be displayed. 

 

 
 

If the Exit POS Password is blank and not configured, pressing the X button on the top-right corner of the Home 

Screen will trigger the X to flash and the Home Screen will not close.  

In order to close the Home Screen when the Exit POS Password is blank, the Clerk ID must be entered first, then the X 

button on the top-right corner of the Home Screen can be pressed to close the Home Screen and return to the Back-

Office dashboard. 

  



Pending Sales 

Pending Sales – Voided Items sent to Kitchen Printers 

This function enables the ability for Voided Items to be sent to Kitchen Printers when using Pending Sales.  

This may be beneficial for the Kitchen staff to be aware of voided items so they don’t cook or prepare any unrequired 

items. 

 

As this function utilises an existing Yes/No option “Send Deleted Items to Kitchen”, you may or may not need to 

perform additional configuration depending on how your system is configured. 

 

To configure this function, go to: Setup > Yes/No Options 

Enter Keyword Search: “deleted”, then ensure that the “Send Deleted Items to Kitchen” option is enabled 

 

 
 

Close the Yes/No options window, then go to: Setup > Global Options > Sales > Pending Sales 

Ensure that “Print to Docket Printers” is enabled. This will ensure that the Pending Sales are sent to the Kitchen Printers 

after the Pending Sale is saved, as well as any deletions will be sent to the printers that originally received the Pending 

Sale order. 
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Ensure that any Stock Items which need to be printed to Kitchen Printers are configured to do so. 

Go to: File > Stock Control > Select the Item > Modify > Tick/Untick the Printers as required 

 

 
 

Printer Names displayed in the above example can be adjusted/modified by going to:  

Setup > Global Options > Printing > Kitchen Printer Names 

More information about Settings available in Global Options > Printing are available in the User Guide by clicking here 

 

Printers can be configured by going to: Setup > Network Printers 

More information about configuring Network Printers is available in the User Guide by clicking here 

 

  

https://userguide.idealpos.com.au/#Global Options/Printing.htm
https://userguide.idealpos.com.au/#Network Printers/Network Printers.htm


A Pending Sale button is also required to use Pending Sales. 

This can be configured by going to: Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons 

Find a blank button and configure it as follows: 

 

 
 

Once the POS Screen button has been created, close the POS Screen Layout windows. 

 

Then go to the POS Screen 

Add Stock Items to the sale that will trigger a Kitchen Print, then press the PENDING button to save as a Pending Sale. 
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If the Yes/No Option “Fast Pending Sale” is disabled, you will see the following prompt. 

If required, enter details, then press the “Save” button to save the Pending Sale. 

 

 
 

The Pending Sale will be printed to the Kitchen and will contain any Stock Items that are configured to print to the 

Kitchen Printer. 

 

 
  



From the POS screen, click on the Pending button, select the Pending Sale from the list, then press the “OK” button. 
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The sale will be displayed on the POS Screen. Select any item that requires voiding, then press the “VOID” button. 

 

 
 

  



The item will be voided from the sale.  

Press the “PENDING” button to save the sale. 

 

 
 

The Pending Sale will be saved using the existing Pending Sale Code and the Kitchen Printer will print out a Kitchen 

Receipt showing the Stock Items that were deleted from the Pending Sale 
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Pending Sales – Reprint to Kitchen Function 

This function adds an option to the Pending Sales screen to allow the Pending Sale to be reprinted to the Kitchen, 

therefore now making it possible to do this. Previous to this change, once a Pending Sale was printed to the Kitchen, it 

wasn’t possible to re-print the pending sale to the kitchen. 

This function can also be used for eCommerce/web orders. When being used with eCommerce orders, it is possible to 

configure your system so that eCommerce orders do not automatically print to the kitchen and to only print them 

manually by pressing the Reprint Kitchen button. 

 

The “Reprint Kitchen” button does not need to be enabled; it will automatically appear in the Pending Sales screen. 

However, your system will need to be configured for Pending Sales, which also includes having a Kitchen Printer 

configured along with having the Stock Items configured so they print to a Kitchen Printer. 

 

The same steps outlined in the above function “Pending Sales – Voided Items sent to Kitchen Printers” can be followed 

to setup your system for Pending Sales. 

 

Once Pending Sales is configured, you can disable the automatic sending of eCommerce orders to Kitchen Printers 

(only disable this option if required and you want to stop this from happening). 

To do this, go to: Setup > Global Options > Interfaces 2 

Under the eCommerce Interface section, uncheck the option “Automatically Send Orders to Kitchen Printers”. 

 

 
 

  



When you have a Web Order, press the Web Orders button on the top-right corner of the POS Screen. 

 

 
 

In the case of a Pending Sale, press the “PENDING” button on the POS Screen. 
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A list of Pending Sales or Web Orders will be displayed. 

The screen may vary slightly for a Pending Sale or Web Order. 

Select the Web Order or Pending Sale from the list, then press the “Reprint Kitchen” button which is located at the 

bottom of the Pending Sale/Web Orders screen. 

 

  
 

The Kitchen Docket will be re-printed to the Kitchen Printer(s).  



Stock Items 

Stock Item – Long Description (Description3) Field 

This function adds a new Description field to the Stock Items screen (Description3). 

This field supports a maximum of 100 characters and will be used as the Long Description for a Stock Item.  

In addition, the Description 3 field will also be used by eCommerce integrations as the Stock Item Long Description. 

As there is now a dedicated Long Description field in the Stock Items screen, the Yes/No option “Use Stock Notes field 

for Long Descriptions” will be retired and the Description 1 field will be returned to the standard maximum length of 

30 characters. This also means that there will be some automatic migration performed in order to transfer long 

descriptions from Description 1 into the new Description 3 field. This may also result in Description 1 being truncated 

down to 30 characters depending on your system configuration before upgrading. See bullet point list further below 

for more information. We recommend that you review your Stock Item Descriptions after the upgrade and make any 

adjustments if necessary. 

 

Changes that are included as part of the implementation of the Description 3 field: 

 

• Removal of Yes/No Option "Use Stock Notes Field for Long Descriptions" from Idealpos 7.1 Build 3 and higher. 

• The Description 1 for Stock Items is automatically migrated into the Description 3 field, dependent on several 

factors. See list of bullet points under "Possible Outcomes for the Description 1 and Description 3 fields after 

upgrading" in the below. 

• The Stock Notes field in the Advanced tab of a Stock Item will be re-instated, regardless of whether or not you 

had the Yes/No option "Use Stock Notes Field for Long Descriptions" enabled prior to upgrading. 

• By default, the Description 2 field will be labelled as "Kitchen Description" and the Description 3 field will be 

labelled as "Long Description". These descriptions can be changed by going to:  

Setup > Global Options > Other Options > Stock Item Descriptions. 

• New Yes/No option "Description 3 is populated when adding new Stock Items".  

This will automatically populate the Description 3 field using the text that was entered into the Description 1 

field when creating new Stock Items. 

• New Yes/No option "Use Description 3 on Receipts/Invoices". 

This will use the Stock Item Description 3 on Receipts and A4 Customer Invoices. 

 

Possible Outcomes for the Description 1 and Description 3 fields after upgrading: 

 

• If the Yes/No Option "Use Stock Notes field for Long Descriptions" is enabled prior to upgrading, the Yes/No 

Option "Use Description 3 on Receipts/Invoices will be automatically enabled. 

• If the Yes/No Option "Use Stock Notes field for Long Descriptions" is enabled prior to upgrading, the 

Description 1 and Description 3 will be updated as follows: 

 

- If the Stock Item was created before the Yes/No Option "Use Stock Notes field for Long Descriptions" was 

enabled (and Stock Notes existed for the Stock Item), the contents of the Description 1 field will be reverted 

back to what was entered into the Description 1 field before the Yes/No option was enabled. The Description 

3 field will be populated with the first 100 characters from the Stock Notes field. 

 

- If the Stock Item was created before the Yes/No Option "Use Stock Notes field for Long Descriptions" was 

enabled (and Stock Notes did not exist for the Stock Item), the contents of the Description 1 field will remain 

unchanged and the contents of the Description 1 field will be copied into the Description 3 field. 

 

- If the Stock Item was created after the Yes/No Option "Use Stock Notes field for Long Descriptions" was 

enabled, the entire contents of the Description 1 field will be copied into the Description 3 field, then the 

contents of the Description 1 field will be truncated to 30 characters. 

 

• If the Yes/No Option "Use Stock Notes field for Long Descriptions" is disabled prior to upgrading, The 

Description 3 field will be populated with the text that has been entered into the Description 1 field. 

 

The Description 3/Long Description field can be accessed by going to:  

File > Stock Control > Stock Items > Select Item > Modify 
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Update the Long Description as required, then press the “Save” button on the bottom-right corner to save your 

changes. 

 

 
 

  



In addition to the Description 3 field being added to the Stock Items screen, it is also possible to search for Stock 

Items using this field via the Stock Items grid screen. 

To enable searching by the Description 3 field, go to: Setup > Users > Select User > Modify 

Then enable the checkbox next to the “Description3” field. 

Description3 is located under File Fields > Stock Items > Description3 

Press “Save” on the bottom-right corner to save the change. 

 

 
 

Close the Users screen. 
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In addition to enabling the new Description3 field in the Stock Items search/grid screen, it is also possible to modify 

the Descriptor/Label that is used for the Description2 and Description3 fields.  

By default, Description 2 will be set to “Kitchen Description” and Description 3 will be set to “Long Description”. 

The descriptor that you enter will appear in the Stock Items grid screen as well as in the Stock Item screen that is 

displayed when modifying a Stock Item. 

To adjust or modify the descriptor used for the Description2 and Description3 fields, go to: 

Setup > Global Options > Other Options > Stock Item Descriptions 

The below example shows the Description 2 set to “Bar Description” and Description 3 set to “Extra Details” 

 

 

 
 

  



After enabling the Description3 field in the Stock Item Search Grid and updating the descriptors for both Description 

fields, the changes will be visible by going to: File > Stock Control > Stock Items 

Items can be searched by entering text into either of the Description 2 or Description 3 fields. 

 

 
 

The column widths can also be adjusted in the Stock Items screen by clicking on the cog icon located on the top-left 

corner of the screen, then re-sizing the column widths as required: 

 

 
 

 
 

After the column widths have been re-sized, the Stock Items screen will need to be closed and opened again in order 

to continue using the Stock Items screen and to open or modify any item displayed in the grid. 
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When modifying a Stock Item, the new Descriptors that were configured for both the Description 2 and Description 3 

fields will be visible as per the below example: 

 

 
 

  



Full use of the Stock Notes field is now available, regardless of whether or not the Yes/No Option “Use Stock Notes 

Field for Long Descriptions” was enabled prior to upgrading to this build. 

When modifying a Stock Item, click on the Advanced tab to access the Stock Notes. 
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Total Stock Level on Stock Items by Location form 

This function enhances the Stock Items by Location form so that it displays the total Stock Level of an item across all 

Stock Locations. This is useful for customers who have Stock Items with a Stock Level across multiple locations, 

allowing them to see an overall total without them having to manually sum up the Stock Level for each location. 

 

There is no additional configuration required to enable this function; the User Interface has been updated and will be 

visible for all Users who access the Stock Items by Location screen. 

 

To access this function, go to: File > Stock Control > Stock Items 

Search for the Stock Item you want to enquire, then select it by clicking on it. 

After the item is highlighted, press the “Locations” button on the bottom-right corner of the screen. 

 

  
 

The Stock Items by Location for the selected Stock Item will be displayed. 

At the bottom of the window, you will see “Total Stock Level” along with the total Stock Level of all Stock Locations. 

 

  



Suppliers 

Supplier Enquiry to Allow for Filtering by Stock Location 

This function adds a Stock Location dropdown box to the Supplier Enquiry screen, adding the ability to filter the 

Supplier Enquiry by the selected Stock Location.  

The Supplier Enquiry screen is used to view a list or history of previous Invoices/Purchases that have been processed 

for either all suppliers or a specific Supplier Code.  

When Stock is received via Transactions > Stock Control > Stock Purchases, a Location option exists which can be used 

to receive the Stock Items from the Invoice/Order into the specified Stock Location.  

After those Invoices/Purchases have been processed, they will appear in the Supplier Enquiry screen.  

The option to filter the Supplier Enquiry by Stock Location can then be used to view the Invoices/Purchases that were 

received into the selected Stock Location. 

This function can be used by venues which have multiple Stock Locations and receive their Orders/Invoices into those 

Locations.  

 

To use this function, go to: Enquiry > Suppliers 

The Location dropdown box is located towards the top-right corner of the Supplier Enquiry screen. 

By default, the Stock Location dropdown box will default to a blank value, which will show Invoices that were received 

into all Stock Locations. The below example shows the Stock Location dropdown box in the default blank state, 

resulting in all invoices being displayed below. 

 

 
  



 Update History 
 

After selecting a Stock Location from the Stock Location dropdown box, the list of invoices displayed in the Supplier 

Enquiry will be filtered by the selected Stock Location. 

The below example shows a list of Invoices that were received into Stock Location 1 

  
 

The below example shows a list of Invoices that were received into Stock Location 2: 

  



User Permissions 

User Permission to modify Stock Item Grid Default Settings 

This function adds the ability to control whether or not a User has access to modify the Stock Item Grid Default 

Settings. Prior to the implementation of this function, Admin users were the only users who had access to this function. 

It is now possible to allow non-Admin users to configure the Stock Item Grid Default settings. 

The Stock Item Grid Default settings refers to configuring the layout that used to display Stock Items on the Stock 

Items grid (which is accessible via File > Stock Control > Stock Items).  

The layout includes column order, alignment, colours, etc. 

Note that all users will still share the same Stock Item Grid settings/layout, regardless of whether the permission has 

been enabled or disabled for the user. Therefore, it is suggested that only the users who are trusted or required to 

modify the Stock Item Grid Default Settings be given access to this function. 

 

To configure and use this function, go to: Setup > Users > Select a User > Modify 

In the below example, we’ll modify the STAFF User: 
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Expand File > Stock Control > Stock Items 

Enable “Default Settings”, then press the “Save” button on the bottom-right corner as indicated below: 

 

 
 

Close the Users screen, then go to File > Log Out 

Login as the User which the above change was applied to: 

 

 
  



Go to: File > Stock Control > Stock Items 

The top-left corner of the screen will contain a cog icon. 

Pressing this icon will allow configuration of the Stock Item Grid Default Settings. 

 

 
 

When the User permission to this function is disabled, the cog icon will simply not appear on the Stock Items screen. 

 

 
 

When the User has access to this function and the cog icon is pressed, the Stock Items screen will be changed to a 

modify grid mode which can be used to adjust the column widths, column order, text alignment, text colours, etc. 

Drag column headers to the desired location, adjust column widths by hovering the mouse over the vertical line 

separating the column headers and click/drag the column to the desired width.  
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Text alignment in each column can be adjusted by clicking on the column header, then pressing the alignment button 

repeatedly to adjust the text alignment to the desired setting. 

 

 

 

 
 

  



The colour for the text used in each column can also be adjusted by selecting the column header so that it is 

highlighted, then press the colour wheel and select a desired colour. 

The colour will be changed for the text shown in the selected column. 

This process can be repeated for each column as required. 

 

 
 

 
 

 
 

In order to return to the normal Stock Items grid view (non-modify mode), you will need to close the Stock Items 
screen and re-open it again via File > Stock Control > Stock Items.  
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The Grid can also be reset to Defaults by pressing the “Defaults” button at the top of the screen. 

 

 
 

A prompt will be displayed to confirm that you want to reset the grid to its default settings 

 

 
 

  



Yes/No Options 

Yes/No Option – 24 Hour Time Format for Kitchen Prints 

This function adds the ability to control what time format is used when printing dockets to the Kitchen. 

By default, this Yes/No option is disabled, meaning that all Kitchen Prints will be printed in the 12-hour format of 

am/pm. When this Yes/No option is enabled, all Kitchen Prints will be printed in the 24-hour time format. 

 

Previous to this change, all Kitchen Docket Formats would use the 24-hour time format, except for “Group Instructions 

by Seat” which would use the 12-hour time format. 

 

To configure this function, go to:  

Setup > Yes/No Options > Enter “24” into the “Enter Keyword Search” field. 

Enable “24 Hour Time Format on Kitchen Prints” to print the time in 24-hour format on Kitchen prints 

Disable “24 Hour Time Format on Kitchen Prints” to print the time in 12-hour am/pm format on Kitchen prints 

 

 
 

 

You may also want to review your Kitchen Docket format and Printer Names, then make any adjustments as necessary. 

This can be done by going to: Setup > Global Options > Printing > Print Formats/Kitchen Printer Names 
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Kitchen Printers are configured via Setup > Network Printers 

Make any adjustments as necessary. Printers can be modified by selecting the required printer, then pressing the 

Modify button. 

Controlling which printer each POS uses is configured at the bottom of the Network Printers screen and can be 

updated by dragging the required printer from the top of the Network Printers screen into the grid at the bottom of 

the screen. 

 

 
 

Kitchen Printing is controlled per-Stock Item. 

Go to: File > Stock Control > Stock Items > Select the Item > Modify 

Under Printer Settings, ensure that you have the required Kitchen Printers enabled for the Stock Item. 

The first printer in the list is always the Receipt Printer, and the other printers in the list are either Kitchen or Bar 

printers as configured in the above steps. 

 

 
  



Go to the POS Screen, then add items which are configured to print to Kitchen and/or Bar Printers. 

 

 
 

Press the “TABLE MAP” button, then select a table from the list to save the items to the selected table. 

The Kitchen Docket will print at the Kitchen Printer. 

The example on the left shows the Kitchen Docket with the Yes/No “24 Hour Time Format for Kitchen Prints disabled, 

and the example on the right shows the Kitchen Docket with the Yes/No option enabled. Both were produced with the 

Kitchen Docket Format set to Group Instructions by Seat. 
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Dry Cleaning Receipt on Second Receipt Printer when Tabs 

This option will work when the Dry Cleaning Tabs are printed on Receipt Printer 2. If Tabs exist for this transaction, 

then the Receipt will also print on Receipt Printer 2. 

 

To enable this option, go to: Setup > Yes/No Options 

Enter Keyword Search: “Dry” 

Enable the option “Dry Cleaning Receipt on Second Receipt Printer when tabs” 

You will also need to ensure that “Dry Cleaning Tabs print on Second Receipt Printer” is enabled for this to work. 

 

 
 

Printers are configured in: Setup > Network Printers 

After configuring the second printer, leave it at the top of the network printers screen and don’t drag it to a column at 

the bottom. 

After the second receipt printer has been configured in Network Printers, you can specify which printer you want to 

use as the Second Receipt Printer by going to: Setup > POS Terminals > Modify > Receipt Printer 

Ensure that you enable the checkbox “Use Second Receipt Printer” 

 

 



Receipt Tabs for a Dry Cleaning Item are configured in File > Stock Control > Stock Items > Select Item > Modify 

When modifying the Stock Item, click on the Advanced tab and ensure that the number of tabs required have been 

entered in the Receipt Tabs field: 

 

 
 

When adding any Stock Items to a sale which have a value specified in the Receipt Tabs as shown above, the Receipt 

will only be printed to the Second Receipt Printer. 

As most Dry Cleaning establishments will charge the customer only after the garments have been cleaned, the 

customer will pay for their Dry Cleaning when picking up their garments.  

Therefore, when the customer picks up and pays their account, the final payment receipt will be printed to the first 
receipt printer. 
For more information about using Dry Cleaning features, refer to the Dry Cleaning topic in the User Guide.  

https://userguide.idealpos.com.au/#Dry Cleaning/Dry Cleaning.htm
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Fast Pending Sale Function 

This function adds the ability to bypass the Pending Sale Save screen. This allows the pending sale to be saved 

automatically without any additional user input. This function may be useful when used with the Kiosk module or when 

additional details for the Pending Sale are not required.  

When enabling this function, the “Auto Generate Pending Sale Codes” option must also be enabled which is outlined 

in the below steps. 

 

To configure and use this function, go to: Setup > Yes/No Options 

Enter Keyword Search: “Fast Pending” then enable the “Fast Pending Sales” Yes/No option 

 

 
Close the Yes/No options window.  

 

If required, you may want to change the description for Pending Sales. 

By default, a description of “Table” will be used, but this can be changed by going to: Setup > Function Descriptors. 

Find the “Pending Sale” function in the list, select it, then press the “Modify” button on the bottom-right corner of the 

screen. 

Enter a description that you want to use for the Pending Sales function. This description will be included at the top of 

any Pending Sale receipts. Press the “Save” button on the bottom-right corner of the window. 

 

 



When saving a Pending Sale, Idealpos needs to be able to generate a code automatically.  

Therefore, Auto Generate Pending Sale Codes must be enabled. 

To enable this setting, go to: Setup > Global Options > Sales > Pending Sales. 

Enable “Auto Generate Pending Sale Codes” under the Pending Sales section. 

Whilst on this screen, you may also want to adjust the behaviour for printing Pending Sales. 

 

Information about the behaviour of the checkboxes and options available in Pending Sales is shown below: 

 

Printed Pending Sales are sent to Receipt Printer - When this option is enabled, any Pending Sales that are printed 

will also be sent to the Receipt Printer and will be printed in the format of a 'bill'.  

In order for this option to take effect, the "Print to Docket Printers" option must be enabled. 

Printed Pending Sales are sent to Windows Printer - When this option is enabled and the Yes/No option 

"Automatically Print to Kitchen" is disabled, a Pending sale that is saved to a Table will be sent to the Windows Printer 

when selecting the Table from the Table Map and pressing the "Kitchen" button.  

Auto Generate Pending Sale Codes - When this option is enabled, Idealpos will automatically generate a Pending 

Sale Code when creating the Pending Sale. This option must be enabled for the Fast Pending Sale function. 

Inhibit Amounts on A4 Windows Prints - When this option is enabled, any amounts such as the Unit Price, Amount 

and Total Amount will not be printed on A4 Windows Prints of the Pending Sale 

Print to Docket Printers - When this option is enabled, Idealpos will send the Pending Sale to the Kitchen printers 

after the Pending Sale has been saved. Note that in order for this to happen, the Stock Items added to the Pending 

Sale must also be configured to print to Kitchen Printers. If required, update/configure any Stock Items that need to be 

printed to a Kitchen Printer by going to: File > Stock Control > Modify. Enable any Kitchen/Bar Printer checkboxes as 

required. 

Print to Windows Printer - When this option is enabled, Idealpos will send the Pending Sale to the Windows printer 

after the Pending Sale has been saved. 
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When saving Pending Sales, Idealpos will automatically generate a Pending Sale code from a pre-configured range. 

The range can be configured/modified by going to: Setup > POS Terminals > Select Terminal > Modify 

Go to the Miscellaneous Settings tab, then adjust the Pending Sales From/To field with the code range that you want 

Idealpos to use when saving a Pending Sale. Codes are assigned in chronological order and once the code range has 

been exhausted, Idealpos will restart assigning pending sale codes from the beginning of the entered range.  

 

 
 

  



Before the Pending function can be used, a button must also be configured on the POS screen if it doesn’t exist 
already. 
Go to: Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons 
Find a blank POS Screen button and click on it, then configure as follows: 
 

 
 

After the PENDING button has been created, close the POS Screen Layout windows. 

 

To ensure that any changes to the Pending Sales options have taken effect, Idealpos will need to be restarted.  

Close the Idealpos Suite via IPS Utils. 

Go to: Start > Idealpos > IPSUtils > Enable the “Close IPS Utility” checkbox then press the “Close” button 
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Start Idealpos either via the Idealpos icon on the desktop, or click on Start > Idealpos > Idealpos 

Go to the POS screen, add items to the sale, then press the “PENDING” button 

 

 
 

The sale will be cleared and the POS screen will be ready for the next sale/transaction. 

The Pending Sale receipt will also be printed if configured to do so as per the settings in:  

Setup > Global Options > Sales > Pending Sales 

The top of the Pending Sale will show the Pending Sale descriptor followed by the code assigned to the Pending Sale. 

 

 
  



To resume the Pending Sale, press the PENDING button on the POS Screen, select the Pending Sale from the list, then 

press OK. 

 

 
 

The items in the Pending Sale will be added to the sale. If required, additional items can be added to the sale, then the 

sale can be finalised by pressing the ENTER button and selecting a Tender Type/Amount. 

 

 


