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Digital Receipts  
IP-3493 – Slyp Digital Receipt – Yes/No Options 

This function adds the ability to adjust the behaviour of Slyp Digital Receipt Prompts via additional Yes/No Options. 
In order to use Slyp Digital Receipts, you must have this interface configured and enabled. 
More information about configuring and using the Slyp Interface is available in the Idealpos User Guide. 
 
The new Yes/No Options for the Slyp Digital Receipt interface are as follows: 
 

• Slyp Digital Receipts for Customer Sales Only – Enabling this option causes the Slyp Digital Receipt prompt 
to only be triggered on Customer Sales (i.e. will only be triggered when a Customer has been added to the 
sale). When the prompt is triggered, the SMS and Email fields will be automatically populated using the 
data that has been configured for the Customer which has been added to the sale. 
In order for this option to apply to a POS Terminal, the Yes/No Option “Slyp Prompt for Digital Receipt” 
must also be enabled for the same POS Terminal. 
 

• Slyp Prompt for Digital Receipt – This option gives the ability to turn the Slyp Digital Receipt prompt on/off 
by POS Terminal. In the initial implementation of the Slyp Digital Receipt Interface, the Slyp prompt would 
appear for all POS Terminals. By using this option, the prompt can be toggled on/off based on POS 
Terminal Number.  
Note that you must have “Prompt for Digital Receipt” enabled in Global Options > Interfaces > Slyp in order 
for this Yes/No Option “Slyp Prompt for Digital Receipt” to take effect and apply to the selected POS 
Terminal numbers. 

 
To configure and use these Yes/No Options, go to: Setup > Yes/No Options > Enter Keyword Search: slyp 
 

 
 
  

https://userguide.idealpos.com.au/#Digital%20Receipts/Slyp/Slyp.htm
https://userguide.idealpos.com.au/
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IP-3087 – EBT Food Stamp Support 
This function adds the ability to configure Idealpos for handling EBT Food Stamps. 
EBT (Electronic Benefit Transfer) Food Stamps are used by welfare recipients as a means to purchase their Food 
and Groceries using funds supplied by the Government body which is responsible for welfare. 
EBT Food Stamps are only permitted to be used for purchasing items which are permitted (Groceries, Food, etc.) 
and are restricted from being used to purchase Alcohol, Tobacco and other prohibited items. 
 
Note that the process for enabling EBT Food Stamps uses similar steps outlined under Special Item Subtotal 
Functionality. However, it should be noted that the steps documented for setting up Special Item Subtotal 
functionality differ slightly to the steps involved for enabling EBT Food Stamp Support in that they are reversed. 
E.g. For EBT Food Stamp Support, any Stock Items which are eligible for purchase using an EBT Food Stamp (such as 
Standard Groceries, Meals, etc.) will be assigned to the Attribute Type “EBT Food Stamp Items” and will have the 
Attribute set to “Yes”. 
Whereas the process that is documented for setting up Special Item Subtotal/PLBPOS Interface involves creating a 
“Restricted Items” Attribute Type, then assigning Restricted Items such as Alcohol to the Restricted Items Attribute 
Type. 
 
As the process required to setup/use EBT Food Stamps is too lengthy for inclusion in the Update History, the entire 
setup and usage of EBT Food Stamps is available in the Idealpos User Guide via the below links: 
For information about setting up EBT Food Stamps, click here. 
For information about using EBT Food Stamps, click here. 
 
It should also be noted that the process which outlines the configuration of EBT Food Stamps does not include any 
integration with third-party hardware or software. It is used as a means to assist the Clerk by showing the Subtotal 
amount of items in a sale which are eligible for purchase using EBT Food Stamps. The Subtotal is shown on the final 
Tender Screen.  
 
The below example shows the Tender screen with EBT Food Stamp Items being the Pizza Stock Items. 
The Item which is not eligible for EBT Food Stamp use is the HAHN LIGHT PACK Stock Item in the below example. 
 

  

https://userguide.idealpos.com.au/#EBT%20Food%20Stamps/Configuring%20EBT%20Food%20Stamp.htm
https://userguide.idealpos.com.au/#EBT%20Food%20Stamps/Using%20EBT%20Food%20Stamp%20Functionality.htm
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EFTPOS 
IP-1345 – Support for PC-EFTPOS Pinpad Surcharges 

This function adds the ability for Idealpos to handle Surcharge Amounts being sent from the PC-EFTPOS (PC-
EFTPOS Australia only) Pinpad back to Idealpos. When a pinpad surcharge is received by Idealpos, the surcharge will 
be recorded against the Undistributed Surcharge Stock Item that’s configured in:  
Setup > Global Options > Sales > Undistributed Links > Surcharges.  
Therefore, you will need to ensure that you have configured your Undistributed Link for Surcharges. 
Any surcharges that are received will be recorded and can be reported on via Idealpos Reports which are accessible 
via the Reports menu from the Back-Office Dashboard. 
 
To set the Undistributed Surcharge Link for Surcharges, go to: 
Setup > Global Options > Sales > Undistributed Links > Surcharges 
 

 
 
The number displayed in the Surcharges field refers to the Stock Item Code that the Surcharges are linked to. 
If your Surcharges field is blank or if it is linked to the wrong Stock Item, press the “>” button within this field. 
This will open the Stock Items search screen where you can either select another Stock Item or create a new Stock 
Item to link the surcharges to.  
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Export Data 
IP-3459 – Export Stock Items – Option to export specific location Stock Level 

This function adds the ability to export the Stock Level of selected Location(s) in the export data file. 
This option can be selected for both “Specific Fields by Range” (perform a manual export at any time) as well as 
“Automatic Export Format” (the selected Stock Location Levels will be included in each subsequent Stock Item 
Export that is triggered automatically via the Automatic Export. 
 
To configure and use this function, go to: 
Back-Office Dashboard > Utilities > Export Data > Stock Items 
 
To configure the fields that will be included in the export file and export Stock Items immediately without waiting 
for the Automatic Export to take place, select the “Specific fields by Range” from the Export dropdown box: 
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If you already have a default format saved, the dropdown boxes may be pre-filled. 
You will require at least one unused field in order to export a specific location Stock Level. 
If all of the 24 fields are configured, you will need to choose an existing field which is least required and change it to 
export the required Stock Location level as required. 
 
All the Locations that are available will be shown in the dropdown box. 
Select the required location(s) from the dropdown box(es). 
 

 
 
If you want to save the selection as default (so that next time you open the Export Stock Items window, it will be 
pre-filled with the same selection as you currently have), press the “Save as Default” button on the bottom-left 
corner of the window. 
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To export the Stock Items immediately using the current selection, press the “OK” button on the bottom-right 
corner of the window. 
 

 
 
Once the Export has been completed, the following prompt will appear: 
 

 
 
 Stock Items will be exported to the Export Folder configured in the Export Stock Items window above. 
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Note that in the Export file, the Location 1 header will simply show STKLEVEL. If Locations other than 1 have been 
selected, the location header will show STKLEVEL#, where # indicates the number of the Location. 
The below example demonstrates this: 
 

 
 
In addition to exporting Stock Items manually via the “Specific Fields by Range” option, you also have the ability to 
specify Stock Location Levels for the Automatic Export Format. 
From the Export Items screen (Utilities > Export Data > Stock Items), select the “Automatic Export Format” from 
the Export dropdown box.  
Then you will need to configure the required fields similar to the above process by selecting the Stock Locations 
from the available dropdown boxes, then press “Save Format” once completed. 
This format will be used when the Stock Items are exported Automatically at the time configured in:  
Setup > POS Terminals > Modify > Import/Export > Automatic Export Settings 
Also ensure that “Use Saved Automatic Export Format” is ticked in the above Automatic Export Settings.  
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IP-3441 – PLBPOS Interface 
The PLBPOS Interface (Product Level Blocking Point Of Sale) is used for restricting Stock Items from being 
purchased by specific Card Types which are typically issued by the Government for welfare recipients. An example 
of this Card Type is a CDC (Cashless Debit Card) and are identified by Idealpos via the Card Prefix assigned to the 
card. 
Items that are usually restricted from purchase by the CDC Card is Alcohol and Gift Cards (welfare recipients may 
attempt to purchase a gift card which can be later used to purchase Alcohol and restricted items). Note that 
restricted items are determined by the Government body and may be subject to change in the future as defined by 
the Government body. 
 
As the process for configuring this interface is quite involved and excessive for the Update History document, 
please refer to the PLBPOS Interface topic in the Idealpos User Guide for more information about setting up this 
interface. 
In summary, the steps involved to configure this Integration are as follows: 
 

• License PLBPOS Interface – The PLBPOS Interface module must be enabled in your Licence Gateway for 
each POS Terminal that will require this interface 

• Create Stock Item Attribute Type/Attribute – Items that are assigned to the Attribute Type/Attribute will 
be restricted from purchase using CDC Card Types 

• Enable Restricted Items in Global Options – The Restricted Items Attribute Type must be selected in Global 
Options 

• Enable PLBPOS Interface in Global Options – The PLBPOS Interface checkbox must be enabled, along with 
the entry of your Tenant ID and CDC Prefixes and enable Enforce Restrictions 

• Configure a Restriction Override POS Screen Button 
• Configure User/Clerk Permissions to access the Restriction Override function 
• Enable Show Special Items Subtotal in Yes/No Options 
• Assign Items to Restricted Item Attribute Type 

 
As outlined above, please refer to the PLBPOS Interface topic in the Idealpos User Guide for further information 
about setting up and using the PLBPOS Interface.  

https://userguide.idealpos.com.au/#PLBPOS%20Interface/PLBPOS%20Interface.htm
https://userguide.idealpos.com.au/#PLBPOS%20Interface/PLBPOS%20Interface.htm
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POS Screen 
IP-3442 – Special Item Subtotal Functionality 

This function adds the ability to enable a secondary Subtotal amount on the Idealpos Tender Screen which will be 
used to display the Subtotal amount of Stock Items in the sale which have been assigned to a specific Stock Item 
Attribute.  
This is a supplementary function for use with Payment Integrations that restrict the types of Stock Items customers 
are permitted to purchase (e.g. Government Supplied Benefit Cards which prevent the Customer from purchasing 
Alcohol, Tobacco or Gambling Items). 
Currently, this function can be used with the below systems: 

• EBT (Electronic Benefit Transfer) Food Stamp Items 
• PLBPOS (Product Level Blocking Point of Sale) Restricted Items 

 
When configuring this function, you would typically assign Stock Items which are restricted from being purchased 
using the EBT Food Stamp to a Stock Item Attribute. Any of these items which exist in the sale will be summed up 
under their own Subtotal amount. The main Subtotal amount will also be displayed and will show the Subtotal 
amount of all Stock Items in the sale, inclusive of the Restricted Items. 
 
To configure and use this function, go to: File > Sales > Stock Item Attributes 
Press the “Add New Attribute Type” button on the bottom-left corner of the window, enter a name for the 
Attribute Type then on the bottom-right corner of the window, press the “Save” button. 
Typically, the name for the Attribute Type will be “Restricted Items”, however, the choice is entirely yours and is 
only used for descriptive/labelling purposes. 
For this example, we will enter “Restricted Items”. 
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Press the “X” button on the top-right corner of the window to close the “Add Attribute Type” window. 
Select the Attribute Type “Restricted Items” from the left-hand side list, then press the “Add New Restricted Items” 
button on the bottom-right corner of the window. 
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Enter “Yes” into the “Add Restricted Items” field, then press “Save” on the bottom-right corner of the window. 
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Enter “No” into the “Add Restricted Items” field, then press “Save” on the bottom-right corner of the window. 
 

 
 
After saving the Attributes, close the Add Attribute window by pressing the “X” button on the top-right corner of 
the window. Press the “X” button again to close the Stock Item Attributes window. 
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The newly created “Restricted Items” Attribute Type needs to be selected in Global Options. 
Go to: Setup > Global Options > Other Options > Special Attribute Types 
From the Special Item Subtotal dropdown box, select “Restricted Items” (or select the name entered during the 
previous step above). 
If configuring this function as part of the PLBPOS Integration, ensure that you configure the email settings. These 
will be used for emailing logs to Idealpos if there are any communication issues with the Central Platform (DXC 
Web Server). The email settings shown below are only for demonstration purposes. Refer to the company you’re 
receiving your email service from for more details about setting up Email settings. These are typically similar 
settings that you’d enter into your email client application to receive emails. 
 

 
 
Ensure that the Yes/No Option “Show Special Items Subtotal” is enabled. 
Go to: Setup > Yes/No Options > Enter Keyword Search: Special 
By default, this option should be enabled, however, if it isn’t, enable “Show Special Items Subtotal” as per the below 
example: 
 

 
 
Close the Yes/No Options window.  
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Stock Items need to be assigned to the Attribute Type. 
We recommend using Range Programming to set all Stock Items as “Restricted Items” and set to “No”, then update 
all Stock Items that are Restricted Items by changing the “No” Attribute to a “Yes” Attribute. 
When setting all Stock Items as Restricted Items – No, you will need to locate an unused Attribute Type slot. If 
performing Range Programming on all Stock Items and selecting a used Attribute Slot, it will be overwritten using 
the selection made during Range Programming. 
To minimise any clashes, you can choose to use Attribute 5 (which is the last available Attribute in the Attribute 
List), however, we still recommend that you ensure this Attribute Slot is not in use across all your Stock Items to 
avoid overwriting any existing data that’s stored in this Attribute Slot. 
 
We strongly recommend that extreme caution be exercised when using Range Programming. 
Leaving all Stock Item criteria (Code, Description, Department and Supplier) on the Range Programming window as 
blank and setting values for the selected field(s) will result in those fields being updated for all Stock Items in the 
system. 
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Once all Stock Items have been set to Restricted Items – No, any items that need to be marked as Restricted Items – 
Yes can be done using either of the two following methods:  
 

• Manually searching for the individual Stock Items via File > Stock Control > Stock Items > Select Stock Item > 
Modify > Update the Stock Item Attributes as required > Save 
This method can be used if you have a select small number of items that need to be restricted. 
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• Use Range Programming to perform a mass-update on an entire range of items. 
Go to: Utilities > Range Programming > Stock Items 
This method is useful for updating a large number of Stock Items all at once. This can be used if all items in 
a specific Department, Category or range of Stock Item Codes all need to have the same Stock Item 
Attribute assigned. Note that when using Range Programming, any values entered into the fields will be set 
for all Stock Items that exist in the entered range at the top of the Range Programming window. 

If data already exists in a Stock Item for the selected field chosen in the Range Programming window, it will be 
overwritten with the value entered in the Range Programming window.  
 
We strongly recommend that extreme caution be exercised when using Range Programming. 
Leaving all Stock Item criteria (Code, Description, Department and Supplier) on the Range Programming window as 
blank and setting values for the selected field(s) will result in those fields being updated for all Stock Items in the 
system.  
 

 
 
After Stock Items have been updated using either one or both of the above methods, the function is ready to be 
used. 
Restart Idealpos by going to Start > Idealpos > IPSUtils > Close. 
Start Idealpos either via the Idealpos desktop shortcut, or by going to Start > Idealpos > Idealpos 
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Go to the POS Screen and add Stock Items to the sale which have been assigned to the above Attribute Type as well 
as Stock Items which do not have the above Attribute Type assigned. 
Press “ENTER” to go the Tender screen. 
The Tender Screen will show the Stock Item Attribute Type description on the Tender screen with the subtotal of all 
Stock Items contained in the sale which are assigned to this Attribute Type and have the “Yes” Attribute selected. 
The main Subtotal will also be displayed and will be a sum of all items in the sale, inclusive of the Restricted Items. 
 

 
 
If you want to be able to filter the Stock Items screen by the Attribute Type, this can be achieved by performing 
extra configuration steps which can be found in the User Guide by clicking here. 
 
Filtering Stock Items in the Stock Items screen based on the above Attribute Type is also outlined in the User Guide. 
Click here for more information about using the Stock Items filter with this function. 

https://userguide.idealpos.com.au/#Special%20Item%20Subtotal/Configuring%20Special%20Item%20Subtotal.htm%23Configure_Stock_Items_screen_to_show_Attribute_Type_Filter
https://userguide.idealpos.com.au/#Special%20Item%20Subtotal/Using%20Special%20Item%20Subtotal.htm%23Filtering_Stock_Items_by_Special_Item_Attribute_Type

