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Docket Printing 

IP-4583 – Option to print Receipt QR Code data on A4 Tax Invoice 

This function adds the ability to print Receipt QR Code data on an A4 Tax Invoice. 

QR Code data can be configured to include a link to the website of your business and/or embed additional data. 

 

To enable this function, go to: Back Office > Setup > Global Options > Printing. 

Enable the checkbox “Print on A4 Tax Invoice”. 

Note that the QR Code Size setting is only used for standard receipt printing and does not affect the QR Code size that 

is printed on A4 Tax Invoices. 
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You will also need to enter some data to embed into the QR Code. 

If a URL is entered into the Receipt QR Code data field (e.g. https://www.idealpos.com.au) and the resulting QR Code is 

scanned using a smartphone or tablet device, a prompt will be displayed, enabling the customer to click on it to go to 

the website.  

If you wish to embed any additional data into your QR Code, enter any of the following tags into the Receipt QR Code 

Data field. Each tag can be entered on a new line, and you may also want to add a description before the tag. 

E.g. Cust Code:[CUSTOMERCODE] 

 

By doing this, the text “Cust Code” will appear before the actual Customer Code. 

 

[DATE] – The date of the sale 

[CUSTOMERCODE] – This will embed the Customer Code into the QR Code. 

[CUSTOMERNAME] – This will embed the Customer’s Name into the QR Code. 

[TAX] – The Tax amount will be embedded into the QR Code. 

[AMOUNT] – The total amount for the sale will be embedded into the QR Code. 

[ddMMyy] – This will embed the date into the QR Code using a short date format of ddMMyy.  

E.g. 010921, where dd is the day of the month, mm is the month number and yy is the year. 

 

An example of the above tags entered in the Receipt QR Code Data field are shown below: 

 

 
 

A QR Code will be generated and displayed at the bottom of an A4 Tax Invoice: 
 

  
 
When scanned, a result such as the below will be displayed on a smartphone or tablet device: 
 

 
  

https://www.idealpos.com.au/
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Depending on your requirements for producing A4 Tax Invoices, you have a few options: 

 

• Enable the Yes/No Option “Automatically Print A4 Invoice after each sale” and an A4 Tax Invoice will be 

printed after each sale (and will include the QR Code configured above). If required, you can instead choose to 

only issue A4 Tax Invoices only for Customer Sales. To do this, leave the “Automatically Print A4 Invoice after 

each sale” unchecked, and instead, enable the Yes/No Option “Print A4 Invoices only for Customer Sales”. 

• Leave the above Yes/No Option disabled, and instead, manually generate an A4 Tax Invoice as required via the 

Journal History Enquiry. 

 

Each of these options are outlined as follows: 

 

To produce an A4 Tax Invoice for each sale (or only for Customer Sales), go to: Back Office > Setup > Yes/No Options. 

Enter “A4” into the search field, then enable “Automatically Print A4 Invoice after each sale”. 

 

 
 

If you only want to issue A4 Invoices to Customer Sales, then leave the above Yes/No Option unchecked, and instead, 

enable “Print A4 Invoices only for Customer Sales”. 
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If “Automatically Print A4 Invoice after each sale” was enabled, the resulting A4 Invoice will be printed automatically to 

your default Windows Printer for each sale that is completed. 
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If “Print A4 Invoices only for Customer Sales” was enabled, an A4 Invoice will only be printed when a Customer has 

been added to the sale. 
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To manually produce an A4 Tax Invoice, go to:  

Back Office > Enquiry > Journal History 

From the list of Journals, select the sale, then press the “Tax Invoice” button on the left-hand side of the window. 
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The Tax Invoice will be printed to the default Windows Printer. 
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EFTPOS 

IP-4524 – Nitro NZ EFTPOS – Support for Pinpad Surcharges 

This function enables Idealpos to handle Surcharge Amounts being sent from the Nitro NZ EFTPOS Pinpad back to 

Idealpos.  

To adjust the surcharges being applied by the pinpad, please refer to your bank or Nitro NZ EFTPOS for further details. 

You may also be able to configure surcharges yourself by opening the Nitro NZ EFTPOS Client > Ctrl Panel > 

Surcharge tab > Enable Surcharge and configure the Surcharge Type and value (see steps further below for more info). 

When a pinpad surcharge is received by Idealpos, the surcharge will be recorded against the Undistributed Surcharge 

Stock Item that’s configured in: Back Office > Setup > Global Options > Sales > Undistributed Links > Surcharges. 

 

Therefore, you will need to ensure that you have configured your Undistributed Link for Surcharges. 

Any surcharges that are received will be recorded and can be reported on via Idealpos Reports which are accessible via 

the Reports menu from the Back-Office Dashboard. 

 

To set the Undistributed Surcharge Link for Surcharges, go to: 

Back Office > Setup > Global Options > Sales > Undistributed Links > Surcharges 

 

 
 

The number displayed in the Surcharges field refers to the Stock Item Code that the Surcharges are linked to. 

If your Surcharges field is blank or if it is linked to the wrong Stock Item, press the “>” button within this field. 

This will open the Stock Items search screen where you can either select another Stock Item or create a new Stock Item 

to link the surcharge to. 

 

For a more in-depth step-by-step set of instructions on setting up Undistributed Links, click here to visit the topic in 

the Idealpos User Guide. 

https://userguide.idealpos.com.au/Content/Global%20Options/Sales.htm#Undistributed_Links
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You might also be able to configure the surcharges yourself by following the below steps, however, if your system 

differs or if you are unable to configure these surcharges yourself, please refer to Nitro NZ EFTPOS or your bank for 

further assistance.  

 

From the Windows System Tray, open the Client icon. This will typically show a green “C” when the pinpad is online 

and successfully communicating with your terminal. 

 

 
 

Select “Ctrl Panel…” 
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Select the Surcharge tab > Enable checkbox “Enable Surcharge”. 

 

 
 

Click on each Card Type and configure the surcharge amount > Press “OK” to save your change. 

WARNING – Entering excessive rates may be in breach of surcharging guidelines set out by your bank. 

Refer to Nitro NZ EFTPOS or your bank for further details. 

 

 
 

Once configured, you may need to restart your POS Terminal for these changes to take effect. 
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IP-4525 – Nitro NZ EFTPOS – Support for Pinpad Tips 

This function adds support for Pinpad Tips to the Nitro NZ EFTPOS Integration in Idealpos. 

When tipping is enabled in Nitro NZ EFTPOS and a sale is tendered, the Pinpad will display a prompt asking the 

customer if they would like to apply a tip to the sale. They will typically see several pre-configured percentage 

amounts to tip; the amounts for each percentage tip are calculated based on the sale amount being tendered. 

The customer can then press a number that corresponds to the percentage they want to tip. 

 

To enable and adjust the tipping options displayed by the pinpad, please refer to your bank or Nitro NZ EFTPOS for 

further details. 

You may also be able to enable and adjust the tipping options yourself by opening the Nitro NZ EFTPOS Client > Ctrl 

Panel > Tipping tab > Enable Tipping Options and configure the Tipping Options (see steps further below for more 

info). 

 

Any tips that are collected as part of the tipping function will be recorded against the TIPS IN Received Account 

function. 

 

To ensure that Idealpos is configured correctly for recording tips collected as part of this function, go to: 

 

Back Office > Setup > Function Descriptors 

Ensure that one of your RECEIVED ACCOUNT Function Descriptors are configured for TIPS IN. 

If you don’t have a RECEIVED ACCOUNT Function Descriptor allocated to TIPS IN, select an unused RECEIVED 

ACCOUNT Function Descriptor and press Modify. 

Typically, unused Received Account Function Descriptors will be labelled as RA 1 to RA 4; the number in the 

description will correspond to the number of the Received Account. 

 

Enter TIPS IN into the Description field, then press “Save”. 
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Close the Function Descriptors window, then go to: 

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify. 

 

Within the EFTPOS Settings tab, ensure that the “Enable Integrated EFTPOS post-transaction Tips” is enabled. 

Also ensure that the “Function to Use” is set to the “TIPS IN” Received Account function that was configured in the 

previous step. 

 

 
 

Close the POS Terminals window to save the changes to the POS Terminal. 

Ensure that each POS Terminal which uses Nitro NZ EFTPOS has the “Enable Integrated EFTPOS post-transaction Tips” 

option enabled and has the TIPS IN Received Account Function selected; repeat the above step as necessary for each 

POS Terminal. 

 

Once configured, we recommend restarting Idealpos on each POS Terminal to ensure that the setting has been 

applied. 
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You might also be able to enable and configure the tipping options displayed by the pinpad yourself by following the 

below steps, however, if your system differs or if you are unable to configure these tipping options yourself, please 

refer to Nitro NZ EFTPOS or your bank for further assistance. 

 

From the Windows System Tray, open the Client icon. This will typically show a green “C” when the pinpad is online 

and successfully communicating with your terminal. 

 

 
 

Select “Ctrl Panel…” 
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Select the Tipping tab > Enable Tipping Options. 

Configure the pre-set Tipping Option percentages, then press “Apply” to save your change. 

You may need to restart your POS Terminal for these changes to take effect. 
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IP-4561 – PC EFTPOS NZ – Option to not automatically print EFTPOS receipt 

This function adds the ability to control whether Idealpos will automatically print an EFTPOS Receipt when Receipts are 

turned off when using the PC EFTPOS NZ Integration. 

 

To configure this function, go to: 

Back Office > Setup > POS Terminals > Select Terminal > Modify > EFTPOS Settings 

Toggle the checkbox “Don’t automatically print EFTPOS Receipt when Receipts turned off”. 

When this option is enabled/checked, Idealpos will not automatically print an EFTPOS Receipt when Receipt printing is 

turned off. 

When this option disabled/unchecked, Idealpos will automatically print an EFTPOS Receipt when Receipt printing is 

turned off. 
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Receipt Printing can be toggled on each POS Terminal via the Receipt On/Off function. 

Ensure that a button on your POS Screen has been linked to the “Receipt On/Off” function. 

A button to turn the Receipt On/Off can be added to the POS Screen by going to:  

Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 

 

Select a POS Screen tab where you want to create the button, then within the tab, locate an unused button and 

configure as follows: 

 

 
 

Once the button is configured, close the POS Screen Layout windows, and go to the POS Screen. 

Navigate to the POS Screen tab where the button was created. 

The button text will change based on whether Receipt Printing is currently turned on or off. 
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Gift Vouchers  

IP-4539 – Wildcard search support for Gift Vouchers 

This function adds the ability to use wildcards when performing a Gift Voucher Enquiry – Name Search. 

When a Gift Voucher Enquiry – Name Search was performed on older versions of Idealpos before this change, you had 

to search for the customer by entering their first Name, then last name which would display any customers in the 

system which match the entered name and have a Gift Voucher. 

 

With this change, you can now enter any portion of the Customer’s name and Idealpos will show any customers that 

have a Gift Voucher and match the entered characters. 

 

There is no configuration required to enable Wildcard search support for Gift Vouchers nor is there any requirement to 

enter a leading character to perform a wildcard search. It is simply a matter of entering a portion of the Customer’s 

name and any matching results will be displayed. 

 

In order to demonstrate this function in the below steps, you will need: 

Gift Vouchers that have been sold but not redeemed 

Gift Voucher button (to sell Gift Vouchers) 

Gift Voucher Enquiry button (to perform the Gift Voucher – Name Search function using the new wildcard function) 

 

It is assumed that your system is already configured for Gift Vouchers. 

If not, please refer to the Gift Vouchers topic in the User Guide for more details. 

 

To use wildcard name search, go to: POS Screen. 

Press the “Gift Voucher Enquiry” button on your POS Screen. 

 

 
 

Within the Gift Voucher Enquiry window, press the “Name Search” button. 

 

 
 

  

https://userguide.idealpos.com.au/Default.htm#Gift%20Vouchers/Gift%20Vouchers.htm
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The Gift Voucher Name Search window will appear. 

In the “Enter Name” field, start entering a customer’s name. 
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You can enter any portion of a customer’s name and any names which contain the entered text will be displayed. 

E.g. Entering “enny” will display Jenny and Penny as shown in the example below. 

There is no requirement to enter an asterisk or any special character to initiate the wildcard search functionality. 

Once you find the required customer, select the Customer’s name from the list on the right-hand side, then press the 

“Use” button on the bottom-right corner of the window. 
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Interfaces 

IP-4516 – Idealpos Online Ordering – Option to link orders to Table Map 

This function adds the ability to automatically link orders received via the Deliverit eCommerce Integration to a Table 

on the Table Map. 

Typically, a venue utilising this integration will have a Table Number displayed at each Table as well as a QR Code. 

When the customer scans the QR Code shown at the table using their smartphone, they will be prompted to enter the 

Table Number they’re seated at, then the customer will select the items they want to order. 

The customer will then need to enter their details (Name, Mobile Phone Number, etc.), then pay for the order on their 

smartphone device using one of the payment options displayed on-screen.  

Once these steps have been completed, the order will be sent to the Kitchen and the items that were ordered by the 

customer will be automatically saved to the table where they’re seated at. 

 

To configure and use this function, go to: 

Back Office > Setup > Global Options > Interfaces > eCommerce. 

 

Enable the option “Enable Web Orders to be linked to Table Map”. 

We also strongly recommend that you enable the option “Automatically Finalise Prepaid Orders”. 

 

Automatically Finalise Prepaid Orders is required so that when prepaid items ordered from Deliverit are received by 

Idealpos, they will be correctly saved to the table with a ‘0.00’ amount owing. 

As Deliverit requires the customer to pay for their order on their own smartphone at the time the order is placed, there 

is no option in Deliverit for the customer to pay in-store. Therefore, all orders received from Deliverit are prepaid and 

Idealpos must be configured so that “Automatically Finalise Prepaid Orders” is enabled. 
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Provided that the integration has already been configured via Idealpos Online eCommerce/Deliverit and the 

eCommerce settings have been configured correctly (e.g. Unmatched Items Link, Web Order Tender, etc. are all 

configured correctly in the Global Options > eCommerce settings), there should be no other special steps required to 

use this function. 

 

The end-to-end ordering process is as follows: 

 

The customer scans a QR Code at the table. 

The Deliverit site will be displayed on their smartphone device. 

They will need to enter their Table Number, then press “Start Ordering” to proceed: 
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The next step the customer will complete is to select the items they wish to order. 

Selecting an item from the menu will display the details about the item and any options which can be added or 

excluded from the item.  

To add the item, they will press the “Add” button at the bottom of the screen. 
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The item is then added to the order: 
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To proceed with the order, they will press the “Checkout” button at the bottom of the screen, which will then display 

the Order Summary.  

To continue with the order, they will need to scroll down to the bottom of the page, then if they’re an existing 

customer that has previously used this integration, they can press the “Login” button to login. 

Otherwise, they will need to enter their First Name, Phone Number, Email Address, Password and Confirm Password. 
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A text message will be sent to the customer’s Phone Number containing a unique SMS Code to confirm the account. 

They will enter the code, then press “Verify Code” to continue. 
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The customer will then be prompted to select a Payment Method to pay for their order. 

The order will not send without completing this step. 

Once the payment details have been entered, the Confirm Order button can be pressed to proceed. 
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A Thank You For Ordering page will be displayed, confirming that the order has been received. 
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The order will be sent to Idealpos and will be saved to the Table Number that was entered by the customer.  

 

 
 

The Kitchen Dockets will also be printed for any items that were ordered. 
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If a table only consists of items ordered by a customer via Deliverit, all items will be prepaid and no further payments 

are necessary. 

When the Table Details for such a table are displayed, the “Outstanding” column will show that there is no money 

owing. 

 

 
 

Press “Select All”, then “Pay 0.00”. 

 

 
  



 Update History 
Return to top 

Idealpos 8 Build 3 - Update History Page 31 of 95 

 

Tender the sale to clear the paid items from the table: 
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The Table is now ready for the next customer: 

 

 
 

Any Pre-Paid Deliverit orders will also appear in the Journal History Enquiry and a Docket can be printed for the 

customer, if they require. 

 

Go to: Back Office > Enquiry > Journal History. 

Select the Journal from the list, then select “Docket Print” from the left-hand side of the window. 
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A Customer Docket will be printed: 
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Network Printers 

IP-4202 – Network Printers – Support for Number of Characters per Line by printer 

This function adds the ability to configure the number of characters per line to print to the network printer. 

Many original receipt printers that are supported only handled 42 characters, whereas many newer network printers 

can support 48 characters per line. 

This function enables these newer printer types to utilise the maximum number of supported characters per line. 

 

To configure this function, go to: 

Back Office > Setup > Network Printers 

 

Select an existing printer from the list and press “Modify” or double click the existing printer. 

Alternatively, press the “Add” button to add a new printer. 

 

 
 

From the Characters per Line dropdown box, select either 42 or 48 depending on the number of characters per line 

supported by your printer. 

If configuring a new printer, enter any other settings required to establish a connection to the printer. 
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If a new printer was added, ensure that you drag the printer from the list of printers at the top of the window to the 

required printer slots in the Printers by POS grid at the bottom of the window. 

The printer will be used for printing receipts/kitchen dockets when a print job is sent to any of the printer slots. 
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POS Screen 

IP-4530 – Stock Item Availability – Function to set availability from POS 

This function enables the Stock Availability of a Stock Item to be toggled between “Always Available” and 

“Unavailable” from the POS Screen. 

Toggling a Stock Item’s Availability using this function will result in the Stock Item’s current Availability status being 

cleared and replaced with either “Always Available” or “Unavailable”. When an item is unavailable, the Stock Item’s POS 

Screen button will appear with a red “X” through it. When the item is available for sale, the red “X” will not appear, and 

the clerk will be permitted to sell the item. 

The other Availability options of “Unavailable when Stock Level reaches Zero” and “Unavailable when Alert Level 

reaches Zero” cannot be selected using this function’ they can only be selected when modifying a Stock Item by going 

to: Back Office > File > Stock Control > Modify Stock Item > Advanced Tab > Availability. 

Access to this POS Screen function can also be controlled via User Permissions or Clerk Permissions. 

 

To configure this function, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

Select a suitable POS Screen tab where you would like this function to reside. 

We recommend adding this function to a Manager, Admin, or similar tab. 

Select a blank button and from the list of functions available on the right-hand side of the button config window, 

choose “Stock Availability”. 

You can also personalise the button as required (Button Caption, Button Colour, Font Colour, etc.). 

Once completed, press the “Save” button. 
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If you added the Stock Availability button to the Admin or Manager tab, and that tab already has User Permissions 

configured accordingly (and you want to skip the configuration of User/Clerk access to the Stock Availability function), 

you can skip the below security configuration steps straight to using this function from the POS Screen.  

Note however that if access to this function is not restricted and the button is added to a different POS Screen tab in 

the future, any Clerk that has access to the POS Screen tab will have access to the Stock Availability function. 

 

You may want to restrict access to this function in one of the following ways: 

 

Restrict a User or Clerk from accessing the POS Screen tab which you added the Stock Availability button to – 

This will restrict them from accessing the Stock Availability function and any other functions which exist on the POS 

Screen tab. 

Restrict a User or Clerk from accessing the Stock Availability function – This will only restrict the User or Clerk 

from accessing the Stock Availability function, whilst still allowing them to access the other functions on the POS 

Screen tab where the Stock Availability button resides. 

 

When configuring permissions, keep the following points in mind: 

• Each Clerk is linked to a User. 

• Any permissions that deny access to a function at a User level will flow down to all the Clerks linked to that 

User, meaning that ALL CLERKS linked to that User will also be denied from accessing that function, even if 

access to the function has been enabled at the Clerk level. 

• If access to a function is enabled at the User level, you can then restrict individual clerks from accessing that 

function via the Clerk Permissions. 
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Close the POS Screen Layout windows, then depending on whether you want to control access to this function for a 

Clerk or User, go to:  

Back Office > Setup > Users 

Or 

Back Office > Setup > Clerks 

 

To configure permissions for Users, select the User from the list, then press “Modify”. 

 

 
 

In the Search field on the top-left hand corner of the window, enter “Stock Availability”. 
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The Stock Availability function will be highlighted in the list of functions. 

Enable or disable the option as per your requirements. 

Note that disabling the Stock Availability option (or any other option) for the selected User will result in all Clerks that 

are linked to the User also being denied access to the function. If you want to control an individual Clerk’s access to a 

function, ensure that the function remains enabled at the User level, then restrict access to the function at the Clerk 

Permission level (see further below for details on controlling a Clerk’s access to a function). 
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If you want to restrict access to the POS Screen tab where you saved the Stock Availability button, this can also be 

configured. 

Under the “Layers” tree, toggle the POS Screen tab to either enable or disable access to the POS Screen tab where the 

Stock Availability button resides. 

Note that you may still want to configure access to both the Stock Availability and POS Screen tab. 

E.g. If the POS Screen tab that contains the Stock Availability button is restricted from being accessed but the Stock 

Availability function is not restricted, the Stock Availability function can still be accessed if a POS Screen button linking 

to the function is created on a different POS Screen tab that is available to the User. 

 

Once you have finished making your changes, ensure that you press the “Save” button on the top-left corner of the 

window. Alternatively, closing the window without pressing the “Save” button will display a prompt asking you if you 

want to save your changes. In either case, ensure changes are saved so they take effect. 
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To configure permissions for Clerks, go to: Back Office > Setup > Clerks. 

From the list of Clerks, select the Clerk that you want to modify permissions for, then press the “Permissions” button 

on the left-hand side: 

 

 
 

On the top-left hand corner of the window, enter “Stock Availability” into the search field. 
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The Stock Availability option will be highlighted in the list. 

Enable/disable the function as required, then save your change. 

You can repeat the process for each Clerk that you want to restrict or allow access to the function. 

As mentioned previously, if you want to restrict a Clerk’s access to a function, ensure that the function is available to 

the User that the Clerk is linked to, then configure each Clerk’s access to a function on a Clerk-by-Clerk basis. 
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To use this function, go to the POS Screen, navigate to the POS Screen tab that contains the Stock Availability button 

and press it. 

 

 
 

A message “Select Item(s) to Toggle Availability” will appear below the sale window. 

 

 
 

Press the POS Screen button for each Stock Item that you want to toggle the availability. 

The availability will toggle between “Always Available” and “Unavailable”. 

The below shows an Available Stock Item and an Unavailable Stock Item. 

Available items will show the standard Stock Item button or Stock Item image on the button. 

Once an item has been toggled to Unavailable, the image will disappear and will show a red “X” behind the button text 

as per the below example: 
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You can continue to toggle each item’s availability by pressing the Stock Item buttons on the POS Screen. 

Once complete, press the “Exit” button below the sale window to exit the Stock Availability toggle function. 

 

 
 

Items which are available can be added to a sale. 

Unavailable items will display a prompt to the Clerk, preventing the sale of the item. 

 

 
 

If you want to set one of the other availability statuses (Unavailable when Stock Level reaches Zero or Unavailable 

when Alert Level reaches Zero), then you will need to modify the Stock Item by going to:  

Back Office > File > Stock Control > Stock Items > Modify the Stock Item > Advanced Tab > Availability. 

 

Stock Item Alert Levels are configured via Back Office > File > Sales > Stock Item Alert Levels. 
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Reports 

IP-4514 – Customer Account Transactions Report – Subtotals when grouped by POS/Location 

This function will display a subtotal of all Customer Account Transactions that took place at each POS Terminal or 

Location when using the Group by POS Terminal/Location checkbox. 

 

To use this function, go to: Back Office > Reports > Customers > Customer Account Transactions 

In the Group by section, enable either Location or POS System: 
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The report will be grouped by the selected option and the subtotal for each group will be displayed, as shown in the 

below example: 
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Restaurant & Table Map 

IP-4520 – Table Orders – Ability to Batch Orders to Kitchen after number of minutes 

This function adds the ability to batch orders to the Kitchen Docket Printers after a pre-configured number of minutes. 

Idealpos will wait for the configured number of minutes to lapse before it prints the Table Order to the Kitchen Docket 

Printer(s). If additional items are saved to the table within the number of minutes window period, the minutes counter 

will reset and will start again - if no additional orders are saved to the table within the number of minutes, then all the 

unprinted Kitchen Items saved to the table will be printed to the Kitchen Docket Printer(s). 

Essentially, this setting introduces a ‘number of minutes inactivity delay’ on Table Ordering. 

This number of minutes setting enables all the guests at a table to take their time and place all their orders one at a 

time and once they’re finished, Idealpos will batch all the items saved to the table as a single Kitchen Docket. 

This enables the chef to prepare all the meals for the table together, ensuring that all guests will receive their meals at 

the same time. 

 

An example of this function is as follows: 

If Idealpos is configured to send orders to the Kitchen after 5 minutes and an order is saved to a table at 1:00PM, then 

another order is saved to the same table at 1:04PM, all the items that were saved at 1:00PM and 1:04PM will be printed 

at 1:09PM (5 minutes after the last order). If additional orders are placed to the same table before 1:09PM, the Kitchen 

Docket(s) for the table will be held from printing until the configured number of minutes have lapsed since the last 

order was placed to the table, then the Kitchen Docket(s) will be printed for the table. 

 

In addition, this function can also be configured so that beverages print immediately. 
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To configure and use this function, go to: 

Back Office > Setup > Global Options > Restaurant > Table Map Kitchen Dockets. 

Select “Batch Orders to Kitchen after # minutes”. 

Enter the number of minutes that you want Idealpos to wait before it prints the Table Map Kitchen Dockets. 

 

 
 

If you require beverages to print immediately, enable the “Print Beverages immediately” checkbox. 

To utilise the “Print Beverages immediately” function, you will need to ensure that your system is configured correctly. 

Detailed steps on how to configure your system for the Print Beverages immediately function are available in the 

Idealpos User Guide by clicking here. 

 

  

https://userguide.idealpos.com.au/Restaurant%20and%20Table%20Map/Setup%20Print%20Beverages%20immediately.htm
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Once “Batch Orders to Kitchen after # minutes” and “Print Beverages immediately” have been enabled, the function is 

ready for use. 

 

Go to: POS Screen. 

Add items to the sale, ensuring that you also include Beverage items: 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 3 - Update History Page 50 of 95 

 

Press the “Table Map” button. 

 

 
 

Select a table from the Table Map and enter the number of Guests/Covers if prompted: 
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If “Print Beverages immediately” was enabled, Idealpos will immediately print the beverage items to the Kitchen 

Docket Printer(s) without delay. 

 

 
 

Any other non-beverage items will be printed after the number of minutes have lapsed, as configured in Global 

Options. If you add any additional items to the Table Order, the timer will be reset and the printing to the Kitchen will 

be delayed for a further set number of minutes. Once there have been no new orders saved to the table within the 

configured number of minutes, the unprinted Kitchen Items that were saved to the table will all be printed to the 

Kitchen Docket Printer(s). 

In the below example, there were no additional items saved to the table after the original order shown in the above 

steps. 

Therefore, the Kitchen Docket for the remaining non-beverage items was printed at 12:12PM, 5 minutes after the items 

were saved to the table, as indicated by the Date/Time shown on the beverage Kitchen Docket above (which was 

printed immediately after the items were saved to the table as per the “Print Beverages immediately” setting). 

 

 
 

If you want to batch multiple orders saved to the same table to a single Kitchen Docket for each Kitchen Printer, 

ensure that you place each order to the same table before number of minutes lapse since the previous order was 

saved to the table. Once there have been no new orders saved to the table for the configured number of minutes, all 

the unprinted Kitchen Items saved to the table will then print to the Kitchen Docket Printer(s). 
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Stock Items 

IP-4472 – Stock Item Tags – Offer suggestions from existing Tags 

When entering a Stock Item Tag, Idealpos will now display a list of suggested tags that match the text entered into the 

Tag field. This function is beneficial for keeping tags consistent across all Stock Items and to prevent similar entries for 

the same tag (e.g. Green, Grn, Small, SML, etc.). 

 

There is no additional configuration required to enable this functionality. 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

Modify a Stock Item by either selecting a Stock Item and pressing Modify or double-click on the item. 

In the Tags field, start entering a tag description. 

Any existing tags that match the text which has been entered will be listed as a suggested tag. 

The existing tag suggestions are based on any tags that have already been entered into the tags field of any Stock 

Item in your system.  

The below example shows the entry of “Hat” into the tags field. The “Add Hat” button directly below the Tags field 

reflects the text entered into the Tags field, the buttons to the right show the suggested tags (Hat Large, Hat Medium, 

Hat Small, Hat Universal Size). 
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To select a suggested/existing tag for the current Stock Item, you can either click on the tag to add it, or you can press 

the down/up arrow on your keyboard to cycle through the tags, then press Enter to add the selected tag.  

The below example shows “Hat” entered into the Tags field with a list of tag suggestions displayed – “Hat Large” is 

outlined indicating that it is currently selected using the arrow keys. 

Once the required tag has been selected, pressing Enter will add the tag. 

Alternatively, you can click on the suggested tag using your mouse cursor to add it. 

 

 
 

The tag will be added to the item and will appear similar to the below example. 

 

 
 

The above process can be repeated to add any other tags as required. 
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IP-4528 – Stock Items – Support for Modifier Grids 

This function adds the ability to configure which POS Screen Grids a Stock Item will step through from the Stock Item 

Advanced Tab > Modifier Grids. This function also enables multiple POS Screen Grids to be specified and Idealpos will 

step through each of those grids when the item is sold from the POS Screen. The grids can contain several modifiers 

for an item, such as Cook Types, Sauce Types, or any other options that are available when selling a specific item. 

  

In previous builds of Idealpos, when you wanted to configure a Stock Item to display and step through multiple POS 

Screen Grids, you had to specify the next POS Screen Grid via the Grid Link setting in each individual Stock Item POS 

Button within a POS Screen Grid. 

 

With this change, you can now configure each POS Screen Grid that will be displayed by the POS Screen after a Stock 

Item is added to a sale, as configured in the Stock Item’s Advanced Tab.  

 

Note that if Modifier Grids have been selected in the Stock Item’s Advanced Tab, any Grid Links that are configured for 

each Stock Item’s button within the POS Screen Grid will be ignored, and instead, Idealpos will display the POS Screen 

Grids that have been entered in the Modifier Grids field. 

 

To configure this function, several steps must be completed which are summarised here and outlined in further detail 

below. You might be able to skip some of these steps if they’ve already been carried out or configured previously: 

 

Creation of Stock Items/Instruction Stock Items – Create each Instruction Stock Item that will be displayed on the 

POS Screen Grids. E.g. Create Stock Items such as Blue, Rare, Medium-Rare, Medium, Medium-Well, Well Done (for 

Cook Types - Meat), or Sauce Types such as Gravy, Diane, etc.  

Creation of POS Screen Grids/Modifier Grids – Create multiple POS Screen Grids. Each POS Screen Grid can contain 

common Stock Item Types/Instructions (e.g. You can create a POS Screen Grid called “Cook Types – Meat” and another 

POS Screen Grid called Sauce Types and so on). The Stock Items/Instruction Items can be included on their respective 

POS Screen Grids. 

Configuring the main Stock Item (Advanced Tab > Modifier Grids) – The main Stock Item(s) will be configured to 

display the required Modifier POS Screen Grids. 
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Go to: Back Office > File > Stock Control > Stock Items. 

Create the required Stock Items that will be displayed on your Modifier Grids. 

The following two examples are a Cook Type Stock Item and a Sauce Type Stock Item which will be used for the POS 

Screen Grids Cook Types – Meat and Sauce Types. 

 

An example of a Well Done Stock Item.  

You will need to create other Stock Items of a similar type (such as Medium-Well, Medium, Rare, etc.) 
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An example of a Sauce Type Stock Item.  

You will need to create other Stock Items of a similar type (such as Gravy, Bechamel, etc.). 
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New POS Screen Grids will need to be created for each type of Stock Item. 

Go to: Setup > POS Screen > Grids. 

Press the “Add” button on the left-hand side to create a new POS Screen Grid. 

Description - Enter a description for your POS Screen Grid (e.g. Cook Types Meat). 

Force Selection – These fields can also be used to force the Clerk to select a specific number of items from the POS 

Screen Grid. This function is useful if a specific number of selections are required to make the item. 

Force Selection Minimum - The number entered into the Minimum field is the minimum number of items that will be 

required for selection before the POS Screen Grid will close and move onto the next grid. 

Force Selection Maximum - The number entered into the Maximum field is the maximum number of items that can 

be selected in the POS Screen Grid. You may want to restrict the number of options selected to prevent the item from 

being too large or overcrowded (e.g. too many toppings on a Pizza, etc.). 

If you want to force the Clerk to only select a single item from the POS Screen Grid, enter 1 into both the Minimum 

and Maximum fields. 

 

Press the “Save” button to the Save the POS Screen Grid. 
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The create new POS Screen Grid form will be cleared, ready for creating another POS Screen Grid. 

Repeat the process for any other required POS Screen Grids (e.g. Sauce Types, etc.). 

 

 
 

Once the Grids have been created, you will need to add items to them. 

Select the POS Screen Grid from the list and press the “Items” button on the left-hand side. 

 

 
  



 Update History 
Return to top 

Idealpos 8 Build 3 - Update History Page 59 of 95 

 

Add the required Stock Items to the POS Screen Grid. 

You can either search for the item using the Stock Item Grid on the top-left corner of the window, then drag the item 

to the POS Screen Grid below: 
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Or you can click on a blank button in the grid below, select the Stock Item function and link to the required Stock Item. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 3 - Update History Page 61 of 95 

 

The final step is to specify the Modifier Grids that you want your Items to display when they’re added to a sale. 

Go to: Back Office > File > Stock Control > Select a Stock Item > Modify. 

In the Advanced Tab, press the “>” button within the Modifier Grids field to display a list of POS Screen Grids. 
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A POS Screen Grids window will be displayed. 

In this window, you can either select a single POS Screen Grid, or multiple Grids. 

To select multiple Grids, hold down the CTRL button while clicking on the required grids. 

Note that the Modifier Grids field supports a maximum of 30 characters, including commas which are used to separate 

each POS Screen Grid selected. 

Select the POS Screen Grids that were created above. 

Press the “OK” button on the left-hand side once the required POS Screen Grids have been selected. 

Also note that the Grids will be added and displayed in POS Screen Grid Code order (e.g. 1,2,3, etc.). 
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The POS Screen Grids will be listed in the Modifier Grids field, each separated by a comma. 

In addition, the POS Screen Grid order that will be used will appear below the Modifier Grids field. 

 

 
 

It is also possible to manually enter the POS Screen Grid Codes into the Modifier Grids field. 

As noted above, there is a limit of 30 characters in the Modifier Grids field, including commas. 
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When a Stock Item which has been linked to the POS Screen Grids via the Modifier Grids field shown above, it will 

display those grids in the same order listed above. 

 

Go to the POS Screen: Add the Stock Item to the sale. In the example used above, the BEEF Stock Item was used. 
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When the Stock Item is added to the sale, the first POS Screen Grid will be displayed (in this case, Cook Types). 
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After a Cook Type has been selected, the next POS Screen Grid will be displayed.  

In this example, Sauce Types: 
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Once a sauce selection is made, the POS Screen will return to MAIN. 
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IP-4529 – Stock Items – Support for Graphic when Adding/Modifying Stock Items 

This function adds the ability to assign an image to a Stock Item as well as the ability to copy the image to all POS 

Screen Buttons which are linked to the Stock Item. Note that this function will copy the image to the buttons on the 

current terminal. In order for the image itself to appear on all networked POS Terminals, the Send Pictures Folder 

function will need to be used. 

Whilst the functionality to assign an image to the POS Screen button has been available for a long time, the ability to 

assign an image to the actual Stock Item itself was not possible until now. 

 

To use this function, go to: Back Office > File > Stock Control > Stock Items. 

Double-click on a Stock Item or select a Stock Item and press the “Modify” button on the left-hand side of the window. 

Within the Stock Item, click on the Advanced tab. 

A new “Graphic” field will appear on the top-left corner of the window, as well as a “Copy to POS Buttons” checkbox. 
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This field can be used to assign an image to the Stock Item. 

Press the “>” button in the Graphic field to open a File Browser window. 

 

 
 

Browse to any folder on your PC, select the image that you want to use, then press “Open”. 

We recommend using a smaller image that will suit the POS Button (for a double-height POS Screen button, a 

resolution of 110x110 is suitable). 
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Once the image has been selected, it will be displayed to the right of the Graphic field, as shown in the example below: 

 

 
 

The Graphic can then be copied to POS Buttons if desired. 

This will trigger the image to be copied to any existing Stock Item buttons on your POS Screen that are linked to the 

Stock Item. If the POS Buttons already contain an image, it will be replaced with the selected image. 

Note – The button image will be copied to all POS Buttons that are linked to this Stock Item. This will take place on all 

POS Screen Layouts that contain a POS Button linked to this Stock Item. 

The image will also automatically be copied into the Pictures folder where all your other Stock Item POS Screen button 

images are located (C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\). 

Enable the “Copy to POS Buttons” checkbox, then press the “Save” button on the top-left corner of the window. 
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One final step (Send Pictures Folder) is required so that the image appears on the POS Buttons at each of your 

networked POS Terminals. 

Go to: Utilities > Send > Pictures Folder. 

Select the POS Terminals that you wish to send the Pictures Folder to, then press the “OK” button on the bottom-right 

corner of the window. 
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The Installation Progress will be displayed on the right-hand side of the window. 

Once completed, press the “OK” button on the bottom-right corner of the window. 
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The image will now appear on each POS Button that’s linked to the Stock Item. 

The below example shows the button on the Bottle Beer & RTD Tab of the POS Screen. 

A button for the Stock Item was pre-configured before the above steps were carried out. 

Your POS Screen Layouts can be modified by going to:  

Back Office > Setup > POS Screen > POS Screen Setup > Selecting the POS Screen Layout > Buttons 

 

Further details on using the POS Screen Layout function are available in the POS Screen Setup topic of the Idealpos 

User Guide. 

 

 

  

https://userguide.idealpos.com.au/Default.htm#POS%20Screen%20Setup/POS%20Screen%20Setup.htm
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Surcharges 

IP-4564 – Ability to handle Multiple Surcharge Setups 

This function improves on the surcharge functionality in Idealpos by adding the ability to handle multiple surcharge 

setups. This function also introduces new possibilities when configuring surcharges along with priorities, where 

Idealpos will use priorities to determine which surcharge should be applied to the sale.  

Included in this function are the following new features: 

 

Configure surcharges that will apply a specific surcharge amount based on the total value of the sale.  

E.g. A surcharge rule can be created where a flat surcharge of 10% will apply on a given day, but if the sale total is less 

than $10.00, then surcharge 15% or If the sale total is more than $20.00, then surcharge 5.00%. 

If the sale is greater than $10.00 but less than $20.00, then the 10% surcharge will apply. 

You can also substitute the percentage surcharge with a dollar amount surcharge at any point in the configuration, 

and this can also be mixed and matched, if required. 

E.g. You could configure the surcharge so that it charges customers a 10% surcharge when the total sale amount is 

less than $10.00 and you could configure the same surcharge to charge customers a $1.00 surcharge for any amount 

that is over $20.00.  

 

Use the new “Apply Surcharge To” function to specify which items are included or excluded from the 

surcharge (based on the Department or Sales Category that the Stock Items belong to). 

Options available are: 

• Apply Surcharge To All Items – The surcharge will apply to any items that are added to the sale.  

• Apply Surcharge To Only Items in Department X – This will only apply the surcharge to Stock Items that are 

linked to the specified Departments. 

• Apply Surcharge To Only Items in Sales Category X – This will only apply the surcharge to Stock Items that 

are linked to the specified Sales Categories. 

• Apply Surcharge To All Items excluding Department X – This will apply the surcharge to all Stock Items 

except for items that are linked to the specified Departments. 

• Apply Surcharge To All Items excluding Sales Category X – This will apply the surcharge to all Stock Items 

except for items that are linked to the specified Sales Categories. 

 

Use Multiple Surcharge Setups to have multiple surcharges active in the same period, with each surcharge 

configured to apply a different surcharge percent for different Departments or Sales Categories. 

E.g. You may want to apply a 10% surcharge on all items being sold from the Coffee Department, but you also want to 

have a 20% surcharge on all items from the Entrée Department. When a customer purchases items from the Coffee 

Department and/or the Entrée Department, the Coffee items will be surcharged at 10% and the Entrée items will be 

surcharged at 20%. This is now possible using the Multiple Surcharge Setups function.  

 

Repeat Every Year surcharge. 

This can be used for the annual Public Holidays that always fall on the same day each year such as Christmas Day, 

Boxing Day, ANZAC Day, etc. You can configure the surcharge once and tick the “Repeat Every Year” checkbox and 

Idealpos will do the rest. 

 

Schedule future surcharges that you want to apply well into the future. 

E.g. You can create a surcharge setup for various Public Holidays in the future. Create a Christmas Day surcharge of 

30%, a Boxing Day surcharge of 20% and so on, without having to manually configure or adjust the surcharge before 

each trading day starts. 
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To configure and use this function, go to: 

Back Office > File > Sales > Surcharges 

If you had a surcharge configured on one or more of your POS Terminals before upgrading to this build, you will see 

the surcharges listed here. 

Depending on how your surcharges were configured on each terminal (before you upgraded), you may have:  

No entries - A surcharge wasn’t configured on any terminals.  

A single entry - You either had a single terminal with a surcharge, or multiple terminals had the same surcharge.  

Multiple entries - Multiple terminals which each had unique surcharge settings. 

 

 
 

  



 Update History 
Return to top 

Idealpos 8 Build 3 - Update History Page 76 of 95 

 

To create a new surcharge, press the “Add” button on the top-left corner of the window. 

 

 
 

The Surcharges - “Add New” window will be displayed. 
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As the surcharge screen now supports new functionality, there are many variations of surcharges that can be created, 

and surcharges can become complex. Therefore, the overall surcharge function is outlined below. 

The Add New Surcharge window contains five sections which are: 

 

Section 1 - Surcharge Code/Description 

This section is used to distinguish the surcharge from other surcharges and contains the following fields: 

Code - The Code is automatically populated and increments by one each time a surcharge is created. 

Description – Enter a description for the surcharge (e.g. Christmas Day surcharge, Easter Holiday surcharge, etc.). 

 

 
 

Section 2 - Surcharge Period  

This section is used to configure the period(s) which the surcharge will be active and contains the following fields and 

options: 

From: This is the starting date and time for when the surcharge will begin. 

To: This is the end date and time for when the surcharge will stop being active. 

Repeat Every Year: This checkbox will enable you to repeat the surcharge each year. This can be used for cases when 

you need to apply a surcharge on a specific day or period each year. An example of this is when you want to apply a 

surcharge for a Public Holiday that takes place on the same day each year (e.g. Christmas Day or Boxing Day) and your 

business is generally open on the day. 

Continuous: This option will trigger the surcharge to apply for the entire duration within the period configured in the 

From and To fields above. 

During Specific Times: This option will enable you to further control the times which the surcharge will apply. By 

selecting this option, the following additional options will be displayed on-screen which can be used to control the 

specific times that the surcharge will apply. 

Time: This is the start time that the surcharge will apply. 

To: This is the end time that the surcharge will apply. 

Day of the week checkboxes: There is a checkbox for each day of the week (Monday, Tuesday, Wednesday, Thursday, 

Friday, Saturday, and Sunday). The surcharge will only apply on days which contain an enabled checkbox. 
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Section 3 - Surcharge amounts and rules  

This section is used to configure the surcharge amount/rules and contains the following fields: 

Surcharge amount and %/$ - The entered value and surcharge type (i.e. % or $) will be used as the flat surcharge rate 

when the total sale amount does not fall within the boundaries configured in the “If Total <” or “If Total >” settings 

that are configured below.  

If Total < amount then Surcharge amount %/$ - If the checkbox is enabled and the sale total is less than the 

amount configured, then the entered surcharge amount and surcharge type will apply. 

If Total > amount then Surcharge amount %/$ - If the checkbox is enabled and the sale total is greater than the 

amount configured, then the entered surcharge amount and surcharge type will apply. 

 

 
 

Section 4 - Apply Surcharge To  

This section enables you to control which items the surcharge will apply to and contains the following options: 

All Items – The surcharge will apply to all items that are added to the sale. 

Only Items in – The surcharge will only apply to items in the sale that are in the selected Departments or Sales 

Categories. You can only select either Sales Category or Department. Once a selection is made, the “>” button in the 

blank field can be pressed and Idealpos will display a list of Sales Categories or Departments. Multiple Sales Categories 

or Departments can be entered, ensuring that they are comma separated. 

All Items excluding – The surcharge will apply to all items that have been added to the sale, except for items that are 

linked to the Departments or Sales Categories that have been configured. Again, multiple Sales Categories or 

Departments can be entered, ensuring that they are comma separated. 
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Section 5 - POS System/User-Defined Text  

This section enables you to control which POS Terminals the surcharge will apply to. 

POS System – Enter the POS Terminal numbers that you want the surcharge to apply to. The “>” button can also be 

pressed to display a list of POS Terminals and from there, you can select the required terminal from the list and press 

“OK” to ensure that the surcharge will apply to the terminal. 

User-Defined Text – This is an advanced feature that enables further control or manipulation over the surcharge 

function. 

 

 
 

 

Once a surcharge has been configured, it will apply during the specified time(s) to the specified items. 
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We have outlined a few surcharge examples below: 

 

Public Holiday Surcharge – Repeat Every Year 

The below example will repeat the Christmas Day surcharge of 20% on All Items every year on the 25th December on 

POS 100. If you don’t want the surcharge to repeat every year, ensure that the “Repeat Every Year” checkbox is 

disabled. 
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Late Night surcharge 

The below example will apply a 20% surcharge on all items between 10:00PM and 11:59PM every day between 1st 

December 2021 and 31st December 2030 on POS 100.  
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Surcharge Priorities 

When creating surcharges, note that they will be applied based on priority. 

Surcharges which are listed at the top of the list will have priority over surcharges that appear at the bottom of the list. 

The priority of each surcharge can be modified by changing the position in which it appears in the list. 

 

Example: Two surcharges exist which have both been configured to be active in the same period for All Items. 

One surcharge is configured with a higher percentage rate than the other. 

Whichever surcharge appears higher in the list will be applied to items in the sale. 

 

 
 

The example below shows the result of a $10.00 total coffee sale using the above surcharge configuration. 
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The priority order of the surcharges can be modified by pressing the “Change Priority” button on the left-hand side of 

the window. 

Arrows will then appear on the left-hand side of the window which can be used to change the priority order. 

The first two arrows are used to move the highlighted surcharge entry up or down in the list.  

The last two arrows are used to move the highlighted surcharge entry to the very top or the very bottom of the list. 

 

 
 

Once the desired priority order has been set, press the “Lock Priority” button on the left-hand side. 

The example below shows the 20% surcharge has been moved to the top of the list and has a priority of 1. 
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With the surcharge priority order now switched so that the 20% surcharge appears at the top of the list, it will be the 

surcharge that takes priority, and therefore, a 20% surcharge will apply when a sale is completed. 

The below example shows a $10.00 total coffee sale using the above configuration. 
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Multiple Surcharges active in the same time period to apply different surcharge percentage to different items 

It is also possible to create multiple surcharges so that each surcharge applies a unique surcharge amount to items 

from a specific Sales Category or Department. 

E.g. You may want to apply a 5% surcharge only to items from the Coffee Department and also apply a 10% surcharge 

only to items from the Entrée Department.  

Idealpos will then apply the surcharge to the items from each department accordingly. 

Regardless of whether the sale contains a mix of items from Coffee and Entrée or items from only one of these 

departments, the correct surcharge will still be applied as per the surcharge configuration.  

 

To achieve this type of surcharge configuration, you will need to configure two surcharges as follows (the priority of 

the following surcharges doesn’t matter, provided that there are no other surcharges higher in priority and active). 

 

5% Coffee Department surcharge, ensuring that the “Apply Surcharge To” is set to “Only Items in Department” [Enter 

Coffee Dept Code].  
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Create another surcharge that applies to the Entrée Department: 
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When items linked to these departments are added to a sale, they will be surcharged at the rate that is applicable for 

the department they’re linked to. 

E.g. Cappuccino, Flat White, Short Black will each be surcharged at 5% (5% Coffee Surcharge). 

Pasta, Beef, Lamb and Duck will each be surcharged at 10% (10% Entrée Surcharge). 

When tendering the sale, the Sale window will display a break-down of these surcharges. 
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The Customer Receipt will also contain a breakdown of the surcharges: 
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Taxes 

IP-4433 – USA/Canada – Tax Shift Function – Force Tax Rate On or Off 

This function is only applicable to the USA and Canada regions and adds the ability to force a tax rate to be either on 

or off via a button linked to the Tax Shift Function. 

Previously, the Tax Shift Function only had the ability to be used as a toggle for a Tax Rate. 

E.g. If Tax Rate 1 is currently enabled and the Tax Shift button linked to Tax Rate 1 is pressed, then the Tax Rate 1 

would become disabled. Likewise, if Tax Rate 1 is currently disabled and the Tax Shift button linked to Tax Rate 1 is 

pressed, then the Tax Rate 1 would become enabled. This button behaviour is essentially a toggle for a Tax Rate. 

 

With this change, you can now create buttons on the POS Screen to either turn Tax Rates on or off, regardless of 

whether the Tax Rate is currently enabled or disabled. 

When the button to force a Tax Rate either on or off is pressed, the enabled or disabled rate will only apply to new 

items that are added to the current sale. 

Once the current sale is either voided or tendered, all Tax Rates will return to a status of being disabled in the next sale 

(items will be taxed based on the Tax Settings configured within the Stock Item).  

 

To configure this function, go to:  

Back Office > Setup > Global Options > Sales 

Review the current Tax Rates that are configured as these will be used as part of this function: 

Also take note of each Tax Rate and the place in which it appears in the configuration (the number position which the 

rate appears will be required when configuring the Tax Shift/Tax On/Off buttons). 

E.g. In the below example, the GST Tax is the 1st tax, the PST Tax is the 2nd tax and the remaining rates are undefined. 

For our example, we will note down 1 as belonging to GST and 2 as belonging to PST. These numbers will be required 

for the Tax Shift button configuration. 
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Default – A checkbox in the default column next to a Tax Rate will trigger any new Stock Items created from this point 

onwards to have that corresponding Tax Rate enabled by default.  

Description – This is simply a description of the Tax Rate for identifying the purpose of the rate (e.g. State Tax, 

Government Tax, etc.). 

Rate – This is the rate as a percentage. 

Label – This is a short label for the tax. 

Inc – This indicates whether the tax will be included in the sell price of an item or if the Tax will be added to the item. If 

this option is unchecked or disabled, the tax will be added onto the item after you press ENTER and go to the Tender 

screen. If this option is checked or enabled, the Tax will be included as part of the sell price. 

 

Show Rates next to items on Receipt – The Tax Rates will be shown next to each item on the receipt. 

Combine Rates into One Total on Receipts/Tabs – The total of all individual taxes that apply to the sale will be 

added together and listed as a single tax total at the bottom of the receipt. If this option is disabled, each tax rate will 

be listed at the bottom of the receipt along with corresponding tax amount for each tax rate that applied to the sale.  

 

Once you have confirmed that your Tax Rates are configured as required and you have noted down the number 

position which each rate appears, you may now proceed to create and configure the required buttons on the POS 

Screen. 
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Close the Global Options window and go to:  

Back Office > Setup > POS Screen > POS Screen Setup 

Select a POS Screen Layout > Buttons 

 

 
 

When creating buttons for the Force Tax On/Force Tax Off buttons, you have the following options: 

 

• Create a generic Tax Off and Tax On button and the Clerk will need to first enter the number which 

corresponds to the Tax Rate they want to turn off or on, followed by either pressing the Tax Off or Tax On 

button. This option will only require two buttons, saving space on the POS Screen for other buttons and 

functions. 

• Create a separate Tax Off and Tax On button for each Tax Rate so that the Clerk won’t have to enter the Tax 

Rate number then press the Tax Off or Tax On button. 

E.g. Create individual buttons for “Tax 1 Off”, “Tax 1 On”, “Tax 2 Off”, “Tax 2 On” and so on. 

You can also configure the button captions so they describe the Tax which they will be toggling off or on. 

E.g. GST On, GST Off, PST On, PST Off and so on. 

This option will require two buttons for each Tax Rate (an “on” button and an “off” button). 

 

Select a POS Screen tab that contains enough unused blank buttons for each Tax Rate On/Tax Rate Off button. 

If creating an On/Off button for each Tax Rate and you are utilising all available six Tax Rates, you will need 12 blank 

buttons. 
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To create basic Tax On and Tax Off buttons (which the Clerk will need to manually enter the Tax number before 

pressing the button), configure the buttons as follows: 

 

Function: Tax Shift 

Automatic Text: [OFF] 

Button Caption: Tax Shift OFF (or any custom text you want to use for this button) 

 

 
 

Function: Tax Shift 

Automatic Text: [ON] 

Button Caption: Tax Shift ON (or any custom text you want to use for this button) 
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If you want the button to use a pre-defined Tax Rate number (instead of forcing the Clerk to manually enter the Tax 

Rate number), enter the Tax Rate number into the Automatic Text field before [OFF] or [ON]. 

E.g. “1[ON]” or “1[OFF]” as shown in the below examples: 

 

 
 

 
 

Repeat the above steps and create a button for each Tax Rate that requires the ability to be enabled or disabled, 

ensuring that you enter the TaxRateNumber followed by [OFF] or [ON]. 
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Once the buttons have been created, the function is ready for use. 

 

Note that it is possible to configure this function to enable or disable multiple Tax Rates from one POS Screen button. 

The ability to enable or disable multiple Tax Rates via one POS Screen button is configured via the Keyboard Program 

Function as well as the POS Screen Layout. If you would like to utilise this functionality, please refer to the 

Enable/Disable multiple Tax Rates using Keyboard Program and Macros in the User Guide which outlines the required 

steps in full. 

 

Close the POS Screen Setup/POS Screen Layout windows.  

 

Open the POS Screen via the “POS” button, located on the top-left corner of the Back Office Dashboard. 

 

Select the POS Screen tab which contains the Tax Shift buttons that were created for this function. 

To turn a Tax Rate On, press the Tax Shift # On or Tax Shift # Off button. 

 

  
 

After pressing the button, the POS Screen sale window will display the following, indicating that the Tax Rate will be 

either off or on. 

 

 
 

 
  

https://userguide.idealpos.com.au/Default.htm#Taxes/Configure%20Tax%20Shift%20to%20Force%20Tax%20Rate%20On%20or%20Off.htm


 Update History 
Return to top 

Idealpos 8 Build 3 - Update History Page 95 of 95 

 

You can now add an item to the sale. 

The Tax Rate will be applied to the item and any consecutive items. 

Note that if the Yes/No Option “Tax Shift one item only” is enabled, the Tax Rate will only be applied to the next item 

added after the Tax button was pressed. Any consecutive items will be taxed as per the Tax Settings that have been 

enabled within the Stock Item. 

When an item has been added to the sale and the item has had a Tax applied to it, the number which corresponds to 

the Tax Rate will be displayed next to the Stock Item Description as per the below example: 

 

 
 

When there have been no taxes applied to the item, the Stock Item Description will be displayed without any Tax Rates 

next to the description, as shown in the example below: 

 

 
 

Once the current sale is finalised (i.e. voided, tendered, saved to a table, etc.), any items added to the next sale will be 

taxed as per the taxes that have been enabled within the Stock Item. 

 


