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EFTPOS 

IP-7188 – Oolio Pay Verifone – Support for Pinpad Home Image 

This function adds the ability to configure a Pinpad Home Image for the Oolio Pay AUS/NZ Verifone EFTPOS Interface. 

The Home Image can be a company logo or any promotional image that the company requires on their pinpad. 

 

Note that this function leverages “Screensaver Mode” functionality in Pocket Pad v2.1.50 or newer. 

As this functionality requires Pocket Pad v2.1.50 or newer to be installed on the Verifone device, contact Idealpos or 

your Idealpos Reseller for further assistance. 

 

To configure this functionality, ensure that Pocket Pad v2.1.50 or newer is running on the Verifone device and the 

“Screensaver Mode” option is enabled in the Pocket Pad app settings. 

 

An image in PNG or JPG format is recommended, and the aspect ratio of the image should be 4:3 (or match the aspect 

ratio of the Pinpad screen). 

While it is possible to place the image in any location, it is recommended that it is stored in C:\ProgramData\Idealpos 

Solutions\Idealpos\Pictures. This is so that the image will be available at all POS Terminals when sending the Pictures 

Folder to all POS Terminals via Back Office > Utilities > Send > Pictures Folder. 

 

Go to: Back Office > Setup > POS Terminals > Select a Terminal > Modify > EFTPOS Settings > Pinpad Home Image. 

Within the Pinpad Home Image field, press the “>” button and browse to the recommended folder location mentioned 

above which should contain the desired image. 

After selecting the image, the Pinpad Home Image field will contain the full path to the image, including the image 

filename as shown in the example below: 

 

 
 

Close the POS Terminal settings window to apply the change. 

If there are multiple POS Terminals with Verifone pinpads, repeat the above process for each POS Terminal. 

The image will be sent to each pinpad. 

Ensure that the Pocket Pad app is running on the Verifone device and ensure that the “Screensaver Mode” option is 

enabled in the Pocket Pad app settings. 

By default, the Pocket Pad app will display a purple Oolio logo if an image has not been set.  

The default purple Oolio logo will be displayed if there are any problems with the selected Pinpad Home Image. 
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Gift Card Interfaces  

IP-6715 – Vii Gift Card Integration 

This function adds Vii Gift Card support to Idealpos, enabling the ability to purchase and redeem Vii Gift Cards. 

Vii is Australia’s leading gift card provider, providing a seamless end to end service. 

Further information about Vii is available on their website – https://www.vii.com.au  

 

The steps to configure and use this interface are shown in this Update History document in the summarised form. 

For full in-depth information about configuring and using this interface, refer to the Vii Gift Cards topic in the Idealpos 

User Guide. In the User Guide Table of Contents on the left-hand side, scroll down to Vii Gift Cards and select the topic 

for further information. 

 

Prior to configuring this interface, note that this interface requires Vii Gift Cards to be enabled in the Idealpos Licence 

Gateway. The Vii Gift Cards module will need to be enabled on each POS Terminal that will utilise the Vii Gift Card 

functionality. 

Alternatively, if the POS Terminal has already been licensed for the Metcash Advanced module, the Vii Gift Cards 

functionality can be configured without purchasing the Vii Gift Card module. 

If the Vii Gift Card module needs to be added to the Licence Gateway, contact Idealpos or your Idealpos Reseller for 

further information. 

Once the licensing component has been completed, the interface can be configured. 

 

Confirm that the required module is enabled in the Licence Gateway 

To configure this interface, go to: Back Office > Setup > Licence Gateway. 

Confirm that the POS Terminals that will utilise this interface have the Vii Gift Cards module enabled (or alternatively, 

check that the Metcash Advanced module has been enabled as mentioned above). 

 

Configure the Gift Card Purchase/Gift Card Redemption Functions for Vii Gift Cards 

Go to: Back Office > Setup > Function Descriptors. 

Locate an unused Function Descriptor and configure as follows (for the redemption of Vii Gift Cards): 

Description: VII GIFT CARD 

Toggle required checkboxes for the Function Descriptor (e.g. Open Cash Drawer, etc.). 

 

Locate an unused Received Account and configure as follows (for the purchase of Vii Gift Cards): 

Description: VII GV PURCHASE 

Gift Voucher: Enable the Gift Voucher checkbox. 

 

Enable the VII Gift Card Tender 

Go to: Back Office > Setup > Yes/No Options. 

Untick the option “Inhibit VII GIFT CARD” 

 

Create a Vii Gift Card Enquiry button 

Go to: Back Office > Setup > POS Screen > POS Screen Setup > Select a layout > Press “Buttons”. 

Select a POS Screen tab and create a button linked to the Gift Voucher Enquiry function. 

Ensure that the Gift Voucher Type is set to “Vii Gift Cards” 

  

https://www.vii.com.au/
https://userguide.idealpos.com.au/
https://userguide.idealpos.com.au/
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Enter Vii Gift Card Interface credentials and link the Gift Card Purchase and Gift Card Redemption functions 

Go to: Back Office > Setup > Global Options > Interfaces > Vii Gift Cards. 

 

Gift Card Purchase: Select the Received Account function configured above. 

Gift Card Redemption: Select the Function Descriptor configured above. 

URL: Enter the URL supplied by VII. 

Username: Enter the Username supplied by VII. 

AIIC: Enter the AIIC supplied by VII. 

CATI: Enter the CATI supplied by VII. 

 

Create Stock Items for Vii Gift Cards 

Create a Stock Item for each Vii Gift Card Type/Denomination that has been supplied by Vii. 

E.g. $20, $50, $100, etc. 

 

Description: VII GIFT CARD $[EnterValue] (or enter the name of the Gift Card brand that has been designed for the 

venue). 

Department: Link to the GIFT CARD Department or the Department designated for this item. 

Scan Code: Enter the Scan Code for the Vii Gift Card (this is the Scan Code for the Gift Card, not the unique Gift Card 

number). 

Purchase Category: Link to the Purchase Category designated for Gift Cards. 

Default Supplier: If the item is supplied by a Supplier, link to the supplier here. 

Default Supplier Stock Code: If the item is supplied by a Supplier, enter the Default Supplier Stock Code here. 

Tax Settings: GST Free 

Attributes:  

Attribute Type: Special Attribute  

Attribute: Vii Gift Card 

Cost Prices: Enter the Cost Price as required. 

 

Selling Prices: Enter the Sell Price for the Gift Card into each of the Price Levels that are used by the venue/site. 

Force Selling Price Entry: If creating a Stock Item for a Gift Card with a variable amount (e.g. a Gift Card that can have a 

custom value loaded onto it), ensure that the “Force Selling Price Entry” checkbox is enabled. 

 

Close Suite/Open Suite to finalise the configuration 

Perform a Close Suite/Open Suite to finalise the configuration. 
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Using Vii Gift Cards 

 

Selling a Vii Gift Card 

Enter or Scan the Vii Gift Card Scan Code 

A Vii Gift Card Sale window appears and within the window, Scan/Enter the Vii Gift Card Code. 

If selling a Vii Gift Card with a custom/variable amount, enter the amount into the Amount field. 

Tender the sale > the Vii Gift Card is loaded with the value entered. 

 

Redeeming a Vii Gift Card 

Add the required items to the sale. 

Press the ENTER button to go the tender screen > enter the value to redeem > select the VII GIFT CARD Tender. 

Idealpos prompts to enter/scan the Gift Card and enter the Gift Card PIN > Press Get Balance. 

Then press the Redeem button to redeem the Gift Card. 

 

 

 

Further in-depth details about configuring and using the Vii Gift Card Integration are available in the Idealpos User 

Guide. 

Go to: https://userguide.idealpos.com.au and in the Table of Contents on the left-hand side, scroll down to “Vii Gift 

Cards”. The topic contains the following pages: 

Configuring Vii Gift Cards – This page outlines the process on how to configure the Vii Gift Card Interface. 

Using Vii Gift Cards – This page outlines the process on how to use Vii Gift Cards (Sale, Redemption, Enquiry, 

Cancellation). 

 

 

 

  

https://userguide.idealpos.com.au/
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Import Data 

IP-7156 – Import Coupon Promotions – Extra fields to support Coupons 

This change adds support for extra fields when importing Promotions. 

The extra fields enable the ability to import Coupon Promotions into Idealpos. 

The extra fields that have been added are listed as follows: 

 

• USER_DEFINED_TEXT – This field refers to the User-Defined Text field that appears in the Advanced tab of the 

Coupon Promotion. 

• INHIBIT_POINTS – This field refers to the Inhibit Points checkbox that appears in the Advanced tab of the 

Coupon Promotion. A value of 1 = Inhibit Points enabled, 0 = Inhibit Points disabled. 

• EXTERNAL_DESCRIPTION – This field refers to the External Description field that appears in the Advanced tab 

of the Coupon Promotion. 

• DATE_REDEEM_FROM – This field refers to the Redeem From field that appears in the Promotion tab of the 

Coupon Promotion (right-hand side of the window). 

• DATE_REDEEM_TO – This field refers to the Redeem To field that appears in the Promotion tab of the Coupon 

Promotion (right-hand side of the window) 

• REDEEM_DAYS – This field refers to the “OR X Days from Print Date” field that appears in the Promotion tab 

of the Coupon Promotion (right-hand side of the window). 

• POS_REDEEM_RANGE – This field refers to the Redeem at POS field that appears in the Promotion tab of the 

Coupon Promotion (right-hand side of the window) and controls which POS Terminals the Coupon Promotion 

can be redeemed at. 

 

Note that not all fields have to be included in the import file. 

Only include the fields that are required. 

 

To utilise these extra fields, include them in an import file and import the file by going to:  

Back Office > File > Sales > Promotions > Promotions. 

Press the “Import” button on the left-hand side of the window and browse to the file that contains the above fields 

with data for each field. 

 

To demonstrate this functionality, the contents of a sample import file are included below with these fields: 

 
ZONE,DESCRIPTION,TRIP_AMOUNT,DISCOUNT_TYPE,PROMO_PRICE,START_DATE,END_DATE,ITEM_CODE,USER_DEFINED_TEXT,INHIBI

T_POINTS,EXTERNAL_DESCRIPTION,DATE_REDEEM_FROM,DATE_REDEEM_TO,REDEEM_DAYS,POS_REDEEM_RANGE 

,Coupon Promotion,10,1,2.00,01/07/2025,31/12/2025,205401,USER DEFINED TEXT HERE,1,EXTERNAL DESCRIPTION 

HERE,01/08/2025,31/12/2025,14,1-2 

 

The contents of the above file shown in Notepad: 
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After importing the file via Back Office > File > Sales > Promotions > Coupon Promotions > Import, the resulting 

Coupon Promotion will appear as follows: 

 

Coupon Promotions – Promotion tab: 
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Coupon Promotions – Advanced tab: 
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Kiosk 

IP-7094 – Kiosk – Option for Customer Name Prompt 

This function introduces the ability to enable a Customer Name Prompt that will appear on the Kiosk Terminal after 

customer presses the “CHECK OUT” button. 

The name that the customer enters via the Customer Name Prompt will be printed on the customer’s receipt as well as 

the Kitchen Docket. 

Having the customer’s name appear on the Kitchen Docket will enable the Kitchen staff to identify which customer the 

order belongs to so that when it is ready for collection, the customer’s name can be called for them to collect their 

order. 

 

To configure this function, go to:  

Back Office > Setup > POS Terminals > Select the Kiosk Terminal > Modify > Display/Kiosk Tab. 

Enable the “Customer Name Prompt” checkbox. 

 

 
 

Close the Modify POS Terminal window. 

If there are multiple Kiosks at the site that require this functionality, repeat the above process to enable the Customer 

Name Prompt for each Kiosk. 

 

After configuring this functionality, the Kiosk Terminal should display the Customer Name Prompt on the next sale. 

However, if not, Idealpos can be restarted on the Kiosk Terminal via IPSUtils > Close (Windows Start Menu > Idealpos 

> IPSUtils > Press the “Close” button, then start Idealpos via the Idealpos desktop shortcut). 

Alternatively, the entire Kiosk Terminal can be restarted which will trigger the change to take effect. 
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To use this functionality, add items to the sale, then press the “CHECK OUT” button at the bottom of the Kiosk screen. 

 

 
 

The Customer Name Prompt will be displayed. 

The customer will enter their First Name and Last Initial using the on-screen keyboard, then press the “Continue” 

button at the bottom of the screen. 
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The Kiosk will show their name at the top of the Kiosk along with items that were ordered. 

The customer will finalise the sale by pressing the “Pay by Card” button at the bottom of the screen (or Pay at Counter 

if Pay at Counter is enabled). 
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The Kiosk will finalise the sale. 

The customer’s name will appear on the receipt printed from the Kiosk. 

 

 
 

The customer’s name will also appear on the Kitchen docket so that the kitchen staff can identify which customer the 

order belongs to. 
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IP-7095 – Kiosk Digital Receipt Functionality 

This function introduces the ability to configure the Kiosk to display a Digital Receipt Screen at the end of the sale 

which enables the customer to retrieve a digital copy of their receipt. 

The Digital Receipt Screen will display a QR Code which the customer can scan with their smartphone and from there, 

they will be taken to a page with their digital receipt. 

 

To enable this functionality, Idealpos Online is required. 

 

As the steps to configure this functionality are extensive, please refer to the Idealpos User Guide – Configuring Kiosk – 

Digital Receipt Screen page.  

Or go to https://userguide.idealpos.com.au and within the Table of Contents on the left-hand side, go to:  

Kiosk > Configuring Kiosk v2 > Digital Receipt Screen. 

 

In summarised form, the process to configuring this functionality involves following the below process: 

 

Go to: Back Office > Setup > POS Terminals > Select the Kiosk Terminal > Modify > Display/Kiosk tab. 

• Digital Receipt Screen: Enable the checkbox. 

• Header Text: Enter the desired Header text that will appear at the top-centre of the Digital Receipt Screen 

(default is “Your Order”). Note: If a Header Image will be configured below, ensure that the Header Text 

field is blank. 

• Footer Text: Enter the desired Footer text that will appear at the bottom of the Digital Receipt Screen (default 

is “Thank you for your Order!”) 

• Header Image: Select the desired Header Image that will appear at the top-centre of the Digital Receipt 

Screen. Supported image formats are JPG and PNG. The image must exist in C:\ProgramData\Idealpos 

Solutions\Idealpos\Pictures\. Note: If a Header Image is selected, ensure that the “Header Text” field is 

blank. 

 

 
 

The Digital Receipt Configuration needs to be completed in Idealpos Online. 

Go to: https://online.idealpos.com.au  

Go to Settings (bottom-left corner) > select the Subscription from the Subscriptions tab > Select the Receipt Format 

tab > Add Receipt Format > Configure the Receipt Format that will be used as the Digital Receipt (Header Logo, 

Header Text, Footer Text, Footer Logo) > Press “Add”. 

After the Receipt Format has been added > press the assign button (located under the Actions column) > enable the 

checkbox for the Kiosk Terminals > OK. 

 

After the above configuration has been completed, it is recommended that the Kiosk Terminals be restarted for the 

changes to take effect. 

 

  

https://userguide.idealpos.com.au/#Kiosk/Configuring Kiosk - Digital Receipt Screen.htm
https://userguide.idealpos.com.au/#Kiosk/Configuring Kiosk - Digital Receipt Screen.htm
https://userguide.idealpos.com.au/
https://online.idealpos.com.au/
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When a customer orders items from a Kiosk Terminal and after they’ve made payment at the Kiosk, the Kiosk will 

display the Digital Receipt Screen as shown below. 

The receipt screen will contain a QR Code at the top which they can scan with their smartphone to retrieve a digital 

copy of their receipt. 

After scanning the QR Code, their Digital Receipt is displayed on their smartphone. 

The example shown below left shows the Digital Receipt Screen on the Kiosk.  

The example shown below right is the Digital Receipt. 

 

  
  



    Update History 
Return to top 

Idealpos 9 Build 9 - Update History Page 15 of 25 

 

IP-7150 – Kiosk – Options to adjust Text on Code Scanning box 

This function introduces the ability to customise the Text on the Code Scanning box. 

This functionality is achieved by using User-Defined Options. 

The following User-Defined Options can be created on the Kiosk Terminal to customise the appearance of the Code 

Scanning box that appears at the top of the Kiosk screen. 

Note that the “Code Scanning” checkbox must be enabled in Back Office > Setup > POS Terminals > Select Kiosk 

Terminal > Modify > Display/Kiosk > “Code Scanning”. 

 

To create the User-Defined Options outlined below, go to: Back Office > Setup > POS Terminals > Select the Kiosk 

Terminal > Modify > POS Settings tab > User-Defined Options > Create the User-Defined Options as required. 

 

The User-Defined Options shown below are an example that show how the User-Defined Options are created to 

customise the appearance of the Code Scanning box. 

Each User-Defined Option outlined on the following page may require some trial and error to achieve the desired 

appearance/position of the text. 

 

 
 

The above options will alter the appearance of the Code Scanning box that appears at the top of the Kiosk screen 
(note that the VIPCard.jpg image used in this example is a custom image that is not included in the Demo Database- 
the image was created, then copied to the folder “C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\”). 
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KIOSKBUTTONPICTURE – This option enables a custom image to be displayed within the Scan Box button. Supported 

image formats are PNG and JPG. Enter the image name as the User-Defined Setting and ensure that the image exists 

in the “C:\ProgramData\Idealpos Solutions\Idealpos\Pictures\” path on the Kiosk Terminal. Note that the area 

designated for the image is quite small, so it is recommended that a small image be used (e.g. 50x40 pixels). 

 

KIOSKBUTTONPICXOFFSET – This option enables the x offset (horizontal) position of the picture button to be 

customised. Starting from the default position where the image appears, the image can be adjusted to appear further 

to the left. It cannot be moved to the right from the default image position. 

 

KIOSKBUTTONTEXT1 – This option enables the first line of text that appears within the button to be customised. 

Enter the desired text into the Setting column of the User-Defined Option. The default value that is used (when this 

User-Defined Option does not exist) is “Are you a Loyalty Customer?”. Some trial and error may be required to achieve 

the desired appearance and ensure that the desired message appears correctly on the Kiosk.  

 

KIOSKBUTTONTEXT1XOFFSET – This option enables the x offset (horizontal) position of the first line of text to be 

customised. Enter a value into the Setting column of the User-Defined Option. Entering a positive value will move the 

text to the right or entering a negative value will move the text to the left.  

 

KIOSKBUTTONTEXT1YOFFSET – This option enables the y offset (vertical) position of the first line of text to be 

customised. Enter a value into the Setting column of the User-Defined Option. Entering a positive value will move the 

text down or entering a negative value will move the text up.  

 

KIOSKBUTTONTEXT1BOLD – This option enables the first line of text to be set as bold. To set as bold, enter a value 

of 1 or to set as non-bold, enter a value of 0 into the Setting column of the User-Defined Option. 

 

KIOSKBUTTONTEXT1SIZE – This option enables the text size for the first line of text to be customised. Enter a value 

into the Setting column of the User-Defined Option. The default value is 12 (when the User-Defined Option does not 

exist). 

 

KIOSKBUTTONTEXT2 – This option enables the second line of text that appears within the button to be customised. 

Enter the desired text into the Setting column of the User-Defined Option. The default (when the User-Defined Option 

does not exist) is “Click to scan card and be rewarded”.  

 

KIOSKBUTTONTEXT2XOFFSET – This option enables the x offset (horizontal) position of the second line of text to be 

customised. Enter a value into the Setting column of the User-Defined Option. Entering a positive value will move the 

text to the right or entering a negative value will move the text to the left.  

 

KIOSKBUTTONTEXT2YOFFSET – This option enables the y offset (vertical) position of the second line of text to be 

customised. Enter a value into the Setting column of the User-Defined Option. Entering a positive value will move the 

text down or entering a negative value will move the text up. 

 

KIOSKBUTTONTEXT2BOLD – This option enables the second line of text to be set as bold.  To set as bold, enter a 

value of 1 into the Setting column of the User-Defined Option. To set as non-bold, enter a value of 0 into the Setting 

column of the User-Defined Option. 

 

KIOSKBUTTONTEXT2SIZE – This option enables the text size for the second line of text to be customised. Enter a 

value into the Setting column of the User-Defined Option. The default value is 12 (when the User-Defined Option does 

not exist). 

  



    Update History 
Return to top 

Idealpos 9 Build 9 - Update History Page 17 of 25 

 

IP-7173 – Kiosk – User-Defined Option to modify “Check Out” button caption 

This function introduces the ability to modify the default button caption “CHECK OUT” that appears within the button 

at the bottom of the Kiosk screen. 

 

To change the button caption, go to:  

Back Office > Setup > POS Terminals > Select a Kiosk Terminal > Modify > POS Settings tab. 

Within the User-Defined Options section on the bottom-left corner of the window, create the following User-Defined 

Option: 

• Description: KIOSKCHECKOUTBUTTON 

• Setting: Enter the desired button caption. It is recommended that a short description be used so that the 

entire caption is visible. If required, test the desired caption to ensure that it appears as desired. 

 

E.g. If the button is required to show “PAY ORDER”, create the User-Defined Option as follows: 

• Description: KIOSKCHECKOUTBUTTON 

• Setting: PAY ORDER 

 

 
 

Repeat the above process for each Kiosk Terminal that requires the button description to be updated. 

After creating the User-Defined Option, it is recommended that a Close Suite/Open Suite be performed on each Kiosk 

Terminal. Alternatively, the Kiosk Terminal can be restarted. 

 

The button shown at the bottom of the Kiosk will reflect the text configured in the User-Defined Option. 
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IP-7174 – Kiosk – Colour Options for Menu Tab Buttons 

This function introduces the ability to customise the colours for the Menu Tab Buttons that appear on the left -hand 

side of the Kiosk screen. 

The colour of the inactive Menu Bar Buttons can be customised as well as the colour of the currently selected Menu 

Bar button. 

 

To configure this functionality, go to:  

Back Office > Setup > POS Terminals > Select a Kiosk Terminal > Modify > Display/Kiosk. 

Within the Colours dropdown box, select the Menu Bar Button Colour or Menu Bar Selected Colour. 

 

 
 

After selecting the desired option, press on the coloured rectangle that appears next to the dropdown box to 

customise the colour. Press “OK” within the Colour selector window once the required colour has been selected. 
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The colour of the rectangle will change to the selected colour. 

 

 
 

If required, repeat the process to customise the Menu Bar Selected Colour. 

 

 
 

After the colours have been customised, close the POS Terminals window to finalise the changes. 

If there are multiple Kiosk Terminals at the venue that require the customisation of these colours, repeat the above 

process for each Kiosk Terminal. 

Once the changes have been made to all Kiosk Terminals, it is recommended that a Close Suite/Open Suite is 

performed on each Kiosk Terminal for the changes to be applied. 

 

When the Kiosk sale screen is displayed, the Kiosk tab button colours will be reflective of the changes made above. 
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Metcash Integration 

IP-7181 – Metcash Interface – Option to not create Indirect Links 

This functionality introduces the ability to configure Idealpos so that Indirect Links are not created or updated when 

processing a Metcash Host. This functionality is available via a new “Don’t Update Indirect Links” checkbox in Global 

Options > Interfaces > Metcash. 

 

To configure this functionality, go to: 

Back Office > Setup > Global Options > Interfaces > Metcash. 

Toggle the “Don’t Update Indirect Links” checkbox as required. 

 

Examples that outline how this checkbox affects the creation of Indirect Links are listed as follows: 

 

Example with “Don’t Update Indirect Links” disabled 

 

Process a Metcash Host (via Back Office > Utilities > Metcash > Import Files) and then create items in Idealpos (via 

Back Office > Utilities > Metcash > Product Linking > Metcash Products > Enable “Create Items” checkbox next to the 

items being created). 

After processing the host and creating the items, Indirect Items (such as VB Can 24*375ML) will have the Indirect 

Item checkbox enabled and they will be linked to the main item (e.g. VB Can 375ML). 

 

The Indirect Item checkbox is enabled as shown below: 
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The Indirect Item tab shows the link to the item. 
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Example with “Don’t Update Indirect Links” enabled 

 

Process a Metcash Host (via Back Office > Utilities > Metcash > Import Files) and then create items in Idealpos (via 

Back Office > Utilities > Metcash > Product Linking > Metcash Products > Enable “Create Items” checkbox next to the 

items being created). 

After processing the host and creating the items, Indirect Items (such as VB Can 24*375ML) will have the Indirect 

Item checkbox disabled and they will not be linked to the main item (e.g. VB Can 375ML). 

 

The Indirect Item checkbox is disabled, and the Indirect tab is greyed out, as shown below: 
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Qantum Interface 

IP-7232 – Qantum Interface – Support for ‘Non Financial’ Membership Category 

This function adds support for a ‘Non Financial’ Membership Category. 

If there is a Customer Type that matches the “MembershipCategory” field, then the Customer is mapped to this 

Customer Type. 

If the Customer Type called “Non Financial”, the Customer will not accumulate points. 
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Reports 

IP-7137 – eCommerce Prepaid Orders – Surcharges on Financial Report 

This function enables eCommerce Prepaid Order Surcharges to appear correctly on the Financial Report. 

Prior to this change, surcharges on eCommerce Prepaid Orders would be combined with other surcharges, causing 

confusion. 

 

To address this, the following has been done: 

 

eCommerce Orders 

• The surcharge has been taken out of “Gross Sales” and put into the top “Subtotal Surcharges” total. 

• The Online Tender has been split and the Surcharge has been put into its own Tender. 

 

eGift Card Sales 

• The surcharge is added to the GST Amounts totals 

• The Online Tender has been split and the surcharge has been put into its own Tender. 

• The Surcharge has been added to the Sales Categories Totals under the Surcharge Sales Category  

 

 

Tender Mapping has been introduced 

If there is a “Mr Yum” tender, then those orders will be linked to that tender rather than the “ONLINE” tender. 

 

To ensure that Tender Mapping for eCommerce works as intended, ensure that the Tender is named such that it is 

identical to the Order Source. 

The Tender Name is configured in Back Office > Setup > Function Descriptors > Modify the tenders as required and 

ensure that they are named to match the Order Source that is in use. 

 

ID Name 

1 Mobi2go 

2 Shopify 

3 Tyro Connect 

6 Mr Yum 

7 Idealpos 

8 ClevaQ 

9 TabSquare 

10 HungryHungry 

13 QJumper 

14 WooCommerce 

15 IBA 

17 Doshii 

18 Hungry Hungry 2.0 

19 eGift Cards 

20 Novo2 

21 Cater Care 
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Reservations 

IP-7217 – SevenRooms Interface – Reservations screen, sort by column 

This function introduces the ability to sort the list of SevenRooms reservations shown in the Reservations screen by the 

column header. This is achieved by pressing on the column header of the desired column to sort by selected column. 

 

To use this functionality, go to: POS Screen > Press the Table Map button > Reservations button. 

A list of SevenRooms Reservations will be displayed. 

Click onto any of the column headers to sort by the data shown within that column. 

E.g. Clicking onto the Arrival Time column header will sort the Reservations by the Arrival Time from earliest arrivals to 

the latest arrivals. 

 

 
 

The column header can be clicked multiple times to change the sort order. 

E.g. Pressing the Arrival Time column header again will sort the Arrival Times from the latest arrivals to the earliest 

arrivals. 

 

 
 

 

 

 


