
Build 50 

Update Details: 

** Enhancements 

    * [IP-220] - Ability to Import Stock Item Attributes by Code or Description 

    * [IP-801] - Adult Age Restriction functionality 

    * [IP-1193] - Customer Type triggers prompt in POS 

    * [IP-1194] - Customer Type can be printed on Kitchen Printer docket 

    * [IP-1352] - Promotion Group Customer Limit - ability to limit by Amount 

    * [IP-1354] - Manual Modifier Grid functionality by Stock Item 

    * [IP-1369] - New Stock Item Label 3x8 format with larger price 

    * [IP-1376] - EMV Datacap Eftpos - support for DisableContactless option 

    * [IP-1386] - Wristband printing on Zebra HC100 supports DATE tag 

    * [IP-1387] - Location Listing to include Stock Location and Site descriptors 

    * [IP-1397] - IBA Interface to support upgraded web service security 

    * [IP-1420] - Support for Tiering on Maxetag Gaming Interface 

    * [IP-1433] - Nitro Eftpos option to Not Print Eftpos Receipt Automatically 

    * [IP-1439] - Yes/No Option to Inhibit Back button on Grids 

    * [IP-1444] - Clubline Export - support for Supplier Discount fields 

    * [IP-1454] - Schedules - ability to Send Message to other terminals 

    * [IP-1485] - Increased Speed of Stock Purchase Invoice printing 

    * [IP-1493] - SQL Data - Waiting for Library Initialization message has stronger wording 

    * [IP-1498] - Enter Stocktake can filter by Department Range 

    * [IP-1500] - Quick Stocktake Function 

    * [IP-1501] - Kitchen Print Item Priority Order 

    * [IP-1509] - Yes/No Option - Automatically send Gift Voucher Email if email address is present 

    * [IP-1510] - Yes/No Option - Inhibit Zero Priced Items on Bill Prints 

    * [IP-1518] - Manual Export of Sales Data in Generic format 

    * [IP-1521] - Warning about nearing the 10GB SQL Server Express database limit 

    * [IP-1537] - Automatic Stock Items Export - Filter by Attribute Type 

    * [IP-1539] - Export Stock Items - ability to save a specific Automatic Export Format 

    * [IP-1540] - Export Stock Items - Scale Unit field added 

    * [IP-1541] - Export Stock Items - Attribute Codes and Description Fields added 

    * [IP-1546] - Attributes Listing 

    * [IP-1547] - Attributes Setup - Attribute / Attribute Type Codes displayed 

    * [IP-1548] - Range Programming - Support for Stock Item Attributes 

    * [IP-1549] - Attribute Types - Ability to Lock Type to specific Stock Item Columns 

    * [IP-1550] - Ability to Override Attribute Column Headers 

    * [IP-1555] - New Zealand Region - removed taxable supply indicator from receipts 

    * [IP-1556] - Stock Levels by Location Report - option to Hide Cost Prices 
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Adult Age Restrictions 

Adult Age Restriction functionality 

This functionality allows you to record an ID against a sale if the customer is deemed to look under the age specified.  

It is configured by Department, and anything sold from that Department will prompt the operator to choose if they 

need to see an ID or not. If an ID is not produced, any sales from linked departments will not be allowed and the sale 

will be cancelled. This functionality can be turned on or off using a Yes/No Option.  

 

Go to File > Sales > Departments > Select Department > Tick: Adult Restriction.  

 

 
 

You can toggle the display of the prompt on specific terminals using a Yes/No Option: Inhibit the Adult Restriction 

Prompt.  

 

Go to Setup > Yes/No Options > POS Screen > Inhibit the Adult Restriction Prompt.  

 

  
 

Go to Setup > Global Options > General > General > Adult ID Age: Set to legal drinking age (Displays at the top-left 

of the POS screen) > Adult Restriction Question Age: Set it to the age operators should think customers look before 

needing to produce ID.  
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Using Age Restriction: Over Age Requirement 

Open POS and start a sale by selling an item from a restricted Department. As soon as you press the stock item, a new 

window will display asking if the customer is over the specified age. No more items can be entered until the question 

has been answered. 

 

 
 

If the operator believes the customer is over 25, they just press the “OVER 25” button and the sale will continue as 

normal. The customer is free to purchase anything they choose.  
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Using Age Restriction: Under Age Requirement 

Open POS and start a sale by selling an item from a restricted Department. As soon as you press the stock item, a new 

window will display asking if the customer is over the specified age.  
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If the operator believes the customer is under 25, they just press the “UNDER 25” button. A new window will display to 

select the ID type to select that the customer must provide to prove they are of age.  

 

 
 

If the operator presses None, due to no ID being present, the sale will be cancelled.  
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The operator can select any other card type that is accepted as a form of ID.  
 

 
 
Enter the date of birth from the ID into the window.  
 

  
 
This will be recorded against the transaction. 
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If the date is voided from the sale, the ID request screen will display again. If the date entered is less than the Adult ID 

Date, a screen will display a message telling the operator the sale is cancelled and the reason why.  

 

 
 
All sales will be recorded in the Journal, successful or not.  
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Customers 

Customer Type Triggers Prompt in POS 

This functionality allows for the Customer Type to be prompted to display on the POS Screen for all customers who are 

linked to the Customer Type’s selected.  

 

Go to File > Customers > Customer Types > Modify > Prompt in POS > Save.  
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Customer Type can be Printed on Kitchen Printer Docket 

This option allows for the Customer Type to be printed to the kitchen, where the chef may be able to make the call to 

push those meal requirements through faster to give this level of customer’s higher service. The Customer Type will be 

printed at the top of the docket.  

 

Go to File > Customers > Customer Types > Modify > Tick: Print at Kitchen > Save.  
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Database 

Warning about nearing the 10GB SQL database limit 

This feature displays a warning message once the database reaches 9GB in size. 
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Export Data 

Automatic Stock Items Export – Filter by Attribute Type 

You now have the ability to Filter by Attribute Type when configuring Automatic Export Settings. 

When you select an Attribute Type in the “Filter by Attribute Type” setting, only Stock Items which match that Attribute 

Type will be included in the Stock Item Export. 

Go to Setup > POS Terminals > select a POS terminal > Modify > Import/Export > Filter by Attribute Type 
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Manual Export of Sales Data in Generic Format 

This option allows data to be manually exported using the Generic format. 

Go to Utilities > Export Data > Stock Item Sales > Select Generic as the Output File Format. 

Select the Date Range that you wish to export and press OK, then choose a file name and location to save the file and 

press Save. 
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Export Stock Items – Ability to save a specific Automatic Export Format 

This function adds the ability to customise the Automatic Export Format. 

Instead of using the default Automatic Export Format which exports Stock Items using a hard-coded selection of fields, 

you can now select up to 24 specific fields which will be exported when an Automatic Export takes place. 

To configure the Automatic Export Format, go to Utilities > Export Data > Stock Items > Export: Automatic Export 

Format.  

Select the specific fields that you want to include in the Automatic Export Format from each of the dropdown boxes. 

If you want the first row of the Automatic Export Format to include the headers of the fields that are being exported, 

tick the “Include Headers” checkbox.  

Note that you don’t have to fill out all available 24 dropdown boxes. 

Once you’ve selected the fields to be included in the Automatic Export Format, press the “Save Format” button. 
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In order to use the Saved Automatic Export Format, it needs to be enabled. 

To enable the Saved Automatic Export Format, go to  

Setup > POS Terminals > Select the POS Terminal which you configured the Automatic Export Format > Modify > 

Import/Export > Use Saved Automatic Export Format. 
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Export Stock Items – Attribute Codes and Description Fields added 

This function includes the ability to export Attribute Codes 1 through to 5 as well as Attribute Descriptions 1 through 

to 5 in the Export Stock Items – Automatic Export Format. To include these fields in the Automatic Export Format, go 

to Utilities > Export Data > Stock Items > Export: Automatic Export Format. 

Select from any of the Attribute Codes 1 through to 5 or Attribute Descriptions 1 through to 5 that you want to 

include in the Automatic Export Format. 
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If needed, you can identify the Stock Item Attributes in your system that correspond to Attribute Codes 1 – 5. 

Go to File > Sales > Stock Item Attributes 

The Attribute Types are listed in the left-hand side column and the Attribute Codes are listed in the right-hand side 

column.  

You may have to click on several Attribute Types in the left-hand side column in order to locate Attribute Codes 1 – 5 

in the right-hand side column. Only Attribute Codes between 1 to 5 can be included in the Automatic Export Format. 
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Export Stock Items – Unit field added 

This function includes the ability to export the Scale Unit field in the Export Stock Items – Automatic Export Format. 

To include this field in the Automatic Export Format, go to  

Utilities > Export Data > Stock Items > Export: Automatic Export Format 
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When the Scale Unit field is included in an Automatic Export Format, it will export whatever value is in the Scale Unit 

field in the Stock Item. In the following screenshot, “kg” has been entered in the Scale Unit field. 

 
 

 

Here is how the Stock Item will appear in a Stock Item Export. 

CODE,DESC,UNIT 

“          121013”,”BEEF RIBS”,”kg” 
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Global Options 

Ability to Override Attribute Column Headers 

This function allows you to override the Attribute Column Headers which are displayed in the Stock Items grid. 

Go to Setup > Global Options > Other Options > Attribute Column Headers 

 
 

You may also need to enable the Attribute Column Headers in Stock Items. 

Go to Setup > Users > Modify > Enable Attribute1Desc – Attribute5Desc 

 
 
The Stock Items Grid (File > Stock Control > Stock Items) will now show the updated Attribute Column Headers 

  



 Update History 
 

Support for Tiering on Maxetag Gaming Interface 

The Maxetag interface has been updated to support tiering. 

Using the Member Rating Guide within Max Gaming will adjust the Customer Type that is recorded in Idealpos. 

If the Update Customer Type from Member Rating Grade checkbox is enabled, the Customer will be added to the 

relevant Rating Customer Type, not the default selected Customer Type.  

This function can be enabled as follows 

Go to Setup > Global Options > Gaming > Update Customer Type from Member Rating Grade 
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Import Data 

Ability to Import Stock Item Attributes by Code or Description 

This function allows you to specify which Attributes a Stock Item will be linked to when importing new Stock Items or 

updating existing Stock Items using Utilities > Import Data > Stock Items. 

When using this function, you have the option of either specifying Attributes by Code or by Description. 

Attribute Codes and Attribute Descriptions can be displayed by running the Stock Item Attributes Listing which is 

explained in this document under Listings – Stock Item Attributes Listing. 

 

If you want to specify the Attribute Codes with your Stock Item import data, include the required attribute headers 

with your Stock Item data and list the appropriate attribute codes for each field: 

ATTRIBUTE1,ATTRIBUTE2,ATTRIBUTE3,ATTRIBUTE4,ATTRIBUTE5 

 

An example of Stock Item import data using Attribute Codes is: 

CODE,DESCRIPTION,DEPARTMENT,ATTRIBUTE1,ATTRIBUTE2,ATTRIBUTE3,ATTRIBUTE4,ATTRIBUTE5 

1,Test Stock Item,402,4,18,29,41,34 

 

If you want to specify the Attribute Descriptions with your Stock Item import data, include the required attribute 

headers with your Stock Item data and list the appropriate attribute descriptions for each field: 

ATTRIBUTE1DESC,ATTRIBUTE2DESC,ATTRIBUTE3DESC,ATTRIBUTE4DESC,ATTRIBUTE5DESC 

 

An example of Stock Import data using Attribute Descriptions is: 

CODE,DESCRIPTION,DEPARTMENT,ATTRIBUTE1DESC,ATTRIBUTE2DESC,ATTRIBUTE3DESC,ATTRIBUTE4DESC,ATTRIBUTE

5DESC 

2,Test Stock Item Two,402,1.25L Bottle,Bourbons,Cab Merlot,Australia,Contains Egg 

 

The Stock Import Data can be saved as a txt file and used in the Import Stock Items screen. 
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To import Stock Items, go to Utilities > Import Data > Stock Items 

 
 

Press the small magnifying glass icon  next to the path to browse to the file that contains the Stock Items you 

want to import or update. Once you have selected your file, press OK to import the Stock Items. The Stock Items will 

be imported using the Attributes that were included in the data. 
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Labels 

New Stock Item Label 3x8 format with larger price 

There is now a third format available for the 3x8 Landscape label. This format will have a larger price displayed than 

the other formats.  

 

Go to Utilities > Labels > Dimensions: 24 labels (3 x 8) Landscape > Design: Format 3 
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Listings 

Location Listing to include Stock Location and Site descriptors 

A change has been made to the Location Listing to show the locations where stock will be drawn from. Stock may be 

recorded as being in one location, but when it is sold, it is drawn from a different location.  

 

Go to Listings > Stock Control > Locations  
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Stock Item Attributes Listing 

This function will produce a list of all Stock Item Attributes that exist in the system. 

Go to Listings > Sales > Stock Item Attributes 
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POS Screen Setup 

Manual Modifier Grid functionality by Stock Item 

This function allows you to have a single button on the POS Screen called Modify (or whatever you choose), which 

links items to a specific grid only when required, instead of being forced to step the operator through various grids, or 

have multiple grids required to be on screen for many different items.  

 

Go to Setup > POS Screen > POS Screen Setup > Layouts > Buttons > Function: Manual Modifier.  

 

 
 

Whenever eggs are ordered for breakfast, they are fried by default (except for Scrambled Eggs, Eggs Benedict) unless 

specified. This allows the chef to know that when the order is received, he can just fry them unless otherwise 

instructed. It can save unnecessary printing of instructions when the default is set.  

 

Go to File > Stock Control > Stock Items > Stock Item: Eggs on Toast > Advanced tab > Link to Grid: Eggs Cooked > 

Tick: Manual Modifier.  
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Now, instead of the grid for Eggs Cooked opening automatically and a selection having to be made, if the customer 

wants Eggs on Toast, the chef cooks them fried. If the customer wants them poached, the operator can press the 

“Modify” button and select a cook type. If you try to modify an item that is not linked to the Modify function, it will 

prompt with a message that the item is not linked, so either cannot be modified, or has to be in a different manner.  
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Promotions 

Promotion Group Customer Limit - ability to limit by Amount 

This functionality allows for a Promotion Group to be used for a dollar value on Promotions within a set time frame on 

Promotions, Coupons and Customer Rewards. If you don’t configure Customer Types to only be able to use these 

promotions, the limits won’t apply to customers without an account.  

 

Go to File > Sales > Promotions > Promotion Groups > Customer Limit: Amount.  
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Go to File > Sales > Promotions > Add.  

 

 
 

In our example, only 10x the discount will be allocated, even though 11x of the item has sold.  
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Range Programming 

Support for Stock Item Attributes 

This function allows you to change the Stock Item Attributes fields across multiple Stock Items at a time. 

Go to Utilities > Range Programming > Stock Items 
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Reports 

Stock Levels by Location Report – option to Hide Cost Prices 

This function allows you to hide the Cost Prices on the Stock Levels by Location Report. 

Go to Reports > Stock Control > Stock Levels by Location > Hide Cost Prices > View 

 
 

The Stock Levels by Location Report will omit the Cost and Total Value columns in the report. 

  



 Update History 
 

Schedules 

Ability to Send Messages to other Terminals 

You are now able to configure messages to be sent to other terminals through Schedules menu. This allows for them 

to be configured for the future, and repeat as often as required.  

 

Go to Setup > Schedules > Type: Send Message > POS: POS Terminal codes that will receive the message. If you want 

to send a message to all terminals, leave this field blank. Any terminal that creates a message to be sent to all 

terminals, will not receive those messages, i.e. terminals cannot send messages to itself.   
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When the message is sent it will display on the screen.  
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Stock Item Attributes 

Attributes Setup – Attribute / Attribute Type Codes displayed 

This function displays the Attribute Code and Attribute Type Codes in the Stock Item Attributes screen. 

Codes for Attribute Types and Attributes are displayed on the left-hand side of the Attribute Type/Attribute. 

This functionality facilitates the function for Importing Stock Item Attributes by Code or Description.  

Go to File > Sales > Stock Item Attributes 
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Attribute Types – Ability to Lock Type to specific Stock Item Columns 

This function allows you to lock Stock Item Attributes to specific Stock Item Columns. 

Go to File > Sales > Stock Item Attributes 

 

 
 

Then select an Attribute Type from the left-hand side column and press the Modify button on the left-hand side. 

Enable the tickboxes for the columns that you want the Attribute Type to be available in, then press Save. 

Repeat this process for each Attribute Type that you want to lock to specific Stock Item Columns. 
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When you open a Stock Item and click on the Attribute Type dropdown box that corresponds to the column, you will 

now only see Attribute Types that have been locked to that column. 

The following are examples for the dropdown box in each column showing that a single Attribute Type has been 

locked to each column. 
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Kitchen Print Item Priority Order 

When a large group of items are ordered together, not only do they print within their print groups, but all of the 

different steaks print together, all of the different fish dishes print together etc. It basically allows the items that need 

the most cooking time to be grouped together. Items with no priority will appear at the bottom of the group of items.  

 

Go to File > Sales > Stock Item Attributes > Add New Attribute Type: Priority > Add New Priority: Enter a range of 

numbers used to order items > Save.  
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Using Kitchen Print Priorities 

Enter Stock Items into the sale in any order. In our example, the priority is displayed in the Stock Item Description.  

 

 
 

The items will be rearranged to print in the order of priority previously chosen. Items of the same priority will be 

printed in the order they were added to the sale.  
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Items within Print Groups will behave the same way.  

 

 
 

The items will be arranged into their Print Groups first, and then ordered in their priority. Items with no priority. 
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Instruction items will respect the item they were entered with and print in the correct order.  

 

 
 

Items in the kitchen will print with all instructions located correctly.  
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Stocktake 

Enter Stocktake can filter by Department Range 

You used to only be able to enter a single Department to filter the results, but you are now able to enter a Department 

range, enabling you to view more data. A Stocktake must be started to be able to view this screen.  

 

Go to Stocktake > Enter Stocktake > Filter Criteria > Department > Enter range; 210,204-205.  
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Quick Stocktake Function 

This function allows you to perform a quick stocktake from the POS screen on a small number of items. It is generally 

used for Service Stations who perform a stocktake when they read the volume of fuel in the tanks. You can configure 

multiple buttons by using a Department Range on each button, so only select Departments are available when that 

particular button is selected.  

 

Go to Setup > POS Screen > POS Screen Setup > Layouts > Buttons > Select Button > Function: Quick Stocktake.  

 

 
 

Department Range: Enter the Departments you want this button to be responsible for.  

Print Stocktake on Receipt Printer: Check to print out the variance reports on the receipt printer.  
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You are able to control which Users have access to this function so not all staff can access it.  

 

Go to Setup > Users > Select User > Clerk Permissions > POS > Quick Stocktake.  
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Using Quick Stocktake 

From the POS Screen select the Quick Stocktake button you created.  

 

 
 

A new window will open where you can enter the quantity of items into the stocktake field. Use the keypad to enter 

the quantity of items and the arrow buttons to the line above or below. You can also directly press the stock item to 

select it.  

 

 
 

When you are ready to save the details, or need to use the POS screen, press Update Stock Levels.  

 

 
 

  



 Update History 
 

A confirmation message will display on screen.  

 

 
 

If a receipt is set to print, the details will be included on there.  
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All Quick Stocktake variances will be recorded in the Archived Stocktakes Reports.  

 

Go to Reports > Stock Control > Archived Stocktakes > Select > View.  
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Yes/No Options 

Yes/No Option to Inhibit Back button on Grids 

This option will hide the Back button on POS screen Grids. It means staff are required to have to enter an item from 

the grid before they can continue with the sale.  

 

Go to Setup > Yes/No Options > POS Screen > Inhibit Back Button on Grids.  

 

 
 

The button will appear a cream colour and not function. You can program a double size button to display over this 

button if required.  
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Yes/No Option – Automatically send Gift Voucher Email if email address is present 

This option will automatically send a Gift Voucher email to the customer when the customer purchases a Gift Voucher 

and there is an email address present for the customer. 

 

Go to Setup > Yes/No Options > Customers > Automatically send Gift Voucher Email if email address is present 
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Yes/No Option - Inhibit Zero Priced Items on Bill Prints 

This option will allow or inhibit zero-priced items from displaying on the bill print and will be ticked by default.  

 

Go to Setup > Yes/No Options > Receipt/Kitchen > Inhibit Zero Priced Items on Bills.  
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Zebra Wristband Printing 

Wristband printing on Zebra HC100 supports DATE and DATE+ tag 

Idealpos will now also support the DATE and DATE+ tags, allowing for more information to be displayed.  

 

For information on using this feature, please visit this link.  

 

 
 

 

 

 

 

http://www.idealpos.com.au/Idealpos/media/Downloads/Userguide/New/Default.htm#Labels/Zebra%20HC100%20Label%20Printer%20for%20Wristbands.htm?Highlight=zebra%20wristbands

