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Back Office 

IP-7533 – Activity Log – Support for Sent Emails 

This functionality adds support for recording entries in the Activity Log/Activity Enquiry when emails are sent from 

Idealpos. 

When Idealpos sends Emails such as Schedules or Send Test Email, an entry for the sent email will be recorded in the 

Activity Log/Activity Enquiry. 

There is no additional configuration required to enable the recording of sent emails in the Activity Log/Activity 

Enquiry. If the Email Settings in Idealpos are configured correctly, events will be written to the Activity Log/Activity 

Enquiry when an email is sent by Idealpos. 

 

For additional in-depth information about the Activity Log, please refer to the Activity Log and Activity Enquiry topic in 

the User Guide. 

 

To configure Email Settings in Idealpos, go to: Back Office > Setup > Global Options > Other Options > Email Settings. 

In the Email Service dropdown box, select one of the following options: 

 

• Idealpos Email – Select this option to use the built-in Idealpos Email Service. When selecting this option, 

additional configuration such as SMTP Outgoing Email Server, SMTP Username, etc. are not required. 

• Sending Email Address – Enter the Sending Email Address in this field. The Sending Email Address will be 

included in emails that are sent from Idealpos. E.g. When a recipient of an email sent from Idealpos selects the 

“Reply” option, the “To” field will be pre-populated with the Sending Email Address. If this field is blank, the 

email address configured in Back Office > Setup > POS Terminals > Modify > Main Settings > User Settings > 

Email will be used as the Sending Email Address. If the Sending Email Address in Global Options > Other 

Options and the Email Address in Setup > POS Terminals > Main Settings are both blank, then the Sending 

Email Address used will be no-reply@idealpos.co. 

 

• Custom – Select this option to use custom configuration of your own Email Service. 

• SMTP Outgoing Email Server – Enter the SMTP Outgoing Email Server as supplied by your Internet Service 

Provider. 

• Sending Email Address – Some Email Servers require a Sending Email Address to authenticate. If this field is 

blank, Idealpos will use the Email Address that is set in Back Office > Setup > POS Terminals > Modify > Main 

Settings > User Settings. This email address must match the server details of the service that is being used. E.g. 

If using Gmail, a @gmail.com account will need to be used. 

• SMTP Username – Enter the SMTP Username supplied by the Internet Service Provider. 

• SMTP Password – Enter the SMTP Password supplied by the Internet Service Provider. 

• SMTP Port – Enter the SMTP Port supplied by the Internet Service Provider.  

 

  
  

https://userguide.idealpos.com.au/Default.htm#Back%20Office/Activity%20Log%20and%20Activity%20Enquiry.htm
https://userguide.idealpos.com.au/
mailto:no-reply@idealpos.co
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When an email is sent by Idealpos, the event will be recorded in the Activity Log. 

Go to: Back Office > Enquiry > Activity Log. 

Sent emails will appear as “Email: name@domain.com”. 

The content (message body) of sent emails is not stored in the Activity Log. 

 

  

mailto:name@domain.com
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Coupon Promotions 

IP-7545 – User-Defined Option to Import Coupons 

This functionality adds the ability to import Coupons via a User-Defined Option. 

Note that Coupons imported with this functionality will be linked to Coupon ID 1/PromotionTableID20001 (i.e. typically 

the first Coupon Promotion). 

Also note that Imported Coupon Codes are all treated as Redeemed. 

Therefore, this functionality is for importing redeemed Coupon Codes which may have been redeemed at another 

venue that should no longer be accepted at the current venue. 

 

To configure and use this functionality, go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > POS Settings > User-Defined Options. 

 

Ensure that the folder path configured in the below User-Defined Option will only be used for this functionality. 

The folder must not contain any text files that are not related to the Import Coupon functionality. 

It is therefore recommended that a specific folder is created and only used for this function. 

 

Create the following User-Defined Option: 

 

• Description: IMPORTCOUPONREDEMPTIONSFILE 

• Setting: Enter the path and filename of the Redemption File. 

 

An Example Setting is shown below: 

• Setting: C:\TEMP 
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The contents of the Coupon Redemption File need to contain a comma separated list of Coupon Codes. 

The below is a sample list of Coupon Codes: 

 

115939849,215939849,315939849,415939849 

 

The below screenshot shows the Coupon Codes within a “CouponRedemptions.txt” file: 

 

 
 

Copy the CouponRedemptions.txt file into the folder path configured in the User Defined Option (e.g. C:\TEMP\). 

Note that any filename can be used for the Coupon Redemption files. 

Once the file has been copied to the Import Folder location, Idealpos will import the Coupon Codes.  

The file will be removed after the Import has been completed. 

 

All imported Coupon Codes will be treated as redeemed. 

The Date Redeemed will be recorded as the date which the Coupon Redemption was imported. 

Attempting to redeem an Imported Coupon will display the following prompt on the POS Screen: 
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Customers 

IP-7649 – Fast Customers – Support for Scan Code as a searchable Parameter 

This function adds an option to search for Customers by Scan Code when using the Fast Customer Searching screen 

on the POS. 

To utilise this functionality, go to:  

Back Office > Setup > Yes/No Options > Search “Fast Customer Search”.  

Ensure that the Yes/No Option “Fast Customer Searching” is enabled. 

 

 
 

Close the Yes/No Options window. 

Customers will need to have Scan Codes to utilise this functionality. 

Scan Codes are set in the record of each Customer. 

Go to: Back Office > File > Customers > Customers > Select a Customer > Modify. 

Ensure that the Scan Code field is populated with the Customer’s Scan Code. 
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Go to: POS Screen. 

Press the “Customer” button > The Fast Customer Searching screen is displayed. 

A new “Scan Code” button is available. 

Select the “Scan Code” button, then enter the Customer’s Scan Code into the search field  > the Customer with the 

entered Scan Code is displayed. 
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Export Data 

IP-7549 – Department Sales Automatic Export 

This functionality introduces the ability to automatically export Department Sales Totals via the Automatic Export 

function. 

 

To configure and use this functionality, go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Import/Export. 

Configure the Automatic Export Settings as follows: 

• Export Folder: Select a folder to export data to (e.g. C:\Temp). 

• Export Sales Format: Department Totals 

• Sales From: Select the required option (All POS Terminals, This POS Only or This Site Only). 

• Export Daily at/or every # minutes: Enter a daily export time in 24 hour format or enter a value into the 

every minutes field.  
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The Automatic Export will be triggered as per the Export Daily at time/or every # minutes. 

The below is an example of data that has been exported with the Department Totals option. 
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IP-7580 – Stock Item Sales Export – Stock Item Totals Format 

This functionality introduces the ability to automatically export Stock Item Totals via the Automatic Export function. 

 

To configure and use this functionality, go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Import/Export. 

Configure the Automatic Export Settings as follows: 

• Export Folder: Select a folder to export data to (e.g. C:\Temp). 

• Export Sales Format: Stock Item Totals 

• Sales From: Select the required option (All POS Terminals, This POS Only or This Site Only). 

• Export Daily at/or every # minutes: Enter a daily export time in 24 hour format or enter a value into the 

every minutes field.  
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The Automatic Export will be triggered as per the Export Daily at time/or every # minutes. 

The below is an example of data that has been exported with the Stock Item Totals option. 
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IP-7654 – Export Other Data – Activity Log Email Addresses 

This function adds the ability to Export Activity Log Email Addresses. 

This function works in conjunction with IP-7533 – Activity Log – Support for Sent Emails. 

When the “Activity Log Email Addresses” option is selected, Idealpos will export a list of Email Addresses that were 

recorded in the Activity Log for the selected Date Range. 

Email Addresses are simply exported as one email address per line in the exported file. 

 

For additional in-depth information about Export Data functionality in Idealpos, please refer to the Export Data topic in 

the User Guide. 

 

To export Activity Log Email Addresses, go to: Back Office > Utilities > Export Data > Other Data. 

In the Export Data Type dropdown box, select the option “Activity Log Email Addresses”. 

In the Date Range, select the required Date Range. 

Press “OK” on the top-left corner to export the Activity Log Email Addresses. 

 

 
 

  

https://userguide.idealpos.com.au/Default.htm#Export%20Data/Export%20Data.htm
https://userguide.idealpos.com.au/
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Browse to a folder location to save the file to, then press “Save”. 

 

 
 

The Activity Log Email Addresses will be exported to the file as one email address per line. 

The below is an example of how the exported email addresses will appear in the file. 
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Labels 

IP-7568 – Stock Item Labels – DesignPro/LabelJoy Export – Support for Stock Item Attributes 

This functionality adds support for the inclusion of Stock Item Attributes in the label data exported by Idealpos. 

Any Attributes that are linked to each Stock Item will be included in the exported label data. 

The Attribute Descriptions associated with each Stock Item can then be included on the generated labels. 

E.g. To indicate which Country a Stock Item is sourced from, a Country-of-Origin Attribute can be linked to Stock 

Items, and the Country of Origin can be included on the labels.  

This will enable customers to easily identify which country a product was sourced from. 

 

If utilising the Stock Item Attribute functionality on labels, it is strongly recommended that each Attribute Type column 

is reserved for a specific Attribute Type.  

This is to ensure that the printed labels display the correct information (as the process for configuring the Label 

Format design may require inserting text prior to the Attribute to describe the Attribute; e.g. Country-of-Origin: 

[Attribute]). 

 

E.g.  

Container Type in Attribute Column 1 

Country of Origin in Attribute Column 2 

Etc. 

 

This can be achieved by going to Back Office > File > Sales > Stock Item Attributes > Select an Attribute Type on the 

left-column and pressing Modify > enable the checkboxes as required to restrict Attribute Types to specific Attribute 

Columns.  

This will ensure that each Attribute Type Column will only show the Attribute Type(s) reserved for that column. 

Note that this will not update any existing Attribute Types that have already been linked to Stock Items. 
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When each Attribute Type has been restricted to a single Attribute Column, it will be the only Attribute Type that will 

appear in the dropdown box for that slot when modifying a Stock Item. 

 

File > Stock Control > Stock Items > Select a Stock Item > Modify > Attributes. 

 

 
 

Attribute Column 1 only shows the “Container Type” Attribute Type in the dropdown box as configured earlier: 

 

 
 

Attribute Column 2 only shows the “Country of Origin” Attribute Type in the dropdown box  as configured earlier: 
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If configuring Label functionality from scratch, refer to one of the following topics, depending on the Label application 

being used; the step when the fields are dragged onto the label, the new Attribute1-5 fields will appear which can be 

dragged onto the label: 

• Avery Design Pro topic in the User Guide (the “Design the Label” page covers adding fields to the label). 

• Labeljoy topic in the User Guide (the Create Labels and Layout in Labeljoy covers adding fields from the Data 

Source). 

 

If one of the above applications have already been configured to print Idealpos Labels, the Label Format can be 

modified to include the new Attribute fields. 

 

To do this, ensure that you export Labels from Idealpos after updating to the new build. 

Go to: Back Office > Utilities > Labels > Select the Label Format > Add Stock Items with Attributes to the grid > 

Export. 

The Label application may open. 

From this point, the Label Format can be opened in the label application, typically by going to:  

File > Open > Browse to the Label format file. 

If using Avery Design Pro, the format is typically a file with a ZDP extension.  

If using Labeljoy, the format is typically a file with a lpa extension. 

 

Avery Design Pro: 

The Insert Field window should include Attribute1 to Attribute5 in the list of Fields. 

Scroll down and select the required Attribute > Insert. 

Note that you may want to use the “Insert Text” function in Avery Design Pro to add a description before the Attribute 

Field (e.g. Add “Country of Origin” before the Attribute field so that the label will show “Country of Origin: [Attribute]”, 

where [Attribute] will be replaced with the Country of Origin data from Idealpos). 

 

 
 

  

https://userguide.idealpos.com.au/#Labels/Avery%20Design%20Pro.htm
https://userguide.idealpos.com.au/Default.htm#Labels/Avery%20Design%20the%20Label.htm
https://userguide.idealpos.com.au/#Labels/Labeljoy.htm
https://userguide.idealpos.com.au/#Labels/Labeljoy%20Create%20Labels%20and%20Layout.htm
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Labeljoy 

The Data Source functionality in Labeljoy can be used to drag the new Attribute fields to the label. 

In the example below, Attribute2 is being used as per the screenshot on the previous pages where Attribute2 is 

assigned to Country of Origin. 

 

Note that the new Attribute1, Attribute2, Attribute3, Attribute4 and Attribute5 fields will appear provided that Idealpos 

has generated Labels after being updated to the new build. 

If the new Attribute fields do not appear in the Data Source, go to: Idealpos > Utilities > Labels > Select the previously 

configured Labeljoy Format > Add Stock Items with Attributes to the Grid > Export. 

This should trigger new data to be exported to the Label Data File which will include the new Attribute fields/data. 
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Note that the text will only include the Attribute Description (e.g. if Country of Origin is “Australia”, the Description wil l 

only show the Country Name on the label as per the example below). 
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Therefore, you may want to select the Attribute field on the Label, then add “Country of Origin” before {Attribute2}. 

This will ensure that the “Country of Origin:” text appears before the actual Attribute data imported from Idealpos. 

Some other adjustments may be required to the label design (resize/move the Stock Item Descriptions on the label) to 

ensure that the Country-of-Origin information appears on the label as desired. 

 

 
 

After the change has been made, save the Label format (lpa) file to ensure that the Attribute data is included on any 

future labels printed from Idealpos.  
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LMG Integration 

IP-7510 – LMG Interface – CPI Price File Import Functionality 

This function introduces the ability to import a CPI Price File from LMG and any Price Changes that are found are 

added to a Scheduled Price Change. 

 

The functionality works as follows: 

The CPI Pricing File is searched for items which match the configured State, Banner and Pricing Zone. 

Any Stock Items in Idealpos which have a Scan Code or Alternate Code that match the Barcode in the CPI File for the 

configured State, Banner and Pricing Zone will be added to a Scheduled Price Change. 

 

To configure and use this functionality, go to: Back Office > Setup > Global Options > Interfaces > LMG. 

 

• State: Enter the State for the CPI Pricing Import (e.g. QLD, SA, etc.). The States will appear in the “State” 

column of the CPI Pricing File. 

• Banner: Enter the Banner for the CPI Pricing Import (e.g. Bottlemart). The Banners will appear in the “Banner 

Name” column of the CPI Pricing File. 

• Pricing Zone: Enter the Pricing Zone for the CPI Pricing Import (e.g. 1). The Pricing Zones will appear in the 

“Pricing Zone” column of the CPI Pricing File. 
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After the CPI Pricing Import has been configured, go to: Back Office > Setup > POS Terminals > Select a POS Terminal 

that will handle the Automatic Import > Modify > Import/Export. 

Within the Import/Export tab, configure the Automatic Import Settings section as follows: 

 

• Import Folder: Enter the Folder Path where the CPI Pricing file will be imported from. Idealpos will look for a 

file named cpi_pricing_*.CSV in this folder (e.g. cpi_pricing_202512_details.csv). 

• Delete files after importing: Enable 
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Once the above steps have been completed, the CPI Price File Import Functionality is ready for use. 

Go to the import folder configured above and paste the CPI file into the folder (the CPI file will need to be named in 

the filename format of cpi_pricing_*.csv – e.g. cpi_pricing_202512_details.csv). 

 

 
 

After the file is imported, the file will be renamed. 

 

 
 

  



    Update History 
Return to top 

Idealpos 9 Build 13 - Update History Page 23 of 57 

 

If any Price Changes are found for the imported CPI File, a Scheduled Price Change will be created. 

The name of the price Change will match the CPI Change Import file. 

Go to: Back Office > File > Sales > Scheduled Price Changes. 

A Scheduled Price Change is created. 
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Select the Scheduled Price Change and press “Modify” to view the Stock Items included in the Price Change. 

 

 
 

The Scheduled Price Change will be run automatically at the date/time shown.   
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Metcash Interface 

IP-7538 – Metcash Interface – Unlinked Items Option on Metcash Products Screen 

This function introduces the ability to filter the Metcash Products Screen by Unlinked Items. 

Selecting the Unlinked option will show Metcash Products which are not linked to an Idealpos Stock Item. 

 

For additional in-depth information about using the Metcash Interface, please refer to the Metcash Integration topic in 

the User Guide. 

 

To access this functionality, go to: Back Office > Utilities > Metcash > Product Linking > Metcash Products tab. 

Select the “Unlinked” option at the top of the window to only display Metcash Products which haven’t been linked to 

Idealpos Stock Items. 

 

 
 

If required, Unlinked Metcash Products can be: 

• Created as New Items – Enable the checkbox under the Create Items column for each item that needs to be 

created. 

• Linked to Existing Items – To link to an existing item, select the item, then press the “Link Existing Item” 

button on the left-hand side. 

 

After the Metcash Products are created as new items or linked to existing items, they will be removed from the 

Unlinked filter. 

 

  

https://userguide.idealpos.com.au/Default.htm#Metcash%20Integration/Metcash%20Integration.htm
https://userguide.idealpos.com.au/
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Pending Sales 

IP-7532 – A4 Pending Sale Prints – Customer Company/Phone/Email fields 

This functionality adds the Customer Company/Phone/Email fields to the top of the A4 Pending Sale print. 

There is no additional configuration required to enable these fields. 

Provided that the data exists against the Customer’s record, these details will be included within the A4 Pending Sale 

print. 

 

For additional in-depth information about using the Pending Sale functionality, please refer to the Pending Sales topic 

in the User Guide. 

 

To use this function, go to: Back Office > File > Customers > Customers. 

Select a Customer > Modify. 

 

Ensure that the customer’s record contains a Company, Phone Number and Email address so that these details appear 

on the A4 Pending Sale print. 

Note that the Mobile Number takes priority over the Phone Number. 

E.g. If the customer’s record contains a Phone Number and a Mobile Number, the Mobile Number will be shown on 

the A4 Pending Sale. 

 

The below shows the fields which store the Customer Company, Phone and Email fields: 

 

 
 

  

https://userguide.idealpos.com.au/Default.htm#Pending%20Sales/Pending%20Sales.htm
https://userguide.idealpos.com.au/
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Go to: POS Screen. 

If a Pending Sale does not already exist for the customer, create a Pending Sale as follows. 

Add the customer to the sale > add items to the sale > Press the “Pending” button. 
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The customer’s details are pre-populated into the fields > Press “Save” to save the Pending Sale. 
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Once a Pending Sale exists for the customer, from a blank sale without items, press the “Pending” button. 
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Ensure that the Pending Sale is selected, then press the “Windows Print” button on the bottom-left corner of the 

window. 
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The A4 Pending Sale is printed to the Windows Printer; it will include the Customer’s Company Name, Phone Number 

and Email Address, as shown below. 
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POS Screen Functions 

IP-7560 – A4 Tax Invoice – Packing Slip tag to hide Invoice text data 

This function introduces the ability to hide Invoice Text Data from the A4 Tax Invoice. 

This can be utilised when a store wants to create a Packing Slip for an order. 

The following data is hidden from the Tax Invoice when using this functionality: 

• Customer’s ABN 

• Invoice # 

• “TAX INVOICE” text 

• Invoice Footer Graphic 

 

To configure and use this functionality, go to: Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons > Select a POS Screen Tab > Locate a blank button and configure as follows: 

 

Function: Tax Invoice 

Automatic Text: [PACKINGSLIP] 

Button Appearance: Customise as required. 

Button Caption: Tax Invoice – Packing Slip (or enter a suitable description as required) 

 

Press “Save” to save the button. 

 

 
  

Close the POS Screen Layout window. 
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Go to: POS Screen. 

Perform a sale and tender as required. 

On the next sale, press the “Tax Invoice – Packing Slip” button. 

The Print Tax Invoice window will by default show the Transaction Number for the last sale. 

Press the “View” button to display the Packing Slip. 

If a Packing Slip is required for a different sale, enter the Journal Number into the “Number” field, then press “View”. 
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The Packing Slip is displayed when pressing “View”: 

The Packing Slip excludes the ABN, Invoice #, “TAX INVOICE” text and Invoice Footer Graphic. 
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Reports 

IP-7602 – Price Changes Report support without Stock Control License 

This function adds the ability to access the Price Changes Report on an Idealpos system that is not licensed for the 

Stock Control module. 

To enable non-Stock Control systems to access the Price Changes Report, the report has been moved to a different 

menu on the Back Office. 

• Previous location of the Report: Back Office > Reports > Stock Control > Price Changes. 

• New location of the Report: Back Office > Reports > Sales > Price Changes. 

 

For more in-depth information about using the Price Changes Report, refer to the Reports > Sales topic in the User 

Guide. 

 

  

https://userguide.idealpos.com.au/Default.htm#Reports/Sales.htm
https://userguide.idealpos.com.au/
https://userguide.idealpos.com.au/
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Reservations 

IP-7444 – Now Book It – Restaurant Reservations Integration 

This functionality adds the ability to configure Idealpos with Now Book It. 

Now Book It is a restaurant reservation system that includes the following functionality: 

• Venue gets access to Now Book It’s Diary to place and manage reservations. 

• Ability to configure and create a Now Book It widget and extract HTML code to add to venue’s website. 

• Venue’s customers can place their reservations via the Now Book It widget on venue’s website. 

• Reservations placed in Now Book It will appear in the Idealpos Table Map. 

• Ability to request a deposit from a customer when placing the reservation via Now Book It; Customer is sent a 

link which enables them to pay the reservation, and once paid, reservation appears in Now Book It and 

Idealpos Table Map. 

• Deposits paid by the customer are deducted from the total amount when paying the table at the end of the 

booking.  

 

The Now Book It interface is configured in Idealpos Online and therefore requires an Idealpos Online subscription. 

The Now Book It interface also requires Now Book It to be enabled in the Idealpos Licence Gateway for each POS 

Terminal and Back Office that will utilise this interface. 

 

Refer to the Idealpos User Guide for more information about setting up and using this interface. 

Go to: https://userguide.idealpos.com.au 

In the User Guide Table of Contents on the left-hand side, navigate to Reservations Interfaces > Now Book It.  

https://userguide.idealpos.com.au/
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Schedules 

IP-7576 – Scheduled Tax Shift Functionality 

This functionality introduces the ability to shift the Tax Rate to a different rate via a Schedule. 

This functionality is only available for Australia and New Zealand and is primarily used by mobile venues that trade in 

various areas where different tax rates apply. 

E.g. A restaurant on a cruise ship which trades in international waters where different Tax Rates apply (or no Tax Rates 

apply) while abroad. 

 

While this functionality is inactive, Stock Items are sold at their standard Sell Prices. 

While this functionality is active via a Schedule, Stock Items are sold at their shifted Tax Rate Sell Price. 

 

Example when Tax Shift is off: 

• Stock Item Sell Price - $10.00 

• Tax Rate enabled for Stock Item – Rate 1 (GST). 

• Tax Rate 1 Amount – 10% 

• Price when sold - $10.00 

• Inclusive Tax amount shown on receipt - $0.91. 

 

Example 1 when Tax Shift is on (Shifted Tax Rate 3 set as 5%): 

• Stock Item Sell Price - $10.00 

• Tax Rate enabled for Stock Item – Rate 1 (GST) 

• Tax Rate 1 Amount – 10% 

• Shifted Tax Rate 3 (Tax Rate 3 set in Global Options) – 5% 

• Price when sold - $9.55 

• Tax amount shown on receipt (this amount is included in the sold price) - $0.45. 

 

How the new Sell Price is calculated in Example 1: 

The Original Sell Price of $10.00 has the original Tax amount of 10% deducted. 

I.e. $10.00 / 1.1 = 9.09. 

The tax exclusive amount of $9.09 then has the new Tax Rate applied. 

I.e. 9.09 x1.05 = 9.545454545454545 (which rounds up to $9.55 which is the new Sell Price triggered by the Tax Shift 

function). 

 

Example 2 when Tax Shift is on (Shifted Tax Rate 2 set as 0% - i.e. the GST Free rate) 

• Stock Item Sell Price - $10.00 

• Tax Rate enabled for Stock Item – Rate 1 (GST) 

• Tax Rate 1 Amount – 10% 

• Shifted Tax Rate 2 (Tax Rate 2 set in Global Options) – 0% 

• Price when sold - $9.09. 

 

How the new Sell Price is calculated in Example 2: 

The Original Sell Price of $10.00 has the original Tax amount of 10% deducted. 

I.e. $10.00 / 1.1 = 9.09. 

Since the Shifted Tax Rate 2 is set as 0.00%, there is no new Tax Rate added on, therefore the Sell Price is $9.09. 

  



    Update History 
Return to top 

Idealpos 9 Build 13 - Update History Page 38 of 57 

 

To configure and use this functionality, go to: Back Office > Setup > Global Options > Sales > Tax Rates. 

Depending on the requirements, the existing Rate 2 (0.00% Tax) can be used if no Tax is to be applied when the 

Scheduled Tax Shift function is active. 

If other Tax Rates need to be configured, they can be set within the available Tax Rate 3 to Tax Rate 6 slots. 

If configuring other Tax Rates, take note of which Tax Rates have been set in each Tax Rate Slot number (as the slot 

numbers will be required when creating the Schedules for the Scheduled Tax Shift functionality). 

 

 
  



    Update History 
Return to top 

Idealpos 9 Build 13 - Update History Page 39 of 57 

 

To configure Scheduled Tax Shift, go to: Back Office > Setup > Schedules. 

Separate Schedules will need to be created to enable and disable the Scheduled Tax Shift functionality at the required 

days/times. 

 

E.g. A Restaurant Cruise Ship is expected to cross a border and leave Australian territory at 11AM on 8 th January 2026 

where a Tax Rate of 0.00% applies (enable Scheduled Tax Shift to set the Tax Rate to 0.00%). 

The Restaurant Cruise Ship is expected to stay abroad where Tax does not apply for a period of a day, then cross the 

border to return on the 10th January 2026 at 11AM (disable Scheduled Tax Shift/return the system to the normal Tax 

Rate). 

For the above example, two Schedules will need to be created which are listed as follows. 

 

Enable Tax Shift 

• Description: Enable Tax Shift 2 

• Type: Send Message 

• Run next at: 08 Jan 2026 11:00 

• Repeat Every: 0 Days 

• From POS: Enter the POS Terminal Number that will send the message to other Terminals. 

Message Options 

• To POS: Enter the POS Terminal Number range which the Scheduled Tax Shift will apply to. 

• Message: [TAXSHIFT2] (enter the number of the Tax Rate Slot which contains the Tax Rate that will apply 

when this function is triggered). 
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Disable Tax Shift 

• Description: Disable Tax Shift 

• Type: Send Message 

• Run next at: 10 Jan 2026 11:00 

• Repeat Every: 0 Days 

• From POS: Enter the POS Terminal Number that will send the message to other Terminals. 

Message Options 

• To POS: Enter the POS Terminal Number range which the Scheduled Tax Shift will be disabled. 

• Message: [TAXSHIFTOFF] 
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Example of Tax Shift Disabled 

When the Tax Shift is not active (Disabled), all Stock Items are sold at their standard Sell Prices. 

 

 
 

Example of Tax Shift Enabled 

When the Tax Shift is active (enabled), all Stock Items are sold at their Tax Shifted Rate. 

 

 
 

Tax Shift messages are also recorded in the Activity Enquiry 

When Scheduled Tax Shift messages are received, they will appear in the Activity Log. 

Go to : Back Office > Enquiry > Activity Log. 
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Tender Types 

IP-1298 – Tender Types Screen with support for 30 Tender Types 

This function increases the maximum number of Tender Types supported on the Tender Screen from 18 up to 30. 

As part of this change, Tender Types have been moved from Back Office > Setup > Function Descriptors to a new 

“Tender Types” option in Back Office > Setup. 

The “Function Descriptors” option continues to exist in the Back Office > Setup menu and is used for configuring the 

descriptions of various Functions. 

 

To configure the additional Tender Types from 19 to 30, go to: Back Office > Setup > Tender Types. 

Configure the new Tender Types 19 and greater as required by selecting a Tender Type > Modify > Enter a Description 

for the Tender Type and make any other configuration adjustments as needed > Press “Save” and repeat for each 

Tender Type. 

 

A screenshot of the Tender Types window is shown below with the additional Tender Types 19 to 30. 
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To enable the Tender Types so that they appear on the Tender Screen, go to: Back Office > Setup > Yes/No Options > 

Tenders. 

Disable the Inhibit Tender option for the additional Tenders that have been configured in the Tender Types above. 
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It is also recommended that the settings for Tender Grid Button Height, Tender Grid Font Size and Tender Grid Line 

Width are adjusted as required, as these control the appearance of the Tender buttons on the POS Screen. 

There may be some trial-and-error required to achieve the desired appearance. 

The example values shown below enable the Tender buttons to display Tender button images which are outlined in 

the enhancement IP-7585 – Tender Types – Support for Graphic on POS Screen. 

If the Tender Type Graphic functionality isn’t being used, the Tender Grid Button Height can be reduced to a value 

such as 700 (which works well with a Tender Grid Font Size of 20). 

 

Go to: Back Office > Setup > Global Options > General > Tender Grid Button Height/Tender Grid Font Size, Tender 

Grid Line Width: 
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Once the Tender Types and Tender Grid settings have been configured as outlined above, go to: POS Screen. 

Add items to the sale > Press Enter. 

The newly configured Tender Types will be shown. 

The example below is shown with a configured Tender Grid Button Height of 700, Tender Grid Font Size 20, Tender 

Grid Line Width 2: 
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IP-7562 – Tender Types – Ability to change Display Order 

This functionality adds the ability to change the Display Order of Tender Types on the Tender Screen of the POS. 

This setting is configured per-POS Terminal, making it possible to have a unique Tender Type Display Order for each 

POS Terminal. 

This function can be useful for setting the most used Tender Types so that they appear at the top of the list, reducing 

the need to scroll through the Tender Types to access frequently used Tender Types. 

 

To configure this functionality, go to:  

Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > POS Settings tab > Tender Display Order. 

 

Press the “>” button within the Tender Display Order field and select a Tender Type > OK. 

The Tender Type Code will be added to the Tender Display Order field. 

Repeat the process to add additional Tender Types to the Tender Display Order field. 

 

Alternatively, the Tender Type Codes can be manually entered into the field as a comma separated list without using 

the “>” button. 

Enter the Tender Type codes into the Tender Display Order field as a comma separated list (e.g. 1,3,5, etc.). 

The Tenders will be displayed in the order specified in this field. 

Note that not all enabled Tender Types need to be specified in this field. 

The Tender Types entered in the Tender Display Order field will be displayed at the top of the Tenders list in the order 

shown in this field, followed by the default order of the remaining Tender Types that haven’t been specified in this 

field. 
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Hovering over the Tender Display Order field will also show the full names of the Tender Types in the entered order. 

 

 
 

To set a Tender Display Order for the remaining POS Terminals, repeat the above process. 

 

Once the Tender Display Order has been set, close the Modify POS Terminal windows and open the POS Screen. 

Note that in most cases, the Tender Display Order should take effect immediately without restarting the POS Terminal. 

If the Tender Display Order does not take effect, restart the POS Terminal or perform a Close Suite/Open Suite on the 

POS Terminal. 

 

Add items to the sale > Press Enter > The Tenders are displayed using the configured Tender Display Order. 
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IP-7585 – Tender Types – Support for Graphic on POS Screen 

This functionality adds the ability to configure a unique Tender Graphic for each Tender Type. 

The configured Tender Graphic will appear on each Tender Type’s button on the Tender Screen of the POS (instead of 

the Tender Type’s Description).  

 

To configure and use this functionality, go to: 

Back Office > Setup > Tender Types > Select a Tender Type > Modify. 

 

Within the “Tender Graphic” field, select a Tender Graphic to be displayed for the Tender Type, then save the change. 

Repeat the process for each Tender Type that requires a Tender Graphic. 

 

If configuring this function on a licensed Idealpos system, ensure that the Tender Graphic image is stored in the 

following folder location:  

C:\ProgramData\Idealpos Solutions\Idealpos\Pictures 

If configuring this function on an unlicensed Demo Database Idealpos system (not licensed, using 20 free accesses), 

ensure that the Tender Graphic image is stored in the following folder location: 

C:\ProgramData\Idealpos Solutions\Idealpos\PicturesDemo 

 

Supported Tender Graphic File Types are PNG, JPG or BMP. 

A maximum Tender Graphic resolution of 187x64 is recommended. 

The Idealpos Demo Database includes the following sample Tender Graphics:  

Eftpos_logo.png, Mastercard_logo.png, visa_logo.png, cash_logo.png, American-Express-logo.png. 

These sample graphics are available in the following folder location: 

C:\ProgramData\Idealpos Solutions\Idealpos\PicturesDemo\ 
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After the Tender Graphics have been configured for the required Tender Types, some additional adjustments may be 

required in the Global Options to increase the Tender Grid Button Height so that Tender Graphics appear correctly. 

Go to: Back Office > Setup > Global Options > General. 

The following are recommended settings that work well with the sample Tender Graphics included in the Idealpos 

Demo Database; they may require adjusting with trial-and-error to achieve the desired appearance with the Tender 

Graphics being used. 

• Tender Grid Button Height: 1400 

• Tender Grid Font Size: 20 

• Tender Grid Line Width: 2 
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After the Tender Graphics have been configured, go to:  

POS Screen > Add items to the sale > Press the Enter button. 

The Tender Types which have been configured with a Tender Graphic will show their respective Tender Graphic in 

place of the Tender Type Description. 

Tender Types without a Tender Graphic will be displayed using their respective Tender Type Description: 
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IP-7586 – Tender Types – Number of Refund Receipts 

This functionality introduces the ability to set the number of Refund Receipts that will be printed when performing a 

Refund to a specific Tender Type. Each Tender Type can have a different number of Refund Receipts configured as 

required. 

 

To configure and use this function, go to: Back Office > Setup > Tender Types > Select a Tender Type > Modify. 

In the # of Refund Receipts, set the required number of receipts that will be printed when tendering a refund to the 

Tender Type. 

Note that this option does not force a receipt to be printed.  

Therefore, the Receipt On/Off function must be turned on for the Refund Receipts to be printed. 

 

Once the required number of Refund Receipts has been set, press the “Save” button on the top-left corner of the 

window. 
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To use this functionality, go to: POS Screen. 

Press the Refund button > Add an item to Refund > Press ENTER to go to the Tender Screen > Select the Tender Type 

which has the Number of Refund Receipts set > The Number of Refund Receipts are printed as per the configured 

value. 
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Users 

IP-7571 – Stock Item Prices – User Permissions to restrict changes by Price Level 

This function introduces the ability to restrict Users from making changes to specific Price Levels via User Permissions. 

This can be used to restrict Users from changing Sell Prices for specific Price Levels that they shouldn’t have access to. 

 

To configure and use this functionality, go to: Back Office > Setup > Users > Select a User > Modify. 

Within File > Stock Control > Stock Items, toggle the checkboxes for each Price Level as required. 

When a Price Level is checked/enabled, the User will have the ability to modify the Sell Price. 

When a Price Level is unchecked/disabled, the Sell Price field will be greyed out, preventing the User from modifying 

the Sell Price. 

In the below example, the ability to modify the Price Level 2 has been disabled for the STAFF User. 

Press “Save” on the top-left corner once the permissions have been modified as required. 
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Login to Idealpos as the User (Back Office > File > Log Out > Login as the restricted User). 

Go to: Back Office > File > Stock Control > Stock Items > Select a Stock Item > Modify. 

The Price Level(s) which were restricted for that User will be greyed out, preventing the User from modifying the Sell 

Price. 
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Utilities  

IP-7536 – Back Office access to View Log Files 

This functionality adds a new View Log Files option to the Utilities menu of the Idealpos Back Office. 

This function can be used to view log files stored in the Idealpos Logs folder. 

Access to the View Log Files option can be controlled via User Permissions to prevent unauthorised staff or users from 

accessing the function. 

 

To use this functionality, go to: Back Office > Utilities > View Log Files. 

The Idealpos Logs window will open. 
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The following functionality is available in the Idealpos Logs window: 

• Split left/right resizable section – Two log files can be opened simultaneously and the split between the 

left/right can be resized. The top of the window displays a listing of the available log files, and the bottom of 

the window displays the contents of the currently selected log file. 

• All – The “All” dropdown boxes at the top of the window can be used to filter the log files that are displayed. 

The list is populated dynamically based on the log files that exist in the Idealpos Logs folder. Some examples 

of options available include IPSClient, IPSDeploy, IPSError, etc. 

• Load More – This button will Load More of the currently selected log file. E.g. When selecting a larger log file, 

only a portion of the log file will be loaded. The “Load More” button can be pressed to Load More of the 

selected log file. This button can be pressed repeatedly as required until enough content has been loaded 

from the currently selected log file. 

• Tail – The “Tail” checkbox can be enabled to display the tail (bottom) of the currently selected log file. This 

option will trigger the currently selected log file to be dynamically updated or refreshed as more data is 

written to it. This can be useful when troubleshooting or reviewing the latest events as they’re written to the 

log file. 

• Search field – The blank search field is used for finding a specific entry in the currently selected log file. E.g. 

Entering “error” and using the Find Next/Find Prev buttons will search the currently selected log file for the 

word “error”. 

• Find Next/Find Prev – These buttons can be used to find the next or previous occurrence of the search term 

entered in the Search field. 
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If required, access to the “View Log Files” function can be controlled via User Permissions. 

Go to: Back Office > Setup > Users > Select a User > Modify. 

Toggle the “View Log Files” option under Utilities as required. 

 

 
 

When the selected User logs into Idealpos, access to the “View Log Files” option will either be greyed out or available, 

depending on how the option is configured in the User Permissions for the User. 

 

 


