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Back Office Dashboard 

IP-7786 – Dashboard KPI – Added “Same Day Last Year” totals 

This function introduces the ability to display “Total This Day Last Year” and “Same Time This Day Last Year” on the 

Back Office Dashboard. 

There is no additional configuration required to use this functionality. 

Note that Total This Day Last Year/Same Time This Day Last Year refers to this same day from last year, not this same 

date last year. 

E.g. If today’s date is Wednesday 25th February 2026, the same day last year is Wednesday 26th February 2025; the 

Total This Day Last Year will display totals from the 26th February 2025. 

 

Go to: Back Office. 

The square shown on the top-right corner of the Back Office Dashboard can be used to toggle through the following 

options; newly added options are listed in bold: 

• Same Time Yesterday 

• Total Yesterday 

• Same Time This Day Last Year 

• Total This Day Last Year 

 

These new options are available for Sales (total $ of sales), Profit (total Profit $) and Number (total number of sales).  
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Bar Tabs 

IP-7774 – Bar Tab Report – Prints for Local Site or All Sites 

This functionality introduces the ability to print a Bar Tab Report for the Local Site or All Sites. 

This is achieved by configuring the POS Screen Button for the Print Bar Tab function. 

When “ALL” is entered in the button’s Automatic Text Field, Bar Tabs from All Sites will be included. 

When the Automatic Text field is blank, only the Bar Tabs from the Local Site will be included. 

  

To configure this functionality, go to:  

Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 

Select a POS Screen Tab to create/modify the button(s). 

Locate a blank/unused button and configure as follows; press “Save” after configuring: 

 

• Function: Print Bar Tab Report 

• Automatic Text: ALL 

• Button Caption: BAR TAB REPORT ALL Sites 

 

  
 

If a button is only required for Bar Tabs at the Local Site, perform the above step and exclude the “ALL” text from the 

Automatic Text field (leave Automatic Text as blank. 

If required, the Button Caption can be adjusted accordingly to reflect whether it is for All Sites or Local Site. 

In addition, it is possible to have multiple BAR TAB REPORT buttons. 

E.g. A venue may want to have two buttons; one for the Local Site and another for All Sites and press the required 

button. 

 

Close the POS Screen Layout windows once configured. 
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Go to: POS Screen. 

Press the BAR TAB REPORT ALL Sites button and the Bar Tabs from All Sites will be displayed on the report. 

 

 
 

Pressing the BAR TAB REPORT button (without the “ALL” text in the button’s Automatic Text field) will display Bar Tabs 

only for the Local Site. 
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Customers 

IP-7782 – Automatic Import Customers – File/Folder options 

This function introduces the ability to specify the File/Folder from where Customers are automatically imported from. 

Previously, customers could only be imported automatically by dropping a cust.txt file into folder location 

“C:\ProgramData\Idealpos Solutions\Idealpos\” 

This change enables the ability to specify which folder location/filename the customers will be imported from. 

Note that if the existing functionality is already in use (cust.txt file is being dropped into the “C:\ProgramData\Idealpos 

Solutions\Idealpos” folder, there is no additional configuration required and the system will continue to work as it 

does. 

To configure and use this functionality, go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify. 

 

In the Import/Export tab > Automatic Import Settings, a new Customer Import Folder\Filename field is available. 

The field is pre-filled with the original folder location and filename that was previously hard-coded 

(C:\ProgramData\Idealpos Solutions\Idealpos\cust.txt). 

 

When configuring this option, there are two possible methods that can be used, depending on the requirements. 

• Option A – Specify a folder path and a filename – Idealpos will only import the specified filename from the 

specified folder location. 

• Option B – Specify a folder path without a filename – Idealpos will import any txt file that is placed within the 

specified folder. 

Note that if multiple files are placed into the folder, Idealpos will only import one file at a time using the 

“Customer Import Frequency” setting or “Automatic Customer Import Daily Time” setting configured in Global 

Options > Customers. Also note that if any non-Customer txt files are placed in the folder location configured, 

Idealpos will attempt to import them, and this will trigger problems if the file(s) placed in the folder are not 

formatted in the expected format. 

 

More information about the format of the customer import file is available in the User Guide by clicking here. 

 

 

https://userguide.idealpos.com.au/Default.htm#Import%20Data/Format%20of%20Import%20Files.htm
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Once the folder/file location is configured, close the Modify POS Terminal window. 

Go to: Back Office > Setup > Global Options > Customers > Miscellaneous. 

Configure the “Automatic Customer Import Daily Time” or the “Customer Import Frequency”. 

If entering an Automatic Customer Import Daily Time, ensure that the time is entered in 24 hour format. 

E.g. 08:30 for 8:30AM, 20:30 for 8:30PM, etc. 

 

Customer Import Frequency options that are available are 1 minute, 2 minutes, 5 minutes or 10 minutes. 

 

 
 

Close the Global Options window once configured. 
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To import a customer file, place a customer txt file into the folder location configured in the POS Terminal settings. 

Ensure that the filename is the same as-per what was configured in the POS Terminal Settings. 

 

To demonstrate this functionality, the following sample cust.txt file was created: 

 

CODE,LASTNAME,FIRSTNAME 

12,Smithson,Smith 

13,Johnson,John 

14,Robertson,Robert 

15,Richardson,Richard 

 

 
 

After placing the file into the configured Customer Import Folder Location, the file will be imported using either the 

Automatic Customer Import Daily Time, or the interval configured in the Customer Import Frequency. 

 

After the customer file is imported, it is deleted automatically; the new customers will appear in the Customers grid 

(Back Office > File > Customers > Customers). 
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EFTPOS 

IP-7711 – Oolio Pay Verifone EFTPOS – Support for Unreferenced Refunds 

This function introduces the ability to perform unreferenced refunds when using Oolio Pay Verifone EFTPOS 

integration. 

To perform an unreferenced refund, press the Refund button on the POS Screen > add/scan item to refund > Select a 

Refund Reason.  

If refunding multiple items, press the Refund button again and add/scan the next item to refund > Select a Refund 

Reason. Once all the items being refunded have been added to the sale, press ENTER to go to the Tender Screen > 

Press the EFTPOS button. 

 

 
 

The “Select Transaction” window will open. 

Close the window by pressing the “X” on the top-right corner. 
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A prompt “Would you like to do an Unreferenced Refund?” will be displayed. 

Press “Yes”. 

 

 
 

The POS Screen will display a prompt like the below: 

Follow the prompts on the pinpad to process the refund. 
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IP-7743 – Oolio Pay Global/AU/NZ/Verifone – Option to not include EFTPOS data on Automatic 

Receipts 

This functionality introduces the ability to disable EFTPOS data from being printed on Automatic Receipts when using 

the Oolio Pay Global/AU/NZ/Verifone EFTPOS Integration. 

Note that this functionality will stop EFTPOS data from being printed on receipts only when the Receipt On/Off 

function is enabled (receipts turned on). 

Also note that receipts will still contain EFTPOS Data when printing a duplicate receipt or manually printing a receipt 

after the transaction. 

 

To configure this functionality, go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify. 

In the EFTPOS Settings tab, enable the option “Automatic Transaction Receipts Don’t include EFTPOS Data”. 

This option is only available for the following EFTPOS Types: 

• Oolio Pay Global 

• Oolio Pay AUS/NZ Linkly 

• Oolio Pay AUS/NZ Verifone 

 

 
 

After configuring the above option, close the Modify POS Terminal window. 
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Go to: POS Screen > add items to sale > Tender with EFTPOS. 

When the receipt is printed, it will exclude the EFTPOS Data. 
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When the “Automatic Transaction Receipts Don’t include EFTPOS Data” option is disabled , the EFTPOS Data will be 

included on the receipt as shown in the example below. 
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Fuel Console  

IP-7544 – Enabler Fuel Interface – Fuel Functions Screen 

This functionality introduces a new Fuel Functions Screen which replaces the previous “Fuel Prices” function. 

If a POS Screen button was previously linked to the “Fuel Prices” Function, it will now link to the “Fuel Functions” 

function after upgrading to v9 Build 14.  

 

The Fuel Functions screen enables access to the following information and functions: 

• Tank – Tank Number. 

• Grade – Grade Description. 

• Price – Sell Price. 

• Capacity – Current Capacity in Litres. 

• Level – Current Tank Level. 

• Buttons on the left-hand side that provide access to Fuel Delivery, Set Tank Level, Grade Prices, Print Tank Data 

and Refresh Tank Data. These buttons enable the following functionality: 

 

• Fuel Delivery – Receive a Fuel Delivery into the selected Fuel Tank and enter the amount of Fuel delivered. 

• Set Tank Level – Set a new Tank Level for the selected Fuel Tank. 

• Grade Prices – Set the Grade Prices (this opens a window to set the Fuel Prices as per the Fuel Prices function 

that was available). 

• Print Tank Data – Prints out a docket with the current Tank Data (list of Tanks, Sell Prices, Capacities and 

Volumes). 

• Refresh Tank Data – This refreshes the data shown on the Fuel Functions screen. 

 

 
 

Configuring access to the Fuel Functions screen and using each of the functions is outlined on the following pages.  
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To configure this functionality: 

If a button was already linked to the Fuel Prices function before upgrading to this build, there is no additional 

configuration required; the Fuel Prices button will open the Fuel Functions function. 

 

If a button wasn’t configured, go to: 

Back Office > Setup > POS Screen > POS Screen Setup. 

Select a POS Screen Layout > Buttons. 

Select a POS Screen Tab > Select a blank button. 

It is strongly recommended that this button only be placed on a POS Screen tab that is restricted to specific Clerks 

(e.g. an Admin or Manager tab that is restricted to Admin or Manager Clerks) to prevent unauthorised changes to Fuel 

Levels and Prices. 

Link the button to the Fuel Functions Function > Press "Save" to save the button. 

 

 
 

Access to POS Screen tabs can be restricted per User or per Clerk. 

To restrict for the User, go to: Back Office > Setup > Users > Select a User > Modify > Clerk Permissions > POS > 

Layers > Disable the checkbox for the POS Screen tab which the button has been placed. 

 

To restrict for the Clerk, go to: Back Office > Setup > Clerks > Select a Clerk from the list > Press the “Permissions” 

button on the top-left corner of the window. 

Clerk Permissions > POS > Layers > Disable the checkboxes next to the Layers/Tabs that the Clerk is not permitted to 

access. 
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When accessing the Fuel Functions function, the following screen will appear. 

 

 
 

To accept a Fuel Delivery, select the Tank, then press the Fuel Delivery button. 

Enter the Delivery Volume and a Delivery Reference then press OK. 

 

 
 

Accept the confirmation to proceed: 
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A docket is printed to the receipt printer. 

Note that the docket will be printed regardless of if receipt printing is disabled. 
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The Set Tank Level button can be pressed to update the Tank Level for the selected Tank. 

Select a Fuel Tank > Press “Set Tank Level”. 

Enter the Measured Volume and a Reference > Press “OK” 

 

 
 

Accept the confirmation to proceed: 
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A docket is printed to the receipt printer. 

As noted previously, the docket will be printed regardless of if receipt printing is disabled. 
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Grade Prices can be changed by pressing the Grade Prices button. 

 

 
 

When Grade Prices are updated, a docket will be printed to the receipt printer. 

As noted previously, the docket will be printed regardless of if receipt printing is disabled. 

The docket will contain a list of Fuel Grades that have had their Prices changed, including the Old Price and New Price. 
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Pressing the Print Tank Data button will produce a docket containing the current Tank Data. 
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Functions 

IP-7710 – Order Number Function – Option to have Keyboard Entry 

This functionality introduces the ability to trigger an on-screen keyboard to appear when pressing the Order Number 

button on the POS Screen. The on-screen keyboard can be used to enter alpha-numeric Order Numbers. 

Note that the Order Number Keyboard functionality is only supported when the “Order Numbers” option is disabled in 

the POSServer. 

 

To configure and use this functionality, go to: 

Back Office > Setup > Global Options > Miscellaneous > Ensure that the Order Numbers option is disabled. 

If the Order Numbers option is enabled, note that disabling it will stop POSServer from centrally issuing Order 

Numbers to all POS Terminals at the venue. 
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Therefore, it is recommended that each POS Terminal is configured to issue a unique range of Order Numbers to 

prevent the same Order Number from being issued by two different POS Terminals. 

 

Go to: Back Office > Setup > POS Terminals > Select a POS Terminal > Modify > Miscellaneous Settings.  

In the “Show Order” and “To” fields, enter an Order Number range that is unique to the POS Terminal. 

E.g. For POS Terminal 1, a range of 100 – 199. 

 

 
 

Close the Modify POS Terminal window, then configure the Show Order fields for the remaining POS Terminals. 

E.g. Back Office > Setup > POS Terminals > Select POS Terminal 2 > Modify > Miscellaneous Settings > Show 

Order/to: Enter a range of 200 to 299. 

Repeat for the remaining POS Terminals as required. 

  



    Update History 
Return to top 

Idealpos 9 Build 14 - Update History Page 23 of 73 

 

Go to: Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 

Select a POS Screen Tab > Locate and click on a blank button > Configure the button as follows: 

Function: Order Number 

Automatic Text: [KEYBOARD] 

Button Appearance/Caption/Colours: Configure as desired. 

Press “Save” once configured. 

 

 
 

Close the modify POS Screen Layout windows. 
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Go to:  

POS Screen > Press the POS Screen Tab which the above button was created on > Press the Order Number button. 

The POS Screen will display the ENTER ORDER NUMBER in the sale window area and the on-screen keyboard will be 

displayed at the bottom of the screen which enables the entry of an alpha-numeric Order Number. 
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After entering an alpha-numeric Order Number, press the Enter button on the bottom-right corner of the on-screen 

keyboard. 

The Order Number will be displayed at the top of the POS Screen. 

 

 
 

Add items to the sale > Press ENTER > Tender the sale. 

The Order Number will be printed on the Customer’s Receipt as well as the Kitchen Docket Printers. 
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LMG Integration 

IP-7577 – Zen Gift Voucher Integration 

This functionality adds the ability to sell and redeem LMG Zen Gift Vouchers with the LMG Zen Loyalty Interface. 

Functions supported on Zen Gift Vouchers are: 

• Gift Voucher Enquiry 

• Gift Voucher Redemption 

• Gift Voucher Sale 

• Gift Voucher Recharge 

 

Before configuring this integration, note that the LMG Zen Loyalty Interface needs to have been already configured. 

If setting up a new site that hasn’t been configured for the LMG Zen Loyalty Interface, refer to the LMG Zen Loyalty 

Interface topic in the User Guide for more information about setting up this interface. This includes the requirement of 

licensing Idealpos for LMG Basic. 

 

To configure this functionality on an existing site that has already been configured for the LMG Zen Loyalty Interface, 

go to: Back Office > Setup > Tender Types > Select the next available/unused Tender > Modify.  

Unused Tender Types are labelled as “Tender #”, where # refers to the number of the Tender. 

This Tender Type will be used for the redemption of Zen Gift Vouchers. 

 

• Description: ONLINE VOUCHERS 

• Show in Banking: Enabled 

• Open Cash Drawer: Configure as required. 

 

Toggle/configure any other options as required, then press the “Save” button on the top-left corner. 
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Go to: Back Office > Setup > Function Descriptors > Select the next unused Received Account Function > Modify. 

Unused Received Account functions are labelled as RA #, where # refers to the number of the Received Account 

Function. 

This Received Account Function will be used for the sale and recharge of Zen Gift Vouchers. 

 

• Description: ZEN Gift Voucher 

• GIFT VOUCHER: Enable checkbox. 

 

Press the “Save” button on the top-left corner after the Received Account function has been configured. 
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Go to: Back Office > Setup > Global Options > Interfaces > LMG. 

• Upload Scan Data: Enable checkbox [enabling this option is a requirement for Zen Gift Vouchers] 

• Zen Gift Vouchers: Enable checkbox 

• Gift Voucher Redeem: Select “ONLINE VOUCHERS” from the dropdown box. 

• All other options such as LMG Site Number, Site Serial, API Key and API Secret should already be 
configured. If this is a new installation of the LMZ Zen Loyalty Interface, refer to the Idealpos User Guide 
for complete information about configuring the LMG Zen Loyalty Interface. 

 
NOTE – It is a requirement that Upload Scan Data is enabled for Zen Gift Vouchers. 
If Upload Scan Data is unchecked, Gift Vouchers will not work correctly! 
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POS Screen buttons will need to be created for the Gift Voucher Enquiry and Gift Voucher Sale/Recharge. 

Go to: Back Office > Setup > POS Screen > POS Screen Setup > Select a POS Screen Layout > Buttons. 

Select a POS Screen tab to place the buttons. 

 

Locate a blank/unused button and configure as follows; press Save after configuring: 

 

• Function: Gift Voucher Enquiry 

• Gift Voucher Type: Zen Gift Vouchers 

• Button Caption: Zen Gift Voucher Enquiry 

• Button Appearance: Customise as required 

 

 
 

Locate a blank/unused button and configure as follows; press Save after configuring: 

 

• Function: Received on Account 

• Received on Account: ZEN Gift Voucher 

• Gift Voucher Type: ZEN Gift Voucher 

• Button Caption: Recharge Zen Gift Voucher 

• Button Appearance: Customise as required 
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The ONLINE VOUCHERS Tender Type will need be enabled on the POS Tender Screen. 

Go to: Back Office > Setup > Yes/No Options > Tenders. 

Uncheck ALL next to the “Inhibit ONLINE VOUCHERS” Tender Type. 

 

 
 

To finalise changes, it is recommended to perform a Close Suite/Open Suite. 

 

Each of the following functions of the Zen Gift Vouchers are outlined below: 

• Gift Voucher Enquiry 

• Gift Voucher Sale 

• Gift Voucher Redemption 

• Gift Voucher Recharge 

 

Gift Voucher Enquiry 

To perform a Gift Voucher Enquiry, press the Zen Gift Voucher Enquiry button. 

The Zen Gift Voucher Enquiry window will appear. 

Enter or Scan the Zen Gift Voucher > Press “Get Balance”. 

The Gift Voucher Balance will be displayed as well as any other details about the Gift Voucher (Purchased Date, Expiry 

Date, Status). 
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Gift Voucher Sale 

To perform a Zen Gift Voucher Sale, press the Recharge Zen Gift Voucher Button. 

Within the Zen Gift Voucher Sale/Recharge window, enter the following details: 

• Scan or Enter Voucher Code: Scan or Enter an unused Voucher Code. The “Enquiry” button can be pressed.  

A “Not Found” prompt will indicate that the Gift Voucher has not been used previously. If the card has been 

previously issued, the card’s details will be displayed on the top-left corner of the window. 

• Amount: - Enter the amount to load onto the Gift Voucher. 

• Recipient Name: Enter the name of the recipient. 

• Email Address: Enter the Recipient’s Email Address. Note that this is only for logging purposes and will not 

send an email to the recipient. 

• GIFT VOUCHER Type: ZEN Gift Voucher (Read-Only dropdown box) 

 

Press “OK” once the above details have been entered. 
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The Gift Voucher is added to the sale window 

 

 
 

Press the ENTER button to go to the Tender screen and finalise the sale. 

The Gift Voucher’s Card Number will appear in the Idealpos Journal History Enquiry (Back Office > Enquiry > Journal 

History). 

 

 
 

After the Gift Voucher is sold, the Gift Voucher Enquiry function will show that it has been loaded with the balance. 
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Gift Voucher Redemption 

To perform a Gift Voucher Redemption, add the items to the sale, then press the ENTER button to go to the Tender 

screen. 

From the Tender screen, press the ONLINE VOUCHERS button. 
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The Zen Gift Voucher Redemption window will open. 

Enter or Scan Gift Card. 

After Entering/Scanning the Card, the “Get Balance” button can be pressed if required to show the available balance 

on-screen. 

The Amount to Redeem field will show the amount being redeemed. 

If required, the amount can be adjusted using the on-screen numeric keypad. 

Press the “Redeem” button. 

 

 
 

After performing a successful redemption, a prompt will appear showing the Available Balance remaining on the Gift 

Voucher. 

 

 
 

Other messages will be displayed depending on the status of the Gift Voucher. 

Not Found – The entered Gift Voucher Number was not found. 

Request Rejected: Requested reserve exceeds current value – This prompt will appear if the value being redeemed 

exceeds the balance available on the Gift Voucher. 
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Gift Voucher Recharge 

To perform a Gift Voucher Recharge, select the Recharge Zen Gift Voucher button on the POS Screen. 

Within the Zen Gift Voucher Sale/Recharge window, Scan or Enter Voucher Code > Press Enquiry. 

Existing Voucher will appear on the top-left corner and will show the Balance, Expiry and Purchased dates. 

An existing Gift Voucher can be recharged, even if the amount of the Voucher has not reached $0.00. 

When a Gift Voucher is recharged, the Expiry Date on the voucher will be updated. 

Enter a Recharge Amount into the Recharge Amount field, then press “OK”. 

 

This will add the entered amount to the existing balance of the Gift Voucher. 

The below example shows a Gift Voucher with a Balance of $49.00 and a Recharge Amount of $51.00. 

After the sale is tendered, the Gift Voucher Balance will increase to $100.00. 

 

 
 

  



    Update History 
Return to top 

Idealpos 9 Build 14 - Update History Page 36 of 73 

 

The Gift Voucher will appear in the sale window. 

 

 
 

Press the ENTER button to go to the Tender screen and finalise the sale. 

When enquiring the Recharged Gift Voucher with the Gift Voucher Enquiry function, the new balance will be displayed. 

 

 
 

 

  



    Update History 
Return to top 

Idealpos 9 Build 14 - Update History Page 37 of 73 

 

Promotions 

IP-7702 – Promotions – Support to trigger based on Customer Postcodes 

This functionality introduces the ability to trigger a Promotion based on the Postcode in the Customer’s Address 

Details. 

This will enable Promotions to be restricted to Customers that reside in specific areas based on their Postcode. 

Postcodes can be specified as a range (e.g. 4000-4100), comma separated list (e.g. 4000,4001,4002) or a combination 

of both (e.g. 4000,4005-4050,4061). 

When a Promotion is configured for this functionality, any Customer that has a Postcode that falls within the entered 

range will be eligible to receive the Promotion when they purchase the required Stock Items specified in the 

Promotion. 

 

To configure and use this functionality, go to:  

Back Office > File > Customers > Customers > Select a Customer > Modify. 

Ensure that a Postcode has been entered within the Address Details field. 

Note that the Postcode in the Delivery Address is not used for this functionality. 

Save the change. 

Repeat the process to update the Address Details/Postcodes of any other Customers as required. 
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Close the Customer windows. 

Go to: Back Office > File > Sales > Promotions > Promotions. 

Add or Modify a Promotion. 

Select the “Advanced” tab. 

 

 
 

In the Advanced Tab of the Promotion, the User-Defined Text Field is used to specify which Postcodes the Promotion 

will apply to.  

Postcodes can be entered as a comma separated list, range, or a combination of both. 

See examples below: 

 

Postcodes entered as a comma separated list. 

[POSTCODES=4000,4001,4002] 

 

Postcodes entered as a range. 

[POSTCODES=4000-4100] 

 

Postcodes entered using a combination of a comma separated list and range. 

[POSTCODES=4000,4001,4005-4010,4101] 

 

Enter the required Postcodes into the User-Defined Text Field. 

 

 
 

Close the Modify/Add Promotion window and when prompted to “Save Changes?”, press Yes. 

The above process can be repeated to setup any other Promotions that are required to trigger based on User-Defined 

Text Fields. 

  



    Update History 
Return to top 

Idealpos 9 Build 14 - Update History Page 39 of 73 

 

Close the Promotions window, go to: POS Screen. 

Add a Customer to the sale that has a Postcode that falls within the same range as set in the Promotion.  

Add Stock Items from the Promotion to the sale.  

The Promotion is triggered. 

 

 
 

When a Customer that does not have a Postcode that matches the Promotion is added to the sale, the Promotion is 

not triggered. 

The Promotion will also not trigger if a Customer is not added to the sale. 
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IP-7703 – Promotions – Support to trigger based on Customer Gender 

This functionality introduces the ability to trigger a Promotion based on the Customer’s Gender. 

When a Promotion is restricted to a specific Gender, it will only be triggered when a Customer that matches the 

specified Gender is added to the sale and they purchase the required Stock Items specified in the Promotion. 

 

To configure and use this functionality, go to: 

Back Office > File > Customers > Customers > Select a Customer > Modify. 

Ensure that the Customer’s Gender has been specified in the Gender dropdown box. 

Available Genders are M, F and O. 

The Gender is automatically selected based on the customer’s title (e.g. selecting Mr will set the Gender to M, or 

selecting Mrs/Miss/Ms will set the Gender to F). If required, a Gender of O can be selected. 

After setting or updating the Customer’s Gender, press the “Save” button on the top-left corner. 

If required, repeat the above to update the Gender for the required customers. 
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Go to: Back Office > File > Sales > Promotions > Promotions. 

Add or Modify a Promotion. 

Select the “Advanced” tab. 

 

 
 

In the Advanced Tab of the Promotion, the User-Defined Text Field is used to specify which Gender(s) the Promotion 

will apply to. 

To restrict the Promotion to Male, enter the following into the User-Defined Text Field: 

[GENDER=M] 

 

To restrict the Promotion to Female, enter the following into the User-Defined Field: 

[GENDER=F] 

 

To restrict the Promotion to Other, enter the following into the User-Defined Field: 

[GENDER=O] 

 

To make the Promotion available to multiple Genders, enter the required Genders as a comma separated list. 

[GENDER=M,F] 

 

 
 

Close the Modify/Add Promotion window and when prompted to “Save Changes?”, press Yes. 

The above process can be repeated to setup any other Promotions that are required to trigger based on the 

Customer’s Gender. 
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Close the Promotions window, go to: POS Screen. 

Add a Customer to the sale that matches the Gender configured in the Promotion.  

Add Stock Items from the Promotion to the sale.  

The Promotion is triggered. 

 

 
 

When a Customer is added to the sale which does not match the Gender specified in the Promotion, the Promotion is 

not triggered. 
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IP-7704 – Promotions – Support to trigger based on User-Defined Text Fields 

This functionality introduces the ability to trigger a Promotion based on User-Defined Text Fields that are set in the 

Customer’s record. 

This will enable Promotions to be restricted to specific Customers based on the value in the Customer’s User-Defined 

Text Fields and they purchase the required Stock Items specified in the Promotion. 

 

To configure and use this functionality, go to: Back Office > Setup > Global Options > Customers > User-Defined. 

In the Text Fields section, there are 10 available fields. 

These can be configured to store text details about the customer. 

E.g. Favourite Drink, Favourite Cook Type, etc. 

Any User-Defined Text Fields that are not currently used will appear as “User-Defined Text #”, where # refers to the 

number of the User-Defined Text Field. 

 

 
  



    Update History 
Return to top 

Idealpos 9 Build 14 - Update History Page 44 of 73 

 

Go to: Back Office > File > Customers > Customers > Select a Customer > Modify. 

In the Advanced tab, the User-Defined Text Fields are displayed at the top of the Advanced tab. 

Enter the required values into the User-Defined Text Fields. 

E.g. Favourite Drink = COKE, Favourite Meal = CHICKEN 

When entering values into the User-Defined Text Fields, take note of the following details as these will be required 

when setting up the Promotion: 

 

• The Text Fields are numbered based on their row number; the first row is UDT1, the last row is UDT10. 

• Promotions can be triggered based on one or more User-Defined Text Fields; 

E.g. If entering [UDT1=COKE] [UDT3=CHICKEN] into the User-Defined Text Field of the Promotion, the 

Customer will need to have Favourite Drink=COKE AND Favourite Meal=CHICKEN in their User-Defined Text 

Fields. 

• The Promotion can be triggered by multiple possible values for each User-Defined Text Field as a comma 

separated list; 

E.g. If entering [UDT1=COKE,SPRITE,FANTA] [UDT3=BEEF,CHICKEN] into the User-Defined Field of the 

Promotion, the Promotion will trigger for Customers that have a Favourite Drink of COKE, SPRITE or FANTA 

AND have a Favourite Meal of BEEF or CHICKEN. 

• The Promotion can be triggered when a Customer’s User-Defined Text Field contains a number value that falls 

between a specified range; 

E.g. If User-Defined Text Field 9 is used to store the age of the member when they joined, the Promotion can 

be setup to trigger for all members that were between a specific age group when joining. 

Entering [UDT9=18-30] into the Promotion’s User-Defined Text Field will trigger when the Customer has a 

value between 18 and 30 in their User-Defined 9 Text Field. 

 

Configure the Customer’s User-Defined Text Fields as required: 
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Go to: Back Office > File > Sales > Promotions > Promotions. 

Add or Modify a Promotion. 

Select the “Advanced” tab. 

 

 
 

In the Advanced Tab of the Promotion, the User-Defined Text Field is used to specify which User-Defined Text Fields 

will be required for the Promotion to trigger. 

To demonstrate this functionality using the example from the previous page, the Promotion will be restricted to:  

User-Defined Text 1 (Favourite Drink) = COKE 

User-Defined Text 3 (Favourite Meal) = CHICKEN 

 

To restrict the Promotion to the above User-Defined Text Fields, the User-Defined Text Field in the Promotion 

Advanced Tab will need to have the following entered: 

[UDT1=COKE] [UDT3=CHICKEN] 

 

 
 

Close the Modify/Add Promotion window and when prompted to “Save Changes?”, press Yes. 

The above process can be repeated to setup any other Promotions that are required to trigger based on User-Defined 

Text Fields. 
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Close the Promotions window, go to: POS Screen. 

Add a Customer to the sale that has their User-Defined Text Fields configured the same as the Promotion.  

Add Stock Items from the Promotion to the sale.  

The Promotion is triggered. 

 

 
 

When a Customer is added to the sale which does not have their User-Defined Yes/No Fields configured to match the 

Promotion, the Promotion is not triggered. 

 

 
 

The Promotion will also not trigger if the Stock Items from the Promotion are added to the sale without a Customer. 
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IP-7705 – Promotions – Support to trigger based on User-Defined Yes/No Fields 

This functionality introduces the ability to trigger a Promotion based on User-Defined Yes/No Fields that are set in the 

Customer’s record.  

This will enable Promotions to be restricted to specific Customers based on the state of the Customer’s User-Defined 

Yes/No Fields (e.g. Yes/No Fields ticked or unticked).  

A Promotion will only trigger when a Customer has been added to the sale which has the required User-Defined 

Yes/No Fields AND they purchase the required Stock Items specified in the Promotion. 

 

To configure and use this functionality, go to: Back Office > Setup > Global Options > Customers > User-Defined. 

In the Yes/No Fields section, there are 5 available Yes/No Fields. 

These can be configured as required to record specific Yes/No details about the customer. 

E.g. Pays Weekly, VIP Customer, Pensioner, etc. 

Any User-Defined Yes/No Fields that are not currently used will appear as “User-Defined Yes/No”. 

Note that these Yes/No Fields will only store a Yes value (checkbox enabled) or a No value (checkbox unchecked). 

For storing User-Defined Text values and triggering Promotions based on those User-Defined Text Fields, a separate 

enhancement is available; see IP-7704 – Promotions – Support to trigger based on User-Defined Text Fields. 
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Go to: Back Office > File > Customers > Customers > Select a Customer > Modify. 

In the Advanced tab, the User-Defined Yes/No Fields are displayed below the Text Fields. 

Toggle the User-Defined Yes/No Fields as required. 

When toggling the Yes/No Fields, take note of the following details as these will be required when setting up the 

Promotion: 

 

• The Yes/No Fields are numbered based on their row number; the first row is UDYN1, the last row is UDYN5. 

• Any Y/N Field that is enabled will be referred to as Y and any Y/N Field that is disabled will be referred to as N. 

• Examples based on the screenshot below: 

• If a Promo is to be restricted to VIP Customers, [UDYN4=Y] 

• If a Promo is to be restricted to non-VIP Customers, [UDYN4=N] 

• If a Promo is to be restricted to Customers that are Pays Weekly? AND VIP, [UDYN1=Y] [UDYN4=Y] 

• Multiple values for each User-Defined Yes/No Field can be specified; e.g. [UDYN4=Y,N] 

• Multiple User-Defined Yes/No Fields can be specified; e.g. [UDYN1=Y] [UDYN4=N] 

 

 

 
 

Press the “Save” button on the top-left corner once updated. 

Repeat the above process for each Customer that requires the Yes/No Fields to be set. 
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Go to: Back Office > File > Sales > Promotions > Promotions. 

Add or Modify a Promotion. 

Select the “Advanced” tab. 

 

 
 

In the Advanced Tab of the Promotion, the User-Defined Text Field is used to specify which User-Defined Yes/No 

Fields will be required for the Promotion to trigger. 

To demonstrate this functionality using the example from the previous page, the Promotion will be restricted to the 

User-Defined Yes/No Field 4 (which is configured as VIP Customer in the Global Options > Customers > Yes/No 

Fields). 

Enter [UDYN4=Y] into the User-Defined Text field: 

 

 
 

Close the Modify/Add Promotion window and when prompted to “Save Changes?”, press Yes. 
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Close the Promotions window, go to: POS Screen. 

Add a Customer to the sale that has their Yes/No Fields configured the same as the Promotion.  

Add Stock Items from the Promotion to the sale.  

The Promotion is triggered. 

 

 
 

When a Customer is added to the sale which does not have their User-Defined Yes/No Fields configured to match the 

Promotion, the Promotion is not triggered. 

 

 
 

The Promotion will also not trigger if the Stock Items from the Promotion are added to the sale without a Customer. 
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Reports 

IP-7697 – Gift Voucher Reports – Support for Gift Voucher Name Filter 

This functionality introduces the ability to filter the Gift Voucher Report using the “Name Like” field. 

A Customer’s Name or any part of their name (First Name and/or Last Name) can be entered into the Name Like field 

prior to running the Gift Voucher Report.  

Depending on the options selected in the report, any Gift Vouchers that were associated with a customer that has a 

name like the one entered with a Customer Name field will be displayed by the Gift Voucher Report. 

E.g. If a customer has a name of “Joe Blow” and part of their name is entered (e.g. Jo, Blo, low, etc.), the report will 

show the customer and any other customers that have a similar name which matches. 

 

Go to: Back Office > Reports > Sales > Gift Voucher Report > Choose the report options required. 

In the “Name Like” field, enter part of the customer’s name > Press “View”. 
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When report runs, it will display any customers that have a name like the entered name. 
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IP-7718 – Automatic Surcharges – Summary and Item Reports 

This functionality adds a new Surcharges Report to the Reports > Sales menu. 

The Surcharges Report enables the ability to report on Automatic Surcharges which have been applied to sales within 

the Date Range selected in the report. 

 

Note – The Surcharges Report will only report on Automatic Surcharges that applied to sales after upgrading to 

Idealpos v9 Build 14. 

Any Automatic Surcharges that were applied to sales that took place prior to upgrading to v9 Build 14 will not 

be included in the Surcharges Report! 

E.g. If a 10% Automatic Surcharge applied to all sales that took place on the day before upgrading to v9 Build 

14, the Surcharges Summary or Surcharge Details by Item will not return any data for that Automatic 

Surcharge. 

 

When running the Surcharges Report, there are two Report Types: 

 

• Surcharges Summary – This will show a Summary of all Surcharges which were triggered within the selected 

Date Range. The Summary will display the Surcharge Code, Surcharge Description, Quantity (the Quantity 

shows the total number of sales which had a Surcharge, not the number of items) and the total Surcharge 

value. 

• Surcharge Details by Item – This will show a detailed report which contains a listing of all the Surcharged 

Stock Items that were sold per Journal. This includes the Journal Number, Stock Item Description, Date of sale, 

Unit Price, Quantity, Pre-Surcharge Amount, Surcharge, Surcharged Amount, Cost. 

 

 

The following options are available in the Report: 

• Date Range – Select a Date to show Automatic Surcharges that were applied on the selected date. 

• Group By – POS Terminal, Location or Site. 

• Report Type: Surcharges Summary or Surcharge Details by Item as outlined above. 

• Selection Range: 

o Site 

o POS System 

o Supplier (Supplier is only available when selecting Surcharge Details by Item)  
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To utilise this functionality, ensure that sales have been performed with an Automatic Surcharge after upgrading to v9 

Build 14. 

An Automatic Surcharge can be created by going to:  

Back Office > File > Sales > Surcharges > Add > Create a new Surcharge. 
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After saving the Surcharge, go to: POS Screen > Perform a sale > Tender the sale. 
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Close the POS Screen > Go to: Back Office > Reports > Sales > Surcharges. 

Select Surcharges Summary to display a summary: 

 

 
 

The Report will show a Summary. 

The Surcharges Summary contains a listing of Surcharge Codes, Surcharge Descriptions, Quantity (Quantity of sales 

that had a Surcharge applied), and the Surcharge Amount. 
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To display a detailed Surcharges Report, select the “Surcharge Details by Item” option: 

 

 
 

When running the Surcharges Report with the “Surcharge Details by Item” selected, a detailed listing will be displayed 

which includes the Journal Number, Stock Item Descriptions, Date, Unit Price, Quantity, Pre-Surcharge Amount, 

Surcharge, Surcharged Amount and Cost. 

If required, the Group by/Selection Range options can be used to perform further grouping/filtering. 
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Reservation Interfaces 

IP-7724 – NowBookIt – Support for Gift Cards 

This functionality adds support for NowBookIt Gift Card redemptions to the NowBookIt Reservation interface. 

To configure and use this functionality, go to: Back Office > Setup > Tender Types.  

Select the next unused Tender Type (unused Tender Types are labelled as “TENDER #”, where # refers to the number 

of the Tender Type) and press Modify > configure as required > Press “Save” on the top-left corner. 
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Go to: Back Office > Setup > Global Options > Interfaces > Reservations. 

Enable the “Gift Cards” checkbox and select the Tender Type that was configured above. 

If required, the ability to enter a Gift Override API Key is available if the restaurant wants to use a separate API Key for  

Gift Cards. 

 

 
 

Close the Global Options window. 

Go to: Back Office > Setup > Yes/No Options > Tenders > Untick the “Inhibit NowBookIt Gift Card” Tender Type. 

 

 
 

To finalise the configuration of Now Book It Gift Cards, perform a Close Suite/Open Suite. 

Go to: Start > Apps/All Apps > Idealpos > IPSUtils > Close > Confirm. 

Idealpos can be started by going to Start > Idealpos > Idealpos or press the Idealpos icon on the Windows desktop. 

Alternatively, a complete restart of the POS Terminals can be done to apply the change. 
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To redeem a Now Book It Gift Card, select the NowBookIt Gift Card Tender when tendering a sale. 
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The Now Book It Gift Card Redemption window will appear. 

Enter or Scan the Gift Card Number. 

To enter a Gift Card Number, press the “>” button within the Gift Card Number field to display an on-screen keyboard. 

When entering a Now Book It Gift Card, either the entire Gift Card Number can be entered, or the last four characters 

of the Gift Card can be entered. 

The Amount to Redeem can be left as the default amount or adjusted by selecting the Amount to Redeem field > 

enter a new amount using the on-screen numeric keypad. 

Press the “Redeem” button to proceed with the redemption. 

 

 
 

 

A “Redemption Successful!” prompt will appear with the amount redeemed. 

 

 
 

Press OK. 

The sale is finalised. 

If the Gift Card has already been redeemed, a prompt of “Card already redeemed” will be displayed. 

If attempting to redeem a value that is greater than what is available on the Gift Card, an “Invalid request” prompt will 

appear.  
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IP-7507 – Now Book It Reservations Screen – Status Filters 

This functionality introduces the ability to filter the Reservations window by the Table Status. 

Status filters available are: All, None, Billed, Cancelled, Confirmed, Dessert, Drinks, Entrée, Finished, Main, No Show, 

Ordered, Paid, Seated, Unconfirmed. 

The list shown in the Status Filters may vary based on configuration in Now Book It. 

 

To use this functionality, go to: POS Screen > Table Map > Reservations. 

A new “Status Filters” button will appear on the top-right corner of the window. 

Pressing the button will display a list of Status Filters which can be selected to filter the Reservations window by the 

selected filters. 

 

Selecting the “All” option will toggle all the statuses as enabled so that they all appear in the Reservations window. 

Selecting the “None” option will toggle all the statuses as disabled so that they don’t appear in the Reservations 

window. 

None can be used if you need to quickly unselect all statuses, then you can enable the required statuses from the list.  
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E.g. When all the status filters are enabled, all Status Types will be shown in the Reservations window. 

 

 
 

When filtering by specific Status(es), only reservations that match the selected Status Type(s) will be shown. 

 

 
 

Pressing the “All” option will enable all statuses or pressing “None” will clear all the statuses: 
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Restaurant & Table Map 

IP-7715 – Table Map Modify – Match All Tables Function 

This functionality adds the ability to match all Tables on the Table Map to the Table Size/Shape and Font of a specific 

Table.  

E.g. A Table Map contains tables which are all square in shape and have a small font size. 

To change the shape of all tables to a circle and increase the font size shown on the tables, the process can be 

achieved quickly using this functionality by setting up a single table to appear as desired, then right-clicking on it and 

selecting “Match All Tables”. All the Tables on the current Table Map will be changed to match the configured table, 

saving time when configuring Table Maps. 

 

To use this functionality, go to: 

Back Office > Setup > Restaurant > Table Maps > Select a Table Map > Modify. 

Right-click on a Table and use the Size/Font options to customise the appearance of the Table. 

The Toggle Shape button can also be used on the bottom-right corner of the window to toggle through various 

shapes. 
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After the table has been customised as required, right-click on it and select “Match All Tables”. 

 

 
 

All the Tables on the current Table Map will have their Table Size, Shape and Font matched to the customised table. 

 

 
 

Press the “Save” button on the bottom-right corner of the Map Modify window to save the changes. 

The above process can be repeated for each Table Map that requires customisation. 
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IP-7721 – Table Map Modify – Option to Set Table to Default 

This functionality adds the ability to restore the formatting (Table Size, Table Shape, Font Style/Size, Number of 

Covers) of the currently right-clicked table to the default format in the Table Map Modify. 

 

To use this functionality, go to: Back Office > Setup > Restaurant > Table Maps > Select a Table Map > Modify. 

Right-click on a Table and select the “Set to Default” option. 

 

 
 

The Table’s formatting (Table Size, Table Shape, Font Style/Size and Number of Covers) will be set to the Default 

Format. 

 

 
 

If the Default Format does not appear as desired or required, a new Default Format can be set. 

Customise the formatting of a Table (Table Size, Table Shape, Font Style/Size and Number of Covers), then right-click 

the Table and select “Make Default”. 

Alternatively, the Idealpos Default options can be restored by right-clicking on a Table and selecting “Reset Defaults”. 

Note that Reset Defaults does not alter the formatting of any existing tables. 

Reset Defaults will restore the default Idealpos formatting so that when any new tables are added, they will use the 

Idealpos Default Formatting. The Reset Defaults option will also restore the Idealpos Formatting that is saved against 

the “Set to Default” option. When the “Set to Default” option is pressed, the Idealpos Default formatting will be used 

instead of any options that were previously set as default. 
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Sales Categories 

IP-7737 – Sales Categories – Support for GL Code field 

This functionality adds support for a GL Code field in the Modify Sales Categories window. 

Each Sales Category can have its own GL Code (General Ledger Code) entered and used with Accounting Functions. 

This functionality was previously configured via the following User-Defined Option: 

SCxxxGLCODE = yyyy 

Where xxx was the Sales Category Number and yyyy was the GL Code. 

 

After upgrading to v9 Build 14, it is recommended that any GL Codes which were linked to a Sales Category via the 

above User-Defined Option GL Codes be updated via the Modify Sales Category window. 

 

User-Defined Options will appear in:  

Back Office > Setup > POS Terminals > Modify > POS Settings > User-Defined Options. 

 

Take note of any User-Defined Options that exist which link a GL Code to a Sales Category. 

Then go to: Back Office > File > Sales > Sales Categories > Select a Sales Category > Modify. 

Enter the GL Code into the GL Code Field, then press “Save” on the top-left corner. 

 

 
 

Repeat the above process for each Sales Category until the GL Codes for all required Sales Categories have been 

updated. 

After completing the above process, the SCxxxGLCODE=yyyy User-Defined Options can be removed. 
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Selling Price Calculator 

IP-7755 – Selling Price Calculator – Option to Round to Nearest 99c 

This functionality introduces a new Nearest 99c Rounding option to the Selling Price Calculator. 

The Nearest 99c option can be used to Round Up or Round Down and can be used together with the Dollar 

Adjustment, Percent Adjustment or Profit Margin options. 

Note that the Selling Price Calculator will affect Sell Prices and therefore, a backup is strongly recommended 

before using this functionality! 

To use this functionality, go to: Back Office > Utilities > Selling Price Calculator. 

 

Populate the Selection Range (Code/Description/Department/Supplier) to restrict the Selling Price Calculation changes 

to specific range. 

Leaving the Selection Range fields as blank will trigger the Selling Price Calculator to run on ALL Stock Items. 

 

• Modify Selling Price – Specify the Price Level to Modify. The Prices in the selected Price Level will be 

modified. 

• Base Calculation on – Specify the Price Level which will be used to base the calculation on. 

• Calculation Methods: 

• Dollar Adjustment – This will adjust the Sell Price by the dollar amount entered in the blank field. 

• Percent Adjustment – This will adjust the Sell Price by the Percentage value entered in the blank field. 

• Profit Margin – This will adjust the Sell Price by the Profit Margin percent entered in the blank field. 

• Rounding – Up/Down – Select up or down depending on the type of rounding required. Round up or down 

must be selected to utilise the Nearest 99c option. 

• Amount to round - Select Nearest 99c to round to the Nearest 99c. 
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Once the options have been set in the Selling Price Calculator, press the “Proceed” button on the top-left corner. 

As stated above, the Selling Price Calculator will affect Sell Prices, therefore, a backup is strongly recommended 

before using this functionality. Any incorrect selections/changes to Selling Prices cannot be undone! 

 

After the Selling Price Calculator finishes processing, the following prompt will appear. 

Press “OK”. 

 

 
 

The Sell Prices are updated as-per the options specified in the Selling Price Calculator. 

Go to: Back Office > File > Stock Control > Stock Items > Select a Stock Item that was within the Selection Range 

updated by the Selling Price Calculator > Modify. 

The Sell Price has been rounded up to 99c as per the options set in the Selling Price Calculator. 
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Stock Purchases 

IP-7753 – Stock Purchases – Item History View increased to 14 periods 

This functionality increases the number of periods to 14 in the Item History View of a Stock Purchase. 

Previously, a total of 12 periods were shown. 

 

To use this functionality, go to: Back Office > Transactions > Stock Control > Stock Purchases > Add/Modify. 

Select a Stock Item in the Purchase Order/Stock Receive. 

The bottom-left corner of the window will now display a total of 14 periods: 

 

 
 

The Transaction Type (Sales Quantity, Write-Offs, Transfers, Purchases, Returns, Variances) and History Type (Day, 

Week, Month) can be selected from the two dropdown boxes at the bottom to control which data is shown in these 14 

period fields: 
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Yes/No Options 

IP-7720 – Yes/No Option – Stock Transfers – Prompt to Email Report 

This functionality introduces the ability to enable a Prompt to Email a Stock Transfers Report after a Stock Transfer is 

processed.  

When processing a Stock Transfer from the Back Office, this option will prompt to Email the Stock Transfer Report. 

The prompt can be toggled on/off via a new Yes/No Option “Stock Transfers – Prompt to Email Report”. 

 

Prior to configuring this functionality, ensure that the Email settings are configured correctly in Idealpos. 

These can be configured by going to: Back Office > Setup > Global Options > Other Options > Email Settings. 

There are two options available: 

• Idealpos Email – This will utilise the Idealpos Email Service to send emails. 

• Custom – This will utilise your own Email Service. When using Custom, you will need to enter additional 

settings:  

o SMTP Outgoing Email Server 

o Sending Email Address 

o SMTP Username 

o SMTP Password 

o SMTP Port 

o Enable SSL/TLS Protocol 

 

The above details can be obtained from your Email Service provider. 

 

To enable this functionality, go to: Back Office > Setup > Yes/No Options > Search “Stock Transfer”. 

Enable the Yes/No Option “Stock Transfers – Prompt to Email Report”. 
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After the option has been enabled, go to: 

Back Office > Transactions > Stock Control > Stock Transfers.  

Select a Date and enter a Reference/Details for the Stock Transfer. 

Add Stock Items to the Stock Transfer via the Add button > Select a Stock Item, Source/Destination Location, Quantity. 

Press the “Process” button on the bottom-right corner. 

 

 
  

The “Would you like to Email this Stock Transfer?” prompt will be displayed. 

Press “Yes” to email the Stock Transfer. 
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The Stock Transfer Transactions Report will open. 

The Email window will appear on top of the Report, enabling the entry of the Email Addresses to send the Report to. 

Enter the required Email Addresses in the To/CC/BCC Fields, and if required, add/modify the details in the 

Subject/Message fields > Press “Send”. 

 

 
 

The Stock Transfers Report will be sent to the entered Email Addresses, with the report being attached as a PDF file. 

 

 


